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About This Guide

This guide describes how to use the Novell® NetWare® Server Consolidation Utility to copy data 
from one location to another location on your NetWare network. The guide is intended for network 
administrators and is divided into the following sections:

Chapter 1, “Overview,” on page 9 explains the capabilities of the Server Consolidation Utility.

Chapter 2, “Installing the Server Consolidation Utility,” on page 13 explains the prerequisites 
and instructions for installing the Server Consolidation Utility.

Chapter 3, “Running the Server Consolidation Utility,” on page 17 provides instructions for 
consolidating data and moving printers using the Server Consolidation Utility.

Chapter 4, “Consolidating Data from Windows NT,” on page 33 provides instructions for 
consolidating data from Windows* NT* to NetWare using the Server Consolidation Utility.

Chapter 5, “Server Consolidation Utility and Novell Nterprise Branch Office,” on page 43 
provides instructions for using the Server Consolidation Utility in conjunction with Novell 
NterpriseTM Branch OfficeTM appliances.

“Troubleshooting the Server Consolidation Utility” on page 49 provides solutions for 
resolving errors encountered during the consolidation process.

Appendix A, “Changing the Server’s Code Page,” on page 53 provides instructions for 
changing the code page on your source and destination servers, if necessary.

Additional Documentation

The entire Server Consolidation Utility documentation set is available online at the Server 
Consolidation Utility documentation Web site (http://www.novell.com/documentation/lg/
servercon20/index.html).

Novell Education offers a variety of courses that help you maximize your investment in NetWare. 
For course descriptions, details, and locations of training events, visit the Novell Education Web 
site (http://www.novell.com/education/netware6).

Documentation Updates

For the most recent version of the Novell NetWare Server Consolidation Utility Guide, see the 
Novell Product Documentation Web site (http://www.novell.com/documentation/lg/servercon20/
index.html)

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
in a cross-reference path.

Also, a trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-
party trademark.
About This Guide 7
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When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as UNIX*, should use forward slashes as required by your software.
8   Novell Server Consolidation Utility 2.5 Administration Guide
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1 Overview

Novell® NetWare® Server Consolidation Utility 2.5 helps you consolidate data and reorganize 
your network by moving data from any number of NetWare volumes (or directories within 
volumes) to another NetWare 5.1, 6.0, or 6.5 server; to a NetWare Cluster/SAN; or to multiple 
NetWare 6.0 or 6.5 servers. This means you have fewer servers to manage. 

This section describes what’s new in this release, what the Server Consolidation Utility is, how it 
works, and how you can use it to consolidate your data, cutting down on the number of servers you 
have to manage and simplifying administration of your network.

What’s New
With NetWare Server Consolidation Utility version 1.0, you could copy entire volumes and 
specific directories between NetWare 4, NetWare 5, and NetWare 6 servers in the same 
eDirectoryTM tree.  

With version 2.0, you could, for the first time, perform these same functions between different 
eDirectory trees, as well as consolidate to NetWare 6.5, the latest and most powerful version of 
NetWare. Version 2.0 also

Copies data from NT* 4.0 Domains to NetWare

Schedules projects and runs them completely unattended

Filters the files you want to copy based on date

Adds users to Directory Services on the destination Tree if they don’t already exist

Copies data to the Novell NterpriseTM Branch OfficeTM Appliance

With version 2.5, you can do all of that and more. New features in version 2.5 let you:

Exclude specific file types or filenames from the copy process

For example, copy all of the data from a volume except for any .mp3 files.

Automatically compare file information between the source and destination after the copy 
process completes

This includes the option of doing a detailed binary (byte-by-byte) comparison.

Check for sufficient disk space on the destination server before beginning the file copy

Disable login on the source server during the copy process

Specify a default server and home directory path for any new users you create on the 
destination server

Copy an expanded list of user attributes when creating users

In each case, the accompanying rights, trustees, ownership, and name space information are copied 
along with the files to the destination server. The utility also copies many user attributes from one 
tree to another.
Overview 9
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Benefits of Using the Server Consolidation Utility
The benefits the NetWare Server Consolidation Utility 2.5 provides can be better understood 
through the following two consolidation scenarios.

In the first scenario, suppose you have five existing NetWare 5 servers and you recently purchased 
two multiprocessor servers and the necessary hardware to create a two-node cluster complete with 
a Storage Area Network (SAN). You have decided to install NetWare 6.5 on the two-node cluster 
because NetWare 6.5 is fully multiprocessor enabled and comes with Novell Cluster ServicesTM 
software and a two-node cluster license. You want to migrate the data from each of the five servers 
to the SAN on the two-node cluster. Rather than manually moving all the data and Printer Agents 
or backing up the data and restoring it to the SAN, you can use the NetWare Server Consolidation 
Utility, which automates the data migration process.

The following figure shows how this consolidation scenario might look.

Figure 1 Cluster Server Consolidation

In the second scenario, suppose you have three existing NetWare 5 servers and you recently 
purchased a multiprocessor server that you want to make a NetWare 6.5 server. You want to 
migrate the data from each of the three servers to the single NetWare 6.5 server. Rather than 
manually moving all the data and Printer Agents or backing up the data on each of the three servers 
and then restoring it to the NetWare 6.5 server, you can use the NetWare Server Consolidation 
Utility to automate the data migration process.

The following figure shows how this consolidation scenario might look.

Server 1 Server 2 Server 3 Server 4 Server 5
Cluster
Server 1

Cluster
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Fiber 
Channel
Switch

Data Migration

Shared Disk
System

Data
Volumes
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eDirectory Tree
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Figure 2 Multiprocessor Server Consolidation

What’s Next
The Server Consolidation Utility has a helpful interface that guides you through each step of the 
consolidation process. See Chapter 2, “Installing the Server Consolidation Utility,” on page 13 and 
Chapter 3, “Running the Server Consolidation Utility,” on page 17 for instructions on how to 
install and use the NetWare Server Consolidation Utility.

Server 1 Server 2 Server 3

Data Migration

Data
Volumes

eDirectory Tree

MP Server
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2 Installing the Server Consolidation Utility 

The Novell® NetWare® Server Consolidation Utility helps you consolidate data from several 
servers onto fewer servers, so you have fewer servers to manage. 

To set up the utility, complete the tasks in the following sections:

“Meeting System and Software Requirements” on page 13

“Installing the Software” on page 15

Meeting System and Software Requirements
The Server Consolidation Utility runs on a Windows workstation and lets you copy files to 
different servers and reassign printer agents to different locations either in the same eDirectoryTM 
tree or between different eDirectory trees.  

Workstation Requirements
A Windows* NT (4.0 with Support Pack 6 or later), Windows 2000, or Windows XP 
Professional Edition workstation with 50 MB of available disk space.

If running on a Windows 2000 workstation, Service Pack 2 or later must be installed.

The Server Consolidation Utility does not work with Windows XP Home Edition or Windows 
95/98.

Novell ClientTM software installed and connected to the network.

Windows NT/2000/XP workstations must be running Novell Client for Windows NT/2000/
XP version 4.83 or later. 
IMPORTANT: If the destination server is running NetWare 6.5 and the Universal Password feature is 
enabled, you must run the Server Consolidation Utility on a workstation running the Novell Client for 
Windows NT/2000/XP version 4.9 or later. Universal Password is disabled by default on NetWare 6.5.

To check the Novell Client version, right-click the N icon on the workstation toolbar, then 
click Novell Client Properties > Client. To download the latest client, see the Novell Software 
Downloads site (http://download.novell.com).

(If copying data from NetWare 4) The IPXTM protocol running on the Novell Client 
workstation.

The source and destination server running on the same LAN segment for best performance.

Microsoft* Jet Database drivers installed if running on a Windows NT 4.0 workstation.

If Microsoft Jet Database drivers are not installed on your NT 4.0 workstation, they can be 
downloaded from www.microsoft.com/downloads by searching for the Jet 4.0 Service Pack 3 
Update.
Installing the Server Consolidation Utility 13

http://download.novell.com
http://download.novell.com


Novell Confidential 03installation.fm last saved  6/23/03 Manual Version: 3/17/03103
Microsoft Data Access Components (MDAC) 2.7 installed on the workstation. 

If MDAC 2.7 is not installed on your workstation, it can be downloaded from 
www.microsoft.com/downloads.

Server Requirements
Destination server running NetWare 5.1 or later.

Source server running NetWare 4.10 or later, or Windows NT 4.0 with Support Pack 6 or later.

To copy data from NetWare 3 servers, use the NetWare Migration Wizard, which is available 
for free at the Novell Software Downloads site (http://download.novell.com).

The Supervisor right to both the source server and the destination server.

Use ConsoleOne® to verify that you have the Supervisor right to both servers.

The latest NetWare Support Packs on both the source and destination servers.

Updates are available for specific NetWare versions at the Consolidated Support Pack home 
page (http://support.novell.com/tools/csp).

(If copying data from NetWare 4.10, 4.11 or 4.2) Each volume to be copied running long name 
space support. 

To add long name space support to a NetWare 4.10 volume, enter at the server console LOAD 
OS2.NAM and then ADD NAME SPACE OS2 volume_name Replace volume_name with 
the name of the NetWare 4.10 volume.

To add long name space support to a NetWare 4.11 or 4.2 volume, enter at the server console 
LOAD LONG.NAM and then ADD NAME SPACE LONG volume_name Replace 
volume_name with the name of the NetWare 4.11 or 4.2 volume.

A backup of eDirectory.

The same code page for both the source and destination servers.

If both servers don’t have the same code page, data will be lost during the consolidation. For 
instructions on changing your server’s codepage, see Appendix A, “Changing the Server’s 
Code Page,” on page 53.

On a NetWare 4 source server, the SET parameter Convert Compressed to Uncompressed 
Option=0.

Setting the option to 0 leaves compressed files compressed when they are accessed. This 
prevents compressed files from uncompressing and taking up all of your destination server’s 
disk space when they are accessed.  Setting the option to 1 changes compressed files to 
uncompressed on second access, and setting the option to 2 always changes compressed files 
to the uncompressed version.

To view your server’s current Convert Compressed to Uncompressed Option SET parameter, 
execute the SET command at the server console prompt, select the File System category, and 
page through the information until you see Convert Compressed to Uncompressed Option.

To change your server’s Convert Compressed to Uncompressed Option to 0, enter SET 
Convert Compressed to Uncompressed Option=0 at the server console prompt.

The latest smdr.nlm and tsa.nlm loaded.
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(If copying data from NetWare 4) The source and destination servers must see each other via 
IPX. For information on verifying IPX communication between servers, see the 
troubleshooting section’s “Errors When Connecting to a NetWare 4 Server” on page 51.

After meeting the system and software requirements, you can install the software and run the 
program.

Installing the Software
The NetWare Server Consolidation Utility is located on NetWare 6.5 CD 1 (Operating System) in 
the products\servcons directory.

Expand the utility and install it on a workstation by double-clicking the nwsc.exe file and 
following the on-screen installation instructions.
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3 Running the Server Consolidation Utility

The Server Consolidation Utility is a Windows program that is launched from the Start menu.

To launch the utility, click Start > Programs > Novell Server Consolidation Utility > Novell Server 
Consolidation Utility. Then complete the following tasks:

1. Create a Project File (page 18).

2. Select a Source and Destination Tree (page 19).

3. Select Volumes, Directories, and Printer Agents (page 19).

4. Perform Pre-Copy Verifications (page 21).

5. Resolve Errors (page 25).

6. Start the Consolidation (page 29).

7. Schedule a Consolidation Project (page 29).

8. Consolidate to or from a NetWare 5.1 Cluster (page 30).

The Server Consolidation Utility has a helpful interface that guides you through each step of the 
process.

Consolidation Issues

There are certain rules that you should be aware of when copying files or moving Printer Agents.

Open files cannot be copied.

There is one exception to this rule. NSS has a feature called File Copy on Write. This permits 
a file that is being changed to be accessed in the same state as it was in when it was last closed 
by all processes. 

This feature is enabled on an NSS volume either by using ConsoleOne® or entering

nss /filecopyonwrite=volname

at the server console to change the volume attributes. For example, nss /
filecopyonwrite=vol1 would enable File Copy on Write for the vol1: volume. The 
effect is immediate, but it affects only files that are currently closed and then opened later.

If you run a Server Consolidation Utility project involving a NetWare® cluster and the cluster 
fails over during the consolidation, the file copy will stop. The Server Consolidation Utility 
project must be run again.

Printer Agents can be moved, print queues cannot.

Printer Agents that are moved still use the same Print Broker.

You can move Printer Agents back after initially moving them.

Printer Agents can be consolidated only within the same tree.  They cannot be moved between 
different trees.
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Print Services Managers must be operational.

After moving Printer Agents from the source to the destination server, unload the source Print 
Services Manager so the migrated Printer Agents can establish a connection to the destination 
Print Services Manager.
HINT: After unloading the source Print Services Manager, send a test print job to the printer that was 
moved. This ensures that communication with the destination Print Services Manager is established. 
After that communication has been established, the source Print Services Manager can be brought back 
up.

You might need to manually load or reload the appropriate tsa.nlm or smdr.nlm.

Create a Project File
The Server Consolidation Utility uses a project (.mdb) file to record your intended actions. The 
actions are recorded so you can execute them now or save the project file and execute the actions 
later.

The filename can be up to 64 characters long and can include any character except \ * ? < > | " /.

You can create a new project, open an existing project, or open the last project you worked on.

1 In the Startup dialog box, click the radio button next to the selection you want.

2 Click OK.

3 (Conditional) If you choose to create a new project, you are prompted to select the source type.  
The choices are:

NetWare NDS/eDir Tree

Microsoft* Windows Domain

3a In the Project Type dialog box, click the radio button next to the selection you want.

3b Click OK.

If you choose to create a new project, you are prompted to view the setup tasks for the utility 
and to verify that you have met the requirements before continuing. 

4 (Optional) To view the utility’s documentation, click View On-line Documentation.

5 Click Next.

After performing the setup tasks for the utility, you must name the project and specify the 
location on the workstation where the project file is to be stored.

6 Type a project filename in the field provided.

7 (Conditional) If you want to store the project file in a location other than the default location 
provided, click Browse.

8 Click Next.
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Select a Source and Destination Tree
After you create a project file, the Startup dialog box is displayed. The Server Consolidation Utility 
allows you to move volumes, directories, and printer objects between servers in either the same 
tree or between different trees. However, in order to do this, you must be logged in to the trees that 
you will be working in.

1 Select the source and destination eDirectoryTM (NDS®) tree from the drop-down list provided 
or click Login to browse to a tree that is not in the drop-down list.

Only trees that you are currently logged in to are available on the drop-down list.

1a (Conditional) In the Novell Login dialog box, click Trees.

1b Browse to each desired tree and log in with the correct username and password.

If you do not know the tree name, in the Server field of the Login dialog box, type the IP 
address or DNS name of the server that you will be consolidating to or from.

1c Click OK.

2 Click Next.

3 In the Startup dialog box, click Create to finish creating the project file.

Select Volumes, Directories, and Printer Agents
The Project Window (see Figure 3 on page 20) is where you select which volumes and directories 
to copy and which Printer objects to move. The Project Window is divided into two panes that each 
show the trees that you are working in.

You drag objects from the left pane and drop them into the right pane. You select volumes and 
directories to copy to different servers, and Printer Agents to move to different Print Managers. 
NOTE: The Server Consolidation Utility does not move Print Brokers or Print Managers. If you want to move 
a Print Broker, you must first create a new one on the target server, copy the contents to the new server, and 
then delete the old one.  The Server Consolidation Utility only moves Printer Agents, and only within the same 
tree.
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Figure 3 Project Window Post-Copy View

When you drag-and-drop volumes into the right pane of the Project Window, a Volume Drop 
Options dialog box displays. You must choose to either migrate the volume contents into the 
directory or volume that you selected or create a new directory with the name of the volume that 
is being moved.

1 Click the radio button next to the option you want. 

2 Click OK.

In addition to dragging-and-dropping objects, you can perform several other tasks from the Project 
Window menu:

Save project settings: Click File > Save As.

Move created and dropped objects around by dragging them to the desired location.

Create a new container or folder: Select the parent container or existing folder in the right 
pane, then click Edit > New Folder.

Cancel a "dropped" action: Select the volume or directory in the right pane, then click Edit > 
Back Out.

Rename a newly created container or folder: Select the parent container or existing folder in 
the right pane, then click Edit > Rename.

Show where a folder or object went: Select the object in the left pane, then click Edit > Where 
Did It Go. The directory or volume that was moved is highlighted in its new location in the 
right pane.

Show where a folder or object came from: Select the object in the right pane, then click Edit 
> Where Did It Come From. The directory or volume that it came from is highlighted in the 
left pane.

Show all folders or objects selected for copying: Select a container in the left pane, then click 
Edit > Show Dropped Folders [or Show Dropped Printers].
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HINT: The previous six tasks can also be performed by right-clicking the object to see the same menu 
option.

Verify the available disk space prior to performing the verification by right-clicking the 
destination volume in the right pane of the Project Window and then selecting Properties. 
Right-clicking the source folder or volume in the left pane of the Project Window and then 
selecting Properties displays the size of the source object.

Creating containers and dragging-and-dropping objects in the Project Window does not 
immediately perform the action. It only creates a preview of where the files and objects will reside. 
The actions are completed only after the verification process is complete and the copy process 
begins.

Perform Pre-Copy Verifications
After you have dragged-and-dropped the selected directories or volumes and have performed any 
other setup tasks, proceed by clicking Project > Verify and Copy Data or by clicking Do the 
Consolidation on the button bar. The Verification Wizard displays.

Begin the Verification

1 Click Next to begin the verification process.

The Dropped Folders dialog box displays, showing the source path and destination path for 
the dropped folders. 

2 Do one of the following:

If the source and destination paths are correct, click Next.

If the source or destination path is incorrect, click Cancel and make the appropriate 
changes in the Project window.

If you created new folders in the right pane of the Project window as part of your consolidation 
project, the Created Folders dialog box now displays.  

3 (Conditional) If prompted with the Create Folders dialog box, do one of the following:

If the destination path of the created folders is correct, click Next.

If the destination path is incorrect, click Cancel and make the appropriate changes in the 
Project window.

The Duplicate File Resolution dialog box displays.  

Resolve File Conflicts

If a file is found on the destination volume or directory that has the same name as a file being 
copied from the source, you must decide what to do. You have three options to choose from on the 
Duplicate File Resolution dialog box: 

Don’t copy over existing files 

The file on the source server is not copied and the file on the destination server is not replaced.

Copy the source file if it is newer (Default)

If the file on the source server is newer than the one on the destination server, the file on the 
destination server is replaced.
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Always copy the source file

The file on the source server always replaces the file with the same name on the destination 
server.

1 Click the radio button next to the option you want.

2 Click Next.

The Synchronize Files and Folders dialog box now displays. 

Synchronize Files and Folders

In the Synchronize Files and Folders dialog box, you have the option to delete files and folders on 
the destination server that do not exist on the source server. Selecting Yes deletes all files and 
folders on the destination server that are not on the source server. No is the default selection. 

1 Click the radio button next to the option you want.

2 Click Next.

The Compare Files and Folders dialog box now displays. 

Compare Files and Folders

In the Compare Files and Folders dialog box, you have the option to compare files and folders 
between the source and destination servers after the copy process completes. Selecting Yes 
compares the following information between the source and destination files and folders:

Names

Dates

Sizes

Attributes

Trustees

Owners

If you select Yes, you are given the option of doing a binary comparison of the files after the copy 
process completes. A binary (byte-by-byte) comparison gives the greatest assurance that two files 
are identical, but it takes longer to complete.

1 (Conditional) If you do not want to compare source and destination files after the copy 
process, click the No radio button.

2 (Conditional) If you want to compare source and destination files after the copy process, click 
the Yes radio button.

3 If you selected Yes in the previous step and if you want to perform a binary comparison of the 
files that were copied, check the Binary Comparison check box.

4 Click Next.

The File Date Filters dialog box now displays.
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Copy Files Based on Dates

In the File Date Filters dialog box, you have the option to copy files based on dates and three 
separate attributes: 

Accessed

Modified

Created

If No is selected in this dialog box, all files are copied. If Yes is selected, date ranges can be entered 
for the file copy. You can select as many criteria as you would like, and only those files that meet 
all of the selected criteria are copied. 

Two dates can be set for each attribute. The first date is an On or After date and the second is an 
On or Before date. For example, if you only check the On or Before check box and set the date for 
November 10, 2000, for the Accessed attribute, only those files accessed on or before November 
10, 2000, are copied. In the same example, if you also check the On or After check box and set the 
date to October 1, 2000, only those files accessed on or after October 1, 2000, and on or before 
November 10, 2000, are copied. 

1 (Conditional) If you do not want to filter files based on dates, click the No radio button.

2 (Conditional) If you want to filter based on dates, do the following:

2a Click the Yes radio button.

2b Check any of the available check boxes for the desired combination of file types and 
dates.

To change the date from the default provided, check the box next to the desired date. Next, 
highlight with your mouse the portion of the date you want to change. Either type a new value 
using the keyboard number pad, or use the mouse to click the Up-and Down-arrows provided 
to the immediate right of the date field.

3 Click Next.

The Wildcard Selection dialog box now displays.

Wildcard Selection

In the Wildcard Selection dialog box, you have the option to exclude specific file types or file 
names from the copy process.

A wildcard is a character that can be used to represent one or more characters in a search. The two 
most commonly used wildcards are

The question mark (?)

Used to represent a single alphanumeric character in a search expression.

For example, excluding the file te?t.txt would exclude tent.txt, test.txt, and text.txt from the 
copy process.

The asterisk (*)

Used to specify zero or more alphanumeric characters in a search expression. For example, 
excluding the file h*s.txt would exclude house.txt, his.txt, horses.txt, and happiness.txt from 
the copy process.
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1 Type the file extension types or filenames in the field provided. For multiple filenames or 
types, press Enter between each entry. Wildcards (* ?) are permitted.

For example, if you want to exclude a specific file named test.txt from being copied, type 
test.txt in the field provided. If you want to exclude all .mp3 files from being copied, type 
*.mp3 in the field provided.

Type as many filenames or file extension types as you want. Separate the filenames or file 
extensions by pressing Enter between each entry. Do not use spaces or commas to separate 
the entries. See the following examples:

Correct:

*.mp3
test.txt
*.wav

Incorrect:

*.mp3 test.txt *.wav

or

*.mp3, test.txt, *.wav

2 Click Next.

If you are performing a consolidation between servers in different trees, the Check for Trustees 
and Ownerships dialog box now displays. If you are performing a consolidation between servers 
in a single tree, proceed to "Verify Password" on page 23.

Check for Trustees and Ownership

When you copy data from one tree to another, the Server Consolidation Utility searches the 
destination tree for trustees that match the source tree trustees of the copied data. Trustees that are 
potential matches are displayed and can be matched up during “Match Up Tree Objects” on page 
26.

This check for trustees and ownerships must be performed the first time a consolidation is run. If 
a consolidation is run a second time, this search does not need to be repeated, as long as trustees 
have not been added to the source server and new directories or folders have not been dropped onto 
the destination server. If either has happened, another search is necessary. This trustee and 
ownership check slows down the verification process.
NOTE: If a file has already been copied to the destination server or tree, that file’s trustees are not updated 
during the consolidation unless the source file’s date is more recent than the date on the destination file. The 
Server Consolidation Utility reads the file date to determine what to copy, and adding trustees to a file does 
not update the file date.

1 Click Browse to select the destination container you want to search.

2 Check the Search All Subordinate Containers check box to search all containers in the 
destination tree below, and including, the one you selected.

Leaving the box unchecked searches only the selected destination container. For better 
performance, limit the search to the container that you believe the object resides in. Searching 
from Root takes significantly longer depending on the size of the destination tree.

3 Click Next.

If consolidating data to an Nterprise Branch Office appliance, there is not an option to specify the 
container you want to search. Click the Yes or No radio button, then click Next.
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The Password Verification dialog box now displays.

Verify Password

1 In the Password Verification dialog box, enter the passwords for the source and destination 
trees in the fields provided.
NOTE: SMS is the back up and copy engine used by the Server Consolidation Utility.  You enter your 
password here because SMS requires that the servers involved in the consolidation are authenticated to 
each other.

2 Click Next. 

The Novell Server Consolidation Verification dialog box now displays.

Check for Sufficient Disk Space and Disable Login

Before beginning to consolidate your data, you can verify that your destination volumes have 
enough space to accommodate the data that will be moved. Verifying disk space can be a long 
process if you have many files to copy.

You can also disable login on the source server before copying file data. Users already logged in 
to the source server are not logged out, but no new logins are allowed until the consolidation 
completes. If you disable login and the workstation running the consolidation project crashes for 
any reason during the consolidation, you might have to manually re-enable login on the source 
server console.

1 To verify the available space on the destination volumes, check the Check for Sufficient Disk 
Space check box 

2 To have the utility disable login on the source server prior to copying data, check the Disable 
Login check box 

3 To begin the verification prior to copying the files and moving the printers, click Next 

During the verification process, you might see a message informing you that an updated tsa.nlm 
or smdr.nlm must be copied for the consolidation to work. Click Yes to continue the project 
verification. Clicking No stops the consolidation.

Resolve Errors
If there were errors discovered in the verification attempt, they will be shown in the Error 
Resolution dialog box. Errors could include name conflicts, insufficient rights, required name 
spaces not loaded, and insufficient disk space.

Errors found during the verification process are classified as follows:

 Errors must be resolved before files can be copied. 

 Errors should be resolved but might not affect the copy process. 

In addition, the Error Resolution dialog box might display informational text classified as follows:

 Information about the decisions you made in the Project Window. 

A description of the error and a possible resolution appears in the Information text box. If no 
resolution is provided, you can find more information in the Novell Error Codes Help system. 
(Search the system by error code number.)
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After resolving any errors that exist, click Next. If there were no errors, warnings, or informational 
text to display, and if you are moving objects from one tree to another, the Tree-to-Tree Object 
Match Up dialog box now displays. If you are not moving objects between trees, proceed to “Start 
the Consolidation” on page 29.

Match Up Tree Objects
All trustees of copied data that appear in both the source and destination trees are displayed in the 
Tree-to-Tree Object Match Up dialog box based on their category. These trustees are discovered 
during the Check for Trustees and Ownership step on page 23.

This screen allows you to match the trustees found in the destination server with trustees from the 
source server. If an appropriate match does not exist, you can create a user on the destination server 
that matches the trustee on the source server. You can also browse to an existing user in the 
destination tree and match it up with the source server trustee.
IMPORTANT: If you are consolidating to an NterpriseTM Branch OfficeTM Appliance, see Chapter 5, “Server 
Consolidation Utility and Novell Nterprise Branch Office,” on page 43 now.

1 Select the type of objects to display from the drop-down list provided in the Tree-to-Tree 
Object Match Up dialog box.

2 Check the check box to the left of the object you want to match up.

To select more than one object, press and hold the Ctrl key while checking the check box to 
the left of the objects that you want to select. You can also check the check box to the left of 
one object, press and hold the Shift key, then check the check box to the left of a second object 
to select those two objects and all other objects located between them in the list.

The following attributes are copied for each selected user:

Common Name

Description

E-mail Address

Fax Number

Full Name

Generational Qualifier

Given Name

Initials

Internet E-mail Address

Language

Locality Name

Lockout After Detection

Login Allowed Time

Login Disabled

Login Expiration Time

Login Grace Limit

Login Grace Remaining
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Login Intruder Limit

Login Maximum Simultaneous

Login Script

Mailbox Location

Network Address Restriction

Organizational Name

Organizational Unit Name

Password Allow Change

Password Expiration Interval

Password Expiration Time

Password Minimum Length

Password Required

Password Unique Required

Physical Delivery Office name

Post Office Box

Postal Address

Postal Code

State or Province Name

Street Address

Surname

Telephone Number

Title

2a (Conditional) If you selected more than one object, right-click on the selected objects and 
then click Create All Selected Objects.

2b (Optional) If you want to create objects for all of the selected objects, click the Yes radio 
button.

2c To select the container that the objects will be created in, click Browse.

2d Click OK.

2e To unmatch more than one object, select the desired objects, right-click the objects, and 
then click Unmatch All Selected Objects.

3  From the drop-down menu under the Destination Object heading, select the option you want:

The object in the destination tree that has the same name as the object in the source tree

Don’t match (object doesn’t exist in the destination tree)

Browse

Create

4 (Conditional) If you selected Browse in Step 3, do the following in the Context Browser 
dialog box:
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4a Select a matching object.

4b Click OK.

5 (Conditional) If you selected Create in Step 3, do the following in the Object Creation dialog 
box:

5a To browse to the container that the new object will be created in, click Browse.

5b Select the container.

5c Click OK.

5d Type the new object’s name in the field provided, then click OK.

5e Repeat Step 5d for each object you want to create.
NOTE: When the Server Consolidation Utility creates a new user, it assigns a random password to that 
user. The username and the randomly assigned password are written to the success log. This log file can 
be viewed after the consolidation completes.

The Server Consolidation Utility allows the user to create groups if they don't already exist in the 
destination tree and it adds the users that are members of the source group to the new destination group. 
However, it does not modify an existing group. If you use the utility to create a group in the destination 
tree and then add additional members to the source tree’s group, those added members are not added 
to the destination group. Also, if you choose to create the groups manually (on the destination) rather than 
using the Server Consolidation Utility, and then you attempt to match up the groups during the 
consolidation, the group members are not transferred.

6 When you have finished matching all the objects, click Next.

7 (Conditional) If you have unmatched objects, do one of the following in the Unmatched 
Objects dialog box that displays:

To proceed without matching the objects, click Yes.

To go back and match up the objects before continuing, click No.

The Default Server and Home Directory for Created Users dialog box now displays.

Default Server and Home Directory for Created Users
In the Default Server and Home Directory for Created Users dialog box, you have the option to 
assign a default server for all created users. The default server is the server the user gets a 
connection to during login if the user doesn't request a connection to a specific server. It’s also the 
server used if the user makes a network request without naming the server, and it’s the server the 
user still has an attachment to after logging out.

You can also assign a parent directory for any created user’s home directory. A home directory is 
an optional, single-valued property that specifies the location (volume and path) and name for the 
user’s working area on the server.

1 (Conditional) If you want to assign a default server for all created users, click the first Browse 
button.

2 Select a server from the tree.

3 Click OK.

4 (Conditional) If you want to assign a parent directory for any created user’s home directory, 
click the second Browse button.

5 Select a directory from the tree.
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6 Click OK > Next.

The Start Novell Server Consolidation Utility dialog box now displays.

Start the Consolidation
After selecting the objects to copy and resolving critical errors, you can now copy your files by 
clicking Proceed in the Start Novell Server Consolidation Utility dialog box.

During the copy process, new folders and objects are created, files are copied, and Printer Agents 
are moved to their destination (as specified in the right pane of the Project Window).

When the copy process is complete, a Process Finished screen displays that lets you

View the error log.

View the success log.

Close the Process Finished screen.
HINT: You can also view the error and success logs of any completed project from the Project Window by 
opening the project file and clicking View > Error Log or View > Success Log, or by clicking the corresponding 
button on the button bar.

If you interrupt the copy process before it completes, all objects, directories, and files already 
copied to the destination server will remain there unless you manually delete them.

Schedule a Consolidation Project
The Server Consolidation Utility lets users schedule projects to run when it is most convenient. 
This means that you can create a consolidation project during the day and schedule it to run during 
the night when there is a smaller chance that files that are to be moved will be open and being 
worked on. 

The Server Consolidation Utility uses the Scheduled Tasks capability built into Windows to 
schedule a consolidation project to run at a time that is most convenient to you. 
HINT: Before scheduling a consolidation project it is recommended that you complete the verification process 
and resolve all errors.  When you have verified the project, resolved any errors, and reached the Start Novell 
Server Consolidation Utility dialog box described in “Start the Consolidation” on page 29, then the project can 
be scheduled.

To schedule a project to run at a later time:

1 Ensure that a Server Consolidation Project has been created. 

Write down the project name and path of its location for later reference.

2 Click Start > Settings > Control Panel. 

3 Double-click the Scheduled Tasks icon.

4 Double-click the Add Scheduled Task icon.

5 When the Scheduled Task Wizard launches, click Next. 

6 Select the Novell NetWare Server Consolidation Utility from the list of programs provided, 
then click Next.

7 Assign the scheduled task a name, select its frequency (in most cases, the preferred choice will 
be One Time Only), then click Next.
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8 Select the start time and date for the project to run, then click Next.

9 Enter the Windows username and password of the admin user that will perform the task, then 
click Next.

10 Verify that the time displayed for running the project is correct. If it is, check the Open 
Advanced Properties for This Task When I Click Finish check box, then click Finish.

11 After the Advanced Properties dialog box opens, click Task.

12 In the dialog box that opens, complete the Run: field.

The dialog box is populated with a pathname that ends in \fc.exe. The following four 
parameters, separated by a single space, must be added to this pathname for the scheduled 
consolidation project to run:

The pathname, in quotation marks, to the consolidation project that you are scheduling to 
run. For example:  

"c:\my projects\sc1.mdb" (where sc1.mdb is the saved project)

The letter Y, to automatically run the selected Server Consolidation project.

The password for the admin on the source server.

The password for the admin on the destination server.

When completed, the Run: field of the Advanced Properties dialog box should look similar to 
this:

c:\program files\novell\netware server consolidation utility\fc.exe "c:\my projects\sc1.mdb" y 
test1 test2

In the previous example, c:\program files\novell\netware server consolidation utility\fc.exe is 
the pathname that was already in the Run: field of the dialog box, "c:\my projects\sc1.mdb" is 
the saved project that is scheduled to run, y is the Yes parameter to automatically run the 
project, test1 is the admin password on the source server, and test 2 is the admin password on 
the destination server.

13 After entering the four parameters, click OK.

14 In the dialog box that appears, enter the Windows username and password of the admin 
running the project, then click OK.

The Server Consolidation project will run at the scheduled time.

Consolidate to or from a NetWare 5.1 Cluster
When a volume is cluster enabled, an object is created in eDirectory with the name of the cluster 
followed by an underscore followed by the volume name. For example, cluster1_vol1. For the 
Server Consolidation Utility to function properly with a NetWare 5.1 cluster-enabled volume, the 
server name followed by an underscore followed by the Volume Name object must be used in the 
Project Window instead. For example, server1_vol1.

This substitution can be accomplished by completing the following steps:

1 Start ConsoleOne, and browse to the context where the NCPTM Server object resides.

2 Right-click the right pane, select NEW/Volume, then type the name of the new object in the 
first field.

This should be the server name followed by an underscore followed by the volume name.
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3 In the second field, browse and select the appropriate server. 

4 In the third field, select the volume from the drop-down menu, then click OK.

5 In the Server Consolidation Utility Project Window, refresh the container where the Volume 
object is located to make the new object appear.

6 When dragging-and-dropping in the project window, use the newly created Volume object. 

If you use the clustername_volumename object instead of creating and using the new Volume 
object, a critical SMDR error will occur and you won’t be able to complete the consolidation 
process.

7 After the consolidation is complete, you can delete the newly created Volume object.
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4 Consolidating Data from Windows NT 

The Novell® Server Consolidation Utility automates key tasks, such as migrating users and their 
file permissions, assigning passwords, and migrating the NT* file system to a designated 
eDirectoryTM tree. This automation eliminates the need to choose from various utilities that would 
help you perform these tasks individually.

Although many tasks are automated in the Server Consolidation Utility, you should consider the 
following issues before you get started.

First, you should plan your consolidation by answering the following questions:

Which NT users are accessing which NT files and directories, and where are those files and 
directories located?

This information will help you decide which NT servers to migrate first and how many servers 
you will need to migrate at one time. When you migrate your users and groups, you will want 
to migrate all files and directories that they have access to at the same time that you migrate 
their User objects.

Which NetWare® servers and volumes am I going to migrate my NT folders to? 

You should plan which servers and volumes in your destination eDirectory tree will receive 
each of your NT folders. You can select a separate location for each NT folder, if desired. In 
order to plan effectively, you will need to become familiar with the file structure on the 
NetWare servers in your destination eDirectory tree.

Which NT users and groups am I going to migrate? Which eDirectory containers on the 
destination eDirectory tree am I going to migrate them into?

Decide which NT user and groups you are going to migrate, then determine whether you will 
need to create separate containers for your NT users and groups in the destination eDirectory 
tree. When you model your migration in the Project Window, you can create any additional 
eDirectory containers you might need by right-clicking an eDirectory Organizational Unit.

Do any existing eDirectory User objects represent the same person in my NT domain?

Determine whether any of your NT users already have an eDirectory account. During the 
migration you will be asked if you want to search the eDirectory tree for duplicate usernames. 
When the Server Consolidation Utility finds identical usernames, it will display these in a 
table where you can choose to merge the listed NT user with an eDirectory User object. 

What will I do with any applications that do not run on NetWare?

The Server Consolidation Utility does not migrate applications. After the migration, you will 
have to reinstall your applications. If you have some applications that do not run on NetWare, 
you can keep an NT server intact and use it as an application server. 

How do I want to migrate information about my users and groups? Do I want to use a 
Template object? 

For information, see “Create a Template Object” on page 35.
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Do I have any trusted domains?

If so, you must reassign any trusted domain permissions to the appropriate NT user and groups 
after the migration is complete. Use ConsoleOne® to reassign all lost trusted domain 
permissions.

When you have planned your migration, you’re ready to begin your NT migration. Complete the 
following tasks in the order they are listed.

1. Meet System and Software Requirements (page 34).

2. Perform Prerequisite Tasks (page 35).

3. Run Server Consolidation (page 36).

4. Model Your Consolidation Project (page 37).

5. Verify Your Consolidation Project (page 38).

6. Migrate Users and Data to the Destination eDirectory Tree (page 39).

7. Perform Post-Consolidation Tasks (page 41).

Meet System and Software Requirements
You can run the Novell Server Consolidation Utility from a Windows NT 4 server or a Windows 
NT 4, Windows 2000, or Windows XP Professional Edition workstation.  

Make sure you have the following NT permissions:

Write/Modify permission to the NT Domain and the Registry of the PDC

Read permission to all folders and files you are migrating

Log in to the NT domain with a user that has administrative rights to the Domain.

The following table lists the hardware and software requirements for the workstation that you are 
using to run Server Consolidation.

To check your current Novell Client version, right-click the N icon on your workstation and then 
click Novell Client Properties > Client. To download the Novell Client, see the Novell Download 
Web site (http://www.novell.com/download).

Continue with the next section, "Perform Prerequisite Tasks."

Platform Hardware Software

Windows NT/2000/XP 
workstations

Minimum hardware 
requirements of 
Windows NT/2000/XP 
workstations

Novell ClientTM for 
Windows NT/2000/XP 
version 4.83 or later
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Perform Prerequisite Tasks

Create a Template Object
The first prerequisite task is to determine whether you want to use a Template object to migrate 
your NT users to the destination eDirectory tree.

A Template object is used to define additional eDirectory User attributes for NT users during the 
migration. Template objects are especially useful for defining additional attributes that are not 
found in the Windows NT domains. We recommend that you use a Template object because it is 
an organized way to migrate your NT users to the eDirectory tree and manage them after they are 
there.
IMPORTANT: In order to migrate home directories, you must use a Template object.

If there is a conflict between the properties of a Template object and an NT policy, the properties 
of the Template object will, in most cases, take priority. For example, if a minimum password 
length of seven characters is specified for user Jeff in an NT policy and a minimum password 
length of nine characters is specified in the Template object, then when Jeff’s object is migrated, 
the object will be created in eDirectory with a password length of nine characters. 

If you want to know what additional eDirectory attributes can be defined in a Template object, run 
ConsoleOne and double-click a Template object to view all of the existing properties.

The last name, full name, and description of every NT object is always migrated and these 
corresponding properties from the Template object are overwritten. 

If you decide to use a Template object, you can create one in ConsoleOne by clicking File > New 
> Object > Template.

Register the Workstation
If you are not running the Server Consolidation Utility from the NT server, make sure that the 
workstation running the Server Consolidation Utility is registered within the domain that you want 
to migrate. If it is registered properly, continue with “Run Server Consolidation” on page 36. 

If you want to change the domain that your workstation is registered in, complete the following 
instructions for Windows NT or Windows 2000.

Windows NT Workstations

1 At the workstation, right-click Network Neighborhood and then click Properties.

2 Click the Identification tab, then click Change > Domain. 

3 Specify the appropriate domain, type your Administrator name and password, then click OK.

4 Reboot the workstation and launch the Server Consolidation Utility again; then continue with 
the next section, "Run Server Consolidation."

Windows 2000 Workstations

1 At the workstation, right-click My Network Places and then click Properties.

2 Click the Network Identification link.

3 Click Properties, specify the computer name and appropriate domain, then click OK.

4 Reboot the workstation and launch the Server Consolidation Utility again; then continue with 
the next section, "Run Server Consolidation."
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Run Server Consolidation
1 Launch the Server Consolidation Utility by clicking Start > Programs > Novell Server 

Consolidation Utility > Novell Server Consolidation Utility.

2 Click Create a New Project > OK. 

3 Click Microsoft Windows Domain > OK.

4 Click the View Online Documentation button. 

This launches your default Web browser and takes you to the NetWare Server Consolidation 
Utility online documentation.

5 Make sure you have completed the system and software requirements in “Meet System and 
Software Requirements” on page 34 of the online documentation. Then close your browser.

6 Click Next.

7 Name your consolidation project, select a place to save it, then click Next.

By default, the Server Consolidation Utility saves your project in c:\Program 
Files\Novell\NetWare Server Consolidation Utility.

8 Verify that the NT domain that appears in the grayed-out text field is the domain that you want 
to migrate.

The Server Consolidation Utility automatically displays the NT domain that your workstation 
or server is a member of. 

You can change the domain that the workstation running the utility is registered in. To do this, 
exit the utility and follow the instructions in “Register the Workstation” on page 35.

9 Select your destination eDirectory tree from the drop-down list, then click Next. 

The destination eDirectory tree is the eDirectory tree that you want to migrate your NT data to.

If you are not logged in to your eDirectory tree, the eDirectory tree name will not appear in 
the drop-down list. If this is the case, click the Browse button to log in to your eDirectory tree. 
After you are logged in, the eDirectory tree name automatically appears in the drop-down list.

10 Decide whether you want Server Consolidation to find any User objects in your NT domain 
and in the destination eDirectory tree that have the same name, click Yes or No, then click 
Next.

11 To create and save your consolidation project, click Create.

When a project is created and saved, the Server Consolidation Utility creates a file that 
contains the success and error logs of your project; these logs contain the details of what took 
place during the consolidation.

12 (Conditional) If you clicked Yes in Step 10, continue with Step 12a. If you clicked No, skip 
the rest of the steps in this procedure and go to “Model Your Consolidation Project” on page 
37.

12a To select an eDirectory container on the destination eDirectory tree, click the Browse 
button.

12b Browse the tree and select an eDirectory container, then click OK.

12c To begin searching for duplicate usernames, click Next.
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12d Decide what you want to do with NT users that have the same name as eDirectory users.

You have the following options for each listed NT user:

Merge the NT user with the displayed eDirectory user. Simply leave that user as it is 
displayed in the table and continue with the next listed NT user.

Merge an NT user with a different eDirectory user. Click the arrow by the eDirectory 
username to view a drop-down list containing all the eDirectory users that have the 
same username (including contexts) as this NT user. Select one of the eDirectory 
names and continue with the next listed NT user.

Do not merge the NT user with any of the matching eDirectory users. Click the arrow 
by the eDirectory username to view a drop-down list, then select Don’t Merge. Select 
this option only if you know that none of the listed eDirectory users represents the 
same person as the adjacent NT user.

12e After you have made a decision for each listed NT user, click Finish.

The Project Window will now appear and the NT users that you chose to merge with 
eDirectory User objects appear automatically as dropped objects in the destination 
eDirectory tree. 

Continue with the next section, "Model Your Consolidation Project."

Model Your Consolidation Project
Most of your work will be done in the Project Window, where you can drag-and-drop NT User and 
Group objects into eDirectory containers, and NT folders into any volume or folder in the 
destination eDirectory tree.

The Project Window is a place to model different migration scenarios before you begin the actual 
migration without affecting your NT domain or your destination eDirectory tree. All of the 
planning in the Project Window is done offline, meaning that items moved and created in the 
Project Window are not actually moved or created until you begin the migration. 
HINT: For information on shared NT folders that end with a dollar sign ($), click anywhere on your Windows 
desktop, press F1, click the Index tab, then type $shares in the keyword text field. 

The Project Window and the Using the Project Window dialog box appear after you have created 
the consolidation project.

The three basic steps outlined in this dialog box should be performed for each consolidation 
project. When you are familiar with the tasks that you will be performing, click Close to access the 
Project Window and begin modeling your migration project.

Using the Project Window

Review the following tips to help you organize your migration project and use the Project Window 
more effectively.

Dragging-and-Dropping the NT Domain Info object—To perform a consolidation from an 
NT domain, you must drag-and-drop the NT Domain Info object from the left pane of the 
Project Window to an eDirectory container in the right pane of the Project Window.

Creating a New eDirectory Organizational Unit or Folder—To create a new eDirectory 
Organizational Unit (OU), right-click the parent eDirectory Organizational Unit or folder and 
then click New Organizational Unit or New Folder. 
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You can create new eDirectory OUs in the eDirectory tree and then migrate your NT 
information to those OUs. This keeps the NT information organized and in one place in the 
eDirectory tree. You can also choose to migrate the NT data to existing OUs; just remember 
that you can always create a new OU in the eDirectory tree if you need to.

If you add new containers or names to the destination tree, the names you choose must adhere 
to the following eDirectory naming conventions:

Names must be unique. For example, Debra Jones and Daniel Jones cannot both be 
named DJONES if they are in the same container.

The following special characters are allowed only if they are preceded by a backslash (\): 
plus sign (+), equal sign (=), and period (.).

Uppercase and lowercase letters, underscores (_), and spaces are not acknowledged by 
eDirectory. For example, Manager_Profile and MANAGER PROFILE are considered 
identical names in eDirectory.

Setting the Context—To set the context, right-click an eDirectory Organizational Unit and 
then click Set Context.

When you set the context, you can designate what part of the eDirectory tree will appear in 
the right side of the Project Window. This is useful if you have a large eDirectory tree with 
many objects.

Setting the context at a specific container will eliminate the need to scroll down or collapse 
objects in your eDirectory tree. Once the context is set, this container will appear as the top 
object in the right side of the Project Window.

Viewing a Description of the Objects in the Project Window—To see a short description 
of what an icon represents in the Project Window, right-click an eDirectory object and then 
click What’s This?

Backing Out a Dropped Object—To return a dropped object to its original position, right-
click a dropped NT object in the NT domain or the destination eDirectory tree and then click 
Back Out Dropped Object.

Finding Out Where a Dropped NT Object Came From—To find out where a dropped 
object was located in the NT domain, right-click an NT object and then click Where Did It 
Come From? When dragging-and-dropping objects, this will help you remember where a 
dropped object was previously located in the NT domain.

When you are satisfied with where you have dropped your NT folders, users, and groups in the 
eDirectory tree, verify your consolidation project to resolve any potential problems before 
migrating your NT data.

Continue with the next section, "Verify Your Consolidation Project."

Verify Your Consolidation Project
After you have modeled your consolidation in the Project Window, you should verify that the 
proposed locations for these new objects do not conflict with existing names, rights, name spaces, 
etc., in the eDirectory tree. 

Remember, dragged-and-dropped items appearing in the eDirectory tree are merely assigned to be 
copied to that area in the eDirectory tree. Objects will not actually be copied until you begin the 
consolidation process.
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Because a similar verification process is run when you begin the actual NT migration, running the 
standalone verification process prior to migration is not mandatory; however, catching any critical 
errors or warnings now will speed up the verification process during the migration. 

You must resolve all critical errors before you begin to actually migrate your migration project. 
Warnings can be resolved after the migration.

Migrate Users and Data to the Destination eDirectory Tree
Although you have selected the volumes and containers where the NT data will be copied, no data 
has yet been migrated. When migrated, NT User objects are converted to eDirectory objects and 
placed in the destination eDirectory tree.

1 From the Server Consolidation Utility toolbar, click Project > Verify and Copy Data or click 
the Do the Consolidation button on the toolbar, and then click Next.

2 Read the Welcome screen, then click Next.

3  If you want to apply a Template object to newly created eDirectory users, browse the tree, 
select the Template object from the tree view, and then click Next. 

If you do not want to use a Template object, uncheck the check box and  click Next.

To migrate home directories, you must use a Template object when migrating your NT users 
to the destination eDirectory tree. Make sure a Home Directory property is defined for the 
Template object you are using.
HINT: If you have not created a Template object but you want to use one now, save the project, go to 
ConsoleOne®, and create the Template object. Next, run the Server Consolidation Utility again and click 
Open Last Project. Then restart this migration procedure again starting with Step 1.

4 Decide how you want to handle any duplicate filenames between the Windows NT domain 
and the destination eDirectory tree, select one of the following, then click Next:

Don’t Copy Over Existing Files—The file on the source server is not copied and the file 
on the destination server is not replaced. 

Copy the Source File If It Is Newer—If the file on the source server is newer than the 
one on the destination server, the file on the destination server is replaced.

Always Copy the Source File—The file on the source server always replaces the file 
with the same name on the destination server.

5 Decide how you want to handle passwords for your NT users, select one of the following, then 
click Next:

Assign the Same Password to All Users—The utility will assign the same password to 
all migrated users.

Assign a Randomly Generated Password to All Users—The utility will randomly 
generate passwords, assign them, and then store the passwords it assigns in a file that it 
creates, named project_name_out.txt. This file is saved in the same directory where your 
consolidation project is located.

Read Passwords from a File—The utility will migrate the current NT passwords to the 
destination eDirectory tree by reading them from a text file. You must create the text file 
containing the NT passwords before you begin the migration.

For more information on how to create this file, click the Help button.
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6 Set NT migration options by checking or unchecking the check boxes next to the following 
options and then click Next:

Copy File Permissions—Normally, the utility migrates file and directory permissions. 
If, for some reason, you want to reassign file and directory permissions, you can choose 
to not copy the file and directory permissions here and then assign them later with 
ConsoleOne.

Copy Everyone Permissions—The eDirectory container that you drop the NT Domain 
Info object into will be assigned the permissions that were associated with group 
Everyone. If you are migrating the Everyone permissions, be sure to drop the NT Domain 
Info object high enough in the eDirectory tree so that all NT users will inherit those 
permissions.
HINT: Every new folder that is created in the NT domain automatically receives the Everyone 
permissions by default.

Restart Option—Normally, this information is not erased; however, if you have 
previously run a consolidation program and deleted the eDirectory objects from the 
destination tree, and you are planning to start over and migrate the same domain again, 
check this check box.

When you migrate users and groups from NT, the Server Consolidation Utility stores a 
table of NT names and associated eDirectory usernames in the registry of the Primary 
Domain Controller (PDC). The utility then uses this information when migrating the file 
system so that it can remember where each user and group has been migrated to in the 
destination eDirectory tree. By storing this information, the utility can assign the correct 
file permissions to the appropriate users. 

7 To begin the verification, click Next in the Verify NT to NetWare Project window. 

8 (Conditional) If prompted, resolve any naming conflicts between different-type objects, then 
click Next.

You can choose to merge different-type objects or to keep them as they are.

9 (Conditional) If prompted, resolve any naming conflicts between same-type objects, then 
click Next.

You can choose to merge same-type objects or to keep them as they are.

10 (Conditional) If prompted, verify that you do not want to migrate the listed NT users and 
groups, then click Next. 

If you migrated all of your users and groups, you will not see this dialog box.

Otherwise, this step must be done three times—once each for your NT local groups, NT global 
groups, and NT users that were not dragged and dropped into the destination eDirectory tree. 

If you have made a mistake, click Cancel to return to the Project Window. Then drag-and-drop 
the objects, go to the toolbar, click Project > Verify and Copy Data, then restart this procedure 
with Step 1 on page 39.

11 Resolve any critical errors. 

Warnings or noncritical errors can be resolved after the consolidation. To resolve a critical 
error or warning, read the description in the text field located beneath it. This description 
should give you a good idea of what could be the possible cause and a suggestion for fixing it. 
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12 Do one of the following:

To start the actual consolidation, click Proceed.

If you are only running the verification process at this point and want to do the 
consolidation later, click Cancel > Yes to save the changes you have made to the project 
file. 

When you are ready to proceed with the consolidation project, restart the Server 
Consolidation Utility, select Open an Existing Project, and click OK. Then select the 
project file you want to open, click Open, and then follow the instructions found in 
“Migrate Users and Data to the Destination eDirectory Tree” on page 39, starting with 
Step 1.

13 (Consolidation only) View the Error and Success Logs.

Continue with the next section, "Perform Post-Consolidation Tasks."

Perform Post-Consolidation Tasks
After you’ve migrated your NT data to the destination eDirectory tree, complete the following 
tasks:

Use ConsoleOne or Novell iManager to make sure that your NT users and groups have been 
migrated to the correct place in the destination eDirectory tree and have the correct file and 
shared permissions. 
HINT: If you end up with more or fewer permissions than you planned for, enter CACLS/? at the DOS 
prompt and follow the on-screen instructions. Permissions are sometimes hidden in Microsoft* utilities; 
therefore, running this command at the DOS prompt lets you see all of the permissions associated with 
your NT objects, even the hidden ones.

At the destination NetWare server, use ConsoleOne or iManager to view the volume that you 
migrated your data to and verify that it was done correctly.

Set up your printer mappings in NDPS®. For instructions, go to the online documentation 
(http://www.novell.com/documentation) for the destination server’s operating system and 
click Print Services > Novell Distributed Print Services. 

Check the migrated users’ home directories to make sure that they were migrated the way you 
expected them to be.

Distribute the new eDirectory passwords to all of your users. The passwords are located in a 
password file that the Server Consolidation Utility created for you named 
project_name_out.txt. This file is located in the same directory where you saved your 
consolidation project.
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5 Server Consolidation Utility and Novell 
Nterprise Branch Office

Novell® NterpriseTM Branch OfficeTM is a business office management solution that reduces the 
costs and challenges of managing and using offices in remote locations. Novell Nterprise Branch 
Office is appliance software that you can deploy on hardware at remote offices and still have the 
flexibility to manage from one central location at your corporate offices. Administrators and users 
access the features they need through the Internet from a Web browser.

Moving directories, volumes, or users and their associated trustees and rights to a new Novell 
Nterprise Branch Office appliance is a daunting task made easier by the Server Consolidation 
Utility. Moving information with the Server Consolidation Utility is faster and easier than 
manually entering individual users, copying files, and manually assigning their rights and trustees 
on a new Nterprise Branch Office appliance.

The Server Consolidation Utility works with Novell Nterprise Branch Office appliances in much 
the same way it works with Novell NetWare servers. However, there are a few differences in the 
way the Server Consolidation Utility runs in relation to Nterprise Branch Office. This chapter will 
describe the following:

Unlocking the Nterprise Branch Office Appliance (page 43)

Binding IPX When Consolidating from NetWare 4 (page 44)

Modifying the Hosts File (page 45)

Performing a Server Consolidation to a Novell Nterprise Branch Office Appliance (page 46)

Unlocking the Nterprise Branch Office Appliance
In order to perform a consolidation to an Nterprise Branch Office appliance, you must be logged 
in as Admin with supervisor rights to the appliance. The Branch Office appliance does not allow 
supervisor rights for Admin unless the server is unlocked. When the server is unlocked, Admin is 
granted supervisor rights and the consolidation can be run.

1 At the server console, log in by entering the Admin username and password.

2 Enter unlock.

3 When prompted, enter y for Yes.

4 To relock the server, at the server console enter lock.
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Binding IPX When Consolidating from NetWare 4
Before running a consolidation project from a NetWare 4 server to an Nterprise Branch Office 
appliance, you must first bind IPXTM on the Nterprise Branch Office appliance and on the 
workstation running the Server Consolidation Utility. Otherwise the consolidation will fail.

1 At the Nterprise Branch Office appliance server console, enter inetcfg.

2 Select Boards, then press Enter.

3 Press Insert.

4 Select the appropriate network interface, then press Enter.

5 Specify a board name and slot number, then press Esc.

6 Select Yes to save changes, then press Enter.

7 To return to the main Internetworking Configuration screen, press Esc.

8 Select Protocols, then press Enter.

9 Select IPX, then press Enter.

10 Enable and configure IPX, then exit the INETCFG utility.
HINT: If you prefer, IPX can also be enabled on the server by adding the appropriate Load and Bind 
commands to the server’s autoexec.ncf file.

Verifying IPX is Bound On the Client
1 Right-click on the red N in the system tray on your workstation.

2 Select Novell Client Properties.

3 Select the Protocol Preferences tab.

If the Protocol window displays both IP and IPX, the client has IPX bound.

If the Protocol window displays only IP, then IPX needs to be bound on the workstation.

Binding IPX on the Client
1 Insert the Novell Clients Software CD (March 2003). 

2 Select the client version you want, then click Next.

3 Select the appropriate language, then click Next.

4 Select Custom, then click Next.

5 Click the radio button next to IP and IPX.

6 Click Next > Next > Finish.
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Modifying the Hosts File
The Server Consolidation Utility connects the servers involved in a consolidation using one of two 
methods, SLP or the sys:\etc\hosts file. Nterprise Branch Office does not configure SLP, so 
consolidations to Nterprise Branch Office appliances must use information in the hosts file.  

In order to successfully complete a consolidation, the sys:\etc\hosts file on the Nterprise Branch 
Office appliance must contain the IP address and server name of the source servers involved in the 
consolidation. This information must be manually input into the file before running the Server 
Consolidation project.
IMPORTANT: The Nterprise Branch Office appliance reconfigures itself each time it is restarted. This causes 
the sys:\etc\hosts file on the appliance to be rewritten each time it is restarted. If only one consolidation is being 
run with an Nterprise Branch Office appliance, the hosts file needs to be modified only once to include the 
source server’s IP address and server name. However, if more than one consolidation is going to be run on 
an Nterprise Branch Office appliance, and the appliance has been restarted since the last consolidation, the 
hosts file must be modified each time the appliance is restarted.

On the Nterprise Branch Office Appliance

1 At the Nterprise Branch Office appliance’s server console, enter edit.

2 Press Insert.

3 Select sys:, then press Enter.

4 Select etc, then press Enter.

5 Select hosts, then press Enter > Enter.

6 Add to the file the IP address and server name of every source server involved in the 
consolidation project.

Type the IP addresses and server names as xxx.xxx.xxx.xxx Server_Name.

7 Save the file.

8 Run the consolidation project.

On the Client Workstation

1 Launch Windows Explorer.

2 Browse to the Nterprise Branch Office server.

3 Double-click the server name.

4 Double-click the sys: volume.

5 Double-click the etc directory.

6 Open the Hosts file with a text editor.

7 Add to the file the IP address and server name of every source server involved in the 
consolidation project.

Type the IP addresses and server names as xxx.xxx.xxx.xxx Server_Name.

8 Save the file.

9 Run the consolidation project.
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Performing a Server Consolidation to a Novell Nterprise Branch 
Office Appliance

When performing a consolidation to the Nterprise Branch Office appliance using the Server 
Consolidation Utility, you will see several screens that are different from the ones displayed during 
a consolidation on a regular NetWare server. The different screens that require navigation are 
described below.

Log In to a Tree

When the Startup dialog box is displayed as described in “Select a Source and Destination Tree” 
on page 19, you must log in to the trees that are involved in the consolidation.  

With the Nterprise Branch Office appliance, the Admin user’s context is always appusers.

Match Up Tree Objects

The Tree-to-Tree Object Match Up screen displays. Any objects that appear in both the source and 
destination trees are displayed based on their class. To match up objects in a consolidation 
involving an Nterprise Branch Office appliance, replace all the steps in "Match up Tree Objects" 
on page 25 with the following:

1 Select the type of objects to display from the drop-down list provided.

2 Check the check box to the left of the object you want to match up.

To select more than one object, press and hold the Ctrl key while checking the check box to 
the left of the objects that you want to select. You can also check the check box to the left of 
one object, press and hold the Shift key, then check the check box to the left of a second object 
to select those two objects and all other objects located between them in the list.

The following attributes are copied for each selected user:

Department

Description

E-mail Address

Fax Number

Full Name

Given Name

Internet E-mail Address

Location

Postal Address

Surname

Telephone Number

Title

Unique IDs

2a (Conditional) If you selected more than one object, right-click the objects and then click 
Create All Selected Objects.

2b (Optional) If you want to create users for all of the selected users, click the Yes radio 
button.
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2c From the drop-down list, select whether these will be Local Users or Remote Users.

2d Click OK.

3  From the drop-down menu under the Destination Object heading, select the option you want:

The object in the destination tree that has the same name as the object in the source tree

Don’t match (object doesn’t exist in the destination tree)

Browse

Create (if you are matching users)

4 (Conditional) If you selected Browse in Step 3, do the following in the Context Browser 
dialog box:

4a Select a matching object.

4b Click OK.

5 (Conditional) If you selected Create in Step 3, do the following in the Object Creation dialog 
box:

5a From the drop-down list, select whether you want to create a Local User or Remote User.

5b Type the new user’s name in the field provided, then click OK

5c Repeat Step 5a for each user you want to create.

6 When you have finished matching all the objects, click Next.

7 (Conditional) If you have unmatched objects, do one of the following in the Unmatched 
Objects dialog box that displays: 

To proceed without matching the objects, click Yes.

To go back and match up the objects before continuing, click No.

Return to "Start the Consolidation" on page 25 to complete the consolidation.
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Troubleshooting the Server Consolidation Utility

Refer to the appropriate section if you are having trouble with any of the following:

“SMDR Not Communicating” on page 49

“NDPS Printer Agents Don’t Migrate” on page 49

“NUWAGENT Won’t Load (NetWare 4.2 Only)” on page 49

“Server Consolidation Performance Problems” on page 50

“Volume Contents Do Not Display” on page 50

“Copies Incomplete Data Files” on page 50

“Errors When Connecting to a NetWare 4 Server” on page 51

In general, when troubleshooting errors in the Server Consolidation Utility, first ensure that the 
latest smdr.nlm and tsa.nlm are loaded on the source and destination servers.

SMDR Not Communicating
Possible Cause: Smdr.nlm is not loaded on either the source or the destination server, or SLP is not properly 

configured.

Action: Enter display slp services smdr.novell//(svcname-
ws==source_server_name)(replace source_server_name with the name of your source 
server) at the destination server console.

If smdr.nlm is not loaded on the source or destination server, manually load it. 

If it appears there is a problem with SLP, go to Novell’s support site (http://support.novell.com/
search/kb_index.jsp) and search for SLP-related configuration information.

NDPS Printer Agents Don’t Migrate
Possible Cause: If after a migration, it appears NDPS® Printer Agents have not migrated, it is possible that NDS® 

has not had time to properly synchronize.

Action: Wait for a few minutes, then check again to see if NDS has been updated to reflect the Printer 
Agent migration.

Action: If the Printer Agents have still not migrated after allowing NDS to synchronize, ensure the Novell® 
Distributed Print ServicesTM Manager (ndpsm.nlm) is loaded on either the source or destination 
server.

NUWAGENT Won’t Load (NetWare 4.2 Only)
Possible Cause: Clibaux.nlm is not loaded.

Action: Go to the server specified in the error message and at the server console, enter load 
clibaux.nlm.
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Server Consolidation Performance Problems
Explanation: The performance of a project can be determined by looking at the success log after a project 

completes. The success log gives the amount of time the project took to complete and the amount 
of data copied.

There are several factors that determine the performance of the file copy. It is also important that 
each server is updated to the latest Support Pack to ensure you have the latest performance 
enhancements for SMSTM.

Possible Cause: Heavy traffic on the network.

Action: Speeds can be increased by connecting servers and the workstation to a dedicated switch.

Possible Cause: A mismatch in duplexing among servers, switches, and the workstation.

Action: Make sure all hardware is set to either full duplex or half duplex. Setting all hardware to half 
duplex might result in greater performance than full duplexing.

Possible Cause: Virus scan software running on the source or destination servers.

Action: Turn off any virus scanning software on the source or destination servers to increase the speed of 
the consolidation. Turn the virus scanning software back on after the consolidation completes.

Possible Cause: An incorrect version of smdr.nlm is loaded on a NetWare® 5 server.

Action: At the NetWare 5 server, unload smdr.nlm, then load the smdr.nlm file that comes with the Server 
Consolidation Utility.

Possible Cause: Small file sizes.

In general, the larger the file sizes, the better the performance. Copying a single 500 MB file will 
be significantly faster than copying five thousand 100 KB files.

Possible Cause: Hardware configuration.

The performance of the Server Consolidation Utility varies according to the environment. Using 
a 100 MB LAN, tests have measured speeds ranging from 3 to 15 GB per hour, with the most 
common speed being between 5 and 8 GB per hour. You should check the performance of your 
LAN before copying very large amounts of data. 

The Server Consolidation Utility will copy data at a faster rate than a Windows* file copy.

Volume Contents Do Not Display
Problem: No data appears in the Volume object after dropping a container into a volume that has not been 

opened.

Action: Map a drive to the volume from a workstation.

Copies Incomplete Data Files
Problem: Files copied to the destination server have any of the following characteristics:

Destination is a 0-byte file.

Creation time and date are incorrect when compared to the source server.

Modification time and date are incorrect when compared to the source server.

File was not completely copied. (This would be indicated by the destination file being smaller 
in size than the source file.)
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Action: Use the latest TSA500 and SMDR on the source server if it is a NetWare 5 server.

Use the latest TSA600 and SMDR on the source server if it is a NetWare 6 server.

For more information, see TID #10076801 in the Knowledgebase at Novell’s Support Web site 
(http://support.novell.com).

Errors When Connecting to a NetWare 4 Server
Problem: When attempting to connect to a NetWare 4 server, any of the following types of errors are 

returned:

An error occurred opening the file. filename was invalid.

Error opening connection to SMDR.

The name spaces couldn’t be checked.

8998 error. NWGetVolumeNumber.

Action: There are several actions to take if errors are returned when trying to connect to a NetWare 4 
server, including the following:

If your source server is NetWare 4, make sure that you have IPXTM on your client. For 
information on verifying IPX on your client, see “Verifying IPX is Bound On the Client” on 
page 44.

Add a mapped drive to the source server.

Ensure that SLP is configured properly on the servers involved in the consolidation project.

Problem: NetWare 6.5 won’t communicate with NetWare 4 during a consolidation. IPX was not installed 
during the NetWare 6.5 installation.

Action: Add IPX to the NetWare 6.5 server after the NetWare 6.5 installation is complete.

1 Enter edit at the NetWare 6.5 server console.

2 Press the Insert key.

3 Select sys: and press Enter.

4 Select System and press Enter.

5 Select autoexec.ncf and press Enter > Enter.

6 Add the server ID of the source server and save the autoexec.ncf file.

Problem: IPX connection is not communicating.

Action: Ensure that there is an IPX connection to the server.

To verify that the source and destination servers can see each other via IPX:

1 On the server console of the destination server, enter serverid xxxxx, where xxxxx is the 
unique server ID number for the server.

2 Enter load ipxping.

3 Enter the internal IPX number of the source server.

4 Repeat this process on the source server, replacing the internal IPX number of the source 
server with the destination server’s internal IPX number in Step 3.

Action: Bind IPX on the destination server.

1 At the destination server console, enter inetcfg.

2 Select Boards and press Enter.
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3 Press the Insert key.

4 Select the appropriate network interface and press Enter.

5 Enter a board name and slot number, then press the Esc key.

6 Select Yes to save changes and press Enter.

7 Press the Esc key to return to the main Internetworking Configuration screen.

8 Select Protocols and press Enter.

9 Select IPX and press Enter.

10 Enable and configure IPX and exit the inetcfg utility.
HINT: If you prefer, IPX can also be enabled on the server by adding the appropriate Load and Bind 
commands to the server’s autoexec.ncf file.

Action: Verify that IPX is bound on the client running the Server Consolidation Utility:

1 Right-click on the red N in the system tray on your workstation.

2 Select Novell Client Properties.

3 Select the Protocol Preferences tab.

If the Protocol window displays both IP and IPX, the client has IPX bound.

If the Protocol window displays only IP, then IPX needs to be bound on the workstation.

Action: Bind IPX on the client running the Server Consolidation Utility:

1 Insert the Novell Clients Software CD (March 2003). 

2 Select the client version you want and click Next.

3 Select the appropriate language and click Next.

4 Select Custom and click Next.

5 Click the radio button next to one of the following two choices:

IP and IPX

IP with IPX compatibility
HINT: You can select this choice if you are running in an scmd environment.

6 Click Next > Next > Finish.

Action: Ensure that the correct smdr.nlm and tsa.nlm are loaded on the server.

1 On the server console, enter unload smdr.

2 Enter smdr new.

3 Enter Y when asked if you want to disable NDS.

4 Enter N when asked if you want to disable SLP.

5 Enter N when asked if you want to disable SAP.

6 Enter N when asked if you want to disable name resolution through sys:\etc\hosts file.

7 Enter load smdr on the server console.

8 Enter load tsa600 on the server console.
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A Changing the Server’s Code Page

When using the Server Consolidation Utility, the source and destination servers must have the 
same code page set, or data will be lost during the consolidation.
WARNING: We do not recommend converting a foreign-language code page server back to English, nor 
converting a foreign-language code page server to another foreign-language code page. If either is done, it is 
possible that documents and folders named with or containing foreign characters might become irreversibly 
corrupted.

There are two recommended ways to create a NetWare® server with foreign-code page support:

Install the server with the regional support you want

Convert an English server to a foreign-language code page

Install a NetWare Server with Regional Support
To install an English server with code page support for a foreign language, you must have an 
English NetWare® installation CD or access to English NetWare install files.

1 Begin the NetWare installation.

For information on installing your specific version of NetWare, see the NetWare on-line 
documentation (http://www.novell.com/documentation).

During the installation, a Regional Settings screen will display. You will see three options:

Country: 001 (USA)

Code page: 437 (United States English)

Keyboard: United States

2 Change the first option, Country:, to the country you want the server to support.

For example, if you want to install your English server with Japanese double-byte support, 
change the Country: option to 081 (Japan).

When you change the Country: option, the Code page: and Keyboard: options change 
automatically to the appropriate code page and keyboard.

3 If you intend to type foreign characters using the keyboard on the server console, accept the 
automatic setting displayed for the Keyboard: option. 

If you do not intend to type any foreign characters on the server console, manually change the 
Keyboard: option to US International (the last keyboard option displayed in the list). 

4 Complete the server installation.

When the server reboots after the installation is complete, you will have an English server 
with a foreign code page.
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Convert an Existing NetWare Server to a Foreign Code Page
To convert an existing English server to a foreign code page, you must have an English NetWare 
installation CD or access to English NetWare install files.

1 Bring the server down.

2 At the DOS prompt, go to c:\nwserver.

3 Rename lconfig.sys to lconfig.437.

The lconfig.sys file determines what code page NetWare will run. The purpose of renaming 
the existing file is to allow for rolling back to the original configuration if necessary.

4 Browse to the \install\lconfig directory on the NetWare installation CD or at the location of 
your NetWare installation files. 

This directory contains the lconfig.sys files for all languages. The naming convention is 
lc_country_codepage.country_telephone_code. Therefore, the Japanese lconfig.sys file is 
named lc_932.081, for example.

The following is a partial list of lconfig.sys files with their associated language names:

Chinese-S LC_936.086

Chinese-T LC_950.088

French LC_850.033

German LC_850.049

Italian LC_850.039

Japanese LC_932.081

Korean LC_949.082

Portuguese LC_860.351

Russian LC_855.007 or LC_866.007

Spanish (Argentina) LC_850.054

US English LC_437.001

5 Select the language code page file you want to implement and copy it to the c:\nwserver 
directory.

6 Rename the lc_xxx.xxx file you just copied to lconfig.sys.

If you are converting an English server to a single-byte language like German or Russian, then 
you are finished. When you start the server, you will have foreign-language code page support 
for the country you selected.

If you have selected a double-byte code page like Japanese or Chinese, continue with Step 7.

7 (Conditional) If installing a double-byte codepage, copy the necessary server font files.  

7a Go to :\startup on your NetWare installation CD and select the font files appropriate for 
your language:

Japan = jpn*.fnt

Korea = kor*.fnt

Chinese T = bg5*.fnt
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Chinese S = gb*.fnt

7b Add Load vgadisp.nlm to c:\nwserver\startup.ncf.

Vgadisp.nlm allows for double-byte characters such as Japanese or Chinese to be viewed 
in the C-worthy portion of the system console. It is cosmetic and does not affect the 
functionality of the server.

8 Restart the server.

You will now have foreign-language code page support for the country you selected.

Verifying the Current Code Page on a NetWare Server
To verify the code page currently installed on your NetWare server, do the following:

1 Enter debug mode on the server console. Press Shift+Shift+Alt+Esc.

2 Enter u OSGetCodePage.

3 Find the line of output that ends similar to ...DOSCodePage]=01B5.

4 Enter zd xxxx (Where xxxx are the last four characters of output from the previous step--In 
this case, 01B5.) in the debugger.

This will return "Evaluates to: 437 dec". The code page is 437, which is the English code page.

The following is a partial list of common codepages:

Chinese-S 936

Chinese-T 950

French 850

German 850

Italian 850

Japanese 932

Korean 949

Portuguese 860

Russian 855 or 866

Spanish 850

US English 437
Changing the Server’s Code Page 55



Novell Confidential Appendix A.fm last saved  6/23/03 Manual Version: 3/17/03103
56   Novell Server Consolidation Utility 2.5 Administration Guide


	About This Guide
	1 Overview
	What’s New
	Benefits of Using the Server Consolidation Utility
	What’s Next

	2 Installing the Server Consolidation Utility
	Meeting System and Software Requirements
	Workstation Requirements
	Server Requirements

	Installing the Software

	3 Running the Server Consolidation Utility
	Create a Project File
	Select a Source and Destination Tree
	Select Volumes, Directories, and Printer Agents
	Perform Pre-Copy Verifications
	Resolve Errors
	Match Up Tree Objects
	Default Server and Home Directory for Created Users

	Start the Consolidation
	Schedule a Consolidation Project
	Consolidate to or from a NetWare 5.1 Cluster

	4 Consolidating Data from Windows NT
	Meet System and Software Requirements
	Perform Prerequisite Tasks
	Create a Template Object
	Register the Workstation

	Run Server Consolidation
	Model Your Consolidation Project
	Verify Your Consolidation Project
	Migrate Users and Data to the Destination eDirectory Tree
	Perform Post-Consolidation Tasks

	5 Server Consolidation Utility and Novell Nterprise Branch Office
	Unlocking the Nterprise Branch Office Appliance
	Binding IPX When Consolidating from NetWare 4
	Verifying IPX is Bound On the Client
	Binding IPX on the Client

	Modifying the Hosts File
	Performing a Server Consolidation to a Novell Nterprise Branch Office Appliance

	Troubleshooting the Server Consolidation Utility
	A Changing the Server’s Code Page
	Install a NetWare Server with Regional Support
	Convert an Existing NetWare Server to a Foreign Code Page
	Verifying the Current Code Page on a NetWare Server


