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About this Guide

This guide is a tutorial, designed to walk you through the details of the common tasks you would 
perform with Novell® ZENworks® for Desktops 3.2 in a software testing lab before you install it 
in a production environment.

The guide is a work in progress: As units of the guide are written, they are previewed on the 
ZENworks Cool Solutions Web site  ((http://www.novell.com/coolsolutions/zenworks/features/
a_labguide_zw.html))  When each of the units is finalized, it is moved to the Novell 
Documentation Web site to become part of the ZENworks documentation set (http://
www.novell.com/documentation/lg/zdfs/index.html). The finalized units currently include:

“Setting Up a ZfD 3.2 Lab Environment” on page 11

“Managing the Complete Workstation Life Cycle” on page 63

Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
About this Guide 9
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I Setting Up a ZfD 3.2 Lab Environment

This unit of the ZENworks® for Desktops (ZfD) 3.2 Lab Guide focuses on installing and setting 
up the product on a server and workstation so that you can competently test it in a lab environment. 
Included in this unit are the following sections:

Chapter 1, “Windows 2000 Server Setup,” on page 13

Chapter 2, “Installing ZENworks for Desktops 3.2,” on page 49

Chapter 3, “Setting Up a Windows 2000 Professional Workstation for Desktop Management,” 
on page 57
Setting Up a ZfD 3.2 Lab Environment 11
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1 Windows 2000 Server Setup

This section of the ZENworks® for Desktops (ZfD) 3.2 Lab Guide contains the following sections:

“Introduction” on page 13

“Installing and Configuring Windows 2000 Server” on page 14

“Setting Up Active Directory” on page 16

“Installing and Configuring DHCP” on page 19

“Installing Novell eDirectory 8.61” on page 25

“Installing Novell Account Management” on page 36

“Configuring Novell Account Management” on page 43

“Testing the Novell Account Management Configuration” on page 47

Introduction
ZfD 3.2 requires either a NetWare® or Windows* server. The section details how to install 
Windows 2000 Server; configure DHCP, DNS, and Active Directory*; install Novell® 
eDirectoryTM; and synchronize Active Directory with eDirectory using Novell Account 
Management.

ZfD 3.2 does not require Active Directory. The configuration detailed here provides one way to 
create transparent access between eDirectory and Windows 2000 resources without redundantly 
managing multiple user accounts.

Because the objective of this Lab Guide is to create a working server as a basis for examining ZfD 
3.2, this section does not explore all features of Novell eDirectory and Novell Account 
Management. Before you work through the steps of this section, you may be concerned with other 
considerations, including:

“Permanence of This Setup” on page 13

“Dependencies” on page 14

“Requirements” on page 14

Permanence of This Setup
This lab requires you to build and configure a Windows 2000 Server for use with ZfD 3.2. When 
you complete this lab, we recommend that you use some form of imaging software to create a 
restorable image of this server. This will facilitate a review of the ZfD-specific portions of the lab 
without the need to reconfigure the server completely.
Windows 2000 Server Setup 13
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Dependencies
This lab requires working knowledge of basic Windows 2000 Server tasks, including installation 
and setup, disk partitioning, user administration, and Windows networking fundamentals. It also 
assumes some basic knowledge of Novell eDirectory. Object naming conventions used for 
eDirectory and Active Directory objects are all in x.500 format, which reads backwards compared 
to the standard file system object naming.

Requirements
Hardware Requirements: The following minimum hardware configuration is required.

Pentium* 500 processor

256 MB RAM

10 GB disk space

Network interface card

Subsequent labs will require one or more Windows workstations.

Software Requirements: The following minimum software configuration is required. 

Windows 2000 Server installation media

An Internet connection for downloading Microsoft* and Novell service packs and other 
resources

Novell eDirectory 8.51 installation media and NICI license

Novell Account Management installation media

Installing and Configuring Windows 2000 Server
Install Windows 2000 Server to your selected server hardware, using the following specifications 
for the first boot:

Use the following specifications for the second boot:

Specification Setting

Primary partition size 1992 MB

Primary partition format FAT (for easier Windows 2000 repairs)

Specification Setting

Regional Settings Standard

Name Whatever you choose

Organization Digital Airlines

Product Key According to your CD

License Mode Per seat
14   ZENworks for Desktops 3.2 Lab Guide
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Use the following steps to complete the server configuration:

1 Reboot the server and log in as Administrator.

2 Create a large extended partition and logical drive, formatted as NTFS > assign the drive letter 
D:.

3 Open Internet Explorer > configure it to use your Internet connection.

4 In Internet Explorer, click Tools  > Windows Update.

On the Microsoft Windows Update home page, click the link for Product Updates and allow 
your system to detect which updates are needed. Apply as many updates as possible.

Computer Name DA-02

Administrator Password novell

Components Default components; remove IIS (Internet INformation Services)

NOTE: Future updates of the Lab Guide may require a Web server. 
In that event instructions for the installation of the Apache Web Server 
or IIS will be explained as needed.

Network Settings Custom. Change your TCP/IP settings as follows:

IP address = 10.0.0.202

Subnet mask = 255.255.255.0

Default gateway = 10.0.0.11

Preferred DNS server = 10.0.0.202

Alternate DNS server = 137.65.1.1

Domain No

Workgroup Workgroup

Specification Setting
Windows 2000 Server Setup 15
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Repeat the Windows Update process through the multiple updates and reboots until your 
server has at least Windows 2000 Service Pack 2 and all the critical updates applied. You 
might also consider updating to the latest version of Internet Explorer.

5 Download the following support files from the Novell Support Connection® Web site (http://
support.novell.com).

W2KINST1.EXE from TID 10064212 (http://support.novell.com/cgi-bin/search/
searchtid.cgi?/10064212.htm)

AMW2KP2.EXE from TID 2959979 (http://support.novell.com/cgi-bin/search/
searchtid.cgi?/2959979.htm)

Setting Up Active Directory
Use the following steps to set up Active Directory on your Windows 2000 Server:

1 From the Windows Control Panel, click Administrative Tools > Configure Your Server. This 
tool may already be open.

2 In the left menu, click Active Directory.

3 In the right pane, scroll to the bottom > click Start the Active Directory Wizard.

4 On the Welcome page of the Active Directory Wizard, click Next.

5 On the Domain Controller Type page, accept the default option of Domain Controller for a 
New Domain > click Next.
16   ZENworks for Desktops 3.2 Lab Guide
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6 On the Create Tree or Child Domain page, select Create a New Domain Tree > click Next.

7 On the Create or Join Forest page, select Create a New Forest of Domain Trees > click Next.

8 On the New Domain Name page, type DA-Domain.DigitalAirlines.com in the Full 
DNS Name for New Domain field > click Next.

9 On the NetBIOS Domain Name page, confirm that the pre-filled name is DA-Domain > click 
Next.

10 On the Database and Log Locations page, change the default paths for Database Location and 
Log Location to D:\WINNT\NTDS > click Next.
Windows 2000 Server Setup 17



Novell Confidential 01_labg_zdfs_setup.fm last saved  5/16/ Manual Version: 3/17/03103
11 On the Shared System Volume page, change the default value for Folder Location to 
D:\WINNT\SYSVOL > click Next.

12 On the Configure DNS page, select Yes, install and configure DNS on this computer > click 
Next.

13 On the Permissions page, select Permissions Compatible with Pre-Windows 2000 Servers > 
click Next.

14 On the Directory Services Restore Mode Administrator Password page, type novell for 
your Administrator password > click Next.

15 In the Summary page, review your settings > click Next to display the Configuring Active 
Directory dialog box.
18   ZENworks for Desktops 3.2 Lab Guide
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If prompted during the configuration, insert the Windows 2000 Server CD.

16 On the Completing the Active Directory Installation Wizard page, click Finish > Restart Now. 
When your server reboots, Active Directory will be installed and ready.

Installing and Configuring DHCP
Use the following steps to install and configure DHCP on your Windows 2000 Server:

1 Log in to your Windows 2000 server as Administrator.

2 If the Windows 2000 Configure Your Server window displays after login, uncheck the Show 
This Screen at Startup check box.

3 From the Windows desktop, click Start > Settings > Control Panel > Add/Remove Programs.

4 In the Add/Remove Programs window, click Add/Remove Windows Components.
Windows 2000 Server Setup 19
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5 On the Windows Components page of the Windows Components Wizard, select Networking 
Services without changing the check box status > click Details. 

6 In the Networking Services dialog box, check Dynamic Host Configuration Protocol (DHCP) 
> click OK.
20   ZENworks for Desktops 3.2 Lab Guide
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7 When the Windows Component Wizard displays again, click Next.

8 In the Windows Component Wizard, click Finish.

9 In the Add/Remove Programs window, click Close.

10 From the Windows desktop, click Start > Settings > Control Panel > Administrative Tools > 
DHCP.

11 In the DHCP window, right-click da-02 [10.0.0.202] > select New Scope.

12 On the Welcome page of the New Scope Wizard, click Next.

13 On the Scope Name page, type LabScope in the Name field > click Next.
Windows 2000 Server Setup 21
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14 On the IP Address Range page, fill in the fields:

Start IP Address: 10.0.0.50.

End IP Address: 255.255.255.0

15 Click Next.

16 On the Add Exclusions page, click Next.

17 On the Lease Duration page, click Next.
22   ZENworks for Desktops 3.2 Lab Guide
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18 On the Configure DHCP Options page, select Yes, I Want to Configure These Options Now 
> click Next.

19 On the Router (Default Gateway) page, type your router address (if you have one) in the IP 
Address field > click Add > click Next.

20 In the Domain Name and DNS Servers window, fill in the fields:

Parent Domain:  digitalairlines.com.

IP Address:  10.0.0.202
Windows 2000 Server Setup 23
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21 Click Add > if you have an external DNS server, enter its IP address > click Next.

22 On the WINS Servers page, click Next.

23 On the Activate Scope page, select Yes, I Want to Activate This Scope Now > click Next.

24 In the Completing the New Scope Wizard window, click Finish.

25 In the left pane of the DHCP window, right-click the DHCP server name > click Authorize.
24   ZENworks for Desktops 3.2 Lab Guide
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26 Close the DHCP configuration utility.

Installing Novell eDirectory 8.61
Installing Novell NDS eDirectory on the ZENworks Windows 2000 server for this Lab Guide 
requires the following parts:

“Install Novell Client 4.83” on page 25

“Install Novell eDirectory 8.61” on page 27

Although Microsoft* Active Directory is not required for ZENworks services, many Windows 
server environments use Active Directory, or its close predecessor Windows NT Domain Services, 
to better manage Windows server security.

For more seamless integration between ZENworks services and Windows Networking, it helps to 
synchronize accounts between Microsoft Active Directory and Novell eDirectory by using Novell 
Account Management. Novell Account Management can be set up quickly, and it provides bi-
directional account synchronization—including password synchronization— between the two 
directory services.

Install Novell Client 4.83
Use the following steps to set up the Novell Client version 4.83:

1 Create a folder called D:\INSTALL on your Windows 2000 server.

2 Download the Novell Client 4.83 from the Novell Software Downloads Web site (http://
download.novell.com). The file to download is named WNT483E.EXE.

3 Extract WNT483E.EXE to D:\INSTALL.

4 Run SETUPNW.EXE from D:\INSTALL\WINNT\I386.

5 On the Software License Agreement page, click Yes.

6 In the Novell Client Installation dialog box, select Custom Installation > click Next.
Windows 2000 Server Setup 25
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7 In the drop-down box that lists the components to install, enable the ZENworks Application 
Launcher only > click Next.

8 In the Protocol Preference dialog box, select IP Only and enable the Remove IPX if Present 
> click Next.
26   ZENworks for Desktops 3.2 Lab Guide
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9 In the Login Authenticator dialog box, click Next.

10 In the last Novell Client Installation box, click Finish.

11 In the Installation Complete dialog box, click reboot.

12 After your server reboots and comes to the Login banner screen, press Ctrl-Alt-Del > select 
the Workstation Only check box > enter Administrator for Username > enter novell 
for Password > click OK to log in.

Install Novell eDirectory 8.61
Use the following steps to install Novell eDirectory on the Windows 2000 server.

1 Insert the Novell eDirectory 8.61 CD. Autorun will start the Novell eDirectory setup.

2 In the Choose Setup Language dialog box, click English > OK.
Windows 2000 Server Setup 27
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3 On the Novell eDirectory 8.6 Installation page, select all three options: Install Novell 
Directory Services, SLP Directory Agent, Install ConsoleOne options > click Install.

4 In the Novell NICI Server for Windows Installation window, click Next.

5 In the License Agreement window, click Accept.

6 In the NICI Server License Install window, enter the path to your NICI license (.nfk) file > 
click Next.

7 In the Installation Complete window, click Close.

8 In the NDS® eDirectory Product Installation window, click Next.

9 In the License Agreement window, click Accept.

10 In the Languages window, click Next.
28   ZENworks for Desktops 3.2 Lab Guide
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11 In the Location window, change the Installation Path field to D:\Novell\NDS > click Next.

12 In the Create Destination Location window, click Yes.

13 In the NDS Install window, select Create a New NDS Tree  > click Next.

14 In the second NDS Install window, fill in the fields:

Tree Name:

    DA_Tree

New Server Object Context:   

    DA-02-NDS.Servers.IST.Corp.DA

Admin Name:  

    Admin

Admin Context:  

    DA

Password: 

    novell
Windows 2000 Server Setup 29
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When you have finished filling out the fields, click Next.

15 In the Novell Certificate Server window, accept the default options > click Next.

16 In the Certificate Authority Installation informational dialog box, click OK.

17 In the LDAP Configuration window, change the Clear Text Port to 388 > change the SSL Port 
to 635 > click Next.
30   ZENworks for Desktops 3.2 Lab Guide
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The default TCP/IP ports will cause the Novell LDAP server to conflict with Active Directory.

18 In the ConsoleOne® 1.3.3 Install window, click Next.

19 In the ConsoleOne 1.3.3 License Agreement window, click Accept.

20 In the Next window, leave all language options unchecked > click Next.

21 In the Location window, change the default installation path to 
D:\NOVELL\CONSOLEONE\1.2 > click Next.

This step conserves space on the C: drive and ensures a smooth ZfD installation.

22 In the ConsoleOne Components window, leave all the default components selected > click 
Next.
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23 In the Jinfonet - License Agreement window, select I Do Accept the Terms of this License 
Agreement > click Next.

24 In the Summary window, click Finish to initiate the ConsoleOne install Progress window.

25 In the Installation Complete window, click Close.

26 In the Choose Setup Language dialog box, click OK.

27 In the Welcome page, click Next.

28 In the Software License Agreement page, click Yes.

29 On the Setup Type page, select Directory from the list of options > click Next.
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30 In the SLP Directory Agent for NT Installation dialog box, make sure that the Tree drop-down 
box shows DA_TREE. Click the expand tree button (+ symbol) next to [Root] and wait for 
the Novell Login dialog box to be displayed.

31 In the Novell Login dialog box, click the Advanced button > enter the following values > click 
OK:

Username:

    Admin

Password:   

    novell

Tree:  

    DA_Tree

Context:  

    DA
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32 When login completes, select the Servers.IST.Corp.DA container.
NOTE: Notation for directory services typically specifies the lowest-level container first.

33 Click Create > rename the new agent SLP Directory Agent > click OK.

34 In the SLP Directory Agent confimation dialog box, click OK.

35 On the Start Copying Files page, click Next.
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36 On the Setup Complete page, click Finish.

37 Most eDirectory installations do not require a reboot. However, if you are prompted to reboot, 
click OK > proceed to reboot.

If you are prompted only to Close, then you do not need to reboot. After clicking Close, click 
the Windows Start menu > Shut Down > Log off Administrator.

38 In the Novell Login dialog box, click Advanced.

39 In the NDS tab's Tree field, type DA_TREE.

40 In the Context field, type DA.

41 In the Username field, type Admin.

42 In the Password field, type novell > click OK.

43 Locate the D:\NOVELL\NDS\NDSIMON.INI file and change its properties to disable the 
Read Only setting.

44 Use Notepad to open D:\NOVELL\NDS\NDSIMON.INI.

45 Find the line that starts with #httpport and remove the leading # symbol > change the port 
from 80 to 90 > save the file.
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This step changes the NDS iMonitor Facility Web server to use port 90 so that the Microsoft 
IIS Web server can continue using port 80.

Installing Novell Account Management
Use the following steps to install Novell Account Management:

1 From the Windows desktop, double-click the ConsoleOne icon.

2 In ConsoleOne, browse the DA_TREE to select the DA organization container. Create a new 
Organizational Unit called ADforest below the DA organization > close ConsoleOne.

3 Insert the Novell Account Management CD into your Windows 2000 Server's CD drive. 
Autorun will start the Novell Account Management setup.

4 From the Choose Setup Language window, select English > click OK.

5 In the Novell Account Management for Windows 2000 splash window, enable both the 
Synchronize Active Directory with eDirectory and the Install ConsoleOne options > click the 
Install button.

Re-installing ConsoleOne is necessary to ensure that the Account Management snap-ins are 
installed.

6 The Novell Client will update if necessary, and the ConsoleOne install will start. Repeat Step 
18 through Step 36 in “Install Novell eDirectory 8.61” on page 27.

7 In the Installation Complete window, click Close.

8 In the Account Management for Windows 2000 Product Installation Welcome window, click 
Next.

9 In the License Agreement window, click Accept.

10 In the Summary window, click Next.

11 If shutting down eDirectory takes more than two minutes, the eDirectory service may have 
encountered a shutdown problem. In this case, refer to Novell Support TID 10064212 (http:/
/support.novell.com/servlet/tidfinder/10064212) at the Novell Support Web site (http://
support.novell.com).
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12 In the Driver Installation Complete dialog box, click Continue.

13 When the Account Management Welcome dialog box is displayed, click Next.

14 In the Account Management Start Copying Files dialog box, click Next.

15 On the Welcome page of the Account Management for Windows 2000 Wizard, click Next.
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16 On the Synchronize Directories page, ensure that the Active Directory Domain field specifies 
DA-Domain > click Next.

17 In the Domains in eDirectory window, select Yes, This Domain Is the First Domain in the 
Forest To Be Synchronized with eDirectory > click Next.
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18 In the Create DirXML Driver page's Name field, type Addriverset > for the Context, 
type Adforest.DA > click Next.

19 On the DirXML Driver Privileges page, click the Add button > browse to find the user 
.Admin.DA > click OK > click Next.
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20 In the Forest Location page's Context field, type  ADforest.DA > click Next.

21 In the New User Location page's Context field, type Adforest.DA > click Next.

22 On the Search for Users to Associate page, select No, Don't Search for User Associations > 
click Next.
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23 On the Users with No Association page, click Next.

24 On the Summary page, click Next.

25 After the synchronization completes, click Finish.

26 In the Password Synchronization Setup dialog box, fill in the fields:

Name: ADPwdSync

Context: ADforest.DA.

27 Click OK.

28 In the Context field of the next Password Synchronization Setup dialog box, type DA > click 
OK.
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29 In the Pwdsync dialog box, click Yes.

30 In the Domains Available for Synchronization field of the Add Domain Provider, click DA-
Domain > click OK.

31 In the Pwdsync dialog box, click Yes.

32 In the Password Filters on DA-Domain dialog box, click the DA-02 list item > click Setup.

33 In the PwdSync window, click OK.

34 In the Password Filters on DA-Domain window, click Close.

35 In the final Account Management for Windows 2000 Setup window, click Finish.

36 Follow the steps for Novell TID 2959979 (http://support.novell.com/servlet/tidfinder/
2959979) at the Novell Support Web site (http://support.novell.com).

37 In ConsoleOne, open the DA_Tree and browse to find the .DA-Domain-
Driver.ADdriverset.ADforest.DA object > right-click the DA-Domain-Driver object > click 
Properties from the pop-up menu.

38 In the Properties of DA-Domain-Driver window, activate the DirXML-Driver Configuration 
page and the Driver Parameters-DA-02-NDS sub-page > set the Polling Interval field to 1 > 
click OK.

This will make AD and eDirectory synchronize very quickly.
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39 Close ConsoleOne.

40 On the Windows Desktop, right-click the My Network Places icon and select Properties.

41 In the Network and Dial-up Connections window, right-click any network connection icon > 
select Properties.

42 In the Properties dialog box, select the Novell Workstation Manager component and click 
Uninstall. Confirm the Uninstall by clicking Yes. Repeat the process for the Novell 
Distributed Print Services > click OK to close the Properties window.

43 Click the Start menu > Shut Down > Restart > OK.

Configuring Novell Account Management
Use the following steps to configure Novell Account Management:

1 Log in as .Admin.DA.

2 Close the Password windows.

3 Launch ConsoleOne from the Windows desktop.
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In the next steps, you will create three Active Directory Organizational Units (OUs) and map 
them to existing containers.

4 Browse to .DA-Domain.DA-Domain.ADforest.DA > right-click the DA-Domain domain 
object > click New > click Organizational Unit from the pop-up menu.

5 In the Create an Active Directory Organizational Unit window, type DA in the Name field > 
change the Default User Creation Context to DA by using the browse button > click OK.

6 Locate the newly created .DA.DA-Domain.DA- Domain.ADforest.DA organizational unit, 
right-click it > click New > click Organizational Unit from the pop-up menu.

If you find that the New option is not available, you may need to stop and re-start the NDS 
Server service in the services Control Panel applet. At time of publication, the author is 
unaware of an appropriate fix for this issue.
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7 In the Create an Active Directory Organizational Unit window, type Corp in the Name field 
> change the Default User Creation Context to Corp.DA by using the browse button > click 
OK.

8 Right-click the newly created .Corp.DA.DA-Domain.DA-Domain.ADforest.DA 
organizational unit > click New > click Organizational Unit from the pop-up menu.

9 In the Create an Active Directory Organizational Unit window, type IST in the Name field > 
change the Default User Creation Context to IST.Corp.DA by using the browse button > click 
OK.

In the next set of steps, you will create three new Active Directory OUs and automatically 
create new eDirectory OUs to which the AD OUs will map.

10 Right-click the .DA.DA-Domain.DA-Domain.ADforest.DA object > click New > click 
Organizational Unit from the pop-up menu.
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11 In the Create an Active Directory Organizational Unit window, type Airports in the Name 
field and change the Default User Creation Context to DA by using the browse button > 
enable Create a Corresponding Organizational Unit in eDirectory > click OK. 

12 Right-click the .Airports.DA.DA-Domain.DA-Domain.ADforest.DA object > click New > 
click Organizational Unit from the pop-up menu.

13 In the Create an Active Directory Organizational Unit window, type AM in the Name field and 
change the Default User Creation Context to Airports.DA by using the browse button. Enable 
the Create a Corresponding Organizational Unit in eDirectory option > click OK.

14 Right-click the .AM.Airports.DA.DA-Domain.DA-Domain.ADforest.DA object > click New 
> click Organizational Unit from the pop-up menu.
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15 Type ATL in the Name field and change the Default User Creation Context to 
AM.Airports.DA by using the browse button. Enable the Create a Corresponding 
Organizational Unit in eDirectory option > click OK.

Testing the Novell Account Management Configuration
Your eDirectory Tree should have the container structure shown here. If so, you can try a few 
things to test your Novell Account Management implementation.

Use the following steps as a guide in your testing:

1 Click Start > Settings > Control Panel > Administrative Tools > Active Directory Users and 
Computers.

2 In the Active Directory Users and Computers window, browse to the .ATL.AM.Airports.DA 
container.

3 Create a user called Philip Marlowe in the ATL.AM.Airports.DA organizational unit.

4 Use ConsoleOne to verify that the user was created in the corresponding eDirectory context.

5 Use eDirectory to change the user phone number, then verify it in the Active Directory user 
admin tool. 
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With the user accounts synchronizing properly, you are ready to proceed to Chapter 2, “Installing 
ZENworks for Desktops 3.2,” on page 49.
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2 Installing ZENworks for Desktops 3.2

This section of the ZENworks® for Desktops (ZfD) 3.2 Lab Guide contains the following sections:

“Introduction” on page 49

“Installing ConsoleOne 1.3” on page 50

“Installing ZENworks for Desktops 3.2” on page 50

“Post-installation Procedures” on page 55

Introduction
This document details the process for installing ZfD 3.2 using Digital Airlines as an example case 
study. Although Digital Airlines is a simple, one-server tree, this setup shows all the steps of a 
custom install.

Some steps, such as those involving installing Inventory or Automatic Workstation Import 
services, are not fully explained in this section of the Lab Guide. Subsequent sections will cover 
those topics in more detail. Before you begin the installation, you may be concerned with other 
considerations, including:

“Permanence of This Setup” on page 49

“Dependencies” on page 49

“Requirements” on page 49

Permanence of This Setup
This process makes permanent schema changes to eDirectoryTM. It also creates several NDS® 
objects in the tree.

Dependencies
This setup assumes that you are using a server built according to the instructions in Chapter 1, 
“Windows 2000 Server Setup,” on page 13.  The server is a Windows* 2000 server running Active 
Directory* and Novell® Account Management for Windows 2000. 

Requirements
You will need the three ZfD 3.2 CDs: Program, Companion, and Client. You will also need to have 
a Windows 2000 server running eDirectory. If you are installing the Preboot services, you will 
need the Preboot Services CD.
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Installing ConsoleOne 1.3
Although your server already has ConsoleOne® 1.2d installed, ZfD 3.2 requires ConsoleOne 1.3 
in order to properly use all of the program snap-ins.

Use the following steps to install ConsoleOne:

1 Log into eDirectory using the following credentials:

Tree name: DA_Tree

Username: Admin

User Context: DA

Password: novell

2 From the ZfD 3.2 Companion CD, find the ConsoleOne folder and run C1.EXE.

3 In the WinZip Self-Extractor [C1.EXE] window, click Setup.

4 In the ConsoleOne 1.3 Install window, click Next.

5 In the ConsoleOne 1.3 License Agreement window, click Accept.

6 At the Location screen, ensure that the path is D:\NOVELL\CONSOLEONE\1.2.

or

If you are installing to a NetWare® server instead of a Windows 2000 server, specify your path 
as \\SERVERNAME\SYS\PUBLIC\MGMT\CONSOLEONE\1.2.

7 Log on to your server as Administrator.

8 In the ConsoleOne Components window, click Next.

9 In the Jinfonet – License Agreement window, click Next.

10 At the Summary screen, click Finish.

11 If you receive a prompt asking how to handle overwriting newer files, select Never Overwrite 
Newer Files > click OK.

12 After the installation, an Installation Complete message appears. Click Close.

Installing ZENworks for Desktops 3.2
Use the following steps to install ZfD 3.2:

1 Remove the Windows share from your server’s C:\NOVELL folder > share D:\NOVELL as 
SYS:.

If you do not change the share to the same folder as your eDirectory root folder 
(D:\NOVELL), your ZENworks installation will fail.

2 Insert the ZfD 3.2 Program CD into the CD drive of your Windows 2000 server. Autorun will 
start the WinSetup installer.

3 In the ZENworks for Desktops – WinSetup window, click English > Install ZENworks.
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4 In the Warning dialog box, read the message carefully > click Yes.

Currently, ZfD 3.2 is slated for localization in English, French, and German only.

5 In the Novell Product Installation window, click Next.

6 In the License Agreement window, click Accept.

7 In the Install Prerequisites window, click Accept.

8 In the ZENworks Install Types Window, select the Custom option > click Next to display the 
ZENworks Install Types window.

Selecting the Custom option ensures that all setup options will be presented during setup.

9 In the ZENworks Components screen, ensure that all options are selected, including the 
Sybase option > click Next.
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The Sybase* option installs the Sybase database for the Inventory Server. For information 
about using Oracle*, see Configuring the Inventory Database for Oracle on a Windows NT/
2000 Server in Workstation Inventory in ZENworks for Desktops 3.2 Deployment Guide.

10 In the ZENworks Part Selection screen, ensure that all options are selected > click Next.

If you do not have the CD for ZfD 3.2 Preboot Services, disable the PXE Support option.

11 In the ZENworks List of Trees window, select the DA_TREE option > click Next.

12 In the ZENworks List of Servers window, select the DA-02-NDS server > click Next.

13 In the Inventory Database Server Selection screen, select the DA-02-NDS server > click Next.

14 In the Inventory Database Volume Selection window, select the SYS option > click Next.
IMPORTANT: Important: Never use SYS in a production environment.
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15 A pop-up notice will warn you that the server will load some components (the Sybase SQL 
server) during install. Click OK to proceed.

16 At the Languages window, click Next.

17 In the Automatic Workstation Import Management window, select Import/Removal > click 
Next.

18 In the Inventory Server Roles window, leave the default inventory role of Standalone > click 
Next.

This server will not take part in multi-site inventory roll-up.

19 In the ScanDir Volume window, select the SYS volume > click Next.
IMPORTANT: Do not use SYS in a production system.

The specified share is used to store .STR files. Store files temporarily hold workstation 
inventory data before it is stored in the database.
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20 In the Site ID for Database window, enter 002 in the SiteID field and DA2site for Site Name 
> click Next.

The Site ID is a three-digit number unique to this inventory server. The Site Name is a unique 
name for the site.

21 In the Site ID for Database warning screen, click OK.

22 In the Summary window, click Finish and the file copy will begin.
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23 When you see the ZfD 3.2 Preboot Services window, remove the ZfD 3.2 Program CD and 
insert the Preboot Services CD > click OK. (This step occurs only if you selected to install 
PXE Support in Step 10 on page 52.) 

24 When you see the ZfD 3.2 Installation window, remove the ZfD 3.2 Preboot Services CD and 
replace it with the Program CD > click OK.

25 If you receive a prompt asking how to handle overwriting newer files, click Never Overwrite 
Newer Files.

26 After the installation, an install log will appear in Notepad. Review the log for errors > click 
Close.
IMPORTANT: Do not reboot the server yet. Proceed to the next section.

Post-installation Procedures
1 Start ConsoleOne and browse the DA_Tree to locate the .IST.Corp.DA container.

Remember, the NDS naming convention is similar to the DNS naming conventions—it reads 
backwards.

2 Create the following organizational unit containers below IST: Apps, Images, Policies, and 
Workstations.

3 Move the application objects from the .Servers.IST.Corp.DA container to the 
.Apps.IST.Corp.DA container. This is most easily done by selecting all the application objects 
as a group > right-clicking them > clicking Move from the shortcut menu.

4 When you have completed these post-installation procedures, restart your Windows 2000 
server.

After you reboot and log in, ZfD 3.2 Pre-Boot Services will automatically self-configure. That 
final process completes the installation of ZfD 3.2.
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3 Setting Up a Windows 2000 Professional 
Workstation for Desktop Management

This section of the ZENworks® for Desktops (ZfD) 3.2 Lab Guide contains the following sections:

“Introduction” on page 57

“Installing Windows 2000 Professional” on page 58

“Installing the Novell Client and ZENworks Agents” on page 59

Introduction
The procedures throughout the ZfD portion of the ZENworks Lab Guide primarily affect 
workstation machines. Because Windows* 2000 Professional represents the most modern and 
widely deployed desktop operating system, and because of its inherent management complexities, 
the ZENworks Lab Guide primarily addresses management for this platform.

This short section of the Lab Guide outlines the basic setup steps for creating a Windows 2000 
Professional workstation and installing the Novell® ClientTM with the correct ZENworks for 
Desktops management agents. Although there are automated methods for deploying the Novell 
Client, they are not covered in this section. 

 Before you begin the installation, you may be concerned with other considerations, including:

“Permanence of This Setup” on page 57

“Dependencies” on page 57

“Requirements” on page 57

Permanence of This Setup
This script requires you to configure a Windows 2000 Professional workstation. After completing 
this script, we recommend that you proceed to Chapter 4, “Manual Workstation Imaging,” on page 
65 in order to create a restorable image of this workstation.

Dependencies
This script requires working knowledge of basic Windows 2000 Professional tasks, including 
installation and setup, disk partitioning, and Windows networking fundamentals.

This section contains the following information:

Requirements
To perform the steps in this script, you will need the following hardware and software:
Setting Up a Windows 2000 Professional Workstation for Desktop Management 57



Novell Confidential 01_labg_zdfs_setup.fm last saved  5/16/ Manual Version: 3/17/03103
Hardware: For acceptable performance in a lab, you will need at least the following hardware 
configuration:

Pentium* 300

128 MB RAM

4 GB disk space

Network interface card

Subsequent scripts require one or more Windows workstations similar to this configuration.

Software: 

Windows 2000 Professional installation media

Novell Client 4.8 installation media available at the Novell Software Downloads Web site 
(http://download.novell.com)

The Novell ZENworks for Desktops 3.2 Program CD

You will also need Internet access to download various service updates.

Installing Windows 2000 Professional
1 Install Windows 2000 Professional to your workstation hardware, using the following 

specifications for the first boot:

Use the following specifications for the second boot:

Specification Setting

Primary partition size 2047 MB

Primary partition format FAT (for easier Windows 2000 repairs)

Specification Setting

Regional Settings Standard

Name Whatever you choose

Organization Digital Airlines

Product Key According to your CD

Computer Name DA-ClientBase

Administrator Name Administrator

Administrator Password novell

Components Default components

Network Settings Typical

Domain No

Workgroup Workgroup
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Use the following specifications for the third boot:

2 After completing the install, log in as Administrator.

3 Create a 2048 MB extended partition and logical drive, formatted as NTFS > assign the drive 
letter D:.

By creating a D: partition of the limited size specified in this step, you will have better luck 
re-imaging this workstation to different hard disks if you choose to use some imaging offering 
other than Novell ZENworks Imaging.

4 Open Internet Explorer and configure it to use your Internet connection.

5 In Internet Explorer, click the Tools menu > Windows Update.

6 On the Microsoft Windows Update home page, click the link for Product Updates and allow 
your system to detect what updates are needed. Apply as many updates as possible.

Repeat the Windows Update process through the multiple updates and reboots until your 
workstation has at least Windows 2000 Service Pack 2 and all the critical updates applied. 
Consider also updating to the latest version of Internet Explorer.

Installing the Novell Client and ZENworks Agents
1 Start the Novell Client install. This task may vary, depending on the media from which you 

will be installing.

2 At the Software License Agreement first install window, select Yes to accept the client license 
agreement.

3 At the first Novell Client Installation window, select the Custom Installation option > click 
Next.

4 In the components window, ensure that the following component options are selected > click 
Next:

Novell Client for Windows 2000

Specification Setting

Users of This 
Computer

Select the Users Must Enter a User Name and Password to Use this 
Computer option
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Novell Workstation Manager

ZENworks Application Launcher NT Service

Remote Management

ZENworks Imaging Service

Novell Workstation Manager is the primary management agent used by ZfD. It gives the 
workstation an identity in the Directory and processes ZENworks policies from the directory. 
(Never run this agent on a Novell Account Management server.)

ZENworks Application Launcher NT Service assists at installing desktop applications to 
Windows NT* workstations where the local user has no rights to perform software 
installations.

Remote Management provides an interface for remote control and diagnostics utilities.

ZENworks Imaging Service performs Windows tasks for workstations that have recently been 
restored from a disk image. These tasks include such things as changing SIDs or NETBIOS 
names.

5 In the Protocol Preference window, switch to IP Only > click Next.

6 In the Login Authenticator window, select the NDS option > click next.

7 In the Workstation Manager window, leave the Tree field blank > click Next.
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The tree specified here becomes the “trusted” tree for the Windows 2000 workstation. 
Workstations are only manageable from the trusted tree. By leaving this field blank, the first 
tree into which the workstation authenticates will be automatically trusted.

8 At the final window, click Finish.

9 At the reboot prompt, do not reboot. Click Close.
IMPORTANT: Do not reboot. Proceed to apply the ZENworks for Desktops 3.2 client service pack.

10 Insert the ZfD 3.2 Companion CD into your workstation’s CD drive.

11 From the CD, run \CLIENT\PRODUCTS\WINNT\I386\SETUPSP.EXE.

12 After the Client Support Pack updates your ZENworks management agents, reboot your 
workstation.

13 Test the Novell Client by logging in using the following credentials:

Tree Name: DA_Tree

Username: Admin

User Context: DA

Password: novell

A successful login confirms your workstation build is ready for management by ZfD.
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II Managing the Complete Workstation Life Cycle

This unit of the ZENworks® for Desktops (ZfD) 3.2 Lab Guide focuses on maintaining 
workstation hardware and software. Included in this unit are the following sections:

Chapter 4, “Manual Workstation Imaging,” on page 65

Chapter 5, “Automatic Workstation Import,” on page 71

Chapter 6, “Remote Management,” on page 81

Chapter 7, “Single-Site Inventory Collection,” on page 87

Chapter 8, “A Tool for the Help Desk: The ZENworks Workstation Browser,” on page 101

Chapter 9, “Applying Windows 2000 Group Policies to Workstations,” on page 105

Chapter 10, “Automated Workstation Imaging,” on page 107
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4 Manual Workstation Imaging

This section of the ZENworks® 3.2 Lab Guide contains the following sections:

“Introduction” on page 65

“Creating ZENworks Imaging Media” on page 66

“Creating a Workstation Image” on page 67

“Restoring a Workstation Image” on page 68

“Troubleshooting and Strategies” on page 69

Introduction
The following procedures cover how to manually create a workstation disk image with ZENworks 
Imaging. By following these procedures, you will ensure that the work you performed in “Setting 
Up a ZfD 3.2 Lab Environment” on page 11 can be quickly restored for use with various 
subsequent exercises, or in the event of an accidental misconfiguration of your workstation.

This procedure is not intended to show all features of ZENworks Imaging. To understand how to 
automate ZENworks Imaging for Windows workstations, including how to implement ZENworks 
Preboot Services, the Lab Guide will include a lengthier section titled "Automated ZENworks 
Imaging" as a complement to this section.

Permanence of This Setup
The steps will add a large ZENworks image file to your server's D: drive.

Dependencies
This procedure is intended to immediately follow completion of all steps in “Setting Up a ZfD 3.2 
Lab Environment” on page 11.

Requirements
To perform the steps in this script, you will need:

Hardware:

A floppy disk drive for your server and workstation

or

A CD burner (preferred for speed)

Software: If you are using a CD burner, you need Adaptec* Easy CD Creator, or similar software.
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Creating ZENworks Imaging Media

Option A: Creating a ZENworks Imaging CD
Creating a ZENworks Imaging CD is the preferred method for manually performing ZENworks 
Imaging tasks. Bootable CDs are significantly faster to use than booting from a floppy disk, and 
easier to manage.

To use this option, your workstation must be capable of booting from CD.

1 On a machine with a CD burner, insert the ZfD 3.2 Program CD.

2 Copy the following files from CD to a local hard drive on the CD burner machine:

\path\PUBLIC\ZENWORKS\IMAGING\BOOTCD.ISO

\path\PUBLIC\ZENWORKS\IMAGING\SETTINGS.ISO

3 Use Adaptec Easy CD Creator (or similar software) to burn a CD session from the 
BOOTCD.ISO CD image. Set the software to leave the CD open after burning BOOTCD.ISO 
as a session. Do not close Easy CD Creator.

4  Use Notepad to  open the SETTINGS.TXT file.

5 Find the line starting with PROXYADDR= and change it to read PROXYADDR=10.0.0.202 
> save the SETTINGS.TXT file.

6 Add the modified SETTINGS.TXT file to the still-open CD in the burner by dragging it into 
Adaptec Easy CD Creator's CD layout.

7 Re-burn the CD with the added SETTINGS.TXT file. Set the software to close the CD session 
and the CD.

After creating a workstation image, you can use this same technique for adding the image file 
to a CD to make self-contained bootable media from which you can restore the ZENworks 
Imaging workstation image.
66   ZENworks for Desktops 3.2 Lab Guide



Manual 3/17/03103Novell Confidential 02_labg_zdfs_wkstn.fm last saved  5/16/
8 Close Adaptec Easy CD Creator.

Option B: Creating ZENworks Imaging Floppy Disks
Using floppy disks is slower than using a CD because you must swap each of the three diskettes. 
However, this method works with even with older workstations that do not have CD drives.

1 Obtain three floppy diskettes.

2 Switch to your Windows* 2000 Server and start ConsoleOne®.

3 In ConsoleOne, click Tools > ZENworks Utilities > Imaging > Create or Modify Boot 
Diskette.

4 In the ZENworks Imaging Boot Disk Creator window, change the Imaging Proxy Server 
Address option to Use IP Address. Type 10.0.0.202 for the IP address.

5 Insert your first floppy disk into the disk drive > click Create Boot Disk 1.

6 Repeat for disk two and disk three.

7 Click Close.

8 Close ConsoleOne.

Creating a Workstation Image
1 On your Windows 2000 Server, create an IMAGES folder at the root of the D: drive.

2 Switch to your Windows 2000 Professional workstation.

3 Reboot your Windows 2000 Professional Workstation with your ZENworks Imaging boot 
media.

4 At the Novell ZENworks Imaging v3.2 text screen's boot prompt, type manual.
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This screen will default to Auto if you press Enter or wait too long before typing.

5 At the bash# prompt, type

IMG MP 10.0.0.202 //DA-02/D:/Images/W2Kpro.zmg

This command will tell the ZENworks Imaging Engine (IMG) to make (M) an image on the 
proxy (P) at address 10.0.0.2 in the server's (DA-02) D:\IMAGES folder. For other command 
line options, consult the ZENworks for Desktops 3.2 documentation at the Novell® 
documentation Web site (http://www.novell.com/documentation.)

If your workstation screen goes blank, it is a screen saver function of the Linux* kernel. Press 
any key to turn on the screen again.

6 After the Imaging job completes, you will return to the bash# prompt. Eject the CD or floppy 
disk > type reboot > press Enter.

Restoring a Workstation Image
1 Either switch to another workstation of similar hardware, or swap your current workstation 

hard disk.

If you switch to another machine, use a machine as close to the same hardware as the original 
machine you imaged. Windows 2000 Professional can adapt to hardware modifications 
relatively well, but still requires reboots when the hardware is significantly different.

If you swap hard drives (often easy with laptop machines) automatic hardware detection 
should not be necessary after the image is restored.

2 Boot your workstation hardware with your ZENworks Imaging boot media.

3 At the Novell ZENworks Imaging v3.2 text screen's boot: prompt, type Manual.

This screen will default to Auto if you press Enter or wait too long before typing.

4 At the bash# prompt, enter

IMG RP 10.0.0.202 //DA-02/D:/Images/W2Kpro.zmg

This command will tell the ZENworks Imaging Engine (IMG) to restore (R) an image from 
the proxy (P) at address 10.0.0.2 in the server's (DA-02) D:\IMAGES folder.

If your workstation screen goes blank, it is a screen saver function of the Linux kernel. Press 
any key to turn on the screen again.

5  After the Imaging job completes, you will return to the bash# prompt. Eject the CD or floppy 
disk > type reboot > press Enter.

After your machine reboots, perform a Login to Local Workstation Only as Administrator. 
Hardware detection may need to complete and prompt for a reboot.

6 On your newly restored workstation, log in to your DA_Tree eDirectory tree as .Admin.DA.

A successful login confirms your workstation image's success.
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Troubleshooting and Strategies

Optimizing Disk Space
The following is a list of a few suggested paths and data types to delete from your file system 
before imaging in order to make your ZENworks Imaging files smaller.

Temp Folders

C:\TEMP

C:\WINNT\TEMP

 C:\DOCUMENTS AND SETTINGS\USERNAME\LOCAL SETTINGS\TEMP

Clear IE Cache

In the Control Panel, open the Internet Options applet and delete the temporary internet files.

Clear Service Pack Files

C:\WINNT\$uninstall_windows_update_folder

C:\PROGRAM FILES\UNINSTALL INFORMATION

Unneeded Applications

Delete applications such as Solitaire, Pinball, and so forth.

Network Cards Support
Most NICs work out of the box with ZENworks Imaging. The Novell ZENworks for Desktops 3.2 
Documentation site (http://www.novell.com/documentation) includes a list of supported NICs. If 
your NIC is not natively supported, you may need to obtain a Linux driver for your NIC and 
specify that NIC when creating your ZENworks Imaging boot media. Further information on this 
process is available in the online documentation.

The ZENworks Lab Guide was tested specifically using Xircom* XCEM 10/100 and Intel* 
EtherLink 10/100 NICs.

Setting Up a Separate Imaging Server
If you want to Image your ZENworks for Desktops 3.2/Windows 2000 Server system, install 
another server into a separate eDirectoryTM tree. The ZENworks Imaging server can run on 
NetWare®, Windows* NT*, or Windows 2000.
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5 Automatic Workstation Import

This section of the ZENworks® 3.2 Lab Guide contains the following sections:

“Introduction” on page 71

“Setting Up the Automatic Workstation Import Debug Screen” on page 72

“Setting Up the Import Server Policy” on page 74

“Testing the AWI Server Policy” on page 76

“Setting Up the zenwsimport DNS Record” on page 76

“Testing the zenwsimport DNS Record” on page 78

“Troubleshooting Tips” on page 79

Introduction
This lab shows how to import workstations to eDirectoryTM using Automatic Workstation Import. 
Having workstations in the directory is essential in order to use many other ZENworks features, 
such as workstation inventory, remote management, enterprise imaging, and workstation 
configuration. 

When completed, this process enables any workstation with the ZENworks for Desktops (ZfD) 3.2 
client to be automatically imported to the DA_Tree eDirectory tree.

Permanence of This Setup
Changes made with this lab are easily reversible. The policy you create, as well as any imported 
workstations, can be deleted.

Dependencies
This lab is intended to be performed on the base DA_02 server, following completion of Chapter 
2, “Installing ZENworks for Desktops 3.2,” on page 49. 

Specifically, this process assumes that your server has had a Custom installation of ZfD 3.2, with 
the Automatic Workstation Import option selected and the role defined as Import/Removal.

You will also need to have a basic understanding of IP and DNS services.

Requirements
To perform the steps in this lab, you will need:

Hardware:
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The DA_02 server, configured according to the instructions in Chapter 2, “Installing 
ZENworks for Desktops 3.2,” on page 49.

One Windows* 2000 Professional or Windows NT* Workstation configured to use DHCP and 
the Novell® ClientTM (version 4.8 with Service Pack 3). 

Software:

The ZENworks for Desktops 3.2 Companion CD, which includes the Novell Client software.

Setting Up the Automatic Workstation Import Debug Screen
Enabling the debug screens for Automatic Workstation Import greatly assists in troubleshooting 
because you can see errors as they occur instead of referring to the Import server's log files.

1 On your Windows 2000 Server, click the Start menu > Run.

2 In the Open field, type notepad D:\Novell\zenworks\AutoWS\zenwsimp.reg 
> click OK.

3 In the zenwsimp.reg Notepad window, locate the zenwsimportCmdLine line. At the end of the 
line, add -Dloglevel=3 after the text -Dlogfilelevel=2 as shown in the illustration below. 
Save the file as zenwsimphigh.reg and close Notepad.

Do not save the file with a .TXT extension.

4 Click the Start menu > Run.

5 In the Open field, type c:\Novell\zenworks\AutoWS\zenwsimphigh.reg > click 
OK.

6 At the Registry Editor window, click Yes to merge the file with your registry.

7 At the Registry Editor informational window, click OK. 

The new registry setting will cause verbose logging of AWI information to the AWI screen.

Next, you need to enable the AWI service screen to display.

8 On your Windows 2000 Server, click the Start menu > Settings > Control Panel > 
Administrative Tools > Services.

9 At the bottom of Services window, double-click the ZENworks Workstation Import service.
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10 In the ZENworks Workstation Import Properties (Local Computer) window, enable Allow 
Service to Interact with Desktop > click OK.

11 In the Services window, select the ZENworks Workstation Import service > click the Actions 
menu > click Restart Service. 

The Workstation Import Service window will appear so you can track workstation import 
events as they happen

12 Close the Services window.
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Setting Up the Import Server Policy
1 Start ConsoleOne® and select the Policies.IST.Corp.DA container > click File > New > Policy 

Package.

2 In the Policy Package Wizard window, select Server Package > click Next.

3 Name the package Server Package > click Next > Finish. 

4 Right-click the Server Package > click Properties.

5 On the General page, check the Workstation Import check box > click Properties. 

6 On the Containers tab, click Add > select the .Workstations.IST.Corp.DA container. 

This step grants rights to the Import service so it can create workstations in our target location. 
To import to multiple containers, you can list a single container above the target containers 
instead of listing all containers.
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7 Click the Platforms-General tab > the Location sub-tab.

8 Enable the Allow Importing of Workstations check box.

9 In the drop-down menu for Create Workstation Objects In, click Selected Container.

10 In the Path field, browse to the .Workstations.IST.Corp.DA container.

11 Click the Naming sub-tab > select MAC Address > click Remove so the Workstation Name 
field reads simply "Computer" > click OK. 
Automatic Workstation Import 75



Novell Confidential 02_labg_zdfs_wkstn.fm last saved  5/16/ Manual Version: 3/17/03103
12 In the Properties of Server Package dialog box, click the Associations tab > click Add > 
browse the tree and select the DA-02 server > click OK. 

You are now ready to test your Workstation Import server and your policy.

Testing the AWI Server Policy
1 Close ConsoleOne.

2 Switch to the workstation and log in to eDirectory as .Admin.DA.

3 On your workstation, click the Start menu > Run.

4 In the Run window's Open field, type wsreg32 > click OK.

5 After about 15 seconds (for timeout purposes) > use Notepad to open the C:\WSREG32.LOG 
file > view the message in the text file:

WSREG-v3.0  While contacting the Work Station Import Service, an error -
1 was encountered, and error description <Winsock connect() failed.> was 
reported.

This error results from the Workstation Registration agent not knowing which host is the 
Import server. You will also notice that the Import Server screen shows no change to indicate 
a registration request.

6 On your workstation, click Start > Run.

7 In the Run window's Open field, type wsreg32 /s=10.0.0.202 > click OK.

The Import Server screen on your Windows 2000 server should show the successful 
workstation import.

8 Open the C:\WSREG32.LOG file again and notice the difference.

9 On your ZENworks Server, open ConsoleOne and select the .Workstations.IST.Corp.DA 
container to view your newly imported workstation.

This confirms that your import policy works. Next, you need to ensure that all workstations 
can contact the Automatic Workstation Import server.

Setting Up the zenwsimport DNS Record
Enabling workstations to contact the Import Server is the key to successful workstation import. 
There are several methods to do this: the command line used in Step 7 on page 76 can be 
automatically pushed to the workstation using the ZENworks Application Launcher; the hostname 
zenwsimport can be made available either by way of DNS or a hosts file; or the ZENworks 
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Application Launcher can be used to set a registry value. For the Lab Guide, we will use DNS to 
quickly enable locating the Workstation Import Server.

By default, the ZFD 3 workstation registration agent looks for the import service running on the 
server with a hostname of zenwsimport. To use DNS, the workstation must be able to ping the 
service at zenwsimport. Therefore, you must create an entry in DNS, or put zenwsimport in each 
workstation's HOSTS table.

1 Switch to your ZENworks server.

2 Click the Start menu > Settings > Control Panel > Administrative Tools > DNS.

3 In the DNS window, double-click the DA-02 server object in the left-most pane.

4  Right-click the Forward Lookup Zones folder > click New Zone from the pop-up menu.

5 In the New Zone Wizard Welcome screen, click Next.

6 In the Zone Type window, select the Standard primary option > click Next.

7 In the Zone Name window's Name field, type DigitalAirlines.com > click Next. 

8 In the Zone File window, accept the default Create a New File With This File Name option > 
click Next.

9 In the Completing the New Zone Wizard window, click Finish.

10 In the DNS window, double-click the Forward Lookup Zones server object in the left-most 
pane so it expands to reveal your new  DigitalAirlines.com zone.

11 Right-click the DigitalAirlines.com zone > click New Host.
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12 In the New Host window's Name field, type zenwsimport. In the IP Address field, type 
10.0.0.202 > click Add Host > click Done.

13 Close the DNS utility.

Testing the zenwsimport DNS Record
1 Switch to your ZENworks workstation.

2 Click the Start menu > Run.

3 In the Run menu's Open field, type CMD > click OK.

4 In the command prompt window, enter ipconfig /renew.

This step is intended to flush the DNS cache on your Windows 2000 Professional workstation.

5 In the command prompt window, enter PING zenwsimport. 

6 Inspect the ping results to ensure a successful ping test.

If your ping is not successful, troubleshoot DNS and DHCP to find the error. For more 
information, see “Troubleshooting Tips” on page 79.

By deploying the zenwsimport DNS record, you have enabled all workstations served by this DNS 
server to use ZENworks Automatic Workstation Import.
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Troubleshooting Tips
The most common mistake people make in setting up Automatic Workstation Import is that 
they forget to test-ping zenwsimport. If the node cannot resolve zenwsimport, the workstation 
manager cannot contact the AWI service.

If you are using DHCP, make sure the DHCP server provides the workstations with a DNS 
zone. If you are using static addressing, the zone must be configured at each machine. If the 
workstation does not have an assigned local zone, it cannot use your zenwsimport DNS 
record.

Make sure the service is running on the server by going to Control Panel > Administrative 
Tools > Services, and ensuring that the ZENworks Workstation Import service is started. (On 
NetWare®, use the java -show command.)

Enabling the server debug screens as shown in “Setting Up a ZfD 3.2 Lab Environment” on 
page 11 allows the monitoring of AWI activity.  On NetWare, this is enabled by adding some 
options to the SYS:System\ZENWSIMP.NCF file, specifically on the java load line.  There 
are four switches in all:

-Dlogfile=sys:zenworks\zenwsimp.log provides the path and file name that will be used 
for logging messages to a file.

-Dlogfilelevel=2 pertains to logging to a file on the server (the file specified in the first 
switch above).  It can range from 0 to 3, where 0 does not log anything and 3 is the most 
verbose of the message sets.

-Dloglevel=0 pertains to logging to the server console.  Like the first switch, it can also 
range from 0 to 3, where 0 does not log anything and 3 is the most verbose of the message 
sets.

-ns works in conjunction with the third switch above.  When -ns is not included, all 
messages go to the main console screen of NetWare, which is usually not a desirable 
place for debugging messages to go. When this switch is included, the debugging 
messages will go to their own screen. (Access the screen through Ctrl+Esc or Alt+Esc.)

By default, logging of messages goes to a server file named ZENWSIMP.LOG in the 
SYS:ZENWORKS directory. Logging to the console is disabled by default (logging is not 
done in either the main NetWare console or a separate screen).

The workstation also has an informational log at C:\WSREG32.LOG.
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6 Remote Management

This section of the ZENworks® 3.2 Lab Guide contains the following sections:

“Introduction” on page 81

“Creating the Workstation Remote Management Policy” on page 81

“Remotely Controlling a Workstation” on page 85

Introduction
This quick procedure takes you through setting up the remote management policy for the 
workstation; later we'll cover the related policy that affects users. After creating the policy, you 
will control a remote workstation from your server, and investigate the remote diagnostics tool.

Permanence of This Setup
This procedure will create a workstation policy in the DA_Tree eDirectory tree.

Dependencies
This procedure assumes that you have completed Chapter 5, “Automatic Workstation Import,” on 
page 71, because remotely managing a workstation requires a corresponding workstation object in 
eDirectoryTM.

Requirements
To perform the steps in this lab, you will need:

Hardware (Minimum):

A ZENworks workstation imported into eDirectory.

A Windows* machine from which to run ConsoleOne®. If you have a ZENworks for 
Desktops server set up according to Chapter 2, “Installing ZENworks for Desktops 3.2,” on 
page 49 your server will work excellently. 

Creating the Workstation Remote Management Policy
In order to enable remote control, you must have the ZENworks Remote Management agent 
installed at the workstation; the workstation must have been imported to eDirectory; and you must 
have a Remote Management Policy that permits remote control. Also, the user attempting to 
remotely manage the workstation must have rights to manage the workstation.

1 Open ConsoleOne and browse to select the .Policies.IST.Corp.DA container.
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2 Click the File menu > New > Policy Package. 

3 From the Policy Package Wizard window, select Workstation Package > click Next.

4 Use the default name Workstation Package > click Next.

5 At the summary screen, enable the Define Additional Properties check box > click Finish.

6 In the Properties of Workstation Package window, enable the check box for Remote Control 
Policy > click Properties.  

7 On the Remote Management tab, click the Control sub-tab.
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8 Enable the Enable Remote Control check box.

9 Disable the Prompt User for Permission to Remote Control check box.

10 Disable the Give User Visible Signal When Remote Controlled check box.

By eliminating the prompt for permission to remote control, and the visible signal when 
remote controlled, you effectively make this policy enable remote control in "stealth" mode. 

11 Enable the Allow Blanking User's Screen check box.

This will also enable the Allow Locking User's Keyboard and Mouse option.

12 Click the View sub-tab.
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13 Enable the Enable Remote View check box. 

14  Disable the Prompt User for Permission to Remote View check box.

15 Disable the Give User Visible Signal When Remote Viewed check box.

16 Click OK to save your policy settings.

17 In the Properties of Workstation Package window, click the Associations tab.

18 On the Associations tab, click the Add button.

19 Browse to select the .Workstations.IST.Corp.DigitalAirlines container > click OK.

20 Click OK to save your changes as the new Workstation Package policy package. 
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Remotely Controlling a Workstation
1 Locate a workstation that you have imported into the .Workstations.IST.Corp.DA container.

2 Right-click the workstation > click Actions > click Remote Control.

3 When the remote desktop screen displays, maximize the screen and interact with the desktop. 
Some ideas for working with Remote Control:

Open an application or file.

Close a running task.

Open the Start menu

Browse the file system.

Log the user off the remote workstation

Shut down the workstation

Try Remote Control before the user logs in.

4 Close the Remote Control window.

5 Right-click the same workstation > Actions > Remote View.

Notice that this allows you to see the remote machine's screen, but does not allow you to affect 
the machine's keyboard or mouse. Because ZENworks for Desktops integrates with 
eDirectory, permissions can be controlled to allow different users different levels of access to 
manage. For more information on Remote Management access control, refer to the ZENworks 

Lock Keyboard/Mouse
Blank Screen

Start Menu
Switch Active App

Reboot
System Key Pass Thru

Navigate
Help

Minimize
Maximize

Close (End Session)
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online documentation on the Novell® Documentation Web site (http://www.novell.com/
documentation).

6 Close the Remote View window.

7 Right-click the same workstation > Actions > Diagnostics.

The Diagnostics tool is a non-intrusive method for snooping out the basic system settings on 
a workstation in order to better diagnose workstation problems. All information viewed 
through the diagnostics tool is "live" data; that is, it comes directly from the workstation, not 
from an inventory database.
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7 Single-Site Inventory Collection 

This section of the ZENworks® 3.2 Lab Guide contains the following sections:

“Introduction” on page 87

“Creating the Workstation Inventory Policy” on page 90

“Collecting Inventory for a Workstation” on page 92

“Exploring a Workstation’s Inventory Information” on page 93

“Reporting and Exporting the Inventory Information” on page 94

“Troubleshooting” on page 98

Introduction
This section takes you through the setup procedure for implementing ZENworks for Desktops 
(ZfD) Inventory for a single site. When completed, the ZfD system will automatically collect 
hardware and software inventory for imported ZfD workstations.

A subsequent Lab Guide section called "Multi-Site Inventory Collection" will cover how to enable 
site-to-site inventory data transfer, also known as "inventory roll-up."

Permanence of This Setup
This procedure makes significant configuration changes to the ZENworks components on your 
server. All changes to eDirectoryTM are easily reversible. However, removing inventoried 
workstations from the Sybase* database may require a little more effort.

Dependencies
This procedure is intended to be performed on the base ZfD server for Digital Airlines, according 
to the procedures outlined in “Setting Up a ZfD 3.2 Lab Environment” on page 11.

You must also have completed the steps in Chapter 5, “Automatic Workstation Import,” on page 
71.

Requirements
To perform the steps in this lab, you will need:

The DA-02 Windows 2000 Server with ZfD

In particular, you must have installed ZfD with the Sybase database server option (not a 
default install setting), and have the ZENworks Inventory server configured as a standalone 
server
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At least one workstation imported to eDirectory

Connecting the Inventory Server to the Database
Every ZENworks inventory server must be connected to a storage database (either Sybase* or 
Oracle*) in order to store and retrieve inventory data. To make this happen, you must create a 
Service Location Policy Package before starting your inventory server.

1 Start at your DA-02 Windows 2000 Server > log in to eDirectory as Admin.

2  Start ConsoleOne®.

3 Browse to and select the .Policies.IST.Corp.DA container.

4 Right-click the Policies container > click New > click Policy Package.

5 In the Policy Package Wizard window, select Service Location Package > click Next.

6 Keep the name Service Location Package > click Next. 
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7 Enable the Define Additional Properties check box > click Finish.

8 In the Properties of Service Location Package window, enable the check box for ZENworks 
Database > click the Properties button. 

9 In the Properties of Service Location Package:ZENworks Database dialog box, click the 
directory browser button > browse to the .Servers.IST.Corp.DigitalAirlines container > select 
ZfD3InventoryDatabase > click OK > click OK. 

10 In the Properties of Service Location Package window, click the Associations tab > Add.

11 Browse and select the .Servers.IST.Corp.DigitalAirlines container > click OK to return to the 
Properties of Service Location Package window. 

12 In the Properties of Service Location Package window, click OK to save the changes to the 
policy package.

13 Restart the ZENworks Inventory service.
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13a On the DA-02 Windows 2000 Server, start the Services Control Panel applet > select the 
ZENworks Inventory Service > click Action  > Restart.

13b If you are using NetWare®: At the NetWare server command prompt, enter ZfDstop > 
wait for all services to stop > enter ZfDstart.

Creating the Workstation Inventory Policy
Now that the Inventory Server is ready to receive and store workstation inventory, you can quickly 
enable workstations to start scanning and sending their inventory data to the server by using a 
Workstation Policy Package.
NOTE: You may have already created a Workstation Policy Package and associated it to your workstation's 
container in Chapter 6, “Remote Management,” on page 81. If so, open the existing Workstation Policy 
Package's properties, and skip to Step 5.

1 Right-click the Policies.IST.Corp.DA container > click New > click Policy Package.

2 In the Policy Package Wizard window, select Workstation Package > click Next.

3 Keep the name Workstation Package > click Next.

4 Select Define Additional Properties > click Finish.

5 In the Properties of Workstation Package window, click the Policies tab > select Windows NT/
2000.

6 Enable the check box for Workstation Inventory > click the Properties button.

7 In the Properties of Workstation Package:Workstation Inventory dialog box, browse to select 
your ZENworks Inventory Service object. It should be located in the 
.Servers.IST.Corp.DigitalAirlines container.

8 Enable the Enable Software Scan check box > click OK.
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9 In the Properties of Workstation Package window, click the Associations tab > click the Add 
button.

10 Browse to select the .Workstations.IST.Corp.DigitalAirlines container > click OK. 
NOTE: If you created your Workstation Package in a previous section of the Lab Guide, you may have 
already made this association.

11 Click OK to save the changes to the Workstation Package policy.
Single-Site Inventory Collection 91



Novell Confidential 02_labg_zdfs_wkstn.fm last saved  5/16/ Manual Version: 3/17/03103
Collecting Inventory for a Workstation
To expedite the process of collecting inventory, we will now force a workstation to run collect its 
inventory and send it to the server. This process usually occurs automatically as a low-priority 
thread on all workstations according to the policy schedule.

1 Double-click the Novell Desktop Management icon from the Windows* desktop system tray. 
(That's the set of icons in the task bar near the clock. The icon looks like a calendar with a 
pencil and a half a clock. In the graphic below, the Novell Desktop Management icon is 
second from left.)  

2 In the Scheduler - Novell Desktop Management window, you should see your Inventory 
policy among any other policies you have enabled. If you do not see your policy, click the 
Refresh button and your policy should then appear. 

3 Select the Workstation Inventory:Workstation Policy action.

Observe the value in Next Run column. This indicates when the policy will activate and 
inventory will next occur. The schedule shown reflects a randomly selected time within the 
default package's schedule. 

Now observe the value in Last Run column. This indicates when the policy has most recently 
occurred. It will probably indicate Never Been Run Before.

4 Click Run Now to force the policy to occur now. The Currently Running status will change to 
Yes.

5 When it switches to No again, proceed to “Exploring a Workstation’s Inventory Information” 
on page 93. This may take several minutes, because inventory is scheduled as a low-priority 
CPU thread and we chose to inventory software as well as hardware.
NOTE: If you run the workstation import and inventory process on multiple workstations, you will gain 
more value from the next two sections.
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Exploring a Workstation’s Inventory Information
1 In ConsoleOne, locate and select the .Servers.IST.Corp.DA container > click the Tools menu 

> Configure DB.

2 If your ZENworks Database object does not automatically show up in the drop-down box, 
browse to select it > click OK > click OK.
NOTE: Because ZfD 3.2 supports multiple site servers within the enterprise, you must select the specific 
inventory server from which you wish to work.

3  Locate and select the .Workstations.IST.Corp.DA container.

4 Locate and select a workstation object in the Workstations container. Right-click the 
workstation > select Actions > click Inventory.

The resulting Workstation Inventory window shows the inventory for the specific workstation 
you selected to view.

5 Explore the Workstation Inventory interface. Specific sections to examine include Hardware 
and Software, but the other sections can also provide very useful information such as network 
connection information and DMA and IRQ usage information.

When you have finished exploring this interface, close the window and proceed to “Reporting and 
Exporting the Inventory Information” on page 94.
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Reporting and Exporting the Inventory Information
ZfD 3.2 ships with a set of pre-made reports for both Workstation Inventory and information on 
the ZENworks Application Launcher. Because there are many pre-made reports, this section will 
explore the interface, but it will not cover these reports extensively. After exploring the pre-made 
reports, this section explores how ZENworks inventory data can be exported to comma-separated 
value (CSV) format for use with any generic reporting tool, such as Crystal Reports.

1 In ConsoleOne, click Tools > ZENworks Reporting.

2 From the Reports window, select Workstation Inventory Lists > Workstation Software 
Listing. In the Software Name field, enter Microsoft Exchange%. Leave the Software Version 
and Database Site Name fields at the default of %, which is a wildcard character to ensure we 
do not further narrow the scope of the report. 

3 To finish, click Run Selected Report.
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4 After viewing the report, click File > Export Report.

5 In the Export Report window's File Name field, type c:\softwarereport > enable the 
HTML option > click OK.

6 Close the View Report:ListSoftware window.
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7 Use a Web browser to open the C:\SOFTWAREREPORT.HTML file that you exported. 

HTML is one of four formats to which you can export the pre-made Zenworks Inventory 
reports. 

Text

HTML

PDF, which uses the Adobe* Portable Document Format

SDF (Standard Data Format) uses delimited text file format, which is importable to 
various applications. (For example, by exporting to SDF, and then changing the file 
extension to CSV, you can open the report with Microsoft* Excel)

For many, the pre-made ZENworks Inventory reports may not cover exactly the data outputs 
needed. Custom reports can be made with various utilities, such as Crystal Decisions' Crystal 
Reports. To ease the pain of creating ODBC and SQL database queries, Novell® provides an 
export tool for use with ZfD inventory.

1 In ConsoleOne, click Tools > Data Export.

2 In the Inventory Database Export window, select Create a New Database Query > click Next.

3 In the Database Fields screen, browse to select Workstation > Hardware > Memory > Physical 
Memory > Physical Memory Size > click the single right-arrow button to move this item to 
the Selected Fields list > click Next.

4 Click Edit Query > change the equal button (  ) to not equal (  ) > OK.

This query ensures that all workstations will be exported, because ZENworks does not 
currently support the 68000 processor.
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To run the export, the Export Wizard requires a query filter of some sort. We will set up a 
query to include all workstations.

5 At the Defined Query window, review your query > click Next > click Next > click Finish.

6 In the Data Export to CSV window, type c:\MyExport.csv in the File Name field > click 
Export.

Make sure you remember to type C:\ in front of the default CSV name.

7 Start Notepad > open C:\MYEXPORT.CSV to see the results of the export. 

In its raw form, this export example could be used to determine which workstations have 
sufficient memory to run specific applications, or a new operating system. By slightly 
restructuring the query portion of this procedure, you could use this tool to show only 
workstations that need a memory upgrade, and so forth. 
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Examples
The following graphics are examples of the inventory information you can view.

Troubleshooting

Server Log Files and Screens
The ZENworks inventory server logs various processes to screen and file. The server logs errors 
to a text file in the following folder:

\da-01\sys\public\zenworks\wminv\logs\invserverlog.txt\zenworksinvservice

The log entries can also be accessed by opening the ZENworks Inventory Server object.
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The server screens are helpful for viewing information in real time.

On Windows servers, simply double-click the ZENworks Inventory Server icon in the 
Windows system tray. This screen info is also logged to 
\WINNT\TEMP\CONSOLELOG.TXT.

On NetWare, switch the server to ZENworks Inventory screen by pressing Alt-Esc a few 
times. The server screen is named the same as all the other Java* screens.

If you want to reliably switch to the inventory screen, try the java -show command at the server 
prompt. This will show you all the available Java processes and their corresponding process 
number. Note the number for the inventory process, and then use Alt-Esc to switch through the 
available screens. The inventory process number will show up in the upper right corner of the 
screen as you switch through them.
NOTE: If you add the -sn"ZENworks Inventory Server" parameter to the Java command line in the workstation 
inventory NCF file, the screen will use the name you provide (inside the quotes) instead of the generic Java 
screen name. (Note that there is no space between -sn and the opening quote.)

Workstation Log Files
The workstation maintains inventory log files in the ZENERRORS.TXT file, found in the 
Windows Temp folder (for example, C:\WINNT\TEMP). The inventory scanner uses this folder 
for other files as well, such as the inventory history file (HIST.INI) used for calculating inventory 
deltas before sending data to the server.

Locating the Database
ZENworks Inventory will not work until a Database Location Policy has been properly configured 
(see “Connecting the Inventory Server to the Database” on page 88.)

A properly functioning inventory server should display the message "Connecting to Database" 
after starting, and it should soon display the message "Connected to Database."
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8 A Tool for the Help Desk: The ZENworks 
Workstation Browser

This section of Unit 2, Managing the Complete Workstation Life Cycle in the ZENworks® 3.2 Lab 
Guide contains the following sections: 

“Introduction” on page 101

“Installing and Using the ZENworks Workstation Browser 3.0” on page 101

Introduction
The Novell® Cool Solutions Web site provides a diverse array of helpful tools, enhancements and 
tips. The ZENworks Workstation Browser has been a popular tool for providing support staff a 
quick access to ZENworks workstation management features without using ConsoleOne®. This 
procedure demonstrates how to install and use the ZENworks Workstation Browser.

Permanence of This Setup
This procedure adds a single a new executable utility to your ZENworks for Desktops Windows* 
2000 Server. This procedure makes no changes to the DA_TREE NDS eDirectory tree, or the 
workstations you access with the ZENworks Workstation Browser.

Dependencies
This procedure assumes that you have completed sections 5, 6, and 7, because you will be 
accessing imported ZENworks workstations, remotely controlling them, and accessing their 
inventory information.

Requirements
To perform the steps in this script, you will need the zenwsbrowser30zfd3setup.zip file from the 
Novell Cool Solutions Web site  (http://www.novell.com/coolsolutions/zenworks/
downloadables.html#browser).

Installing and Using the ZENworks Workstation Browser 3.0
1 On your ZENworks for Desktops Windows 2000 Server, extract the ZENworks Workstation 

Browser download, and start the extracted file ZENWSBrowser30ZfDsetup.exe.

2 In the license agreement window, click Yes > Next > Finish.
A Tool for the Help Desk: The ZENworks Workstation Browser 101

http://www.novell.com/coolsolutions/zenworks/downloadables.html#browser


Novell Confidential 02_labg_zdfs_wkstn.fm last saved  5/16/ Manual Version: 3/17/03103
3 In the ZEN for Desktops 3 Directory field, enter \\DA-01\Sys\ConsoleOne\1.2 > OK.

4 After the installation is complete, close the readme.txt Notepad window.

5 Close the Novell Consulting window (opened by the install process).

6 Click the Start menu > Programs > Novell Consulting > ZEN Workstation Browser 3.0.

7 Use the browser window to open the .Workstations.IST.Corp.IST container > Double-click 
the container to show your list of imported workstations.
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8 From the list of workstations, select a workstation object for which the physical workstation 
is powered on and connected to the network > click Remote Control.

9 After the Remote Control window opens, test it > close it.

10 At the top of the ZENworks Workstation Browser window, click the ZfD Inventory Server 
selection button. (The button looks like the front face of a satellite dish.)

11 In the ZENWSBrowser: ZfD3 Inventory Server Dialog window, select your inventory server 
from the list > click Save/Use.

12 From the list of workstations, select a workstation object for which the physical workstation 
is powered on and connected to the network > click Inventory.

13 Inspect the Inventory for the workstation > close the Inventory window.

Explore other features of the ZENworks Workstation Browser as you like.
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9 Applying Windows 2000 Group Policies to 
Workstations

[This section is under construction.]
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10 Automated Workstation Imaging

This section of the ZENworks® for Desktops (ZfD) 3.2 Lab Guide includes the following 
subsections:

“Updating to the Current Imaging Engine” on page 108

“Enabling a Workstation for ZENworks Imaging” on page 108

“Creating a Simple Workstation Image Object” on page 112

“Deploying a ZENworks Base Image to a Workstation” on page 113

“Creating ZENworks Add-On Images” on page 116

“Deploying a ZENworks Add-On Image to a Workstation” on page 123

“Setting Up Workstation Policies for Imaging” on page 126

Introduction
ZfD Imaging is an extremely flexible method for deploying workstation operating systems and 
modifying existing operating systems. The information in this section covers the enabling of a 
workstation for ZfD imaging, creating a workstation image, and then deploying that image. More 
advanced imaging topics are also included.

Permanence of This Setup
Throughout this procedure, you will create and modify several objects within the directory. You 
will also create and modify several very large file system objects. All changes you make can be 
deleted or reversed, with one exception: if you modify your DHCP server for ZENworks for 
Desktops Preboot Services, you make a permanent attribute change to the default options of the 
Microsoft* DHCP server.

Dependencies
This procedure requires you to have previously performed the tasks included in Chapter 4, 
“Manual Workstation Imaging,” on page 65. Additionally, the procedures in this part of the Lab 
Guide require that your imaging engine uses the code released on November 21, 2001. This release 
is described in “Updating to the Current Imaging Engine” on page 108.

Requirements
To perform the steps in this script, you will need the following equipment:

A ZENworks for Desktops 3.2 server, configured according to the information provided in  
Chapter 1, “Windows 2000 Server Setup,” on page 13 in Chapter 2, “Installing ZENworks for 
Desktops 3.2,” on page 49.
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At least one workstation configured according to information provided in Chapter 3, “Setting 
Up a Windows 2000 Professional Workstation for Desktop Management,” on page 57.

Updating to the Current Imaging Engine
On November 21, 2001, Novell's ZENworks Imaging development team published important new 
breakthroughs for ZENworks imaging. Among the work published, the developers included a 
significant code revision that is required to complete this lab.

If you have already updated the imaging engine in order to complete the procedure in Chapter 4, 
“Manual Workstation Imaging,” on page 65, you do not need to update the imaging engine as 
described in the steps below.

1 Download the ZENworks Imaging update file that accompanies the Cool Solutions article 
Windows XP Imaging and IDE Performance Enhancements (http://www.novell.com/
coolsolutions/zenworks/assets/zfd-3.20.1.zip).

2 Extract the update file and copy the extracted contents to your server's 
D:\NOVELL\PUBLIC\ZENWORKS\IMAGING folder, putting the files in the correct 
subfolders according to the Readme file.

Enabling a Workstation for ZENworks Imaging
There are two methods for automating ZENworks Imaging at the workstation.

Imaging Option A . This is the traditional, out-of-the-box ZENworks for Desktops method 
of installing a ZENworks Imaging Partition, sometimes referred to as "the Linux partition," to 
the workstation hard drive. For more information, see “Imaging Option A: Installing the 
ZENworks Imaging Partition” on page 108.

Imaging Option B. This method uses an add-on product, ZENworks for Desktops 3.2 
Preboot Services. For more information, see “Imaging Option B: Using ZENworks for 
Desktops 3.2 Preboot Services” on page 109.

If you have installed ZENworks for Desktops 3.2 Preboot Services, we recommend that you 
skip Option A and perform the steps in Option B instead.

Imaging Option A: Installing the ZENworks Imaging Partition
If you have a PXE-ready workstation, it is strongly advised that you skip this option and use 
“Imaging Option B: Using ZENworks for Desktops 3.2 Preboot Services” on page 109.
WARNING: This procedure will destroy all partition data on your workstation hard drive. Do not perform these 
steps on a production workstation, or on any workstation that may have the only copy of important data. Ensure 
that you have manually created an image of this workstation following the procedure described in  Chapter 4, 
“Manual Workstation Imaging,” on page 65.

Use the following steps to create a ZENworks Imaging partition:

1 Select a workstation for ZENworks Imaging. 

The closer this hardware is to matching the hardware from which you created your previous 
workstation image, the better success you will have with the restored image. Windows* 2000 
can usually automatically accommodate minor differences in hardware.
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2 If your ZENworks Imaging boot media was not created from the November 21, 2001 Cool 
Solutions imaging update, then re-create your ZENworks Imaging boot media. For more 
information, see “Creating ZENworks Imaging Media” on page 66.

3 Reboot your workstation with your ZENworks Imaging boot media.

4 Enter install at the boot prompt of the ZENworks Imaging version 3.2 text screen.

This command wipes the hard disk of all non-system partitions.

5 If you are using floppy diskettes as your media, follow the prompts for each floppy disk as 
needed.

6 When prompted to press any key to reboot, remove the ZENworks Imaging media and shut 
down your workstation.

Imaging Option B: Using ZENworks for Desktops 3.2 Preboot Services
If you have already completed Option A, you can skip Option B. Proceed to “Creating a Simple 
Workstation Image Object” on page 112.

Ensure that your server and workstations are on an isolated network segment before you use these 
steps for imaging a workstation.

1 Select a workstation with PXE capabilities.

The closer this hardware is to matching the hardware from which you created your previous 
workstation image, the better success you will have with the restored image. Windows 2000 
can usually automatically accommodate minor differences in hardware.

2 Boot the workstation and start its BIOS setup program.

The method for entering the BIOS setup program varies per equipment manufacturer and 
machine model.

3 In the workstation’s BIOS Setup program, set the workstation to use PXE > save your new 
BIOS settings > exit.

This will also vary from machine model to machine model. It may be phrased “Enable 
Network Boot” or may be in the workstation boot order, such as floppy, CD, Hard Disk, 
Ethernet.

4 Power off your workstation.

5 Switch to your ZENworks for Desktops Windows 2000 server.

6 Click the Start menu > Settings > Control Panel > Administrative Tools > DHCP.

7 Open the LabScope DHCP scope and select Configure Options.
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8 In the Scope Options list, try to find Option 060. If you can find the option, skip to “Creating 
a Simple Workstation Image Object” on page 112.

or

Because Option 060 is not standard on Windows 2000, you may need to add it from the 
command line. To do so, continue with Step 9.

9 Close the DHCP management console.

10 Open a Windows 2000 command line session (that is, start CMD.EXE).

11 At the Windows Command prompt, enter netsh.

The command prompt will be displayed as netsh>.

12 At the netsh prompt, enter dhcp server.

13 At the dhcp server prompt, enter add optiondef 60 ClassID STRING 0 
PXEClient.

14 At the dhcp server prompt, enter quit > exit.

15 From the DHCP management console, click to open the LabScope DHCP scope > right-click 
Scope Options > click Configure Options.
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16 Select DHCP option 060 ClassID > click OK.

Option 060 should now appear as a one of the Scope Options in your list.

17 Close the DHCP console.
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Creating a Simple Workstation Image Object
Use the following steps to create a simple Workstation Image object.

1 On your ZENworks for Desktops Windows 2000 Server, start ConsoleOne®.

2 In ConsoleOne, browse to the .Images.IST.Corp.DA container.

3 Right-click the .Images.IST.Corp.DA container > click New > Object > Workstation Image > 
OK.

4 In the New Workstation Image window’s Name field, enter Windows 2000 Pro > enable the 
Define Additional Properties check box > click OK.

5 In the Properties of Windows 2000 Pro window, click the browse button at the far right of the 
Base Image File field.
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6 In the Image File Location Window, browse to find your server (.DA-
02.Servers.IST.Corp.DA) in the Server field.

7 In the Path field, type D:\images\w2kpro.zmg.

NOTE: Make sure that this path is valid. Open the D:\IMAGES folder and verify the filename. This image 
file was created in Chapter 4, “Manual Workstation Imaging,” on page 65.

8 Click OK > OK.

Deploying a ZENworks Base Image to a Workstation
Use the following steps to deploy a ZENworks base image to a workstation.

1 On your ZENworks for Desktops Windows 2000 Server, in ConsoleOne, browse to the 
.Workstations.IST.Corp.DA container.

2 Double-click the workstation object that corresponds to the physical workstation for which 
you enabled automatic ZENworks Imaging in “Updating to the Current Imaging Engine” on 
page 108.

3 In the Properties window for the workstation object, click the ZENworks Imaging tab > click 
the Configuration page.

4 Select Put an Image on this Workstation on Next Boot  > select Use this Image Instead of the 
Effective Policy Image or Multicast Session check box > browse to and select the Workstation 
Image object called Windows 2000 Pro.Images.IST.Corp.DA > click OK.
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WARNING: The attributes you have just set on the workstation object will destroy all data on the 
workstation at its next reboot. The image that you selected will restore a working operating system on the 
workstation.

5 Reboot the target workstation and allow the workstation image to restore. After the 
workstation has been restored with a working operating system, proceed to Step 6.

6 On your ZENworks for Desktops Windows 2000 Server, in ConsoleOne, browse to the 
.Workstations.IST.Corp.DA container.

7 Double-click the workstation object that corresponds to the physical workstation that you just 
re-imaged > click the ZENworks Imaging tab > click the Configuration page.
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Note that the Put an Image on this Workstation on Next Boot check box was automatically 
disabled by the ZENworks Imaging process.

Troubleshooting
This troubleshooting section includes the following information:

“General Troubleshooting” on page 115

“PXE Troubleshooting” on page 115

“Imaging Partition Troubleshooting” on page 116

General Troubleshooting

Your workstation must have an identity in the ZENworks Image Safe Data (ZISD) store (boot 
sector 6 on your hard drive). Use the following steps to check the ZISD data:

1 Boot the workstation from your imaging media.

2 At the boot prompt, enter the following command:

manual

3 At the bash# prompt, enter the following command:

 img i z

4 Verify that the ZISD data is present and correct.

ZISD information is populated by the Novell® ClientTM ZENworks Imaging Service component. 
If you do not have the Imaging Service installed on your workstation, imaging by workstation 
name will fail.

If a blue screen appears on Windows 2000 or Windows NT after rebooting from an image, your 
image may have been created from workstation hardware that is significantly different from the 
workstation hardware to which you restored the image.

The Windows NT Hardware Abstraction Layer (HAL) makes the Windows NT* and Windows 
2000 operating systems not portable between unlike hardware systems. This is not just a problem 
with using imaging software—the same problem would result from moving a physical hard drive 
from one system to another.

PXE Troubleshooting

Try booting from your imaging media and using the Auto option at the boot menu. If imaging fails, 
then follow the steps in “Imaging Partition Troubleshooting” on page 116.

If imaging works, it is likely that your PXE implementation has a problem. Try the following 
strategies to investigate the problem:

From the Start menu, click Programs > PXE > Monitor PXE Services > Stop All Services > 
Start All Services.

Make sure that DHCP is running.

Make sure that Option 060 is properly added and is being served on your DHCP scope.

Make sure that your workstation is attempting to boot from network via PXE.
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Check the physical workstation ZISD identification. The following message may be displayed 
if your physical workstation’s ZISD identification does not match the workstation object you 
are assigning to re-image:

No extended information available

Imaging Partition Troubleshooting

Make sure your ZENworks Imaging media specifies the correct address for your server 
(10.0.0.202) in the SETTINGS.TXT file.

Creating ZENworks Add-On Images
Add-on images are a powerful but little-understood tool within the ZENworks Imaging arsenal. 
Add-on images do not re-create the partitions on your workstation, but they add data to existing 
partitions.

To further their potency, add-on images can also change registry settings on an existing 
workstation operating system.

Add-on images are a powerful pre-boot alternative to using traditional ZENworks Application 
Launcher (NAL) methods for making workstation changes.

In this section, you will create an add-on image file for adding ConsoleOne to a local workstation. 
Because there is a Windows Registry setting to indicate the local path to the ConsoleOne 
executable, you will also export and manually edit a registry file to accompany the ConsoleOne 
application data.

This section includes the following information:

“Preparing the Windows Registry” on page 116

“Building an Add-On Image for the C Drive” on page 118

“Creating an eDirectory Object for the C Drive Add-on Image” on page 121

“Building an Add-On Image for the D Drive” on page 122

Preparing the Windows Registry
The following steps will help you to get the Registry files in order.

1 Start REGEDIT.EXE.

2 Select the following Registry Key:  
HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSI
ON\APP PATHS\CONSOLEONE.EXE.
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3 Click the Registry menu > click Export Registry File.

4 Save the file to your Desktop as C1PATHD.REG.

5 Close the REGEDIT utility.
NOTE: You now have a registry file from a workstation that had ConsoleOne installed to the D drive. This 
means that the registry will specify that ConsoleOne is on drive D.

You will now edit the file to specify drive C instead, and save the file with a new name.

6 On your Windows desktop, right-click the C1PATHD.REG file > click Edit.

7 In the C1PATHD.REG - Notepad window, change all D:\ references to C:\. There should be 
two such references.
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8 Save the file to the Desktop as C1PATHC.REG > close the C1PATHC.REG file > close 
Notepad.

You now have two .REG files on the desktop. The C1PATHC.REG file references the C drive as 
the path to ConsoleOne. The C1PATHD.REG file references the D drive as the path to 
ConsoleOne. Keep both files on the desktop as you build the add-on images.

Building an Add-On Image for the C Drive
Use the following steps to build add-on images:

1 On the ZENworks for Desktops 3.2 Windows 2000 server, start ConsoleOne > click the Tools 
menu > ZENworks Utilities > Imaging > Image Explorer.

2 From the Image Explorer, click to open the Untitled object > click the Partition 1 object > click 
the Create Folder button.

3 In the Create Directory dialog box, type Novell > click OK.

4 Select the new Novell folder > click the Add Folder button.
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5 In the Browse for Folder dialog box, browse to and select D:\NOVELL\CONSOLEONE > 
click OK.

NOTE: You now have the ConsoleOne files in the add-on image. You will now add a registry file to make 
ConsoleOne work on drive C when pushed from this add-on image.

6 From the ZENworks Image Explorer Image menu, click Add Registry File.

7 Browse to the desktop > select the C1PATHC.REG files > click Add.

NOTE: Now that the image is ready to be pushed to a workstation’s C drive, you are ready to make one 
other change to the image for further flexibility. If you push this image to a workstation’s D drive (instead 
of C) the registry file would be incorrect. Therefore, this file should be excluded when pushing the add-on 
to the D drive.

ZENworks Imaging makes this an easy task by using “file sets.” File sets give you the ability to push an 
image file using a file set number, and exclude specific files based on that file set number. In the next step, 
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you will exclude the registry file from file set 2. Subsequently, if you were to push this add-on image to 
any partition other than the C drive, you would use file set 2, which excludes the registry file.

8 From the ZENworks Image Explorer, select the \PROGRAM 
FILES\ZENWORKS\IMAGING folder > right-click the C1PATHC.REG file > select File 
Sets > Exclude from Set 2.

NOTE: This exclusion could also be performed at the specific file level. However, in the case at hand, 
excluding the whole folder structure where the registry file has been placed makes more sense. You will 
leverage this exclusion from file set 2 in “Scripted Imaging” on page 130.

9 In the Image – ZENworks Image Explorer window, click the Save button > save the Image as 
D:\IMAGES\C1TEMP.ZMG.

NOTE: Add-on images are not compressed by default. Depending on your bandwidth and CPU speed, 
compression may give a significant performance boost. Low-powered CPUs may be slow with high 
compression and compression becomes much less important with greater bandwidth.

10 From the Tools menu, click QuickCompress > browse to specify C1TEMP.ZMG as your 
Image File to Compress > type ConsoleOne.zmg in the Save Compressed Image As field > 
enable the Optimize for Space option > click Compress.

11 In the Save Compressed Image As field, type consoleone.zmg.

12 Click Optimized for Space > click Compress.
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13 When the image finishes compressing, close the ZENworks Image Explorer.

14 Delete the C1TEMP.ZMG file. (Do not delete the CONSOLEONE.ZMG image file.)

Creating an eDirectory Object for the C Drive Add-on Image
Use the following steps to create a Novell eDirectoryTM object for the add-on image:

1 From ConsoleOne,  browse to the .Images.IST.Corp.DA container.

2 Right-click the .Images.IST.Corp.DA container > click New > Object > Workstation Image > 
OK.

3 In the New Workstation Image dialog box Name field, type ConsoleOne_C > select Define 
Additional Properties > click OK.

4 In the Properties of ConsoleOne_C dialog box, click the Add button.

5 In the Image File Location dialog box, browse to select the DA-02 server for the Server field.

6  In the Path field, type D:\images\ConsoleOne.zmg > click OK.
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NOTE: The image object specifies which file set to use with the add-on image. This feature allows you 
to represent a single image file as several different image objects using different file sets. In the case of 
the image you are using, the C1PATHC.REG registry file is flagged to be excluded from File Set 2. You 
will leave this image object set to use File Set 1, so the .REG file will be included.

7 Click OK to close the Properties of ConsoleOne_C image object.

Building an Add-On Image for the D Drive
So far, you have created an add-on image file for putting ConsoleOne on a workstation’s C drive 
and updated a relevant registry key. You also created an image object in the directory. As part of 
your tasks, you prepared the ConsoleOne image file for use on any partition by excluding the 
registry file changes from File Set 2.

However, if you were to put the ConsoleOne image into a partition other than the C drive, you 
would not get the appropriate registry changes integrated so that the target workstation recognizes 
where its local installation of ConsoleOne can be found.

The following steps are to create an add-on image file for handling the registry when you put the 
CONSOLEONE.ZMG image into a D drive.

Imaging registry changes are integrated by the ZENworks Imaging Service, a ZENworks agent 
installed with the Novell Client (Client32TM). The ZENworks Imaging Service only integrates 
registry changes found on the Windows system drive (usually C:\), so you need to create a separate 
add-on image from the main CONSOLEONE.ZMG file. You will then script the images as 
explained in “Scripted Imaging” on page 130.
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1 Start the ZENworks Image Explorer again. (ConsoleOne > Tools > ZENworks Utilities > 
Imaging > Image Explorer.) 

This will provide you with a new, empty image to work on.

2 In the Image – ZENworks Image Explorer window, click the Image menu > Add Registry File.

3 In the Add Files To Image window, browse to the desktop and select the C1PATHD.REG file 
> click OK.

4 Click the File menu > Save As > enter D:\IMAGES\C1PATHD.ZMG for the filename > click 
Save.

5 Close the ZENworks Image Explorer.
NOTE: Because you will use this image file with scripted imaging, you do not need to create a 
Workstation Image object to represent it in the directory.

6 Delete the two .REG files from the server desktop.

Deploying a ZENworks Add-On Image to a Workstation
Use the following steps to deploy the ZENworks add-on image (one you previously created) to a 
workstation:

1 On your ZENworks for Desktops Windows 2000 Server, in ConsoleOne, browse to the 
container .Workstations.IST.Corp.DA.

2 Double-click the workstation object that corresponds to the physical workstation for which 
you enabled automatic ZENworks Imaging in “Updating to the Current Imaging Engine” on 
page 108.

3 In the Properties window for the workstation object, click the ZENworks Imaging tab > click 
the Configuration page > select the Put an Image on this Workstation on Next Boot check box 
> select the Use this Image Instead of the Effective Policy Image or Multicast Session check 
box > browse to and select the .ConsoleOne_C.Images.IST.Corp.DA workstation image 
object > click OK.
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NOTE: The attributes you have just set on the workstation object not destroy the data on the workstation 
at its next reboot. Add-on images merely inject new data into an existing disk partition.

4 Reboot the target workstation and allow the workstation image to restore. After the image 
process completes, proceed to Step 5.

5 After the workstation reboots into Windows, log in as .Admin.DA and inspect the C: drive to 
confirm that C:\NOVELL contains the new ConsoleOne data.

6 Use REGEDIT.EXE to verify the entries in the HKLM > Software > Windows > 
CurrentVersion >AppPaths > ConsoleOne.exe key.

Combining a Workstation Base Image and an Add-On Image
Use the following steps to combine a workstation base image and an add-on image:

1 On your ZENworks for Desktops Windows 2000 Server, start ConsoleOne.

2 In ConsoleOne, browse to the .Images.IST.Corp.DA container.

3 Right-click the .Images.IST.Corp.DA container > click New > Object > Workstation Image > 
OK.
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4 In the Name field of the New Workstation Image dialog box, type W2KproConsoleOne > 
select the Define Additional Properties check box  > click OK.

5 In the Properties of W2KproConsoleOne window, click the browse button at the far right of 
the Base Image File field.

6 In the Server field of the Image File Location dialog box, browse to find your server (.DA-
02.Servers.IST.Corp.DA) > type D:\Images\w2kpro.zmg in the Path field > click OK.

7 In the Properties of W2KproConsoleOne page, click Add.

8 In the Server field of the Image File Location dialog box, browse to and select the DA-02 
server > in the Path field, type D:\images\ConsoleOne.zmg > click OK.

This image object now combines a base image and an add-on image for use in a single 
imaging session.

9 Click OK to close the Properties of W2KproConsoleOne window.
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Setting Up Workstation Policies for Imaging
Use the following steps to set up workstation policies for imaging:

1 In ConsoleOne, browse to the .Policies.IST.Corp.DA container.
NOTE: You may have already created a Workstation Policy Package and associated it to your 
workstation's container in Chapter 6, “Remote Management,” on page 81, or in Chapter 7, “Single-Site 
Inventory Collection,” on page 87. If so, open the existing Workstation Policy Package’s properties and 
skip to Step 5.

2 Right-click the Policies.IST.Corp.DA container and select New > Policy Package.

3 In the Policy Package Wizard, select Workstation Package > click Next.

4 Keep the name Workstation Package > click Next > enable the Display Details After Creation 
check box > click Finish.

5 In the Properties of Workstation Package page, select Workstation Imaging Policy > click 
Properties.
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6 In the Properties of Workstation Package:Workstation Imaging Policy page, click the Image 
Selection tab > Add.

7 In the Use This Image field of the New Image Selection Rule dialog box, select the Windows 
2000 Pro image object > in the When the Following Conditions are Met fields, select Hard 
Drive Size > less than (<) > 2048 > click OK.

This rule in the imaging policy will cause the Windows 2000 Pro image object to be restored 
on any system with less than a 2 GB hard drive. See “Image Selection Policy Tips” on page 
129 for information on how to effectively use the other hardware criteria options.

8  In the Properties of Workstation Package:Workstation Imaging Policy page, click the Image 
Selection tab > Add.

9 In the Use This Image field of the New Image Selection Rule dialog box, select the 
W2KproConsoleOne image object > in the When the Following Conditions are Met fields, 
select Hard Drive Size > greater than or equal to (>=) > 2048 > click OK.
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The rules you have created will now select a simple base image for workstations with smaller 
hard drives, and a base image plus an add-on image for workstations with larger hard drives.

10 Click OK to save the changes to the imaging policy.

11 In the Properties of Workstation Package page, click the Associations tab. Ensure that the 
.Workstations.IST.Corp.DA container is listed. If it is not, add it to the list > click OK to save 
the changes to the Workstation Package.
NOTE: Because the Image Selection policy is part of a workstation package, it will only affect 
workstations that have previously been imported. Automatic imaging for non-imported workstations is 
covered in “Scripted Imaging” on page 130.

12 Use ConsoleOne to browse to the container .Workstations.IST.Corp.DA.

13  Double-click the workstation object that corresponds to the physical workstation for which 
you enabled automatic ZENworks Imaging in “Updating to the Current Imaging Engine” on 
page 108.

14 In the Properties page of the workstation object, click the ZENworks Imaging—Configuration 
tab > enable the Put an Image on this Workstation on Next Boot check box > disable the Use 
this Image Instead of the Effective Policy Image or Multicast Session check box > click OK.
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NOTE: The attributes you have just set for the Workstation object will re-image the workstation according 
to the effective Workstation Policy Package for this workstation.

15 Reboot your target workstation and allow the imaging session to complete > log in and verify 
that the workstation contains the correct data set from the image object selected by policy.

Image Selection Policy Tips
Most environments will have many workstation types that require different base images. To 
effectively use Image Selection policies, you will need to use criteria other than hard drive size.

The ZENworks Imaging Engine is responsible for identifying system hardware during the image 
selection process, so for an image to be selected, such as on CPU and sound card types, you must 
specify these in your policy the same way that the Imaging Engine detects them.

Fortunately, there is an easy way to find out what the Imaging Engine detects on each platform. By 
booting from your ZENworks Imaging media and entering manual mode, you can enter the img 
i h command (I for information, H for hardware) to see the exact details of what the ZENworks 
Imaging Engine detects.

Another helpful command for the ZENworks Imaging Engine is the previously-mentioned img i 
z command (z for ZENworks Image Safe Data (ZISD), which is the workstation ID stamped to 
the hard disk). This information can help you to troubleshoot a workstation that is not picking up 
the correct policy.

The ZISD information can be cleared with the ZISCLEAR.EXE DOS utility, or through a 
Windows registry key (HKLM > SOFTWARE > Novell > ZENworks > ZISWIN Clear=1). More 
information on this process is available in Troubleshooting Workstation Imaging in the 
Workstation Imaging section of the Troubleshooting guide.
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Scripted Imaging
Use the following steps to automatically perform workstation imaging.

1 From ConsoleOne on your ZENworks for Desktops Windows 2000 Server, browse to the 
.Images.IST.Corp.DA container.

2 Right-click the .Images.IST.Corp.DA container > New > Object >Workstation Image > OK.

3 In the Name field of the New Workstation Image dialog box, type Scripted Windows 
2000 Pro > select Define Additional Properties > click OK.

4 In the Properties of Scripted Windows 2000 Pro dialog box, select Use Scripted Imaging > 
enter the following lines of text into the image script field.

The following lines delete all partitions:

img pd1

img pd2

img pd3

img pd4

The following lines create a 2 gigabyte DOS partition (C:) and set it active:

img pc1 FAT16 2040

img pa1

The following line creates a second partition (D:) to fill the drive and formats it to use the 
FAT32 file system:

img pc2 FAT32

The following line inserts the Windows 200 Pro base image data as an add-on into the C: 
partition:

img rp 10.0.0.202 //da-02/d:/images/W2Kpro.zmg a1:p1
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The following line inserts the ConsoleOne image data into D: using file set 2, which excludes 
the ConsoleOne registry settings for use with the C: drive:

img rp 10.0.0.202 //da-02/d:/images/ConsoleOne.zmg a1:p2 s2

The following line inserts the C1pathD image file to C:, where the ZENworks Imaging 
Service client component can integrate the ConsoleOne registry settings to recognize 
ConsoleOne on drive D:

img rp 10.0.0.202 //da-02/d:/images/C1pathD.zmg a1:p1

5 Verify the script you have entered for accuracy > click OK.

Troubleshooting
Imaging scripts are intended to execute with a minimum of feedback at the target workstation. This 
makes it challenging to root out errors in your scripts. When creating imaging scripts, it can be 
extremely helpful to insert pauses between tasks by adding these lines:

echo Press Enter

read ans

Longer scripts may have issues executing because of a bug in the original proxy server code that 
fails to send the long script to the target workstation. The result is that the Imaging Engine 
prematurely finishes, without executing any commands and displaying a cheery “Operation 
Successful” message. (That message is a lie. Don’t believe it.) At the time of this publication, 
Novell is releasing a fix in file ZD32NWB.EXE on the Novell Support Web site  (http://
support.novell.com/cgi-bin/search/searchtid.cgi?/2961527.htm).

NTFS partitions are a different challenge. Microsoft has three versions, all supported by 
ZENworks. Because Microsoft frequently changes the NTFS version and sub-version code, 
Novell only pre-formats NTFS partitions. To make an NTFS partition that you create with the IMG 
command work properly, you would need to image a valid NTFS partition and insert it as an add-
on image to a partition created by the ZENworks Imaging engine.
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Example Script

The first line of the script pre-formats a 4 GB NTFS partition:

IMG PC2 NTFS 4096

The second line of the script injects NTFS information into NTFS partition:

IMG RP 10.0.0.202 //DA-02/D:/Images/NTFSimage.zmg a1:p2

Until the NTFS formatting information is put into a pre-formatted NTFS partition, the NTFS 
partition will not accept any other file system data.

For more information on using commands in image scripts, refer to the ZENworks for Desktops 
3.2 online documentation (http://www.novell.com/documentation/lg/zdfs/index.html).

Using the Server Policy for Imaging
The ZENworks Server Policy Package has several settings for helping to customize your 
ZENworks Imaging environment. The server’s Imaging policy can assign static IP addresses to re-
imaged workstations, and assign Windows networking parameters such as Workgroup name or the 
prefix for the unique workstation name.

Although most elements of the Imaging policy are helpful and benign, be careful of the Image 
Selection Criteria. This looks the same as the Image Selection Criteria we used within the 
Workstation Policy Package, but it has one key difference: when enabled, the server-based Image 
Selection policy enforces its rules on every unregistered workstation that connects to the server. In 
this case, “unregistered workstations” includes workstations that have been imported into the 
directory but do not have the ZENworks Imaging Service client agent installed.

This can be devastating if you have PXE enabled on unregistered workstations and a server policy 
that forces a re-image on loosely-defined criteria. Therefore, as a rule, never enable the server 
Image Selection Criteria on a production network segment unless you fully understand exactly 
what you are doing.

The server-based Image Selection Criteria is the perfect tool for your workstation build lab, which 
of course should be on its own isolated segment. Using the Server policy, you could hook up a 
number of workstations, and set a server policy to invoke a multicast session, a complex scripted 
image, or various combined image types.

Use the following steps to set up the server policy for imaging:

1 In n ConsoleOne, browse to the .Policies.IST.Corp.DA container.

2  Right-click the Server Package object > click Properties. (This object was created in Chapter 
5, “Automatic Workstation Import,” on page 71.

3 In the Properties of Server Package window, enable the Workstation Imaging Policy check 
box > click Properties.

4 In the Properties of Server Package:Imaging Server Policy window, double-click the Image-
safe Data tab > select Windows Networking.
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5 On the Image-safe Data – Windows Networking tab, type DA- for the Computer Name Prefix 
> select the Make the Computer a Member of the Following Workgroup check box > enter 
WORKGROUP for the workgroup name.

The settings you have made will now only affect workstations that don’t already have their 
ZISD information. Workstations with ZISD information will keep their workstation 
NETBIOS name and workstation object ID.

6 Click the Image Selection tab > click Add.

7  In the New Image Selection Rule window, browse to select the Scripted Windows 2000 Pro 
image from the Images.IST.Corp.DA container > set the When the Following Conditions are 
Met parameters to Hard Drive Size > 0 > click OK.
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WARNING: These rules will cause all ZENworks Imaging-enabled workstations served by your Lab 
Scope segment to re-image at their next reboot. Proceed with extreme caution!

8 Click OK > OK to save all the changes to your Server Package.

9 Reboot the ZENworks Imaging-enabled workstation that you want to re-image.  Allow the 
workstation to complete its re-imaging process.
NOTE: Because we have set up an Image Selection Rule in the Server Package, we do not need to set 
the workstation object to re-image. This will happen automatically for workstations, imported or not.

10 After the workstation re-images, log as Admin.DA and inspect the system.

Make sure that the NTFS partition was created, and that it contains the ConsoleOne data.

Open REGEDIT.EXE and check to see that the ConsoleOne.exe registry key 
(HKLM\Software\Windows\CurrentVersion\AppPaths\ConsoleOne.exe) is set to your 
D: drive.

11 Start ConsoleOne from your workstation.

12 Remove the image selection criteria from the Server Package’s Workstation Imaging policy.

NOTE: By removing all image selection criteria from the server policy, you eliminate additional boot time 
for PXE-enabled workstations. When criteria exist in the server policy, PXE must boot the imaging engine 
in order to read the rules, even if the rules effectively exclude the specific workstation that is booting. This 
only applies to the server policy, and indicates yet another reason why the Imaging Server Policy’s Image 
Selection Rules should be used only on isolated, special-use segments.

Troubleshooting
If your workstation does not re-image from the server policy and you want it to, it may be because 
the workstation has been registered by the ZENworks Imaging Service, and therefore is protected 
as a managed workstation. That means you’ll need to clear the ZENworks Image Safe Data on the 
hard disk. A fast way to do this is to create a DOS bootable floppy, put ZISCLEAR.EXE on it, and 
run ZISCLEAR.EXE from a DOS boot. ZISCLEAR can be obtained from the Novell Support Web 
site (http://support.novell.com/cgi-bin/search/searchtid.cgi?/2957610.htm).
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