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64Setting Up GroupWise Modes and 
Accounts

This section will familiarize you with GroupWise® modes and accounts, and help you set up users to 
use them.

Section 64.1, “GroupWise Modes,” on page 1055
Section 64.2, “Accounts,” on page 1062

64.1  GroupWise Modes
GroupWise provides three different ways to run the GroupWise client: Online mode, Caching mode, 
and Remote mode. 

Section 64.1.1, “Online Mode,” on page 1055
Section 64.1.2, “Caching Mode,” on page 1055
Section 64.1.3, “Remote Mode,” on page 1057

NOTE: Remote mode is not available in the GroupWise Cross-Platform client.

Most GroupWise features are available in all three GroupWise modes, with a few exceptions. 
Subscribing to other users’ notifications is not available in Caching mode. Subscribing to other 
users’ notifications and Proxy are not available in Remote mode.

64.1.1  Online Mode
When users use Online mode, they are connected to their post office on the network. The user’s 
mailbox displays the messages and information stored in the network mailbox (also called the 
Online Mailbox). Online mode is connected to the network mailbox continuously. In Online mode, 
if the Post Office Agent shuts down or users lose network connection, they temporarily lose the 
connection to their mailboxes.

Users should use this mode if they do not have a lot of network traffic, or if they use several different 
workstations and do not want to download a local mailbox to each one. 

64.1.2  Caching Mode
Caching mode stores a copy of a user’s network mailbox, including messages and other information, 
on the user’s local drive. This allows GroupWise to be used whether or not the network or Post 
Office Agent is available. Because the user is not connected to the network all the time, this mode 
cuts down on network traffic and has the best performance. A connection is made automatically to 
retrieve and send new messages. All updates are performed in the background so GroupWise work 
is not interrupted.

Users should use this mode if they have enough disk space on the local drive to store mailbox. 

Several users can set up their Caching Mailboxes on a single shared computer.
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If users run Caching Mode and Remote Mode on the same computer, the same local mailbox (also 
called the Caching Mailbox or Remote Mailbox) can be used to minimize disk space usage. 

If disk space is limited, users can restrict the items that are downloaded to the local mailbox. They 
can specify to get the subject line only or specify a size limit.

If users back up their Caching Mailboxes, they can protect items that might be deleted if the system 
is set up to automatically clean up items (or if the system administrator runs an Expire and Reduce).

To use Caching mode, the client installation must be a standard installation, not a workstation 
installation.

Allowing or Forcing Use of Caching Mode

The system administrator can allow or disallow the use of Caching mode, and can also force users to 
log in to GroupWise in Caching mode. 

If the system administrator forces Caching mode on Cross-Platform client users and then restricts 
Online mailbox size so that users have items in their Caching mailboxes that are no longer available 
online, the administrator needs to make sure users understand about doing backups. See “Backing 
Up Your Mailbox” in “Managing Your Mailbox” in the GroupWise 7 Cross-Platform Client User 
Guide.

1 In ConsoleOne®, click Tools > GroupWise Utilities > Client Options.
2 Click Environment > Client Access.
3 Select or deselect Allow Use of Caching Mode.
4 Select or deselect Force Use of Caching Mode.

Specify the number of days before Caching mode will be enforced. This allows the user to 
continue using Online mode until the grace period has passed. The grace period begins the first 
time the user connects to the POA. The setting applies per user per workstation.
The Force Caching Mode setting is not enforced on a workstation that does not have enough 
disk space for a Caching mailbox. The amount of disk space that is required is: the size of the 
mailbox + 20 MB + 25% of the mailbox size.
The Force Caching Mode setting is also not enforced when a user connects from a shared 
Windows workstation or terminal server if you configure these workstations to be excluded. 
You do this by setting a registry key on the Windows workstation. The registry key is in 
HKEY_LOCAL_MACHINE. Under Software\\Novell\\GroupWise\\Client, add 
a dword value named No Local Store with a value of 1. This prevents the user from creating a 
Caching or Remote mailbox by using the GroupWise Windows client menus. However, the 
user can still create a Caching or Remote mailbox by using the startup switches /pc, /pr, or /ps.

Downloading the System Address Book

When users prime their Caching mailboxes, they receive a copy of the system address book. After 
the initial priming of the Caching mailbox, users can re-download the system address book and their 
personal address books in Caching mode by clicking View > Retrieve System Address Book or View 
> Retrieve Personal Address Book while in the Address Book. Address books also be re-
downloaded in Caching mode when users click Tools > Retrieve Entire Mailbox.
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Users can also specify to download the system address book (and any rules they have created) on a 
regular basis. 

1 In Remote or Caching mode, click Accounts > Account Options.
2 Right-click the GroupWise account, then click Properties > Advanced.
3 Select Refresh Address Books and Rules Every __ Days. By default this is set to 7 days, but it 

can be changed.

If you configure the POA to generate the system address book regularly, Caching mode users always 
have a current copy to download. 

1 In ConsoleOne, right-click the POA object, then click Properties > GroupWise > Maintenance.

On the Maintenance page, make sure that Generate Address Book for Remote is selected. You can 
choose the time when you want the generation to take place.

If you want to generate the system address book for download more than once a day, you can delete 
the existing wprof50.db file from the \wpcsout\ofs subdirectory of each post office. A new 
downloadable system address book is generated automatically for users on each post office.

64.1.3  Remote Mode
Remote mode is familiar to GroupWise users who use Hit the Road. Similar to Caching mode, a 
copy of the Online mailbox, or the portion of the mailbox that users specify, is stored on the local 
drive. Users can periodically retrieve and send messages with the type of connection they specify 
(modem, network, or TCP/IP). Users can restrict what is retrieved, such as only new messages or 
only message subject lines. 

NOTE: Remote mode is not available in the GroupWise Cross-Platform client.

To use Remote mode, the Windows client installation must be a standard (full) installation, not a 
workstation installation.

As an administrator, you can allow or disallow the use of Remote mode for client users.

1 In ConsoleOne, click Tools > GroupWise Utilities > Client Options.
2 Click Environment > Client Access.
3 Select or deselect Allow Use of Remote Mode.

The following topics explain the capabilities users have when they are allowed to use Remote mode.

“Remote Password” on page 1058
“Async Gateway and X.25 Gateway” on page 1058
“Remote Performance” on page 1058
“Hit the Road” on page 1058
“Remote Properties” on page 1059
“Remote Mode Connections” on page 1059
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Remote Password

To use Remote mode, users must have a password set in Online mode. When they run in Remote 
mode for the first time, they can specify to use the same password in Remote mode or choose a new 
one.

Async Gateway and X.25 Gateway

For GroupWise to use a modem connection, the GroupWise Async Gateway or X.25 Gateway must 
be installed and configured in your GroupWise system. The gateway provides the means by which 
the client communicates with the GroupWise system.

Remote Performance

The system administrator can configure the MTA so that it re-directs Remote mode requests to other 
MTAs and POAs. The GroupWise client can establish a client/server connection to an MTA across 
the Internet. For more information, see Section 41.2.2, “Enabling Live Remote,” on page 637.

Hit the Road

Users can use Hit the Road on the Tools menu (or switch from Online mode to Remote mode) to 
create, set up, or update the Remote mailbox. A copy of the mailbox is created on the user’s local 
drive and any current connections are detected and set up. If users have already used Caching mode, 
the local mailbox has already been created. Users can also use Hit the Road to create setup files on a 
diskette to set up their Remote mailbox on a computer that’s not connected to the network. Several 
users can set up their Remote mailboxes on a single shared computer.

Hit the Road creates a network connection for the method (direct connection or TCP/IP) GroupWise 
uses to access the user’s post office. GroupWise can then use this connection, when running in 
Remote mode, to connect to the GroupWise system. For example, a network connection lets users of 
docked laptops run GroupWise in Remote mode and connect to the GroupWise system through the 
network connection rather than a modem connection.

Hit the Road also creates modem connections for Remote Profiles in the Async Gateway or X.25 
Gateway. Remote Profiles let GroupWise connect to the GroupWise system.

To use Hit the Road:

1 In the GroupWise client, click Tools > Hit the Road.
2 Follow the prompts to create the Remote mailbox on the computer or on a diskette.

Installing the Remote Mailbox from Diskette

If Hit the Road created the user’s Remote mailbox on diskette, the user needs to install the Remote 
mailbox on the computer that will be running in Remote mode. 

1 Insert the diskette containing the Remote mailbox into the computer’s disk drive. 
2 From the Windows Taskbar, click Start > Run.
3 Type a:\setup, then click OK.

Follow the prompts. The setup program creates a Remote mailbox and copies the required files 
to the computer’s hard drive.
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Remote Properties

Users can change the way Remote mode is set up, including the connection, time zone, signature, 
and so forth, in Account Options on the Accounts menu. Remote is listed as an account.

By default, if an item is deleted from the Remote mailbox, the item is deleted from the Online 
mailbox the next time a connection is made. Deletion options in Remote Properties can be changed 
so that an item deleted from the Remote mailbox stays in the Online mailbox or vice versa.

Remote Mode Connections

“Setting Up a Modem Connection” on page 1059
“Setting Up a Network Connection” on page 1060
“Setting Up a TCP/IP Connection” on page 1061

Setting Up a Modem Connection

If you are going to connect with a modem, you must create at least one modem connection. A 
modem connection provides GroupWise with the information it needs to connect to the GroupWise 
system through the GroupWise Async Gateway or GroupWise X.25 Gateway.

To set up a modem connection:

1 In the client, log in or change to Remote mode.
2 Click Accounts > Send/Retrieve > GroupWise Options. 
3 Click Configure > Connect To > New.
4 Make sure Modem is selected, then click OK.
5 Type a descriptive name for the modem connection in the Connection Name box.
6 Click the country code, then type the area code and phone number for the gateway to the master 

GroupWise system.
You can use a comma (,) to signal a one-second pause in dialing such as 9, (800) 555-5555. The 
9 accesses an outside line and the comma causes a one-second pause to wait for the dial tone 
before dialing the number. If you enter dashes, spaces, and parentheses, they are ignored. 

7 Type the login ID for the gateway.
8 Click Password, type the gateway password, then click OK.
9 Retype the password, then click OK. 

10 Click the Advanced tab.
11 If your modem requires a script, specify the path to the script in the Modem Script box, click 

Edit Script, then specify the necessary When Given and Respond With commands.
To save the script without changing its filename, click Save > Close.
or
To save the script with a new filename, click Save As, type a name, then click Close.

12 Click a disconnect method.
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13 Click Attempts, then specify the number of times to redial if the line is busy.
14 Click Retry Interval, then specify the time interval between each redial attempt.
15 Click OK.
16 Select the connection you want, then click Select.
17 Select the location you are connecting from in the Connecting From box. If none are listed, use 

the Default Location option.
If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

18 Select the modem to use for dialing up the gateway in the Connect Using box. If you have not 
yet defined your modem, click Modem to add a modem to your system.

19 Click OK, then click Close.

Setting Up a Network Connection

While running in Remote mode, GroupWise can connect to the user’s Online mailbox using a 
network connection. A network connection is useful for laptop users connecting to the network 
through a docking station, or for remote users connecting through a modem using remote node 
software.

To create a network connection:

1 In the client, log in or change to Remote mode.
2 Click Accounts > Send/Retrieve > GroupWise Options.
3 Click Network > OK.
4 Type a descriptive name for the network connection in the Connection Name box.
5 Type the path to any post office directory in the master GroupWise system.

Users can connect to their own post offices or to any post office in the master GroupWise 
system to access their Online mailboxes.

6 Click a disconnect method.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all responses to 
the requests are received (or disconnects automatically when 
the time allowed by the gateway has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and pending 
responses are received. Pending responses are responses to 
other requests that are waiting to be downloaded to you.

Manually Lets you manually control when to disconnect (or disconnects 
automatically when the time allowed by the gateway has 
expired).
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7 Click OK.
8 Select the connection you want, then click Select.
9 Select the location you are connecting from in the Connecting From box. If none are listed, use 

the Default Location option.
If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

10 Click OK, then click Close.

Setting Up a TCP/IP Connection

A TCP/IP connection enables GroupWise, while running in Remote mode, to connect to the 
GroupWise system through a network connection using TCP/IP rather than a modem connection. A 
TCP/IP connection can be made through a network connection, such as a laptop connecting to the 
network through its docking station, or through a modem using remote node software.

To create a TCP/IP connection:

1 In the client, log in or change to Remote mode.
2 Click Accounts > Account Options, then double-click the Remote account.
3 Click Connection > Connect To > New > TCP/IP > OK.
4 Type a descriptive name for the TCP/IP connection.
5 Type the IP address or the DNS name.
6 Type the IP port for this address.
7 Click a disconnect method.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all responses to 
the requests are received (or disconnects automatically when 
the time allowed by the gateway has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and pending 
responses are received. Pending responses are responses to 
other requests that are waiting to be downloaded to you.

Manually Lets you manually control when to disconnect (or disconnects 
automatically when the time allowed by the gateway has 
expired).

Method Description

When All Updates Are Received Disconnects after requests are sent and after all responses 
to the requests are received (or disconnects automatically 
when the time allowed by the gateway has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses are 
responses to other requests that are waiting to be 
downloaded to you.
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8 Click OK.

9 Select the connection you want, then click Select.
10 Select the location you are connecting from in the Connecting From box. If none are listed, use 

the Default Location option.
If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

11 Click OK, then click Close.

64.2  Accounts
Section 64.2.1, “Accounts Menu,” on page 1062
Section 64.2.2, “Enabling POP3, IMAP4, and NNTP Account Access in Online Mode,” on 
page 1062

64.2.1  Accounts Menu
In addition to the Remote account, users can access and configure POP3 and IMAP4 Internet e-mail 
accounts and NNTP News accounts from the Accounts menu. While the user is in Remote and 
Caching mode, POP3, IMAP4, and NNTP accounts are accessed without needing to connect to the 
GroupWise system. If the system administrator enables it, users can also access and configure their 
POP3, IMAP4, and NNTP accounts from the Accounts menu while in Online mode.

NOTE: The Accounts menu is not available in the GroupWise Cross-Platform client.

64.2.2  Enabling POP3, IMAP4, and NNTP Account Access in 
Online Mode
By default, POP3, IMAP4, and NNTP accounts can be added, configured, and accessed by users in 
Remote and Caching mode only. Account items and information are not accessible in Online mode, 
nor can items and information be uploaded to the Online mailbox until the system administrator 
enables it.

To enable POP3, IMAP4, and NNTP account access for clients in Online mode for an entire post 
office:

1 Make sure GroupWise 6.x agents have been installed. For more information, see Part X, 
“Message Transfer Agent,” on page 611.

2 Make sure Internet Addressing is enabled. For more information, see Section 4.11, “Internet 
Addressing,” on page 70.

3 In ConsoleOne, select the post office object.
4 Click Tools > GroupWise Utilities > Client Options.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by the 
gateway has expired).

Method Description
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5 Click Environment > General.
6 Select Allow Use of POP and IMAP Accounts in the Online Mailbox.
7 Select Allow Use of News (NNTP) Accounts in the Online Mailbox.
8 Click OK.
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65Setting Defaults for the 
GroupWise Client Options

The GroupWise® client includes options (preferences) that can be set by individual users. As a 
GroupWise administrator, you can determine the default settings for the options. If you don’t want 
users to change the default settings you’ve established, you can lock the settings. 

Section 65.1, “Client Options Summary,” on page 1065
Section 65.2, “Setting Client Options,” on page 1069
Section 65.3, “Resetting Client Options to Default Settings,” on page 1100

65.1  Client Options Summary
Default settings can be established at the user level, the post office level, or the domain level. User 
settings override post office settings, and post office settings override domain settings. However, 
locked settings override unlocked settings even if they are set at a higher level.

1 In ConsoleOne®, select a Domain, Post Office, or User object, then click Tools > GroupWise 
Utilities > Client Options.

The client options table in this section summarizes all client options and provides links to 
descriptions of the options. For more detailed instructions, see Section 65.2, “Setting Client 
Options,” on page 1069.

Environment
Send
Security
Date and Time

NOTE: The Cross-Platform client does not recognize all of the client options that can be set in 
ConsoleOne. Client options that the Cross-Platform client does recognize are marked with an 
asterisk (*) in the table.
Setting Defaults for the GroupWise Client Options 1065
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Table 65-1   Client Options

Client Options Type Client Options Tab Client Options

Environment 

Click Tools >
GroupWise Utilities >
Client Options >
Environment

General Refresh Interval
Allow Shared Folder Creation
Allow Shared Address Book Creation
Check Spelling Before Send
Show Messenger Presence
Allow Use of POP and IMAP Accounts in the Online Mailbox
Allow Use of News (NNTP) Accounts in the Online Mailbox

Client Access Client Licensing
Full License Mailboxes
Limited License Mailboxes

Client Login Mode
Allow Use of Remote Mode
Allow Use of Caching Mode

Force Caching Mode after __ Days
Show Login Mode Drop-Down List on Client Toolbar

Views View Options
Read Next After Accept, Decline, or Delete

 Open New View after Send
Allowable Read Views

Plain Text
HTML

Allowable Compose Views
Plain Text
HTML

Disable HTML View

File Location Archive Directory
Custom Views

Cleanup Mail and Phone
Manual Delete and Archive
Auto-Delete After
Auto-Archive After

Appointment, Task, and Note
Manual Delete and Archive
Auto-Delete After
Auto-Archive After

Empty Trash
Manual
Automatic After

Purges
Allow Purge of Items Not Backed Up

Prompt before Purging
Perform Maintenance Purges on Caching/Remote
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Appearance Schemes
GroupWise 6.5 Look
GroupWise 7 Look

Individual Settings
Display Main Menu
Display Nav Bar
Display Main Toolbar
Use GroupWise Color Schemes
Sky Blue, Olive Green, Silver, Sky Blue, Spring Green, 

Sterling Silver
Display Folder List
Simple Folder List
Full Folder List
Long Folder List
Display QuickViewer
QuickViewer at Bottom
QuickViewer at Right

Retention Retention

Junk Mail Junk Mail Handling
Enable Junk Mail Using Junk Mail Lists
Enable Junk Mail Using Personal Address Book
Auto-Delete After
Enable Blocked Mail Using Block Mail Lists

Send 

Click Tools >
GroupWise Utilities >
Client Options >
Send

Send Options Classification*
Normal, Proprietary, Confidential, Secret, Top Secret, For 

Your Eyes Only
Priority*

High, Standard, Low
Reply Requested*

When Convenient, Within __ Days
Allow Use of Reply to All in Rules
Allow Use of Internet Mail Tracking
Expiration Date
Delay Delivery
Wildcard Addressing
Notify Recipients
Convert Attachments
Allow Reply Rules to Loop
Global Signatures

Mail Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information, 
Auto-Delete Sent Item

Return Notification
When Opened/Deleted

None, Mail Receipt, Notify, Notify and Mail

Client Options Type Client Options Tab Client Options
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Appointment Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification
When Opened/Accepted/Deleted

None, Mail Receipt, Notify, Notify and Mail

Task Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification*
When Opened/Accepted/Completed/Deleted

None, Mail Receipt, Notify, Notify and Mail

Note Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification
When Opened/Deleted

None, Mail Receipt, Notify, Notify and Mail

Security Conceal Subject
Require Password to Complete Routed Item
Secure Items Options

Do Not Allow Use of S/MIME*
URL for Certificate Download
Sign Digitally*
Encrypt for Recipients

Encryption Key Size

Disk Space 
Management 

User Limits
Mailbox Size Limit
Threshold for Warning Users
Maximum Send Message Size
Limits Apply to Cache
Notify the Administrator When Threshold Limit Is 

Exceeded
Notify the Administrator When Size Limit Is Exceeded

Global Signature Global Signature

Security 

Click Tools >
GroupWise Utilities >
Client Options >
Security

Password Enter New Password*
Clear User Password*
Allow Password Caching
Allow eDirectory Authentication Instead of Password
Enable Single Sign-On
Use Collaboration Single Sign-On (CASA)

Client Options Type Client Options Tab Client Options
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65.2  Setting Client Options
Default settings can be established at the user level, the post office level, or the domain level. User 
settings override post office settings, and post office settings override domain settings. However, if 
you set a lock on an option at a higher level, the higher level then overrides the lower level setting.

To modify the default settings for the GroupWise client: 

1 In ConsoleOne, click a Domain object if you want to modify the settings for all users in the 
domain.

or

Click a Post Office object if you want to modify the settings for all users in the post office.

or

Click a User object or GroupWise External Entity object if you want to modify settings for the 
individual user. To change the same settings for multiple users, select multiple objects.

2 With the appropriate GroupWise object selected, click Tools > GroupWise Utilities > Client 
Options to display the GroupWise Client Options dialog box.

Macros View Macro Security
Always Play Received Macros
Never Play Received Macros
Always Prompt Before Playing a Macro

Notify Check for Mail Every

Date and Time 

Click Tools >
GroupWise Utilities >
Client Options >
Date and Time

Calendar Month Display Option
First of Week
Highlight Day
Show Week Number

Appointment Options
Include Myself on New Appointments
Display Appointment Length As Duration, End Date and 

Time
Default Length

Alarm Options
Set Alarm When Accepted
Default Alarm Time

Work Schedule
 Start/End Time

Work Days

Busy Search Appointment Length
Range and Time to Search
Days to Search

Client Options Type Client Options Tab Client Options
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3 To set the Environment options, click Environment > continue with Section 65.2.1, “Modifying 
Environment Options,” on page 1070.
or
To set the Send options, click Send > skip to Section 65.2.2, “Modifying Send Options,” on 
page 1082.
or
To set the Security options, click Security > skip to Section 65.2.3, “Modifying Security 
Options,” on page 1093.
or
To set the Date and Time options, click Date and Time > skip to Section 65.2.4, “Modifying 
Date and Time Options,” on page 1096. 

65.2.1  Modifying Environment Options
1 If the Environment Options dialog box is not displayed, follow the instructions in Section 65, 

“Setting Defaults for the GroupWise Client Options,” on page 1065 to display the dialog box.

2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Environment Options: General” on page 1071
“Environment Options: Client Access” on page 1072
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“Environment Options: Views” on page 1075
“Environment Options: File Locations” on page 1076
“Environment Options: Cleanup” on page 1077
“Environment Options: Appearance” on page 1078
“Environment Options: Retention” on page 1079
“Environment Options: Junk Mail” on page 1080

NOTE: The Environment options are not currently recognized by the Cross-Platform client.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.
After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Environment Options: General

The General options determine such settings as the refresh interval for new messages, whether users 
can create shared folders and address books, and which types of accounts can be used while in 
Online mode.

Figure 65-1   Environment Options Dialog Box with the General tab Open

Refresh Interval

Determine how often the GroupWise client lists will be updated to reflect new message status. The 
default is 1 minute.

Allow Shared Folder Creation

Enables users to share folders with other users. By default, this option is enabled.
Setting Defaults for the GroupWise Client Options 1071
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Allow Shared Address Book Creation

Enables users to share address books with other users. By default, this option is enabled.

Check Spelling Before Send

Automatically spell checks the message text of each item before the item is sent. By default, this 
option is disabled.

Show Messenger Presence

Displays the Messenger presence information in the GroupWise Windows client. Messenger 
presence enables users to easily choose instant messaging as an alternative to e-mail. Messenger 
presence icons appear in the From field of a received message, in the Quick Info for users specified 
in the To, CC, and BC fields of a new message, and in the Quick Info for users in the Address Book. 
Messenger presence is enabled by default.

The Address Book must be properly configured to support Messenger presence. See Section 6.3, 
“Supporting Messenger Presence Display in GroupWise,” on page 90.

Allow Use of POP and IMAP Accounts in the Online Mailbox

Select this option to enable users to access POP and IMAP accounts while using the GroupWise 
client in Online mode.

By default, this option is disabled. If you enable this option, an Accounts menu is added to the 
GroupWise client, allowing users to add POP and IMAP accounts to GroupWise, set account 
properties, and send and retrieve items from their POP and IMAP accounts. In addition, users are 
allowed to upload POP and IMAP items from the Remote mailbox to the Online mailbox.

Allow Use of News (NNTP) Accounts in the Online Mailbox:

Select this option to enable users to set up newsgroup (NNTP) accounts while using the GroupWise 
client in Online mode.

Environment Options: Client Access

The Client Access options allow you to apply a license type (full or limited) to users’ mailboxes and 
enable or disable the Remote and Caching modes in the GroupWise client for Windows. 
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Figure 65-2   Environment Options Dialog Box with the Client Access Tab Open

Client Licensing

GroupWise offers two types of mailbox licenses: full client mailbox licenses and limited client 
mailbox licenses. 

A full client mailbox license has no mailbox access restrictions; the mailbox can be accessed by any 
GroupWise client (Windows or WebAccess) as well as any third-party plug-in or POP/IMAP client.

A limited client mailbox license restricts mailbox access to the following:

The GroupWise WebAccess client (including wireless devices)
A GroupWise client (Windows or WebAccess) via the Proxy feature
A GroupWise client (Windows or WebAccess) via the Busy Search feature
A POP or IMAP client

A limited client license mailbox does not allow access through the GroupWise client for Windows 
(other than via Proxy or Busy Search).

You can use this option to specify the type of client license that you want applied to users’ 
mailboxes. This enables you to support the type of GroupWise mailbox licenses you purchase. For 
example, if you only purchased limited client license mailboxes for users on a specific post office, 
you can mark all mailboxes on that post office as being limited client license mailboxes.

For information about generating an audit report that shows the type of license applied to each 
mailbox in a post office, see Section 12.4, “Auditing Mailbox License Usage in the Post Office,” on 
page 191.
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Client Login Mode

Choose from the following settings to determine which login modes are available to GroupWise 
users when using the GroupWise client for Windows. These settings apply only if you selected Full 
License Mailboxes for the client licensing.

Allow Use of Remote Mode: Select this option to enable users to log in with GroupWise in 
Remote mode. With Remote mode, the GroupWise client uses a Remote mailbox on the user’s 
local drive. The user must initiate a connection (modem, direct, or TCP/IP) to send or retrieve 
items from the GroupWise system. For more information about Remote mode, see 
Section 64.1.3, “Remote Mode,” on page 1057. By default, this option is enabled. 

NOTE: Remote Mode is not available in the Cross-Platform client.

Allow Use of Caching Mode: Select this option to enable users to log in with GroupWise in 
Caching mode. With Caching mode, the GroupWise client uses a Caching mailbox on the 
user’s local drive (this can be the same mailbox as the Remote mailbox). The GroupWise client 
periodically initiates a connection with the GroupWise system to send and receive items. For 
more information about Caching mode, see Section 64.1.2, “Caching Mode,” on page 1055. By 
default, this option is enabled.
Select the Force Caching Mode option (available only if the Allow Use of Caching Mode 
option is enabled) to force users to run in Caching mode. By default, this option is disabled. 
Specify the number of days before Caching mode is enforced. This allows the user to continue 
using Online mode until the grace period has passed. The grace period begins the first time the 
user connects to the POA. The setting applies per user per workstation.
The Force Caching Mode setting is not enforced on a workstation that does not have enough 
disk space for a Caching mailbox. The amount of disk space that is required is: the size of the 
mailbox + 20 MB + 25% of the mailbox size.
The Force Caching Mode setting is also not enforced when a user connects from a shared 
Windows workstation or terminal server if you configure these workstations to be excluded. 
You do this by setting a registry key on the Windows workstation. The registry key is in 
HKEY_LOCAL_MACHINE. Under Software\\Novell\\GroupWise\\Client, add 
a dword value named No Local Store with a value of 1. This prevents the user from creating a 
Caching or Remote mailbox by using the GroupWise Windows client menus. However, the 
user can still create a Caching or Remote mailbox by using the startup switches /pc, /pr, or /ps.
By Default, Show Login Mode Drop-Down List on Client Toolbar: Select this option to 
have the Login Mode drop-down list displayed on the client’s toolbar. This enables users to 
change the mode themselves and is necessary only if you allow multiple modes to be used. By 
default, this option is enabled.
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Environment Options: Views

Figure 65-3   Environment Options Dialog Box with the Views Tab Open

The Views Environment options determine when items open, and whether or not users can read and 
compose messages in HTML.

View Options

Choose from the following settings to determine what occurs when the user performs an action that 
closes the current view.

Read Next after Accept, Decline, or Delete: Select this option to have the next available 
received item automatically open after the user accepts, declines, or deletes an appointment, 
task, or note. By default, this option is enabled.
Open New View after Send: Select this option to have a new send view open after a user 
sends a message. By default, this option is disabled.

Allowable Read Views

Choose from the following settings to determine what read views you allow the clients to use.

Plain Text (Default): Select this option to allow users to read items in plain text.
HTML: Select this option to allow users to read items in HTML.

Click Set Default to select the default read views.

Allowable Compose Views

Choose from the following settings to determine what compose views you allow the clients to use.

Plain Text (Default): Select this option to allow users to compose items in plain text.
HTML: Select this option to allow users to compose items in HTML.
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Click Set Default to select the default compose views.

Disable HTML View

Turns off the ability to view or compose messages in HTML View.

Environment Options: File Locations

The File Locations options determine the locations of users’ archive directories and the custom 
views directory.

Figure 65-4   Environment Options Dialog Box with the File Locations Tab Open

Archive Directory

Select the directory to be used for archiving items for both the Windows client and the Cross-
Platform client. Each user must have his or her own archive directory, so this can be a local directory 
(for example, c:\novell\groupwise for the Windows client and \home\groupwise for 
the Cross-Platform client) or a personal user directory on a network server. If you select a local 
drive, make sure users have the directories created. If you select a network drive, make sure users 
have the necessary rights to access the directories.

IMPORTANT: If you want to use a network location, do not specify the same directory for users in 
more than one post office. The names of users’ individual archive directories are based on their 
FIDs. FIDs are unique within a post office, bur users in different post offices can have the same FID. 

Custom Views

This option applies only if you are using custom views. Select the directory where the views are 
located. The GroupWise product does not include the capability to design custom views, but third-
party products make use of this feature to support their specialized capabilities.
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Environment Options: Cleanup

The Cleanup options determine the delete and archive settings for GroupWise items (mail messages, 
phone messages, appointments, tasks, and notes).

Figure 65-5   Environment Options Dialog Box with the Cleanup Tab Open

Mail and Phone

Choose from the following settings to determine how mail and phone messages are deleted and 
archived:

Manual Delete and Archive: Select this option to have mail and phone messages deleted or 
archived only when users manually do it. This is the default setting.
Auto-Delete After: Select this option to have GroupWise automatically delete mail and phone 
messages that are older than the specified number of days. If you use this option, you should 
notify users so they know they must archive items they want to save.
Auto-Archive After: Select this option to have GroupWise archive mail and phone messages 
that are older than the specified number of days. Users must have an archive directory specified 
in order for items to be archived. See “Environment Options: File Locations” on page 1076 for 
information about setting a default archive directory location. 

Appointment, Task, and Note

Choose from the following settings to determine how appointments, tasks, and notes are deleted or 
archived:

Manual Delete and Archive: Select this option to have appointments, tasks, and notes deleted 
or archived only when users manually do it. This is the default setting.
Auto-Delete After: Select this option to have GroupWise automatically delete appointments, 
tasks, or notes that are older than the specified number of days. If you use this option, you 
should notify users so they know they must archive items they want to save.
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Auto-Archive After: Select this option to have GroupWise automatically archive 
appointments, tasks, and notes older than the specified number of days. Users must have an 
archive directory specified in order for items to be archived. See “Environment Options: File 
Locations” on page 1076 for information about setting a default archive directory location.

Empty Trash

Deleted items are moved to the Trash folder. They can be retrieved from the Trash until it is emptied. 
Items in the Trash still take up disk space. Select from the following settings to determine how the 
Trash folder is emptied: 

Manual: Select this option to require the user to manually empty the Trash. This is the default 
setting.
Automatic: Select this option to have GroupWise automatically empty items from the trash 
after they have been in it for the specified number of days.

Purges

Allow Purge of Items Not Backed Up: Select this option to enable items that have not been 
backed up to be removed from the Trash. This option is enabled by default.

Select the Prompt Before Purging option (available only if Allow Purge of Items Not Backed 
Up is enabled) to prompt the user to confirm the purging of any files that have not been backed 
up.
Perform Maintenance Purges on Caching/Remote: On the Disk Space Management page 
(Tools > GroupWise Utilities > Client Options > Send > Disk Space Management) in 
ConsoleOne, you can limit the size of users’ Online mailboxes. You can now enforce the same 
mailbox size limits on users’ Caching and Remote mailboxes, wherever those mailboxes are 
located.
The size limit is applied to users’ Caching and Remote mailboxes regardless of the amount of 
available disk space on users’ hard drives. The size limit is applied the next time the 
GroupWise Windows client synchronizes with users’ Online mailboxes. Because users might 
lose items that they have been storing locally when the size limit is enforced, you should warn 
users that size limits are going to be placed on their local Caching and Remote mailboxes. 

Environment Options: Appearance

The Appearance options determines the appearance of the GroupWise Windows client.
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Figure 65-6   Environment Options Dialog Box with the Appearance Tab Open

Schemes

There are three available schemes that determine how the GroupWise Windows Client appears.

Default: Displays the Main Menu, Toolbar, full Folder list, the Nav Bar, and the Sky Blue 
color scheme.
GroupWise 6.5: Looks just like the 6.5 client. It displays the Main Menu, Toolbar, and the full 
Folder list.
Simplified: Displays the Sky Blue color scheme, the Nav bar, and the simple Folder list.

Individual Settings

You can also control individual appearance settings for the GroupWise Windows client.

Display Main Menu: Displays at the top of the window in the GroupWise client.
Display Nav Bar: Displays at the top of the window in the GroupWise client.
Display Main Toolbar: Displays underneath the Navigation bar in the GroupWise client.
GroupWise Color Scheme: Overrides any operating system color schemes for the GroupWise 
client. You can select Blue, Olive Green, Silver, Sky Blue, Spring Green, or Sterling Silver.
Display Folder List: Displays the Folder list on the left side of the window in the GroupWise 
client. You can select from a Simple Folder List or a Full Folder List. If you are using the 
GroupWise 6.5 Look, you can also select to view the Long Folder List.
Display QuickViewer: Displays the QuickViewer in the GroupWise client. You can select to 
display the QuickViewer on the right side or at the bottom.

Environment Options: Retention

The Retention tab is displayed only if the Provides Message Retention Service setting is turned on 
for a trusted application. For information, see Section 4.12, “Trusted Applications,” on page 70.
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Message retention is configurable by administrators only, not by GroupWise users. The Retention 
options do not display in the GroupWise client.

Figure 65-7   Environment Options Dialog Box with the Retention Tab Open

Enable Message Retention Service

Select this option to enable the Message Retention Service. If you are setting client options for a 
domain, all user mailboxes in the domain support message retention. Likewise, if you are setting 
options for a post office, all user mailboxes in the post office support message retention. After a 
user’s mailbox is enabled for message retention, the user cannot perform any action (purging, 
archiving, etc.) that removes messages from the mailbox until the messages have been copied to 
another storage location by a trusted application that has been designed to provide the Message 
Retention Service.

Environment Options: Junk Mail

The Junk Mail Handling Environment options determine the junk mail handling functionality of the 
GroupWise client.
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Figure 65-8   Junk Mail Tab in the Environment Options Dialog Box

Junk Mail Handling

Select Enable Junk Mail Handling to enable junk mail handling. This setting determines whether or 
not the Junk Mail Handling feature is available for a user. This setting affects both the client and the 
POA. Junk Mail Handling allows users to block or “junk” unwanted Internet e-mail. When this 
setting is disabled, the client does not display any Junk Mail Handling menus or dialog boxes, and 
the POA does not perform any junk mail handling for the user. When this setting is enabled, the 
client displays Junk Mail Handling menus and dialog boxes, and the POA performs junk mail 
handling if the block and junk lists are also enabled. 

Enable Junk Mail Using Junk Mail Lists

 Select this option to cause junking based on e-mail addresses and domain names available to users. 
A user can junk e-mail from a specific Internet e-mail address or from an entire Internet domain, 
when the e-mail addresses and Internet domains are listed in the user’s Junk List. (Initially, there are 
no entries in a user’s junk list.) Junked items are delivered to the Junk Mail folder in the user’s 
Mailbox.

When this setting is enabled or disabled and not locked, the user’s initial setting to use the Junk List 
is enabled or disabled. Users can change the setting. When the setting is enabled and locked, a user's 
Enable Junk List setting is enabled and cannot be disabled. When the setting is disabled and locked, 
the Junk List is unavailable to the user. Client menu options and dialog boxes involving the Junk 
List are not displayed.

Enable Junk Mail Using Personal Address Book

Select this option to cause  junking based on personal address book entries available to users. A user 
can junk e-mail from all users whose addresses are not in any personal address books (including 
Frequent Contacts) without building a Junk List.

When this setting is enabled or disabled and not locked, the user’s initial setting to use personal 
address books is enabled or disabled. Users can change the setting. When the setting is enabled and 
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locked, a user's Enable Junk Mail Using Personal Address Book setting is enabled and cannot be 
disabled. When the setting is disabled and locked, this option is unavailable to the user.

Auto-Delete After

Select this option and specify the number of days after which you want junked items to be 
automatically deleted from users' mailboxes. The default is 14 days.

When this setting is enabled or disabled and not locked, the user's initial setting to delete junked 
items is enabled or disabled. Users can change the setting. When the setting is enabled and locked, a 
user’s Automatically Delete Items setting is enabled and cannot be disabled. When the setting is 
disabled and locked, this option is unavailable to the user.

Enable Blocked Mail Using Block Mail Lists

Select this option to make blocking available to users. A user can block e-mail from an Internet e-
mail address or Internet domain, when blocked e-mail addresses and Internet domains are listed in 
the user's Block List. (Initially, there are no entries in a user's Block List.) Blocked items are blocked 
when the POA processes delivery to the user's mailbox, and the items are never delivered to the 
user's mailbox. When the POA log uses verbose mode, the log displays information about blocked 
items.

When this setting is enabled or disabled and not locked, the user’s initial setting to use the Block List 
is enabled or disabled. Users can change the setting. When the setting is enabled and locked, a user's 
Block List setting is enabled and cannot be disabled. When the setting is disabled and locked, 
blocking is unavailable to the user. Client menu options and dialog boxes involving the Block List 
are not displayed.

65.2.2  Modifying Send Options
1 If the Send Options dialog box is not displayed, follow the instructions in Section 65, “Setting 

Defaults for the GroupWise Client Options,” on page 1065 to display the dialog box.
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2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Send Options: Send Options” on page 1083
“Send Options: Mail” on page 1085
“Send Options: Appointment” on page 1086
“Send Options: Task” on page 1087
“Send Options: Note” on page 1088
“Send Options: Security” on page 1089
“Send Options: Disk Space Management” on page 1091
“Send Options: Global Signature” on page 1092

NOTE: To see which Send options are recognized by the Cross-Platform client, refer to the 
client options table in Section 65.1, “Client Options Summary,” on page 1065.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.
After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Send Options: Send Options

The Send Options determine general settings that apply to all GroupWise item types (mail messages, 
phone messages, appointments, tasks, and notes).

Figure 65-9   Send Options Dialog Box with the Send Options Tab Open
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Classification

Select the default for the security classification label at the top of the message box. The 
classifications do not provide any encryption or additional security. They are meant to alert the 
recipient to the relative sensitivity of the item. The options are Normal, Proprietary, Confidential, 
Secret, Top Secret, and For Your Eyes Only. The default is Normal.

Priority

Select High, Standard, or Low as the default item priority. Priority determines which post office 
directory an item is placed in. This, in turn, determines how quickly items are delivered. High 
priority items are queued ahead of normal or low priority items.

Reply Requested

Select the Reply Requested option to have items always include a reply request. By default, this 
option is disabled. If you enable the option, select whether the recipient is asked to reply when it is 
convenient or within a specific number of days.

Allow Use of Reply to All in Rules

Select this option to enable users to use the Reply to All action when creating rules. By default, this 
option is disabled, which means that only the Reply to Sender action is available.

Allow Use of Internet Mail Tracking

Select this option to allow users’ GroupWise clients to automatically embed information in Internet-
bound items. The embedded information instructs the receiving system to send back a delivery 
notification message (if it is supported). By default, this option is enabled.

To make Internet Status Tracking work, users must also turn on the setting in the GroupWise client 
(Tools > Options > Send Options > Mail > Enable Delivery Confirmation). By default, the Enable 
Delivery Confirmation is turned off in the GroupWise client.

Expiration Date

Select this option to have unopened messages expire after the specified number of days. By default, 
this option is disabled.

Delay Delivery

Select this option to delay the delivery of messages for the specified number of days. For example, if 
you specify 3 days, a message is not delivered until 3 days after the day it is sent. Messages are 
delivered at 12:01 a.m. of the appropriate day. By default, this option is disabled.

Wildcard Addressing

Wildcard addressing enables a user to send an item to all users in a post office, domain, GroupWise 
system, or connected GroupWise system by inserting asterisks (*) as wildcards in e-mail addresses.

Not Allowed: Select this option to disable wildcard addressing.
Limited to Post Office (Default): Select this option to limit wildcard addressing to the user’s 
post office. This means that a user can send an item to all users on the same post office by 
entering * in the item’s address field.
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Limited to Domain: Select this option to limit wildcard addressing to the user’s domain. This 
means that a user can send an item to all users in the domain by entering *.* in the item’s 
address field. A user can also send an item to all users on another post office in the domain by 
entering *.post_office_name in the item’s address field.
Limited to System: Select this option to limit wildcard addressing to the user’s GroupWise 
system. This means that a user can send an item to all users in the GroupWise system by 
entering *.*.* in the item’s address field. A user can also send an item to all users in another 
domain by entering *.domain_name or to all users in another post office by entering 
*.post_office_name.
Unlimited: Select this option to allow unlimited use of wildcard addressing. This means that a 
user can send an item to all users in another GroupWise system by entering 
*.post_office_name.domain_name or *.domain_name in the item’s address field.

Notify Recipients

Select this option to have recipients notified when they receive an item, if they are using GroupWise 
Notify. By default, this option is enabled.

Convert Attachments

Select this option to allow conversion of attachments in items sent to non-GroupWise e-mail 
systems through a GroupWise gateway.

Allow Reply Rules to Loop

By default, GroupWise does not allow a rule-generated reply to be replied to by another rule-
generated reply. This situation, referred to as looping, can quickly increase message traffic. To allow 
reply rules to loop, select this option. 

Send Options: Mail

The Mail options apply to mail and phone messages only.

Figure 65-10   Send Options Dialog Box with the Mail Tab Open
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Create a Sent Item to Track Information

By default, items the user sends are inserted in the user’s Sent Items folder. Deselect this option if 
you do not want the items placed there. If items are not placed in the Sent Items folder, users cannot 
check the delivery status of the item. The following options are available only if this option is 
selected.

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the message to view the status.
Delivered and Opened (Default): Select this option to track delivered and opened status only. 
The user can open the Properties window of the sent message to view the status.
All Information: Select this option to track all status information (delivered, opened, deleted, 
emptied). The user can open the Properties window of the message to view the status.
Auto-Delete Sent Item: Select this option to automatically delete messages from the user’s 
Mailbox after all the recipients have deleted the messages and emptied them from the Trash.

Return Notification

In addition to status tracking information, the user can receive notification when a message is 
opened or deleted. Choose from the following notification options:

None (Default): The user does not receive notification. 
Mail Receipt: The user receives a mail message stating that the recipient opened or deleted the 
message.
Notify: The user receives notification through GroupWise Notify when the recipient opens or 
deletes the message.
Notify and Mail: The user will receive notification through GroupWise Notify and a mail 
message.

Send Options: Appointment

The Appointment options apply to appointments only.
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Figure 65-11   Send Options Dialog Box with the Appt Tab Open

Create a Sent Item to Track Information

The setting for this option is inherited from the setting on the Mail tab; it can only be enabled or 
disabled on the Mail tab. If the option is enabled, you can choose from the following status tracking 
levels: 

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the appointment to view the status.
Delivered and Opened: Select this option to track delivered and opened status only. The user 
can open the Properties window of the appointment to view the status.
All Information (Default): Select this option to track all status information (delivered, 
opened, deleted, emptied). The user can open the Properties window of the appointment to 
view the status.

Return Notification

In addition to status tracking information, the user can receive notification when an appointment is 
opened, accepted, or deleted. Choose from the following notification options:

None (Default): The user does not receive notification. 
Mail Receipt: The user receives a mail message stating that the recipient opened, accepted, or 
deleted the appointment.
Notify: The user receives notification through GroupWise Notify when the recipient opens, 
accepts, or deletes the appointment.
Notify and Mail: The user receives notification through GroupWise Notify and a mail 
message.

Send Options: Task

The Task options apply to tasks only.
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Figure 65-12   Send Options Dialog Box with the Task Tab Open

Create a Sent Item to Track Information

The setting for this option is inherited from the setting on the Mail tab; it can only be enabled or 
disabled on the Mail tab. If the option is enabled, you can choose from the following status tracking 
levels: 

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the task to view the status.
Delivered and Opened: Select this option to track delivered and opened status only. The user 
can open the Properties window of the task to view the status.
All Information (Default): Select this option to track all status information (delivered, 
opened, deleted, emptied). The user can open the Properties window of the task to view the 
status.

Return Notification

In addition to status tracking information, the user can receive notification when a task is opened, 
accepted, completed, or deleted. Choose from the following notification options:

None (Default): The user does not receive notification. 
Mail Receipt: The user receives a mail message stating that the recipient opened, accepted, 
completed, or deleted the task.
Notify: The user receives notification through GroupWise Notify when the recipient opens, 
accepts, completes, or deletes the task.
Notify and Mail: The user receives notification through GroupWise Notify and a mail 
message.

Send Options: Note

The Note options apply to notes only.
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Figure 65-13   Send Options Dialog Box with the Notes Tab Open

Create a Sent Item to Track Information

The setting for this option is inherited from the setting on the Mail tab; it can only be enabled or 
disabled on the Mail tab. If the option is enabled, you can choose from the following status tracking 
levels: 

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the note to view the status.
Delivered and Opened (Default): Select this option to track delivered and opened status only. 
The user can open the Properties window of the note to view the status.
All Information: Select this option to track all status information (delivered, opened, deleted, 
emptied). The user can open the Properties window of the note to view the status.

Return Notification

In addition to status tracking information, the user can receive notification when a note is opened or 
deleted. Choose from the following notification options:

None (Default): The user does not receive notification. 
Mail Receipt: The user receives a mail message stating that the recipient opened or deleted the 
note.
Notify: The user receives notification through GroupWise Notify when the recipient opens or 
deletes the note.
Notify and Mail: The user receives notification through GroupWise Notify and a mail 
message.

Send Options: Security

The Security options apply to all GroupWise item types (mail messages, phone messages, 
appointments, tasks, and notes).
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Figure 65-14   Send Options Dialog Box with the Security Tab Open

Conceal Subject

Select this option to conceal the item’s subject so the notification that appears on the recipient’s 
screen does not include the subject. The subject of the item is also concealed in the recipient’s 
mailbox and the sender’s Sent Items folder. It is visible only when the item is being read.

Require Password to Complete Routed Item

Select this option to require a user to enter a password before completing a routed item.

Secure Items Options

If users have installed security providers on their workstations, select the options you want them to 
use.

Do Not Allow Use of S/MIME: Select this option to disable S/MIME functionality. This 
disables the Encrypt and Digitally Sign buttons (and other related S/MIME functionality) in the 
GroupWise client. By default, this option is enabled. When it is enabled, you can modify the 
rest of the options in the dialog box.
URL for Certificate Download: Specify the Internet address of your preferred certification 
authority. If not otherwise changed in this field, the GroupWise client accesses http://
www.novell.com/groupwise/certified.html, which lists several common certification 
authorities.
Sign Digitally: Select this option to enable users to add a digital signature to their outgoing 
messages. Recipients of a digitally-signed item who have S/MIME-enabled e-mail products are 
able to verify that the item is actually from the sender. This setting is not a useful security 
measure unless you lock it as the default.
Encrypt for Recipients: Select this option to enable users to encrypt an outgoing item so they 
can ensure that the intended recipients who have an S/MIME-enabled e-mail product are the 
only individuals who can read the item. This setting is not a useful security measure unless you 
lock it as the default.



novdocx (en)  10 M
arch 2008
If you enable the Encrypt for Recipients options, you can set the encryption algorithm and key 
size. The available algorithm methods (RC2, RC4, DES, 3DES) are trusted algorithms that 
encrypt or transform data to mask the original content. The key size sets the default size (in 
bits) of the encryption key that is used with the algorithm you select. These settings are not 
useful security measures unless you lock them.

Send Options: Disk Space Management

The Disk Space Management options let you enforce disk space limitations for users on a post 
office.

Figure 65-15   Send Options Dialog Box with the Disk Space Management Tab Open

User Limits

Select this option if you want to impose limits on the size of users’ mailboxes or the size of 
messages they can send. By default, this option is disabled. If you enable it, you can modify the 
following options:

Mailbox Size Limit: Specify the maximum amount of post office disk space available to users 
for storing message and attachment files. The setting uses logical disk space because 
attachments are shared by all recipient users on the same post office. Messages in shared 
folders are counted as disk space only for the owner of the shared folder. If you do not want to 
limit the mailbox size, set the value to zero (0).

If users meet or exceed their mailbox size limits, they cannot send items until their mailboxes 
are under the size limit. Users can reduce the size of their mailboxes by deleting or archiving 
items.
Threshold for Warning Users: Select the mailbox capacity (as a percentage) that must be 
reached before the user is warned that his or her mailbox is reaching its limit. For example, if 
the mailbox size limit is 200 MB and the threshold is set at 75%, users receive warnings when 
their mailboxes reach 150 MB. Set the value to 0 or 100 if you do not want users to receive a 
warning.
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Maximum Send Message Size: Specify the maximum size of a message (in kilobytes) that a 
user can send using the GroupWise client. If the user sends an item that exceeds this size, a 
message notifies the user that the item is too large to send. 
You can also set message size limits at the post office level through POA configuration, at the 
domain level through MTA configuration, and at the GroupWise system level through Internet 
Agent configuration, as described in Section 12.3.4, “Restricting the Size of Messages That 
Users Can Send,” on page 185.
Limits Apply to Cache: Use the same disk space limits for users’ Caching mailboxes on local 
workstations as you are using for their Online mailboxes in the post office. If you impose this 
limit on users who have existing Caching mailboxes, their Caching mailboxes might be 
reduced in size in order to meet the new disk space limit. Such users should be warned in 
advance so that they can back up their Caching mailboxes before the size reduction takes place. 
Otherwise, user could lose messages that they want to keep.
Notify the Administrator When Threshold Limit Is Exceeded:  Select this option so that 
the administrator is notified along with the user when the user’s mailbox exceeds the size 
established in the Threshold for Warning Users field. The administrator who receives the 
notification must be defined on the Identification page of the Domain object.
Notify the Administrator When Size Limit Is Exceeded:  Select this option so that the 
administrator is notified when the user’s mailbox exceeds the size established in the Mailbox 
Size Limit field. The administrator who receives the notification must be defined on the 
Identification page of the Domain object.

Send Options: Global Signature

The Global Signature option lets you set the global signature. To set options at the domain level, 
select a domain. To set options at the post office level, select a post office. To set options for 
individual users, select one or more users. 

Figure 65-16   Send Options Dialog Box with the Global Signature Tab Open
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Global Signature

1 Select a global signature to append to users’ messages.

When enabled, global signatures are automatically appended to every message that is sent by 
the users. For more information, see Section 4.14, “Global Signatures,” on page 72.

2 Select Apply the signature to all messages to add the signature to all internal or external 
messages.
or
Select Apply signature to external messages only to apply the signature to messages that are 
sent through the GroupWise Internet Agent.

If you select Default Global Signature, the default signature that is used by the GroupWise Internet 
Agent is applied. If you select None, then no signature is applied. 

NOTE: All Global Signature options pertain only to the Windows client.

65.2.3  Modifying Security Options
1 If the Security Options dialog box is not displayed, follow the instructions in Section 65, 

“Setting Defaults for the GroupWise Client Options,” on page 1065 to display the dialog box.

2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Security Options: Password” on page 1094
“Security Options: Macros” on page 1095
“Security Options: Notify” on page 1096

NOTE: To see which Security options are recognized by the Cross-Platform client, refer to the 
client options table in Section 65.1, “Client Options Summary,” on page 1065.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.
After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.
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4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Security Options: Password

The Password options let you reset a user’s password and enable various methods by which a user 
can set up the GroupWise client so that he or she doesn’t have to enter a password at startup. 

Figure 65-17   Security Options Dialog Box with the Password Tab Open

For background information about passwords, see Chapter 70, “GroupWise Passwords,” on 
page 1133.

Enter New Password

This option is available only when setting client options for an individual user. You can use this 
option to set or reset a user’s password. You should advise the user to change the password as soon 
as possible.

Retype Password

This option is available only when setting client options for an individual user. If you enter a new 
password, verify it by retyping it in this field.

Clear User Password

This option is available only when setting client options for an individual user. Select the option to 
clear an existing password without assigning a new password.

Allow Password Caching

Select this option to allow users to enable the Remember My Password option under Security options 
in the GroupWise client. The Remember My Password option stores the user’s password in the 
workstation’s Windows password list so that the user does not need to enter the password when 
starting GroupWise. This option is enabled by default.
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The Remember My Password option applies to Windows 95/98/ME only. It is not displayed to users 
running the GroupWise client on Windows 2000/XP/2003. Because Windows 95/98/NT are not 
supported platforms for the latest client release, this option is for older versions of the client.

Allow eDirectory Authentication Instead of Password

Select this option to allow users to select the No Password Required with eDirectory option under 
Security options in the GroupWise client. When this option is selected in the client, the user can 
access his or her mailbox without requiring a password if he or she is already logged in to Novell 
eDirectory. Mailbox access is granted based on eDirectory authentication, not on password 
information. 

NOTE: In versions of GroupWise prior to the GroupWise 5.5 Enhancement Pack, this option was 
called Allow NDS Single Sign-on. The option name has been changed to avoid confusion with the 
Novell Single Sign-on product.

Enable Single Sign-On

Select this option to give users the Use Single Sign-on option under Security Options in the 
GroupWise client. This option lets the user access his or her mailbox without reentering the 
password. After a user selects Use Single Sign-On in the GroupWise client, the GroupWise 
password is stored in eDirectory for the currently logged-in user.

IMPORTANT: Novell Single Sign-on must be installed on the user’s workstation in order for this 
option to take effect. 

Use Collaboration Single Sign-on (CASA)

Select this option to give users the Use Collaboration Single Sign-on (CASA) option under Security 
Options in the GroupWise Windows client. This option lets the user access his or her mailbox 
without reentering the password if the Collaboration Single Sign-on (CASA) software is installed. 
After a user selects Use Collaboration Single Sign-On (CASA) in the GroupWise client and if the 
CASA client is installed, the GroupWise password is stored for the currently logged-in user.

Security Options: Macros

The Macros option determines how GroupWise handles macros that are included in received 
messages.
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Figure 65-18   Security Options Dialog Box with the Macros Tab Open

View Macro Security

Choose from the following settings to determine the level of macro security:

Always Play Received Macros: Select this option to play attached macros when the message 
is opened.
Never Play Received Macros: Select this option to ignore attached macros. Macros do not 
play. 
Always Prompt Before Playing a Macro (Default): Select this option to have the user 
prompted to play the macro.

Security Options: Notify

The Notify option determines how often GroupWise Notify checks a user’s mailbox for newly 
received items. If new items are detected, the user is notified. The default is every minute.

Figure 65-19   Security Options Dialog Box with the Notify Tab Open

65.2.4  Modifying Date and Time Options
1 If the Date and Time Options dialog box is not displayed, follow the instructions in Section 65, 

“Setting Defaults for the GroupWise Client Options,” on page 1065 to display the dialog box.
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2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Date and Time Options: Calendar” on page 1097
“Date and Time Options: Busy Search” on page 1099

NOTE: The Date and Time options are not currently recognized by the Cross-Platform client.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.
After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Date and Time Options: Calendar

The Calendar options determine basic settings for the GroupWise Calendar.
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Figure 65-20   Date and Time Options Dialog Box with the Calendar Tab Open

Month Display Option

Select from the following options to determine how the month calendar is displayed:

First of Week: Select the day of the week that you want to display as the first day on the 
calendar.
Highlight Day: Select any days you want highlighted, such as weekends and holidays.
Show Week Number: Select this option to display the week number (1 through 52) at the 
beginning of the calendar week.

Appointment Options

Select from the following options to determine how appointments are handled:

Include Myself on New Appointments: Select this option to have the sender automatically 
included in the appointment’s To: list. This option is enabled by default.
Display Appointment Length As: When creating an appointment, the sender must specify the 
appointment’s length. You can use this option to determine whether the sender enters a duration 
for the appointment or an end time for the appointment. Select the Duration setting to have 
appointments display a Duration field that the sender must fill in (for example, 30 minutes, 1 
hour, or 10 hours). Select the End Date and Time setting to have appointments display End 
Date and Time fields that the sender must fill in (for example, June 3, 2007 and 10:00 a.m.). 
The default setting is Duration.
Default Length: Select the default length for appointments. Users can change the length. If the 
appointment’s length is displayed as a duration, the duration defaults to this length. If it is 
displayed as an end date and time, the end time defaults to the start time plus the default length 
(for example, if the start time is 9:00 a.m. and the default length is 1 hour, the end time defaults 
to 10:00 a.m).
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Alarm Options

Users can set appointment alarms so that they are notified prior to an appointment time. Select from 
the following options to determine the default settings for an alarms:

Set Alarm When Accepted: Select this option to have an alarm automatically set when the 
user accepts an appointment. By default, this option is enabled.
Default Alarm Time: Select the number of minutes before an appointment to notify the user. 
The default is 5 minutes.

Work Schedule

The work schedule determines the user’s normal work days and hours. In the calendar and during 
busy searches, any days or hours outside of the work schedule are represented by gray squares (Out 
of Office). Users can still be scheduled for appointments during non-work hours. 

Start Time: Select the daily start time. The default is 8:00 a.m.
End Time: Select the daily end time. The default is 5:00 p.m.
Work Days: Select the work days. The start time and end time are applied to each work day. 

Date and Time Options: Busy Search

The Busy Search options determine the amount of free time required for the appointment and the 
range of dates to search. 

Figure 65-21   Date and Time Options Dialog Box with the Busy Search Tab Open

Appointment Length

Set the default appointment length to search. You can set the length in 15-minute increments. The 
default is 15 minutes. This setting is used only when the user does a busy search through the Busy 
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Search option on the Tools menu. Otherwise, the default appointment length defined on the 
Calendar tab is used (see “Date and Time Options: Calendar” on page 1097).

Range and Time to Search

Specify the number of days to include in the search, then set the daily start and end times for the 
search.

Days to Search

Select the days to search. By default, the typical work days (Monday through Friday) are selected. 

65.3  Resetting Client Options to Default Settings
You can reset client options to the defaults for one or more users using Mailbox/Library 
Maintenance.

1 In ConsoleOne, select one or more User objects (or GroupWise External Entity objects).
2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.
3 In the GroupWise Objects list, select Users/Resources.
4 In the Actions list, select Reset Client Options, then click Run.
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66Distributing the GroupWise Client

You can distribute the GroupWise® client software in various ways:

Section 66.1, “Using GroupWise AutoUpdate and SetupIP to Distribute the GroupWise 
Windows Client,” on page 1101
Section 66.2, “Using ZENworks Desktop Management to Distribute the GroupWise Windows 
Client,” on page 1114
Section 66.3, “Using Novell ZENworks Linux Management to Distribute the GroupWise 
Cross-Platform Client,” on page 1119

66.1  Using GroupWise AutoUpdate and SetupIP 
to Distribute the GroupWise Windows Client
During installation and subsequent updates, the GroupWise® 7.x Windows client Setup program 
(setup.exe) by default requires user intervention at the workstation in order to install the client 
software. However, by using a setup configuration file (setup.cfg), you can simplify or 
eliminate the user responses during installation, and you can cause installations and updates to occur 
at specific times.

With AutoUpdate enabled, users are prompted to update their Windows client software, but they are 
not required to update and they can turn off the update prompt. If you want, you can force users to 
update their client software immediately, or you can allow them a specified number of grace logins 
to their existing version before you force them to update. This allows you to maintain current 
versions of the Windows client software on the network. 

By default, AutoUpdate requires that users workstations have a mapped drive to the 
client\win32 directory in the software distribution directory. However, with SetupIP enabled, 
users can install the Windows client software by way of a TCP/IP connection to a Web server and do 
not required a mapped drive

Section 66.1.1, “Preparing to Use AutoUpdate,” on page 1102
Section 66.1.2, “Using the Setup Configuration File,” on page 1105
Section 66.1.3, “Modifying the Setup Configuration File,” on page 1105
Section 66.1.4, “Adding LDAP Directory Service Accounts,” on page 1109
Section 66.1.5, “Testing Your AutoUpdate Configuration,” on page 1110
Section 66.1.6, “Enabling AutoUpdate,” on page 1111
Section 66.1.7, “Modifying the addon.cfg File,” on page 1112
Section 66.1.8, “Error Log File,” on page 1113

NOTE: This section does not apply to the Cross-Platform client.
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66.1.1  Preparing to Use AutoUpdate
Your preparation for implementing AutoUpdate depends on whether users install the Windows 
client software from a mapped drive or a TCP/IP connection.

“Verifying the Windows Client Software in the Software Distribution Directory” on page 1102
“Accessing the Windows Client Software from a Mapped Drive” on page 1102
“Accessing the Windows Client Software from a TCP/IP Connection to a Web Server” on 
page 1103

Verifying the Windows Client Software in the Software Distribution Directory

In order for AutoUpdate to function correctly, the Windows client software must be available in the 
client subdirectory of the software distribution directory that is assigned to each post office on 
the Post Office Settings property page of each Post Office object.

During the initial installation of the GroupWise Administration component, the Windows client files 
are copied to the software distribution directory on one server. For example, if you accepted the 
default z:\grpwise\software as your target, the Windows client software was copied to 
z:\grpwise\software\client\win32. 

Depending on the size of your GroupWise system, you might have created additional software 
distribution directories after your initial installation, as described in Section 4.9, “Software 
Directory Management,” on page 65. Before you enable AutoUpdate, ensure that all software 
distribution directories contain the Windows client software that you want to distribute to users.

Accessing the Windows Client Software from a Mapped Drive

If you want to use AutoUpdate to install the Windows client software from a software distribution 
directory on a mapped drive, users must be given Read and File Scan rights to the following 
directories:
software_distribution_directory\client
software_distribution_directory\client\win32
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In addition, when AutoUpdate runs, users’ workstations must have a drive mapped to the following 
directory:
software_distribution_directory\client\win32

Skip to Section 66.1.2, “Using the Setup Configuration File,” on page 1105.

Accessing the Windows Client Software from a TCP/IP Connection to a Web Server

If you want to enable SetupIP, so that users do not need a mapped drive to the software distribution 
directory, you must configure your Web server to provide the Windows client software to users. You 
can make the Windows client software available on as many as five Web servers. This section walks 
you through setting up and testing the first Web server. Repeat the procedure as need for additional 
Web servers.

1 Create a subdirectory in the documents directory of your Web server for the Windows client 
software:

For example, you could create a subdirectory named gw7client in the documents directory 
of your Web server. 

2 In the new client directory, create a win32 directory.
3 Browse to the following directory:
software_distribution_directory\admin\utility\setupip

4 In the setupip directory, run writeip.exe.

Web Server Documents Directory

Apache 2 on NetWare 6.5 sys:\apache2\htdocs

Apache 1.3 on NetWare 6 sys:\apache\nwdocs

Netscape Enterprise Server for NetWare on 
NetWare 6

sys:\novonyx\suitespot\docs

Apache 2.2 on Linux /srv/www/htdocs

Microsoft Internet Information Server (IIS) 5 on 
Windows Server 2000/2003/2003 R2

\inetpub\wwwroot
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4a In the IP Addresses list, specify the location of the client directory you created in Step 1 
above.
For example, you could specify:
http://172.16.5.18/gw7client

or
http://intranet.corporate.net/gw7client

You can include proxy and port information, for example:
http://intranet.corporate.net/gw7client;proxy.corporate:1690

When you set up multiple Web servers, each location is checked in order during 
AutoUpdate, until a connection is made. If you select Choose IP Address at Random, the 
order in which the locations are checked is selected randomly when AutoUpdate occurs. 
This balances the load on each Web server.

4b Select other download options as desired to control how the Windows client downloads 
the software from the Web server.
Download to a Temporary Directory: Select this option if you want the Windows client 
to download the updated software, install it, then delete the temporary location so that no 
trace is left on each user’s workstation.
Download to a Specific Directory: Select this option if you want to control the directory 
on each user’s workstation where the Windows client software is downloaded. This option 
allows you to choose whether the installation image remains on each user’s workstation, 
the quantity of files to download, and whether each user can choose the location for the 
installation image. If you allow users to choose the location, users are prompted for the 
download directory.

4c Click OK.
The writeip.exe program now creates a customized setupip.exe program. In 
addition, it creates a writeip.ini file that stores the options you selected when you 
ran writeip.exe.

4d If you are installing in a multilingual environment and you want to suppress the language 
prompt during installation, add a section similar to the following to the writeip.ini 
file:
[Language]
ShowLanguageDialog=No
Language=Yes

where Language is on of the languages listed in the setup.cfg file. Add a Language 
line for each language that you want installed on each user’s workstation. Without this 
section in the writeip.ini file, users are prompted to choose among the available 
languages.

5 From the setupip directory, copy the new setupip.exe file to the 
software_distribution_directory\client\win32 directory.

6 Copy the setupip.fil file from the setupip directory to the new client directory you 
created on the Web server in Step 1.
The setupip.fil file contains all of the Windows client software files that are language 
independent. 

7 To support the languages in use by Windows client users, copy setupip.xx files from the 
setupip directory to the client directory you created on the Web server in Step 1.
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The setupip.xx files (where xx represents a two-letter language code) contain all of the 
Windows client software files that are language specific. 

8 Continue with Using the Setup Configuration File.

66.1.2  Using the Setup Configuration File
The setup configuration file (setup.cfg) is an ASCII text file that supports extended ASCII 
characters. Its default location is the following directory:
software_distribution_directory\client

This is not the same directory where the Windows client Setup program (setup.exe) is located:
software_distribution_directory\client\win32

Therefore, by default, when a user runs the Setup program, the user must respond to the prompts that 
the Setup program displays, because the setup configuration file is not available.

The setup configuration file contains the responses normally provided by the user during the 
installation of the Windows client software. For example, the path for the client files, the folder for 
the GroupWise icons, and whether to automatically launch Notify are specified in this file. In 
addition, information can be added to the setup configuration file to add predefined LDAP directory 
service accounts to the Address Book in the client during installation.

If you modify the default setup configuration file and copy it to the same directory where the Setup 
program is located (that is, to the win32 directory), the Setup program reads the setup configuration 
file and performs the installation according to the entries in the file. Depending on the entries in the 
setup configuration file, the user might or might not be prompted to provide information during the 
Windows client installation.

66.1.3  Modifying the Setup Configuration File
The setup configuration file (setup.cfg) is divided into the following sections. In the setup 
configuration file, each section head must be enclosed in brackets [ ] as shown in the list below. 

Make a backup copy of the setup configuration file, then modify the file as needed so that the Setup 
program (setup.exe) performs the Windows client software installation the way you want it to, 
when you enable AutoUpdate.

“[GroupWiseSetup]” on page 1105
“[ShowSetup]” on page 1107
“[AutoUpdate]” on page 1107
“[Startup]” on page 1108
“[GWCheck]” on page 1108
“[IntegrationApps]” on page 1109
“[Languages]” on page 1109

[GroupWiseSetup] 

“Version=” on page 1106
“Path=” on page 1106
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“Folder=” on page 1106
“LaunchMessenger=” on page 1106
“LaunchNotify=” on page 1106
“OutlookFirewallException=” on page 1106
“GWMailTo=” on page 1106
“IPAddress=” on page 1106
“IPPort=” on page 1107
“DefaultIPAddress=” on page 1107
“DefaultIPPort=” on page 1107

Version= 

Specifies the GroupWise version being installed. It must match the actual version being installed; 
otherwise, the Setup program does not use the setup configuration file. The default is 7.0.

Path= 

Specifies the path where you want GroupWise to be installed during a standard installation. The 
default path is c:\Novell\GroupWise.

Folder= 

Specifies the Windows folder where GroupWise icons are created. The default is Novell GroupWise.

On the Windows Start menu, icons are provided for the GroupWise client, Notify, and the 
GroupWise Address Book.

LaunchMessenger=

Specifies whether GroupWise Messenger should be launched when GroupWise starts. The default is 
No.

LaunchNotify=

Specifies whether GroupWise Notify should be launched when GroupWise starts. The default is No.

OutlookFirewallException=

Specifies whether Outlook should be added to the Windows XP Firewall exceptions list. The default 
is Yes, which adds Outlook to the exceptions list.

GWMailTo=

Specifies whether GroupWise should be called when the user clicks a MailTo link in an HTML file 
displayed in a Web browser. The default is Yes.

IPAddress=

Optionally specifies the IP address for the client to always use (as opposed to the first time it starts). 
Use this setting to set the IP address per post office when using multiple post offices.
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IPPort=

Optionally specifies the port for the client to always use (as opposed to the first time it starts)

DefaultIPAddress=

Optionally specifies the default IP address for the client to use the first time it starts. This should be 
an IP address that everyone on the system has access to (for example, ngwnameserver).

DefaultIPPort=

Optionally specifies the default port for the client to use the first time it starts.

[ShowSetup]

“ShowDialogs=” on page 1107
“ShowProgress=” on page 1107
“Show Finish=” on page 1107

ShowDialogs=

Specify No to hide dialog boxes during the installation. Specify Yes to show the dialog boxes. The 
default is Yes.

If an entry is missing from the setup configuration file and ShowDialogs=Yes, the Setup program 
selects the default setting. If ShowDialogs=No, the Setup program prompts the user for a selection.

ShowProgress=

Specify Yes to show the progress indicator during the installation. Specify No to hide the progress 
indicator during installation. The default is Yes.

Show Finish=

Specify Yes to display the Finish dialog box during the installation. Specify No to hide this dialog 
box. The default is Yes.

[AutoUpdate] 

When an update to the GroupWise software is available, users are prompted if they want to install 
the new software when they start GroupWise. For complete instructions on enabling AutoUpdate, 
see Section 66.1.6, “Enabling AutoUpdate,” on page 1111.

“Enabled=” on page 1108
“SetupIPEnabled=” on page 1108
“ForceUpdate=” on page 1108
“GraceLoginCount=” on page 1108
“PromptUntilUpdated=” on page 1108
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Enabled=

Specify Yes if you want users to be prompted to update their Windows client software as soon as a 
newer version is available. Specify No if you want to disable the AutoUpdate feature. The default is 
Yes.

If you specify No, the ForceUpdate= entry below is ignored. This can be useful if you intend to 
distribute the client software using a different method, such as ZENworks® Desktop Management, 
or if you want to disable AutoUpdate at the post office level during a migration to a newer version of 
GroupWise. 

SetupIPEnabled=

Specify Yes if you want AutoUpdate to obtain the Windows client software from a Web server, as 
described in “Accessing the Windows Client Software from a TCP/IP Connection to a Web Server” 
on page 1103. The default is No, which means that AutoUpdate needs a mapped drive by default.

ForceUpdate= 

Select Yes if you want GroupWise to automatically update the users’ software. The default is No.

Users can still click Cancel to cancel the update. However, they cannot run the GroupWise client 
and access their mailboxes until they do update the client software.

GraceLoginCount=

Specify the number of grace logins allowed before you require the users to update their client 
software. The default is 0 (zero).

If ForceUpdate is set to No above, this entry is ignored.

PromptUntilUpdated= 

Specify Yes if you want GroupWise to prompt the user to update the client each time the GroupWise 
client starts, until the user does update the client software. The default is No, which means that, if the 
user chooses not to update the client software, the user is allowed to continue running the current 
version indefinitely.

[Startup] 

“Notify=” on page 1108

Notify=

Specify Yes to place Notify in the Windows Startup folder so that it starts automatically when the 
computer starts. The default is No. 

In the GroupWise client, users can configure GroupWise to start Notify automatically using Tools > 
Options > Environment > Launch Notify on Startup.

[GWCheck]

This section installs and enables GroupWise Check (GWCheck). GWCheck is a tool that performs 
maintenance and repair tasks on GroupWise databases in order to keep GroupWise running 
smoothly. 
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GWCheck is a standalone version of the Mailbox/Library Maintenance feature available in 
ConsoleOne®. GWCheck checks and repairs GroupWise user, message, library, and resource 
databases without having ConsoleOne and the GroupWise snap-in loaded. In addition to checking 
post office, user, and library databases, it can also check remote and archive databases that cannot be 
accessed by ConsoleOne because they are not available on the network.

“InstallGWCheck=” on page 1109
“GWCheckEnabled=” on page 1109

InstallGWCheck=

Specify Yes to install GWCheck files to the workstation. Specify No to not install GWCheck. The 
default is Yes.

GWCheckEnabled=

Specify Yes to install the files to the same directory as the GroupWise client (grpwise.exe), 
which results in the Repair Mailbox option being enabled under the Tools menu in the client. Specify 
No to install the files in a GWCheck subdirectory below the GroupWise client directory, which 
disables the Repair Mailbox option until the files are manually copied into the GroupWise directory. 
The default is No.

[IntegrationApps] 

GroupWise installs integrations for the following applications, if found, unless the entry is set to No.

Microsoft Excel
Microsoft Word 
Microsoft PowerPoint
Corel* Presentations*
Corel Quattro Pro*
Corel WordPerfect*

[Languages] 

The default language is set to English, and all other languages are set to No, meaning that they are 
not installed. See the setup.cfg file for the list of languages. The GroupWise client might not yet 
be available in all listed languages.

66.1.4  Adding LDAP Directory Service Accounts
LDAP directory service accounts provide users with the ability to search directory services such as 
Bigfoot for names of people. Each search can check potentially millions of names. After locating a 
name through a directory service search, users can add those names to their personal address books.

You can add predefined LDAP directory service accounts to the Address Book by adding 
information to the setup configuration file. This information can be added even after the initial 
installation. After the accounts are added, this information does not need to be removed from setup 
configuration file. During subsequent installations, GroupWise adds any new accounts listed but 
does not update or duplicate existing LDAP accounts.
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The user can also choose to add LDAP directory service accounts after the GroupWise client is 
installed.

To add an LDAP account during installation, add the following lines to the setup configuration file, 
providing information that is specific to the account:
[LDAP Account 1]
Description=Ldap Server1
Server=ldap.server1.com
Port=389
SearchRoot=c=us
Login=TRUE

You can add multiple accounts:
[LDAP Account 2]
Description=Ldap Server2
Server=ldap.server2.com
Port=389
SearchRoot=0=widget, c=us
Login=FALSE

66.1.5  Testing Your AutoUpdate Configuration
Before you enable AutoUpdate for client users, you should test the modifications you have made to 
the setup configuration file.

1 Copy the modified setup.cfg file from the client directory to the win32 directory in the 
software distribution directory.

2 On your own workstation or a test workstation, run setup.exe in the win32 directory 
3 If the Windows client installation goes as planned, continue with Step 5 if you are using 

SetupIP.
or
If client workstations will be updated from the same software distribution directory where you 
just tested the setup.exe program, skip to Section 66.1.6, “Enabling AutoUpdate,” on 
page 1111.

Parameter Description

Description= The name that displays in the list of LDAP directory services in the 
Address Book.

Server= The LDAP server DNS hostname or IP address.

Port= The LDAP directory service port number. The number is usually 389.

SearchRoot= The base or root of the LDAP directory service where the user searches 
for names. For example, the base could be a country, organization, or 
other type of grouping. This is not required for all LDAP directory services. 
If a search root is required, the LDAP directory service provides the 
information.

Login= TRUE means users are prompted for a username and password when 
they use that LDAP directory service.
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4 If the Windows client installation does not go as planned, review your modifications to the 
setup.cfg file, as described in Section 66.1.3, “Modifying the Setup Configuration File,” on 
page 1105, then return to Step 1 repeat the test.

5 After you can install successfully from the software distribution directory, copy the modified 
setup.cfg file from the client directory to the win32 directory on the Web server.

6 E-mail the setupip.exe file to yourself.
7 On your own workstation or a test workstation:

7a Make sure you are connected to the Internet, so that you can access the Web server where 
the Windows client software is located.

7b Run setupip.exe.
Because you have already tested your setup configuration file, installation from the 
Internet should also run as expected.

8 If you encounter problems with setting up AutoUpdate and SetupIP, more detailed background 
information and instructions are provided in:

TID 3730554: Novell GroupWise SetupIP Client Installation Guide in the Novell Support 
Knowledgebase (http://www.novell.com/support)
Upgrading Clients to GroupWise 6 in a NetWare Environment (http://support.novell.com/
techcenter/articles/nc2001_12c.html) by Danita Zanre
Consultants Corner: (Client) Push Comes to Shove (http://www.novell.com/
coolsolutions/feature/19506.html) by Gregg Hinchman

Although these documents reference earlier versions of GroupWise, the AutoUpdate and 
SetupIP strategies still apply.

9 When testing is successful, continue with Enabling AutoUpdate.

66.1.6  Enabling AutoUpdate
After you have customized the setup configuration file (setup.cfg) and tested it, you are ready 
to enable AutoUpdate. After AutoUpdate is enabled, Windows client users start experiencing client 
software updates the next time they start the Windows client. They might or might not be prompted 
and they might or might not see information displayed during the update, depending on your 
customized entries in the setup configuration file.

1 In ConsoleOne, click Tools > GroupWise System Operations > Software Directory 
Management.
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2 Select the software distribution directory, then click Update.

3 Select Force Auto-Update Check by GroupWise Components.
This causes the GroupWise client to check for a new version each time it starts. If a new 
version is found, the user is prompted to update the client software, unless you set 
ForceUpdate=Yes in the setup configuration file.
If a mapped drive to the software distribution directory is found on the user’s workstation, the 
client software is installed from the mapped drive. If a mapped drive to the software 
distribution directory is not found on the user’s workstation, GroupWise checks the Web server 
locations you specified using writeip.exe and installs the client software from one of those 
locations.
If no connection to the software distribution directory can be made, a setupip.err file is 
created in c:\windows of the user’s workstation. This file explains why none of the 
connections could be made.

4 Repeat Step 1 through Step 3 for each software distribution directory where you have updated 
the software and modified the setup configuration file.

66.1.7  Modifying the addon.cfg File
The addon.cfg file is an ASCII text file that supports extended ASCII characters. The 
GroupWise client setup program uses the addon.cfg file to install additional components on 
users’ workstations. The components might include software not shipped with GroupWise. The 
addon.cfg is specific to each program being installed. The required program files and the 
associated addon.cfg file must be copied to a subdirectory under 
software_distribution_directory\client\win32\addons.

During the client installation, the GroupWise setup program searches the subdirectories under the 
\addons directory for any addon.cfg files. The setup program then executes the installation 
program for that component using the settings specified in addon.cfg. If an entry is missing in 
the addon.cfg file, the installation program prompts the user for the required information.

The addon.cfg files for Internet Browser Mail Integration, PDA Connect, and GroupWise Tip of 
the Day are included in the corresponding subdirectories under addons, but the basic control for 
installing these two components is in the [GWMAILTO], [PDAConnect], and [GWTip] sections of 
setup.cfg.

For information about installing GroupWise Messenger as an additional component by modifying 
the addon.cfg file, see “Installing the Messenger Windows Client as a GroupWise Windows 
Client Add-On” in “Managing Messenger Client Users” in the Novell Messenger Administration 
Guide.

When creating an addon.cfg file for a different component, you must include at least the 
following section headings and associated entries. If the installation program requires additional 
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information, you can include that information as additional entries. The required entries are as 
follows:

“[GroupWiseAddon]” on page 1113
“[Name]” on page 1113
“[Description]” on page 1113

[GroupWiseAddon] 

This section head must be included with the following entries.

[Name] 

Under this section head, specify the two-letter language code for the language being installed, 
followed by the name of the add-on. This name appears in the components listing. 

Example:  US=GroupWise Tip of the Day

[Description] 

Under this section head, specify the two-letter language code followed by a short description of the 
add-on. This description appears in the Description field when the component is highlighted in the 
component listing. 

Example:  US=GroupWise Tip of the Day introduces new features and 
provides tips for using the GroupWise client.

66.1.8  Error Log File
If an error occurs during the installation and ShowDialogs=No, the error message is logged in 
gwsetup.err in the user’s \windows directory. If ErrorMessage=error_text has been added as 
the last entry under the [GroupWiseSetup] section, the error text is displayed. Otherwise, a generic 
error message is displayed notifying the user to contact the system administrator. The log file is an 
ASCII text file.

Entry Example

Install=add-on’s_setup_program_filename Install=setup.exe

Parameters=parameters_to_be_passed_on_t
o_the_add-on’s_setup_program

Parameters=/install

Silent=parameters_to_append_to_administra
tor-defined_setup

Silent=/s

Size=installed_size_of_add-on_in_kilobytes Size=100
Distributing the GroupWise Client 1113
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66.2  Using ZENworks Desktop Management to 
Distribute the GroupWise Windows Client
You can use the Application Management functionality in Novell ZENworks Desktop Management 
to distribute the GroupWise Windows client to workstations. The following sections provide 
instructions:

Section 66.2.1, “Creating a GroupWise Client Application Object,” on page 1114
Section 66.2.2, “Using GroupWise 7 Tuner,” on page 1117
Section 66.2.3, “Configuring ZENworks to Use a Transform File,” on page 1119

IMPORTANT: This information assumes that you are familiar with ZENworks Desktop 
Management. For background information, or for help completing the ZENworks tasks outlined in 
the steps below, see the ZENworks Desktop Management documentation at the Novell ZENworks 
Documentation Web site (http://www.novell.com/documentation-index/
index.jsp?category=ZENworks).

66.2.1  Creating a GroupWise Client Application Object
The following steps explain how to use ZENworks Desktop Management to create a GroupWise 
client Application object from the .msi file. Depending on your version of ZENworks Desktop 
Management, the steps might be slightly different. If you want to change the default MSI 
installation, then you must use the GroupWise 7 Tuner program to create a custom transform file. 
For more information on how to use GroupWise 7 Tuner, see Section 66.2.2, “Using GroupWise 7 
Tuner,” on page 1117.

1 In ConsoleOne®, right-click the container where you want to create the GroupWise client 
Application object, then click New > Object to display the New Object dialog box.

2 In the list of objects, click Application, then click OK to display the New Application dialog 
box.

3 Select An Application that Has an .msi File, then click Next to display the .msi file path page.

http://www.novell.com/documentation-index/index.jsp?category=ZENworks
http://www.novell.com/documentation-index/index.jsp?category=ZENworks
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4 In the Path to .msi File field, browse for and select the groupwise.msi file.
5 Click Next to display the Application object information page, then customize the object name, 

source path, and target path information if necessary.

Object Name: The name to be used for the Application object in eDirectory. You might want 
to use a descriptive name. 
Administration Package Path: The directory from which the GroupWise client will be 
installed. Specify the full path to the client directory (for example, 
\\server1\vol1\grpwise\software\client\win32). Unless all users will have 
the same drive mapping to the volume, make sure you use a UNC path.
This path is saved as the Administration Package Path variable. If you need to change it later, 
you can do so on the Application object’s Sources page (Application object > Common > 
Sources).

6 Click Next to display the rules to control availability of this application page, then modify the 
rules if necessary.
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7 Click Next to display the user associations page.

You can associate the Application object with the users and workstations you want the object 
distributed to at this time, or you can create the associations later.

8 After you add the associations you want, click Next, review the information, then click Finish 
to create the Application object.

9 Right-click the newly-created GroupWise client Application object, then click Properties.
10 Configure any other Application object settings required to provide the performance or 

functionality you want.
For example, you can configure the Application object so that the GroupWise client is installed 
immediately upon distribution to the user’s workstation, without any intervention by the user. 
Or, you can change the locations where the GroupWise client’s icon is displayed. Or, you can 
specify the location of a transform file for custom MSI installs. For information about 
Application object settings, see the ZENworks Desktop Management documentation at the 
Novell ZENworks Documentation Web site (http://www.novell.com/documentation-index/
index.jsp?category=ZENworks).

After you associate the Application objects with the users you want, Novell Application LauncherTM 
displays the Application object’s icon on the users’ workstations, if the workstation meets the 

http://www.novell.com/documentation-index/index.jsp?category=ZENworks
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operating system requirements. If the Application object’s icon does not appear immediately, have 
the user refresh Novell Application Launcher. 

If a service is preventing the GroupWise Windows client from installing correctly you can add a 
property to the GroupWise application object that stops the service until the installation has finished.

1 In ConsoleOne, right-click the container where you created the GroupWise client Application 
object, then double-click the GroupWise Application object.

2 Click MSI > Properties, then click Add.
3 In the Value name field, type STOPSERVICE.
4 In the Value Data field, type the name of the service to stop.
5 Click OK twice.

66.2.2  Using GroupWise 7 Tuner
GroupWise 7 Tuner is an application that allows you to customize your MSI install. The Tuner 
application creates a transform file called groupwise.mst, which you can specify to use when 
performing an MSI install with ZENworks. You must have write access to the software distribution 
directory to use the GroupWise 7 Tuner application.

NOTE: If you install the GroupWise client using a Tuner file to a protected area, such as the 
C:\Program Files directory, the installation fails if you try to install using a non-
Administrator user. You must install the GroupWise client to an unprotected are such as, 
C:\Novell\GroupWise if you are using a non-Administrator user.

1 From the \admin\UTILITY\GWTUNER directory of the GroupWise 7 Support Pack 1 or 
greater download, select the GWTuner.exe file, then click OK to run the GroupWise 7 Tuner 
application.

2 Specify the location of the client distribution directory on your GroupWise system, then click 
Next.

3 Specify where the GroupWise client should be installed on the client machines.
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4 Specify which program folder the GroupWise client should be installed to.
5 Select if you want to add a GroupWise icon to the client desktop. 
6 Select if you want to add a GroupWise icon to the client Quick Launch.
7 Select if you want to add GroupWise to the client Startup folder.
8 Click Next to continue.
9 Select the languages to install, then click Next.

10 Select the default startup language for the client, then click Next.
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11 Select which software integration you want the client to use.

12 Select which add-on software to install with the client, then click Finish to create the transform 
file (groupwise.mst) in the client software distribution directory.

66.2.3  Configuring ZENworks to Use a Transform File
After you have created the transform file (groupwise.mst), you must configure ZENworks to 
use the transform file when doing MSI installations.

1 From ConsoleOne, right-click the application file that was created in Section 66.2, “Using 
ZENworks Desktop Management to Distribute the GroupWise Windows Client,” on 
page 1114, then click Properties.

2 Click the MSI > Transform tab.
3 Click Add, then browse to the location of the transform file (groupwise.mst).
4 Click OK to add the transform file to the Transform List.
5 Click OK again.

66.3  Using Novell ZENworks Linux Management 
to Distribute the GroupWise Cross-Platform 
Client
You can install the GroupWise Cross-Platform client and agents using Novell ZENworks Linux 
Management or later. Refer to the Novell ZENworks Linux Management site (http://
www.novell.com/products/zenworks/linuxmanagement/) for additional information.
Distributing the GroupWise Client 1119
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67Supporting the GroupWise Client 
in Multiple Languages

The GroupWise® client software is available in a broad range of languages to meet the needs of 
users in many countries. If your GroupWise system services users who speak more than one 
language, the following tasks help you meet your multilingual users’ needs.

Section 67.1, “Providing the GroupWise Client Software in Multiple Languages,” on 
page 1121
Section 67.2, “Providing Post Office Support for Multiple Languages,” on page 1121

67.1  Providing the GroupWise Client Software in 
Multiple Languages

1 Make sure that you have the multilingual version of GroupWise.
2 Install the client software in the languages you need in one or more software distribution 

directories, following the instructions in Section 4.9, “Software Directory Management,” on 
page 65.

3 Distribute the client software to users, as described in Chapter 66, “Distributing the GroupWise 
Client,” on page 1101.

By installing the GroupWise client software in their language of choice, users can begin using 
GroupWise in that language immediately. However, there are a few language-related details of 
GroupWise functionality that are not taken care of by the client software running on users’ 
workstations. For a fuller multilingual implementation, continue with Section 67.2, “Providing Post 
Office Support for Multiple Languages,” on page 1121.

67.2  Providing Post Office Support for Multiple 
Languages
A few aspects of GroupWise functionality are affected by the language in use by the POA running 
for the post office to which users belong. The POA returns certain text in the language in which it is 
running, not the language in use on users’ workstations. 

The status information (Delivered, Opened, an so on) displayed in the Properties page of items
The text of return notification mail receipts (if the user has enabled this type of notification)
The sort order in the Address Book

In some circumstances, these issues can be resolved by grouping users who speak the same language 
into the same post office and then installing the POA in the same language that the users are using. 
For more information, see Section 11, “Creating a New Post Office,” on page 155.

At present, the POA is available in fewer languages than the GroupWise client, so this solution helps 
only those client users who are somewhat familiar with the language in use by the POA. For more 
information, see Chapter 7, “Multilingual GroupWise Systems,” on page 105.
Supporting the GroupWise Client in Multiple Languages 1121
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68Tools for Analyzing and 
Correcting GroupWise Client 
Problems

The following tools can assist you in analyzing and correcting GroupWise® client problems.

Section 68.1, “GroupWise Exception Handler for the Windows Client,” on page 1123
Section 68.2, “GroupWise Check,” on page 1123

68.1  GroupWise Exception Handler for the 
Windows Client
In the event that the GroupWise Windows client causes an exception (or “crashes”), GroupWise 
generates a GroupWise Exception Report. This report contains information that is useful in 
analyzing the problem that the client is having so that it can be solved.

The report is saved in \temp\grpwise.rpt. The \temp directory used is the one specified by 
the TMP environment variable, or if not defined by TMP, the one specified by the TEMP 
environment variable. If neither environment variable is defined, GroupWise uses the current the 
windows directory.

Each time an exception or crash occurs, a new report is appended to grpwise.rpt. If the file reaches 
100 KB, the oldest reports (at the beginning of the file) are deleted.

The GroupWise Exception Report contains information such as the date and time the report was 
generated, the exception code, fault address, date of grpwise.exe, computer and username where the 
exception occurred, hardware and operating system information, process modules, raw stack dumps, 
and call stacks.

68.2  GroupWise Check
GroupWise Check (GWCheck) is a tool that performs maintenance and repair tasks to keep 
GroupWise operating efficiently. It is essentially a standalone version of the Mailbox/Library 
Maintenance feature available in ConsoleOne®. GroupWise Check checks and repairs GroupWise 
user, message, library, and resource databases without having ConsoleOne and the GroupWise snap-
in loaded. In addition to checking post office, user, and library databases, it also checks remote and 
archive databases. 

Section 68.2.1, “Enabling GroupWise Check in the Windows Client,” on page 1124
Section 68.2.2, “Using GroupWise Check with the Cross-Platform Client,” on page 1124
Tools for Analyzing and Correcting GroupWise Client Problems 1123
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68.2.1  Enabling GroupWise Check in the Windows Client
GroupWise Check can be installed with the GroupWise Windows client (unless you have specified 
in setup.cfg that it not be installed), and is available by clicking Tools > Repair Mailbox in the client 
in Caching and Remote modes after you complete the following:

1 Locate the directory named gwcheck. This is a subdirectory of the directory where the client 
is installed (usually c:\novell\groupwise).

2 Locate grpwise.exe. It is usually in c:\novell\groupwise.
3 Copy all the files in gwcheck to the directory where grpwise.exe is located.

You can now run GroupWise Check in Caching and Remote mode. The GroupWise Check dialog 
box is titled GroupWise Mailbox Maintenance. You can also use Ctrl+Shift when accessing a 
Caching or Remote mailbox to run GroupWise Check before opening the mailbox.

For detailed information about GroupWise Check, click Help or see Section 34.1, “GroupWise 
Check,” on page 429.

68.2.2  Using GroupWise Check with the Cross-Platform Client
GroupWise Check is not accessible from the Cross-Platform client but can be installed on a Linux 
workstation if you need to repair local databases. For installation instructions, see Section 34.1.3, 
“Using GWCheck on Linux,” on page 432. 

GWCheck is installed by default on the Cross-Platform client for Macintosh. You must start 
GWCheck from a terminal window on a Macintosh. For further instructions, see Section 34.1.4, 
“Using GWCheck on Macintosh,” on page 434.
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69Startup Switches for the 
GroupWise Client

The GroupWise® client has optional startup switches that you can use when you start the program. 
Some of these startup switches are for your convenience, while others are necessary to run 
GroupWise on your particular hardware. Some switches are not available in the Cross-Platform 
client. 

69.1  /@u-?
Displays a login dialog box whenever you open the GroupWise client, allowing you to supply any 
necessary login information.

Syntax:  /@u-?

Example:  groupwise.exe /@u-?

69.2  /@u-user_ID
Lets you use your GroupWise user ID to use the GroupWise client as yourself on another user’s 
computer. The other user remains logged on to the network.

Windows Client Cross-Platform Client

/@u-? -@u=?

/@u-user_ID -@u=user_ID

/bl N/A

/c N/A

/cm N/A

/iabs N/A

/ipa-IP_address_or_hostname -ipa=IP_address_or_hostname

/ipp-port_number -ipp=port_number

/l-xx -l= xx

/la-network_ID N/A

/nu -nu

/ph-pathname -ph=pathname

/pc-path_to_caching_mailbox -pc=path_to_caching_mailbox

/pr-path_to_remote_mailbox N/A

N/A -ui=xxx
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Syntax:  /@u-user_ID

Example:  groupwise.exe /@u-ltanaka

69.3  /bl 
Prevents the GroupWise client logo screen from being displayed when you start the GroupWise 
client. 

Syntax:  /bl

Example:  groupwise.exe /bl

This startup switch is not available in the Cross-Platform client.

69.4  /c
Checks for unopened items. If there are unopened items, the GroupWise client opens as usual. 
Otherwise, the GroupWise client does not start. 

Syntax:  /c

Example:  groupwise.exe /c

This startup switch is not available in the Cross-Platform client.

69.5  /cm
Checks for unopened items. If there are unopened items, the GroupWise client opens minimized and 
a beep sounds. Otherwise, the GroupWise client does not start. 

Syntax:  /cm

Example:  groupwise.exe /cm

This startup switch is not available in the Cross-Platform client.

69.6  /iabs
Initializes the Address Book when the GroupWise client starts. 

Syntax:  /iabs

Example:  groupwise.exe /iabs

This startup switch is not available in the Cross-Platform client.

69.7  /ipa-IP_address_or_hostname
Lets you specify the IP address or the hostname when you are running in client/server mode.

Syntax:  /ipa-IP_address

Example:  groupwise.exe /ipa=127.65.45.1
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69.8  /ipp-port_number 
Lets you specify the IP port number when you are running in client/server mode.

Syntax:  /ipp-port_number

Example:  groupwise.exe /ipp-1677

69.9  /l-xx
Applies only if you have two or more language versions or language modules. This option instructs 
GroupWise to override the default environment language (under Environment in Options) with the 
language specified by the language code xx. The language codes are listed below. This table lists the 
language codes used by all Novell® products. GroupWise might not yet be available in some of the 
listed languages. For current information, contact your local reseller.

Table 69-1   Language Codes

Language Code

Arabic AR

Chinese Simplified ZH-CN

Chinese Traditional ZH-TW

Czech CS

Danish DK

Dutch NL

English US

Finnish SU

French FR

German DE

Hebrew HE

Hungarian MA

Italian IT

Japanese JA

Korean KO

Norwegian NO

Polish PL

Portuguese BR

Russian RU

Spanish ES

Swedish SV
Startup Switches for the GroupWise Client 1127
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Syntax:  /l-xx

Example:  groupwise.exe /l-ES

69.10  /la-network_ID
Lets you use your network ID to use the GroupWise client as yourself on another user’s computer. 
The other user remains logged on to the network. 

Syntax:  /la-network_ID

Example:  groupwise.exe /la-jgrey

This startup switch is not available in the Cross-Platform client.

69.11  /nu
Turns off AutoRefresh. If this option is selected, click View > Refresh whenever you want to update 
the display to see the items currently in your mailbox.

Syntax:  /nu

Example:  groupwise.exe /nu

69.12  /ph-pathname
Lets you specify the path to the post office.

Syntax:  /ph-pathname

Example:  groupwise.exe /ph-j:\mail\denver1

69.13  /pc-path_to_caching_mailbox
Opens GroupWise in Caching mode. GroupWise must be restarted when you change from Online to 
Caching.

Syntax:  /pc-path_to_caching_mailbox

Example:  groupwise.exe /pc-c:\novell\groupwise\cache

69.14  /pr-path_to_remote_mailbox
Opens the GroupWise client in Remote mode. This startup switch can be used in the Target text box 
only. 

Syntax:  /pr-path_to_remote_mailbox

Example:  groupwise.exe /pr-c:\novell\groupwise\remote

This startup switch is not available in the Cross-Platform client.
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69.15  -ui=xxx
Lets you specify which user interface “Look and Feel” to use. This switch is currently only available 
on Linux. Currently only gtk is supported. This starts the GroupWise Cross-Platform client on Linux 
using the GTK “Look and Feel”. This only works properly if you are using the GNOME* desktop 
manager.

Syntax:  -ui=xxx

Example:  /opt/novell/groupwise/client/bin/groupwise.sh -ui=gtk

this startup switch is not available in the Windows client or the Macintosh Cross-Platform client.
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