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About This Guide

Designer for Identity Manager can help you design, test, document, and deploy Identity Manager
solutions in a highly productive environment.

Newcomers can use wizards to build Identity Management solutions. Veterans and expert users can
bypass the wizards and interact directly at any level of detail.

Audience
Designer for Identity Manager was created for the following audiences:

+ Enterprise IT developers
+ Consultants
+ Sales engineers

*

Architects or system designers

*

System administrators
Designer is aimed at information technology professionals who:

+ Have a strong understanding of directories, databases, and the information environment
+ Act in the role of a designer or architect of identity-based solutions

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comment feature at the bottom of each page of the
online documentation, or go to www.novell.com/documentation/feedback.html and enter your
comments there.

Documentation Updates

For the most recent version of the Designer 4.0 for Identity Manager 4.0 Administration Guide, visit
the Identity Manager Web site (http://www.novell.com/identity/access/identity_integration).

Additional Documentation
+ Understanding Designer for Identity Manager (http://www.novell.com/documentation/
designer40/designer_intro/data/front.html)

+ Identity Manager 4.0 Installation Guide (http://www.novell.com/documentation/idm40/
idm_install/data/front.html)

+ Understanding Policies for Identity Manager 4.0 (http://www.novell.com/documentation/
idm40/policy/data/bookinfo.html)

+ Policies in Designer 4.0 (http://www.novell.com/documentation/idm40/policy_designer/data/
bookinfo.html)

+ Novell Credential Provisioning for Identity Manager 4.0 (http://www.novell.com/
documentation/idm40/policy_credprov/data/bookinfo.html)

About This Guide
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+ ldentity Manager 4.0 DTD Reference (http://www.novell.com/documentation/idm40/
policy_dtd/data/bookinfo.html)

+ Identity Manager 4.0 Driver Guides (http://www.novell.com/documentation/idm40drivers/
index.html)

For more documentation concerning Identity Manager 4.0, see Identity Manager 4.0 Documentation
Index (http://www.novell.com/documentation/idm40/index.html).
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Installing Designer

*

*

*

*

*

Section 1.1, “Requirements,” on page 17

Section 1.2, “Installing,” on page 17

Section 1.3, “Upgrading Designer 2.1x To Designer 3.x,” on page 21
Section 1.4, “Using the Silent Install,” on page 21

Section 1.5, “Uninstalling Designer,” on page 21

1.1 Requirements

*

*

Section 1.1.1, “System Requirements,” on page 17
Section 1.1.2, “Platform Requirements,” on page 17

1.1.1 System Requirements

*

*

*

*

Minimum resolution is 1024 x 768. The recommended resolution for Designer is 1280 x 1024.
1024 MB RAM.

1 GB available disk space (recommended).

1 GHz processing speed.

Gettext utilities (Linux only).

When you install support packages for Designer, such as NICI, certain Linux core utilities are
needed. The GNU gettext utilities provide a framework for internationalized and multilingual
messages. Before installing Designer, make sure that you have installed this package. You can
use YaST to check for dependencies and installed packages.

1.1.2 Platform Requirements

You can install Designer on the following:

*

*

*

*

*

Windows Vista Business and Ultimate with SP1 (32-and 64-bit)
Windows XP Professional with SP3 (32-bit)

openSUSE 10.3 (32 and 64-bit)

SUSE Linux Enterprise Desktop 10 with SP2 (32-and 64-bit)
SUSE Linux Enterprise Server 10 with SP2 (32-and 64-bit)

1.2 Installing

*

*

Section 1.2.1, “Installing Designer If Eclipse Is Not Already Installed,” on page 18
Section 1.2.2, “Installing Designer If Eclipse Is Already Installed on Your System,” on page 20

Installing Designer
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1.2.1 Installing Designer If Eclipse Is Not Already Installed

*

*

*

*

“Downloading the Files” on page 18
“Installing on Windows” on page 18
“Installing on Windows Vista” on page 19
“Installing on Linux” on page 19

Because Designer runs in an Eclipse environment, Designer installs Eclipse on your workstation.

Downloading the Files

1

2

Download the correct . iso image or .zip file for your system.
Downloads are available at the following locations:

+ Novell Downloads (http://download.novell.com/index.jsp)

+ Cool Solutions (http://www.novell.com/coolsolutions/dirxml/designer/)
If you downloaded a . iso image, burn that image file to a CD or DVD.

Installing on Windows

1
2

From the designer_install directory, run install.exe.
Select a language to use during the installation, then click OK.

Design. Deploy. Document

va5

SR . S, . Novell

E-Eng lish ~

Portugués (Brasil)

The default language is English. You can select a different language from the drop-down list.

The languages displayed in the language-selection dialog box are filtered, based on the default
system locale. If the default system locale is English (or another Latin-based character set),
only languages that use the Latin character set are displayed.

If the default system locale is set to Japanese (or any double byte-locale), only the double-byte
locales, such as Chinese, Korean, and Japanese, are displayed in the list. The exception to this
is English, which is always in the list, regardless of the default system locale.

Review the Introduction, accept the license agreement, select a location for the Designer files,
then select shortcuts to Designer.
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4 Select the desired shortcuts for your Windows machine.

5 Select a language for the Designer user interface.

Y2 Designer for Identity Manager,

Create Shortcuts

@ Introduction

@ License Agreement
@ Install Folder

= Shortcuts

Please select the shartcuts to create for Designer for Identity Manager. ¥ou may also select the
preferred user interface language for Designer for Identity Manager. You may change this preference
later frarm within Designer for Identity Manager.

N

Cancel

Create a shortcut on my Start Menu
Create a shortcut on my Deskiop
Create a shortcut on my Guick Launch Bar

[ ciearan [ sesctan

User Interface Language:

English v
Cutch ~
English

French
German
Italian
1apanese

Spanish s

[ Previous ] [ Mext ]

The default is the language that you selected to use for the installation. You can select a
different language from the drop-down list.

After installation, you can change the language. See “Language” on page 453.

6 Review the summary of choices, then install Designer.

7 Review known issues in the Readme, then complete the installation.

8 To run Designer, click the Designer for Identity Manager icon on the desktop.

Installing on Windows Vista

Windows Vista has implemented a new User Account Control feature that prevents applications
from running as Administrator unless you specifically allow it. If Designer does not install correctly
or launch after installation on Windows Vista:

1 Right-click the Designer icon on the desktop.

2 Select Run as Administrator.

Installing on Linux

Installing NICI requires root privileges. The install program prompts you for the root password so
that you can install these components.

Installing Designer

19



To install on Linux:

1 From the Identity Manager CD or .zip file, run /linux/designer_install/install.bin.
2 To run Designer, click the Designer icon on the desktop.

Designer installs its own JRE during the installation program. This JRE does not impact Java
installed for other uses on the workstation.

IMPORTANT: For updating your JRE, you must note that JRE 1.6 versions upto update 23 ship
with CVE-2010-4476 security vulnerability (http://www.oracle.com/technetwork/topics/security/
alert-cve-2010-4476-305811.html). This security vulnerability has been addressed in JRE 1.6.0-24
version. You must use the FPUpdater tool that Sun has recently released to update your JRE to JRE
1.6.0-24 version. The instructions for installing the latest JRE versions are available at the JRE
Patch Download Site (http://www.oracle.com/technetwork/java/javase/fpupdater-tool-readme-
305936.html).

1.2.2 Installing Designer If Eclipse Is Already Installed on Your
System

NOTE: Because of the interaction between Designer and third-party Eclipse plug-ins, Novell does
not support installing Designer into an existing Eclipse installation.

For additional information, see the CoolSolutions Web site (http://www.novell.com/coolsolutions/
dirxml/designer/existinginstall_instructions.html).

1 Make sure that the stand-alone Designer is not installed on the system.
2 Download a platform-specific file from the eclipse.org Web site:

Platform Filename

Linux wtp-all-in-one-sdk-R-1.5.0-200606281455- 1 inux-
gtk.tar.gz

Windows wtp-all-in-one-sdk-R-1.5.0-200606281455-
win32.zip

3 Unzip into the directory of your choice.

4 From the designer_instal l/features directory, unzip all of the files in the folder. This step
creates a separate eclipse directory with features and plugins subdirectories.

5 Copy the contents of the Designer features and plugins subdirectories into the main Eclipse
features and plugins subdirectories.

6 Because of the memory usage of Designer, you will need to change your heap and stack
settings for Eclipse. In the Eclipse directory, find the file eclipse. ini and add the following
lines (or change existing lines to match):

* -vmargs
¢+ -Xms512m
¢+ -Xmx1024m
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1.3 Upgrading Designer 2.1x To Designer 3.x

To upgrade to Designer 3.x, follow the same procedure that is outlined in Section 1.2, “Installing,”
on page 17. If you install Designer in its present location, you see the Designer Found message,
asking if you want to upgrade. If you select Yes, Designer deletes the older version of Designer and
installs Designer 3.x in its place.

When upgrading to Designer 3.x, take note of three items:

+ Do not use Designer 2.1x workspaces for Designer 3.x. Designer stores projects and
configuration information in a workspace and these are not compatible between Designer
versions.

In Designer 3.x, default workspaces are stored under the C:\Document and
Settings\Username\designer_workspace directory for Windows XP, the
C:\users\Username\designer_workspace directory for Windows Vista, and the
\home\username\designer_workspace for Linux.

+ Import all Designer 2.1x projects into Designer 4.x. This runs the Converter wizard, making the
projects compatible to run in Designer 3.x. Be sure the Copy project into the workspace option
is selected. For more information on the Project Converter, see Section 17.1, “Converting
Earlier Projects,” on page 373.

+ If you are running workflow provisioning and provisioning with roles, follow the installation or
upgrade procedures as outlined in Identity Manager Roles Based Provisioning Module 3.7
(http://www.novell.com/documentation/idmrbpm37/index.html).

1.4 Using the Silent Install

You can install Designer by using scripts. This feature is a silent install.

To use the silent install, run the install program with -i silent option. The option is the same
whether you install on Windows or Linux. For example:

+ Windows: install.exe -i silent
+ Linux: .Zinstall -i silent

The -i silent option uses all of the default values in the installation. To change the default values:

1 Issue the command install -r.
The -r option creates installer.properties file.
2 Edit the installer._properties file to add the desired values.
3 Issue the command install -i silent -f installer.properties.

1.5 Uninstalling Designer

+ “Uninstalling on Windows” on page 22
+ “Uninstalling on Linux” on page 22

Installing Designer
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Uninstalling on Windows

1 Inthe Control Panel, select Add/Remove Programs.
2 Click Designer for Identity Manager > Change/Remove > Uninstall > Yes.

To easily uninstall on English-language workstations, select Uninstall from the Start menu. For
example, on Windows, click Start > All Programs > Novell Designer for Identity Manager >
Uninstall.

Uninstalling on Linux

1 Make sure that you have the correct privileges to uninstall.
2 RunUninstall_Designer_for_ldentity Manager.
This file is in [path you chose to install into]/designer/UninstallDesigner.
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Creating a Project

IMPORTANT: Projects created in Designer releases earlier than Designer 3 work in Designer 3
once they are converted. However, projects created in Designer 2 or 3 don’t work in Designer 1.1 or
earlier releases.

*

Section 2.1, “When No Project Exists,” on page 23

*

Section 2.2, “When You Want to Create an Additional Project,” on page 24

*

Section 2.3, “When You Want to Import a Project,” on page 26

*

Section 2.4, “When You Want to Disable a Project,” on page 26

2.1 When No Project Exists

1 Make sure that the Designer perspective (in the upper right corner) is selected.

£ | g Designer
2 If you are just starting Designer and have no projects in the Project tab, you see the following
window:
== Project &2 EE atine | 5 = & 8
Projects @

There are currently no projecks, You can
create ar import projects by clicking the
links below,

E Mew Identity Manager Project

Import a Projeck:
3 File Swstem
=i Idenkity vault

,Irﬁ Wersion Control

3 Click New Identity Manager Project to launch the Identity Manager Project Wizard.
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@ New Identity Manager Project |:|E]

new Identity Manager Project IE

Mame the project and choose a location,

Project MName: |

Project conkents

|Jse default

| Browse,..

4 Name the project, then click Finish.

Ensure that you protect your work by periodically saving your project by backing up your project
files and project data. You use the Version Control feature in Designer 3.x to automatically create
versioned backups of your projects. You can also easily make a copy of your projects by performing

the following:
1 Right-click a project in the Project view.
2 Select Copy Project.

2.2 When You Want to Create an Additional
Project

1 Right-click in the Project view pane, then click New > Identity Manager Project.

=% Blanston0o1

{3 siystem Model
= Cesigrer
LT Blanstono2

(=ER=AE s ron0 3 |

» |18 Identity Manager Project...

['] 2y

Open With 4

Import
B Export Project

&% Refresh erator

[des] Copy Project..
B Move...
Disable Project

Rename. ..

i Check In...
erator

¥ Delete

Properties
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2 Inthe Identity Manager Project Wizard, name the project.

@ New Identity Manager Project

nNew Identity Manager Project @

Mame the project and choose a location,

Project Mame: Blansan1|

Project contents
Use default

Designer stores the project in a local directory. You specified this directory when you installed
Designer. Typically, this default directory is c:\Documents and
Settings\Username\designer_workspace for Windows XP and
c:\users\Username\designer_workspace for Vista. To specify a different directory,
deselect Use Default, then browse to and select the desired directory.

WARNING: Earlier Designer workspaces are not compatible with Designer 3.5 and above.
Designer stores projects and configuration information in a workspace. These workspaces are
not compatible from one version of Designer to another. You need to point Designer 3 to a new
workspace, and not to a workspace used by a previous version of Designer.

If you have Designer 2.x or 3.5 Milestone projects, you can import the projects into Designer
3.5 (File > Import > Project from File System). Be sure Copy project into the workspace is
selected. Importing the project runs the Converter Wizard, making the project compatible with
Designer 3.5 architecture and placing it under your designated Designer 3 workspace directory
(designer_workspace by default).

3 Click Finish.

The project is stored in a directory structure with the project name as the initial directory
containing files with a .proj and a .project extension. In this example, the project is stored
in the c:\Documents and Settings\Novell User\designer_workspace\Blanstonl
directory on a Windows XP workstation.

Address 5 CADocuments and Settings\Movell User\designer_warkspace\Blanston1

Folders X Mame Size Type

= J Iy CompLiter a | DDocUments File Folder

B ) [SModel File Foldear
=% DRIVE_C (C) )Toobox File Folder

+- ) del [ project 1KB PROJECT File

+-| ) docsysx [ Blanston Lepra 1KB CPROIFie

=) Documents and Settings [EBlanstonLproj 1KB PROIFie

The project name appears in the Project view. When you select the System Model icon under
the project name, Designer opens the Modeler (an editor) for the new project.

For information on saving a project, see “Section 17.1, “Converting Earlier Projects,” on
page 373”.
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2.3 When You Want to Import a Project

To import a project from an Identity Vault or from the File System, see Chapter 11, “Importing into
Designer,” on page 225.

2.4 When You Want to Disable a Project

You can disable and enable projects from the Project view.

1 To disable a project, right-click a project in the Project view and select Disable Project.

awn Cutline

ERIEYE|ansion00 1

s Mew 4
=D gpen with ’
1= Blang
s Import 4
= 0 JB Export Project
== Blans
SE &9 Refresh
&& D|[f3 copy Project...
FE move.

= Rename...

@ Check In...
=8 Blang W Update. ..

i s
CED K Delete

= Properties

Once disabled, the project is not accessible from any of the other views, including the Version
Control view, and the project is converted to a placeholder in the Project view.

T BlanstonQo 1
1= Blanstonoz

2 To enable the project, right-click the project placeholder in the Project view and select Enable
Project. The project is again accessible in the other views.
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Creating a Model

The Designer Modeler lets you create and manipulate a model of your Identity Manager
environment within a Designer project. This section discusses the following topics:

*

*

Section 3.1, “Basic Tasks,” on page 27

Section 3.2, “Accessing the Modeler,” on page 28

Section 3.3, “Selecting a Modeling Mode,” on page 29

Section 3.4, “Working from the Palette,” on page 36

Section 3.5, “Copying and Pasting,” on page 41

Section 3.6, “Moving Items,” on page 45

Section 3.7, “In-Line Editing,” on page 46

Section 3.8, “Tooltips and Toolbar,” on page 46

Section 3.9, “Organizing by Domain Groups,” on page 47

Section 3.10, “Connecting Applications,” on page 54

Section 3.11, “Aligning and Laying Out Components,” on page 61
Section 3.12, “Editing Multiple Objects,” on page 68

Section 3.13, “Modeling Active Directory Domain Controllers,” on page 68
Section 3.14, “Saving Your Model,” on page 70

3.1 Basic Tasks

This section lists basic tasks for creating a model after you have created a project.

1

In Designer, select a project.

If your project doesn’t appear in the Modeler, open the Project view (Window > Show View >
Project), expand the project, then double-click System Model.

Drag an Identity Vault object from the palette to the Modeler.

When you create an Identity Vault or server in Designer 3, the default Identity Manager engine
version is 3.6. Designer assumes that the Identity Vault has 3.6 capabilities. You can
successfully deploy and run 3.6 projects only on Identity Manager 3.6 servers.

You can easily change the engine version by selecting a version from the Server DN field.
However, selecting earlier engine versions takes out any later version capabilities and features
from within Designer.

Before you deploy a project, you must associate a server with the Identity Vault. You do this
through the Identity Vault properties. See Section 4.3, “Configuring Identity Vaults,” on
page 74.

You can add multiple Identity Vaults.
Configure a driver set.

Each Identity Vault contains a driver set. See Section 4.5, “Configuring Driver Sets,” on
page 78.

Creating a Model
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4 Add applications.

Drag applications from the palette to the Modeler view. See Section 4.11, “Configuring
Application Properties,” on page 120.

5 Configure drivers.

Driver connections are automatically drawn between the application and the driver set. See
Section 4.7, “Configuring Drivers,” on page 87.

6 Develop and customize your model.

Develop according to what you planned in Planning Identity Solutions (http://
www.novell.com/documentation/designer30/designer_intro/data/gsplanning.html) in the
Understanding Designer for Identity Manager.

7 Save your model (design).
Do one of the following:
+ From the main menu, select File > Save (or Save All).
+ From the main menu, select File > Close > Yes.
+ Click the X in the Modeler’s tab, then select Yes.

3.2 Accessing the Modeler

The Modeler space is the main working area. It is an editor where you design projects. It is the main
work space and primary means of interacting with Designer. All other editors, views, and dialog
boxes support and provide functionality for the Modeler.

Figure 3-1 Designer’s Modeler

@ Designer - Project2/ProjectZ.proj - Designer, E H'EI”'X‘
File Edit Wew Projct Tools Live Model Window Help
NrHalgxdvLBE @i B it £ | @) Desigrer |
= Praject | o= Outine 52 ‘%5 Navigatar = O/ *projectz - Developer 23 i 5AP-HR Filter =g
(u|gF @ =l & | Modeler T00% B2y =3 Palette b
— [y Select
E [ Project2 ~ ~ |k
=[@] Tdentity vaul: 0 i Marquee
s Connection
@ server
=% Driver Set T Identity Yault
i mew Library 60 Driver Set
© Driver [ Domain Group
G;f Driver 2 [ Database
@) Driver 3 =
& Driver 4 —
©) Driver 5 (= E-Mal
=) AR Palet | ETEEBIISe
%) Publisher (= Identity Assurance
&, subscriber = MainFrame
Q SAP-HR Filker (= Message Bus
M= Mapping Policy
TH password(Sub)-Pub Emal MotFicati (= Op System
& Input Transform Styleshest L= PBX
KE ottt Transform Shilesheek vl (== Setrvice
4 | ] (= Tool >
Views =
' Provisioning |l B Dataflow ©2 a [ pelimited Taxt
[ Fan-out
G & El & [ @eneric App
@ CommExec [E| HTTR Server
© sroup [ 50ar server
@® organizational Rals b |
@® organizational Unit
® user
v
B ko
[show effective Flows & | 3] [lssProvisioning
&) Developer | [3 Architect | % Dataflow | [EZ] Table
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To get started, you create a project and drag items from the palette into the Modeler space. Then you
arrange and configure the items.
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If the Modeler doesn’t display:
1 Expand a project in the Project view.

1= Project &2 =2/ T8

== Designer
=I[= Documents
= Generated
=I-[= Toolbox

== DocumentGenerator

@ Styles
+-1=F Enforcerl
+-1=F Project?

If you haven’t yet created a project, create one.
2 Double-click System Model.

3.3 Selecting a Modeling Mode

Section 3.3.1, “Developer Mode,” on page 30
Section 3.3.2, “Architect Mode,” on page 31
Section 3.3.3, “Dataflow Mode,” on page 35
Section 3.3.4, “Table Mode,” on page 36

*

*

*

*

The Modeler has tabs along the bottom, so that you can switch among different modeling modes.
The modes have different advantages, depending on the task you’re trying to do and the role that you
are acting in.

Figure 3-2 Modeler Modes

& Developer | [ Architect ?" Dataflow | EZ| Table

The modes are synchronized with each other with selection, data, and content. They are also
synchronized with the Outline View and Thumbnail view.

As you switch modes in the Modeler editor, the editor tab at the top displays the mode that you are
in. Also as you switch modes in the Modeler editor, Designer also remembers and restores to the
Modeler page you were last on when you close and re-open a project. This helps you stay in the last
mode you were last in.

By default, the theme preference is different for each mode. To configure each theme independently
in the Modeler preferences:

1 Click Window > Preferences then select Novell > Identity Manager > Modeler.
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2 Click the Themes tab.
3 Select a theme, then click OK.

3.3.1 Developer Mode

Figure 3-3 Developer Mode
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Use Developer mode to do all low-level operations with driver sets, drivers, policies, and
applications. This mode lets you manage all of the visual elements and configuration details that you
need to fully build and deploy an identity solution.

In Developer mode, the palette organizes the applications and systems into categories. You can
customize them to show up as one alphabetical list by using the Modeler Preferences. See “Palette
Page” on page 471.

Working with Labels

Figure 3-4 An Application’s Label

My SLILY
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By default in both Developer and Architect modes, labels appear under application icons in the
Modeler. They also appear above Identity Vaults in Architect mode.To configure these labels to not
appear, use the Modeler Preferences. See “Modeler” on page 469.

3.3.2 Architect Mode

Figure 3-5 Architect Mode
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Use the Architect mode to work at a design level for your projects. Because the design level doesn’t
show drivers, driver sets, or policies, you focus more on systems. This mode helps you do large-
scale design, which is more intuitive to architects and business strategists.
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It is quite likely that you will start in this mode when you begin each project. You will probably
spend time putting together an accurate diagram of your enterprise as you consult with various
people throughout your organization. As you do so, you should capture key information on each
system, such as the owner, contact information, machine environment, software versions, and
authentication credentials. As you go through this process, you will also define your project
requirements, start thinking about your data, and capture that information in your project.

When the time is right, you can switch to the Developer mode and delve into the technical details of
building a working solution. Depending on the size of your project and the makeup of your team,
you could have architects and designers build high-level solutions with Designer in the Architect
mode, and then send the project to identity developers who understand the details of writing policies
and configuring systems. They can share the same project.

In Architect mode, you can connect any design element with any other design element, application,
image, or ldentity Vault. The connecting lines enable you to express any relationship, making
Architect mode a general-purpose, high-level business modeler. The Architect-mode lines don’t
display when you switch to the Developer mode.

NOTE: When you add icons representing driver applications through the Architect mode, you will
need to configure those drivers in the Developer mode. Once you have added the necessary drivers
and switch to the Developer tab, right-click the line between the driver icon and the driver set, then
select Run Configuration Wizard.

The design elements have connectivity information tied to them. You can use design elements to
perform live operations or to remotely control other elements that are in your environment but are
not necessarily included in your Identity Manager infrastructure.

When using the Architect mode, you should be familiar with the following:

+ “The Palette in Architect Mode” on page 32
+ “High-Level Data Flows in Architect Mode” on page 33
+ “Tasks” on page 34

The Palette in Architect Mode

In Architect mode, the palette lists all applications in one folder and design elements in another
folder. The Architect Modeler view now contains all of the graphical modeling tools that are present
in the Developer Modeler view. This includes:

+ Rulers

*

Snap-in guides

*

Alignment hints
Grid
Snap-in movement

*

*

The Graphics folder has an Image icon. When you drag this icon to the Modeler, Designer displays a
generic graphic:

Figure 3-6 The Image Icon
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To edit the properties of this icon:

1 Right-click the icon, then select Properties.

@ Properties for Image |:|@@

type filker text Image S
Irnage
Conneckivity Mame: | Image
[Restore Qefaults] [ Apply ]
[:‘:7:] [ [o]'4 ] [ Cancel ]

2 Inthe Name field, replace Image with a caption.
3 Browse to and select a replacement graphic, then click OK.
You might need to reduce the size of the graphic before importing it.

After the image is in the Modeler, you can drag it, change it, connect lines to it, align or distribute it,
or delete it.

High-Level Data Flows in Architect Mode
To set data flows in Architect mode:

1 Right-click the line between an application and an Identity Vault.

2 Select Show Dataflow View.

3 Right-click the line again and select Dataflow.

4 Specify synchronization and notification events, then click OK.
This option is used the same way as in Developer mode except that in Architect mode, Designer
automatically configures all the details (schema, filters, and mapping policies) for you. You won’t

see the Data Flow Wizard for these details. Before deployment, you can edit the details by using
Developer mode.
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Tasks
You can perform the following tasks in Architect mode:

+ Straighten connections (edges). See Section 3.11, “Aligning and Laying Out Components,” on
page 61.

+ View Password Sync icons and edit synchronization. See Section 7.6, “Integrating Passwords,”
on page 191.

+ Auto-connect eDir-to-eDir.

+ When deleting the driver line, view a prompt to confirm drivers being deleted.
+ Display design elements in your model.

Open the Design Elements folder on the palette, drag design elements onto the Modeler, and
connect the design elements.

Figure 3-7 Items in the Design Elements Folder
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3.3.3 Dataflow Mode

Figure 3-8 Dataflow Mode
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The Dataflow mode launches the Dataflow Editor, so that you can see all of the filters that control
how data flows between the connected systems and Identity Vaults. In the Dataflow Editor, you can
right-click an eDir-to-eDir connection and have the option to remove the connection.

The Dataflow mode is synchronized with the Modeler and with the Outline view when you add,
delete, change, or synchronize objects. Also, you can see how passwords flow from each server. See
Chapter 7, “Managing the Flow of Data,” on page 167.

The Dataflow toolbar enables you to perform the following actions:

+ Deploy driver filters for all drivers in the Dataflow view
+ Refresh the Dataflow view’s Ul screen
+ Save the current Dataflow view to an HTML file. You can select a directory to put the file.

+ Save all of the filtered views (Notify, Sync, Reset, Password Sync) to an HTML files. You can
select a directory to put the files.

+ Go up and down to the Identity Vaults

+ Create a new Identity Vault

+ Add an application driver for a connected system

+ Filter Identity Vaults and application drivers out of the Dataflow view
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The pull-down menu allows you to perform the following:

+ Expand all containers

+ Collapes all containers

+ Launch Dataflow preferences
+ Get help

The Architect and Modeler views contain the same pull-down menu with the same functionality.

3.3.4 Table Mode

Figure 3-9 Global Table Editor
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Table mode provides a Global Table editor, which lists all design elements in the project. You can
scroll this table to quickly scan essential information, such as the element’s type, the container
where the element resides, and details, such as an element’s size, or driver and serverinformation.
You can efficiently find all items of a particular type and edit their settings.

To edit an entry in the table, double-click a line, or right-click a line and select either Open With,
then an editor. You can also right-click a line, select Open, and Designer launches the editor that has
been associated with the action. For example, drivers open their Properties page, policies open in the
Policy Builder, etc.

When you select an entry in the table, Designer synchronizes the selection with the Outline view, so
that you can view the selection’s container.

To sort the lists, click a column header.

3.4 Working from the Palette

+ Section 3.4.1, “About the Palette,” on page 37
+ Section 3.4.2, “Palette Operations,” on page 37

*

Section 3.4.3, “Using Generic Applications,” on page 38
Section 3.4.4, “Fly-Out Palette,” on page 38
Section 3.4.5, “Resizing the Palette,” on page 39

*

*
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*

Section 3.4.6, “Docking the Palette,” on page 39

*

Section 3.4.7, “Arranging Folders and Applications,” on page 40

*

Section 3.4.8, “Changing the Layout,” on page 40

*

Section 3.4.9, “Keyboard Support for the Palette,” on page 41

3.4.1 About the Palette

Figure 3-10 Designer’s Palette
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The palette is the source of all of the items that you add into the Modeler. To build a model, do one
of the following:

+ Drag and drop items from the palette to the Modeler space. When you drag and drop an
application, it auto-connects to the closest driver set.
+ Click an item in the palette, then click in the Modeler space where you want the item to go.

3.4.2 Palette Operations

Table 3-1 Palette Operations

Operation Description

Connection Connects items in the Modeler space.

Identity Vault Places an Identity Vault in the Modeler space.

Driver Set Places an eDirectory Driver Set object in an Identity Vault. All applications
that you want to connect use a Driver Set object as a hub between the two
applications.
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Operation Description

Group Lets you group and organize items in the Modeler space.

Folders Applications are organized within folders or drawers. To open or close a
folder, click it. To hold the folder in place and make sure that it doesn't fully
collapse (even when you open other folders), click the pin. Once the Palette
is full unpinned folders automatically close when you open another folder.

Applications The various applications that you can connect are grouped into folders by
type. You can drag and drop these applications to the Modeler space and
begin editing them. The Modeler automatically adds a connecting line, which
represents a driver.

Scrolling Arrows Small directional arrows. If a folder has many items, or if the screen area is
restricted, scrolling arrows appear. To scroll through he contents of a folder,
click the arrows.

3.4.3 Using Generic Applications
Figure 3-11 The Generic App Option on the Palette
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Scenario: A Generic Application. Fridrik creates a project with his own items and graphics, in his
own version of Designer. He transfers the project to you, but you are using a different version of
Designer, which doesn’t understand those items. Your version renders the transferred objects as
Generic applications.

3.4.4 Fly-Out Palette

Figure 3-12 The Palette’s Control Arrow
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To hide the palette, click the small control arrow on the palette. The palette collapses.

To open the palette again and keep it open, click the arrow.
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To temporarily open the palette again, hover the cursor over the collapsed palette, below the control

arrow. The palette quickly expands. This is fly-out mode.

To change the palette from fly-out mode, click the control arrow again. The state persists and is

restored the next time you run the application.

3.4.5 Resizing the Palette

1 Click the palette’s thick border that faces the Modeler space.

2 Drag the line.

The size persists and is restored the next time you run the application.

3.4.6 Docking the Palette

To dock the palette on the left or right of the Modeler space:

1 Click the top palette header.
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2 Drag the palette to the desired location.

The location persists and is restored the next time you run the application.
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3.4.7 Arranging Folders and Applications

By default, applications are placed in folders.
To arrange applications alphabetically instead of in folders:

1 Click Window > Preferences > Novell > Identity Manager > Modeler > Palette.

bype Filker bexk Palette

General
[=)- Designer Far 100
Configuration
Document Generakion (*) arrange applications in an alphabetical lisk
Entitlements
iManager
ImportDeploy
Language
= Modeler
Dataflow
Palette
Palicy Builder

Developer-mode palette organization
() Arrange applications in Folders

2 Select Arrange applications in alphabetical list, then click OK.

3.4.8 Changing the Layout

1 Right-click the palette.

1 Palette

[:3 Select

r-a
L Marques

s Connection

@ 1 Layouk Columns

ot e arge lons
Icons Onl

[ Settings... ¥

[~ Database

Details

2 Select Layout.
3 Select an option.

Setting Description

Layout: Columns Displays folders and applications in columns.

Layout: List Arranges folders and applications in a list.

Layout: Icons Only Removes descriptive labels.

Layout: Details Briefly describes palette items.

Use Large Icons Toggles the size of icons used for applications.

Settings Enables you to set the layout and icon size in
one dialog box. Controls how folders (drawers)
behave.
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3.4.9 Keyboard Support for the Palette

Table 3-2 Shortcut Keys for the Palette

Keystroke Description

Left-arrow Collapses an open folder. The focus must be on the folder, not the
application.

Right-arrow Opens a collapsed folder. Moves into an open folder.

Up-arrow Moves up to the next folder.

Down-arrow Moves down to the next folder.

3.5 Copying and Pasting

Section 3.5.1, “Copying Applications,” on page 41

*

*

Section 3.5.2, “Copying a Driver Set,” on page 42

*

Section 3.5.3, “Copying an ldentity Vault,” on page 43

*

Section 3.5.4, “Copying a Domain Group,” on page 44

*

Section 3.5.5, “Copying between Editors,” on page 44

3.5.1 Copying Applications

Figure 3-13 Applications to Copy

You can copy and paste the following within the same editor or to another editor:

+ Applications, including custom applications
+ Disconnected applications
+ Driver icons

1 Select an application or driver icon.
2 Press Ctrl+C, then Ctrl+V.
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The copy and paste operations are also accessible from the Clipboard context menu. (Currently, they
aren’t accessible from the main menus.)

When you copy an application in the same editor, Designer copies all of the application’s attributes,
and copies all subelements. Therefore, all drivers that the application is connected to are copied, and
all policies that the drivers contain are also copied. The new application defaults to connect to the
same driver sets that the previous application connected to.

To copy an application to a different driver set (in the same editor or in another editor):

1 Select the application.

2 Press Ctrl+C.

3 Select the target driver set that the application will connect to.
4 Press Ctrl+V.

If you copy and paste an application without selecting a target driver set, Designer makes a copy and
connects it to the current driver set.

You can select multiple applications and then copy and paste them.

3.5.2 Copying a Driver Set

Figure 3-14 Driver Sets

You can copy and paste driver sets within the same Identity Vault or to another Identity Vault in the
same editor or in another editor.

1 Select a driver set.

2 Press Ctrl+C, then Ctrl+V.
When you copy a driver set in the same editor, Designer copies all of the attributes of the driver set,
including the following:

+ All drivers that the driver set is connected to

+ All policies that the drivers contain

+ All target applications
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To copy to a different editor:

1 Select a driver set.
2 Press Ctrl+C.

3 Select the target Identity Vault in the other Modeler editor where you want the driver set to be
copied to.

4 Press Ctrl+V.

By default, the new driver set is created in the same Identity Vault as the one that it was copied from.
However, if you select another Identity Vault, the driver set is copied there.

After you copy and paste, you might need to move the pasted objects to a better location so that they
don’t cover up an existing object. To do this, leave the objects selected after you paste them, then
move them. Another way to easily select objects:

1 Right-click a driver set.

2 Select Select All Connected Applications.

3 Move one of the selected applications.

All connected applications move together.

When you copy a driver set, it has the same settings, except for the selected servers, which are blank.
This exception occurs because the Identity Manager engine does not allow more than one driver set
on an ldentity Vault to be associated with the same server. Therefore, you need to set up the servers

for the new driver set. If you copy an Identity Vault, Designer copies the driver sets. The new driver
set has the same server settings set up for you.

You can select multiple driver sets and then copy and paste them. To copy and paste multi-driver
connections, you must copy the driver set or Identity Vault that contains them. In Designer 2.0, if
you copy the application that has a multi-driver connection, the application and only one of its
drivers are copied.

3.5.3 Copying an Identity Vault

You can copy and paste Identity Vaults within the same editor, to another editor in the same Modeler
space, or in a specific Domain Group.

1 Select an Identity Vault.

2 Press Ctrl+C.

3 Select nothing or the target Domain Group (in the same editor or another) where you want the
Identity Vault to be copied to.

If you select nothing, the new Identity Vault is copied to the right of the previous ldentity Vault
in the current editor.

4 Press Ctrl+V.

The new Identity Vault appears to the right of the previous Identity Vault and is the same size as the
one that it is being copied from.

When you copy an ldentity Vault, Designer copies all of the elements of the Identity Vault. The
elements include servers, e-mail templates, driver sets, and connected applications.

You can select multiple Identity Vaults and then copy and paste them.

Creating a Model 43



3.5.4 Copying a Domain Group

You can copy and paste Domain Groups within the same editor or to another editor in the same
Modeler space or in a specific Domain Group.

1 Select a Domain Group.

2 Press Ctrl+C.

3 Select the location for the new Domain Group.

If you select nothing, the new Domain Group is copied to the right of the previous Domain
Group in the current editor.

4 Press Ctrl+V.

The new Domain Group appears to the right of the previous Domain Group, and is the same size as
the one it was copied from.

When you copy a Domain Group in the same editor, Designer copies all of the attributes of the
Domain Group. However, Designer doesn’t copy all subelements.

You can select multiple Domain Groups and then copy and paste them.

3.5.5 Copying between Editors

To easily copy and paste between two editors:

1 Using the Project view, open two projects.
One project is active. The second project’s tab displays at the top of the Modeler.
2 Close the palette by clicking the control arrow on the palette’s title bar.

3 Click the second project’s tab and drag it to the Modeler’s right border.

The tab changes to a folder icon until it arrives near the border, where the folder changes to an
arrow.

4 Release the mouse.
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5 Copy items from one editor to the other.

3.6 Moving Items

After an item is in the Modeler space, you can move it by dragging it to a new location. The Modeler
prevents you from placing objects where they don’t belong. For example, you cannot move a driver
set out of an Identity Vault to the Modeling space, or drop an application inside of an Identity Vault.
You can always drag objects into a Domain Group, or drag a driver set from one vault into another.

If you drag a driver set into an Identity Vault, the Identity Vault automatically grows or shrinks to fit
the driver set, so you don’t need to manually resize the vault. This behavior can be turned on or off
in Preferences. See “Modeler” on page 469.

Figure 3-15 Example Driver Sets in an Expanded Identity Vault
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3.7 In-Line Editing

Figure 3-16 An In-Line Edit
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To edit the names of objects, do one of the following:

+ Select the item, press F2, then edit the label.
+ Double-click the item, then edit the Name field.

You can do an in-line edit for any type of item in the Modeler, including the driver lines.

3.8 Tooltips and Toolbar

As you mouse over objects in the Modeler, a tooltip appears with the name of the object.

Figure 3-17 A Tooltip

The Modeler also provides a toolbar.

Figure 3-18 The Modeler Toolbar
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The Modeler toolbar enables you to quickly find often-used features:

+ Search

+ Find adriver’s status (also available from the Live menu when you select a driver set or Identity
Vault)

+ Start, stop, or restart a driver (also available from the Live menu when you select a driver set or
Identity Vault)

¢ Clear all items
+ Save a shapshot of the model
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The pull-down menu allows you to perform the following:

*

Expand all containers

*

Collapes all containers

*

Launch Modeler preferences

*

View demos on how to use the Designer
Get help

*

The Architect and Dataflow views contain the same pull-down menu with the same functionality.

3.9 Organizing by Domain Groups

+ Section 3.9.1, “About Domain Groups,” on page 47

+ Section 3.9.2, “Key Features,” on page 48

+ Section 3.9.3, “Creating a Domain Group,” on page 48

+ Section 3.9.4, “Minimizing (Collapsing) Domain Groups,” on page 50
+ Section 3.9.5, “Restoring Domain Groups,” on page 51

+ Section 3.9.6, “Maximizing Domain Groups,” on page 51

+ Section 3.9.7, “Auto-Placement of Neighbors,” on page 51

+ Section 3.9.8, “Grouping into a New Domain Group,” on page 51

+ Section 3.9.9, “Ungrouping a Domain Group,” on page 52

+ Section 3.9.10, “Clearing Contents,” on page 53

+ Section 3.9.11, “Changing a Domain Group Icon,” on page 53

+ Section 3.9.12, “Keyboard Support for Domain Groups,” on page 54

3.9.1 About Domain Groups
Figure 3-19 The Domain Group Option on the Palette
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Domain Groups enable you to organize your model into logical groupings that help to keep your
diagram clean. Domain Groups have no technical function, and they have no impact on how items
and relationships are stored in the Identity Vault. This option is just a tool to help you better organize
and view items in the Modeler.
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Using Domain Groups is the key to modeling your entire enterprise, no matter how large it is. You
can create a model that is manageable, useful, and logical, according to how you want to organize
and diagram your enterprise.

Figure 3-20 A Domain Group in the Modeler
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3.9.2 Key Features

+ Change a group name through the Properties view.
+ Drag and drop items in and out of groups.

+ Minimize or restore groups.

+ Move everything in a group.

+ Remove everything in a group.

+ Nest groups within groups (no limit).

+ Resize groups. A minimum size is enforced.

+ Ungroup. Remove the group but leave the children.

3.9.3 Creating a Domain Group

1 Drag and drop a Domain Group from the palette to the Modeler space.
2 Organize items inside Domain Group items.

To add another Domain Group, drag and drop one from the palette.
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To add an Identity Vault, do one of the following:

+ Drag an Identity Vault from the palette.
+ Right-click in the Domain Group, then select New > Add Identity Vault.

The Add Server to Identity Vault dialog box appears. If you select Specify a Server, Designer
provides a dialog box that enables you to select an eDirectory server or specify a server
manually.

To add a driver set:

1 Right-click inside an Identity Vault.
2 Select Add Driver Set.

To add an application:

1 Right-click a Driver Set object.
2 Select Add Connected Application.

The application is added to the right of the right-most connected application. If this is the first
application, it is placed under the driver set.

The application defaults to a generic application type. To change the type:

1 Right-click the application, then select Properties.
2 Select a different application, then click OK.

When you add selected items to a Domain Group, the Domain Group expands.

Figure 3-21 A Domain Group
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If you move an item to the edge of the Domain Group, the boundaries expand, so that the items
remain inside the Domain Group. You can drag an item from the Domain Group to remove it from
the group.

You can have nested domains. If you expand a nested domain, the outer (hosting) domain auto-
increases in size. You aren’t required to manually resize parent domains. By expanding, the hosting
domain displays the nested domain, so that the nested domain isn’t cut off.

3.9.4 Minimizing (Collapsing) Domain Groups

To minimize a Domain Group, click the Minimize = button. When a Domain Group is
minimized, it defaults to a random icon. You can use Properties to change the icon. (See “Changing
a Domain Group Icon” on page 53.) The icon and minimized state of the group are saved in the
Project file.

When a group is minimized, you can’t see its contents, nor can you drag new items into the group.
However, you can move, rename, or delete it.

When you minimize a group, lines that were connected to items in the group now connect to the
group. This functionality enables you to see that there is a relationship with items in the group and
items outside the group. Depending on your objects, their relationships, and state of other related
groups, multiple lines might collapse into one line.

Figure 3-22 A Collapsed Group
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When you expand the group, the lines are moved back to the actual items they connect with. This
functionality works for any level of nesting of groups.
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3.9.5 Restoring Domain Groups

To restore the Domain Group to its original size, click the Restore & button.

3.9.6 Maximizing Domain Groups

To maximize a Domain Group, click the Maximize n button. The group expands to a much larger
size. To return it to the original size, click the Restore button.

You can maximize only first-level groups. For inner groups, the Maximize function is disabled.

3.9.7 Auto-Placement of Neighbors

To push or pull the neighboring items when you expand or contract Domain Groups, hold down the
Ctrl key while you expand or contract the Domain Group. Any item that is to the right or below a
Domain Group is affected.

3.9.8 Grouping into a New Domain Group

1 Inthe Modeler, select multiple items.
2 Right-click, then select Add to Group.
The Modeler creates a new Domain Group and adds those items, preserving their relative spacing to

each other. This process removes the items from wherever they previously existed and places them
in the proper area in the new group.

The following figure illustrates two Applications that have been added to a new Domain Group and
removed from their previous groups.
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Figure 3-23 Grouping into a New Domain Group
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3.9.9 Ungrouping a Domain Group

Figure 3-24 Ungrouping a Domain Group
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To ungroup a Domain Group, right-click it, then select Ungroup.

This process removes the Domain Group but leaves all contents where they are, so that they won’t
be deleted. This is just a way to ungroup the items. Depending on what level you are in the Modeler,
the ungrouped items are automatically added to the host group or to the main Modeling space.

3.9.10 Clearing Contents

Figure 3-25 Clear All Items
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To remove all contents from the Modeler, click Model, then select Clear All Items.
To remove all contents from a Domain Group, right-click, then select Clear Domain Contents.

Designer prompts you before clearing the Modeler space.

3.9.11 Changing a Domain Group lcon

1 Right-click a Group Domain item in the Modeler, then select Properties.
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2 Browse to and select an image (for example, finance.png).

Icons for Domain Group components reside in the Group directory in the Modeler plug-in
directory. By default, Designer opens the Group directory.

Designer supports .GIF, . JPEG, .PNG, and Windows .BMP formats. You can add your own
icons to the Group directory.

3 Click Open, then click OK.
The minimized 16x16 version of the image also now appears in the Domain Group title bar.

As you add Domain Group items, Designer randomly assigns icons from the Group directory to the
new Domain Group.

3.9.12 Keyboard Support for Domain Groups

Table 3-3 Shortcut Keys for Domain Groups

Keystroke Description

Alt+Down-arrow Navigates into a Domain Group
Alt+Up-arrow Navigates out of a Domain Group
Delete Deletes the selected items

3.10 Connecting Applications

+ Section 3.10.1, “Automatic Connections,” on page 55

+ Section 3.10.2, “Connection Target Highlights,” on page 55

+ Section 3.10.3, “Automatically Creating Objects,” on page 56
+ Section 3.10.4, “Auto Redraw,” on page 56

+ Section 3.10.5, “Manually Connecting,” on page 56

+ Section 3.10.6, “eDir-to-eDir Connections,” on page 56
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+ Section 3.10.7, “Multiple Driver Connections,” on page 57

+ Section 3.10.8, “Straightening Connections,” on page 58

+ Section 3.10.9, “Reconnecting,” on page 60

+ Section 3.10.10, “Driver Icons,” on page 60

+ Section 3.10.11, “Selected Drivers,” on page 60

¢ Section 3.10.12, “Auto-Layout of Imported Objects,” on page 61
+ Section 3.10.13, “Keyboard Support for Connections,” on page 61

3.10.1 Automatic Connections

When you drag an application into the Modeler space, and the Modeler contains a driver set,
Designer automatically draws a connecting line between the Driver Set object and the application.

When you use the palette’s Connection function to connect an application to an Identity Vault, you
can begin or end your driver line at the Identity Vault. The line automatically connects to a driver set
in an Identity Vault.

If the Identity Vault contains more than one driver set, the Connection function connects the driver
line to the first driver set. This functionality also works for multi-driver connections.

All multi-driver driver lines are bendable. You can lay them out so that the lines don’t overlap at any
angle. Also, you can reconnect multi-driver connections.

If an Identity Vault has multi-driver connections in a Domain Group and you minimize that Domain
Group, a single collapsed line represents all of the multi-driver connections.

3.10.2 Connection Target Highlights

When you drag an application across the Modeler space, the closest Identity Vault and closest driver
set in that Identity Vault are highlighted. The highlights indicate the item that the application will
connect with when you drop the application.

Figure 3-26 Connected Objects

w—s Connection

Tdentity Yault

., Driver Set

| Damain Graup

= Database

[ Directary

[ E-Mail *
@ Exchange
GroupWise

El Motes

= Enterprise

[= Identity Assurance
(= MainFrame

=~ Message Bus

[=- Op System

=L PRY

Creating a Model 55



3.10.3 Automatically Creating Objects

If you drop an application into the Modeler space, and that space has no Identity Vaults, Designer
automatically creates an Identity Vault.

If you add a driver application in the Modeler by right-clicking in the Modeler, then selecting New >
Application, the driver application is now added at the place where you right-clicked. This makes it
easier to locate items in the view.

3.10.4 Auto Redraw

If you move items, lines are automatically redrawn.

3.10.5 Manually Connecting

To manually connect an application to a driver set:

1 Click Connection in the palette.
2 Draw a line between the application and the driver set.

To reconnect an application, select the driver line, then drag one end of the line to another driver set
or application.

The drag gesture gravitates the line towards the nearest connectable point. This functionality helps
you know what you can connect to and where you can connect the item. If you try to connect to
something that isn’t allowed, the cursor usually indicates so, or nothing happens when you drop the
item.

3.10.6 eDir-to-eDir Connections

Figure 3-27 eDir-to-eDir Connections

56 Designer 3.5 for Identity Manager 3.6 Administration Guide



An eDir-to-eDir connection is a special type of connection. It is used frequently in Identity Manager
environments. This connection is a way to configure two eDirectory drivers to communicate directly
with each other. (No other drivers are able to communicate directly with any other type of driver.)
This type of connection is most commonly used for synchronizing a local directory tree with a
Metadirectory Identity Vault.

To create an eDir-to-eDir connection, do one of the following:

+ Drag a line between two Identity Vaults
+ Drag a line between two driver sets

When you connect a line between two eDirectory applications, the line automatically turns into an
eDir-to-eDir connection. See the illustration in Section 7.2.6, “Viewing an eDir-to-eDir Driver,” on
page 180.

To disconnect an eDir-to-eDir connection, right-click an eDir item, then select Disconnect eDir-to-
eDir. Designer creates two new eDirectory applications and redirects each driver to its respective
application. A new driver is not created. No data is lost. Designer keeps the same drivers.

If you delete one side of an eDir-to-eDir connection, Designer converts the remaining half into a
regular driver connection to an eDirectory application.

3.10.7 Multiple Driver Connections

To connect more than one driver from a driver set to an application:

1 Select Connection in the palette.
2 Connect the driver set and the application again and again.

Each time you connect, a new line is added. All lines are bendable, so that the lines don’t overlap. To
get the model to look optimal, you probably need to move the application slightly from its default
position.

You can also connect more than one driver to a single application. This actually causes the
application to act as a hub. Each driver can connect to and authenticate to the application or system
the same or differently, depending on your needs. Each driver can access the same part of the
application or system or different parts (for example, different tables in a database). The Modeler
lets you diagram a layout according to your needs.
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Figure 3-28 Multi-Driver Connections
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3.10.8 Straightening Connections

To straighten connecting lines:

1 Press Ctrl, then select one or more items in the Modeler.

58 Designer 3.5 for Identity Manager 3.6 Administration Guide



L—= LOENCICY XS5UFance

- = == MainFrame

S E == Message Bus
0 e - Unida Change Lacation

——— Show Subsystems
dr-UUC

b =3 Add to Group

?’ Show Dataflow View
Drakaflow 4

& Remaote Contral Desktop
@; Discover Domain Controllers

ﬁ Manage Application Schema. ..

Document Selection. ..
Criver »
¥ Delete
2 Right-click, then select Straighten Connections.
What is straightened depends on what you select:
Table 3-4 Straightened Connections
Selected Item What Is Straightened
A driver That driver’s line
An application The connecting driver’s line
An Identity Vault All lines that originate from that driver set in that
Identity Vault
A Domain Group Everything in the Domain Group
A project (selected by clicking the Modeler’s Everything in that project

background)

Lines are straightened only if they are less than 20 pixels from a north, west, south, or east
alignment. The intent of this operation is to quickly nudge lines that are almost straight, so that they
become perfectly straight.

This nudging removes the tedium of meticulously dragging items into perfect alignment and being
concerned with the pixels. If a line isn’t almost straight, it is left alone. In fact, the Straighten
Connection operation is disabled unless the selected items qualify to be straightened. If some of the
selected items qualify but others don’t, the operation is still enabled, but only eligible lines are
straightened.
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3.10.9 Reconnecting

To reconnect components, do one of the following:

+ Drag the end of a line (driver) from one application to another.
+ Drag the end of a line (driver) from one driver set to another.

3.10.10 Driver Icons

Table 3-5 Driver Icons

Icon Description

[3 A driver. The entire line between a driver set object and an application represents
a driver.

§-] A remote driver.

™ A firewall. Indicates that the driver is communicating across a firewall.

The following figure illustrates these icons.

Figure 3-29 Driver Icons
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To see, turn on, or turn off driver icons:

1 Right-click a driver line.
2 Select an option (for example, Mark as Firewall) to turn on or turn off.

3.10.11 Selected Drivers

As you move the mouse over a driver, the line thickens so that it is more obvious. You can click and
interact with this line.
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3.10.12 Auto-Layout of Imported Objects

When you import objects from the directory, they are automatically laid out, connected with lines,
and assigned an icon that matches objects and relationships as closely as possible.

For example, if you import a Driver Set object, Designer imports all of the drivers and connects
them with lines. Also, each driver points to an application icon. Application icons include the
following:
+ The exact Application icon (for example, Avaya or PeopleSoft)
+ The image stored on the driver
The image is embedded in a square application icon.
+ A generic application icon

If no image is stored on the driver, Designer supplies an icon for one of the following
applications:

+ Generic

+ JDBC

+ LDAP
Delimited Text

The auto-layout mechanism uses the layout topology that you have selected. The default is Fan
Out - Bottom. You can customize this setting in Preferences. See “Modeler” on page 469.

*

3.10.13 Keyboard Support for Connections

Table 3-6 Shortcut Keys for Connections

Keystroke Description
/ Navigates to the item’s next connection
\ Navigates to the item’s previous connection

3.11 Aligning and Laying Out Components

+ Section 3.11.1, “Alignment Hints,” on page 62
+ Section 3.11.2, “Using Rulers,” on page 63
+ Section 3.11.3, “Using a Grid,” on page 65
+ Section 3.11.4, “Distributing Applications,” on page 66
+ Section 3.11.5, “Auto-Layouts,” on page 67
+ Section 3.11.6, “Layouts to Use for Imports,” on page 67
Alignments place objects in the same horizontal or vertical plane. Alignments help you see

relationships in your model. You can align or attach items to the left, center, or right of alignment
guides.

When you move the guide, attached items move with it, staying attached in the same relative
positions.

Creating a Model

61



To align components:

1 Press Ctrl, then select more than one item.
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2 Right-click, then select Align.
3 Select an alignment option.

You can also attach an item by dragging it to a guide. After you wait a moment, the guide line is
highlighted, indicating that the item is attached.You can align within the same group but not across
groups.

Guides that you set up are restored the next time that you run Designer. You don’t need to re-create
them.

Also, the alignments and attachments (left, center, or right) are stored in the project on a per-item
basis, so that they are also restored.

3.11.1 Alignment Hints

Horizontal and vertical “hint” lines can be set to automatically show as you drag items into vertical
or horizontal alignment with neighboring items by clicking View > Alignment Hints.
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Figure 3-30 Alignment Hints
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The Alignment Hints feature is off by default. To turn it on, click View > Alignment Hints.

Horizontal and vertical hint lines automatically show as you drag items into vertical or horizontal
alignment with neighboring items.

3.11.2 Using Rulers

To turn on the horizontal and vertical rulers:

1 Click the Modeler space to make it active.
2 Click View > Rulers.
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To create a guide (line), click either ruler.
To anchor items to a guide, drag the items in the model to the line.

To simultaneously move all anchored items, drag the line.
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3.11.3 Using a Grid

Figure 3-31 The Modeler’s Grid
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When the grid is on, the snap-to-grid functionality is on.
To turn grid lines on and off:

1 Click the Modeler, so that the Modeler is the active view.
2 Click View > Grid.

To coerce objects to not align with the grid, temporarily turn off snap-to-grid by holding down the
Alt key. (Linux doesn’t support this functionality.)

To constrain items to north-south or east-west coordinates, press Shift while dragging the items.
To change the grid size:

1 Click Window > Preferences > Novell > Identity Manager > Modeler > Display.
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2 Type avalue in the Grid Width field.

3.11.4 Distributing Applications

Figure 3-32 Distributing Applications
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To equally distribute (space) applications horizontally or vertically:

1 Press Ctrl, then select three or more items.
2 Right-click, then select Distribute.
3 Select a distribution (for example, Vertical).
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3.11.5 Auto-Layouts

Designer ships with a number of predefined layout topologies: circle, half-circle, star, box, and
different fan-out layouts.

Figure 3-33 A Half-Circle Layout

These layouts are set on a per-driver-set basis. Therefore, each driver set can have its own layout.
To select a layout:

1 Right-click a driver set, then select Arrange Applications.
2 Select an arrangement (for example, Fan Out - Left).
If your model has an incorrect layout, the layout options are dimmed.
After you set a layout, applications that you connect will automatically snap into that layout. Certain
connected objects (for example, multi-driver connections, eDir-to-eDir connections, and

applications that are connected but reside in a different Domain Group) are ignored. They aren’t
included in the layout, and they don’t disturb it.

An option on the Arrange Applications submenu on the Modeler’s context menu enables you to
expand or contract the layout arrangement. This option makes all spokes of the layout longer or
shorter when you drag a slider.

3.11.6 Layouts to Use for Imports

To specify what layout to use on new driver sets that you import:

1 Select Window > Preferences > Novell > Identity Manager.
2 Click Modeler > Layouts.
3 Select an arrangement (for example, Half Circle), then click OK.
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3.12 Editing Multiple Objects

You can open multiple objects and edit them at the same time. These objects must be of the same
type (for example, policies).

To find out whether you can edit an object, right-click it. If Edit displays among the menu items, you
can edit that object.

1 In the Outline view, expand the project that contains the objects that you want to edit.
2 Select the objects.
3 Right-click, then select Edit.
4 Edit the objects.
You can copy and paste from one editor to another. Data must be of the same type.

3.13 Modeling Active Directory Domain
Controllers

+ Section 3.13.1, “Configuring a Connection,” on page 68
+ Section 3.13.2, “Discovering Controllers,” on page 69
+ Section 3.13.3, “Information about Domain Controllers,” on page 69

3.13.1 Configuring a Connection

You can configure an LDAP connection to an Active Directory system so that you can discover its
Domain Controllers.

1 Right-click the Active Directory application, then select Properties > Connectivity.

2 Properties for, Active Directory. ‘Ll@@
type Filker bext Connectivity L
General
AD Damain LDAP |y

Administrator
Connectivity Host:
Envvironment Part:

User:

Password:

Restore Defauls Apply

2 Complete the LDAP authentication information.

As you tab from the Host field to the User field, Designer automatically builds a full user
context. You can modify this context.
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3.13.2 Discovering Controllers

1 Right-click the Active Directory application.
2 Select Discover Domain Controllers.

E] 1dentity vault

If Designer finds any controllers, it lays them out and expands the Active Directory application
as a container.

3.13.3 Information about Domain Controllers

Information about each controller is loaded into the Modeler. To view this information, edit the
Domain Controller object and select the AD Domain page.

Figure 3-34 The AD Domain Page

@ Properties for Active Directory

type filter bext AD Domain =l (=
- General
AD Domain i @ This information is currently used solely for documentation purposes, &
Administratar i :

- Connectivity
- Environment

DNS Host: [1 |

Operating System: | |

Operating System Version: | |

Service Pack: | |

Restore Defaults Apply
®

If the LDAP connection information is filled out, you can reread the information from that system
by clicking the Refresh button.
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3.14 Saving Your Model

To save your model, do one of the following:

+ From the main menu, select File > Save (or Save All).
+ From the main menu, select File > Close > Yes.
+ Click the X in the Modeler’s tab, then select Yes.

For more information, see The Project View (http://www.novell.com/documentation/designer30/
designer_intro/data/projprojectview.html) in the Understanding Designer for Identity Manager.
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Configuring Objects in Designer

Designer allows you to easily view, configure, and modify settings for Identity Vaults, driver sets,
drivers, and connected systems.

+ Section 4.1, “Viewing Object Properties,” on page 71

+ Section 4.2, “Configuring a Domain Group,” on page 73

+ Section 4.3, “Configuring Identity Vaults,” on page 74

+ Section 4.4, “Configuring Servers,” on page 77

+ Section 4.5, “Configuring Driver Sets,” on page 78

+ Section 4.6, “Configuring Libraries,” on page 86

+ Section 4.7, “Configuring Drivers,” on page 87

+ Section 4.8, “Configuring Jobs,” on page 116

+ Section 4.9, “Configuring ID Policy Containers,” on page 117

+ Section 4.10, “Configuring ID Policies,” on page 118

+ Section 4.11, “Configuring Application Properties,” on page 120

+ Section 4.12, “Configuring Policies,” on page 125

+ Section 4.13, “Adding Prompts to a Driver Configuration File,” on page 126

+ Section 4.14, “Editing a Notification Template Name,” on page 127

¢ Section 4.15, “Synchronizing Passwords,” on page 127

4.1 Viewing Object Properties

To quickly view or edit properties of items (for example, an Identity Vault or a driver), you can use
the Properties view or a Properties dialog box.

+ Section 4.1.1, “Properties View,” on page 71
+ Section 4.1.2, “Properties Dialog Box,” on page 72
+ Section 4.1.3, “Operations Relating to Properties,” on page 73

4.1.1 Properties View

If the Properties view is open when you select an item in the Modeler, information about that item
displays in the Properties view. You can then quickly view or edit information.
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Figure 4-1 The Properties View
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To open the Properties view, click Window > Show View > Other > General > Properties. For
additional information, see The Properties View (http://www.novell.com/documentation/
designer35/designer_intro/data/projpropertiesview.html) in the Understanding Designer for Identity
Manager.

4.1.2 Properties Dialog Box

The list of property pages in the Properties dialog box is organized alphabetically across Designer
with the exception og the General page, similar to that of Eclipse.

To view or edit properties of items:

1 Open the Properties dialog box by doing one of the following:
+ Double-click an item in the Modeler or in the Outline view.

+ Right-click an item (for example, an Identity Vault) in the Modeler or Outline view, then
select Properties.

+ Select an item, then press Enter.

+ Select an item, then select File > Properties.

+ Select an item, then select Model > [object] > Properties.
The following figure illustrates a driver’s properties page:
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o Properties for 01Domain

type filter text General

General

Driver Configuration
Engine Control Yalues Motes:
GCVsS

Health

iManager Icon

Log Lewvel

Manifest

Mamed Passwords
Reciprocal Atributes
Trace

Mame: O10oman

Sarver Driver Version =
& fabioz.novel 3.5.3

Basic i
Configuration @
File::
Supported Dk
Format:

[Restore Qefaults] l Apply ]

@ [ o' H Cancel ]

2 Edit settings, then click OK to save.

4.1.3 Operations Relating to Properties

Table 4-1 Operations Relating to Properties

Operation Description

Open the Properties view Click Window > Show View > Other > General > Properties.

Open the Properties dialog box  Double-click an item, or right-click, then select Properties.

Edit settings You can edit the settings of any item selected in the Modeler or
Outline view.

View a server’s properties In the Outline view, right-click the server icon, then select Properties.

Save to memory or disk When you click Apply or OK in a properties dialog box, changes are

committed to memory. However, changes are not saved to disk
unless you select File > Save.

4.2 Configuring a Domain Group

To view or change a domain group’s settings, double-click the domain group.
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Figure 4-2 The Domain Group Property Page
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1 To change the domain group’s icon, click Browse, then navigate to and select an image file.

By default, the Browse button opens the icons/group folder in the
com.novell .designer.core plug-in. The default image selected is administrative.png.
To select a different image, double-click it.

Click Apply.

To change the name of the domain group, edit the Name field.
Add details in the Notes pane.

Click OK.

The image (for example, administrative.png) appears to the left of the domain name in the
Modeler.

ga b~ 0N

4.3 Configuring Identity Vaults

To view or change an Identity Vault’s settings, double-click the ID vault object in the Outline view
or the Modeler.
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Figure 4-3 ldentity Vault Properties
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The Identity Vault Properties page has three options. In addition, you can configure a hostname in

the hosts file.

+ Section 4.3.1,
+ Section 4.3.2,
+ Section 4.3.3,
Section 4.3.4,
Section 4.3.5,

*

*

“Configuration Settings,” on page 75
“Administrator,” on page 76

“Server List,” on page 76
“iManager,” on page 76

“Local Hostname,” on page 77

4.3.1 Configuration Settings

Table 4-2 Configuration Settings for an Identity Vault

Field Description

Vault name The name of the Identity Vault object. The default is Identity Vault.

Host The eDirectory host where you plan to log in and deploy.

Username The eDirectory username that has sufficient rights to make changes to
objects associated with this deployment.

Password The password for the above user.
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Field Description

Save password Saves the password permanently, so you are authenticated into this
Identity Vault each time you open Designer. If you use this option, the
password is saved locally in Designer’s file system and is not secure.

If you do not select this option, the password is remembered only until
you close Designer.

Test connection Selecting this button allows the user to create, or, if a connection is
unresponsive, to re-create a connection to the Identity Vault. If a
connection has not been established to the Identity Vault, the button
displays Test connection. After a connection is established, the button
displays Refresh connection.

Deploy context The default DN container assigned to all driver sets that are
associated with this Identity Vault. If you specify a DN container on the
Driver Set object, that setting takes precedence over the default
setting.

4.3.2 Administrator

The Administrator option is divided into three sections. Entering information in these sections is
optional.

+ Personal Information: Lets you enter information specific to the Identity Vault, such as
Name, Title, Department, and Location.

+ Contact Information: Lets you enter information such as Email, Phone, Cell Phone, Pager,
and Fax.

+ Notes: Allows you to type any reminders you might need for future reference.

4.3.3 Server List

The Server List option displays the servers that are associated with the selected Identity Vault. You
can add, edit, or remove the server entries.

NOTE: If you select the option to allow a default server to be created, that server shows up as
Default Server.default_container in the list. You cannot deploy a driver set into an existing
eDirectory tree if you have Default Server.default_container in the Server List. You must first
remove this reference and add a Metadirectory server in an eDirectory tree.

4.3.4 iManager

The iManager option displays the URL that Designer uses to launch the Novell iManager
administrative tool. You can modify this URL as needed.

To launch iManager from Designer, select Tools > iManager.
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4.3.5 Local Hostname

If desired, Designer supports designating a hostname for your Identity Vault by adding an entry to
the hosts file of your local OS. After assigning a hostname to the Host address of your Identity
Vault, you can use the hostname instead of an IP address or DNS name to access the Identity Vault.

For example, if your Identity Vault has a host address of 192.168.100.254, you can associate the
name ID-VAULT to that address in your local hosts file. Then, in Designer, you can refer to the

Identity Vault by the name ID-VAULT instead of using the IP address.

For more information about using your local hosts file, consult your operating system’s

documentation.

4.4 Configuring Servers

1 Right-click the server icon & in the Outline view.

2 Select Properties.

@y Properties for fabio2

| General

Mame:

Set

MNotes:

Properties | Contact Information

Context:

Host address:

DMS name:

Identity Manager | 16

WEFSIoN:

elirectory | ebirectory for Linux v8.8 SP3 [DS] | N2

Warsion:

Assigned Driver | TREE 1D Blariston, Inc.

Gl H Cancel ]

Table 4-3 on page 78 lists settings for the Server Properties page:
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Table 4-3 Settings for the Server Properties Page

Field
Description

Name The name of the Server object. The Identity Vault lists the server. You can
browse to and select the server.

Context The server’s context. The ldentity Vault assigns the context. You can browse to
and select the context.

Host address The server’s IP address.

DNS name The domain name or complete directory context name.

Identity Manager Section 5.2, “Changing the Identity Manager Version,” on page 130The version

version of Identity Manager that is running on the server. The default is Identity
Manager 3.6. You can change the version by using the drop-down list. See .

eDirectory version The version of eDirectory that the server is using.

Assigned Driver Set The driver set the server is assigned to.

Notes Information that you want to specify, to help you maintain the server.

Use the Contact Information tab to provide information on the person to contact and other items of
interest concerning the server.

4.5 Configuring Driver Sets

A driver set is a container that holds Identity Manager drivers. Only one driver set can be active on a
server at a time. As a result, all active drivers must be grouped into the same driver set. To view or
change settings, double-click a driver set in the Modeler.

+ Section 4.5.1, “Driver Set General Options,” on page 78

+ Section 4.5.2, “Driver Set Global Configuration Values,” on page 80

+ Section 4.5.3, “Java Environment Parameters,” on page 80

+ Section 4.5.4, “Driver Set Log Levels,” on page 81

+ Section 4.5.5, “Driver Set Named Passwords,” on page 82

+ Section 4.5.6, “Driver Set Server List,” on page 82

+ Section 4.5.7, “Driver Set Trace,” on page 83

4.5.1 Driver Set General Options

When you create an Identity Vault, a driver set is added to the vault by default.

Figure 4-4 A Driver Set in an Identity Vault

El 1denticy vaul: 2
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You can add other driver sets by dragging the Driver Set object from the palette to the Modeler.
From the General page, you can specify or change driver set values.

Figure 4-5 Driver Set Properties

3 Properties for Driver Set

|type filter text | Gereral
Senre] Marme: | Driver Set | Q,
GCVs
Jawa
Log Level Create a new partition on this driver set
Named Easswords @ Movell recommends that ol create a partition for
server List Driver Set objects. See the documentation for details.
Trace
Deploy Context; | O=navel v | Q,
@ EnsLre that your deploy context is in Qualified-Diot
notation (ou=IDM.o=company). Ctherwise, Liser
priovisioning will not work property,
Apply
@ QK ] [ Cancel ]

Table 4-4 Driver Set Settings

Field Description

Name The name of the Driver Set object (for example,
DriverSet1.)

Create a new partition on this driver set We recommend that you select this option. For
details, see “Planning the Technical Details of your
Identity Manager Implementation” (http://
www.novell.com/documentation/idm/install/data/
alorukg.html#alorukq) in the XYZ Guide.
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Field Description

Deploy context The Identity Vault assigns the default DN container
value to all driver sets. If you specify a DN
container here on the Driver Set object, that setting
takes precedence over the Identity Vault setting.

You can manually enter this value or browse for it.

4.5.2 Driver Set Global Configuration Values

Global configuration values (GCVs) are settings that are similar to driver parameters. Global
configuration values can be specified for a driver set as well as an individual driver. If a driver does
not have a GCV, the driver inherits the value for that GCV from the driver set.

GCVs allow you to specify settings for Identity Manager features such as password synchronization
and driver heartbeat, as well as settings that are specific to the function of an individual driver
configuration. Some GCVs are provided with the drivers, but you can also add your own. You can
refer to these values in a policy to help you customize your driver configuration.

To view or change the driver set's GCV settings, double-click the driver set. From the Global
Configuration Values page, you can add, edit, or remove values, or edit the XML file for the driver
set. To select a value, click on the value or the control field to the right of the value’s name. Use the
Add, Edit, Remove, and Edit XML buttons at the bottom of the page.

For more information on global configuration values, see Section 4.7.2, “Driver Global
Configuration Values,” on page 89.

4.5.3 Java Environment Parameters
The Java Environment Paramaters enable you to configure the Java virtual machine (JVM) on the

Metadirectory server asociated with the driver set. The parameters apply only if the driver set is
associated with a Metadirectory server that is version 3.6 or newer.

Table 4-5 Java Environment Parameters Settings

Field Description

Classpath Additions Specifies additional paths for the JVM to search for package (-jar)
and class (. class) files. Using this parameter is the same as using the
jJjava -classpath command. When entering multiple class paths,
separate them with a semi colon (;) for a Windows JVM and a colon (%)
for Unix/Linux JVMs.

JVM Options Specifies additional options to use with the JVM. Refer to your JVM
documentation for valid options.
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Field

Description

Initial Heap Size

Maximum Heap Size

Specifies the initial (minimum) heap size available to the JVM.
Increasing the initial hap size can improve startup time and
performance. Enter a numeric value followed by g, m, or k (case
insensitive). If no letter size is specified, the size defaults to bytes.
Using this parameter is the same as using the java -Xms command.

Refer to your JVM documentation for information about the JVMs
default initial heap size.

Specifies the maximum heap size available to the JVM. Enter a
numeric value followed by g, m, or k (case insensitive). If no letter size
is specified, the size defaults to bytes. Using this parameter is the same
as using the Java -Xmx command.

Refer to your JVM documentation for information about the JVMs
default maximum heap size.

4.5.4 Driver Set Log Levels

The Driver Set Log Level options enable you to view high-level information. For lower-level
information, use the Trace option.

Figure 4-6 Driver Set Options for Logging

@ Properties for Driver Set |:|@@

bype filker bext

General
GCYs
Java Environment. Parameters
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Server List
Trace

Driver Set Log Level =10

O Log errors
O Log errors and warnings
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(O Update only the last Iog time
() Turn logging off
[ Turn off logging ko driver set, subscriber, and publisher logs

Maximum number of entries in the log (50-500): | gp

[ Restore Defaulks ] [ Apply ]

[ Ok H Cancel ]

By default, logging is turned off. To track errors, messages, or events, change the default.

1 Double-click the driver set.

2 Select Driver Set Log Level.

3 Select a logging option.
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The log option that you select determines which messages are available in the log.

4 To configure audit instrumentation, select Log specific events, click the event selector button,
select events, then click OK.

The Update only the last log time option updates the time stamp to indicate the last activity of
the driver.

5 Specify the number of entries in the log.
The default is 50 entries (lines) in the log. If you want a longer history, increase the number.
6 Save changes by clicking OK.
The driver set log contains messages from the engine when it tries to start or stop drivers. To view

the log, use iManager. Select the Status Log icon above the Identity Vault in the Identity Manager
Overview.

455 Driver Set Named Passwords

The Named Passwords property page allows you to manage (add, edit, delete) named passwords for
the selected driver set. When defined in the driver set, named passwords are available to all drivers
in the driver set.

NOTE: If you create a named password of the same name in both the driver set and a driver in the
driver set, the named password settings in the driver take precedence.

You can define named passwords on both drivers and driver sets. For more information about named
passwords, see Section 4.7.6, “Driver Named Passwords,” on page 99.

45.6 Driver Set Server List

After adding one or more servers to the Identity Vault, you can view or change the driver set’s server
association.
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Figure 4-7 Server List
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Select a server in the Available Servers list, then use the arrows to move the server to the Selected
Server list. If a server is not in the Available Servers list, you must first add it by editing the Identity
Vault properties. See Section 4.3, “Configuring Identity Vaults,” on page 74.

45.7 Driver Set Trace

Although a driver set has nothing to trace, you can add a trace level to a driver set. The Trace setting
specifies a trace level used with all drivers associated with the driver set.

With the trace set, DS Trace displays Identity Manager and DirXML events as the engine processes
the events. The trace level affects each driver in the driver set. Use the trace level for
troubleshooting issues with the drivers when they are deployed. DS Trace displays the output of the
specified trace level.

WARNING: You should use the trace level only for testing or for troubleshooting driver issues.
Setting a driver trace level on a production driver can cause Identity Manager server to process
events slowly.

To set a driver set’s trace characteristics:

1 Inthe Outline view or Modeler, right-click the driver set, then select Properties.
2 In the driver properties, select Trace in the left navigation area.
3 On the Trace page, specify the trace settings for the driver set, then click OK.
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Table 4-6 Driver Set Trace Settings

Field Description

Trace level The IDM engine supports the following trace levels:
+ Trace level 0: Displays fatal messages, errors, warnings and
successes.

+ Trace levels 1: Displays informational messages in addition to
the information from Trace level 0.

+ Trace level 2: Displays contents of XML documents in
addition to the information from Trace level 1.

+ Trace level 3: Displays policy information in addition to the
information from Trace level 2.

XSL Trace Level DS Trace displays XSL events. Set this trace level only when
troubleshooting XSL style sheets. If you do not want to see XSL
information, set the level to 0.

Java Debug Port Allows developers to attach a Java debugger.

Trace File When a value is set in this field, all Java information for the driver is
written to file. The value for this field is the path for that file.

As long as the file is specified, Java information is written to this
file. If you do not need to debug Java, leave this field blank.

Trace File Encoding The trace file uses the system’s default encoding. You can specify
another encoding if desired.

This option is only available if the driver set is associated with a
server that is version 3.6 or newer.

Trace File Size Limit Sets a limit for the Java trace file. Select Unlimited to allow the file
to grow to fill the disk.

The following methods help you capture and save Identity Manager trace information.
+ “Windows” on page 84
+ “UNIX” on page 85
+ “iMonitor” on page 85

Windows

Open the Control Panel, select NDS Services, then click DS Trace.DLM > Start. A window named
NDS Server Trace Utility opens.

To set the filters to capture the DirXML trace information:

1 Click Edit > Options > Clear All.
2 Click the boxes next to DirXML and DirXML Drivers, then click OK.

To save the information to a file:

1 Click File > New.
A dialog box prompts for a filename.
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2 Enter a filename with the extension of .1og.
3 To stop capturing information, click File > Close.
The file is saved.
UNIX

Use the ndstrace command at the console to display the Identity Manager events. The exit
command quits the trace utility.

Table 4-7 ndstrace Commands

Command Description

Set ndstrace=nodebug Turns off all trace flags.

Set ndstrace on Displays trace messages to the console.

Set ndstrace file on Captures trace message to the ndstrace. log file in the /var/
nds directory.

Set ndstrace file off Stops capturing trace messages to the file.

Set ndstrace=+dxml Displays the Identity Manager events

Set ndstrace=+dvrs Displays the Identity Manager driver events.

iMonitor

Use iMonitor to get DS Trace information from a Web browser.

Table 4-8 Platforms and Commands for Web Browsers

Platform Command
Windows ndsimon.dlIm
Linux/Solaris/AIX/HP-UX ndsimonitor
1 Access iMonitor from http://server_ip:8008/nds (the default port).
2 Click Trace Configuration.
3 Click Clear All.
4 Click DirXML and DirXML Drivers.
5 Click Trace On, then click Trace History.
6 Click the Current document icon to view the live trace.
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4.6 Configuring Libraries

The Library object is a repository of commonly used policies that can be referenced from multiple
locations. You can place a policy in the library that every driver in the driver set can reference. You
can find the Library object in the Outline view.

1 Right-click the Library object and select Properties to view its Properties page.

° Properties for IDVault Library

General
General
Marme: ICWault Library
Deploy G=novel v Q
Context:
Description:
lRestore Qefaults” Apply l
@ | ok [ canca |

The following table lists settings for the Library Properties page:

Field Description

Name The name of the library. You can modify the name to be more
descriptive, especially if you have more than one library in a
tree.

For example, you might have one library at the Identity Vault
level containing policies that are generic to most drivers, and
another library at the Driver Set level containing policies that
are specific to that driver set.

Deploy Context The Identity Vault assigns the default DN container value to a
library created or deployed at the Identity Vault level. If you
specify a DN container here on the Library object, that
container setting takes precedence over the Identity Vault
setting. You can manually enter this value or browse to and
select the context.

Libraries created under the driver set do not have the Deploy
Context option.

Description This field allows you to type a description of the selected
library.

86 Designer 3.5 for Identity Manager 3.6 Administration Guide



2 After you have modified the fields, select Apply to apply the new settings, then click OK to

close the Properties page.

For more information on what you can add to a library, see Library Objects (http://
www.novell.com/documentation/idm36/policy_designer/data/rlibrary.html) in the Policies in
Designer 3.5.

4.7 Configuring Drivers

A driver provides the connection between an application and the Identity Vault. The driver is the
connector that enables data synchronization and sharing between systems. To view or change
settings, double-click a driver or driver line in the Modeler.

*

*

Section 4.7.1, “Driver General Settings,” on page 88
Section 4.7.2, “Driver Global Configuration Values,” on page 89
Section 4.7.3, “Driver Log Level,” on page 95

Section 4.7.4, “Driver Configuration,” on page 96

Section 4.7.5, “Driver Manifest,” on page 99

Section 4.7.6, “Driver Named Passwords,” on page 99
Section 4.7.7, “Driver iManager Icon,” on page 100
Section 4.7.8, “Driver Trace Levels,” on page 100

Section 4.7.9, “Engine Control Values,” on page 103
Section 4.7.10, “Driver Health Configuration,” on page 105
Section 4.7.11, “Reciprocal Attributes,” on page 113
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4.7.1 Driver General Settings

Figure 4-8 The Driver’s General Property Page
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NOTE: Driver versions vary for each driver.

Table 4-9 The Driver’s General Settings

Field Description

Name Displays the driver name, which you can change.

Notes Enables you to type notes about your driver implementation.

Server/Driver Version Displays the server name to which driver is associated. The driver
version only shows if the driver is running. Driver versions vary for
each driver.
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Field Description

Basic configuration file Displays the configuration filename that this driver uses. Contains
the filename of the configuration file that was used during import.

To view the path to this file, click the information icon next to the
filename. You might want to view the file to find out version
information.

If you haven't yet run the import wizard, this field is set to None.

Supported DN format Displays the format (for example, LDAP) that is supported for each
driver. This DN information is important for policy building and
simulation.

For additional details, click the information icon next to the format
field.

The driver property page is dynamic. Labels and descriptions are dynamically read from the driver
configuration file for the Authentication ID and connection information

4.7.2 Driver Global Configuration Values

Global configuration values (GCVs) are settings that are similar to driver parameters. GCVs can be
specified for an individual driver as well as a driver set. If a driver does not have a GCV, the driver
inherits the value for that GCV from the driver set.

GCVs allow you to specify settings for Identity Manager features such as password synchronization
and driver heartbeat, as well as settings that are specific to the function of an individual driver
configuration. Some GCVs are provided with the drivers, but you can also add your own. You can
refer to these values in a policy to help you customize your driver configuration.

To edit the driver set’s GCV settings, double-click the Driver Set object in the Modeler view. From
the Global Configuration Values page, you can add, edit, remove, or edit the XML for GCVs.
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Figure 4-9 The Global Configuration Values Page
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To view or change the driver’s GCV settings, double-click the driver. From the Global
Configuration Values page, you can add, edit, or remove values, or edit the XML file for the driver.
To select a value, click on the value or the control field to the right of the value’s name. Use the Add,
Edit, Remove, and Edit XML buttons at the bottom of the page.

You can add, edit, and remove GCVs on the Global Configuration Values page, except for those
values found under the Password Management heading. Password values are accessed through the
Password Synchronization page; click the Launch Password Sync Dialog icon to the right of the
control field and the Information icon.

In lIdentity Manager 3.6, GCVs play a much bigger role in configuring drivers. The two required
options for configuring a driver are Driver Configuration and GCVs. However, because each driver
contains different values and parameters, you need to consult the driver manual for specific values.
Go to the Identity Manager Drivers Web site (http://www.novell.com/documentation/idm36drivers/
index.html), then select the manual for the driver you are configuring.

+ “Structured Global Configuration Values” on page 91
+ “Adding or Editing a Structured GCV Element” on page 92
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Structured Global Configuration Values

Structured global configuration values allow you to place GCVs into a group. You do this by
creating a template containing the GCVs that you want in the group, along with their default values.
Then, you create instances of the template with the values you want to change. You can create
instances by selecting a Structured GCV and clicking Add, then modifying the values.

NOTE: Structured GCV is supported with Identity Manager 3.6.1 and above.

Figure 4-10 Structured Global Configuration Values Page
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Icon Description
Adds an instance to the Structured GCV template.
xi Deletes an instance from the Structured GCV template.

Save the changes by clicking Apply, then click OK.
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Adding or Editing a Structured GCV Element

1 To open the Global Configuration Values Definition Wizard, click Add/Edit on the Global
Configuration Values page.

Figure 4-11 Define GCV Page

= Global Configuration Value Definition @

Define GCY

Specify name, display name and tvpe For the GCY

Marne:
Test
Display name:;
Test
Descripkion:

A best widget

Typet

skructured v

Minirmurm Instances:

Mazximum Instances:

Yalue Separator:

Instance Separator:

1
2

<new lines= |

2 Specify the values for different fields in the Define GCV page:

Field

Description

Name

Display name

Description

Type

Specify the name for the GCV. The name should be unique for
each GCV.

Specify the display name of the GCV. It can be same as the name
of the GCV.

Provide a brief description of the GCV.

Select structured from the Type drop down list.
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Field

Description

Minimum Instances

Maximum Instances

Value Separator

Instance Separator

When you add an instance, the GCVs in the instance take the
default values. However, you can define the number of instances
a GCV should contain. The Ul enforces the restrictions.

Specify the value for minumum number of instances you want. By
default, the minimum number of instances is '0'".

When you add an instance, the GCVs in the instance take the
default values. However, you can define the number of instances
a GCV should contain.

Specify the value for maximum number of instances you want. By
default, the maximum number of instances is 'unlimited'.

Define a value separator for a GCV. A value separator acts as a
separator between the instance value strings when the structured
value is output as a single string.

For example: If "one", "two", and "three" are the instance items,
and ";" is the value separator, the following is the unstructured
output of a single instance:

"one;two;three"

Define an instance separator for a GCV. An instance separator
acts as a separator between the instances when the structured
value is output as a single string.

For example: If "one;two;three" and "four;five;six" are the
instance strings and "&#10;" is the instance separator (a linefeed
character), the following is the unstructured output:

"one;two;three

four;five;six"

3 Click Next.
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The Structured GCV template page displays a list of GCV elements in a table.

Figure 4-12 Structured GCV Template Page

= Global Configuration Value Definition @
Structured GCY template
Specify the GCY elements For this skruckured GCY
& = &
Marne Descripkion Type Yalue
dm integer 1
(7 [ Firiish ] [ Cancel ]

4 Use the toolbar to add, edit, or remove GCV elements from the template table.

A GCV element is displayed as a row in the table. You can specify a value for it by clicking the
cell in the Value column. Other fields of the table are automatically populated.

Icon Description

Adds a GCV element to the Structured GCV template.

i Allows you to edit a GCV element in the Structured GCV template.

= Removes a GCV element from the Structured GCV template.

i Deletes all GCV elements from the Structured GCV template. All elements
are deleted in one operation.

ir Moves the selected row up.

& Moves the selected row down.
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5 Click Finish to complete the Structured GCV configuration.

GCVs added to the table are actually the elements of the template. When a GCV element is
removed from the template, it is also removed from all the instances of the structured GCVs. In
addition, any Edit operation changes the GCV elements in all the instances of the structured
GCVs.

4.7.3 Driver Log Level

The Driver Log Level options enable you to view high-level information. For lower-level
information, use the Trace option. See Section 4.7.8, “Driver Trace Levels,” on page 100.

Figure 4-13 Settings for the Driver Log Level

L] Properties for StateMachine-Yer2

type Filter text Driver Log Level P

General

Driver Configuration
Engine Control Yalues Disabled
GCYs

iManager Icon

Use log settings from the driver set

Manifest

Mamed Passwords
Reciprocal Attributes
Trace

Maximum number of entries in the log {S0-500):

[ Restore Defaulks ] [ Apply ]

[:‘:7:] [ OF H Cancel ]

By default, logging inherits the setting from the driver set. To change the default:

1 Double-click the driver.
2 Select Driver Log Level.
3 Select a logging option.
The option that you select determines which information is available in the log.

To configure the audit instrumentation, select Log specific events, click the event selector
button, select events, then click OK.

4 Specify the number of entries in the log.
The default is 50 entries (lines) in the log. If you want a longer history, increase the number.
5 Save changes by clicking OK.
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The driver log contains messages from the driver. The messages are related to operations that the
driver performed or tried to perform. To view the log, use iManager. Select the log icon on the
Driver object in the Identity Manager Overview.

4.7.4 Driver Configuration

Identity Manager 3.6 Driver Configuration Wizard adds all policies when the driver is imported, and
are not lost if you did not select an option in the Import Information Request forms when you
initially import or create a driver. If this is a driver configuration file that came with Identity
Manager 3.6, you can change the driver’s values through the Driver Configuration option in the
driver’s Properties page.

The two required options for every driver are Driver Configuration and GCVs. With the Driver
Configuration option selected, fill out the required values and parameters that are necessary to have
the driver run in your network environment. However, because each driver contains different values
and parameters, you need to consult the driver manual for specific values. Go to the Identity
Manager Drivers web site (http://www.novell.com/documentation/idm36drivers/index.html), then
select the manual for the driver you are configuring.

+ “Driver Module” on page 96

+ “Authentication” on page 97

+ “Startup Option” on page 98

+ “Driver Parameters” on page 98

+ “ECMASCcript” on page 99

Driver Module

Table 4-10 Driver Module Settings

Field Description

Java: Name of the Java class Specify the name of the Java class that will be instantiated
for the shim component of the driver. This class can be
located in the classes directory as a class file, or in the
lib directory as a .jar file.

Native: Name of the DLL Specify the name of the .d 11 file that will be instantiated for
the application shim component of the driver.

Connect to Remote Loader Select this option if you want to connect the driver to the
Metadirectory engine that uses the Remote Loader.

Driver object password: Set Password Set a password for the Driver object. If you are using the
Remote Loader, you must enter a password on this page or
the remote driver cannot run. The Remote Loader uses this
password to authenticate itself to the remote driver.
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Field

Description

Remote Loader client configuration for
documentation: Include in documentation

Enables you to document your Remote Loader
configuration for the driver. From the drop-down list, select
a name that you specified on the driver’s documentation

property page.

To use this option, see Section 4.7.9, “Engine Control
Values,” on page 103.

Authentication

Table 4-11 Authentication Settings

Field

Description

Authentication information for server

Authentication ID

Connection Information

Set Password

Remove Password

Host name

Port

KMO

Other parameters

The server that the driver is associated with.

Specify the application user ID. This ID is used to pass
Identity Vault subscription information to the application. If
you have enabled SSL/TLS for eDirectory drivers, this option
is dimmed.

Specify the address or name and port of the server that the
application shim should communicate with.

Enables you to set or change an application password (for
example, Active Directory).

Deletes the password to the application.

Specifies the address or name of the machine where the
Remote Loader runs. For example, enter
hostname=192.168.0.1.

If you don't specify this communication parameter, this value
defaults to localhost.

Specifies the port that the Remote Loader uses to accept
connections from the remote interface shim. For example,
enter port=8090.

If you don't specify this communication parameter, this value
defaults to 8090.

Specifies the Key Name of the Key Material Object containing
the keys and certificate used for SSL. For example, enter
kmo=remote driver cert.

If you don't specify this communication parameter, no value is
stored for this parameter. SSL won't be available.

Provides reference information. It is included when you
document your entire project.
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Driver Cache Limit

Figure 4-14 Options for the Driver Cache

Driver cache limit
& Urlimited
() Cache limit (KB):

The driver cache is a file that holds Identity Vault events until a driver can process them.
This file can become very large in the following situations:

+ If events occur at a steady rate that is faster than Identity Manager can process them over a long
period of time.

+ If the driver is shut down for long period of time but is not disabled.

By default, the driver cache (file) size is limited only by available disk space. This is the
recommended setting.

The only reason to set some other limit is to protect against accidentally filling up the disk. The
number that you use depends on the difference between projected amount of available disk space
without anything in the cache and the amount of free disk space that you want to ensure will always
be left available, divided by the number of drivers on the server.

The primary reason that the cache file becomes very large is if the driver is left not running over a
long period of time. In this case, the recommendation is to disable the driver rather than set a cache
limit. After the limit is reached, all the cached events are discarded.

Startup Option

Table 4-12 Startup Settings

Setting Description

Auto start The driver starts automatically when the Metadirectory engine loads.
Manual You must start the driver manually from the driver state location.

Disabled Disables the driver.

Do not automatically If you don't select this option, a driver that has been deployed but disabled
synchronize the driver resynchronizes on startup. If you select this option, a driver that has been

deployed but disabled does not resynchronize.

Driver Parameters

From this tab, you can enter common driver options, Subscriber and Publisher channel options, as
well as edit XML. Because the Driver Parameters options are different for each driver, refer to the
Identity Manager Drivers web site (http://www.novell.com/documentation/idm36drivers/
index.html) for configuration information on the driver you have selected.
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ECMAScript

Displays an ordered list of ECMAScript resource files that are loaded when the driver starts. The
ECMAScript files contain extension functions that can be used in policies. For more information,
see Using ECMAScript in Policies (http://www.novell.com/documentation/idm40/policy_designer/
data/ecmaoverview.html) in the Policies in Designer 4.0.

4.7.5 Driver Manifest

The driver manifest is like a resume for the driver. The driver manifest states what the driver
supports, and includes a few configuration settings. The driver developer should provide the driver
manifest. Usually a network administrator does not need to edit the driver manifest.

For more information, see the developer documentation for Identity Manager drivers.

4.7.6 Driver Named Passwords

The Named Passwords property page allows you to manage (add, edit, delete) named passwords for
the selected driver. You can define named passwords on both drivers and driver sets.

Named Passwords let you store multiple passwords securely by referring to each password by a key,
or name. When you refer to the named password in a driver policy, you use the name only, not the
password value. Then, when the driver needs the password value to execute the policy, it requests
the password value from the Metadirectory engine. This method lets you avoid revealing the
password value in the code for a driver policy.

The following example shows how a Named Password can be referenced in a driver policy on the
Subscriber channel in XSLT:

<xsl:value-of

select="query:getNamedPassword($srcQueryProcessor, >mynamedpassword’)”
xmIns:query="http://www.novell.com/java/
com.novell_nds.dirxml._.driver.XdsQueryProcessor/>

You can store and retrieve named passwords for any driver without making changes to the driver
shim.

As a security measure, in addition to using named passwords, you should contro

| access to all Identity Manager objects in eDirectory.

NOTE: A driver developer can also customize a driver to use named passwords in other ways, such
as retrieving Named Passwords when the driver starts up, instead of requesting them from the
Metadirectory engine each time they are needed.

For example, the Identity Manager Driver for Lotus Notes driver has been customized to support
additional ways of using named passwords, and examples of those methods are included in the
sample driver configurations. For more information, see the Identity Manager driver guides (http://
www.novell.com/documentation/idm35/index.html).
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4.7.7 Driver iManager Icon

You can see and edit the iManager icons that each driver uses. This is important because iManager
renders driver icons in a particular way. However, those icons don't appear in Designer. Conversely,
Designer's application icons don't appear in iManager's user interface.

To help bridge that gap, you can view the iManager icon to be used in Designer:

1 Inthe Modeler, right-click a driver (for example, eDirectory), then select Properties.

2 Inthe left navigation area, select iManager Icon.
Designer displays an icon. It is associated with the driver in Designer, unless a different one
was imported and stored on the driver.

For information about editing or changing icons, see Chapter 18, “Editing Icons for Drivers and
Applications,” on page 403.

4.7.8 Driver Trace Levels

You can add a trace to your driver. With the driver trace level set, DS Trace displays driver-related
Identity Manager events, at the level of detail specified by the driver trace level, as the engine
processes the events. The driver trace level affects only the driver or driver set where it is set.

WARNING: You should use the trace level only for testing or for troubleshooting driver issues.
Setting a driver trace level on a production driver can cause Identity Manager server to process
events slowly.

To set a driver’s trace characteristics:

1 In the Outline view or Modeler, right-click the driver, then select Properties.
2 In the driver properties, select Trace in the left-side navigation.
3 On the Trace page, specify the driver’s trace settings, then click OK.
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Field

Description

Trace level

Trace level: Use setting from the
driver set

Trace file

Trace file: Use setting from the
driver set

Trace File Encoding

Trace file size limit

Trace file size limit: Use setting from
the driver set

The IDM engine supports the following trace levels:
+ Trace level 0: Displays fatal messages, errors, warnings and
successes.

+ Trace levels 1: Displays informational messages in addition to
the information from Trace level 0.

+ Trace level 2: Displays contents of XML documents in
addition to the information from Trace level 1.

+ Trace level 3: Displays policy information in addition to the
information from Trace level 2.

Consult the driver documentation for additional trace options that
might be available.

NOTE: You can also set the driver trace level in Designer by right-
clicking a driver (in the Outline or Modeler views) and selecting Live
> Set Driver Trace Level.

This immediately deploys the trace level to the selected driver. To
update the driver trace level in your project as well, select Update
local model.

If you select this option, all trace levels set at the driver set take
precedence over any driver settings. Otherwise, the driver settings
are effective.

Specify a filename and location where the Identity Manager
information is written for the selected driver. When a value is set in
this field, all Java information for the driver is written to file.

As long as the file is specified, Java information is written to this
file. If you do not need to debug Java, leave this field blank.

If you select this option, all trace levels set at the driver set level
take precedence over any driver settings. Otherwise, settings at
the driver level are effective.

The trace file uses the system’s default encoding. You can specify
another encoding if desired.

This option is only available if the driver is associated with a server
that is version 3.6 or newer.

Allows you to set a limit for the Java trace file. Select Unlimited to
allow the file to grow to fill the disk.

NOTE: The trace file is created in multiple files. Identity Manager
automatically divides the maximum file size by ten and creates ten
separate files. The combined size of these files equals the
maximum trace file size.

If you select this option, all trace levels set at the driver set level
take precedence over any driver settings. Otherwise, settings at
the driver level are effective.
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Field Description

Trace name Helps you track trace messages. The name that you specify here
appears with the driver trace messages. Use a trace name if the
driver name is very long.

The following methods help you capture and save Identity Manager trace information.

Windows

Open the Control Panel, select NDS Services, then click DS Trace.DLM > Start. A window named
NDS Server Trace Utility opens.

To set the filters to capture the DirXML trace information:

1 Click Edit > Options > Clear All.
2 Click the boxes next to DirXML and DirXML Drivers, then click OK.

To save the information to a file:

1 Click File > New.
A dialog box prompts for a filename.

2 Enter a filename with the extension of .1og.

3 To stop capturing information, click File > Close.
The file is saved.

UNIX

Use the ndstrace command at the console to display the Identity Manager events. The exit
command quits the trace utility.

Table 4-13 ndstrace Commands

Command Description

Set ndstrace=nodebug Turns off all trace flags.

Set ndstrace on Displays trace messages to the console.

Set ndstrace file on Captures trace message to the ndstrace. log file in the /var/
nds directory.

Set ndstrace file off Stops capturing trace messages to the file.

Set ndstrace=+dxml Displays the Identity Manager events

Set ndstrace=+dvrs Displays the Identity Manager driver events.

iMonitor

Use iMonitor to get DS Trace information from a Web browser.
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Table 4-14 Platforms and Commands for Web Browsers

Platform Command
Windows ndsimon.dlm
Linux/Solaris/AIX/HP-UX ndsimonitor

1 Access iMonitor from http://server_ip:8008/nds (the default port).
2 Click Trace Configuration.

3 Click Clear All.

4 Click DirXML and DirXML Drivers.

5 Click Trace On, then click Trace History.

6 Click the Current document icon to view the live trace.

4.7.9 Engine Control Values

The engine control values enable you to change certain default behaviors of the Metadirectory
engine can be changed. You can access the values only if a server is associated with the Driver Set
object. The values are populated based on the Identity Manager version of the servers that are
associated with the driver set (servers can be associated through the Engine Controls for Server
entry).

Changing a version of an Identity Manager server affects the engine controls for all drivers in a
driver set that is associated with the server. When the Identity Manager version is changed, the
engine controls for all associated drivers are updated to match the specified version. During the
update process, all current settings for existing engine controls are merged into the new engine
controls. If the engine controls are not valid for the version of the selected server, they are removed
as options.

In Designer:

1 Inthe Modeler, right-click the driver line.
2 Select Properties > Engine Control Values.

3 Click the tooltip icon to the right of the Engine Controls for Server field. If a server is
associated with the Identity Vault, and if you are authenticated, the engine control values
display in the large pane.

Table 4-15 Engine Control Values

Field Description
Subscriber channel retry The Subscriber channel retry interval controls how frequently the
interval in seconds Metadirectory engine retries the processing of a cached transaction after

the application shim's Subscriber object returns a retry status.

Qualified form for DN-syntax The qualified specification for DN-syntax attribute values controls whether

attribute values values for DN-syntax attribute values are presented in unqualified slash
form or qualified slash form. A True setting means the values are
presented in qualified form.
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Field

Description

Qualified form from rename
events

Maximum eDirectory
replication wait time in
seconds

Use non-compliant
backwards-compatible mode
for XSLT

Maximum application
objects to migrate at once

Set creatorsName on
objects created in Identity
Vault

Write pending associations

The qualified form for rename events controls whether the new-name
portion of rename events coming from the Identity Vault is presented to the
Subscriber channel with type qualifiers. For example, CN=. A True setting
means the names are presented in qualified form.

The maximum eDirectory replication wait time controls the maximum time
that the Metadirectory engine waits for a particular change to replicate
between the local replica and a remote replica. This only affects
operations where the Metadirectory engine is required to contact a remote
eDirectory server in the same tree to perform an operation and might need
to wait until some change has replicated to or from the remote server
before the operation can be completed (for example, object moves when
the Identity Manager server does not hold the master replica of the moved
object; file system rights operations for Users created from a template.)

This control sets the XSLT processor used by the Metadirectory engine to
a backward-compatible mode. The backwards-compatible mode causes
the XSLT processor to use one or more behaviors that are not XPath 1.0
and XSLT 1.0 standards-compliant. This is done for backwards-
compatibility with existing DirXML style sheets that depend on the non-
standard behaviors.

For example, the behavior of the XPath “I=" operator when one operand is
a node set and the other operand is other than a node set is incorrect in
DirXML releases up to and including Identity Manager 2.0. This behavior
has been corrected; however, the corrected behavior is disabled by default
through this control in favor of backwards-compatibility with existing
DirXML style sheets.

This control is used to limit the number of application objects that the
Metadirectory engine requests from an application during a single query
that is performed as part of a Migrate Objects from Application operation.

If java.lang.OutOfMemoryError errors are encountered during a Migrate
from Application operation, this number should be set lower than the
default. The default is 50.

NOTE: This control does not limit the number of application objects that
can be migrated; it merely limits the batch size.

This control is used by the Identity Manager engine to determine if the
creatorsName attribute should be set to the DN of this driver on all objects
created in the Identity Vault by this driver.

Setting the creatorsName attribute allows for easily identifying objects
created by this driver, but also carries a performance penalty. If not set, the
creatorsName attribute defaults to the DN of the NCP™ Server object that
is hosting the driver.

This control determines whether the Identity Manager engine writes a
pending association on an object during Subscriber channel processing.

Writing a pending association confers little or no benefit but does incur a
performance penalty. Nevertheless, the option exists to turn it on for
backwards compatibility.
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Field Description

Use password event values  This control determines the source of the value reported for the
nspmDistributionPassword attribute for Subscriber channel Add and
Modify events.

Setting the control to False means that the current value of the
nspmDistributionPassword is obtained and reported as the value of the
attribute event. This means that only the current password value is
available. This is the default behavior.

Setting the control to True means that the value recorded with the
eDirectory event is decrypted and is reported as the value of the attribute
event. This means that both the old password value (if it exists) and the
replacement password value at the time of the event are available. This is
useful for synchronizing passwords to certain applications that require the
old password to enable setting a new password.

Enable password This control determines whether the Identity Manager engine reports the
synchronization status status of Subscriber channel password change events.
reporting

Reporting the status of Subscriber channel password change events
allows applications such as the Identity Manager User Application to
monitor the synchronization progress of a password change that should
be synchronized to the connected application.

4.7.10 Driver Health Configuration

This properties page is only available if the ldentity Manager server version is set to 3.6 or newer.

The Driver Health Configuration allows you to monitor a driver’s state of health (green, yellow, or
red), and to specify the actions to perform in response to each of these health states.

To do so, you define the conditions (criteria) that determine each of the health states, and the
associated actions to perform whenever the driver’s health state changes. For example, if the driver’s
health changes from a green state to a yellow state (based on the conditions you’ve established), you
can perform such actions as restarting the driver, shutting down the driver, and sending an e-mail to
the person designated to resolve issues with the driver.

You can also define custom driver states that are independent of the standard green, yellow and red.
Whenever the driver meets the conditions for the custom statet, Designer performs the associated
actions.

To monitor a driver’s health state using the Driver Health Configuration, you must complete the
following tasks:

+ “Creating a Driver Health Configuration” on page 106
+ “Modifying the Health State Conditions” on page 107
+ “Creating a Driver Health Job” on page 109

Additionally, you can perform the following tasks to further configure the Driver Health Check
environment:

+ “Modifying the Health State Actions” on page 110
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+ “Creating a Custom State” on page 111
+ “Modifying the Driver Health Job Settings” on page 112

NOTE: Monitoring driver health is applicable only to deployed drivers. Designer does not indicate
driver health in the Modeler or any other pre-deployment interface. Use iManager to monitor the
health of deployed drivers. For more information about driver health monitoring in iManager, see
Monitoring Driver Health (http://www.novell.com/documentation/idm36/idm_common_driver/
data/bdygx01.html) in the Identity Manager 3.6 Common Driver Guide (http://www.novell.com/
documentation/idm36/idm_common_driver/data/front.html).

Creating a Driver Health Configuration

The health configuration of drivers at version 3.6 (or newer) is configured automatically. Skip this
section if your drivers are version 3.6 (or newer). If you have drivers older than version 3.6, you
must create the health configuration for each driver you want to monitor.

To create a driver health configuration:
1 Inthe Modeler or Outline view, right-click the driver, then select Properties.

2 In the left-side navigation, select Health.

Mo Driver Health Configuration

This driver does not contain any health configuration information.
reate a basic health configuration by selecting the link belaw,

% Mesw Driver Health Confiquration

3 Select New Driver Health Configuration.

Designer creates a basic health configuration with sample conditions for the green and yellow
states (none for red).
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Driver Health Job: none

I arder far the Driver Health Canfiguration to be processed, & Driver Health Job
must be configured. Greate a Driver Health Jab.

Conditions

' Condition Group 1

Driver Skake is running

Driver in Cache Owverflow is False

[] Always execute actions when conditions are krue
Select Edit to define action

4 Continue with “Modifying the Health State Conditions™” on page 107.

Modifying the Health State Conditions

The driver health configuration lets you define the conditions that determine each health state. The
green state contains conditions intended to represent a healthy driver, while a red state represents an
unhealthy driver, having failed conditions for both green and yellow states.

The Driver Health job evaluates the conditions for the green state first. If the driver fails to meet the
green conditions, it evaluates the yellow conditions. If the driver fails to meet the yellow conditions,
it is automatically assigned a red state.

To modify the conditions for a state:
1 Inthe Modeler or Outline view, right-click the driver where you want to modify the health
check configuration, then select Properties.
2 In the left-side navigation, select Health.
3 Click the state tab (Green or Yellow) that you want to modify.
[ Condtions N
- Condition Group 1

Driver State s starting
Tetal Sze i kess then or equal 5000

(o]
- Condition Group 2
Driver State s running

The tab displays the current conditions for the health state. Conditions are organized into

groups, with logical operators (either AND or OR), to link each condition and condition group.
Table 4-16 describes the conditions that the Driver Health job can evaluate.
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Table 4-16 Driver Health Check Conditions

Condition

Description

Driver State

Driver in Cache
Overflow

Newest

Oldest

Total Size
Unprocessed Size

Unprocessed
Transactions

Transaction History

Running, stopped, starting, not running, or shutting down. For example, one
of the default conditions for the green health state is Driver State is running.

The state of the cache used for holding driver transactions. If the driver is in
cache overflow, all available cache has been used. For example, the default
condition for the green health state is Driver in Cache Overflow is false and

the default for the yellow health state is Driver in Cache Overflow is true.

The age of the newest transaction in the cache.

The age of the oldest transaction in the cache.

The size of the cache in bytes.

The size of all unprocessed transactions in the cache.

The number of unprocessed transactions in the cache. You can specify all
transactions types or specific transaction types (such as adds, removes, or
renames).

The number of transactions processed at various points in the subscriber or
publisher channel over a given period of time. This condition uses multiple
elements in the following format:

<transaction type> <transaction location and time period > <relational
operator> <transaction number>.

¢ <transaction type>: Specifies the type of transaction being evaluated.
For example, adds, removes, renames, and so forth.

+ <transaction location and time period>: Specifies the point in the
subscriber or publisher channel and the time period being evaluated.
For example, you might evaluate the total number of transactions
processed as publisher reported events over the last 48 hours. The time
period cannot exceed the Transaction Data Duration setting, which is
configurable in the Driver Health job. For more information, see
“Modifying the Driver Health Job Settings” on page 112.

+ <relational operator>: Specifies the relationship between the identified
transactions and the <transaction number> (equal to, less than, greater
than, and so forth.)

+ <transaction number>: Specifies the number of transactions being used
in the evaluation.

For example:

<number of adds> <as publisher commands> <over the last
10 minutes> <is less than> <1000>
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Condition

Description

Available History

The amount of transaction history data that is available for evaluation. This
condition helps ensure that a Transactions History condition does not cause
the current state to fail because it does not have enough transaction history
data collected for the time period being evaluated.

For example, assume that you want to use the Transactions History condition
to evaluate the number of “Add as Publisher” commands over the last 48
hours. However, you don't want the condition to fail if there is less than 48
hours of data. You could create condition groups similar to the following:

Groupl
Available History <is less than> <48 hours>

or

Group2

Available History <is greater than or equal to> <48
hours> and

Transactions History <number of adds> <as publisher
commands> <over the last 48 hours> <is less than> <1000>

The state evaluates to true if either condition group is true.

The state evaluates to false if both conditions evaluate to false.

4 Modify the condition criteria as desired.

+ To add a new group, select the Conditions tab, then click Append Condition Group [&.

+ To add a condition, select an existing condition group, then click Append Condition £- .

+ To reorder condition groups or individual conditions, select the condition group or
condition, then click Move Up 1 or Move Down <*. You can also use these buttons to
move a condition from one group to another.

+ Cut, copy and paste a condition group or condition to the clipboard by right-clicking the
item, then selecting the appropriate clipboard action.

5 Click Apply to save your changes without closing the Properties page.

6 If you want to change the actions associated with the conditions you’ve set, continue with
“Modifying the Health State Actions” on page 110.

Creating a Driver Health Job

The driver health job is available only for Identity Manager server version 3.6 or newer.

The Driver Health job executes periodically to evaluate the health of a driver configured for health
checks. The job evaluates the conditions defined for each of the driver’s health states, then assigns
the driver the appropriate state. The job also executes any actions associated with the assigned state.

If a Driver Health job does not exist, the Driver Health Configuration page displays a New Driver
link from which you can configure the Driver Health job. If a Driver Health job already exists, the
Driver Health Configuration page does not display this prompt.

To create a Driver Health job:

1 Inthe Modeler or Outline view, right-click the driver, then select Properties.
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2 In the left-side navigation, select Health.
3 Click Driver Health Job to open the Job dialog box. Select the appropriate job, then click OK.

Follow the prompts to import the configuration file for the Driver Health job. Refer to the
following information for details:

+ Where to place the driver: Place the job in the same driver set as the driver. The correct
driver set is selected by default. You can only have one driver health job per driver set.

+ Import a configuration: Import the configuration from the server. In the Show field,
select Identity Manager 3.6 configurations, then select the Driver Health job in the
Configurations field.

+ Email server: Select the e-mail server that you want used for any actions that initiate e-
mail. If you have not defined additional e-mail servers, select the Default Notification
Collection server.

+ Servers: If the driver set is associated with only one server, that server is selected and
cannot be changed. If the driver set is associated with multiple servers, select the server
where you want to run the job.

After creating the Driver Health job, you can modify job settings as needed. For example, you can
configure how often the job runs, which drivers use the job, and how much data the job maintains to
support transaction history. For more information, see “Modifying the Driver Health Job Settings”
on page 112.

Modifying the Health State Actions

The Driver Health Configuration lets you define the actions that the Driver Health job performs
when the driver health state changes. For example, if the state changes from green to yellow, you can
shut down or restart the driver, generate an event, or start a workflow.

The Driver Health job performs a health state’s actions only once each time the conditions are met;
as long as the driver state remains the same, the actions do not repeat. If the driver state changes
because its conditions are no longer met, the Driver Health job performs the state’s actions again the
next time its conditions are met.

1 Inthe Modeler or Outline view, right-click the driver where you want to modify the health
check configuration, then select Properties.

2 In the left-side navigation, select Health.
3 Select the state tab (Green or Yellow) that you want to modify.

i [ ] always execute actions when conditions are true

Clear Driver cache

The tab displays the current actions for the health state. If no action is assigned, the Driver
Health Configuration displays Define new action here in the Actions tab.

4 Select the Actions tab, then click Append Action = to add an action to the health state.

Select an action from the dropdown list. Table 4-17 describes the actions that the Driver Health
job can perform.

NOTE: Some actions require additional information before they will execute.
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Table 4-17 Driver Health Check Actions

Action Description

Clear Driver Cache Removes all transactions, including unprocessed transactions, from the
cache.

Execute ECMAScript Executes an existing ECMAScript. Specify the DirXML-Resource object that
contains the ECMAScript.

Generate Event Generates an event that can be used by Novell Audit and Novell Sentinel.

On Error If an action fails, tells Designer what to do with the remaining actions, the
current health state, and the Driver Health job.

Restart Driver Restarts the driver (stop, then start)

Send Email Sends an e-mail to one or more recipients. The template you want used in
the e-mail message body must already exist.

Start Driver Starts the driver.
Start Workflow Starts a provisioning workflow.
Stop Driver Stops the driver.

Write Trace Message Writes a message to the driver’s log file, using the message parameters
specified in the action.

5 If you want the actions executed every time the conditions evalute to true, click Always execute
actions when conditions are true.

By default, actions are performed only one time while a driver's health state remains the same;
regardless of the number of times the conditions are evaluated, as long as the health state
remains in effect (true), the actions are not repeated. For example, when the driver's health state
changes from red to green, the green state's actions are executed. The next time the conditions
are evaluated, if the health state is still green, the actions are not repeated.

Selecting the Always execute actions when conditions are true setting causes the actions to be
repeated each time the condition evaluates to true. For example, if the driver's health state
repeatedly evaluates to green without changing to another state, the green state's actions are
repeated after each evaluation.

6 Click Apply to save your changes without closing the Properties page.

Creating a Custom State

The Driver Health Configuration lets you create one or more custom states to perform actions
independent of the driver’s current health state (green, yellow, red). If the driver meets the custom
state’s conditions, the Driver Health job performs its actions.

As with the standard driver health states (green, yellow, red), the Driver Health job performs a
custom state’s actions only once each time the conditions are met; as long as the driver state remains
the same, the actions do not repeat. If the driver state changes because the custom state’s conditions
are no longer met, the Driver Health job performs the custom state’s actions again the next time its
conditions are met.

1 Inthe Modeler or Outline view, right-click the driver where you want to create a custom state,
then select Properties.
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2 In the left-side navigation, select Health.
3 Select the pulldown menu =, then select New Custom State.

4 Green | Yellow €3 Red | Custom State 57

% D v

Driver Health Job: none

fn arder for the Driver Health Configuration to be processed, a Driver Health
Job st be configured. Greate a Driver Health Job.

Conditions

Condition Group 1
Define new condition here

i [ always execute actions when conditions are krue

Select Edit to define action

4 Define the conditions and actions for the custom state, then click Apply to save the changes
without closing the Properties page.

For information about defining state conditions, see “Modifying the Health State Conditions”
on page 107. For information about defining state actions, see “Modifying the Health State
Actions” on page 110.

Modifying the Driver Health Job Settings

NOTE: The driver health job is available only for Identity Manager server version 3.6.

The Driver Health job evaluates the conditions for the health states and assigns the driver the
appropriate state. The job also executes any actions associated with the assigned state.

As with all driver jobs, there are several settings that you can modify to optimize the job’s
performance for your environment, including how often the job runs, which drivers use the job, and
how much data the job maintains to support transaction history.

To modify the job settings:

1 Inthe Modeler or Outline view, open the driver set object where the driver health job is stored.
2 Right-click the appropriate job object, then select Edit.
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3 Change the desired settings on the following tabs, then click OK to save your changes:

Tab Description

Schedule The Driver Health job is a continuously running job, meaning that it does not stop
unless a health state action shuts it down or you shut it down manually. The job must
run continuously to be able to support transaction data collection for use in
Transactions History conditions.

If the job does stop, it is restarted based on the schedule. The default schedule
checks every minute to see if the job is running. If the job is not running, it is started.

Scope By default, the job applies to all drivers in the driver set. This means that you only
need one Driver Health job per driver set. However, you can create multiple Driver
Health jobs for different drivers within the same driver set. For example, you might
have some drivers whose health you want updated more frequently than other
drivers, in which case you would need at least two Driver Health jobs.

Parameters You can change any of the following job parameters:

¢ Login ID: This defaults to the login ID that was used when creating the driver
job. You should only change this if you want the driver to authenticate using
different credentials.

+ Login password: This is the password required for the login ID that you
supplied in the Login ID field.

+ Polling interval: Determines how often the job evaluates the conditions for the
health states, assigns the driver the appropriate state, executes any actions
associated with the assigned state, and stores the driver’s transaction data. The
default polling interval is one minute.

+ Polling interval units: Specifies the time unit (minutes, hours, days, weeks) for
the number specified in the Polling interval setting.

+ Duration transaction data is kept: Specifies how long a driver’s transaction
data is kept. The default retains a transaction for two weeks before being
deleted. Longer transaction durations require more memory.

For example, to store transaction data for one driver every minute (Polling
interval) for two weeks requires approximately 15 MB of memory.

+ Duration units: Specifies the time unit (minutes, hours, days, weeks) for the
number specified in the Duration transaction data is kept setting.

4.7.11 Reciprocal Attributes

NOTE: This properties page is only available if the Identity Manager server version is set to 3.6.

The Reciprocal Attributes propoerties lets you create and manage backlinks between objects. For
example, the Group object includes a Members attribute that contains pointers to all User objects
that belong to that group. Similarly, each User object includes a Group Membership attribute that
points to the Group objects of which that user is a member. These two-way links between objects are
known as reciprocal mappings.
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Figure 4-15 Custom Reciprocal Attribute Mapping Property Page for Driver Objects
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You can manage all reciprocal mapping configuration from the toolbar in the property page, which

contains the following toolbar icons:

Use the New Attribute icon to add a new attribute to the reciprocal mapping list.

Use the Delete icon to delete the currently selected reciprocal mapping entry from the

Use the Clear All Attribute Mappings icon to delete all reciprocal mappings.

Use the Move Up icon to move the currently selected attribute up in the mapping list. To
do so, select the attribute entry you want to move up, then click Move up.

Use the Move Down icon to move the currently selected attribute down in the mapping

list. To do so, select the attribute entry you want to move down, then click Move Down.

Icon Description
&
_ list.
&
2ty
&
i

Use the Expand All icon to expand all reciprocal attribute mapping entries.

Use the Collapse All icon to expand all reciprocal attribute mapping entries.

The Custom Reciprocal Mapping page lets you do the following:

+ “Adding a Reciprocal Attribute Mapping” on page 115

+ “Removing a Reciprocal Attribute Mapping” on page 115
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+ “Removing an Attribute from the Reciprocal Mapping List” on page 116
+ “Editing Reciprocal Attribute XML” on page 116
Adding a Reciprocal Attribute Mapping

When creating a reciprocal attribute mapping, you must first add one of the attributes to the
reciprocal mapping list:

1 Inthe Reciprocal Attributes page, click New Attribute @' .

2 Inthe new attribute entry, select the desired attribute from the dropdown list, then click OK.

Atribuke: << Select an Attribute »>» v

Canel

3 Specify the specifics of the reciprocal mapping, then click OK.

Source class: <% Select a Class > v
Destination class: | << Select a Class == v
Reciprocal attribute: | <= Select an Attribute »» v

Source Class Specifies the class name to which the attribute in the mapping list is
associated. For example, if you placed the Group Membership attribute in
the reciprocal mapping list, the associated Source Class is User.

Destination Class Specifies the class name associated with the attribute to which you want
to create a reciprocal mapping.

Reciprocal Attribute Specifies the attribute name to which you want to create a reciprocal
mapping.

Removing a Reciprocal Attribute Mapping
To remove a reciprocal mapping between attributes:

1 Select the reciprocal mapping you want to remove by selecting it in the reciprocal mapping list.
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When selected, the attribute name in the Attribute tab is highlighted.

=l @ aktribute: Group Membership

Source class: Group
Destination class; nestedGroupAux
Reciprocal atkribuke: groupfMember

2 Click Delete * .

Removing an Attribute from the Reciprocal Mapping List
To remove an attribute from the reciprocal mapping list:

1 Select the attribute you want to remove by selecting it in the reciprocal mapping list.
When selected, the attribute name in the Attribute tab is highlighted.

SN ST = Equivalent Ta Me

Source class: < Any Class =
Destination class: < Any Class =
Reciprocal attribuke: Security Equals

2 Click Delete ¥ .
To remove all attributes from the reciprocal attribute mapping list, click Clear All Attribute

Mappings & .
Editing Reciprocal Attribute XML

If desired, you can edit the XML for a reciprocal attribute directly. To do so, click Edit XML in the
Custom Reciprocal Attribute Mapping page. This opens a basic XML editor that lets you modify the
XML directly. When finished, click OK or Cancel to close the XML editor.

4.8 Configuring Jobs

Designer has a job scheduling utility to schedule events. Through this utility, the system can be set to
disable an account on a specific day, or to initiate a workflow to request an extension for a person’s
access to a corporate resource. Designer’s job scheduler contains the same functionality as the job
scheduler found in iManager. For information on creating jobs, see Section 14.1, “Creating a Job,”
on page 328.

In the Outline view, right-click the Job icon, then select Properties.

+ Section 4.8.1, “General,” on page 116
* Section 4.8.2, “Trace,” on page 117

4.8.1 General

You have one selection under the General heading: Policy Name. You can change the job’s name by
modifying the name that appears in the Policy Name entry. Then click OK.
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4.8.2 Trace

Through the Modeler, you can add a trace level to your jobs. With the trace level set, DS Trace
displays the Identity Manager events as the engine processes the events. The trace level only affects
the driver where it is set.

WARNING: You should use the trace level only for testing or for troubleshooting driver issues.
Setting a driver trace level on a production driver can cause Identity Manager server to process
events slowly.

Table 4-18 describes the Job trace settings:

Table 4-18 Job Trace Settings

Field Description

Trace level As the job trace level increases, the amount of information
displayed in DS Trace increases.

Trace level 1 shows errors, but not the cause of the errors. To see
password synchronization information, set the trace level to 5.

Trace file Specify a filename and location where the Identity Manager
information is written for the selected driver. When a value is set in
this field, all Java information for the job is written to file.

As long as the file is specified, Java information is written to this
file. If you do not need to debug Java, leave this field blank.

Trace File Encoding The trace file uses the system’s default encoding. You can specify
another encoding if desired.

This option is only available if the job is on a driver or driver set
associated with a server that is version 3.6 or newer.

Trace file size limit Allows you to set a limit for the Java trace file. If you set the file size
to Unlimited, the file grows in size until no disk space is available.

NOTE: The trace file is created in multiple files. Identity Manager
automatically divides the maximum file size by ten and creates ten
separate files. The combined size of these files equals the
maximum trace file size.

Trace name Helps you track job trace messages. The name that you specify
here appears with the job trace messages.

For more information about viewing as saving trace information with DS Trace, see Section 4.7.8,
“Driver Trace Levels,” on page 100.

4.9 Configuring ID Policy Containers

An ID Policy container is a repository for ID policies and is used in conjunction with the ID
Provider driver. When the ID Provider driver receives an ID request from a client, it generates an
identification that is based on the ID policy specified in the request and passes the identification to
the client.
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To configure an ID Policy container, you must first add the 1D Provider driver to a driver set that
accesses an ldentity Manager 3.6 Identity Vault. Then, under the ID Provider driver, create an ID
Policy container by right-clicking the 1D Provider driver and selecting New > ID Policy Container.
After the container is created, double-click the ID Policy container in the Outline view, or right-click
the ID Policy container and select Properties.

Table 4-19 ID Policy Container General Settings

Field Description

Name The name of the ID Policy container. You can
change the name as necessary.

Notes You can add notes to better define how you are
using the ID Policy container.

In order for ID policies to work, you must also add and configure an ID policy in the ID Policy
container. See Section 4.10, “Configuring 1D Policies,” on page 118.

4.10 Configuring ID Policies

An ID policy allows the ID Provider driver to generate unique 1Ds. When the 1D Provider driver
receives an ID request from a client, it generates an identification that is based on the ID policy
specified in the request and passes it to the client. ID Provider driver and ID policies are a feature of
Identity Manager 3.6.

The ID Provider driver can act as a client itself and can assign IDs to objects in the Identity Vault.
For more information about the 1D Provider driver and its components, see the 1D Provider Driver
Guide (http://www.novell.com/documentation/idm36drivers/index.html).

To configure an ID policy, you must first add the ID Provider driver to a driver set that accesses an
Identity Manager 3.6 Identity Vault. Then under the ID Provider driver, create an 1D Policy
container, then add an ID policy. Once created, double-click the ID policy in the Outline view, or
right-click the 1D policy and select Properties.
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Figure 4-16 The ID Policy’s General Properties Page
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| Apply |
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Table 4-20 The ID Policy’s General Settings
Field Description
Policy Name The name of the ID policy.

Policy’s Last ID

Constraints:

Minimum/Maximum

Exclude/Include

Prefix:

The last ID number that was used by this ID policy.
If you have deployed this ID policy, use the Connect
icon to update this field to the last ID number that
was stored in the Identity Vault for this ID policy.

NOTE: Only the ID Provider driver can update the
last value stored in the Identity Vault.

Numbers must be between 0 and 2147483647. If
you have a fixed system that can only handle eight
digits, set the Maximum to 99999999.

Allows you to include or exclude a set of numbers
that you type in. Numbers can be typed in a coma-
delimited list and you can use ranges, such as
10,100,1000,5000-10000,1099, etc.

Allows you to give a prefix to the IDs that are
generated using this ID policy. If you create multiple
ID policies, a prefix is useful to see which ID
policies are being used. An example is WFID, for
workforce IDs.
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Field

Description

Fill: Yes/No

Access Control:

Enabled

ACL:

If you choose Yes, the ID is filled with leading zeros
(0) up to the maximum length. This helps keep
generated IDs at the same length. If you select No,
it does nothing and the ID lengths increment over
time.

Check this box if you want to enable access control
lists.

Type in the access control lists you want to use.
Access control must be enabled before you can
type in ACLs.

4.11 Configuring Application Properties

To view or change an application’s settings, double-click the application (for example, LDAP

Directory) in the Modeler.

Figure 4-17 The General Properties Page for an Application
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Section 4.11.1, “General,” on page 121
Section 4.11.2, “Environment,” on page 121
Section 4.11.3, “Administrator,” on page 121
Section 4.11.4, “Connectivity,” on page 121
Section 4.11.5, “AD Domain,” on page 125
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4.11.1 General

Table 4-21 An Application’s General Settings

Field Description

Type Changes the type of application your driver connects to. For
example, if you configure a JDBC driver to connect to a MySQL*
database, but then need to change to an Oracle database, you can
scroll to Database, select Oracle, then click Apply.

New Enables you to edit a driver’s icon. See Section 4.7.7, “Driver
iManager Icon,” on page 100.

Edit Enables you to use the Icon Editor to customize the application’s
icon. Is available after you click New, edit an icon, and click
Update.

Browse Enables you to navigate to and select an image file.

Name Enables you to customize the application’s name or label.

Version Enables you to document the application’s version.

4.11.2 Environment

You can enter notes about the application’s environment.

4.11.3 Administrator

The Administrator option is divided into three sections. Entering information in these sections is
optional.

+ Personal Information: Enables you to enter information specific to the Identity Vault, such as
Name, Title, Department, and Location,

+ Contact Information: Enables you to enter information such as Email, Phone, Cell phone,
Pager, and Fax.

+ Notes: Allows you to type any reminders you might need for future reference.

4.11.4 Connectivity

+ “Host Names” on page 122

+ “LDAP” on page 122

+ “VNC” on page 123

+ “eDirectory / NDS” on page 123

+ “Configuring a Remote Connection” on page 124
¢ “Customizing the Viewer” on page 124
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Host Names

NOTE: This control is available only for eDirectory and NDS applications.

The Host Names field lets you create a list of server IP addresses and DNS names for your
eDirectory or NDS application. Since servers can have multiple IP addresses and DNS names, it is
useful to be able to create a list of those host names that you can easily access when configuring
connectivity for your eDirectory or NDS application.

Figure 4-18 Host Name List for eDirectory and NDS Applications

Hosk Mames (IP addresses and DN names):

192,165.15.254 Mew, ..
servlz.carpl.com

192,168.10.35 Edit. ..

Delete

LDAR | wWE | eDirectory

Huosk: b
Park: 192,1658.158,254
mrk: servlz.carpl.com
192,165.10.35
User:
=Er [Clear items in lisk]
Password:

You can add, modify, and delete host names from the Host Names list.

When you specify a host on the LDAP, VNC, or eDirectory/NDS tabs, the host entry is automatically
added to the Host Names list.

Double-click an entry in the Host Names list to automatically populate the Host field in the the
LDAP, VNC, or eDirectory/NDS tabs.

Host entries in the Host Names list are also available from the Host field dropdown list in the LDAP,
VNC, and eDirectory/NDS tabs.

LDAP

You can configure some applications (for example, Active Directory, eDirectory, and LDAP) for an
LDAP connection. If the application doesn’t support an LDAP connection, the LDAP tab doesn’t
display.

Host: The server’s IP address or DN (in LDAP format).
Port: The server port to communicate with the directory.

User: The user’s name.

122 Designer 3.5 for Identity Manager 3.6 Administration Guide



Password: The user’s password.

VNC

From within Designer, you can view the desktop of the machine that is running your applications,
and remotely control that desktop by interacting with it. This feature enables you to administer users
or your applications with the native tools of that system, from one location.

This functionality is hosted in an embedded editor inside Designer. You can have multiple remote
control sessions with different systems, all open at the same time.

Figure 4-19 A Remote Desktop
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eDirectory / NDS

You can configure connectivity to eDirectory and legacy NDS applications. This is similar to
configuring an LDAP connection, but uses native eDirectory and NDS protocols instead of LDAP.

Legacy NDS applications display this tab as NDS, while eDirectory application display it as
eDirectory.

Host: The server’s IP address or DN (in eDirectory/NDS format).
Port: The server port to communicate with the directory.
User: The user’s name.

Password: The user’s password.
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Configuring a Remote Connection

To remotely control a desktop, the machine that is running your application needs to have a VNC
(virtual network computing) server installed and running. You can usually download a VNC server
for free from the Internet.

You can easily configure any system or design element in Designer for this feature by editing any
application or design element:

1
2

3

4

Right-click an application or design element.

Select Properties > Connectivity.
@ Properties for Driver E @@
type filter bext Connectivity -3
General
Ervviroranent WHC
Adrinistrabor
Connectivity
Hast:
Port:
Password:
Restore DeF«.R;I]_ Apply

On the VNC tab, type the authentication information.

Host: The DN (for example, server33.houston.company.com) of the server where the VNC is
running.

Port: Typically 5901 for Linux servers or 5900 for Windows.
Password: The password to the VNC server.
Click OK.

Customizing the Viewer

A toolbar at the top of the desktop viewer enables you to configure the following:

*

Encoding type (RAW, RRE, CoRRE, Hextile, Zlib, Tight).

The default is Tight.
Compression level.
JPEG Image Quality (0 - 9).
The default is 6.
Cursor shape updates.
The default is Enable.
Use CopyRect.

The fault is Yes.
Mouse buttons 2 and 3.
The default is Normal.
View only.
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The default is No, so that you can interact with the desktop.
Clipboard.

Record session and save to file.

Send Ctrl+Alt+Delete.

Refresh.

*

*

*

*

For more information, see TightVNC documentation.

4.11.5 AD Domain

You can capture information about an Active Directory application. This information is useful if you
want Document Generator to include this information when you document the project.

If you provided information in the LDAP settings, Designer populates the AD Domain fields.

4.12 Configuring Policies

+ Section 4.12.1, “Editing a Policy Name,” on page 125
+ Section 4.12.2, “Viewing References,” on page 125
+ Section 4.12.3, “Editing a Credential Provisioning Policy,” on page 125

4.12.1 Editing a Policy Name

1 In the Outline view, right-click a policy or rule.
2 Select Properties.
The General setting displays by default.
3 Edit the name in the Policy Name field, then click OK.

4.12.2 Viewing References

The References page lists policy sets and policies that reference the policy listed in the General
page. To view the references to this policy:

1 In the Outline view, right-click a policy or rule.
2 Select Properties > References.

Linkage is how the policies reference each other. In Identity Manager versions earlier than 3.5,
linkage determined the order that policies were executed. To change the linkage, use the Policy
Builder.

4.12.3 Editing a Credential Provisioning Policy

1 In the Outline view, right-click a credential provisioning policy (for example, a repository).
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2 Select Properties.
3 Edit the policy name, then click OK.

4.13 Adding Prompts to a Driver Configuration
File

Several node types are defined for driver configuration files. These extensions were made to support
the following:

+ Prompting once for a value that is used repeatedly throughout a single driver configuration file.

+ Prompting once for a value that is used across multiple driver configuration files, as part of the
Import Drivers Wizard.

+ Allowing the user to select a value from a drop-down list of values.
+ Global modification of the driver configuration file as per a contained XSL stylesheet.

+ Built-in variables that can be referenced without declaring them to access information about the
driver and its environment (a tree name, driver set name, driver set DN, server name, server
DN, driver name and driver DN).

+ The ability to “layer” prompts. It is possible to ask the user multiple sets of questions, with the
second and later sets being controlled by the user's responses to prior sets. For more
information, refer to the FlexiblePrompts document.

The primary new node types are variable-decl, variable-ref, and xsl-modify.

Table 4-22 New Node Types

New Node Type Description

variable-decl Allows you to define driver configuration variables that are prompted for (optionally)
and replaced into a driver configuration file during its import. Multiple variable-decl
blocks can be used to define a “layered” set of prompts. Refer to the FlexiblePrompts
document for more information.

variable-ref Used to reference a variable defined in a variable-decl within your driver configuration
files.
xsl-modify Used to globally modify the driver configuration file after all variables (and prompting)

have been resolved. The contents of this node are extracted and used as an XSL style
sheet that is applied to the patched driver configuration file.
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For information on adding prompts to a sample configuration file, see “Editing Driver Configuration
Files,” which is an appendix in the Novell Identity Manager Administration Guide (http://

www.novell.com/documentation/idm35/index.html).

4.14 Editing a Notification Template Name

1 Inthe Outline view, expand Default Notification Collection.

=2 Project | OF Outline 53 =g
ELIEEES
= g projeck
=[] 1dentity vault
E server

+ E Driver Set
-k [_)el‘ault Matification Collection

=
g

Avvailability
Availabiliby_en

=/| Default Job Matification

Default Job Motification_en
Delegate

= Delegate_en
_-—' Fargok Hink
E Fargot Hink_en

= Forgot Password

s Forgot Password_en
=/| Passwiord Reset Fail

2 Right-click a notification template (for example, Forgot Password), then select Properties.
3 Edit the name, then click OK.

For additional information, see Chapter 10, “Setting Up E-Mail Notification Templates,” on

page 215.

4.15 Synchronizing Passwords

To view or edit password synchronization, use the Dataflow editor. See Section 7.2.1, “Filtering

Views,” on page 174 and “Synchronizing Passwords” on page 174.
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Managing Identity Manager
Versions

Your environment might have versions of Identity Manager earlier than version 3.6, or you might
have a mixture of different versions of Identity Manager.

Before Designer 2.0, if you configured and wrote policies for an earlier version of Identity Manager
in your environment, you might have encountered the following issues:

+ You could easily build a solution that would not deploy.

+ You did not know which features worked in one environment versus another environment.

To solve these issues, Designer 3.5 tracks versions of the following objects:

+ Identity Manager engines

+ Identity Vaults (trees)

¢ Drivers
As you use Designer 3.5, you see only the Ul of features that apply to the version that you are
working on. Project Checker and Deploy ensure that what you have configured is supported in the
target environment.

+ Section 5.1, “Key Differences in Identity Manager Versions,” on page 130

+ Section 5.2, “Changing the Identity Manager Version,” on page 130

+ Section 5.3, “Tracking Versions of Identity Manager,” on page 131

+ Section 5.4, “Information in the Driver Configuration Wizard,” on page 133

+ Section 5.5, “Checking Projects for \Version Issues,” on page 134

+ Section 5.6, “Adjusting the UI Based on the Version Number,” on page 135
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5.1 Key Differences in ldentity Manager Versions

Table 5-1 Differences in ldentity Manager Versions

Identity Manager 3.0.1

Identity Manager 3.5

Identity Manager 3.6

+ New DirXML Script actions
* New Log Events:
+ Add Value (on add)
¢ Get Named Password
+ Reset Attributes
+ Add Value (on modify)

+ Resource Objects were
added:

¢ Credential
Provisioning
Applications

+ Credential

Provisioning
Repository Objects

+ Generic Resource
Objects

+ New object types were
added:

+ ECMAScript Objects
+ Jobs

+ Mapping Table
Resource Objects

+ Resource Libraries

* New Policy Linking
capabilities where a policy
can be in multiple lists

+ Many new DirXML Script
actions, conditions, tokens,
and verbs

+ Ability for DirXML Script to
nest conditions

+ Driver-scoped local
variables in DirXML Script
that let you refer to variable
outside of the policy

*

Support for 64-Bit Operating
Systems

New installation Program

New Driver Configuration Files
Driver Health Monitoring

New ID Provider Driver
Reciprocal Attribure Mapping

Addtional DirXML Script
Elements

Nested Group Support
User Application
Designer 3.5

5.2 Changing the Identity Manager Version

You can both import and deploy to all versions of Identity Manager that shipped since Identity
Manager 2.0, up to and including Identity Manager 3.6. You can also import from DirXML 1.x

environments.

Because versions earlier than Designer 2.0 M5 did not track Identity Manager versions, those earlier
projects do not have version information.. When you convert an earlier project, Designer 3.5
defaults the Identity Manager version numbers to 3.5. During conversion, Designer informs you that
this default is being applied.

You can change this version number by doing either of the following:

+ In the Outline view, right-click the Server object, select Properties, then select from the Identity
Manager Version drop-down list.

+ In the Modeler, select an Identity Vault, click Window > Preferences, expand Novell and select
Identity Manager, then select a version from the drop-down list.

You can also find information on upgrades, information on downgrades, and a link to a help topic.
This information explains the key differences between versions of Identity Manager.

When you import into a new server (or create a server based on a server that you have browsed to in
the directory), the new server inherits the imported version of Identity Manager.
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If you do a live update in the server properties page, Designer updates the server to the current
version of Identity Manager that is in the target environment.

5.3 Tracking Versions of Identity Manager

Designer 4.0 tracks the Identity Manager version. Filtering functionality is based on this version
information. When multiple servers are associated to a driver set, Designer calculates an “effective
engine version.” This version is the earliest Identity Manager version in the driver set.

If you want to use the latest Identity Manager 3.5.1 features, it is important that all servers belonging

to the driver set are upgraded to 3.5.1. This version can be manually upgraded or downgraded from
the server properties page.

Additionally, live update buttons retrieve current Identity Manager and eDirectory version
information on the server properties page.

Figure 5-1 Live Update Buttons

Identity Manager 351
Wersion:

elirectary Mersion: eDirectory 8.8

Assigned Driver
Sek:

W

Driver Set, Identity Wault

The Add Server dialog box allows you to specify version information when an Identity Vault is
created.

Figure 5-2 The Add Server Dialog Box

@ Add Server Association E|

Specify Server for Identity Vault

HS LL

Take the defaul, specify, or browse to a server,

Server DN | 0 ey 454 ¥ Q

Identity Manager Yersion; |3,5.1

For version information or to change the default, click here

[ [l 8 H Cancel ]

The Driver Set Log Level and Driver Log Level propety pages have dynamic version widgets next
to any log event that is not supported by your effective Identity Manager version. Designer 2.0 M5

added support for several Identity Manager log events: Set SSO Credential, Clear SSO Credential
and Set SSO Passphrase.
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Figure 5-3 Log Events
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For more information about these events, see the Credential Provisioning Policies (http://
www.novell.com/documentation/idm35/index.html?page=/documentation/idm35/policy_credprov/

data/bookinfo.html) documentation.

The following figure illustrates an unsupported log event:

Figure 5-4 Message Concerning an Identity Manager Version

.Feature Mot Supported

AN

"Job" is not supported with wour current server's Identiby

Manager setting.

To enable this Feature, set the Identity Manager version on all of
wour setvers in the driver set o 3.0.1 or later,

For more details on the

Identity Manager, click (here:

ences between the wersions of
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5.4 Information in the Driver Configuration
Wizard

Figure 5-5 The Driver Configuration Wizard

@ Driver Configuration Wizard

Select Driver Configuration ‘

Listed below are all driver configurations that can connect o applications or
syskems in your model,

‘fou are imporking ko an Identity Manager 3.5.1 system

[ 5how &l

Driver Configuration Config Yer  Min IDM Ver | #
Avaya PBR User 2 3.5
d| AvayaPBE: 2 3.5

-

0,200710311316/defs/driver_configs/DelimitedTextCSYSample-IDM3_5_0-:

[CPerform required prompt checking
oo not show this dislog again

(3] [ Run ] [ Close ]

In Designer 3.5, the Driver Configuration Wizard provides more information than previous
milestone releases, including the following:

+ The engine version that you are importing into. This information is taken from the current
project. You control the version number.

+ A descriptive name of the driver configuration (no longer just the filename).

+ The version of the configuration as a single (undelimited) version number.

+ The minimum required engine version for this configuration to run.

+ The full filename of the selected list item. This name is below the list. It is displayed there for
transparency.

+ A check box that indicates possible unrecommended or incompatible configuration files.

Figure 5-6 A Deselected Show All Check Box

@ Driver Configuration Wizard

Select Driver Configuration ‘

Listed below are all driver configurations that can connect to applications or

syskems in your model,

Driver Configuration Config Wer  Min IDM Yer | #

‘fou are importing to an Identity Manager 3.5.1 system

Avaya PBX User 2 3.5

i [ Avaya PBY 2 3.5
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By default, the Show All check box is deselected if unrecommended or possibly incompatible
configuration files are available. If all available driver configuration files are recommended and
guaranteed compatible, the check box is dimmed and selected, indicating that all available
options are displayed.

A deselected Show All check box implies the following:
+ Additional driver configuration files are available but they are not recommended.
+ The additional driver configuration files are probably incompatible with the engine
version that you are importing to.

In the following figure, the Show All check box is selected.

Figure 5-7 A Selected Check Box in the Wizard

@ Driver Configuration Wizard

Select Driver Configuration c

Listed below are all driver configurations that can connect to applications or systems in your
model.

‘fou are importing to an Identity Manager 3.0.1 system

Driver Configuration Config Ver | Min IDM Y # |

IDM Driver for IDBC 2 i: 2.0.1

IDM Driver For JDBC 2 I 3.5.0
12 [ IDM Driver For JM5 5.0 1 3.5.0
E LOAP 1 2.0.1
b |
£ |
| Caftrunicom.novell designer idmfdefs/diver_corfigs/ActiveDirectory-ID2_0_L-vixml | [Browse. .

Perform required prompt checking
0o nat shaw this dialog again

.':':7';. Run ] [ Close ]

The list now contains many more items than were displayed when the check box was deselected.
These new items were previously hidden because the minimum required engine version for them is
3.5. Because the user is importing to 3.5, the configuration might be incompatible.

5.5 Checking Projects for Version Issues

A full suite of project checks makes sure that what you have configured makes sense for your target
environment and can be successfully deployed. Designer's Ul blocks the creation of unsupported
objects and hides features based on the version number. Nevertheless, unsupported actions might
still occur through a few “back-door” methods, such as copying and pasting, importing, and
downgrading your server after you have configured for a newer environment.

In all of these methods, Project Checker catches the problems.

For example, for policy libraries to work, all of the servers on a given driver set need to be at the
same ldentity Manager 3.5 version. Project Checker catches problems like this where you might
have an unsupported mix of servers. In this case, the project check results would look like the
following figure:
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Figure 5-8 Project Checker
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I:_D Identity Wault user password is not stored in the project, Identity Wault
4 »

\ersion problems are sorted to the top and have a version icon. If you double-click the item, you get
more details about the problem and how to resolve it.

5.6 Adjusting the Ul Based on the Version
Number

Designer displays and enables or disables capabilities based on the version of Identity Manager that
is associated with the Identity Manager engine. For example, if you edit a policy that is associated
with a server that uses Identity Manager 3.5, Policy Builder shows you all of the new actions,
conditions, verbs, and tokens that ship with that release. This feature lets you try out the next version
of Identity Manager before it is even released.

Also, if you set the server to Identity Manager 3.5 (or earlier), you get the previous version of Policy
Builder that Designer has shipped with in the past.

If you try to create an object that is not supported by your server version, a prompt tells you that this
action isn't supported. For example, Identity Manager 3.5 introduces the concept of Jobs, Mapping
Tables, and Policy Libraries. If you try to create one of these objects on a 3.5 server, you see the
following message:

Figure 5-9 Prompt: Feature Not Supported

.Feature Mot Supported x|

"Job" is not supported with wour current server's Identity
& Manager setting.

To enable this Feature, set the Identity Manager version on all of
wour servers in the driver set to 3.5 or later,

Far more details on the differences between the versions of
Identity Manager, click ihere:

Future milestones of Designer will continue to evolve the Ul to better handle version differences.
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Managing the Schema

Designer includes a copy of the base Identity Vault schema, which is stored in the
BaselVSchema.xml file. This file is located in
\Designer\eclipse\plugins\com.novell.core.datatools_x.x.x.x\defs\schema, where
X.X.X.X represents the specific Designer build.

Do not directly modify BaselVSchema.xml. Instead, use Designer to add the schema information
from this file into your project. The Manage Schema tool allows you to change the schema as part of
the project without modifying the original BaselvSchema.xml file.

You can add, delete, rename, and modify classes and attributes in the Identity Vault schema. You can
import the Identity Vault schema from the production environment, or use the default schema. After
modifying the schema, you can deploy it into the production Identity Vault.

WARNING: If you do not have a good understanding of how the Identity Vault schema works,
changing the default schema can cause data corruption. If you modify classes or attributes and then
deploy the modified schema into a tree where these classes are in use, one of the following problems
can occur:

+ Those objects can become unknown.
+ Synchronization errors can occur.

To understand the basics of the schema, see “Managing the Schema” (http://www.novell.com/
documentation/edir88/index.html?page=/documentation/edir88/edir88/data/a4a9bz0.html) in the
online documentation for Novell eDirectory 8.8.

If you subscribe to LogicSource, see Novell LogicSource for eDirectory (http://support.novell.com/
subscriptions/articles/novell_logicsource.html) for additional information. LogicSource is a
subscription-based service that Novell provides to its customers.

+ Section 6.1, “Using the Manage Schema Tool,” on page 137

+ Section 6.2, “Creating Classes and Attributes,” on page 147

+ Section 6.3, “Modifying the Schema,” on page 149

+ Section 6.4, “Deploying the Schema into the Identity Vault,” on page 150

+ Section 6.5, “Exporting the Schema to a File,” on page 152

+ Section 6.6, “Importing the Schema,” on page 155

+ Section 6.7, “Managing a Copy of an Application Schema,” on page 160

+ Section 6.8, “Mapping Identity Vault to an LDAP Schema,” on page 162

+ Section 6.9, “Comparing the Schema,” on page 163

6.1 Using the Manage Schema Tool

To open the Manage Schema tool, right-click an Identity Vault object (in the Modeler or Outline
View), then select Manage Vault Schema.
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If a custom schema in the production environment needs to be tested, you can import the schema
into Designer. After you have tested and modified the schema, you can deploy it into the production
environment. For information about importing schema, see Section 6.6, “Importing the Schema,” on
page 155.

The Manage Schema tool lets you add, delete, rename, and modify classes and attributes in the
Identity Vault schema. The class information and the attribute information is organized into separate
tabs in the Manage Schema tool.

+ Section 6.1.1, “The Classes Tab,” on page 138
+ Section 6.1.2, “The Attributes Tab,” on page 141

6.1.1 The Classes Tab

From the Classes tab, the Manage Schema tool lets you add, delete, rename, and modify schema
classes.

Classes | attributes

E-l" : 1 @ Flags:
[Anything] & @ Effective ] Container
[Mokhing] ) Nor-effective
AFP Server ) Auiliary
Ass |
apﬁ]caﬁgnﬁnhty ASNL: | 2.5.6.1
applicationProcess
AuditFile Object ] show inherited assaciations
authPasswordObject
Birdery Object Artributes | Super | Sub Containnment
Bindery Queue
certificationuthaority @ T
certificationauthorityer2 : ;
CommExec Alizsed Object Name (Mandatory)
Computer
contingentWorker w
] only show changes

[ K ][ Cancel J El

The Classes tab includes the following components:

+ “Classes List Toolbar” on page 138

+ “Only Show Changes” on page 139

+ “ASN1” on page 139

+ “Flags” on page 139

+ “Show Inherited Associations” on page 140
+ “Associations List” on page 140

Classes List Toolbar

The Classes list includes the following tools:
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Table 6-1 Classes List Toolbar

Icon Description

Add Class (ﬁ’ Launches the New Class Wizard to create a new
Identity Vault class.

Rename Class @ Renames any non-base class. You cannot rename
base classes.

Delete Class ¥ Deletes any non-base class. You cannot delete
base classes.

Schema Notes =] Adds descriptive notes to any non-base class.You
cannot add notes to base classes.

Only Show Changes

The Only show changes checkbox is below the Classes list. When selected, the Classes list displays
only those classes that are not part of the base schema, as defined in BaselvVSchema.xml. If no non-
base classes exist, the Classes list is empty.

Deselect Only Show Changes to see a complete list of base and non-base classes in the Identity
Vault schema.

ASN1

Specifies the class’s “Abstract Syntax Notation number One” ID. The ASNL1 ID is important is you
plan to make the schema definition publicly available.

If you register your schema definition with Novell, Novell assigns your class an ASN1 ID. This
unique identifier eliminates the possibility of schema collisions caused by duplicate schema names
with different definition structures.

For more information about ASN1, visit the ASN.1 Consortium (http://www.asnl.org/).

Flags
The Flags options let you modify the class type:

Table 6-2 Supported Class Types

Flag Description

Effective You can create an instance of the defined object in
the Identity Vault.

Noneffective Only used to define other classes. You cannot
create an object of a noneffective class.

Auxiliary Combines attributes to be added to other classes
by extending the object class attribute.

Container Sets the object as a container object instead of a
leaf object. If it is set to container, this object can
contain other objects.
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Show Inherited Associations

The Show Inherited Associations checkbox determines whether the Associations list displays all
attributes associated with a class. When selected (the default), the Associations list displays both
assigned and inherited attributes. When deselected, the Associations list displays only assigned
attributes.

NOTE: When you select Show Inherited Associations, you cannot delete entries from the
Associations list.

Associations List

The Associations List displays the classes and attributes associated with the selected class. The
Associations List includes four tabs, each with a toolbar.

Attributes: The Attributes tab displays the attributes associated with the selected class. It also
identifies if attributes are mandatory or naming. All unmarked attributes are optional.

The Attributes tab includes the following tools:

Class Field Description

Add Naming @i Adds a naming attribute association to the selected
class.

Add Mandatory &f Adds a mandatory attribute association to the
selected class.

Add Optional & Adds an optional attribute association to the
selected class.

Delete ¥ Deletes an attribute association from the select
class.

Super: The Super tab displays the classes from which the selected class inherits attributes. A class
that another class inherits from is called a superclass.

A class can inherit attributes from more than one super class. The super class that every class
inherits from is Top. No class exists above Top. For example, Group inherits directly from Top, but
User inherits from Organizational Person. Organizational Person inherits from Person. Person
inherits from ndsLoginProperties, and ndsLoginProperties inherits from Top.

The Super tab includes the following tools:

Class Field Description

Add Superclass Association & Adds a superclass association to the selected
class.

Delete ¥ Deletes a superclass association from the selected
class.

Sub: The Sub tab displays all classes that inherit from the selected class. If the Sub tab is empty, no
classes inherit from the selected class.
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The Sub tab includes the following tools:

Class Field Description

Add Subclass Association G Adds a subclass association to the selected class.

Delete ¥ Deletes a subclass association from the selected
class.

Containment: The Containment tab displays the container classes that can contain the selected
class. For example, if you select the class Group, the Manage Schema tool lists the domain,
Organization, and Organizational Unit classes, which can contain the Group class.

The Containment tab includes the following tools:

Class Field Description

Add Containment Class Association G Adds a containment class association to the
selected class.

Delete ¥ Deletes a containment class association from the
selected class.

6.1.2 The Attributes Tab

From the Attributes tab, the Manage Schema tool lets you add, delete, rename, and modify attributes
associated with schema classes.

Clasees | Attributes

a [ @ Fags:
Attributes of | Alias w | []Public Read [[Hidden
sync Immediate [ Single-Valued
ifl —— # | [Jread Only [CIrer replica
iased Object Name

Audit:File Link [ 5tring [“Iserver Read
Autharity Revocation [CTwrite Managed

auxClassCompakibility

Back Link [(5ized

Bindery Property

CA Private Key

CA Public Key _

Certificate Revocation ASNL: | 2,16,840.1,113719.1.1.4.1,174
Certificate Walidity Inkerval

creatorshlame Syntax: | Distinguished Marme w
Cross Certificate Pair

DirdML-Associstions " - T

Eoulvalent To , 7 [] show inherited associations

11N

Used by Classes: @ G
[C] only shows changes @ @ @
Top

L oK J[ CanceIJ El

The Attributes tab includes the following components:

+ “Attribute List Toolbar” on page 142
+ “Only Show Changes” on page 142
+ “Flags” on page 142
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+ “ASN1” on page 143
+ “Syntax” on page 143
+ “Show Inherited Associations” on page 146
+ “Associations List” on page 146
Attribute List Toolbar

The Attributes list includes the following tools:

Table 6-3 Classes List Toolbar

Icon Description

Add Attribute & Launches the New Class Wizard to create a new
attribute.

Rename Attribute [F2 Renames the selected non-base attribute. You

cannot rename base attributes.

Delete Class # Deletes the selected non-base attribute. You
cannot delete base attributes.

Schema Notes =] Adds descriptive notes to any non-base
attribute.You cannot add notes to base classes.

Only Show Changes

The Only show changes checkbox is below the Attributes list. When selected, the Attributes list
displays only those attributes that are not part of the base schema, as defined in Base IVSchema. xml.
If no non-base attributes exist, the Attributes list is empty.

Deselect Only Show Changes to see a complete list of base and non-base attributes in the Identity
Vault schema.

Flags

Attribute flags specify the information that is stored in the attribute and limit the list of acceptable
operations that the Identity Vault, and eDirectory clients, can perform on the attribute.

Table 6-4 Supported Attribute Flags

Constraint Description

Public Read Allows anyone to read this attribute without the read privilege
specifically assigned. You can't use inheritance masks to prevent
an object from reading attributes with this constraint.

Sync Immediate When the attribute is modified, it is synchronized immediately to all
of the servers in the replica ring.

Read Only Only the eDirectory server process can read this attribute.

String Allows only string information to be stored in the attribute.
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Constraint Description

Write Managed Explicit rights are granted before this attribute can be changed. In
order to modify this attribute, users must have managed rights on
the object to change the attribute.

Hidden Only the eDirectory server process can read this attribute.

Single Valued Allows one value to be stored in the attribute.

Per Replica Allows one value to be stored in the attribute.

Server Read The attribute can be read by an NCP™ server object even though

the right to read is not inherited or explicitly granted. The NCP
server object is always able to read this attribute, regardless of the
rights granted in the ACL.

Sized Limits the range of values supported by the attribute to some
subset of those supported by the attributes data type.

For example, you might restrict an Integer attribute to only accept
values between 1 and 100.

ASN1

Specifies the attribute’s “Abstract Syntax Notation number One” ID. The ASNL1 ID is important is
you plan to make the schema definition publicly available.

If you register your schema definition with Novell, Novell assigns your attribute an ASN1 ID. This
unique identifier eliminates the possibility of schema collisions caused by duplicate schema names
with different definition structures.

For more information about ASN1, visit the ASN.1 Consortium (http://www.asnl.org/).

Syntax

An attribute syntax defines a standard data type that an attribute uses to store its values in the
Identity Vault. Each attribute must have a syntax. Table 6-5 describes the available syntaxes for
Identity Vault attributes.

Table 6-5 Syntax for Attributes

Syntax Description

Back Link The remotelD field identifies the backlinked object on the server, and the
objectName field identifies the server holding an external reference.

Boolean Two Boolean attributes match for equality if they are both True or both False. True is
represented as one (1), and False is represented as zero (0). Any attribute defined
by using this syntax is single valued.

Case Exact String  Attributes using this syntax can set size limits. Two Case Exact Strings match for
equality when they are of the same length and their corresponding characters are
identical.
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Syntax Description

Case Ignore List ~ Two Case Ignore Lists match for equality if the number of strings in each is the
same, and all corresponding strings match. For two corresponding strings in the list
to match, they must be the same length and their corresponding characters must be
identical (according to the rules for case ignore strings).

Case Ignore String Used in attributes whose values are strings and where the case (upper or lower) is

ignored.
Class Name Used to match two class names where the case (upper or lower) is ignored.
Counter The attribute is single valued. The syntax is similar to Integer, except that any value

added to an attribute is arithmetically added to the total, and any value deleted is
arithmetically subtracted from the total.

Distinguished The attribute is the distinguished name of the object up to 256 Unicode* characters.
Name This is not case sensitive.
EMail Address Used to match attributes whose values are e-mail addresses and whose lengths

and corresponding characters are identical; however, it ignores case (upper and
lower). Only the EMail Address attribute uses this syntax.

Facsimile Facsimile Telephone Number values are matched based on the telephone number

Telephone Number field. The rules for matching fax telephone numbers are identical to those for the
Case Exact syntax except that all space and hyphen (-) characters are skipped
during the comparison. Only the Facsimile Telephone Number attribute uses this
syntax.

Hold This syntax is an accounting quantity, which is an amount tentatively held against a
subject’s credit limit, pending completion of a transaction. In the wire format, the
Subject field is the distinguished name of the object. The Identity Vault treats the
Hold amount similarly to the Counter syntax, with new values added to or subtracted
from the base total. If the evaluated Hold amount goes to 0 (zero), the Hold record is

deleted.
Integer The attribute is an integer. Attributes using this syntax can set size limits.
Interval The Interval value is the number of seconds in a time interval.
Net Address Stores the network address as a binary string. The string is the literal value of the

address. It lists the type of communication protocol used.

Numeric String Two numeric strings match for equality when they are of the same length and their
corresponding characters are identical. It matches the digits 0-9 and spaces if they
are contained in the numeric string.

Object ACL An Object ACL value can protect either an object or an attribute. The protected
object is always the one that contains the ACL attribute. If an ACL entry is to apply
to the object as a whole, the protected attribute name should be left empty (NULL).
If a specific attribute is to be protected, it should be named in the ACL entry.

Octet List A presented octet list matches a stored list if the presented list is a subset of the
stored list. Octet strings are so designated because they are not interpreted by the
Directory. They are simply a series of bits with no Unicode implications.

The length is the number of bits divided by 8 and rounded to the nearest integer.
Thus, each octet represents eight bits of data. The number of data bits is always
evenly divisible by 8.
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Syntax

Description

Octet String

Path

Postal Address

Printable String

Replica Pointer

Stream

For two octet strings to match, they must be the same length and the corresponding
bit sequence (octets) must be identical. When comparing two strings, the first pair of
octets that do not match are used to determine the order of the strings. Octet strings
are not Unicode strings.

The string represented by the path field is compared for equality using the same
rules that Case Exact String uses. That is, two paths match for equality when their
lengths and corresponding characters, including case, are identical.

An attribute value for Postal Address is typically composed of selected attributes
from the MHS Unformatted Postal O/R Address version 1 according to
Recommendation F.401. The value is limited to 6 lines of 30 characters each,
including a Postal Country Name. Normally the information contained in such an
address could include a name, street address, city, state or province, postal code,
and possibly a postal office box number depending on the specific requirements of
the named object.

The following characters are in the printable string character set.
A.Z

a..z

0...9

Space Character

* Apostrophe

( Left Parenthesis

) Right Parenthesis
+ Plus Sign

, Comma

- Hyphen

. Period

/ Slash

: Colon

= Equal Sign

? Question Mark

Two printable strings match for equality when they are the same length and their
corresponding characters are identical. Case (upper or lower) is significant when
comparing printable strings. For example, as printable strings, “Jones” and “JONES”
do not match.

Each value of the replica pointer syntax is composed of five parts:

* The complete name of the server that stores the replica.

+ A value describing a the capabilities of this copy of the partition: master,
secondary, read-only, or subordinate reference.

+ Avalue indicating the current state of the replica (new, dying, locked, changing
state, splitting, joining, or moving).

+ A number representing the replica. All replicas for a partition have a different
number assigned when the replica is created.

+ A referral that contains a count of the addresses and one or more network
addresses that hints at the node where the server probably resides. Because
servers are accessible over different protocols, the server might have an
address for each supported protocol.

Streams are files of information. The data stored in a stream file has no syntax
enforcement of any kind. It is purely arbitrary data, defined by the application that
created and uses it. The attribute is single valued.
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Syntax Description

Telephone Number The length of telephone number strings must be between 1 and 32. Two telephone
numbers string match for equality when they are of the same length and their
corresponding characters are identical. All spaces and hyphen (-) characters are
skipped during the comparison.

Time A time value consists of a whole number of seconds, where zero equals 12:00
midnight, January 1, 1970, UTC.

Timestamp A Timestamp value contains three components:
* The wholeSeconds field consists of the whole number of seconds, where zero
equals 12:00 midnight, January 1, 1970, UTC.

* The replicaNum field identifies the server that created the Timestamp. A
replica number is assigned whenever a replica is created on a server.

+ The eventID field is an integer that orders events occurring within the same
whole-second interval. The event number restarts at one for each new second.

Typed Name The syntax names an Identity Vault object and attaches two numeric values to it:

* The level of the attribute indicates the priority.

+ The interval indicates the frequency of references.

The the objectName or Distinguished Name identifies the Identity Vault object
referred to by the Typed Name.

Unknown Unknown syntax is used to stop the loss of data, if the Identity Vault database
becomes corrupted. When an object becomes Unknown, there is information stored
in this attribute that can allow the object to be recovered. This syntax is used by the
Identity Vault.

NOTE: The information in Table 6-5 comes from the Novell LogicSource for eDirectory.
LogicSource is a subscription-based service Novell provides to its customers. For more information
about LogicSource, see Novell Technical Subscriptions (http://support.novell.com/subscriptions/
articles/novell_logicsource.html).

Show Inherited Associations

The Show Inherited Associations checkbox determines whether the Associations list displays all
classes associated with an attribute. When selected (the default), the Associations list displays both
assigned and inherited classes. When deselected, the Associations list displays only assigned
classes.

The schema allows for inheritance of other attributes from super classes. If you select this item, all
attributes that are associated with a class, whether assigned or inherited, are listed. If you don’t
select this item, only the assigned attributes are listed.

Used by Classes lists all classes that use the selected attribute. If you select Show inherited
associations, the list includes classes that inherit the attribute.

Associations List

The Associations List displays the classes associated with the selected attribute. The Associations
List toolbar lets you make changes to the classes associated with the attribute.
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Class Field Description

Add as Naming @i Associates the selected attribute as a naming
attribute to a class.

Add as Mandatory &j Associates the selected attribute as a mandatory
attribute to a class.

Add Optional Associates the selected attribute as an optional
attribute to a class.

Delete ¥ Deletes the selected classes from the association
list.

6.2 Creating Classes and Attributes

Designer allows you to create Identity Vault classes and attributes to fit the needs of your
environment. You can test and use the new schema with the Identity Manager drivers in Designer
before implementing it in the production environment.

+ Section 6.2.1, “Creating Identity Vault Classes,” on page 147

+ Section 6.2.2, “Creating ldentity Vault Attributes,” on page 148

6.2.1 Creating Identity Vault Classes

+ “Adding a Class” on page 147
+ “Adding a Note” on page 148

Adding a Class

1 Inthe Modeler, right-click the Identity Vault, then select Manage Vault Schema.

The Classes tab lists all classes that are defined in the schema and stored in Designer. For more
information about the Classes tab, see Section 6.1.1, “The Classes Tab,” on page 138.

2 Select the Add a Class icon GF.

3 Inthe Create Class Name dialog box, specify the class name (for example, Emplinfo) and
ASNL ID (if applicable), then click Next.

For more information about ASN1 IDs, see “ASN1” on page 139.
4 In the Class Flags dialog box, select the class type, then click Next.
For information about the class type options, see Table 6-2 on page 139.

5 In the Class Inheritance dialog box, select the classes from which the new class inherits, then
click Next.

Select one or more classes in the Available classes list and move them to the Inherited classes
list with the right-arrow button. Remove classes from the Inherited classes list using the left-
arrow buttons.

6 Inthe Mandatory Attributes dialog box, select the mandatory attributes, then click Next.

The inherited attributes displayed in the Inherited mandatory attributes pane depend upon the
classes from which the new class inherits.
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7 Inthe Optional Attributes dialog box, select optional attributes, then click Next.
The Inherited optional attributes pane lists default optional inheritances.
8 Inthe Naming Attributes dialog box, select the naming attributes, then click Next.

The Identity Vault schema allows for inheritance from other classes. A class that another class
inherits from is called a superclass. A class can inherit attributes from one or more
superclasses.

Every class inherites from the superclass Top. No class exists above Top. For example, Group
inherits directly from Top, but User inherits from Organizational Person. Organizational Person
inherits from Person. Person inherits from ndsLoginProperties, and ndsLoginProperties inherits
from Top.

9 In the Containment Classes dialog box, select the containment classes for the new class, then
click Next.

This specifies the types of container classes that can contain the new class. For example, if you
select the class Group, the Manage Schema tool lists Domain, Organization, and
Organizational Unit classes as containment classes for the Group class

10 Inthe New Class Summary, review the new class information, then click Finish.
The new class appears in the Classes pane.
11 Click OK to save changes and close the Manage Schema tool.

Adding a Note

Designer allows you to add notes about any class you create. The information is stored as desc in
the _ Idif file and as a note in the .sch file.

1 Select the class you want to add a note to, then click the Schema Notes icon =l

2 Type the note in the window, then click OK.

6.2.2 Creating Identity Vault Attributes

To create a new Identity Vault attribute:

1 Inthe Modeler, right-click the Identity Vault, then select Manage Vault Schema.
2 Select the Attributes tab.

The Attributes list displays all attributes that are defined in the schema and stored in Designer.
You can view all attributes at once, or view the attributes associated with a specific class by
selecting a class from the drop-down list.

For more information about the components of the Attributes tab, see Section 6.1.2, “The
Attributes Tab,” on page 141.

3 Select the Add an Attribute icon @& .

4 In the Create Attribute Name dialog box, specify the attribute name (for example, EmpID) and
an ASNL1 ID, if applicable, then click Next.

For more information about the ASNL1 ID, see “ASNL1” on page 143.
5 In the Attribute Syntax dialog box, select the proper attribute syntax, then click Next.

An attribute syntax defines a standard data type that an attribute uses to store its values in the
Identity Vault. Each attribute must have a syntax. See Table 6-5 on page 143.
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6 In the Attribute Flags dialog box, select the flags for the attribute, then click Next.

Attribute flags constrain the information that is stored in the attribute, and the list of acceptable
operations that the Identity Vault, and Identity Vault clients, can perform on the attribute. For
more information about attribute flags, see “Flags” on page 142.

7 Inthe New Attribute Summary dialog box, review the new attribute information, then click
Finish.
The new attribute appears in the Attributes list.

8 Click OK to save changes and close the Manage Schema tool.

6.3 Modifying the Schema

Designer allows you to modify the Identity Vault schema. The following sections describe fields and
definitions used in the Manage Schema tool for classes and attributes.

+ Section 6.3.1, “Deleting Schema Definitions,” on page 149

+ Section 6.3.2, “Modifying Classes or Attributes,” on page 149

+ Section 6.3.3, “Renaming Schema Definitions,” on page 150

6.3.1 Deleting Schema Definitions

You can delete an extended schema definition. You cannot delete base schema elements. If you
select a base schema class or attribute, the Delete icon is disabled.

1 Inthe Modeler, right-click an Identity Vault, then select Manage Schema.

2 Select the class or attribute that you want to delete, then click the Delete icon .

6.3.2 Modifying Classes or Attributes

1 Inthe Modeler, right-click an Identity Vault, then select Manage Vault Schema.
2 Select the class or attribute that you want to modify.
3 Modify the class or attribute as desired.
If you select a base schema class or attribute, the following pop-up message appears:

@ Confirm §|

You cannot modify base schema classes, Would wou like to create an identity
- waulk specific copy of this class to allow modification? Selecting ves may cause
errars if the schema is deplayed.

It is best to modify only the extended schema and not the base schema. Modifying the base
schema can cause data corruption and synchronization errors.
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6.3.3 Renaming Schema Definitions

You can rename extended schema definitions. You cannot rename any base schema classes or
attributes. If you select a base schema item, the Rename icon is dimmed, indicating it is unavailable.
+ “Renaming a Class” on page 150
+ “Renaming an Attribute” on page 150

Renaming a Class

1 Inthe Modeler, right-click an Identity Vault, then select Manage Vault Schema.
2 In the Class page, select a class that you want to rename, then click the Rename Class icon [£2.
3 Inthe Rename Class dialog box, specify the new class name, then click OK.

Renaming an Attribute

1 Inthe Modeler, right-click the Identity Vault icon, then select Manage Vault Schema.
2 Select an attribute you want to rename in the Attribure tab, then click the Rename an Attribute

icon [f@.

3 Inthe Rename Attribute dialog box, specify the new attribute name, then click OK.

6.4 Deploying the Schema into the ldentity Vault

After the Identity Manager driver is tested with the new schema, you can deploy the modified
schema into the Identity Vault.

1 Inthe Modeler, select the Identity Vault.

2 Select Live > Schema > Deploy.

3 Specify the Host Name.

@ schema Deploy Wizard |:|@@

Select Destination for Deploy @

Select the location where wou want to deploy the schema

Deploy to ebirectory

Host Mame: | 133.56,121,38| v
(Example: 192,168,144, 199 ar myserver, companty . com}

User Marne: | admin. novell "
{Example: Admin.Mowvell)

Passward:

The host name can be the server’s IP address or the DNS name of the server.
4 Specify the User Name, which must be a user with administrative rights to the schema.
5 Specify the user’s password, then click Next.
6 Select the classes and attributes to deploy into the Identity Vault schema, then click Next.
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@ Schema Export Wizard L E|E]

Select Classes and Attributes for Export @
Select "Export Al associations” to associate the selected attributes with classes that
might already exist in the destination system,
Classes: Attributes: [CJExport &l assodiations
[[] sssServerPolicies P #ccount Balance A
[[] sssserverPolicyOveride Allows Unilitited Credit
[[] strongawuthenticationUser audio
[[] styleshest businessCategary
[] Template carlicense
[ Tep departmentiiumber
[[] Tree Root displayhlame
[[] uamPosixConfig employesType
[] uamPosixGroup [¥] Given Mame
[[] uamPasieser Group Membership
[] uamPosidiorkstation [¥] Higher Privileges
[[] Unknown Hane Directory
User homePhone
| [ usersecuritylnformation ¥ | | [7] homepostaladdress |
Select All| | Deselect Al | select al | [Desslect al| ( Show aa |
[Ainciude base schema
@ T T R

7 Review the summary of classes and attributes to be deployed, then click Finish.
If you have selected duplicate attributes or classes, a warning box appears

@ Confirm rg|

#p Do you want ko try to delete duplicate existing attributes ar classes From
\:/ eDirectory before deploving?

8 Select Yes or No, depending upon whether you want to resolve the duplicate classes or
attributes.
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9 Review errors or warnings, then click OK.

@ Schema Export Wizard f'5_<|

Deploy Messages @
The following problems and warnings occurred while deploying the schema:

@ Error deploying attribute rbsAssignedRoles: CANT_MODIFY_EXISTIMG_ATTRIEUTE
@ Error deploying attribute Audit:Link List: CANT_MODIFY_EXISTING_ATTRIBUTE
@ Error deploying attribute Audit: Contents:CANT_MODIFY_EXISTIMG_ATTRIBUTE

':':’:' [ Ok I [Save ko Log... ]

6.5 Exporting the Schemato a File

+ Section 6.5.1, “Exporting the Schema to a .sch File,” on page 152
+ Section 6.5.2, “Exporting the Schema to an LDIF File,” on page 153
6.5.1 Exporting the Schema to a .sch File

1 Inthe Modeler, right-click an Identity Vault, then select Export to File > Schema.
2 Inthe Schema Export Wizard, select .sch format.

@ Schema Export Wizard

Select Destination for Export @
Select the location where you want to export the schema

Export ko file

|| | ’Browse...]

() .sch Format
() .IdiF Format

3 Specify a filename and location where you want to save the schema file, then click Next.
Designer appends the .sch extension when you export the file.
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4 In the Select Classes and Attributes for Export page, select the classes and attributes to export

to the .sch file, then click Finish.

@ Schema Export Wizard = El@

Claszes:

[ sssServerPolicies

[] sssserverpolicyOverride
[] strongawthenticationliser
[] stdeshest

[] Template

L Tep

[] Tree Root

[] uamPosteConfig

[[] uamPosioGroup

[] uamPosidiser

[] wamPosiworkstation
[] unknown

User

[] userSecurityInfarmation

| select il | | Deselect Al

[¥] Inchude base schema

A

Select Classes and Attributes for Export

Select "Export all associations” o associate the selecked attribubes vath classes that
might already exist in the destination system,

Attributes:

Account Balance
Allows Unlimited Credit
audio
businessCategory
carlicense
deparkmentiumber
displayhame
ernployesType
Given Name

Group Membership
Higher Privileges
Hame Directory

[+] homePhone
homePostaladdress

| select all | | Deselect Al|

(33

[C]Export 2l associations

La

@ [

< Back

|| Finish ||

[ rext >

Cancel

Export all associations (above the Attributes pane) enables you to associate the selected
attributes with the classes that might already exist in the Identity Vault. If you do not select this
box, the new attributes that should be associated with the class are not associated.

For example, if the Employee Photo attribute is associated with the User class, and Export all
associations is not selected, Employee Photo is not associated with the User class.

The classes and attributes that are in Designer are listed in the two columns. All classes and
attributes are selected by default. To prevent a class or attribute from being deployed, deselect
it. To add all classes and attributes, click Select All. To remove all classes and attributes, click

Deselect All.

6.5.2 Exporting the Schema to an LDIF File

1 In the Modeler, right-click the Identity Vault, then select Export to File > Schema.
2 In the Schema Export Wizard, select .Idif format.
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@ Schema Export Wizard

Select Destination for Export @
Select the location where you want to export the schema

Export ko File

| | [Browse...]

() .sch Format
(&) Idif Format

3 Specify a name and location where you want to save the schema file, then click Next.
Designer appends the .1dif extension when you export the file.

4 In the Select Classes and Attributes for Export page, select the classes and attributes to export
to the . Idif file, then click Finish.

@ Schema Export Wizard - FEIIE]

Select Classes and Attributes for Export @
Select "Export all associations” to associate the selected sttribubes with classes that
might already exist in the destination system,
Classes: Attributes: [C]Export all associations
[ sssServerPolicies A Account Balance ~
[] sssServerpolicyCverride Allow Unlimited Credit
[ strongauthenticationser sudio
[ styleShest businessC ategory
(] Tempilate carlicense
] 1op departmentiiumber
[] Tree Roat displayName
[ vamPasixConfig emplovesType
[] uamPosixGroup Given Name
[] uamPostdlser Group Membership
[] uamPosixWorkstation Higher Privileges
[ Unknown Harme Directory
User homePhaone
[] userSecurityInformation v homefostaladdress v
[Setect Al | [Deselect an
Inchude base schema
@ | <Back || met> [ Fnsh ][ concet |

Export all associations (above the Attributes pane) enables you to associate the selected
attributes with the classes that might already exist in the Identity Vault. If you do not select this
box, the new attributes that should be associated with the class are not associated.

For example, if the Employee Photo attribute is associated with the User class, and Export all
associations is not selected, Employee Photo is not associated with the User class.

5 Click OK in the warning.

The class and attribute names in Designer are the Identity Vault (eDirectory) names. The names
for the classes and attributes in the LDIF file are the LDAP names. The Identity Vault names
differ from the LDAP names. Verify that the names listed in the LDAP file are correct for your
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environment before importing the file. For a list of Identity Vault class and attribute names
mapped to LDAP class and attribute names, see Section 6.8, “Mapping Identity Vault to an

LDAP Schema,” on page 162.

6.6 Importing the Schema

Designer allows you to import the schema from your production environment to do in-depth testing

with the Identity Manager drivers.

+ Section 6.6.1, “Importing the Schema from the Identity Vault,” on page 155
+ Section 6.6.2, “Importing the Schema from a File,” on page 157

6.6.1 Importing the Schema from the Identity Vault

1 In Designer, select an Identity Vault, then select Live > Schema > Import.

2 Inthe Select Source for Import dialog box, specify the access information to access the server

that has the schema to import, then click Next.

Specify the appropriate host name (or IP address), username, and password to access the server.

NOTE: The specified user must have administrative rights to the schema.

@® schema Import Wizard

Select Source for Import

Select the location to import the schema

Import from eDirectory

Host Mame; | 137.105.11.28 v
{Example: 192,168, 14,199 of myserver.company.com)

User Mame: | admin.corpl v
Exampla: Admin.MNowvell)

Fassword: | eesess

3 Inthe Select Classes and Attributes for Import page, select the classes and attributes to import

into the project, then click Next.
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@ Schema Import Wizard |Z|@@

Select Classes and Attributes for Import @

Select "Import all associations” ko associate the selected attributes with dasses that
might already exist in Designer,

Classes: Attributes: [Jimpart all associations

[arething] Fs [Anvthing] ~
[Mothing] [Mothing]

AFF Server accessCardhumber

Alias Account Balance

apchadmnConfiguration aCL

apchadmnConfigurationBlock, Aliased Object Name

apchadmniModule allowaliasTosncestor

apchadmnserver Allow Unlimited Credic
apchadmniirtualHosk v| apchadmn-BlockType

applicationEntity +| apchadmn-ConfigurationInfo
applicationProcess
Audit:File Object
authPasswordObject

<
1)
a
=
=
[
[N
2
:Il
=
[=]
[
c
[11]
=]
i
i1}
=
]

apchadmn-ModuleFileMame
apchadmn-ModuleCbjectFile

EEEEREEEEREEEEEEEEEEE

bhCommunity apchadmn-ModuleSymbolfame

bhCommunityMembership apchadmn-Scope

bhGadget apchadmn-Serveralias

bhModule apchadmn-ServerConfLastModified

bhPage apchadmn-ServerLastBackup

bhPageset apchadmn-ServerMame

bhPartal apchadmn-ServerPath
bhPortalZonfig b’ apchadmn-ServerPlatform [V
[Select All ] [Deselect all ] [Show &l ]
@ ’ < Back ][ Mext = ] [ Firish ] [ Cancel ]

Import All Associations: Enables you to associate the selected attributes with the classes that
might already exist in Designer. If you do not select this box, the new attributes that should be
associated with the class are not associated.

For example, if the attribute of Employee Photo is associated with the User class, and you do
not select Import all associations, Employee Photo is not associated with the User class.

View Differences: Enables you to view the differences in the schema between the Identity
Vault and Designer.

When you click View Differences, Designer opens the Schema Differences page, where you can
select those differences between the live Identity Vault and the Identity Vault in your project.

You can select schema differences individually, or click Select All to import all the schema
differences.

Click OK to move the selected class and attribute import selections into the Select Classes and
Attributes for Import page.

4 Click Next to bring up the Import Summary page, where you can review classes and attributes
to import into the project. Then click Finish.

If errors occur during the import process, the Import Messages page lists them.
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. Schema Import Wizard

The following problems and warnings occurred while importing the
schema:

Attribute already exists - srvprvHideUser, Owverwriting the old attribute.
Attribute already exists - memberlUid, Overwriting the old attribute.

Attribute already exists - UserPKCS12, Overwriting the old atiribute,
Attribute already exists - srvprvQuerylist, Owverwriting the old atiribute,
Attribute already exists - loginsShel, Overwriting the old attribute.

Attribute already exists - Transitive Wector, Owverwriing the old attribute.
Attribute already exists - gecos, Qverwriting the old attribute,
Attribute already exists - homeDirectory. COwerwriting the old atiribute.

Class aready exists - srvprvTeam. Overwriting the old class.

Class dready exists - DirsML-WorkOrder, Owverwriting the old class.

Class already exists - srvprvTheme, Cwarwriting the old class.

Class already exists - DirkML-pbxcAudixSubscriber, Overwriting the old class.
Class aready exists - srvprvRequest. Owverwriting the old class.

Class aready exists - rbsRole2. Owerwriting the old class.

Class aready exists - srvprvAppConfig. Owverwriting the old class.

< »

Import Messages @

] ryriting the old atmibuis
Could not add attribute Permanent Config Parms to class NCP Server because

Could not add attribute memberlid to class posixGroup because itis aready U

Could not add attribute loginshell to class posixAccount because it is already L
Could not add attribute Transitive Yector to class Partiion because itis already
Could not add attribute gecos to class posixAccount because it is already Using

Could not add attribute homeDirectory to class posixAccount because it is alre

@ [ o' ] [Sage tolog

)

5 On the Import Messages page of the Schema Import Wizard, click OK.

If you want to save the differences to a log file, click Save to Log. This brings up the Save As

dialog box, where you can choose a filename and directory to store the file in.

6 Click Save, then click OK.

6.6.2 Importing the Schema from a File

When you created an Identity Vault in the Modeler, Designer created a base schema in your project.
If a.sch file or .1dif file has been saved, you can quickly add classes and attributes for your drivers

by importing classes and attributes from the saved file.

+ “Importing the Schema from a .sch File” on page 157
+ “Importing the Schema from an LDIF File” on page 159

Importing the Schema from a .sch File

1 Inthe Modeler, right-click the Identity Vault that will use the imported .sch file.

2 Select Import Schema from File.
3 Select .sch format.
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3 Schema Import Wizard

Select Source for Import

Select the location to import the schema

Import from file

| ChDocuments and SettingsiMovell UseryMy Documentsidflesi | | ﬁrowse...é

@ .sch format
() Idif format

@ Mext = Cancel

4 Browse to and select the .sch file that you want to use, then click Open.
5 Click Next, then review the .sch file.

@ schema Import Wizard |:|@®

Raview LDIF/.SCH File for Import @

Review and make any desired changes to your Idiff.sch fle. Changes wil
be imported to Designer, but not saved back to the file,

NDSSchemaExtensions DEFINITIONS | =BEGIM 2
"User" ATTRIBUTE ::=

{

Operation  ADD,

SyntaxID SYN_DIST_MAME,

Flags {DS_SYMNC_IMMEDIATE, DS_MNONREMOVABLE_ATTR, DS_SERVE

ASM1ChDr {2 168401113719114 1111}

w

S X

@ [ Firish H Cancel

6 Make changes if necessary, then click Finish.
7 Click OK.

@ Schema Import Wizard

Import Messages @
The following problems and warnings occurred whie importing the
schema:

Liattribute already exists - User, Owerwriting the old atirbute, : A~
U attribute aready exists - DirdML-SPENttementskML. Gverwriting the old attrit—
U Atrbute aready exists - nspmbistrbutionPassword, Sverwriting the old atirib
U AtTbLte aready exists - MGW: Document Area Size. Sverwriting the old atirit

If errors occur, a deployment summary screen lists them.
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Importing the Schema from an LDIF File

1 Inthe Modeler, right-click the Identity Vault that will use the imported .1dif file.
2 Select Import Schema from File.
3 Select .Idif format.

@ Schema Import Wizard |:|@®

Select Source for Import @

Select the location to impart the schema

Import from file

| | [ﬁrowse...]

() .sch format

@ < Back Mext = Finish

4 Specify, or browse to, the . Idif file that you want to use, then click Open.
5 Click Next, then review the .1dif file.

® schema Import Wizard

Review LDIF/.SCH File for Import @

Review and make any desired changes ko your diff.sch file. Changes will be imported ko
Designer, but not saved back to the file.

[¥]For existing classes, import only optional atkributes (do not overvibe mandatory or naming attributes)
VErsion: 1 Tl

#ND5 attribute:EmplD

#5yntax:SYN_INTEGER

dni: cn=schema

changetype: modify

add: attributeTypes

aktributeTypes: (
empid-oid
MNAME ‘EmplD"
SYNTAX 1.3.6.1.4.1,1466.115.121.1.27
SIMGLE-VALUE
%-NDS_NOT_SCHED_SYNC_IMMEDIATE '1'
)

#NDS class:Employes
dn: cre=schema

@ < Batk Fish || cancel |

6 Make changes if necessary, then click Finish.
7 If you receive a Warning box, read the message and click OK.

Managing the Schema 159



The LDAP names of the attributes and classes are different
! E from the eDirectory names, Designer displays the eDirectory
L) names of the classes and attributes. Designer does not update
the Attribute Map and Class Map kables on the LDAR Group
object in eDirectory.

[ 0o nat shows this dislog bosx again

The class and attribute names in Designer are the Identity Vault (eDirectory) names. The names
for the classes and attributes in the LDIF file are the LDAP names. The Identity Vault names
differ from the LDAP names. Verify that the names listed in the LDAP file are correct for your
environment before importing the file. For a list of Identity Vault class and attribute names
mapped to LDAP class and attribute names, see Section 6.8, “Mapping Identity Vault to an
LDAP Schema,” on page 162.

8 Click OK.

. Schema Import Wizard

Import Messages @
The following problems and warnings occurred while importing the schema:

A Attribute already exists - DirsML-SPERtitlementssML, Cverariting the old attribute, ”~
A Aktribute already exists - DirdML-pbxPassword, Owerwriting the old attribute,

If errors occur, a deployment summary dialog box lists them.

6.7 Managing a Copy of an Application Schema

The ldentity Manager engine currently uses the application schema for the following:

+ DirXML® Script uses the dn-format/dn-delims to figure out how to parse or convert DNs
coming from and going to the application.

+ The multi-valued flag on attributes that are used during the attribute merge process that
happens as part of a match, resync, or migrate.

+ Section 6.7.1, “Editing an Application’s Schema,” on page 160
+ Section 6.7.2, “Refreshing the Application Schema,” on page 162

6.7.1 Editing an Application’s Schema

Designer enables you to manage a copy of the connected system’s schema. You can make changes to
a copy of the application schema so that you can test the Identity Manager drivers in Designer. The
schema changes cannot be deployed into the live application schema.

1 Right-click the driver connection in Designer, then select Manage Application Schema.
2 Add, rename, or delete the application’s classes or attributes, then click OK.
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24 SAP-USER Schema E]

DM Format: | <ash v|
Classes: @P E (@ attributes of this dass:
Flags:
Flags:
ASHL: | |
ASHL: Typei | v|
[ Ok ][ Zancel l
Field Description
DN format Specifies the separator character used when specifying
distinguished names. For example, admin.utah.novell.com.
Classes Lists all of the classes stored in Designer from the
application’s schema.
Add a class Adds a new class.

Rename class
Delete class

Refresh application schema

Help

Flags: Container

ASN1

Attributes of This Class

Renames the selected class.
Deletes the selected class.

Provides a new copy of the application’s schema.This option
is useful if the application schema changes.

Launches the Help documentation for the Manage Schema
tool.

Specifies whether the class is a container.

The unique ID of the class.

Lists all of the attributes stored in Designer for the selected
class from the application’s schema.
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Field Description

Add an attribute Adds a new attribute for the selected class.

Rename attribute Renames the selected attribute.

Delete attribute Deletes the selected attribute.

Flags Specifies the details of the attribute. To edit the flags, select

an attribute.

Type Specifies the syntax of the attribute. To view the syntax,
select an attribute. To change the syntax, select an option
from the drop-down list.

6.7.2 Refreshing the Application Schema

If the application schema changes, you can get a new copy of the application’s schema by refreshing
the application schema.

1 Right-click the driver connection, then select Live > Refresh Application Schema.

‘@ Expart ko Configuration File. ..
EL Import from File, ..

Lise i = Import...
3 Delete ﬁ.,n Deploy...
%, Compare...
Properties
Driver Configuration »

&% Refresh Application Schema. ..

2 Click the browse icon.

@ Sclect Server g|
Server DM (eDirectory): | DMy AUl R |

@ Select & server Fram the eDirectory tree that the driver is

running on.

[ K, H Cancel ]

3 Browse to and select the server where the driver is installed, then click OK twice.

6.8 Mapping Identity Vault to an LDAP Schema

When accessing the Identity Vault through LDAP, the names of classes and attributes might be
different than when accessed through the standard NCP-based APIs.
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For more information about how that mapping is performed, see

+ “Class and Attribute Mappings” (http://www.novell.com/documentation/edir88/
index.html?page=/documentation/edir88/edir88/data/n0000007.htmI#a5bwxyz)

NDK: Novell eDirectory Schema Reference (http://devsup.novell.de/ndk/doc/ndslib/
index.html?page=/ndk/doc/ndslib/schm_enu/data/h4glmnli.html) at the Novell Developer Support
Web page

6.9 Comparing the Schema

Designer allows you to compare schema from your production environment to do in-depth testing
with the Identity Manager drivers. Designer now provides conflict resolution on individual classes
and attributes and allows you to view the differences between existing and new values when
importing and deploying the schema. For example, before deploying schema to an Identity Vault
you can run Schema Compare.

Schema Compare shows the differences between the schema of the ID Vault and that of the
Designer. The viewer shows 'Schema' at the root level with 'Classes' and 'Attributes' under it. Classes
and Attributes can be expanded to list various classes and attributes respectively. When an item is
selected, the information section shows it as equal (no action is necessary) or unequal. If they are
unequal, you can choose not to reconcile them, choose to update them in Designer, or choose to
update them in eDirectory. To reconcile the differences between the schema of the Designer and that
of the eDirectory while in Compare, you don’t need to run the Import or Deploy of Schema.

Do the following to determine if you have deployed all the changes you made in the Designer
schema to the Identity Vault schema.

1 Right-click the ID Vault in either the Modeler view or in the Outline view. Select Live >
Schema > Compare to bring up the Designer/eDirectory Schema Compare window.
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a DesignerfeDirectory Schema Compare |z|@®

Select an object or attribute: =] | Show differences

= g schema
= Classes
) Reconcile Action: (%) by not reconcile
@ nrfTeamRole
=@ Attributes
6@ nrfalowMgrirant ToRole () Update eDirectary
@@ nrfalowMgrGrant Tolser
@@ nrfAlowMgrMaodifyRole
@@ nrfalowMgrModifyson
@ refallowMgrRevokeFromRale
@@ nrfalowMgrReyvokeFromlser
@ nrfRole
@ nrfRoleScope

Information
Compare Status: @ Mok Deploved

Text Compare

¢ Designer eDirectory

@ Close:

)

2 Expand the Select a class or attribute portion of the window to see the listed classes or
attributes respectively. Select an individual class or an attribute to see the actual differences
displayed in the Text Compare portion of the window.

The plus icon at the right side of the Select a class or attribute allows you to expand all
elements in the parent object, and the minus icon collapses all of the elements. The ? icon
displays the Summary/Compare dialog box help.

3 By default, the Compare window only displays values that are different between eDirectory
and Designer. To view all the classes and attributes, select Show all from the pull-down menu.
Your choices are Show differences, Show deletes, and Show all.

4 Check to see the status of the values that are shown. Values that are equal are shown as Equal
on the Compare Status line in the Information portion of the Compare window.
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Infor mation
Compare Status: = Unequal

Reconcile Action: @ pg not reconcile
C Update Desigher

(O Update eDirectory

The overlay image displayed in the Compare Status entry identifies objects or attributes that
need reconciliation. The following table describes what you see in the Compare Status line and
the overlays that you can see:

Compare Status Description

Equal The selected classes or attributes are same in eDirectory and Designer.

Unequal The value of the selected class or an attribute, or one or more classes or
attributes, are different in eDirectory and Designer.

]

Not Deployed The selected class or an attribute is not deployed to eDirectory.

e

Not Imported The selected class or an attribute does not exist in Designer.

B

Under the Information portion of the Compare window, select how you want to reconcile the
differences between the Source and Destination.

If Compare Status shows Unequal, you have three choices:
+ To do nothing, keep the default value of Do Not Reconcile.

+ To update the schema in Designer so that it contains the same information as the schema
in eDirectory, select Update Designer.

+ To update the schema in eDirectory to reflect the changes you have just made to the
schema in Designer, select Update eDirectory.

Check to see the Text Compare values.

The Text Compare values displayed in the bottom portion of the Designer/eDirectory Schema
Compare window shows the difference at the child object level. The Text Compare dialog box
uses the Eclipse* Compare editor to compare classes and attributes. The differences in the code
are highlighted in blue.
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3
(2
]
B

Text Compare
Designer eDirectory
"User" OBJECT-CLASS ::= "User" OBJECT-CLASS ::= [+]

{ {
Flags {"DS_EFFECTIVE CLASS"}, Flags {"DS_EFFECTIVE CLASS"},
Super {"Organizational Person"}, Super {"Organizational Person"},
Mandatory Attributes {"profession"}, Optional Attributes {"Account Balance"
Opticonal Attributes {"AccessID","Account }/( ASN1 {2.5.6.10}
ASN1 {2.5.6.10} }

}

K1 ) ] [l

7 After you view the differences, click Reconcile to perform the reconciliation actions for each
object in the tree, or click Close to close the Designer/eDirectory Object Schema Compare

window.
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Managing the Flow of Data

Designer allows you to manage how the data flows between the Identity Vault and the connected
systems. You can see how the data flows between all of the connected systems, make changes as
needed, create reports about the data, and view the flow of passwords between the systems.

The Dataflow view and the Dataflow editor manage the data. The Dataflow view displays the flow
of data in the modeler per driver. The Dataflow editor displays a more granular view.

+ Section 7.1, “The Dataflow View,” on page 167

+ Section 7.2, “The Dataflow Editor,” on page 173

+ Section 7.3, “Adding Items in the Dataflow Editor,” on page 181

+ Section 7.4, “Editing Items,” on page 185

+ Section 7.5, “Generating HTML Reports,” on page 189

+ Section 7.6, “Integrating Passwords,” on page 191

7.1 The Dataflow View

The Dataflow view displays a toolbar in the upper right corner of the view. For information on the
icons in this toolbar, see The Dataflow View (http://www.novell.com/documentation/designer35/
designer_intro/data/projdataflow.html) in the Understanding Designer for Identity Manager.

The following figure illustrates the Dataflow view. You can use it to control the flow of data
between the Identity Vault and connected systems. The Modeler displays the dataflow.

Figure 7-1 The Dataflow View

& Dataflow 52 =

G @& HEL

@ CommExec
@ Counkry
® DirML-rwowarkorder

® DirgML-pbxaudixsubscriber
® DirsML-pbxExtension

@ Group

® Organization

{® organizational Role

® organizational Unit

® srvprvDirectoryModel

@ ser

I O e R O e O e O R ey B Ry Y

[ 5how effective Flows

+ Section 7.1.1, “Accessing the Dataflow View,” on page 168
+ Section 7.1.2, “Flow Arrows in the Modeler,” on page 168
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+ Section 7.1.3, “Viewing How Attributes Are Synchronized,” on page 170
+ Section 7.1.4, “Changing the Data Flow,” on page 170

7.1.1 Accessing the Dataflow View

If you have closed the Dataflow view, you can access it by selecting Window > Show View >
Dataflow.

Figure 7-2 Selecting the Dataflow View

Window Wl

Mews Window P 5
Mews Editor )

ct2 - Developer &8
Open Perspective

Show Yiew

** Dataflow

Zustomize Perspective. .. E‘_{' Mawvigatar

Save Perspective As,.. o= Cutline

Reset Perspective . Policy Set

Close Perspective == Praject

Close All Perspectives 1) Project Checker

Mavigation ¥ | G Provisioning i
=Y. P

If the Dataflow view is blank and no project is displayed in the Modeler:

1 Expand a project in the Project view.
2 Open the project by double-clicking System Model.
Objects and icons appear in the Dataflow view.

If you want to change how the data flows from the Modeler:

1 Right-click a driver or application in the Modeler.

El 1dentiy waul:

Copy

B2 Mark as Firewall

o 4 @ Publish "CommExec” from LinuxUnix
@ Subscribe "CommExec” ko Linusdnix

o Simulate. ..
@@ Sync "CommExec” both directions

(B show Policy Sets
<:| Ignore "CommExec” From LinuxUnix
D Ignore "CommExec” to LinuxUnix

(]D Ignore "CommExec” both directions

E Run Configuration Wizard, ..

2 Edit Entitlements. ..
B e e et

2 Select Dataflow, then select how you want the data flow to change.

7.1.2 Flow Arrows in the Modeler

When the Dataflow view opens, it automatically reads the filters and shows the classes and
attributes. (If a filter with classes and attributes doesn’t exist, you can create one.)
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Figure 7-3 Flow Arrows in the Modeler

ZH Password{Pub)-Publish NDS Pa:
PublisherCreateRule
PublisherMatchingRule
I publisherPlacementRule
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&E subscriberEventTransformss
@ Delimited Text Fiker
Mg MappingRule
EP| Password{Subj-Pub Email Motificatic
o InputTransformss
e OukputTransformss
) Delimited Text v
< | ¥

o Provisioning | (B Policy Set @' Dataflow 22 =0

G & B E L

=] O User -~
@ Description

@ Facsimile Telephone Mumber

@ gGiven Mame L
@ Internet EMail Address

@ moabile

A mmmrnPickviba dime M A

[ 5how effective flows

& Developer | [ Architect @' Dataflow Table

As you select a class (for example, ) or attribute in the Dataflow list, the appropriate driver lines are
highlighted in red in the Modeler. Icons enable you to see Sync, Notify, Reset, and Ignore filter

settings all at the same time.

Table 7-1 Dataflow Icons

Icon Description

f}. Green arrow: the Publisher channel is synchronized.
o= Orange arrow: the Subscriber channel is synchronized.
E Bell: the attribute is set to Notify.

ﬁ Reset arrow: the attribute is set to Reset.

No decoration  The attribute is set to Ignore.

The color coding matches the Dataflow icons in the Filter editor and the Dataflow editor.
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7.1.3 Viewing How Attributes Are Synchronized

Figure 7-4 Show Effective Flows

= Project | ¥ Dataflow 53 = 08

@ Description
@ FUID

+-0® Group w
|| Shiowe effective Flows

To view whether attributes are synchronized or whether they will be notified, select Show effective
flows. When you select this check box, the synchronize arrows don’t show if the parent class isn’t set
to synchronize. Therefore, you view an accurate diagram of actual flows.

However, if you want to view how attributes are configured to synchronize, regardless of the parent
class, deselect Show effective flows. The synchronize arrows indicate which items are synchronized.

If you select an attribute that can't synchronize (whether or not Show effective flows is selected), you
see a Blocked warning in the upper left. This warning indicates that this attribute can’t be
synchronized or notified because the parent class isn’t synchronized.

Figure 7-5 The Blocked Text and Icon

Palicy Set ?Data Flow &2 »1 =0
G T EE
@ m -~

@ Description

@ Equivalent Ta Me

@ Full Mame

@ Groun Membershio b
[ 5how effective Flaws

To view an explanation, mouse over the Warning icon.

7.1.4 Changing the Data Flow

You can change how the data flows for classes and attributes from the Dataflow view.
To change the flow for a class:

1 Select a class in the Dataflow view.
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Properties Palicy Set =g
G T HE L
@ Crganizational Unit ~
=] @ Iser —
----- @ buildirgrare
@ M
----- @ comparry v
[ showe effective Flows

2 Right-click a driver line in the Modeler.
3 Select Dataflow.

f

SUSE

Linu

B2 Mark as Firewall

saa Straighten Connection

@' Shows Dataflow Yiew

L4 @ Publish "CommExec” from LinuxUnix
@ Subscribe "CommExec” ko Linusdnix
@@ Sync "CommExec” both directions

& Simulate. ..
(B show Policy Sets

<:| Ignore "CommExec” From LinuxUnix

E Run Configuration Wizard, ..
£# Edit Entitlements. ..

L T [PV T

D Ignore "CommExec” to LinuxUnix
GD Ignore "CommExec” both directions

4 Select the option to change the data flow for the class.
To change the flow for an attribute:

1 Select an attribute in the Dataflow view.

Properties Policy Set =8
C T [ &
EI@ User b
"o =
----- @ company

‘o @ Description
@ DirdL-ADAlIasMame

<

[ shaw effective Flows

2 Right-click a driver line in the Modeler.
3 Select Dataflow.
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< Undo Change Location

Mew
Copy

B2 Mark as Firewall

?’ Show Dataflow Yiew

@ Publish "CommExec.Description” From LinuxJnix

@ Subscribe “CommExec, Description” to LinuxUnix
@@ Sync "CommExec,Description” both directions

o Simulate. ..
(2 shaw Policy Sets

O—b Motify "CommExec.Description” From LinuxUnix
b" Matify "CommExec, Description” o LinuxUnix
O-b-b Motify "CommExec,Description” both directions

E Run Configuration Wizard...
£# Edt Entitlements. ..

f‘g Password Synchronization. ..

@ Manage Application Schema... "‘9.' Reset "CommExec,Description” from LinuxUnix

'3.-» Reset “CommExec,Description” o LinuxUnix
Docurnent Selection. ..

‘(@ Export ko Configuration File, .,
| Import From File... <] lgnare "CommExec.Description’ from LinuxUnix

!ﬂ" Reset “"CommExec.Description” both directions

4 Select the option to change the data flow for the attribute.
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7.2 The Dataflow Editor

Figure 7-6 The Dataflow Editor

View: | Al Fikers v Attributes: a v deR @ 8 OF <
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| =
=/ DOCIDMTEST
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The Dataflow editor enables you to do the following:

+ Use filters to display how data flows between all systems and Identity Vaults.
+ View how passwords flow from each server.
+ Generate reports of the data.

When object additions, deletions, changes, and selections synchronization occur, the Dataflow
editor synchronizes with the Modeler and the Outline view.

To access the Dataflow editor, click the Dataflow tab.

To adjust the area for the Identity Vaults, move the slider bar. This setting persists and is restored the
next time you run the editor.

+ Section 7.2.1, “Filtering Views,” on page 174

+ Section 7.2.2, “Filtering Identity Vaults and Applications,” on page 176

+ Section 7.2.3, “Pinning the Identity Vault,” on page 176

+ Section 7.2.4, “Expanding and Collapsing the Identity Vault,” on page 177
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+ Section 7.2.5, “Switching to an eDirectory Tree Icon,” on page 179
+ Section 7.2.6, “Viewing an eDir-to-eDir Driver,” on page 180
+ Section 7.2.7, “Keyboard Support,” on page 180

7.2.1 Filtering Views

By default, the Dataflow editor shows all dataflows. The View drop-down list (in the upper left
corner of the Dataflow editor, not in the Dataflow view), enables you to view notification,
synchronization, reset, or Password Sync information. These filtered views do not allow you as
much editing capability as the main view, but just what is necessary in that filter. For example, you
can’t add attributes, vaults, or applications, because by default they wouldn’t appear in the filter.

Figure 7-7 Options to Filter Views in the Dataflow View

Yiew: |al Fikers w

Matify - Filkered

Svnc - Filkered

Reset - Filkered
Password Sync

+ “Using the All Filters View” on page 174

+ “Synchronizing Passwords” on page 174

Using the All Filters View

If you are in the All Filters view, you can further filter with the Attributes list. Because the Dataflow
editor provides non-filter attributes, you can choose to view regular filter-based attributes, non-filter
attributes, or both.

Figure 7-8 Options in the All Filters View

View: | Al Filkers w |  Attributes: sl v
eDir2eDir Al ry | Entitlements Servic..
Drrivet Mon-Filker Entitlzrents Servic,,
? | &=
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DirXML-SharedProfile T T 4|z
Group dp @B db
Organizational Unit T = T

User @ @B B

Synchronizing Passwords

The Password Sync view enables you to see and edit how all passwords flow in the project.
Designer displays the information on a per-server basis and shows how passwords flow among all of
the applications.

174 Designer 3.5 for Identity Manager 3.6 Administration Guide



Figure 7-9 The Password Flow

sl *Projectz - Dataflow 52 54p-HR Filker =8
View: | Al Filers v Hy  HE +d O P
Al Filkers eDirZeDir LinuzUniz
Mokify - Filkered
Sy - Filtered Dwiver Linud_nii.

Reset - Filkered
SUSE

[= Identity ¥ault

 server dAD aw

eDir2eDir Delimited Te:xt

Driver 4 Delimited Text
@] -
@
;

[= Identity Yault 2

A server 0

To edit the password flow:

1 Select Password Sync in the View filter.
2 Double-click the flow arrow.

You can also right-click, then select Password Synchronization.
3 Edit the password synchronization options.

For more information about password synchronization, see “Password Synchronization across
Connected Systems” in the Novell Identity Manager Administration Guide (http://
www.novell.com/documentation/idm35/index.html).

Password Synchronization Options

G A

®
®
®

@ If the password does not comply, enforce the
password policy on the connected system by
resetting the user's password to the Distribution
Passwiord

The application accepts passwords (Subscriber Channel) i a4

Matify the user of password synchronization Failure wia E-Mail @

[ Ok ] [ Cancel

4 Click OK.
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7.2.2 Filtering Identity Vaults and Applications
You can select the Identity Vaults and applications that you want to view in the editor.

1 Inthe Dataflow editor, click the Filter View icon.
fEHB+ s ECGHE®

View: v Attributes: |l v F
eDirZeDir Active Directory
Driver Aictive Directory
,.,
! @
[= Identity ¥ault —|

2 Select Enabled.
The Identity Vaults and applications that you select here are included in the HTML reports. For
more information, see Section 7.5, “Generating HTML Reports,” on page 189.

Enabled
Shiow the Fallawing Yaults and Apps:

=-[w] 33 Wault
elirzelir (STHARMOM3 eDirectory Driver)

Ackive Directary (Active Directary)

=[] kvedjur Yault
eDirZelir (STHARMOMNS eDirectory Driver)

Delimited Textz (Delimited Text2)
Useradpplication (Userdpplication)

You can scroll and resize the dialog box. Also, you can interact with the Dataflow editor in the
background, in any mode. This is convenient if you want to scroll a different section into view

while this dialog box is up.

7.2.3 Pinning the ldentity Vault

To change the scope of the editor to show a single Identity Vault, right-click the vault, then select
Pin Vault to Top Header Row.
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Figure 7-10 Pinning an Identity Vault
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With a medium or large-sized project, the dataflow table can contain hundreds of rows and
thousands of items. If you have multiple vaults and want to narrow the scope to more easily edit a
vault without excessive scrolling, you might want to pin a vault. When an Identity Vault is pinned, a

pin icon displays in the upper right corner.

Figure 7-11 A Pinned Identity Vault

ERIDM Yault]

-»

To unpin the vault, right-click the Identity Vault, then select Unpin Vault from Top Header Row.

7.2.4 Expanding and Collapsing the Identity Vault

+ “Expanding an Identity Vault” on page 177
+ “Expanding All Identity Vaults” on page 178

+ “Expanding Classes” on page 179

Expanding an Identity Vault

When the editor first loads, all vaults are expanded at the top level by default.
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To collapse or expand the list of classes and attributes in an Identity Vault, do one of the following:

+ Click the - or + icon below the Identity Vault icon.

Figure 7-12 Icons to Expand or Collapse the List of Classes

elirectory Driver Active Directory
eDirectory DHwer Bctive Directory
!@Uﬂ 7
N Active
Directory,
@-JJ Yault
Country @ @ <:| D
Group ap @
Organization S ap
Organizational Unit | G
User @ @ @ @
elirectory Driver Delimited Text
eDirectory Dtiver Drelirnited Text
N Texi=
@kvedjur vaul]

& Developer [ Architect ?‘ Drataflow Table

+ Select the Identity Vault, then press the Right-arrow key to expand the information, or press the
Left-arrow key to collapse the information.

Expanding All Identity Vaults

To expand or collapse the list of classes and attributes for all Identity Vaults, click the Expand all
Identity Vaults or Collapse all Identity Vaults from the pull-down menu.on the toolbar.
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Figure 7-13 Select to Expand or Collapse All Identity Vaults
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To view all attributes in a class, select the class, then press the Right-arrow key. To collapse the list
of attributes, press the Left-arrow key.

To view all classes and attributes in an Identity Vault, right-click the Identity Vault icon, then select
Expand Vault. To list just classes in an Identity Vault, right-click the Identity Vault, then select

Collapse Vault.

Figure 7-14 Menu Options to Expand an Identity Vault
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7.2.5 Switching to an eDirectory Tree Icon

To switch from an Identity Vault icon to an eDirectory tree icon, right-click the Identity Vault, then
select Change to eDirectory Tree.
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Figure 7-15 Changing to an eDirectory Tree
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7.2.6 Viewing an eDir-to-eDir Driver

You can easily view both ends of an eDir-to-eDir connection so that you can configure the dataflows
on both sides. Designer automatically detects the two eDirectory applications and aligns them in the
same table column. A red line connects them.

Figure 7-16 An eDir-to-eDir Connection
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7.2.7 Keyboard Support
You can navigate by using the Up-arrow, Down-arrow, Left-arrow, and Right- arrow keys as well as

PageUp, PageDown, Home, and End. In addition, you can navigate from one Identity Vault to
another by clicking the up-arrow or down-arrow on the toolbar.
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Figure 7-17 Navigation Icons
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7.3 Adding Items in the Dataflow Editor

+ Section 7.3.1, “Adding an Identity Vault in the Dataflow Editor,” on page 181
+ Section 7.3.2, “Adding a Driver in the Dataflow Editor,” on page 182

+ Section 7.3.3, “Adding an Application in the Dataflow Editor,” on page 182
+ Section 7.3.4, “Adding Classes and Attributes,” on page 183

+ Section 7.3.5, “Adding Non-Filter Attributes,” on page 183

7.3.1 Adding an Identity Vault in the Dataflow Editor

Figure 7-18 The Dataflow Editor’s Toolbar
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To add an Identity Vault, click the Add Identity Vault icon on the toolbar.
To configure the Identity Vault, double-click it.

To delete an Identity Vault, select it, then press Delete.
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7.3.2 Adding a Driver in the Dataflow Editor

Figure 7-19 An ldentity Vault in the Dataflow Editor
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To add a driver while in the Dataflow editor, right-click an Identity Vault, then select Add App/
Driver.

To delete an Identity Vault or driver, select it, then press the Delete key.

7.3.3 Adding an Application in the Dataflow Editor
1 On the toolbar, click the Add Application icon.

View: [l Fiters = e | B &+ & (U) @

Avaya 2 elirectory 2 bt
Driver Driver 2
KVAyA elirectony
PRX N
Identity ¥ault 1

2 Browse to and select the driver set that you want this application to connect to, then click OK.

@ Choose Driver Set

‘Which driver set do wou want to connect this application to?

= [l project 3

17 ¥ault

= Kwedjur Yaulk
E Driver Set

Identicy vault

3 Select the driver you want to create, then click OK.
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@ Select Driver

Select one of the Following drivers:
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| Cancel

Designer creates a skeleton of the driver. It does not launch the Driver Configuration Wizard. If
you want to configure the driver, right-click the connection icon in the Modeler, then select Run

Configuration Wizard.

7.3.4 Adding Classes and Attributes

You can add classes and attributes to the dataflow.

To add a class:

1 Right-click an Identity Vault, then select Add Classes.
2 Select the class that you want to add, then click OK.
If you want to add more than one class, press Ctrl and select the classes.

To add an attribute:

1 Right-click a class, then select Add Attributes.

2 Select the attribute that you want to add, then click OK.

If you want to add more than one attribute, press Ctrl and select the attributes.

7.3.5 Adding Non-Filter Attributes

The Dataflow editor provides non-filter attributes. By default, all classes and attributes in the
Dataflow editor come directly from all of the filter policies of the drivers. However, in production
environments, it is common to cause data to flow a certain way directly in your Policy Script code,

XSLT, or in external code that you call out to.
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Usually, these non-filter attributes aren’t defined in a policy filter (unless you’re describing
“augmented” processing) and aren’t in the schema map. This is because they are generated outside

of normal driver operations and you need them in the schema mapping rule only if the engine
processes them.

Normally, non-filter attributes are operated on in the Publisher Command Transformation policy set
or the Subscriber Output Transformation policy set.

The Dataflow editor lets you add the non-filter attributes to the table for documentation purposes so
that you can capture the attributes and have an accurate picture of your actual enterprise dataflows.

To add a non-filter attribute:

1 Right-click the class or attribute name, then select Add Non-Filter Attribute.

= 13 ¥ault

Country
Group
=l Organization

@ Description

@ PNt

@ add Filker attribute, ..
E 1
¥ add Mon-Filker Attribute

& i
El Orgs i Edit Schema...

Usel
M Remove

2 Specify the name of the attribute or class, or click Browse, then browse to and select the
attribute or class.

® Add Non-Filter Attribute =3

Add Non-Filter Attribute

This atkribuke usually isn't defined in a filker ar the schema map, but is actual data that your
policies define flows For and that you want ko note For docurmentation,

‘Where the Flow is Defined
Mame: |

(*) In Policy

@y Policy Script ar %5LT

@ Usually in the Publisher channel's
Cormmand skep or Subscriber channel's
Cukput skep.

() In External Service
@, &.9. Java RMI call out to the driver,

3 Click OK.
4 Select where the flow of the attribute or class is defined.

In Policy: The dataflow is defined in a policy script or an XSLT style sheet.
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In External Service: The dataflow is defined in a Java RMI call to the driver.
5 Click OK.

If the non-filter attribute is defined by a policy, a small P is added to the icon. This icon distinguishes
a non-filter attribute from a regular filter attribute.

Figure 7-20 A Non-Filter Attribute

By In Palicy
If the attribute is defined by an external service, a small E is added to the icon.

Figure 7-21 A Non-Filter External Attribute

(@, In External Service

7.4 Editing Items

Section 7.4.1, “Editing within the Dataflow Editor,” on page 185
Section 7.4.2, “Editing Non-Filter Attributes,” on page 187
Section 7.4.3, “Managing Schema,” on page 187

*

*

*

*

Section 7.4.4, “Removing a Flow,” on page 187

*

Section 7.4.5, “Changing How Data Flows,” on page 188

7.4.1 Editing within the Dataflow Editor

As a convenience, you can edit many items within the Dataflow editor. This capability turns the
Dataflow editor into a full project editor that allows you to have all the tools you need in one place.
You can edit Identity Vault properties, classes, attributes, drivers, and applications.

*

“ldentity Vault Properties” on page 185

*

“Classes and Attributes” on page 186
+ “Drivers” on page 186
+ “Applications” on page 187

Identity Vault Properties

Access the Identity Vault’s properties pages by doing one of the following:

+ Double-click the Identity Vault.
+ Select the Identity Vault, then press Enter.
+ Right-click the Identity Vault, then select Properties.
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Figure 7-22 The Properties Option
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Classes and Attributes
Launch the Manage Schema tool by doing one of the following:

+ Double-click the class or attribute.
+ Select the class or attribute, then press Enter.
+ Right-click the class or attribute, then select Edit Schema.

This tool enables you to modify classes and attributes. For more information, see Chapter 6,
“Managing the Schema,” on page 137.

Figure 7-23 The Edit Schema Option
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Drivers
To access the driver’s property pages, click the driver name below the application name.

Figure 7-24 Location of a Driver Name
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Applications
Access the properties pages for the application by doing one of the following:

+ Double-click the application.
+ Select the application, then press Enter.
+ Right-click the application, then select Properties.

Figure 7-25 The Properties Option for an Application
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7.4.2 Editing Non-Filter Attributes

The directional flow of these attributes is edited in the same way as other attributes. Right-click the
arrows and select Publish, Subscribe, Ignore, Reset, or Remove from Filter.

Reset means that you have the value reset under certain conditions. The attribute might be in a
policy filter, but in addition, you might have some manual logic that resets the value. Occasionally,
resets by manual logic occur in production environments.

7.4.3 Managing Schema

To import, deploy, and edit the schema in the Dataflow editor, right-click an Identity Vault. All
schema changes made outside of this editor are synchronized. For more information, see Chapter 6,
“Managing the Schema,” on page 137.

Figure 7-26 The Manage Schema Option
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7.4.4 Removing a Flow

If a particular flow (Publisher or Subscriber channel) is not defined in the policy filter’s XML, a red
X replaces the Publisher or Subscriber channel arrow. This means that it’s not in the policy and there
will be no flow. This scenario is essentially the same as an Ignore Flow icon, which is an empty
white arrow. However, the distinction is useful so that you know what is actually in your policy’s
XML.

To remove the flow from the XML.:

1 Right-click the Publisher or Subscriber channel icon.
2 Select Remove from Filter.

Managing the Flow of Data 187



<:| Ignore - App's Changes

® @ '@, Motify - Wault of App's Changes
@ @ @ Publish - App's Changes ko Yault
@ @ } Reset - Changes in Wault Mok Made by App

@] =) Remove from Filker

If a class or attribute is marked to be removed on both channels and nothing references it,
Designer removes it from the Dataflow editor’s table.

7.4.5 Changing How Data Flows

To change the way data flows, right-click the arrow that displays the dataflow, then select the option
that you want.

When you right-click the arrow that displays the dataflow for an attribute, you are presented with
five options, as shown below:
+ Ignore
+ Notify
Subscribe/Publish
+ Reset

*

+ Remove from Filter

The functionality for these options changes depending on whether you have selected the left
(Publisher) channel or the right (Subscriber channel).

For the Publisher Channel:

+ Ignore - App’s Changes instructs the Identity Vault to ignore changes made in the application.

+ Notify - Vault of App’s Changes notifies the Identity Vault about changes made in the
application.

+ Publish - App’ Changes to Vault transfers the changes made to the application into the Identity
Vault.

+ Reset - Changes in Vault Not Made by App resets the changes in the Identity Vault that were not
made by the application.

+ Remove from Filter removes the flow from the XML.

For the Subscriber Channel:
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Figure 7-27 Subscriber Channel Options
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+ Ignore - Vault’s Changes instructs the application to ignore changes made in the Identity Vault.

+ Notify - App of Vault’s Changes notifies the application about changes made in the Identity
Vault.

+ Subscribe - Vault’s Changes to App transfers the changes made to the Identity Vault into the
application.

+ Reset - Changes in the App Not Made by Vault resets the changes in the application that were
not made by the Identity Vault.

+ Remove from Filter removes the flow from the XML.

When you right-click the arrow that displays the dataflow for a class, you are presented with three
options, as shown below:

Figure 7-28 Changing the Publisher Flow

o
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@E @ Publish - App's Changes ko Waulk
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@B b
L& Ab
@B @
+ Ignore

+ Publish/Subscribe
+ Remove from Filter

The Reset and Notify options are only available when you select an application.

7.5 Generating HTML Reports

Designer allows you to generate HTML reports about your project.

1 Click the Save Current View to HTML icon or the Save All Views to HTML icon.
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View: |Al Filters - = 65‘3@ UI_%D{? 3 G @

Avaya 2 elirectory 2
Drriver Crriver 2
K\‘W}’ﬂ\ cifrectory
e N
Identity ¥ault 1

Save Current View to HTML generates a report for the current view. Save All Views to HTML
generates nine reports.

Mame ¢ | Modified | Size | Tvpe
Clicons 121812006 12:15 PM File Folder
&] DrataFlowall, bl 121812006 12:29 PM 1 KB HTML File
&] DataFlowFilker btml  12/8/2006 12:15 PM 1 KB HTML File
&] DataFlowhonFilte. ..  12/8/2006 12:15 PM 1 KB HTML File
&] MatifyFlowsall. bl 121812006 12:15 PM 6 KB  HTML File
&] PasswordFlowall.... 1282006 12:15 PM 7KB HTML File
&] ResetFlowall, html 121812006 12:15 PM 1 KB HTML File
&] SyncFlowall, bl 121812006 12:15 PM 101 KE HTML File
&] SyncFlowFilker btml  12/8/2006 12:15 PM 101 KE HTML File
&] SyncFlowhonFilte. .. 1282006 12:15 PM 1 KB HTML File
Kl | |

The HTML files are automatically named. The descriptive names tell what the report is. All
images that you need to support the HTML document are copied to an icons subdirectory
where the HTML is saved. The process includes all of your custom application icons.

You are prompted to save the project to disk.

% Save Views to HTML

) The project will be saved First ta make sure the images are on
'j disk.,

Do wou wank bo proceed?

[ oo not show this dislog bax again

Saving is necessary to make sure that all of your icon information is in a state where it can be
successfully copied.

2 Click Yes to save the project.
3 Browse to and select the location where you want to save the reports, then click OK.
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The directory you select for saving is stored in Designer’s memory and becomes the default
directory the next time you save.

4 Click OK in the Information dialog box that indicates where the report is saved.

If you pin an Identity Vault and then generate a report, the report is for that Identity Vault. The
Identity Vault’s name is included in the HTML name.

Figure 7-29 A Pinned Identity Vault
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If the Dataflow editor has multiple applications, Designer provides a scrollbar to scroll through all
the applications within the Dataflow editor.

Figure 7-30 Continuation Rows in a Report
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7.6 Integrating Passwords

If a driver is synchronizing passwords (in at least one direction), a small password-field icon ...
appears under the driver icon. This icon enables you to know where passwords are being
synchronized.

To toggle this icon on or off:

1 Select Window >Preferences > Designer for IDM > Modeler.
2 Click the Display tab.
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3 Select or deselect Show password icons in Developer mode.

% Preferences

itype Filker baxt | Modeler

[+ General

| Behaviors | Display | Guidance || Layouts || Pages || Prompts | Themes

[=)- Designer For IDM

i Document Generation
H W i i i
Entilements [#] Show driver icons in Developer mode

‘- iManager L Show password icons in Developer mode

- Configuration [#] show labels by applications and Identity Yaults (Architect mode)

H Import Deploy Auto-expand Identity Yaults o fit contents
- Language
20 1odeler [#] suto-shrink Identity Yaults to fit contents
fJ: Policy. Buider [ Auto-size Identiby Vaults to Fit their titles
“ Project Checker
‘- achema
e Sinichin (rid Width: | 50

- Trace

If you mouse over the password icon in Developer mode, a helpful tip explains how your passwords

are flowing for each server involved in the flow.

To configure the flow of password synchronization:

1 In Dataflow mode, select Password Sync in the View drop-down box.

2 Double-click the flow arrow.
3 Select options, then click OK.

Password Synchronization Options

Identity Manager accepts passwords (Publisher channel) @ o

Use the Distribution Password For password synchronization @

@ If the password does not comply, enforce the
password policy on the connected system by
resetting the user's password ko the Distribution

Password

always accept the password; ignore password palicies
The application accepts passwords (Subscriber Channel) @ N

Maokify the user of password synchronization Failure via E-Mail @

Reset the user's password to the Distribution Password @

accept the password only if it complies with the user's password palicy @

I

Cancel
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Creating and Managing Policies

Policies enable you to customize the flow of information into and out of Novell eDirectory for a
particular environment.

For example, one company might use the inetorgperson as the main user class, and another company
might use User. To handle this, a policy is created that tells the Metadirectory engine what a user is
called in each system. Whenever operations affecting users are passed between connected systems,
Identity Manager applies the policy that makes this change.

Policies also create new objects, update attribute values, make schema transformations, define
matching criteria, maintain Novell Identity Manager associations, and many other things.

For more information on policies, refer to the following:
+ Understanding Designer for Identity Manager (http://www.novell.com/documentation/idm36/
policy/index.html?page=/documentation/idm36/policy/data/bookinfo.html)

+ Policies in Designer (http://www.novell.com/documentation/idm36/policy_designer/data/
bookinfo.html)

+ Novell Credential Provisioning for Identity Manager 3.6 (http://www.novell.com/
documentation/idm36/policy_credprov/data/bookinfo.html)

+ ldentity Manager 3.6 DTD Reference (http://www.novell.com/documentation/idm36/
policy_dtd/data/bookinfo.html)
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Enabling Staging of Projects

Using ldentity Manager can involve two or more stages, such as development, the test environment,
and the production environment. In an Identity Manager environment, the drivers are the most
critical components. When an Identity Manager project is moved from one stage to another, moving
drivers becomes critical. Staging provides users the flexibility to validate the appropriate resources
in real time, which ensures uniformity across all stages.

Figure 9-1 Staging Identitiy Manager Projects

Figure 9-1 shows a basic representation of the movement of Identity Manager projects across
different stages. Three projects are developed and tested in three separate setups and then connected
in the subsequent stages. The scale of projects grows with stages, but not necessarily the scale of an
individual driver.

Staging Identity Manager projects is discussed in the following sections:

+ Section 9.1, “Prerequisites,” on page 196

+ Section 9.2, “Importing Additional Objects from eDirectory,” on page 196

+ Section 9.3, “Deploying Additional Objects into eDirectory,” on page 201

+ Section 9.4, “Exporting LDIF Container Objects to an LDIF File,” on page 205

+ Section 9.5, “Importing Objects from an LDIF File into an LDIF Container,” on page 207
+ Section 9.6, “Setting up Driver Security Equivalences,” on page 208

+ Section 9.7, “Editing the LDIF Container Data by Using an Editor,” on page 213

+ Section 9.8, “Deleting the LDIF Container,” on page 213

+ Section 9.9, “Changing the LDAP Properties,” on page 214
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9.1 Prerequisites

Ensure that the following prerequisites are met before attempting staging Identity Manager projects:
+ All the stages should have the same version of eDirectory, Identity Manager, and ldentity
Manager drivers.
+ Designer 3.5 or later is present.

+ All the applications and drivers are fully developed and tested in one stage before moving them
to the next stage.

Refer to the Identity Manager 3.6.1 Staging Best Practices Guide (http://www.novell.com/
documentation/idm36/idm_staging/data/front.ntml) for more information on pre-staging
activities.

9.2 Importing Additional Objects from eDirectory

Designer provides the functionality to store additional objects (objects that are not modeled in the
Designer). These objects are stored in an LDIF container under the Identity Vault. By default, there
is no LDIF container. An LDIF container is created when the Import Additional Objects or Import
Objects from LDIF File into LDIF Container option is selected.

1 Inthe Modeler, select ID Vault > Live > Import Additional Objects.

O

- < Undo Change Location

Diskribuke
Align

‘alidate
Team

Cornpare With -
Replace with | ol Deploy...
&3 Compare...

p | =5 Impart. .

& Change to eDirectory Tres
Schema

= Add to Group &% Manage Directory
% DS Trace
i | iManager

% Manage Waulk Schema.. .

iy Document Selection. ..

@5 Imnport Objects From LDIF file. ..

E Impork Schema From File. .

Import From Configuration File. ..
Export ko File

ﬁ Driver Status
2 start Al Drivers
& stop all Drivers

)| @ Restart all Drivers

E-Mail Templates F-":I Import Additional Objects. ..
| = Deploy Additional Objects...
¥ Delete

Properties

eloper | [

2 Inthe Import Additional Objects page, click Browse to open the eDirectory Browser.
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& Import from Identity Vault

Import objects into an Identity Vault

Select the objects ta import fram eDirectary.

Objects ko Impart: =

Browse. .. |E|

Remave

eDir-ko-eDir. ..

= .
&) Conkinue Cancel
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3 Inthe eDirectory browser page, select the objects that should be directly imported, then click
OK. Or select the objects, select Import sub-containers also, then click OK.

@ Browse Identity Vault b__q
File

Select an object:

EYET] cHirac_TREE Sriovel
2 novel By security
m Security

[Jimport sub-containers also oK

The selected objects are displayed in the Import Objects dialog box.
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@ Import from Identity Yault

Import objects into an Identity Yault

Select the objects to import from eDirectory,

Ohjects ta Import:

X]
@

= vell. CHIRAG_TREE.
[=-[+] testz
= [w] test3
= [+] test4
=[] tests
=) [+] tests
(= [w] test?
= [w] testd
=[] testd
=-[«] test1in

testuser

Browse. ..

eDir-to-elir. .,

Continue H Cancel
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4 If you do not want to import a given object, either deselect it and continue or select it and click

Remove.
a Import from ldentity Yault E]
Import objects into an Identity Yault §
Select the objects ko import From eDirectary,

CObijects ba Innport: =

test, novell, CHIRAG_TREE, Browse, .,
testl, novell. CHIRAG_TREE.
Remove

(7) [ Continue H Cancel ]

5 Click Continue to import the selected objects. These objects are stored in the LDIF container.

These objects are retrieved by an LDAP channel. If you are running the LDAP service on non-
default ports, see Section 9.9, “Changing the LDAP Properties,” on page 214 for more
information. The objects in the LDIF container are overwritten. To keep a record of the objects
stored in the LDIF container, export the information of the LDIF container into an LDIF file.
For more information, see Section 9.4, “Exporting LDIF Container Objects to an LDIF File,”
on page 205.
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9.3 Deploying Additional Objects into eDirectory

Designer allows you to update objects that are already present in eDirectory. The current
functionality does not support the deployment of objects containing references to objects in
eDirectory. To deploy these objects, you can either manually create the objects in eDirectory or
remove the references (see Section 9.7, “Editing the LDIF Container Data by Using an Editor,” on
page 213). Designer allows you to update objects that are in eDirectory.

1 Inthe Modeler, select ID Vault > Live > Deploy Additional Objects.

O < Undo Changes Location
W——

Mew

O u; saa Straighten Conneckions

{__3 Select Connected Applications
Diskribute
Align

Walidate

Team
Compare With
Replace With

3
L= Impark...

_E Deploy...

? Change to eDirectory Tree
hange to Identity Waulk [ Meta-Directory
= Add ko Graup

-"_C‘% Compare...

Schema 4

s}% Manage Dirackory

& Manage vault Schema...

& DS Trace

i Document Selection...
ﬁg Impoart Objects from LDIF file. ..
ﬁ Imnpart Scherma from File, ..
Imnport From Configuration File, ..
Export ko File
E-Mail Templates

e | iManager

&) Driver Status

D start all Drivers
2 stop All Drivers
@) Restart &l Drivers

22 Import Additional Obiects. ..

'_g Deploy Additional ¢

¥ Delete

veloper | [2 Archite Properties

& Remowe from Conkexk

| e2mof 254m

Chrl-+alk+Shift+Down
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2 Select or deselect the objects by clicking Select All, then click Deploy.

@ Deploy Objects

.l select the objects that need to be deployed
Select the objects that need to be deploved

x)

E COhjects to be Deployed

] novell

[0 -H testt.novel

[Jupdate existing objects in eDirectary

Deploy

] [ Cancel
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If the objects are already present in eDirectory, a warning is displayed.

@ Im port Results gl

Dperation Fesulks: = ['Es']
= 'Q' Identity Wault additional objects deplay

A l:lhjEtEt could nok be added in eDire y
a{},‘ Ohiject could not be added in eDirectory

Details:
& Warning
Dbject: ou=test, o=novel
Description: Ohject could not be added in eDirectory

Technical Data: LDF\PExceptinnl Entry Already Exists (A3 Entry Already Exists | -
LDAPE<ception; Server Message: NDS error: entry already exists (-606) B
LDAPException: Matched D B
com,novell ldap, LDAPResponse, getResultException{Unknown Source)
com.novell Idap, LDAPResponse, chkPesult Code{Unknown Source)
com.novell Idap, LDAPConnection, chkResult CodedUnknown Source’
com.novell dap, LDAPConnection, add(Unknown Source)
com.novell dap, LDAPConnection, add{Unknown Source)
com.novell core, datataols, access, nds LDAPConnectionObject, updakeCObjects(LDAPCon

Enabling Staging of Projects 203



3 If the objects are already in eDirectory, click Update Existing Objects in eDirectory to update
them, click Deploy, then click OK.

< Deploy Objects &|
.l select the objects that need to be deployed
Select the objects that need to be deployed

& Ohjects to be Deploved

.ﬂ test, nowvell
.B testl.novell

| Update existing objects in eDirectory

[ Deploy H Cancel

If there are no objects or the information is not in a proper format in the LDIF container, a
warning is displayed.
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9.4 Exporting LDIF Container Objects to an LDIF
File
You can export objects from the LDIF container and store them in the LDIF file.

1 Inthe Modeler, select ID Vault > Live > Export to File > Additional Objects.

E‘ IdEntir" [T [
C.‘j' Undo Change Location

=-a-a Straighten Connections

[j Select Connected Applications
Distribute
Align

Yalidate

Tean
Compare With
Replace With

? Change to eDirectary Tree
Change to Identity Yault | Meta-Direckory
=3 Add ko Group

[& Manage vault Schema...

Docurment Selection, .,

@F‘ Import Objects From LDIF file. ..
=, tmport Schema from File, .
Import Fram Configuration File. ..

E-Mail Templates Configuration...

_ﬁ schema. ..

Live 4

¥ Delete

Properties

&% Remowve From Conbesxt Chrl+alk+Shifk+Dovn
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2 From the file browser that displays, specify the name of the file into which objects stored in the
LDIF container should be exported, then click Save.

Export Objects to LDIF
Save it | [ New Folder v| Q . sl

&l

ty Recent
Documents

™

Desktop

&

by Documents

-

tdy Compuiter

File name: | Identity Wault 2 w | | Save |

MyNetwork | Saveastype | “Idi v| | conce |

@

If there is no information in the LDIF container, a warning is displayed.
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9.5 Importing Objects from an LDIF File into an
LDIF Container

You can export objects from an LDIF file to an LDIF container. This overwrites the existing objects

of the LDIF container.

1 Inthe Modeler, right-click the 1D Vault and select Import from LDIF File.

(2 Architect

< Undn Change Locakion

Mew

wea Straighten Connections

{1 Select Connected Applications
Distribute
Align

Yalidate

Tearn
Compare With
Replace with

? Change to eDirectory Tree
Change to Identity Wault [ Meta-Direckory

o Add ko Group

{& Manage vault Schema. .,

2, Import Schema From File. ..
Trnpart Fram Configuration File. .
Expott to File
E-Mail Templates

Livve

¥ Delete

Properties

& Remove From Conkext ChrlH-alk+Shift+Dowvn
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2 From the file browser that displays, select the file from which the LDIF object should be
imported, then click Open.

Select LDIF File ?]X]

Loaok in: |@ Mew Folder V| < ? > '

—_2_ 4] rdentity vaulk 2

My Recent
Documents

Desktop

&

by Documents

ty Conmpiter

File name: | Identity Wault 2 w | I Open l

My Notwork. | Fies of type: = Idi v| | conce |

9.6 Setting up Driver Security Equivalences

Designer allows you to define and deploy the Security Equivalences objects for the drivers in
eDirectory.
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To set Security Equivalences for a driver:

1 Right-click a driver and select Live >Set up Driver Security.

ra =

< Undo Change Locatian

Tl 4
Copry 3

B2 Mark as Firewal

s-e-n Straighten Connection

?" Showe DakaFlow Yiew

Z Dir¥ML Scripk Tracing. ..
(B shaw Policy Sets

& Simulate. ..

El Run Configuration Wizard. ..
& Edit Entitlements. ..
% Password Synchronization. ..

E Manage Application Schema. ..

Document Selection, .,
Export bo Configuration File.. .
Irmport From Configuration File...

l=; Import...
¥ Delete Q Deploy...
ﬁ Compare, ..
Properties

Driver Configuration

E§5 Refresh Application Schema. ..

ﬁ Crriver Status
i} Start Driver
ﬁ Stop Driver
(@) Restark Driver

13 Set Driver Trace Lewel,..
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2 On the Driver Security Equivalences/Exclussions page, click Define Security Equivalences.

& Driver Security Equals/Exclusions

Mowell recommends that vou do the Following For drivers:
- Define Security Equivalences on them
- Identify all objects that represent Administrative Roles and exclude them From replication.

[DeFine ‘Security Equivalences'. .. ]

[Exclude ‘Bdministrative Roles',.. ]

3 On the Deploy Security Equivalences page, select the Security Equivalences object from the
list, click Deploy, then click OK.

For example, testuser.novell is not in eDirectory but in the LDIF container. The Deploy
operation picks testuser.novell from the LDIF container and adds it to eDirectory.

@ Deploy - Security Equivalences E]
Diriver Driver St Identity Waulk
Delimited Text  SyncDS Identity Yault

Security Equivalences:

Remaove

Deploy

[ oK H Cancel ]

You can remove the existing Security Equivalences object and define new Security
Equivalences objects for the Driver.
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4 Select the Security Equivalences object, then click Remove.

& Deploy - Security Equivalences

Driver Driver Set  Identity Yault
Delimited Text  SyncDS Identity Yault

Security Equivalences:

QK ] [ Cancel
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5 To add a new object, click Add, select the object, then click OK.

*® Deploy - Security Equivalences

Diriver Driver et Identity Yault
Active Direckory TestSet Identity Yaulk

Security Eguivalences;

® Browse Identity Vault

File:
Select an object:
& [B] DESIGNER-SHAMMI B arpi A
oy adceeeie 00T e admin
& % kpr USEr
& A el [ BLr-DESIGHER
55 REE {EBLR-DESTGNER-PS
By test [ZELDaP Server - BLR-DESIGNER
&5 userapp LA Group - BLR-DESIGHER
R alala €72 Hitp Server - BLR-DESIGNER,
1@ dm 4 545 Service - BLR-DESIGHER L
BB security 59 545 Service - TestServer i
< | > b
[ oK ] [ Cancel ]
O=novell
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9.7 Editing the LDIF Container Data by Using an
Editor

Designer allows you to modify the LDIF objects by using different editors. Under the ID Vault,
right-click the LDIF Container, then click Open With > Select Designer Built-in Editor. Or double-
click the LDIF Container to open it.

= 2l project
=Bl 1dentity vault 2
o
E serw
= &l Drive ¥ Delete
“ Linrgrp——
% Diefault Motification Collection

Cpen With ¥|  Designer Built-in Editar

9.8 Deleting the LDIF Container

Designer allows you to delete the LDIF Container. Under the ID Vault, right-click the LDIF
Container, then click Delete.

= 2l project
=Bl 1dentity vault 2

U | DIF-Tdentity Vaulgs :
ﬁ Cpen ith #
SErver

=] E Diriver Set

| 5 Delete

iﬂ Library
% Default Motification Collection
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9.9 Changing the LDAP Properties

You can modify non-default LDAP properties by using the Properties view of the Identity Vault.
This is used for importing and deploying objects.

1 Under the Properties view, click ID Vault, then specify the LDAP clear text port and LDAP
secure port numbers.

] Properties &3 ?" Dataflow | (2 Policy Set

Property Yalue
| = 1.0dentity¥aut | |
Marme Identity Waulk 2
Host Address 164,99,136,134
ser Mame adrmin . noveel
Passward Hokkkatok
Conkexkt
ldapClear TextPort 359
ldapSecurePart 636
uselDAPSecure”hannel false
= 2. Administrator
Marne
Cell
Department
E-rnail
Fax
Lacation
Mokes
Pager
Phone
Title

2 Save the project.
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Setting Up E-Mail Notification
Templates

Notification templates enable you to customize and send e-mail messages that users receive when
triggers occur.

+ Section 10.1, “Viewing Notification Templates,” on page 215

+ Section 10.2, “Editing a Notification Template,” on page 218

+ Section 10.3, “Adding and Deploying a Notification Template,” on page 221

+ Section 10.4, “Policy Builder and Notification Templates,” on page 223
Section 10.5, “Configuring the E-Mail Server,” on page 223

*

10.1 Viewing Notification Templates

Designer provides default notification templates, which you can view or edit. To view the templates,
perform the following:
1 Select an Identity Vault in the Modeler.

2 Inthe Outline view, scroll to and right-click the Default Notification Collection for that Identity
Vault.

3 Select Add Default Templates if you want to add the default English version of the notification
templates to the Identity Vault.
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Project TN, [EF T BB
L= outputTransformss
[E Delimited Text
=-ig) Diriver
%) Publisher
& Subscriber
@ Driver Filter
[E Delimited Text 2
=g/ Diriver 2
%) Publisher
: Subscriber
@ Driver 2 Filter

B rvaya

. on Collection
Attestation Completed Motification
Attestation MNotification
Ry ailability
Default Job MNotification
Delegate
Forgot Hint
Forgot Password
Password Reset Fai
Password Set Fail
Fasswiord Sync Fai
Frovisioning Approval Completed Motificaton
Prowisioning Notification
Prowisioning Notification Activity
Prowisioning Reminder
Proscy
Raole Request Approval Completed Motification
Raole Request Motification

%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%)
%

If Default Notification Collection isn’t expanded, expand it. The expanded tree shows the
default notification templates. The install program no longer installs all of the notification
templates with Designer.

Select Add All Templates to update all of the notification templates that are installed with
Designer to the Identity Vault. You can then use the Filter option in the Outline view to filter
out the notification templates that you don’t want to see.

To view and edit the internationalized template files, click the Filter button in the Outline view,

then select languages that you want to see.

Oz =

0=

u]

)

)

+

i

BEEIEEE
= % Default Motification Collection e
€3] wailability
% Default Job Matification
% Delegate
% Fargot Hint
=/| Forgak Password
% Password Reset Fail
%, Password Set Fail
% Password Sync Fail
=/| Provisioning Approval Completed Mot
% Provisioning Motification
% Provisioning Motification Activity
=/| Provisioning Reminder
%, Proxy
Identity Yault 2
& server
E Drriver Set
= % Default Motification Collection
E2) availability
% Default Job Matification
S| Delegate
% Fargot Hint

A

Enabled
Show items of bype:

= [#] Identity Yault
Server
=[] Driver Set
(=[] Driver
Publisher
Subscriber
Policy
Entitlement
Application

(=[] E-Mail biotification Template
.
' l!lnese Simplified
[] chinese Traditional
[ outch
[ French
[] German
[ ttalian
[] Japanese
[] Portuguese EBrazi
[ Spanish
[ Russian
[ Swedish

216 Designer 3.5 for Identity Manager 3.6 Administration Guide




5 If you have a certain template that you want to have all of the localized templates, right-click
that template and select Add Localized Templates. All of the localized templates are added for
the selected template. Use the Filter button to select the languages you want to see.

6 Use the templates in the Default Notification Collection to send e-mail notifications to users in
the Identity Vault. You can customize these templates with your own text.

Right-click a template (for example, Forgot Hint), then select Edit.
You can also open a template by double-clicking it.

Template Name Description

Attestation Completed Notification Sends an e-mail natification when the workflow
process for your attestation request is
completed.

Attestation Notification Sends an e-mail notification when a new

compliance activity is submitted that requires
your attention.

Availability Sends an e-mail notification when an availability
setting has been created or modified.

Default Job Notification Sends an e-mail notification to report results of
the job as configured in the template. Contains
the name of a job and any status information
from the job.

Delegate Sends an e-mail notification when a a delegate
assignment has been created or modified

Forgot Hint Sends an e-mail notification when a user forgets
a password and requests a hint.

Forgot Password Sends an e-mail natification when a user
incorrectly enters a password.

Password Reset Fail Sends an e-mail notification when a user tries to
reset a password but doesn’'t meet password
policy requirements.

Password Set Fail Sends an e-mail notification when a user’s
password cannot be set in the connected
system.

Password Sync Fail Sends an e-mail notification when a user’s

password fails to synchronize.

Provisioning Approval Completed Notification Sends an e-mail notification when a workflow is
completed. Indicates the overall workflow and
provisioning decision.

Provisioning Notification Sends an e-mail notification to a user or
manager for approval. Indicates that action is
required from the user or manager.

Provisioning Notification Activity Sends an e-mail notification to a user or
manager about the activity of the provisioning
notification.
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Template Name Description

Provisioning Reminder Sends an e-mail notification when a user activity
timeout expires. Reminds the user or manager to
act.

Proxy Sends an e-mail natification when a proxy

assignment has been created or modified.

Role Request Approval Completed Notification ~ Sends an e-mail notification to a user or
manager that the approval process is completed.

Role Request Noatification Sends an e-mail notification to a user or
manager that a new role request requires
approval.

10.2 Editing a Notification Template

1 Select an Identity Vault.

2 Inthe Outline view, right-click a template (for example, Forgot Hint), then select Edit.

3 Select a format, specify a subject, add tokens, customize the message that users receive, then
save and close the template.

E-Mail Template Editor @
E2) Forgot Hink, Default Motification Collection, Identity ault

E-Mail Content

Send As (OHTML (O Text Tokens:
$UserFullamesd MNew...
Subject: $Hint$
‘four password hint request
Message:
B 7 U TR @S] [@¥ E= = EE D=
<head:> A
<titlex>Your password hint request</titlex
<stylex
<!-— body { font-family: Trebuchet M3 } —->
</style>

</headr<body EGCOLOR="#FFFFFF">
<prDear §UserFulllamed,</p>
<p>¥ou hawve reguested that your password hint be emailed to you. The password
hint i= given below:</p>
<prHint: §Hint§</p>

<p>If you did not recguest that your hint be emailed to you, please contact the v

< >

¢ >
2] E-Mail Template Editar

+ Section 10.2.1, “Selecting a Format,” on page 219

+ Section 10.2.2, “Specifying a Subject,” on page 219

+ Section 10.2.3, “Working with Tokens,” on page 219

+ Section 10.2.4, “Editing a Template Message,” on page 220
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10.2.1 Selecting a Format

Select whether users receive this e-mail notification in HTML or text format.

Figure 10-1 Options for Sending the Notification

Send As @HT

10.2.2 Specifying a Subject

The subject is the text that a user views in an e-mail’s Subject heading or field. You can change the
text in the Subject field. You can also use tokens here. The text or tokens don’t determine the name
of the template.

Figure 10-2 The Subject Field

Subjeck:

| Your passwiord hink request

10.2.3 Working with Tokens

A token is a variable or replacement tag for items such as the user’s name. Tokens help you
personalize the message to the user.

Figure 10-3 The Tokens Dialog Box

Tokens:

$UserFulllames Mew, ..
$Hint$
Rermaove

Insert

Each template includes default tokens. For example, the Forgot Password e-mail template for
sending a password to the user includes the default replacement tag named $CurrentPassword$.

You can define other tokens for use in the body of the message or in the subject. Your ability to do so
depends on the application that uses the templates. To find out how to define additional replacement
tags, see the documentation for the application. For example, Identity Manager Password
Synchronization can’t use a replacement tag that you create unless the policy in the driver
configuration that uses the template also contains the definition of the replacement tag.

Adding a Token
1 Click New.
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Add Replacement Tag
Enter the token name and walue For the token,

Marne:

Descripkion:

I (] 4 l[ Cancel ]

2 Inthe Create a Replacement Tag dialog box, type a name for the token.
You don’t need to type the $ characters. Designer provides them.

3 Type a description for the token.

4 Click OK.

When you add a token, the tag is automatically added to the XML source for the template. After you
add a tag, you can edit it only in the XML Source view.

Removing a Token
To delete a token, select it, then click Remove.

Make sure that you don’t remove tags that are needed for the body of the message.

Inserting a Token

1 Inthe template, click where you want to insert a token.
2 Select a token.
3 Click Insert.
Designer inserts the selected token into the e-mail template.

10.2.4 Editing a Template Message

The text of the e-mail message appears in the Message field. Customize the text so that it suits your
environment. Use tokens to personalize the e-mail message.
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Figure 10-4 The Message Edit Box

B 7 U T §FH @Y == = EE ==

<head:> -
<title>¥Your password hint reqhest<!title>
<stylex

<!—-— body { font-family: Trebuchet M3 } -->

</style>

</ headr<body BGCOLOR="#FFFFFF">
<prDear §UserFullMNamed,</p>
<p>¥ou hawve recguested that your password hint he emailed to you. The password ¥

< >

<
2] E-Mail Template Editar

1 Inthe E-Mail Template Editor, place your cursor in the Message edit box, then press
Ctrl+Spacebar.

2 Select an HTML tag by double-clicking a tag in the drop-down list.

<prDear §UserFullllamed, </p>

{33 # |8 link.if the href attribute is present, and the target
<> abhr for a link if the name attribute is present

< ¥ acronym

<% address

<> applet

<*h

<> basefont

<>hdo

<% bgsound

<> big "

3 Format text by using the toolbar.

BIU TR HE Q% =E 2= F [

L1
[olie
[ifile
sl
i
n+
i

4 Preview the text by clicking the Preview icon .
5 Save the template by selecting File > Save.

You can also click the Save icon.

If the code isn’t valid, you can’t save the template.

10.3 Adding and Deploying a Notification
Template

+ Section 10.3.1, “Adding a Notification Template,” on page 221
+ Section 10.3.2, “Importing a Notification Template,” on page 222
+ Section 10.3.3, “Deploying a Template,” on page 222

10.3.1 Adding a Notification Template

1 Select an Identity Vault in the Modeler.
2 Inthe Outline view, scroll to Default Notification Collection for that Identity Vault.
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3 Right-click, then select New Template.

E-Mail Templates

Add Notification Template
Enter the template name.
Mame: | |

Open the editor after creating a template,

Ok l [ Cancel

4 Name the template.

5 If you want to automatically open the template editor so that you can view or edit the template,
select Open the editor after creating a template.

6 Click OK.
7 Customize the text by editing the template message.
8 Click Save on the Designer tool bar.

10.3.2 Importing a Notification Template

To import a notification template from a file:

1 In the Outline view, scroll to Default Notification Collection for an Identity Vault.
2 Right-click, then select Import Template from File.

3 Browse to and select the template.

4 Customize the text for your environment by editing the template message.

To import a notification template as a live operation:

1 In the Outline view, scroll to Default Notification Collection for an Identity Vault.
2 Right-click, then select Live > Import.

3 Specify the host name (IP address) for the tree.

4 To authenticate, specify the user name and password.

5 Browse to and select the template, then click OK > Continue > Import > OK.

6 Customize the text for your environment by editing the template message.

10.3.3 Deploying a Template

After you add or import a template, deploy it.

1 Customize the text for your environment by editing the template message.
2 Right-click the template.
3 Select Live > Deploy.
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10.4 Policy Builder and Notification Templates

For information on using the Policy Builder interface to send e-mail notifications, see Send Email
(http://www.novell.com/documentation/idm36/policy _designer/data/dosendemail.html) and Send
Email from Template (http://www.novell.com/documentation/idm36/policy_designer/data/
dosendemailfromtemplate.html) in the Policies in Designer 3.5 guide.

10.5 Configuring the E-Mail Server

The e-mail server sends notification e-mails from applications that use the Notification
Configuration templates.
1 Select an Identity Vault in the Modeler.
2 Inthe Outline view, scroll to Default Notification Collection for that Identity Vault.
3 Right-click, then select Properties.
4 Specify the host name, From, and authentication settings for your SMTP e-mail server.
Host Name: The host name of your SMTP e-mail server. This can also be an IP address.

From: When a user opens the e-mail, the text that you enter in the From edit box is displayed
in the From field of the user’s e-mail heading. Depending on your mail server settings, the text
in this field might need to match a valid sender in the system (for example,
helpdesk@company.com instead of descriptive text such as The Password Administrator).
Such a match allows the mail server to do reverse lookups or authentication.

Authenticate to the server by using credentials: Use for a secured SMTP server.

If your server requires authentication before sending e-mail, specify the username and
password here.

Although the authentication information is specified here, you might also need to specify it
separately for the application that is sending the notification e-mails.

For example, Forgotten Password e-mail notifications can be sent by using the authentication
information you specify here. However, notification e-mails for Identity Manager Password
Synchronization require the authentication information to be provided in the driver policy that
is used to send notification e-mails.

5 Click OK.
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Importing into Designer

Designer’s Import feature allows you to import the following items into defined projects:

+ Projects from the File System or from the Identity Vault (eDirectory)

+ Libraries

+ Driver sets

+ Individual drivers

+ Channels

+ Policies

+ Schema
Depending on a project’s complexity, importing can save you time in building and rebuilding
drivers, channels, and policies. For instance, after a driver, channel, or policy is built, you can import

it into new projects and modify it to run in the new environment instead of starting from scratch on
each new driver, channel, or policy.

You import projects, drivers, channels, schema, and policies from an existing eDirectory tree
running the Identity Manager system (Identity Vault) or from an exported project located in the file
system. In Designer, use the Deploy feature to save drivers, channels, and policies into a
Metadirectory server in an ldentity Vault. Use the Export feature to save project, drivers, channels,
and policies to a local, removable, or network directory.

What you can import depends on the level you are at within a project. For instance, at the File >
Import level, you can import a project from the file system or from an Identity Vault. At the project
level, you can import driver sets, drivers, channels and policies; at the driver level, you can import
channels and policies, and at the channel level, you can import policies.

During import, Designer does not import anything that is encrypted. This includes named
passwords, e-mail notifications, existing certificates, and the Secure Login administrator password.
+ Section 11.1, “Importing Projects,” on page 225

+ Section 11.2, “Importing a Library, a Driver Set, or Driver from the Identity Vault,” on
page 236

+ Section 11.3, “Importing a Driver Configuration File,” on page 245

+ Section 11.4, “Importing Channels, Policies, and Schema Items from the Identity Vault,” on
page 250

+ Section 11.5, “Using the Compare Feature When Importing,” on page 259
+ Section 11.6, “Error Messages and Solutions,” on page 267

11.1 Importing Projects

Designer’s Import feature allows you to import projects from the File System or from an Identity
Vault (eDirectory). What you are able to import depends on the level you are at within a project. To
import an eDirectory object, you must have sufficient rights to access the eDirectory tree that is
associated with the Identity Vault you are designing.
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When you initially open the Designer utility and close the Welcome view, you have no projects that
are currently available.

For information on creating a new project, see Chapter 2, “Creating a Project,” on page 23. For
information on importing projects, see the following sections:

¢ Section 11.1.1, “Importing a Project from the Identity Vault,” on page 226

¢ Section 11.1.2, “Importing a Project from the File System,” on page 231

+ Section 11.1.3, “Importing a Project from iManager,” on page 233

+ Section 11.1.4, “Importing a Project from a Version Control Server,” on page 234

11.1.1 Importing a Project from the Identity Vault

1 In Designer, click File > Import.
or

Click Import Project From Identity Vault from the No Projects Available page in the Projects
view, then skip to Step 3.

2 From the Import window, select Identity Manager Project (From Identity Vault) under the
Designer for Identity Manager heading. Click Next.

Select

\J
Irmport an existing Identity Manager project from an Identity I g 5 I
Wault,
Select an import source:

type filter text

I Project (From File System)
LESIProjact (From Idantity Yault)

(L7 Project ¢From Yersion Contral)

The Import window allows selections under a number of tabs, including Designer for Identity
Manager. Selections under the Designer for Identity Manager tab include:

+ Importing an existing Identity Manager project from the file system (the project must have
avalid .project file).

+ Importing an existing Identity Manager project from an Identity Vault.

+ Importing an existing Identity Manager project from an iManager export file (Driver Set
or Driver).

+ Importing an existing Identity Manager project from a version control server.
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3 In the Project (From Identity Vault) window, give the new project a name. Select where the
contents of this project are to reside (for Windows workstations, the default is C:\Documents

and Settings\Username\designer_workspace). Click Next.

@ Project (From the Identity Vault)

Project Name and Location @

Marne this project and choose a location, P

Project name: | Blanston |

Project Contents
Ise Diefault

@ l < Back ” Next > l

4 In the Import Project From Identity Vault window, specify the information needed to
authenticate to the Identity Vault (eDirectory) of your choosing. In the Host Name field, you
can use either a tree name or the IP address of the Identity Vault.

@ Project (From the Identity Vault) EIEE

Enter Authentication Information @
Enter information to authenticate to the Identity Yault of your choice, P
Host name: | 192.168.14.199 v ®
User narne: |admin.blansmn v| )

Password: | sssses |

[Osave password

@ l < Back ” MNext > l

5 Fill in the User Name and the Password fields.

If you select Save Password, Designer remembers your password. Otherwise, the next time you
close Designer, you need to re-authenticate when you import, deploy, or compare Designer

objects with the Identity Vault.
You can use history drop-down lists to choose a previously entered value from a list.

6 Click Next.
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In the Import Project From Identity Vault page, the Identity Vault Schema and the Default
Notification Collection are added as import options. If you do not want to import one of these
options, select the option and click the Remove button.

8 Inthe Import Project From Identity Vault page, click the Browse button to select the object you
want to import within eDirectory. Click OK to return to the Import Project From Identity Vault
page.

! (x|
Import Project From Identity Vault @
Add Driver Sets or Drivers to the import list by clicking on the A
Browse butbon and selecting them from the Identity Yault.
Ohijects o Import:
Browse, .,
@ Browse Identity Vault (%]
File
Select an object:
=&l IDMYAULT & Active Directary
=I-&8 Novell @ Active Directory2
“3 Extend & Active Directorys
+-78 South & Delimited Text
+-%8 Tomcat-Rales & DSML SOaP
+-78 Users & eDirectory Driver
+- 98 VirtualOffice &) Grouptivisel
+-45 Novell+Metware 6 ¢ ‘:IJLDAP
+-E &pache Group @Loopback
+-68 apchadmn-Reqistry G test
B WO iver Set
+- £ RootServerInfo
<& Security
+-&% Logging Services
< % >
(a]4 | Cancel |
Driver Set.Movell

9

10

11

If there are drivers you do not want to import with the driver set, select the driver and press the
Remove button. You can import multiple driver sets during the import operation. Just browse to
the various objects that you want to import and add them to the list.

Driver sets that are not associated with a server have a red minus sign in the lower right portion
of the driver set icon. These driver sets need a server association in order to be deployed.

(Conditional). You can also import policy libraries. Select the Browse button to browse to and
select the library you want to import, then click OK to add the library to the Import Project
from Identity Vault page.

After you have selected the objects you want to import, click Finish.

When the driver set imports, you see the Import Results window showing you if there were any
problems with the import procedure.
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12
13

-} Import Results W‘

Operation Results: m = E
LE} [Centity VALt Schema
& entilment.novel
Details:
o Information
Object: Identity Yault Schema
Description: The import of 'Tdentity Yault Schema' was successful,

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 501 for further information.

To close the Import Results page, click OK.

(Conditional) If you are importing more than one eDirectory driver, select the eDirectory driver
in the Objects to Import window and click the eDir-to-eDir button in the Import Project From
Identity Vault page to display the Connect to Identity Vault window, where you can import the
associated driver in the other eDirectory trees. Novell recommends that you import both
eDirectory drivers, especially if you have SSL/TLS enabled. Provide the username and
password, then click Continue. (Skip this step if you only want to import one eDirectory
driver.)

@ Connect to |dentity Vault 23]

biy| Provide the credentials to the Identity Vault that contains the associated
eDirectory driver for driver 'eDirectory Driver 1o madeans',

Host Mame: | 192.168.14,199 v| @
User Marme: | adrmin.blanston v| ®
Fassword: | ssssss |

[save password

Continue l [ Cancel ]
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14 (Conditional) If you specify the username and password and select Continue to import both
eDirectory drivers, you then see a Browse Identity Vault window where you select the
corresponding eDirectory driver. Select the driver and click Finish.

@ Project (From the Identity Vault)
Import Project from Identity Vault @

Add driver sets to the import list by clicking the Browse button and selecting them from the Identity Yault,

Cbjects to Impart:

= [m]€H mydriverset navell MADEANZ_TREE. [ Browse... ]
[#l& Active Directary

[¥®) Delimited Text
[1% Delimited Text OO
El eDirectory Driver to madean3 @ eDir-to-=0ir. ..
G‘) Password Sync Status Reflector
@l User Application
[l Useripplication

E4NS_TREE.

] Delimited Text
Ei eDirectory Driver to madean2

@ Hext = ’_ Einish ] l Cancel ]

You are returned to the Project (From Identity Vault) window, where you can select or deselect
the drivers, allowing you to choose only the drivers in a driver set that you want to import.

15 Click Finish.

By having both drivers available, you can view the complete data flow between the two
eDirectory drivers, as well as the other drivers you selected.
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11.1.2 Importing a Project from the File System

Earlier Designer workspaces are not compatible with Designer 3.5 and above. Designer stores
projects and configuration information in a workspace. These workspaces are not compatible from
one version of Designer to another. You need to point Designer 3 to a new workspace, and not to a
workspace used by a previous version of Designer.

If you have Designer 2.x or 3.5 Milestone projects, import the projects into Designer 3 (File >
Import > Project from File System). Be sure Copy project into the workspace is selected. Importing
the project runs the Converter Wizard, making the project compatible with Designer 3.5 architecture
and placing it under your designated Designer 3 workspace directory (designer_workspace by

default).

1 In Designer, click File > Import.
or

Click Import from file system from the No Projects Available page in the Project’s view, then

skip to Step 3.

2 From the Import window, select Designer for Identity Manager > Project (From File System),

then click Next.

Select

Import an existing Identity Manager project from the file
systemn. This project must have a valid .project file,

Select an import source:

type filter text

CERFoject (From File System)
5 Project (From Identity Vault)

] Project (From iManager Expart File)
7 Project (From version Contral)

@

=l

Cancel

3 From the Import Existing Projects page, select between the root directory or archive file. The
default is Select root directory. Browse to the directory containing valid projects.
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& Project (From File System)

Import Existing Projects @
Choose a project folder that containg one or more valid .project files, 4
(@ select raot directory: | C:\Documents and SettingsiMovell User'Designerwo
O select archive file:
Projects:
0= Select all
[¥]= Blanstonl
[#]'= Blanston2 Deselect all
V] Copy praoject into the workspace
DQpen projects after import
Cew )=o)

4 Select the directory where the exported project is saved with the .project extension.

There must also be a valid project file in the selected directory, or the project does not display
in the Projects window. If you have multiple projects you want to import and they are under the
same directory, select the directory above the projects and click OK. In the Import EXisting
Projects window, you can select or deselect any of the projects, then click Finish.

Make sure the Copy Project into Workspace option is selected to copy the contents of the
project into the workstation’s local workspace. (Do not use previous Designer workspaces for
Designer 3.5.)

You can also import multiple projects at the same time by specifying the base or root directory
where you want to start your search. The Import Wizard searches the selected directory and all
of its subdirectories for valid Designer projects to import. You can then select the projects that
you want to import into Designer by using the check boxes. If a project with the same name
already exists in Designer, you can’t import that project and you won’t be able to select it from
the list.

(Optional) If you have selected multiple projects, select whether to open these project’s
directories in the Model view. Designer won’t open all of the projects that are imported from
the file system unless you select Open projects after imports.

(Optional) You can also import projects from ZIP or TAR archives. Click the Select archive file
selection and select the directory where the exported project is saved with the .zip or .tar
extension. The whole archive is searched for valid Designer projects to import.

If the Projects you are importing need to be converted to this version of Designer, you will see
the Project Converter window. See Section 17.1, “Converting Earlier Projects,” on page 373
for more information.

In the Import Existing Projects window, you can select or deselect any of the projects, then
click Finish.
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11.1.3 Importing a Project from iManager

You can create a new Designer project by selecting an iManager .xml export file. These include
driver set and driver exports as well as Novell sample configuration files.
1 Click File > Import > Designer for Identity Manager > Project (From iManager Export File).
or

Click Project (From iManager Export File) from the No Projects Available view, then skip to
Step 3.

Select
N |
Import an existing Identity Manager project from an Manager export file I E 5 I
{driver set or driver),
Select an import source:

|type filter text |

k% Project (From File System)
_;__ PrD]ect (FrDm Identlt\,r Vault)

| PI’D]EEt (From Versmn Contrul)

2 Type a project name. Use the default designer_workspace directory for the project, or type or
browse to the directory where you want to import the project. Click Next.
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Choose File

Choose an iManager export file to import.

File: |

Lookir: | '_‘| My Documents
Y | Adabe - Joriver set.omil
th |y Cyberlink @ DriverSet.xml |
by Recent il.ﬂiclﬁles @ ebirectory Driver to Blanston Inc.al |
Daocuments :.lﬁMy Tusic i@ Event TransForm.xml
e ﬂMy Pictures 2 IDMDriverSet.xml
Lﬁ Pty videos 2 J0BC Z.xml
Deskiop Imyfiles ‘@ Manage Modify  xml
|i@ Ackive Directary2 xml | mydriverset, xml
& Active Directory, xml 2 SchemaMapping, xml
—‘j |@ Active Directory_Publisher062606.xml @ template.xml
My Documerts | | 3_., Active Directory_Publisher . xml
o) | i ADOZ-0306, xml
2 = — i@ ADOZ_Publisher xml
!1_5 g |i@ Blanston_xfer_to_IDM.xml
- | i@ Delimited Text,xml
My Computer
‘r‘] File hame: _Driver Set.xml VJ'
iy Metwork Files of type: * wrnl ~|

3 Select the directory where the exported project is saved with the .xml extension, click Open,
then click Finish.

4 When importing a driver set or driver into a project, you are asked if you want to validate the
values within the drivers you are importing. If you do not want to validate the driver
configuration at this time, click No.

Otherwise, click Yes and continue importing the project.

You can only import the driver functionality that you saved to the .xml file. This file does not
contain default driver configurations unless that is what you have saved.

5 Fill out the information requested in all of the Import Information Requested windows that you
see for each driver in the driver set, or for each driver selected. The Import Information
Requested windows contain different driver information from each selected driver.

6 Click Next or Finish (depending on the number of pages presented).
7 Click OK to close the Import Configuration Results window.

11.1.4 Importing a Project from a Version Control Server
The Import dialog box lists projects and enables you to select projects that you want to import.

There are a number of ways to access the Import dialog box in order to import projects from a
version control server, and this example covers one of those methods.

234 Designer 3.5 for Identity Manager 3.6 Administration Guide



Figure 11-1 The Import Wizard

Select
elec \

Import existing projects from a verson control server, I-E 4 5 I

Select an import source:

|type filer text |

k25 Project (From File System)

L5 Project (From Identity Yault)
Project (From iManager Export File)
& E ject (Frorm on Contral)

@ Mext = Cancel

1 Select File > Import.
or
If no projects are available, select Import from version control from the Project view.

2 Click Project (From Version Control) > Next.

3 Type a URL in the Version Control Server URL field, then press Enter. For example:
https://sun._provo.novell._com/svn
svn://123.123.131.120/trunk

4 Provide authentication to the Subversion* server if required. Depending on the type of security
you have set up, you might need to supply SSH authentication, SSL client certificate
authentication, or basic HTTP authentication.

& Version Control Authentication

Provide your username and password for the realm:
<gvn: /151,155,160, 120:3690>
13266d7e-de2d-do4e-843b-349e607 4229

Username: | Movell User |

Password: | TYTTITI] |

[IRemember my password

@ oK l l Cancel

5 Select a project or projects.
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@ Project (from Version Control Server)

Import Projects from Version Control Server

Specify & version control server URL to search for existing
projects.

Yersion Contral Server URL:

gy 151,155,160, 120 frunk

Projects:
[hello Select All
[]scott
O tost Deselect All
%p1030b
[ %p1030c -
[J=p1021b
[ #p1031c
[J#pli0la

Use default lacation

@ [ Finish H Cancel ]

Version control searches for projects three levels deep from the directory specified in the
Version Control Server URL: entry.

6 Click Finish. At the Version Control page that shows you the version control server status, click

OK.
The projects are imported into Designer and are added to the Project view and the Version
Control view.
¥ Project Checker | (0 version Contrel 52 €] Error Log HwEETO
Object StatLis | Date | User | <]
; 4/1/08 9:42 AM tpew —l
= IdentityManager 4/1/08 2:42 AM tpew
=1l Modeler Workspace 4108 9:42 AM bob
- (Bl FABIO 13TREE 4/1/08 9142 AM bob
B FARIO12-MDS 4/1/08 9:42 AM bob
+ &0 ds301 4/1/08 9:42 AM bob
+ @E Default Notfication ¢ 4/1/08 9:42 AM bob
i Schema 47108 9:42 AM bob ﬂ
47M of 2540 | "}

11.2 Importing a Library, a Driver Set, or Driver
from the Identity Vault

To import an eDirectory object, you must have access to the eDirectory tree that is associated with
the Identity Vault.

+ Section 11.2.1, “Associating a Server to the Identity Vault,” on page 237
+ Section 11.2.2, “Importing a Library from the Identity Vault,” on page 238
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+ Section 11.2.3, “Importing a Driver Set from the Identity Vault,” on page 239
+ Section 11.2.4, “Importing a Driver from the Identity Vault,” on page 242

11.2.1 Associating a Server to the Identity Vault

When you add a new Identity Vault to a project, you see the Add Server Association window, where
you can accept the default server, specify a server, or browse to a server. The import and deploy

features use the server association for later identification. To do this:

1 Inthe Modeler view, drag an Identity Vault icon from the Palette to the Modeler view to bring

up the Add Server Association window.

. Add Server Association

Specify Server for Identity Vault

Take the default, specify, or browse to a server,

Server DN | SRR gli=rs
Iderttity Manager Version:

For version information or to change the default, click
here

X

L LL

I

oK

H Cancel ]

Type the server’s DN context in the Server DN field, or click Browse.

2 If you select Browse, fill in the appropriate host name, user name, and password in the

Credentials to Identity Vault window. Click OK.

Credentials to Identity Vault

Tree: |

v| (#)

Username: |

v| o)

Password: |

[[]5ave passward

Cancel

3 Inthe Browse for Server Object window, select the server you want to associate with this driver

set and click OK.

In the Add Server Association window, you also see the Identity Manager version displayed.
This is important when importing and exporting driver sets and drivers, because you must

match driver sets and drivers to the correct Identity Manager version.
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4 Click the For version information or to change the default, click here entry for more
information.

5 Click OK to close the Add Server Association window and add an Identity Vault to your
Modeler view.

11.2.2 Importing a Library from the Identity Vault

1 Right-click the Identity Vault in the Modeler view, then click Live > Import.

2 (Conditional) If you have not yet provided authentication information, specify it now. In the
Identity Vault Credentials window, fill in the host name, the user name and password
information, then click OK.

Use the drop-down lists if they apply to your connection and user information. The Save
Password option allows Designer to keep password information for future connections to this
Identity Vault. Otherwise, you will see the Identity Vault Credentials page the next time you
open Designer.

3 On the Import from Identity Vault page, browse to the Library object by clicking the Browse
button.

4 Select the Library object and click OK.

@ Import from Identity Vault @

Import objects into an Identity Vault
Select the objects to import From eDireckory, @[]
Objects to Import: H =
ffft Mew Library novel
@ | Continue | [ Cancel

The library is added to the Import from Identity Vault page.
5 Click Continue, then click Import to import the library.
6 On the Import Results page, click OK.
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11.2.3 Importing a Driver Set from the Identity Vault

To import an Identity Manager Driver Set object (and all contained drivers) into an Identity Vault
object in the Modeler view:

1
2

Right-click the Identity Vault in the Modeler view, then click Live > Import.

(Conditional) If the Driver Set that comes with the Identity Vault creation is empty, you are
asked if you want to remove the default Driver Set icon from the selected Identity Vault. Click
Yes.

(Conditional) If you filled out the authentication information when you initially created an
Identity Vault icon in the Modeler view, go to the Properties view under the Project view.
Specify authentication credentials for the selected Identity Vault, then skip to Step 5.

(Conditional) If you have not yet provided authentication information, specify it now. In the
Identity Vault Credentials window, fill in the host name, the user name and password
information, then click OK.

Use the drop-down lists if they apply to your connection and user information. The Save
Password option allows Designer to keep password information for future connections to this
Identity Vault. Otherwise, you will see the Identity Vault Credentials window the next time you
open Designer.

In the Import from Identity Vault window, browse to the driver set by clicking the Browse
button.

Import objects into an Identity Vault
Select the objects to import from eDirectory,

File

Select an ohject: owse. . Il

- novell |
=78 Tomcat-Role
=718 Wirtualoffice
42 MovelHhetin
62 Apache Grou
-6 apchadmn-Ri
6T OpenSSH Se
=B W rryclriverset

& people

i By Security

w0 588 1 eainn Sorvicoe

Ll 2}

<

0K H Cancel ]

Chl=mydriverset. O=novell

@ [ Continue H Cancel ]

6 Select the driver set you want to import, click OK to place the driver set in the Objects to

Import list in the Import Driver Set from eDirectory window. You can then deselect the drivers
you do not want to import by deselecting the box next to the driver name. If you chose the
wrong driver set, select the driver set and click Remove. Otherwise, click Continue.
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You can import multiple driver sets during the import operation. Just browse to the various
objects that you want to import and add them to the Objects to Import list.

Driver sets that are not associated with a server have a red minus in the lower right portion of
the driver set icon. These driver sets need a server association in order to be deployed. An error
displays if the application can’t authenticate to the eDirectory tree you have selected.

(Conditional) If you are importing one or more eDirectory drivers, select the eDirectory driver
in the Objects to Import window, then click the eDir-to-eDir button.

(Conditional.) If you fill out the user name and password and click Continue to import both
eDirectory drivers, you then see a Browse Identity Vault window where you select the
corresponding eDirectory driver. Select the driver and click OK.

@ Import from Identity Vault )]
Import objects into an Identity Vault @H
Select the objects to import from ebirectary,

Objects to Import:

[/ RefDriver
[ T1l-References
[ T2-References
= DE rydriverset.novell MADEANZ_TREE.
[7)l@) Active Directary
[l Delimited Text
[/ Delimited Text OO
D@ eDirectory Driver to 108
LR =Directory Driver to m
7]/ Gereric Loopback
[/ Password Sync Status Reflector
M) User application v

adeans

(3) The selected eDirectory driver is not associated with another

eDirectory driver,

@ [ Cortinue H Cancel ]

You are returned to the Import Driver Sets from eDirectory window, where you can select or
deselect the drivers, allowing you to choose only the drivers in a driver set that you want to
import.

Click Continue. This brings up the Import Summary window, where you can see all of the
Driver Set objects that are being imported into Designer. This summary uses the same format
as the Compare window (see Section 11.5, “Using the Compare Feature When Importing,” on
page 259 for further information). Click Import to continue.

(Optional) As the import operation progresses, you are asked to associate a server with the
Identity Vault. Select the option that best suits your needs.
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@ Add Server to Identity Vault 1

®

\‘\_’/ ‘ou need to associate a server with "Identity Vault 1"
in order to deploy. How do yvou want to do that?

®iallow default server to be created

(O Specify a sarver

O Dan't create a server now

[CJremember selection - don't prompt again

[ Ok l [ Cancel ]

+ Allow default server to be created: Creates a dummy server with global configuration
values and other elements that are associated with this project until you specify an actual
server for the project. Make sure you have designated a correct Identity Vault server when
you deploy the driver set.

+ Specify a server: Brings up the credentials screen, allowing you to designate a host
server, a user name, and password for the Identity Vault server for this project.

+ Don’t create a server now: Skips all associations for this project. You need to fill in the
host information before you deploy this driver set.

+ Remember selection - don’t prompt again: Continues to use whatever server option
you chose the next time Designer needs to associate a server with an Identity Vault.

11 After you decide your plan of action and select the option you want, click OK to continue the
import procedure.

12 Click Finish.

If you selected in Step 7 to connect eDirectory drivers, you can view the complete data flow
between the two eDirectory drivers, as well as the other drivers you selected.

-
El 10M_TREE E] Blanston Inc.

Generic Mull

When the driver set imports, you see the Import Results window, showing you if there were any
problems with the import procedure.

Importing into Designer 241



-} Import Results g‘

Operation Restits: m = E
LE} [Centity VALt Schema
& entilment.novel

Details:

o Information

Object: Identity Yault Schema

Description: The import of 'Tdentity Yault Schema' was successful,

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 501 for further information.

13 Click OK to finish the import process.

11.2.4 Importing a Driver from the ldentity Vault

To import an Identity Manager Driver object (and all contained channels and policies) into a driver
set:

1 Select an Identity Vault in the Modeler view. If you have added a new Identity Vault to a
project, see Section 11.2.1, “Associating a Server to the Identity Vault,” on page 237 first, then
return to Step 2.

2 \Verify that the authentication credentials in the Properties view for the Identity Vault are
correct.

3 Right-click a DriverSet object within the Identity Vault, then select Live > Import.
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El Blanston Inc.

= Straighten Connections
(¥ select Connected Applications

arrange Applications 4
Distribute 4
Align 4

Dacument selection. ..
Import from Configuration File...
& Export to Configuration File...

& Deploy...
¥, Compare...

¥ Delete

Properties i i
Driver Set Configuration ¥

@ Driver Status...
D Start Drivers
@ Stop Drivers
@ Restart Drivers

4 (Conditional) If the Identity Vault is not authenticated to the eDirectory tree, you see the
Identity Vault Credentials window asking for the hostname, username and password. Provide

the information, then click Next.

5 In the Import from Identity Vault window, click Browse to select a Driver object from the

Identity Vault.

¥ Import from Identity Vault

Import objects into a Driver Set

Select the objects to import from eDirectory,

Obijects to Import:

File

| Browse..,
@ Browse |dentity Vault 3

Select an object:

|
= & Driver Set Al
. @& Active Direct
& Driver
- g/ Driver 2
i g/ eDirectary Di
& [E!
&g/ SAP-USER
- @) Userapplicat
w &3 Driver Set jj
&% Driverset

. @& IDM Driver Set %
£ i | >

CH=Groupwise. CN=Driver Set.O=MNovell

OK

] [ Cancel J

r

6 Click OK to place the driver in the Import from Identity Vault window, then click Continue to
install the driver and bring up the Import Configuration window.
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7 Inthe Import Configuration window, select Configure to edit the driver configuration, or select
Close to close the Import Configuration window. Most drivers cannot run with default values.
You need to modify the driver configuration values and parameters so the drivers can work
properly in your network environment.

2 Import Configuration

GroUpiwise-Reskit-IDM3_0_1-v 1.xml

@ The file import was successful.

Select "Configure” to edit the driver configuration. The import was
successful but the configuration values and parameters for the driver
may have been set to default values,

| corfigure... | ’ Close

NOTE: You also see the Import Configuration window when you drag an application from the
Palette to a driver set in the Modeler view.

8 When you select Configure, the driver’s Property page with the Driver Configuration option is
displayed. Fill out the required values and parameters that are necessary to have the driver run

in your network environment.

® Properties for GroupWise (Resource Kit)

Driver Configuration
General -
Driver Corfiguration Drver Module |Authenu'ca1jon Startup Option | Driver Parameters
Engine Control Yalues
Gcg\J:s ®ava
; Mame of the Java class:
iManager Icon
Log Level ‘ com.novel.gw.dirml driver.gu . SWdriverShim v
I\Nﬂamfejtp . O Native
amed Passwords
Mame of the DLL:
Trace
O Connect to Remote Loader:
Diriver Object Password
Remaote Loader client configuration for documentation
[
Select Remote Loader client configuraton:
< > Apply
) ol ] ’ Cancel ]
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The two required options for every driver are Driver Configuration and GCVs. However,
because each driver contains different values and parameters, you need to consult the driver
manual for specific values. Go to the Identity Manager Drivers web site (http:/
www.novell.com/documentation/idm36drivers/index.html), then select the manual for the
driver you are configuring.

9 (Conditional) If you are importing one or more eDirectory drivers, Novell recommends that
you connect to those eDirectory drivers during the import process. Select the eDirectory driver
in the Objects to Import window, then click the eDir-to-eDir button.

10 (Conditional) Fill out the user name and password for the other eDirectory tree and select
Continue to import both eDirectory drivers.

11 (Conditional) In the Browse Identity Vault window, select the corresponding eDirectory driver,
then select the driver and click OK. You are returned to the Import Drivers from eDirectory
window.

When the driver imports, you see the Import Results window showing you if there were any
problems with the import procedure.

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 501 for further information.

12 Click OK to finish the import process.

11.3 Importing a Driver Configuration File

You can import an Identity Manager driver configuration file into the selected driver set for a project
by using the Import from Configuration File option, which imports an XML configuration file that
can be a driver set, an individual driver, driver channels, or policies. If you import a driver
configuration file that contains only a policy, Designer creates the framework for parent containment
objects, such as a channel, a driver, or a driver set. Such parent containment objects do not contain
attributes; they are only the framework of the channel, driver, or driver set from where the policy
came.

These configuration files are in XML format, which you can save to a local, removable, or network
directory through the Export to Configuration File option. After you select the driver configuration
file to import, you are prompted to provide driver-specific information for setting up the driver and
building policies. The exported .xml files are compatible with those used by the iManager driver
configuration file plug-ins for Identity Manager 2.7. This allows you to export configuration files
from Designer and import those files through iManager or through Designer’s Import feature.

You can also use the Import from Configuration File option as a backup method. For example, if you
are working on a group of policies in an Active Directory driver, you can use the Export to
Configuration File to back up your work, adding dates to the exported filenames so you can select a
particular driver configuration that you want to use as the basis for your Active Directory driver. If
something goes wrong, you can re-import the base driver. You can also use this export/import
feature to export and import just the policies you are working on.

Of course, a better method for backing up your projects is through the version control feature. See
Chapter 19, “Version Control,” on page 411.
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You can import a configuration from a file in three ways:

+ Section 11.3.1, “Importing an Identity Manager Project from the File System,” on page 246

+ Section 11.3.2, “Importing a Driver Configuration from a File in the Modeler View,” on
page 246

¢ Section 11.3.3, “Importing from a File through the Outline View,” on page 248

11.3.1 Importing an Identity Manager Project from the File
System

The Import an Identity Manager Project from File System option allows you to import an Identity
Manager project that has been saved to the file system through the Export > File System option. The
project must have a valid .project file and accompanying file structure for the project to
completely import. For information about importing a project, see Section 11.1.2, “Importing a
Project from the File System,” on page 231.

11.3.2 Importing a Driver Configuration from a File in the
Modeler View

You can import a previously exported configuration file or one of the sample .xml driver
configurations that are included with Designer. To import a configuration file into a driver set:
1 Select an Identity Vault in the Modeler view.

2 Right-click a DriverSet object within the Identity Vault, then select Import from Configuration
File.

3 Inthe Import a Driver Configuration File window, type the name of the configuration file, or
browse to and select the .xml file.

If you use the Browse feature, by default Designer takes you to the following directories:
+ for Windows:

C:\Program
Files\Novel I\Designer\eclipse\plugins\com.novell._idm_3.5.x\defs\drive
r_configs\current\drivername

+ For Linux:

/home/username/designer/eclipse/plugins/com.novell.idm_3.5.x/defs/
driver_configs/current/drivername

(The “x” after the idm_3.5 number refers to Designer build numbers). You can use one of the
xml configuration files in a selected directory or you can browse to a directory containing an
exported configuration file.

4 Click OK.

5 Complete the import by filling out the Import Information Requested prompts for the driver
configuration file.
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@ Import Information Requested

\‘_?/ The driver writer requested that the Following information be supplied in order to import this driver configuration File.

Information requested: * Required

3

The name of the driver contained in the driver configuration file is “eDirectory Driver", Enter the actual name you want to use For the driver,

Driver name: *

eDirectory Driver| 2?

Enter the DMS host name or IP address, and communication port of the Dir<ML server in the remaote tree, For example:

[151.155.144,23:5196]
[hostname:§196]

Remote Tree Address and Part: *

| hostname ;8196

Data flow can be configured at this time for the driver, Select the data flow that yvou desire, Bi-directional means that both eDirectory trees are
authoritative sources of the data synchronized between them, Authoritative means that the local tree will be the authoritative source,
Subordinate means that the local tree is NOT an authoritatve source.

Configure Diata Flow:

Bi-directional -
Choose the desired Form of placement, Choose Mirrored to synchronize objects hierarchically between the local and remate trees, Choose Flat
to synchronize all Users and Groups into specific containers, Choose Department o synchronize Users and Groups by department (0L},

Configuration Option:

Miverwad -

Ok | Cancel

-

v

+ The template varies, depending on the driver configuration file selected and the state in
which the file was saved. Saved files might only prompt for a driver name, but need other

values in order to work in a network environment.

NOTE: The pre-ldentity Manager 3.6 Driver Configuration Wizard adds different

policies to the driver, depending on which options you select when you initially import the
driver. If you want to change an option that you did not initially choose, it is not possible,
because the information is not included in the driver. You must delete the driver and create

a new one through the Driver Configuration Wizard.

WARNING: Do not use the Driver Configuration Wizard on the .xml file that you are
importing. The Wizard brings up the Import Information Request forms, but these forms
are pulled from the default driver that come with Designer and will overwrite the driver

you are importing. Use this method only if you need to start over.

+ Identity Manager 3.6 Driver Configuration Wizard adds all policies when the driver is
imported, and are not lost if you did not select an option in the Import Information
Request forms. If this is a driver configuration file that came with Identity Manager 3.6,

you can change the driver’s values through the Properties page.

If the driver needs other values and parameters in addition to what appears on the Import
Information Requested template, close the template, right-click the driver line in the
Modeler view and select Properties > Driver Configuration and GCVs to fill out what you

need. You may also need to fill out GCVs at the driver set level.
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Since each driver contains different values and parameters, consult the driver manual that
matches the installed driver at the Identity Manager Drivers web site (http://www.novell.com/
documentation/idm36drivers/index.html). Then select the manual for the driver you are
configuring.

6 Click OK, then click OK in the Import Configuration Results window.

7 You might have imported a single driver or a collection of drivers (a driver set). If you are

importing a driver set, repeat Steps 4 and 5 for each driver in the driver set. When you are
finished with each imported driver, click OK at the Import Configuration Results window.

11.3.3 Importing from a File through the Outline View

You can use the Outline View to import driver sets, drivers, channels, and policy configuration files
from the file system. The following example demonstrates how to import a driver, but the procedure

also works for the other files.

1 Double-click the System Model icon under a project name in the Project view. This brings up
the project model in the Modeler view.

2 Click the Outline tab.
3 Right-click the Driver Set object and select Import from Configuration File.

G - outre x g BfW EE® O
= Tl Blanstono3
=-[@] Blanston, Inc.
& server
e W Corivver Set
e
Copy

+

Z Dir¥ML Script Tracing...

B Document Selection. ..,

Impart from Configuration File. ..
M Export to Configuration Fie...

Live

¥ Delete

Properties

4 In the Import a Driver Configuration File window, type the name of the configuration file, or
browse to and select the .xml file.

When a driver is exported, Designer uses the name of the driver set or driver object, to which
you can add dates. In this example, it is an Active Directory driver that was exported June 26th

and is now being imported.
5 Click Open, then click OK to import the configuration file.
To import a policy into a driver set:

1 Inthe Outline view, click the Driver Set icon, then click Import from Configuration File.

2 Inthe Import a Driver Configuration File window, browse to or specify the XML configuration
file name.
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@ Import a Driver Configuration File

File: |

HBI’DWSE... ]

Laok in: | 15 Projects

v o

] E|‘

N I Elanstonl
uﬁ I Elanstonz
MyRecent | |C)Blanston3
Documents I BLanstans
e Blanstan, Fo,xml
|_ Blanstonz, source.none.xml
Desktop Blanston2, saurce. primaty . xml

Blanstonz, saurce . style, xml
Driver Set.xml

Entitlernents Service Driver,xml
Exchange Wolker xml

My Documents
Y Input Transform,xml

ModelerQutlinestate, xml

mydriversek,xml

“|Password( Subg-Pub Email Motifications. xn

; LDAR. xrl
-:_-‘.J;g LDAP_Publisher xml
= [ Loophack.xml
ry Computer .
< 1 5
‘ﬁ__; File name: |Passw0rd[5ub]-F’uh Email Motifications. =ml ¥ | [ Open ]
My Netwark, Files af hpe: | * = | ’ — ]

Click Open, then click Save to import the selected policy.

Each policy is saved to its own .xml file. By default, Designer uses the name of the policy or

rule selected.

In the Perform Prompt Validation window, you are asked if you want to fill in required driver
information. If you answer Yes, you see the Import Information Requested dialog box as
described in Step 5 and you must provide values to all of the required fields. If you answer No,
you still see the Import Information Requested dialog box, but it isn’t necessary to fill in the

required information.

Complete the import by filling out the Import Information forms for the driver configuration
file as necessary. Policies are saved with a skeleton driver configuration structure, which
designates where the policy resides. In this case, the driver already existed and the imported

policy was initially written for that driver.
Click OK.

When the policy or rule is imported, you see the Import Configuration Results window, which
indicates if there were any problems with the import procedure.
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@ Import Configuration Results &

Operation Results:
@ Manage Modify.xml

Details:

0 Information

Description: The file import of Manage Modify.oml was successful,

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 501 for further information.

7 Click OK to finish the import process and close the Import Configuration Results window.

11.4 Importing Channels, Policies, and Schema
Items from the Identity Vault

A channel is a combination of rules and policies, and Designer allows you to import a channel
instead of the entire driver. The Subscriber and Publisher channels describe the direction in which
the information flows. The Subscriber channel takes the event from the Identity Vault and sends that
event to whatever the receiving system is (application, database, CSV file, etc.) The Publisher
channel takes the event from the application, database, CSV file, etc., and sends that event to the
Identity Vault. The Subscriber and Publisher channels act independently; actions in one are not
affected by what happens in the other.

+ Section 11.4.1, “Importing a Channel,” on page 251
+ Section 11.4.2, “Importing a Policy,” on page 254
¢ Section 11.4.3, “Importing a Schema,” on page 256
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11.4.1 Importing a Channel

To import an Identity Manager channel (a Subscriber channel or a Publisher channel) object (and all
contained policies) into a driver:
1 Select either a Driver object or an Application object in the Modeler view.

The Driver object is represented by the line between the Identity Vault and the Application
object and has a circle icon to represent it &/. The Application object connects to the Identity
Vault through the Driver object.

2 Right-click a Driver object, then click Live > Import.
or
Right-click an Application object and click Driver > Import.

El IoM_TREE

& DirsML Script Tracing...
W (2 Show Policy Sets

& Simulate...

¥] Run Configuration Wizard...

Document Selection...
& Export to Configuration Fie..,

<7 Undo Change Lacation Import from Configuration Fike.,..,

DistribLite " & Deploy...
Align Y & Compare...
. ) R
i Show Subsysterms Criver Configuration
=@ Add to Group O Criver Status
# Show Dataflow Yiew O sStart Dr.lver
© Stop Criver
@ Remote Control Desktop @ Restart Driver

& Manage Application Schema...,
9= Aop & Set Up Driver Security...

Document Selection... @ Set Driver Trace Level..,

Froperties
# Delete

Properties _
3 If Designer can’t authenticate to the eDirectory tree specified in the Identity Vault, you see the

Identity Vault Credentials window if you have not previously specified the authentication
credentials or if you do not save the password. Fill in the appropriate information and click OK.

4 In the Import from Identity Vault window, browse to and select either a Publisher or a
Subscriber Channel object from the eDirectory tree under the corresponding driver.
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# Import from Identity Vault

Import objects into a Driver .@n
Select the objects to import from eDirectory, i

Obijects to Import:
@ Browse Identity Vault = [l

File

Select an object:

]

=) Active Directs :I

- @) Publisher |
=g Subscribe

& & Marv's Tok =

{SiPublisher

: El & Delimited Tes Password(Pub)-Sub Ema!l Not!ﬂcat!ons
oo 2 = Password(Sub)-Pub Email Motifications
& 4g Delimited Te: == ”
= : Z% Schematapping
& eDirectory Dr Tarv's 1ob
& g eDirectory Dr
& &) Generic Loopl
& &) Password Sy ¥
[ | s |

[ Ok ] [ Cancel ]

Ch=Subscriber.Ch=Active Directory CH=rnydriverset.O=novell cancel

5 You can import more than one channel at a time; if you want to import both channels, select
one channel, click OK, then browse to the next channel, select it, and click OK.

6 Click Continue.

As the channel imports, you see the Import Summary window showing you the differences
between eDirectory (the source of the import) and Designer (the destination).
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@ Import Summary

Selact an object or atiribute: =

= 5 Subscriber
2 Atributes
(@ DirdML-EventTransformationRule
73 Manage Madify

[“lonly show differences

Text Compare

.+ Designer (Destinatior

[CDon't shaw this dialog again

eDirectory (Source)

Infarmation
Compare Status: B not Irnported

|

Cancel ]

[ Import H

You can click the different objects in the channel view differences between the two drivers. All
channel information is overwritten by the import procedure; however, the rest of the driver is

unaffected.
7 Click Import.

For more information on Compare, see Section 11.5, “Using the Compare Feature When

Importing,” on page 259.
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@ Import Results

Operation Results: H =L
& Subscriber Userapplication Driver Set.Movell

Details:

o Information

Description: The import of Subscriber,Userapplication.Driver Set.Novell was
successful

If there are any problems with the import procedure, they are displayed with a red icon in the
Import Results window and you see an error description that is related to the operation results.
If you have multiple errors, selecting an error displays the error’s description in the Details >
Description field. See “ldentity Vault Configuration Errors” on page 502 for further
information.

8 Click OK to finish the import process.

11.4.2 Importing a Policy

A policy is a collection of rules and arguments that allows you to transform the data that an
application sends to and receives from eDirectory. You use policies to manipulate the data you
receive from eDirectory or from the connected system so they can synchronize the information in
their databases. Each driver connects to a different system, and policies tell the driver how to
synchronize the data on that connected system to the Identity Vault.

You might use the Import feature for policies more than anything else. For example, you can set up a
policy to allow users with the title “Manager” to be placed in a specific container, no matter which
application the information is coming from, and you can place this information in multiple
connected systems. However, because each application is different, you need to modify the
arguments and rules within policies to reflect those differences. For more information about policies,
see Understanding Policies for Identity Manager 3.6 (http://www.novell.com/documentation/
idm36/policy/data/bookinfo.html) and Policies in Designer 3.5 (http://www.novell.com/
documentation/idm36/policy_designer/data/bookinfo.html).
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To import an eDirectory Policy object (for example, a rule or a style sheet) into a driver or channel

(Subscriber or Publisher):

1 Select a driver in the Modeler view.

or

Click the Outline tab and select a Driver or Channel object from the Outline view.
2 Verify that the authentication credentials in the Properties view for the selected Identity Vault

are correct.

3 Right-click the Driver or Channel object, then click Live > Import.

M
Z Dir¥ML Script Tracing...
& Simulate. .

[El Import from Configuration File. .,
Export to Configuration Fie...

’.'J Im [als] rt..

Properties

& Deploy...
&5 Compare...

4 If the application can’t authenticate to the eDirectory tree, you see the Identity Vault
Credentials window asking for the hostname, username, and password if you have not
previously specified the authentication credentials or if you do not save the password. Fill in
the appropriate information and click OK.

5 In the Import from Identity Vault window, click Browse, then select a policy object from the
channel you specified when you started the import process.

File

Select an object:

%) Publisher ~
& Subscriber
& Marv's Job
&/ Delimited Text
& Delimited Text Ol
&/ eDirectory Driver 1
& eDirectory Driver 1
& Generic Loopback
& Password Sync St
& test
& User Application
& Userspplication
fiid DsetLib
& PwdEsxpz
& TestDSet
fify mLib
fifl Marv's Library v

S=Command Transform 5SS

= Command Transform
2ation

== Event Transform

== Matching

== Pagsword(Pub)-Add Password Payload

== Password(Pub)-Check Password GCY

=5 Password (Pub)-Default Password Policy

=8 Password (Pub)-Publish Distribution Password

28 Pagsword (Pub)-Publish NDS Password

S Placement

2= UserMameMap

Ok ] I Cancel

CH=Creation.CN=Publisher, CN=Active Directory CN=rmydriverset. O=novell
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Policies are found under either the Publisher or Subscriber channel of a selected driver or under
the driver itself. Be sure to match the proper policy to the proper channel or driver object.

6 Click OK, then click Continue to import the policy.

You see the Import Summary window showing you the differences between eDirectory (the
source of the import) and Designer (the destination). You can click the different objects in the
policy to see what is different between the two policies. All selected policy information is
overwritten by the import procedure; however, the rest of the driver is unaffected.

7 Click Import.

If the importing policy contains the same values as the policy in Designer, you are not allowed
to import the policy. (See Section 11.5, “Using the Compare Feature When Importing,” on
page 259 for more information on the Compare feature.)

Clicking Import brings up the Import Results window. If there are any problems with the
import procedure, they are displayed with a red icon, and you see an Error description that is
related to the operation results. If you have multiple errors, selecting the different errors
displays the error’s description in the Details > Description field. See Section 21.5.3, “Error
Messages and Solutions,” on page 501 for further information.

8 Click OK to finish the import process.

For policy design, see the Policy Builder and Policy Management Help topics within the
Designer utility. Also, see Understanding Policies for Identity Manager 3.6 (http://
www.novell.com/documentation/idm36/policy/data/bookinfo.html) and Policies in Designer
3.5 (http://www.novell.com/documentation/idm36/policy_designer/data/bookinfo.html).

11.4.3 Importing a Schema

You can import a schema from the Identity Vault or from a .sch file into your project. When you
import a schema, you can select the whole Identity Vault schema (not recommended) or just the
schema differences between the Identity Vault and your project.

1 Bring up the project in Designer’s Modeler view. Right-click the Identity Vault and select Live
> Schema > Import.
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< Undo Change Location

NEN 4

=== Straighten Connections

("1 Select Connected Applications
Distribuite 4
Align 4

& Change to eDirectory Tree
Change to Idenfity Vault / Meta-Directory
=@ Add to Group

& Manage Vault Schema...

Document Selection. ..
L Import Schema from Fle...
Import from Configuration File...
Export to File 4
E-Mail Templates L =i
Tovt
4 = Import.
& Daploy...
5 Compare...

¥ Delete

Properties

4 Manage Directory
& OS Trace
@ Manager

© Driver Status
© Start Al Drivers
© Stop Al Drivers
@ Restart All Crivers

2 On the Select Source for Import page, select Import from eDirectory if you can connect to an
actual Identity Vault.

NOTE: The specified user must have administrative rights to the schema.

@ Schema Import Wizard 3]
Select Source for Import @
Select the location to import the schema

Import from eDirectory

Host Narme: | 192.168.14.199 vl

{(Example: 192,168,14,199 or myserver.compary.com)

LUser Marne: | admin.novell v|

(Example: admin Novell)

Password: | [TTTIT] |
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3 Inthe Import from eDirectory section, specify the hostname, username and password
connection information.

The Host Name and User Name entries have drop-down menus storing the last information you
typed into these fields, which you can use for filling in these entries.

4 Click Next.
5 Decide which classes and attributes to import.

On the Select Classes and Attributes for Import page, you can select all of Identity Vault’s
schema, including classes and attributes. However, this can create very large documents when
you document the project (600 pages or more).

6 If you want to import all the classes and attributes, click Select All, click Finish, then skip to
Step 8.

Select only the classes and attributes that you want to import. If you only want to import the
schema differences between the live Identity Vault and the Identity Vault in your project, click
View Differences, then continue with Step 8.

. Schema Import Wizard

Select Classes and Attributes for Import

Select "Import all associations” to associate the selected atiributes with
classes that might already exist in Desigrer.

Classes: Attributes: O Import &l associations
|| [Arwything] # || [ [Arything] ~
[ ] [Mothing] [ [Mothing]

[] AFP Server [] accessCardMumber

[ ] Alias [ ] Account Balance

[] apchadmnConfiguration [ acL

[ ] apchadmnConfiguratiorBlock [ miased Object Mame

[] apchadmntodule [ alowaliasToAncestor

[ ] apchadmnServer [ ] Mlow Unimited Credt

[] apchadmmviruaHost [ apchadmn-Block Type

[ applicationEntity [ apchadmn-ConfigurationInfo

[] applicationProcess [ apchadmn-ModuleDisable

[] Audit:File Object [ apchadmr-ModuleFieName

[] authPasswordobject [] apchadmn-ModuleCbiectFie

[ ] bhcommunity [ apchadmr-ModuleSymbolMame

1 hheamem mitubarmbarchin 1 amchadmn-Seane 4
< > < >
’Select Al ] ’Dgse\ect Al ] ’Show Al ]
YWiew Differences...

@ [ <pack | mext> | Emsn [ cancel |

7 On the Schema Differences page, you see the schema differences between the live Identity
Vault and the Identity Vault in your project. Click Select All if you only want to import schema
differences. Otherwise, click Cancel.
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. Schema Import Wizard @

Schema Differences

Class/Atribute
Class: DirXML-ApplicationAtirs
Class: DirdML-Driverset
Class: DirkML-WorkOrder
& Class: DirsML-WorkToDo
O Class: ndsLoginProperties
[ Class: nestedaroupAux
[ Class: nspmPasswordPolicy
O Class: salesman
Class: SAS:Service
[ Clags: SMS SMDR, Class
[ Class: srvprvAppConfig
[ Class: srvprvRecipReport
[ Class: srvprvRecipReportDefs
O cClass: srvprvRecipResoLrce
[ Class: srvprvRecipResourceBinding

[ Class: srvprvRecipResourcebefs
Class: srvprvRequest

[ rlase srunreTaam

4

@

[ Class: srvprvRecipResourceCollection

33

This table shows all of the differences between the Identity Yault schema and the
current project schema. To select all of these in the selection wizard, click Select All.

Cifference

COptional atiributes are different

Optional atiributes are different

Optional attributes are different, different «
Cifferent contanment

Optional attributes are different

The class does not exist in the project.
Optonal atiributes are different, different «
The class does not exist in the project.
Optional atiributes are different

The class does not exist in the project.
Optional atiributes are different

The class does not exist in the project.
The class does not exist in the project.
The class does not existin the project.
The class does not exist in the project.
The class does not exist in the project.
The class does not exist in the project.

Optional attributes are different
intinnal attribe tae ara diffarent

’ Ok l [ Cancel

\

8 Selecting Select All > OK brings you back to the Select Classes and Attributes for Import page
with the schema differences now selected under the Classes and Attributes headings. If you
select any classes from the Schema Differences page, the Import all associations box is
selected. Leave it selected, as it enables you to associate the selected attributes with the classes
that might already exist in Designer. Click Finish.

If you selected Cancel on the Schema Differences page, make your schema selections on the
Select Classes and Attributes for Import page, select the Import all associations box
(recommended), and click Finish.

9 (Optional) Click Next if you want to see the Import Summary page to see the classes and
attributes that you are importing. Then click Finish.

10 On the Import Messages page of the Schema Import Wizard, click OK.

If you want to save the differences to a log file, click Save to Log. This brings up the Save As

dialog box, where you can choose a filename and directory to store the file in.

11 Click Save, then click OK.

11.5 Using the Compare Feature When Importing

Designer’s Compare feature allows you to see differences between the driver sets, drivers, channels,
and policies that are stored in projects and those that are running in deployed systems, and reconcile
any differences to either Designer or Identity Vault. Previous versions of Designer only provided
conflict resolution when importing a Driver. While importing, you could select which policies of the
driver you wanted to update, but you could not view any differences between existing and new

values.

Designer provides conflict resolution on an object-by-object basis and allows you to view the
differences between existing and new values when importing and deploying driver sets, drivers,
channels and policies. For example, before importing a driver object in Designer to a driver object
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that already exists in the Identity Vault, you can run Compare. Compare shows whether the driver
objects are equal (no action is necessary) or unequal. If unequal, you can choose not to reconcile the
driver objects, choose to update the driver object in Designer, or choose to update the driver object

in the Identity Vault.

You can run the Compare feature at any time. If you choose to reconcile the differences between
drivers objects in Designer and eDirectory while in Compare, you won’t need to run Import or

Deploy.

*

*

*

*

Section 11.5.1, “Using Compare When Importing a Driver Object,” on page 260
Section 11.5.2, “Using Compare on a Channel Object,” on page 263

Section 11.5.3, “Using Compare On a Policy,” on page 263

Section 11.5.4, “Matching Attributes with Designer Properties,” on page 263

11.5.1 Using Compare When Importing a Driver Object

Use this procedure if you want to import a Driver object from the Identity Vault and the same driver

already exists in Designer.

1 Right-click the driver object in either the Modeler view or in the Outline view, then click Live
> Compare to bring up the Designer/eDirectory Object Compare window.

Select an object or attribute: = = | Showal

= €y Active Directory
=@ attributes

@ DirXML-InputTransform
@ DirXML-OutputTransform
@ DirXML-MappingRule
@ DirXML-ECMASeript
@ DirkML-DriverFilter
@ DirkML-Corfigharifest
@ DirxML-davatodule
@ DirkML-flativeModule
@ DirkML-TraceMame
@ DirXML-Driverlmage
@ DirkML-TraceFile
@ DirkML-DriverTracelevel
@ DirkML-Loginit
@ DirkML-Tracelewel
G Nirk ~Tearasizel nnit

Text Compare

Designer
<?xwl version="1.0" encoding="UTF-8"2><filter>
<filter-class class-name="Group” publisher="syn¢
<filter-attr actr-name="CHN" publisher="ignor
<filter-attr atbtr-name="Description” publisk
<filter-attr attr-name="Full Name" publisher
<filter-attr attr-name="L" publisher="sync"
<filter-attr actr-name="Member" publisher="s
<filter-attr attr-nawe="Owner" publisher="s1
</filter-classs
<filter-class class-nawe="Organizational Unit” |
<filter-attr actr-name="Description” publisk
<filter-attr atbtr-name="0U" publisher="ignor
</filter-class»
<filter-class class-name="User" publisher='sync’
«filter-attr attr-name="CN" publisher="ignoy
>

-

® DesignerfeDirectory Object Compare |;‘@@
&

Information
Compare Status: @ Equal

Reconcile Action:

eDirectary
<2xml version="1.0" encoding="UTF-§"?><filter> | A
<filter-class class-nanme up" publisher="
<filter-attr attr-name="CN" publisher=ri

<filter-attr attr-name="Description” puk
<filter-attr attr-name="Full Name" publi
<filter-attr attr-name="L" publisher="sy
<filter-attr attr-name="Nember" publishe
<filter-attr attr-nawme="Owner” puklisher

</filver-class>

<filter-class class-—nane="Organizational Uni
<filCEr-attr attr-name="Description” puk
<filter-attr attr-name="0U" publisher="i

</filter-class>

<filter-class class—name="User” publisher=ns
<filter-attr attr-name="CN" publisher="i ¥

< >

Closs

Under the Select an object or attribute, you see the selected object with the differences between
Designer’s and eDirectory’s driver object. You can select the attributes and child objects to see
the actual differences displayed in the Text Compare area.
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@ DesignerfeDirectory Object Compare

Select an object or attribute: + (=] |Show Al ~

= &IJ Active Directary B
=@ Attributes

Dir<ML-Input Transform

DirXML-Oukput Transform

Dir XML-MappingRule

Dir ¥ML-ECMASCripk

Dir sML-DriverFilker

Dir XML-Confighanif est

Dir %ML-Jav aModule

Dir “ML-MativeModule

Dir=ML-TraceMame

Dir sML-DriverImage

Dir ML-TraceFile

Dit sML-DriverTracelewvel

Dir ¥ML-LogLimit

Dir#ML-Tracelewvel

Dir XM -TrareSizel irnik

SEAEAAIAREAARAA®E

The plus icon at the right side of the Select an object or attribute allows you to expand all
elements in the parent object, and the minus icon collapses all of the elements. The “?” button
in the bottom left portion of the window displays the Summary/Compare dialog box help.

Server-specific attributes are attributes that have a value for each server that is associated with
a driver set. These attributes are displayed in the Attributes list with the server name in
parentheses to the right of the attribute name.

By default, the Compare window only displays values that are different between Identity Vault
and Designer. To view all of the object values, select Show All from the drop down menu.

Values that are equal are shown as Equal on the Compare Status line under Information.

Infor mation
Compare Status: 5 Nt Imported e
Reconcile Action: 3 pg rot recorcile
O Update Designer
b’

The overlay image displayed in the Compare Status entry identifies objects or attributes that
need reconciliation. The following table describes what you see in the Compare Status line and
the overlays that you can see:

Compare Status Description

Equal The selected attribute’s value or all attributes of the selected object are the
same in eDirectory and Designer.

Unequal The value of the selected attribute, or one or more attributes of the

selected object, are different in eDirectory and Designer.
]
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Compare Status Description

Not Deployed The selected object or the object containing the selected attribute is not
deployed to eDirectory.

"

Not Imported The selected object or object containing the selected attribute does not
exist in Designer.

]

Unknown The selected object or object containing the selected attribute cannot be
compared, such as a password.

2|

Deleted Designer tracks objects that are deployed, then deleted from the Designer
project.

*

You can also see an Attribute Note if you select an attribute.

3 In the Information portion of the Compare window, select how you want to reconcile the
differences between the Source and Destination. If Compare Status shows Unequal, you have
three choices:

+ Do not reconcile: To do nothing, keep the default value of Do Not Reconcile.

+ Update Designer: To update the driver in Designer so that it contains the same
information as the driver in the Identity Vault, select Update Designer.

+ Update eDirectory: To update the driver in eDirectory to reflect the changes you have
just made to the driver in Designer, select Update eDirectory.

If you select the parent object to perform the update, then all of the child objects under the
parent reflect that choice and you see the Reconciled By Parent button selected. If you do not
choose a parent object, you can reconcile each child object individually.

4 View the differences displayed in the Text Compare area.

Texk Compare
Desigrer eDirectory
<?xml version="1.0" encoding="UTF-8"2:<filter: <2xml version="1.0" encoding="UTF-8"?:<filter> R
<filter-class class-name="Group™ publisher="syng <filter-class class-name="Group” publisher="
<filter-attr attr-name="CN" publisher="igno: <filter-attr attr-name="CHN" publisher="i
<filter-attr attr-name="Description™ publist <filter-attr attr-nawe="Description® puk
<filter-attr attr-name="Full Name" publisher <filter-attr attr-nsmwe="Full Mame" publi
<filter-attr attr-name="L" publisher="sync'" <filter-attr attr-name="L" publisher="s%
<filter-attr attr-name="Merber" publisher=": <filter-attr attr-name="Nerber™ publishe
<filter-attr attr-name="0Owner" publisher="s3 <filter-attr attr-name="Owner"” publisher
</filter-classs </filter-class>
<filter-class class-name="Organizational Unit" 3 <filter-class class-name="Organizational Uni
<filter-attr attr-name="Description” publist <filter-attr attr-name="Description” puk
<filter-attr attr-name="00" publisher="ignor <filter-attr attr-name="0U" publisher="i
</filter-clasa> </filter-class>
<filter-class class-name="User" publisher="sync' <filter-class class-name="User"™ publisher="z
<filter-attr attr-name="CN" publisher="ignor <filter-attr attr-name="CN™ publisher="i ¥
< b3 < >

The Text Compare values displayed in the bottom portion of the Designer/eDirectory Object
Compare window vary, depending on the object being compared. For instance, Compare shows
you changes down to the policy level. The Text Compare dialog box uses the Eclipse Compare
editor to compare attributes that contain XML data, such as policy data, driver filters, or
configuration data. The differences in the code are highlighted in blue.
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5 After you view the differences, click Reconcile to perform the reconciliation actions for each
object in the tree, or click Close to close the Designer/eDirectory Object Compare screen.

After reconciliation, the object matches both locations and has been imported or deployed
through the action.

11.5.2 Using Compare on a Channel Object

Use this procedure if you want to import a channel object from the Identity Vault and the same
channel already exists in Designer. You can view the differences and decide whether to reconcile
them.

1 Right-click the channel object in the Outline view. Click Live > Compare to bring up the
Designer/eDirectory Object Compare window.

All Compare windows behave as described in Section 11.5.1, “Using Compare When
Importing a Driver Object,” on page 260.

After reconciliation, the Channel object matches both locations and has been imported or
deployed through the action.

11.5.3 Using Compare On a Policy

Use this procedure if you want to import a policy object from the Identity Vault and the same
channel already exists in Designer. You can view the differences and decide whether to reconcile

them.
1 Right-click the policy object in the Outline view. Select Live > Compare to bring up the
Designer/eDirectory Object Compare window.

All Compare windows behave as described in Section 11.5.1, “Using Compare When
Importing a Driver Object,” on page 260.

After reconciliation, the policy object matches both locations and has been imported or
deployed through the action.

11.5.4 Matching Attributes with Designer Properties

The attributes of the object are displayed in the single list. Selecting an attribute displays its value
below the attribute list with the Designer value on the left and the eDirectory value on the right. The
name displayed in the list is the eDirectory attribute name.

The following tables map the eDirectory attribute to the Designer property page or control where
you can change or set the attribute (you can’t make changes inside the Compare window).

+ Table 11-1 on page 264 shows Driver Set eDirectory attributes

+ Table 11-2 on page 264 shows Driver eDirectory attributes

+ Table 11-3 on page 265 shows Channel eDirectory attributes

+ Table 11-4 on page 265 shows the Job eDirectory attributes

+ Table 11-5 on page 266 shows the Resource eDirectory attributes

+ Table 11-6 on page 266 shows the ID Policy eDirectory attributes

+ Table 11-7 on page 266 shows the Library eDirectory attribute
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+ Table 11-8 on page 267 shows the Notification Template eDirectory attributes

+ Table 11-9 on page 267 shows the Notification Template Collection eDirectory attributes

Table 11-1 Driver Set eDirectory Attributes

Driver Set eDirectory Attribute

Designer Property

DirXML-DriverTraceLevel

DirXML-XSLTraceLevel

DirXML-JavaEnvironmentParameters

DirXML-JavaDebugPort
DirXML-JavaTraceFile
DirXML-Trace File Encoding
DirXML-TraceSizeLimit
DirXML-LogLimit
DirXML-LogEvents
DirXML-NamedPasswords

DirXML-ConfigValues

Driver Set Properties->Trace->Driver Trace Level
Driver Set Properties->Trace->XSL Trace Level

Driver Set Properties -> Java

Driver Set Properties->Trace->Java Debug Port

Driver Set Properties->Trace->Java Trace File

Driver Set Properties -> Trace - Trace File Encoding

Driver Set Properties->Trace->Trace File Size Limit

Driver Set Properties->Driver Set Log Level->Log Limit

Driver Set Properties->Driver Set Log Level->Log Specific Events
Driver Set Properties -> Named Passwords

Driver Set Properties->Global Configuration Values

Table 11-2 Driver eDirectory Attributes

Driver eDirectory Attribute

Designer Property or View

DirXML-InputTransform
DirXML-OutputTransform
DirXML-MappingRule
DirXML-Driver Filter
DirXML-ConfigValues
DirXML-DriverTracelLevel
DirXML-EngineControlValues
DirXML-LogEvents
DirXML-LogLimit
DirXML-ConfigManifest
DirXML-JavaModule
DirXML-NativeModule
DirXML-Driverimage

DirXML-Reciprocal AttrMap

Policy Set View->Input Transformation

Policy Set View->Output Transformation

Policy Set View->Schema Mapping

Policy Set View->Driver Filter

Driver Properties->Global Configuration Values

Driver Properties->Driver Log Level->Driver Log Level

Driver Properties -> Engine Control Values

Driver Properties->Driver Log Level->Log Specific Events
Driver Properties->Driver Log Level->Log Limit

Driver Properties->Driver Manifest

Driver Properties->Driver Configuration->Driver Module: Java
Driver Properties->Driver Configuration->Driver Module: Native
Driver Properties->iManager Icon

Driver Properties -> Reciprocal Attributes
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Driver eDirectory Attribute

Designer Property or View

DirXML-TraceLevel
DirXML-TraceFile
DirXML-TraceFileEncoding
DirXML-TraceSizeLimit
DirXML-TraceName

DirXML-DriverCacheLimit

DirXML-ShimAuthID

DirXML-ShimAuthServer

DirXML-ShimAuthPassword

DirXML-ShimConfiginfo

DirXML-DriverStartOption
DirXML-ECMAScript

DirXML-NamedPasswords

Driver Properties->Trace->Trace Level

Driver Properties->Trace->Trace File

Driver Properties -> Trace - Trace File Encoding
Driver Properties->Trace->Trace File Size Limit
Driver Properties->Trace->Trace Name

Driver Properties->Driver Configuration->Authentication->Driver
Cache Limit

Driver Properties->Driver Configuration->Authentication->User ID

Driver Properties->Driver Configuration->Authentication-
>Connection Information

Driver Properties->Driver Configuration->Authentication->Set
Password

Driver Properties->Driver Configuration->Driver Configuration-
>Driver Parameters

Driver Properties->Driver Configuration->Startup Option
Driver Properties->Driver Configuration->ECMAScript

Driver Properties -> Named Passwords

Table 11-3 Channel eDirectory Attributes

Channel eDirectory Attribute

Designer View

DirXML-EventTransformationRule
DirXML-MatchingRule
DirXML-CreateRule
DirXML-PlacementRule

DirXML-CommandTransformation

Policy Set View->Event Transformation
Policy Set View->Matching

Policy Set View->Creation

Policy Set View->Placement

Policy Set View->Command Transformation

Table 11-4 Job eDirectory Attributes

Job eDirectory Attribute

Designer View

XmlIData

DirXML-ServerList
DirXML-Scope
DirXML-EMailTemplates

DirXML-EMailServer

Job Editor, XML cannot be edited directly only
through Job Editor Ul

Job Editor
Job Editor
Job Editor

Job Editor
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Job eDirectory Attribute

Designer View

DirXML-NamedPasswords
DirXML-TraceName
DirXML-TraceFile
DirXMI-TraceSizeLimit
DirXML-TraceFileEncoding

DirXML-TracelLevel

Job Editor

Job Properties -> Trace

Job Properties -> Trace

Job Properties -> Trace

Job Properties -> Trace - Trace File Encoding

Job Properties -> Trace

Table 11-5 Resource eDirectory Attributes

Resource eDirectory Attribute

Designer View

DirXML-ContentType

DirXML-DirXMLData

DirXML-NamedPasswords

Read only, cannot be edited set at creation time of
object

Resource Editor

Resource Editor

Table 11-6 1D Policy eDirectory Attributes

ID Policy eDirectory Attribute

Designer View

DirXML-idPolMin

DirXML-idPolMax

DirXML-idPolPrefix

DirXML-idPolArea

DirXML-idPolFill

DirXML-idPolAreaEl

DirXML-idPolAccessControl

DirXML-idPolACL

ID Policy Properties -> Constraints Minimum
ID Policy Properties -> Constraints Maximum
ID Policy Properties -> Constraints Prefix

ID Policy Properties -> Constraints Exclude/Include
Text Field

ID Policy Properties -> Constratints Fill Yes/No

ID Policy Properties -> Constraints Exclude/Include
Radio Button

ID Policy Properties - Access Control enabled

ID Policy Properties - Access Control ACL

Table 11-7 Library eDirectory Attribute

Library eDirectory Attribute

Designer View

Description

Library Properties -> Description
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Table 11-8 Notification Template eDirectory Attributes

Notification Template eDirectory Attributes Designer View
notfMergeTemplateSubject Template Editor
notfMergeTemplateData Template Editor

Table 11-9 Notification Template Collection Attributes

Notification Template Collection Attributes Designer View

notfSMTPEmailHost Notification Template Collection Properties - > Host
Name

notfSMTPEmailFrom Notification Template Collection Properties - > From

notfSMTPEmailUserName Notification Template Collection Properties - > User
Name

11.6 Error Messages and Solutions

To view error messages along with their possible solutions associated with importing and deploying
files, see Section 21.5, “Deploying Identity Manager Objects,” on page 498.
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Documenting Projects

When you create a project, it’s vital to keep track of how the driver works and how it’s implemented
into a network. The Document Generator helps you quickly generate customized documentation for
your Designer projects. These documents can save you weeks or months of gathering and writing
driver specifications and their implementations. To generate a document, choose a document style
(it can be the default style that comes with Designer or one that you customize) and a Designer
project or portion of a project. The Document feature combines the information and structure of the
selected style with the project information in order to generate customized project documentation.

Designer comes with a default document style so you won’t need to create a document from scratch.
This default style contains everything that you have placed in a project through Designer. You must
first use this default style to create your own document style for the project you are working on, then
you can either use it as it is or customize it to meet your particular needs, including or excluding
information as needed. After you have edited the style to your liking, you can also use it to
document your other projects. There is an advanced editing feature that allows you to create your
own sections for adding information that you did not create in Designer.

+ Section 12.1, “Creating a Document Style,” on page 269

+ Section 12.2, “Editing a Document Style for Your Needs,” on page 271

+ Section 12.3, “Generating a Document,” on page 272

+ Section 12.4, “Using Your Style Template for Other Projects,” on page 275

+ Section 12.5, “Customizing Styles to Include or Exclude Information,” on page 278

+ Section 12.6, “Advanced Editing of a Document Style,” on page 281

12.1 Creating a Document Style

A document style allows you to define how you want your project information to look. In a matter of
minutes, you can generate a document that contains all elements that you have placed in a project
and define a document style to designate how the information looks, as well as what information
you want in a document.

1 Select a project in the Project view, then right-click the Toolbox > DocumentGenerator > Styles
icon.

2 Select New > Document Generation Style (.docgen).
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=% Project £2 . g= Outline = = 8|kl *Blanstoni - De

Modeler I

1= Blanston
== Blanstonl
‘il System Model
== Documents
= Gererated
== Toolbox
== DocurnentGenerator

4 &7 Identity Manager Project. .

Irnport 4B Cocument
[ Export Project

Copy

@ Refresh

The Document Generation Style (.docgen) is the default style that is provided with Designer.
You use this as the template for your own .docgen style.

3 Specify a name for the Designer project, or use the default of the project’s name. Then specify
a name for the style, with a .docgen extension, or use the default name of the project you are
presently in, then click Finish.

@ New Document Generation Style

Select a Project for Your New Style

Your new style {docgen) is placed in the selected project.

Designer Project:

Style Name: Blanstonl.docgen

@ < Back [ ekt > ] [ Einish l ’ Cancel ]

A .docgen file is created that you can use as the basis for designing your own style template.
The .docgen template is placed in the Style Editor view for your modification (see

Section 12.2, “Editing a Document Style for Your Needs,” on page 271). You can use the
defined elements in your new style template again and again.

4 Use this basic document style template to generate documentation for a project, or customize it
for your needs.

+ Section 12.3, “Generating a Document,” on page 272

*

Section 12.2, “Editing a Document Style for Your Needs,” on page 271
Section 12.4, “Using Your Style Template for Other Projects,” on page 275

*

*

Section 12.5, “Customizing Styles to Include or Exclude Information,” on page 278

*

Section 12.6, “Advanced Editing of a Document Style,” on page 281
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12.2 Editing a Document Style for Your Needs

Now that you have created a .docgen style template, you can edit the file to meet your
documentation needs. The .docgen file appears under the Toolbox > DocumentGenerator > Styles
directory in the Project view. Double-click the .docgen file to bring up the template in the Style
Editor.

You can add or modify information in the style template, which in turn affects the documents that
you generate. The information that you can customize through the Style Editor appears in the Style
Editor view. For more detailed editing, see Section 12.6, “Advanced Editing of a Document Style,”
on page 281.

+ Section 12.2.1, “Editing a Style Template,” on page 271
+ Section 12.2.2, “Editing Sections of a Style,” on page 272

12.2.1 Editing a Style Template

1 Select a project in the Project view, then expand the Toolbox > DocumentGenerator > Styles
icon.

2 Double-click the .docgen file. The file appears in the Style Editor view.

Tl *Blanstan - Developer [E Blanstonl.docgen o3 =B
Style Editor B Identity Manager System
= Identity Manager Sys
[E (Title Paged
[E] Table of Contents
=-[E] 1. Docurment
=-[E 1.1. Legal
B Disclairmer
B Trademarks _—
[E 1.2 Document History Document Properties | Client Properties | Header | Font Settings | Other
=-[E 2. Project Information
[El 2.1. Executive Summary Solution name:
=[] 2.2. Systerm Overview
[E z.2.1. Hierarchical View

tem

Title: |Identity Manager System

Identity Manager System Solution

[E] 2.2.2. Cantact Infarmation Short solution narne:
[E] 3. Project Configuration oM
=-[E 4. sppendix
=-[E 4.1, sppendix &: Policies Prepared by:

[E] 4.1.1. Policy Containers

[E] 4.1.2. Policy Detail
=[] 4.2. Appendix B: Schema Document dats:

B 4.2.1. Schema Overview

[E] 4.2.2. Schema Detail

[Prepared by]

Document type:

SO ke

3 Use the Style editor to edit sections of a style or to modify the style according to your needs.
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The Style editor is divided into two parts, beginning with the Identity Manager and working
through the Appendixes. When you click an item under the Style Editor section, the right
portion of the view changes to display the information associated with the heading. For
example, clicking Disclaimer under the Document > Legal heading allows you to edit the
disclaimer content.

4 Save your changes. Your changes are saved when you close the Style Editor, or when you click
the Save icon lzl.

12.2.2 Editing Sections of a Style

1 Select an item (for example, Executive Summary) in the Style Editor view.
2 Enter data or make changes in the left pane.

3 Select other items as appropriate and make changes. The information in the left pane varies,
depending on items that you select.

The main areas that you need to pay attention to are the information found under Identity
Manager System (Title Page and Table of Contents), Document, Legal, Disclaimer,
Trademarks, and Executive Summary.

4 Save your changes. Your changes are saved when you close the Style Editor, or when you click
Save [E.

5 Use this document style to generate documentation for a project, or continue to customize it for
specific documentation needs.

+ Section 12.3, “Generating a Document,” on page 272

+ Section 12.4, “Using Your Style Template for Other Projects,” on page 275

+ Section 12.5, *“Customizing Styles to Include or Exclude Information,” on page 278
+ Section 12.6, “Advanced Editing of a Document Style,” on page 281

12.3 Generating a Document

1 (Conditional) If you haven’t yet created a Designer Project, create one.
la Select File > New > Identity Manager Project.
1b Provide a project name, then click Finish.

2 (Conditional) If you haven’t yet created a document style that you want to use as a template for
your documentation, create one. See “Creating a Document Style” on page 269 and “Editing a
Document Style for Your Needs” on page 271.

3 Inthe Project view, select and expand a project, then right-click the .docgen icon under
Toolbox > DocumentGenerator > Styles and select Generate Documentation for This Style.
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= Froject 52 o= Outline =

1= Blanston
=-1=F Blanstonl
Tl Systern Model
== Documents
= Generated
== Toolbox
=2 DocurnentSener ator
=2 Styles
Blanstonl.docgen
B New 3
[

Irport »
& Export Project

Copy
&9 Refresh

Open With *
Rename

¥ Delete

Eﬁ" Generate Documentation for Th

You can also expand the Toolbox > DocumentGenerator > Styles folder and click the .docgen
file to open the file in the Style Editor, then click the Document Generation icon @ to the right

of the Style Editor heading.

4 (Conditional) If the Project folder you selected does not contain a .docgen file, you are asked

to select a Base Style. Select a .docgen style, then click Next.

& Generate Documentation

Select a Base Style

Define your docurment's formatting by selecting a style to serve as
your model,

Styles: =The style is older than the currently supported version,

(= styles
Default_Style.dacgen
[z Provigioning Style
Tl Blanston
21| Blanstonl
Blanstonl.docgen
Blanstonl_a.docgen
T] Blanston2

@ [ Mext = l I Finish ] I Cancel

l

5 (Conditional) Designer includes the ability to generate documents to RTF (Rich Text Format).
If you want to enable this functionality, click Window > Preferences to bring up the Preferences

window. Then, under Novell > Identity Manager, select Document Generation.
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@ Preferences

|type filter ket |

General
Help
= Movel
Designer
[=- Identity Manager
Configuration

Entitlements
iManager
Import/Deploy
Maodeler
Policy Builder
Firmulation
Provisioning
Web and XML

Document Generation

General

Automatically open the rendered file after document generation
Show warning dialog box when the style is an older version

‘Warn me before overwriting existing file during document genaration.
[CEnable RTF suppart (experimental)

] Gutput XML source files

Modeler

Document applications and drivers related ko other selected items

Docurnent Appearance
Select the language you want the document ko generate in:

| English v

Select the Font to use for documentation:

| rial

’ Restore Defaulks ] ’

Apply

]

[ o

l [ Cancel

l

By selecting Enable RTF support (experimental), you can select the RTF format when creating

documents.

Generate Documentation

Select the settings For documentation.

Designer Project: Project1 I

| C:\Documents and Settings\LukePenrod\Designer | workspacelF |

PDF {Printable Document Format)

Filename: | Projecti.rf
Directory:

Format:

.’-:7‘. TiT (Text Docurnent

OK l [ Cancel ]

6 On the Generate Documentation page, fill in the needed information.
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-

Generate Documentation

Select the settings For documentation,

Designer Project: Projectl hi

Filenarne: Project1,rtf

Directory: C:\Documents and Settings'LukePenrad|Designerwarkspace|F
Format; RTF (Rich Text Format) v

@ [ oK ] [ Cancel ]

+ Select the name you want to call the file, or keep the default name. If you are generating
the whole document, the default name often suffices. If you are generating a document for
a section, such as an Executive Summary, name the file to reflect the section you are
documenting.

+ Select the directory where you want to store the document. If you use the default output
location that appears in the Directory field, your generated document is visible under the
Documents\Generated folder of the Project View.

+ Select the format for the file. If you have enabled rich text formatting, you can select PDF
(Printable Document Format), TXT (Text Document), or RTF (Rich Text Format).

7 Click Finish to generate the document. The document appears in the current Project >
Documents > Generated folder unless otherwise specified.

PDF files must be viewed through a PDF viewer, such as Adobe Acrobat*. If Adobe Acrobat is
installed on your workstation, Designer launches the document in Acrobat. RTF files can be
viewed in any word processor that can handle Rich Text Formatted files, such as Wordpad in
Windows.

The Filter editor provides an option to add notes to class and attributes, and these notes are
added to the documentation. Password synchronization on drivers is also documented, showing
how the administrator has set up password synchronization for the Publisher and Subscriber
channels. You can also document contact information on the administrator for Identity Vault
and application objects, as well as reciprocal mapping information.

12.4 Using Your Style Template for Other
Projects

To generate documentation for any project, you can use the default style provided with Designer or
you can use your own customized styles.

+ Section 12.4.1, “Document a Section of the Style,” on page 275
+ Section 12.4.2, “Document Multiple Sections of the Style,” on page 278
12.4.1 Document a Section of the Style

Instead of generating a document for the entire project, you can generate a document for a selected
section of a project.

1 With the project’s .docgen file open in the Style Editor pane, right-click a section of the style.
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2 Select Generate Documentation for This Section.

1| Blanstonl - Developer Blanstonl.docgen &3 ¢ Blanston3 - Developer =

Style Editor B @ | Trademarks
= Identity Manager System
+-[E] (Title Page)
+-[E] Tahle of Contents [Mlinclude this section in the final document
=-[E] 1. Document
=-[E 1.1. Legal
+-[E] Disclairmer
+-[E] Trademarks
SBE 1 > Document History |

Title: |Trademarks

New Child 4
&2 Undo Set cirkz phovell and Metware are registered trademarks of a
. in the United States and other countries, </
of Cut ovell Metwark Symbal is 3 trademark of Movell, Inc. </p=
=] Copy third-party trademarks are property of their respective
=
¥ Delete right © 2000, Inc. All rights reserved, Mo part of this
validate n may be reproduced, photocopied, stored on a refrieval

r transmitted without the express writken consent of
nsulting, <=

Load Resource...

Refresh
Show Properties View

B Generate Documentation for This

3 In the Generate Documentation window, type a different project name in the Filename field
(for example, DocHistoryofMerger), then click OK.

Specify which portion or portions of the project you want to include in the generated document.

You can document domains, Identity Vaults, driver sets, drivers, and applications using the Modeler
view or the Outline view (use the Ctrl key to select multiple items). Document generation also ties in

with schema notes, classes and attributes. You can find out more about this in Chapter 6, “Managing

the Schema,” on page 137.

For example:

1 To document a specific driver in a project, right-click the driver in the Modeler or Outline view

and select Document Selection.
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=i I0M Driver Set
= 9] re Dir

# Shaw Dataflow Yiew

& Sirmulate. .,
(3 Show Policy Sefs

¥£] Run Canfiguration Wizard...
%y Password Synchronization. ..
& Manage Application Schema...

B§: Document S Lo
&4 Export to Configuration File. .,

Live
¥ Delete

Properties

2 Select the .docgen style sheet for the document and click Next.

3 Give the document a filename, such as the driver’s name, select the document’s format, and
click Finish to generate the driver document.

By default, documenting an application includes the connected driver (and its related objects).
Likewise, documenting a specific driver includes its connected application. However, you can
change this behavior in the Documentation Generation’s Preferences page.

1 Click Window > Preferences to bring up the Preferences window.

2 Under Designer for IDM, select Document Generation.

|type filker kext |

General
Help
(=) Movwell
Designer
(=) Identity Manager
Configuration
Diocument I:Er::rneratin:nné
Entitlements
iManager
Import/Deplay
Modeler
Policy Builder
Simulation
Pravisioning
web and $ML

Document Generation L=

General

Automatically open the rendered file after document generation
Show warning dialog box when the style is an older version

Warn me before overwriting existing file during document genaration.
[]Enable RTF support (experimentali

[ output #ML source files

Modeler

Document applications and drivers related to other selected items

Docurnent Appearance
Select the language you want the document ko generate in:

| English “

Select the Font to use for documentation:

| arial v |

[ Restore Defaults ] [ Apply

]

[ Ok ] [ Cancel

]
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Under the Modeler heading, the Document applications and drivers related to other selected
items option is selected by default, which means that directly related items are included in the
documentation. For example, by default, documenting a driver set includes the direct children
(the applications) as well as some information of the direct parents (the Identity Vault and
domain) to give context to the driver set. Deselecting this option excludes direct children of the
selected item.

3 Select or deselect the options you want, then click OK.

12.4.2 Document Multiple Sections of the Style

If necessary, you can generate only selected sections so that peers can help you with information in
the selected sections.

1 If you have not already done so, double-click the .docgen file to bring up the template in the
Style Editor.

2 Select or deselect section headings. Each section and child section has a check box entitled
Include this section in the final document. By default the box is checked, as shown below.

- Project Configuration

[inciude this section in the final docurment

Title: | Project Configuration

To limit the sections you want to document, deselect the check boxes in the sections you don’t
want to generate.

3 Click the Generate Document icon B to the right of the Style Editor heading and generate
your document.

Give the document a unique name to reflect the type of information it includes.

12.5 Customizing Styles to Include or Exclude
Information

Novell does not recommend that you document all Identity Vault schemas unless you need to.

+ Section 12.5.1, “Identity Vault Schema and Application Schema,” on page 278
+ Section 12.5.2, “Using Project Configuration to Limit Information,” on page 279

12.5.1 Identity Vault Schema and Application Schema

The defaults for Identity Vault schema have been changed to include custom schemas and any
modified changes to the Identity Vault base schema. For application schema, Designer includes all
schemas by default. However, these can be turned off.

Select the Appendix B: Schema heading the in the Style Editor view. This brings up the Appendix B
section template in the right side of the Style Editor view.
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Figure 12-1 The Appendix B: Schema Section Template

Appendix B: Schema

Minciude this section in the final document

Title: |appendix B: Schema

Identity Yault schema to be documented:

Document custom or imported schema

Application scherma to be documented:

Docutnent all schema elerments

The Appendix B: Schema section has three selections:

+ Include this section. The Include this section in the final documentation check box allows you
to include or not include Appendix B information in the documentation. By default, the box is
selected to include this information. Deselect the check box if you do not want to include

application or Identity Vault schemas in the document.

+ Document Custom and Imported Identity Vault Schema. By default, the Identity Vault
Schema to be documented selected documents any schema that you import from the Identity
Vault or that you create. The choices are Document custom or imported schema, or None.

+ Document all Application Schema. By default, the Application schema to be documented
selection includes all of the application schema. The choices are Document all schema
elements, or None.

12.5.2 Using Project Configuration to Limit Information

The Project Configuration heading allows you to include or deselect information on:

+ Identity Vault

+ Driver Sets
+ Drivers
+ General

The following table shows what type of information can be included or excluded in these areas.

Table 12-1 Project Configuration

Identity Vault

Information to Select or Deselect

Selected Include host information

Selected Include username information

Selected Include deployment context information
Selected Include driver set names
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Identity Vault Information to Select or Deselect

Selected Include policy library on Identity Vaults

Deselected Include e-mail notification templates

Deselected Include XML source while documenting policies under the policy library
Deselected Include XML source while documenting credential provisioning objects under

the policy library

Deselected Include XML source while documenting mapping table objects under the policy
library

Driver Set Information to select or deselect

Selected Include server information associated with the driver set

Selected Include driver set Global Configuration Value (GCV)

Selected Include the policy library on driver sets

Selected Include job objects on driver sets

Deselected Include the XML source for policies under the policy library

Deselected Include the XML source for credential provisioning objects under the policy
library

Deselected Include the XML source for mapping table objects under the policy library

Deselected Include the XML source for job objects

Driver Information to select or deselect

Selected Include the driver filter policy

Selected Include policy set

Selected Include server-specific information for this driver

Selected Include Remote Loader configuration

Selected Include entitlements

Selected Include credential provisioning

Selected Include mapping table

Selected Include ECMA script resource object

Selected Include job objects

Deselected Include the XML source when documenting entitlement objects

Deselected Include the XML source when documenting credential provisioning objects

Deselected Include the XML source when documenting mapping table objects

Deselected Include the XML source when documenting job objects

General Information to select or deselect

Deselected Include passwords

Selected Page break after this section
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WARNING: Credential provisioning for the XML source might contain passwords that will be
displayed in clear text. If this option is selected, passwords are displayed in clear text and
documentation includes all passwords in the project.

Designer can only display passwords if they have been set in the Designer. If you import a project
from the Identity Vault, Designer cannot show the passwords in the documentation.

12.6 Advanced Editing of a Document Style

In addition to selecting and deselecting the content of a document style, you can also change the
layout and usability of your document style. You do this by editing the attributes that are associated
with certain sections. You can also create additional sections for your documents as you see fit.

¢ Section 12.6.1, “What’s In the Advanced Editing Mode,” on page 281

+ Section 12.6.2, “A Walk-through Tutorial,” on page 288

+ Section 12.6.3, “Selecting a Language for Generated Documents,” on page 294

+ Section 12.6.4, “Double-Byte Font Support,” on page 295

12.6.1 What’s In the Advanced Editing Mode

-+l

The Advanced Editing icon | | lets you toggle between simple editing and advanced editing modes.
By using the advanced editing mode, you can define information and a structure that is different
from the default template already attached to a predefined style. In this example, the Title Page
template is shown in its XSL format, which you must maintain.
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Figure 12-2 Viewing a Predefined Template

Style Editor
@ CLIENT _MUMBER

@ DOCUMENT _DATE

@ DOCUMENT_TYPE

< SOW_NUMBER

@ PRGE_NUMBERING_FORMAT
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@ FONT_SIZE_1
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<
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<
@
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3

FONT_SIZE_2
FOMT_SIZE_3
FOMT_SIZE_4
FOMT_SIZE_S
Comment
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DEBLIG_PARAMS
[E] (Title Page)
[E] Tsble of contents
B 1. Document
% @ BreakafterSection
# [E 1.1, Legal
+ [B] 1.2, Document History
=[] 2. Solution
% % BreakAfterSection
@ [E] 2.1. Executive Summary
# [E] 2.2, System Overview
= [B 3. configuration
# (8] 3.1, Overview
% [8 2.2, System Configuration
# [B] 3.3 Remote Loader Configuration
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[l Templats
® % Content
= [B 4.2, Policy Detail
= [E 5. appendix B: Schema
% % Comment
#- ¢ doclvSchema

-8B -80-80 88

| @ | section Template
~ <?xml version="1.0"7>
<x=2l:scyleshesr wersion="1.0" xmlns:docgen="hctctp://cor

<fnslistyleshesn>

<#sl:import href="dgSection.xsl"/>

<wzl:param name="Contenc"/>
<x=l:param name="szhowSectionNuwrbering™/>

name="3ection. Body"” xmlns:des="http
k break-atter="page">

l:pall-template name=FFormat.oucputTexti
iwith=param neme="value" select="${Coni
</xslicall-templates
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itable>

<fo:table-column colunn-width="6&1i1
n colwm-widch=".7;

<foitable-co
<fortable-body
<¥slrapply-tewplates mode="loca.
</fo:table-hodys
</fo:table>
<fu=liif>

<ffo:blocks
<fxal:cemplate:>

<xsl:

cemplate mode="local” match="domain|domainlte

all-template name=MFormat.ContextRow'>
name="text"” select="{name"/:
name="level™ select="count (i
name="href” selecc="fguid”/:
:vith-param name=""show-page-ref®><xsl:i:
iwith=parom neme="ipage"” =zelect="'auto''
<fxsl:call-templates>

ith=param
twith-param
Liwith-parsm

“xslrapply-templaces mwode="local®/ >

</xsl:tempplace>

< » - b »

Table 12-2 Style Editor Legend

Icon Name Description

E Green Page A green page means it's a titled section. The title appears
when you generate the document.

B Grey Page A grey page means it's not a titled selection. These pages
are also in parentheses; for example, (Title Page).

= White Page A white page means this section is disabled and is not
included when you generate the document.

[l Template A yellow template page gives specific format and styles that
are included when you generate a document.

* Global Attribute A global (red) attribute means it is passed down to every
section below it (all children sections).

@ Local Attribute A local (green) attribute means it is only used by the section
in which it appears.

¢ Grey Attribute A grey attribute is used for comments.

282 Designer 3.5 for Identity Manager 3.6 Administration Guide



Icon

Name Description

Control Icon A Control type defines the functionality that you can give to
Attributes. Each Control type has a different functionality.

Advanced editing mode allows you to add the following:

*

*

“Sections” on page 283

“Viewing or Editing Properties of a Section” on page 285
“Templates” on page 286

“Attributes” on page 286

“Controls and Parameters” on page 287

You can have multiple sections in a document, but only one template per section. The template
defines the section’s layout; however, you can use the default template for newly created sections.
You can also have multiple attributes defining how the section looks, as well as multiple controls.
You use parameters (such as names and values) to specify options for a Control type. A Parameter is
a general name for a child item of a Control. The name of the Control denotes the type of control and
what you can perform by using that type.

Sections

Sections are blocks of the documentation composed of attributes, parameters, templates, and
controls through XSL programming. Section content includes a Title, Body, and children or
subordinate information. The following example shows the Section Properties page of the Identity
Manager System as seen through the simple edit mode.
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Figure 12-3 Section Properties Page

¢l *Blanstonl - Developer Blanstonl.docgen 53 =8
q . [ "
Style Editor B Identity Manager System
= Identity Manager System

E (Title Page)
[E] Table of Contents
=-[E] 1. Document
=-E 1.1, Legal
[E] Disclaimer

E] Trademarks —
[l 1.2. Document Histary Document Properties | Client Properties | Header | Font Settings | Other

Title: [dentity Manager System

=-[E 2. Project Information
[E] 2.1. Executive Summary Solution name:

=-[E 2.2 System Overview

Identity Manager System Solution
[E] 2.2.1. Hierarchical Yiew ki 9T Sy

[E 2.2.2. Contact Information Short solution name:
[El 3. Project Configuration M
=-[E] 4, sppendix
=-[E] 4.1, sppendix &: Policies Prepared by:

[E] 4.1.1. Policy Containers

[E] 4.1.2. Policy Detail
=[5 4.2, sppendix B; Schema Document date:

[E] 4.2.1. Schema Overview

[ 4.2.2. Schema Detail

[Prepared by]

Docurnent type:

SOW number:

The ldentity Manager System section contains a section title (this can be changed), along with a
number of tabs (attributes): Document Properties, Client Properties, Header, Font Settings, and
Other. Each of these tabs contain fields that are editable; for instance, you can give the section title a
different name. When you click the Advanced Editing icon, you see that the Identity Manager
System section contains one template that includes several attributes, controls, and parameters
underneath the heading.
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Figure 12-4 Advanced Editing Mode

H =
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Viewing or Editing Properties of a Section

If you click a section within the Style Editor and look in the Properties view (by default the lower
left corner of Designer), you see the values associated with the selection. (If you do not see the
Properties view by default, right-click a section and select Show Properties View.)

Figure 12-5 The Properties View of the Appendix B: Schema

5 :{__:D - =09 +-|E] 1.1, Legal _
+-[E] 1.2. Document History
Property J =-[E] 2. Project Information
Enabled ™ true +- % BreakafierSection
D '%Schemaﬁppendix +-[E] 2.1, Executive Summary
Mis ID = #-[E] 2.2. System Owerview
Nurmbered "f true +-[E] 3. Project Configuration
Source = =-[E] 4. sppendix
Title = Appendix B: Schema +-[E] 4.1. appendix 4: Policies
Titled "f frue +-[E] 4.2. ppendix B: Schema
Yersion =
<

These values are edited in the Properties view. The Values for the section heading are listed in the
following table:

Table 12-3 Values of a Section

Property Name Description

Enabled (True/False) Indicates whether this section is enabled. You can change this
setting by using the section Style Editor, which is the editor shown to the right of
the hierarchical view.

ID Used for reference. Most the time, ID is left empty. However, you can specify an
ID for convenience in finding this section during the transformation process.
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Property Name

Description

NLS ID

Numbered

Source

Title

Titled

Version

Used for reference. Most the time, NLS ID is left empty.

(True/False) Indicates whether this section should be included in the numbering
and placed in the Table of Contents.

Data source used to transform the template. For example, designer, style, and

none.

The value to be displayed as the title. You can change this setting by using the
section Style editor, which is the editor shown to the right of the hierarchical view.

(True/False) Indicates whether the title value should be shown in the generated
document. Otherwise, it is used only in the GUI for context.

The version of the section.

NOTE: Values change, depending on what you select under the Style Editor view. For example, an
attribute shows different properties than a section or a template.

Templates

A template is the XML source that defines the overall layout of a generated page. For instance, the
Title Page contains a template, as well as a number of headings. The following figure illustrates the
parts of the Executive Summary template. For more information about templates, see “A Walk-

through Tutorial” on page 288.

Figure 12-6 Parts of the Executive Summary Template

-

Section Content <

.

Section Main 4

-

Attributes

2.1 Executive Summary

This company operates a Meta
Directory and other various
information systems where
identity information related to
employess and user accounts
are stored and maintained

The administrator of portal
users is seamlessly integrated
in the existing user
adminlsiration process.

2.1.1 Account Details

Some of the accounts include

Information on the s

} Section Title
=

> Section Body

>

} Section Children

Attributes are the child elements of a section. For example, clicking the Advanced Editor mode
while selecting the section title Identity Manager System reveals the following attributes in red
(global), green (local), and grey (comment):
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Figure 12-7 Attributes
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Controls and Parameters

You can add parameters to control the appearance of a style. For example, in the Advanced Editing
mode, the structure of the Short (abbreviated) Solution Name entry is a global attribute that contains
a control and a label, and the control type known as textbox allows anyone to type a name that

appears in the generated document. Use the Properties view to edit controls.

Designer’s supported parameters or values for controls include the following:

Table 12-4 Supported Parameters

Control Parameter or Value Description

Table columns="3" Number of columns to show in the control.
header="date” Column header text.
width="30" Column width for each column.
label="show this” Explains what you see in this control.
addrows Displays a button to perform this function.
removerows Displays a button to perform this function.

File extensions=".jpg;*.gif" Supported extensions separated by a semicolon

label="show this”

(*.Jpg;*.Jpeg;*.gif). (One file only.)
The label explains what you can do with this

control.
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Control Parameter or Value Description

Select (Identity option="font 1” Parameters allow font point selection, such as

Manager System/ option="font 2" option = “20pt” and option = “24pt”

font Settings) label="show this” The label indicates what you can do with this
control.

Checkbox label="show this” The label explains what you can do with this

control. It includes a check box.

Textbox or label="show this” The label explains what you can do with the text
Textarea box or text area control. You edit these controls
through the Properties view.

Comment label="show this” Allows you to add comments to help users. You
edit this control through the Properties view.

12.6.2 A Walk-through Tutorial

Now that you better understand what components are necessary in order to add advanced
functionality to your template, use this section to create a new section, add an attribute, and view the
source.

+ “Creating a New Section in a Style” on page 288

+ “Adding an Attribute to a Style” on page 288

+ “Enabling Documents to Recognize Your Additions” on page 289

+ “Viewing the Source” on page 294

Creating a New Section in a Style
To insert an additional section into the Style Editor:

1 Create or open an existing .docgen file in the Style Editor.
2 Click the Enable Advanced Editing icon. 3

The tree view of the document outline expands to include additional objects, (such as attributes,
template, and parameters).

3 Right-click the parent section where you want to add your new section, then select New Child
> Section. Specify a new section name; for this example, call it “My Section.”

4 (Optional) Reorder the section by dragging the section object to a different location in the
navigation tree. You can also copy and paste within this style or other styles.

5 Click the Save icon, then continue with “Adding an Attribute to a Style” on page 288.

Adding an Attribute to a Style

1 Right-click a section under the Style Editor view. Select New Child > Attribute.

2 Specify the attribute name in the Attribute Name window. For example, MyAttribute with no
spaces. Click OK.
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3 Specify a value under the Value property in the Properties view. For example, This is my
attribute value.

Policy Set | & Properties &2 B = o8 L1 Legal .
=[] 1.2, Document History
Property Value =-[E] 1.2, My Section
Global ik false Ay At ibute
Group .i _ =-[E 2. Project Infarmation
Marme iMYAW'hUte - ¢ BreakafterSection
Mis ID - = 2.1. Executive Summary
Yalue ‘= Thig is my attribute value +-[E 2.2. Svstern Overview
+-[E] 3. Praject Configuration

The Properties view shows the following values for attributes (attributes are defined through
controls and parameters):

+ Global: passed down to subsections.

+ Group: used to group attributes together. These appear as part of a tab in Style Editor’s simple
mode.

+ Name: The attribute’s name.
+ NLS ID: The attribute’s NLS identification.
+ Value: The attribute’s value.

You can also show your attribute with another control type. The following example first creates a

control, then changes the control type from check box (the default) to something else, such as a text
area.

1 Right-click MyAttribute and select New Child > Control.

2 With your cursor on the control you just created, change the control type value to Text Area in
the Properties view.

3 Click your section to see the changes take place.

Policy Set ' b S k"= v = H #-|5| 1.1. Legal

—+T

+-[E] 1.2, Document History
=-[E 1.3, My Section

5. ¢ Myatribute

=} Control {texthox)
=-[E] 2. Project Information

4 % BreakafterSection
+-[E 2.1, Executive Surrmary
+-[E] 2.2, System Overview

Proper ty Yalue
Type :

Check Box
Select

Camment
Table hd

Enabling Documents to Recognize Your Additions

After you have added attributes, your generated document doesn’t include information from these
attributes until you do one of the following:

+ Make sure your section is a leaf section (does not contain child sections).

+ Create a template that uses the attribute explicitly. This is usually the preferred method because
you can display the attribute values exactly the way you want.
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Method 1: Set the Section Source to “Style”

If you create a section without a template (and the template is a leaf section containing no section
children), the default template generates the attribute values with the document. You do not need to
do anything. You can generate a document for just that section by right-clicking the section head and
selecting Generate Documentation for This Section. Or you can click the Generate Document icon
at the top to generate the whole document.

NOTE: Text boxes, text areas, and tables are the only attributes that are generated through the
default template (check boxes, selects, and comments are not generated).

Method 2: Add a Template for a Custom Layout
Complete the following tasks:

+ “Creating a Template” on page 290

+ “Creating Another Section and Template” on page 292
Creating a Template

1 Right-click your newly created section.
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2 Select New Child > Template.

Section Template
| <?xml version="1.0" encoding="UTF-8"2><xsl:stylesheer werzion="1.0" sxmins:fo="htop:i// 1A
<ksl:import href="dgiection.xsl"/>

<x&l:pacam name="DOCUMENT DATE"/>
<x=liparam name="SOLUTION NAME™/:
<usl:param name="SHORT SOLUTION NAME"/>
<xzl:iparam name="DOCUNENT TYPE"/>

: ipacam neme="CLIENT NANE"/>
L param nane="SHORT_CLIENT‘NAHE"fb
aram name="CLIENT NUHBER"/>
¥sliparam name="PREPARED EY"/>
<Xsl:param Dame= "SQW_NUHBER"." >

:param name="customlmage’/ >
l:param name="imageWideh"/>

ksl:template name="Zection.Contenc">
<fo:block>
<x%3l:1f test="§30LUTION NAME '= '' or $SHORT SOLUTION NAME !'= ''":
<fo:block space-after="{JFONT_SIZE_4)">
Solution: <x=livalue-of select="§SOLUTION MAME"/>
<k=l:if test="{SHORT_SOLUTICN NAME != ''®:
[<xal:value-ol selecc="§SHORT_SOLUTION_ NAME™/>)
</ e T e
</fo:b 4
<fxsl:if>

<x8l:if ceste"§PREFARED BY i= '!Ms
<fotblock space-after="{iFONT_SIZE 4)">
Prepared hy: <x=l:value-of stlccb‘"SPREPARED_BY".":
</ fosblock>
</xsl:ifs
<xzl:if test="$CLIEN‘I‘_NJ.HE I= ' pr $SHOR‘I‘_‘CL IENT_NJ\HE b= 1y,
<fothlock space-atter="{3FONT SIZE 4)">
For Client: <xsl:value-of select="{CLIENT NAME"/>

«x21:1f tesc="§5HORT CLIENT NANE |= *‘''>
[<xsl:value=-of selccl:""$SHORT_CLIEI‘TT_N!.HE"/Di
fusl:if>

</fo:rblocks

<fxsliif>
<xsl:if test="$§CLIENT NUHBER != ''">

<fo:block space-after="{ $FONT_SIZE_4} i

Client number: <xsl:value-of aselect="3CLIENT NUMBER"/>

</fo:block:>
</xsl:if>
1:if vest="§DOCUMENT _DATE != 'i"
<fo:hlock space-attec="{jFONT_SIZE 4:">

Document Date: <xsl:value=of select-"$DOCUHENT‘_DATE",’b
</fo:hlocks v

The template has some default content that consists mostly of comments, which helps you get
started on your first template. This is shown in the next task; for now, replace the comments in this
template with the following XSL commands:

<xsl:param name="MyAttribute"/>

<xsl:template name="'Section.Body"'>
MyAttribute:
<xsl:call-template name="Format.OutputTextArea'>
<xsl:with-param name="value" select="$MyAttribute"/>
</xsl:call-template>
</xsl:template>
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There is a Format.OutputTextArea call in the XSL that is a helper function included with the
Document Generator Core Support Templates. Because HTML code is allowed in text areas, this
ensures that it’s interpreted and escaped properly. If you want to see the core XSL library calls for
documentation generation, see “Document Generator Core Support Templates” on page 531.

Your template should look like this:

Figure 12-8 Example Template

<2l wersion="1.0" encoding="UTF-3"2:-
<xzl:atylesheet version="1.0" xmlns:xsl="http:/ www.wd.ocg 1
<®zliinmport href="dgfection.xs1"/>

<Hzliparam name="Myittribute”/>

<¥zl:itemplate name="Zection, Body™>
Mylittribute:
<xsl:call-template name="Format.OutputTextirea™s>
<xsl:with-param name="value" select="iNviccribuce™/>
</fH=zlipall-template:
</x=l:templates

</®xzlistylesheets

Generating a document for this section should give you something like this:

Figure 12-9 Sample Section

1. MySection

MyAttribute:
This is my attribute

Creating Another Section and Template
1 Right-click your newly created section and select New Child > Section. In the Section Name
window, name the new section Table of Contents and click OK.

2 Right-click this new section and select New Child > Template. Carefully read through the
comments in this template. These details are important.

When you create a custom section, you are inserting some information into the document. As
the comments mention, developers usually override one of the following template functions:

+ Section Body (most common)
+ Section Content
+ Section Title

The following image illustrates which section is being defined. As a developer of the style, you
write this template to overwrite the area that is of interest.
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r r
2.1 Executive Summary } Section Title
3

This company operates a Meta

Directory and other various

information systems where

identity information related to

employees and user accounts
i

Section Content 4 are stored and maintained

+ Section Body

The administrator of portal
users is seamlessly integrated
in thi existing user
adminisiration process,

L "

. 2.1.1 Account Details
Section Main < Section Children
l Some of the accounts include

Information on the-se—" T

For this example, you should overwrite the Section.Body because you don’t want to change the
default behavior of the Title, nor do you want to change the way other sections are related to
this one. (You can use the hierarchical view to control this with the default template if
necessary).

3 To overwrite the Section Body, simply uncomment the sample function that is shown in the
default template. This is shown below:

Section Template

< ?¥ml version="1.0" encoding="UTF-5"2>
<xzl:stylesheet version="1.0" wmlns:xsl="http://www.wi. org/ .
<xEl:import href="dgSection.xs1" >

o= fEE
* Tahle of Contents example (remove commenting below

Thizs template asswnes you have your section source
to 'style' (the default walue), and demohstrates b
render data taken frow an XML source.

* % o o

w -
<xsl:itemplate nsme="Iection.Body ™=
<fo:hlockrHere is my Table of Contents:</fo:block:
<xsl:apply-templates/>
</usl:templatesr

wHslitemplate match="children's
<forbhlock margin-lefoc="{count (ancestor: ) femn™> - <xslis
<¥aliapply-templates/ >

</xslitemplate>

</x=l:stylesheet>

2l |

If you render your document at this point, you get no content in your Table of Contents (other than
the surrounding text). This is because this template assumes that the style source has been specified
for this section. To specify the source:

1 Click the Table of Contents section.
2 From the Properties view, set the source to style.
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3 Right-click MySection and select Generate Documentation for This Section.

Sample

1. My Section

MyAttribute:
This is my attribute value.

1.1. Table of Contents

Here is my Table of Contents:
- My Section
- Table of Contents

Viewing the Source

When your generate your document, you’ll notice there is an Output XML Source Files option. Click
the box next to this option to turn it on. You’ll see .xm1 source files appear where you are generating
the document. These source files are the XML data that is used in your template when you set the
source (for example, to “style™). Designer 1.1 and above include the following sources:

Table 12-5 Sources

Source Key Description

none An empty source, used when no source is specified or when “none” is specified.
style The XML source of the style, used to build things like the Table of Contents.
designer A source that has been defined by an extension point for the Designer model. This

contains all information about the configuration of your Designer project.

12.6.3 Selecting a Language for Generated Documents

You can also select the language you want to print the document in.

1 Click Window > Preference > Designer for IDM > Document Generation. Under the
Document Language heading, select the language you want to use for document generation.
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@ Preferences |Z| @I gl

type filker bext Document Generation
General
Help Genetal
= Movell Aukomatically open the rendered file after document generation
Designer Shaww watning dialog box when the style is an older version

(=) Identity Manager

i - Warn me before overwriting existing file during document genaration.
Configuration

Document Generation Enable RTF support {experimental)
Entitlements [ output #ML source files
iManager
Import/Deploy Modeler

Modeler Document: applications and drivers related to other selected items

Palicy Builder
Simulation Document Appearance

Provisioning Select the language you want the document ko generate in:
Web and XML 3

[Restore Defaults ] ’ Apply ]

6] [ a8 H Cancel ]

Current languages include:

+ Chinese Simplified

¢ Chinese Traditional

+ Dutch

+ English (default)

+ French

+ German

+ ltalian

+ Japanese

+ Portuguese Brazil

+ Spanish
2 After you select a language, click Apply.
3 Click OK to close the Preference page.

12.6.4 Double-Byte Font Support

Designer now has double-byte font support for the Document Generation feature. If you select a
language that uses double-byte characters, such as Chinese Simplified, Chinese Traditional, and
Japanese, as a starting point Designer automatically installs the font Proportional Mincho. A
good font that covers both proportional spacing and double-byte support is Arial Unicode MS.

For English and other languages, the default font is Arial.
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To add a font for your specific language:

1 Click Window > Preference then expand Novell > Identity Manager and select Document
Generation. Under Document Appearance, select the font you want to use.

it\,rpe filter text |

" Sthema

- Simulation

. Trace
[#-Help
Mowell
Provisioning
Wieb and XE

-

iz}

Z Kl

] Policy Builder
- Project Checker

Lok in: | e Mew CDrive [C:)

My Recent
Documents

by Documents

My CampLiter

My Network

Document Generation
& General
B Designer for IDM iohneral
" Configuration [¥] sutomatically open the rendered file after document generation
* Document Seneration [¥]show warning dialog box when the style is an older version
Entitlerments [Flwarn me before averwriting existing file during document genaratian,
; iManager [“|Enable RTF support (experimental)
- Impart/Deploy [¥] cutput ML saurce files
Language
3] Modgele? e

[]Dacument applications and drivers related to other selected items

Document Appearance
Select the language you want the docurnent to generate in:

i English

i

Select the font to use for documentation:

! Arial

v|

vi@?‘ v [Mv

[CDELL
) Distiller 7Tnstall
| docsysx

=) downloads
[C)DRIVERS
ed
[JEPSON
() gwelisnt
() gwsetup
ChI3ss

D MDPS

|||_j nls

I:_ﬂ Movvell

(I M4 instal

[ Documents and Settings

C)o00Installl 13
|)Pragram Files
:ﬁ Temp

Suser

|5 WINDOMWS
times. ttF

File narne:

Files of type:

|times b v [ open |

|TrueT_|,lpeFont[".ttf] [ Cancel ]

v

To change the font on a Windows workstation, you must first copy the font file from the
C:\Windows\Fonts directory to another directory. You can then use the Browse button to

select the font.

To change the font on a Linux workstation, browse to the usr/share/fonts/truetype
directory, or to another directory containing the fonts you want.

Click the Browse button to bring up the Open window, change to the directory where you
placed the font, then click Open.

You can also type the directory and font file name into Font Settings field, or use the drop-
down menu to select a font that you have previously selected.

3 Click Apply, then click OK.
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Using the above steps globally changes the font in the generated document, and also adds double-
byte font support for your selections.
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Using Entitlements

Identity Manager allows you to synchronize data between connected systems. Entitlements allow
you to set up criteria for a person or group that, once met, initiate an event to grant or revoke access
to business resources within the connected system.

You can think of an entitlement as a permission slip. For example, if you want a new employee to be
given an Active Directory account when he is added to your Human Resource system, he must have
a permission slip, or entitlement, for the Active Directory account. If the user doesn’t have the
permission slip, he doesn’t receive the account. This gives you one more level of control and
automation for granting and revoking resources.

Use Designer to create entitlements and deploy them into existing Identity Manager drivers.
Designer allows you to create entitlements through the Entitlement Wizard, which gives you a
graphical interface where you can create the entitlement step by step. Because of this graphical
interface, we recommend using Designer for creating and editing entitlements.

There are four aspects to making entitlements work effectively: design, creation, editing, and
management.

+ Section 13.1, “How Entitlements Work,” on page 299

+ Section 13.2, “Designing Entitlements,” on page 301

+ Section 13.3, “Creating Entitlements through the Entitlement Wizard,” on page 304
¢ Section 13.4, “Editing and Viewing Entitlements,” on page 316

¢ Section 13.5, “Managing Entitlements,” on page 321

+ Section 13.6, “Creating Entitlement Policies,” on page 321

13.1 How Entitlements Work

The following diagram shows the basic entitlement process.
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Figure 13-1 Basic Overview of Entitlements

Entitlement Metadirectory Active Directory Active
Agent Server Driver Directory
_zr:\
(-] 4
Entitlementz Driver B -
. %.Fll.ter ) |_, iUser Accounts
Role Assignments L+ - DM L-E nlitlementFef
Provizioning / = User &
Warkflows L e - | Z|Entitlements
I User A User Account = o
DitXML-EntitlementRef Group Membership
Exchange Maibox
AD Uzer Account —_ .
- :i Policies

Uszer Account
Group Membership
Exchange Mailbox

1. An entitlement agent grants an entitlement to a user. There are three ways that entitlements are
granted to a user:

+ Role-Based Entitlements: The Entitlements Service driver grants the entitlement based
on criteria that places the user in a particular role (or group). This criteria can be based on
any event that occurs in the Identity Vault. For example, adding a new employee in an HR
system causes a User object to be created in the Identity Vault. Creation of the new User
object is the criterion that causes the Entitlements Service driver to grant the Active
Directory User Account entitlement to the user.

To create role-based entitlements in Designer, see Section 13.3, “Creating Entitlements
through the Entitlement Wizard,” on page 304.

+ User Application Role Based Provisioning: The user receives a role assignment through
the User Application. The User Application’s Role Service driver grants the user any
entitlements associated with the new role. For example, a user is assigned an Accountant
role that requires access to the Accounting group in Active Directory. The Role Service
driver grants the Active Directory Group Membership entitlement to the user.

To create entitlements for role based provisioning, use the Role editor. See “Specifying
Entitlements” under Using the Role Editor (http://www.novell.com/documentation/
idmrbpm361/dgpro/data/roles_roleseditor.html#roles_entitlements).

+ User Application Workflow-Based Provisioning A provisioning workflow grants the
entitlement to the user. For example, a new employee is added to the HR system, which
causes a User object to be created in the Identity Vault. Creation of the new User object
initiates a workflow that grants the Active Directory User Account entitlement to the user.

Creating entitlements to use with workflow-based provisioning is an involved process. To
get you started, see Configuring Provisioning Request Definitions (http://
www.novell.com/documentation/idmrbpm361/dgpro/data/prdefworkingchapter.html)

2. When an entitlement is added to or removed from a user’s DirXML-EntitlementRef attribute,
any entitlement-enabled drivers begin to process the event. Only drivers that have the DirXML-
EntitlementRef attribute added to their Subscriber channel filter monitor users for entitlement
changes.

3. The driver processes the entitlement event against the Subscriber channel policies. If the
entitlement event is for an entitlement that applies to the driver, the policies are processed.
Otherwise, no processing occurs. In the above diagram, the Grant User Account policy is
processed because 1) the Active Directory User Account entitlement was added to the user’s
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DirXML-EntitlementRef attribute and 2) the User Account entitlement is defined on the Active
Directory driver. Likewise, if the Active Directory User Account entitlement is later removed
from the user’s DirXML-EntitlementRef attribute, the Revoke User Account policy is
processed.

4. The policies trigger the granting or revoking of access to the entitled resource. In the above
diagram, the Grant User Account policy triggers the creation of a user account in Active
Directory.

13.2 Designing Entitlements

You must know beforehand what you want to accomplish with entitlements. Entitlements work from
the functionality you build into Identity Manager drivers through policies. These driver policies
implement rules and process the events between the Identity Vault and the connected system. If the
policies in the Identity Manager driver do not specify what you want to do, entitlements cannot
work. For example, if you don’t specify the action section of the Check User Modify for Group
Membership rule in the Command policy, attempts to grant or revoke a group membership
entitlement are ignored.

When you know what you want to accomplish with Identity Manager, you can correctly design
granting and revoking capabilities for any connected system resources. The following four-step
procedure can help you plan to create and use entitlements:

1. Know what you want to accomplish in your business situation. You can design and implement
many business solutions through ldentity Manager, but you need to know what you want to do
before implementing something that isn’t defined. Make a numbered list of what you want to
do.

2. Define an entitlement that represents one item from your numbered list. You can create
valueless and valued entitlements. Valued entitlements can get their values from an external
query, they can be administrator-defined, or they can be free form. There are examples in
Section 13.3, “Creating Entitlements through the Entitlement Wizard,” on page 304.

3. Add policies to the Identity Manager Driver to implement the designed entitlement. To create a
policy for an Identity Manager driver, you need to be conversant with XSLT or DirXML script
to define the way the connected system handles and receives information, and the way Novell
eDirectory stores information. Unless you are a good DirXML programmer, this is a job for
consultants.

4. Set up a managing agent to grant or revoke the entitlement. If you want an automated process,
use Role-Based Entitlements; if you want a manual process, use the User Application’s
workflow-based provisioning feature. See “Installation” in the Identity Manager 3.6.1
Installation Guide. As you plan your entitlements, use the following sections for more
information.

*

Section 13.2.1, “Terminology,” on page 302

*

Section 13.2.2, “Entitlement Prerequisites,” on page 302

*

Section 13.2.3, “ldentity Manager Drivers with Preconfigurations that Support Entitlements,”
on page 302

*

Section 13.2.4, “Enabling Entitlements On Identity Manager Drivers,” on page 303

Using Entitlements 301



13.2.1 Terminology

Following are some terms that are used throughout this section.

Table 13-1 Terminology

Terms Explanation

Entitlement An Identity Vault object that represents a business resource in a connected
system.

Entitlements Service Grants and revokes entitlements. For Role-Based Entitlements, the agent is

driver the Entitlements Service driver, which must be initiated for entitlements to
work.

Grant or revoke Granting or revoking an entitlement is controlled by Global Configuration

Variables (GCVs) on an Identity Manager driver.

Entitlement consumer Anything that uses entitlement-related information. Entitlement consumers
include iManager, the User Application, and Identity Manager policies.

13.2.2 Entitlement Prerequisites

QO eDirectory 8.7.3.3 or later with the latest Support Pack (SP8 or later)
Q Identity Manager 2 or 3
O An Entitlements Service driver

You must have an Entitlements Service driver in each driver set where you want to use
entitlements. This requires a very simple, two-step setup for each driver set. To do this, see
Creating Entitlements (http://www.novell.com/documentation/idm36/idm_entitlements/data/
bedroxr.html) in the Identity Manager 3.6 Entitlements Guide.

O A driver configuration that supports entitlements
Before you can use entitlements with a connected system, do one of the following:

+ Import the Identity Manager driver configuration for the driver and specify that the driver
has entitlements enabled.

+ Enable your driver to support entitlements. To do this:
1. Create entitlements using Designer.

2. Add the DirXML-EntitlementRef attribute to your driver filter as described in
Section 13.2.4, “Enabling Entitlements On Identity Manager Drivers,” on page 303.

3. Write policies to implement the entitlements you create in Step 1 under Section 13.2,
“Designing Entitlements,” on page 301.

13.2.3 Identity Manager Drivers with Preconfigurations that
Support Entitlements

The following drivers include configuration files that already contain entitlements and the policies
required to implement the entitlements. These entitlements support the most common scenarios:
granting and revoking user accounts, groups, and email distribution lists.

+ Active Directory: Grant and revoke accounts, group membership, Exchange Mailbox
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*

GroupWise: Grant and revoke accounts, grant and revoke members of distribution lists

*

LDAP: Grant and revoke user accounts

*

Linux and UNIX: Grant and revoke accounts

*

Lotus Notes: Grant and revoke user accounts and group memberships
+ RACF: Grant and revoke group accounts and group memberships

These are example entitlements and policies that you can use as is if they meet your needs. If not,
you can modify them to meet your needs, or you can use them as examples as you implement
additional entitlements.

13.2.4 Enabling Entitlements On Identity Manager Drivers

Before you can use entitlements, you must first ensure that your driver has entitlements enabled.
You can do this through the Entitlements Wizard as you finish creating entitlements; this applies to
both preconfigured and non-preconfigured drivers.

However, if you want to use the preconfigured driver’s entitlements and the infrastructure that
supports them, you must enable entitlements when you initially create a driver in Designer or
iManager; the preconfigured policies and rules that support the preconfigured entitlements cannot be
added later without re-creating the driver. If you import a driver that has entitlements enabled into
Designer from an Identity Vault, the imported driver also has entitlements enabled. If you deploy a
driver that has entitlements enabled into an Identity Vault, the deployed driver also has entitlements
enabled.

You can see if your preconfigured drivers have entitlements enabled by clicking the Outline view,
then clicking the Subscriber channel of your selected driver. If entitlements are enabled, you should
see the preconfigured entitlements appear under the Subscriber Channel. If entitlements do not
appear under the Subscriber Channel in the Outline view, entitlements were not enabled when the
driver was initially installed.

However, you can still use entitlements on preconfigured Identity Manager drivers that do not have
entitlement preconfigurations enabled. To do this, run the Entitlement Wizard. The last page in the

Entitlement Wizard asks if you want to add the DirXML-EntitlementRef attribute to the driver filter,
with Yes selected. Click OK. However, because the policies and rules are not in place on the driver,
you won’t be able to use their preconfigured entitlements without adding those supporting policies

and rules yourself.
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Figure 13-2 Enabling Entitlements

®

@ Add To Filter

? To enable entitlements for this driver, the Dir¥ML-EntitlementRef

“f/ atfribute needs 0 be added to the User class in the driver filter,
If you want to enable entitlements for another class, you can do
g0 from the filter editor,

Do you want Designer to enable entitlements for the User class in the
driver filter for you?

OMo

[Jremember selection. Don't prompt again,

[ Ok l [ Cancel

You can also use entitlements on Identity Manager drivers that do not contain entitlement
preconfigurations. To enable your driver to support entitlements, add the DirXML-EntitlementRef
attribute to your driver filter. Run the Entitlement Wizard as described above to add the DirXML-
EntitlementRef attribute to the driver filter.

13.3 Creating Entitlements through the
Entitlement Wizard

Designer comes with an Entitlement Wizard. This wizard steps you through the creation of
entitlements by asking a series of questions about how the entitlement will be used in the enterprise.
Use one of the following methods to access the Entitlement Wizard:

From the Outline View

To access the Entitlement Wizard from the Outline view, right-click a Driver object, then click New
> Entitlement.
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Figure 13-3 Adding an Entitlement through the Outline View
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From the Modeler View

To access the Entitlement Wizard from the Modeler view, right-click the driver icon, then click New

> Entitlement.

There are two types of entitlements that you can create: valueless and valued. The type you use

depends on whether you need to pass additional information to the policies.

+ Section 13.3.1, “Valueless Entitlements,” on page 305

+ Section 13.3.2, “Valued Entitlement that Queries an External Application,” on page 307

*

*

Section 13.3.3, “Administrator-Defined Entitlements with Lists,” on page 312
Section 13.3.4, “Administrator-Defined Entitlements without Lists,” on page 314

13.3.1 Valueless Entitlements

A valueless entitlement has no values to go with it. An example is the Account Entitlement for
Active Directory, which is used to turn on account capabilities. You use valueless entitlements if you

don’t need to pass any extra information to driver policies.

To create a valueless entitlement:

1 Right-click the driver icon in the Outline view or in the Modeler view, then click New >

Entitlement.
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@ New Entitlement Wizard 3]

Name Entitlement

Give the entitlerment a name and a description.

Mame: |Acc0unt

W sz name for display name

Display Mame: |

Description: | This is an Account Entitiement,

@ | Mewt = | | Cancel |

2 Type the name and description information. For this example, the entitlement is named
Account, with a description of “This is an Account Entitlement.” Click Next.

@ New Entitlement Wizard 3]

Set Entitlement Yalues

‘You can set values on an entitlerment for use by policy or other entitiement consumers,

Do you want this entitement to include values?
®Ma

(@) Choose this if your entitierment doesn't require values,

O es

(3) Choase this if you want to query values fram an application or to define a group of
valles,

[ Einish l ’ Cancel ]

3 Because this first example is valueless, select No to Do you want this entitlement to include
values?
4 Click Finish.

5 Inthe Add To Filter dialog box, answer Yes if you want the driver to listen for this entitlement.
This enables entitlements for the driver.
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@ Add To Filter )]

?/ To enable entitlements for this driver, the DirxXML-EntitiementRef

= attribute needs to be added to the User class in the driver filter,
If you want to enable entitlerments for another class, you can do
so from the filter editar,

Do you want Designer to enable entitlements for the User class in the
driver filter for you?

[Cremember selection. Dan't prompt again.

[ OK. l ’ Cancel ]

The DirXML-EntitlementRef attribute allows the driver filter to listen for entitlement activities.
This is necessary in order to use the entitlements you are creating.

If you don’t want to see the Add To Filter window on every entitlement you are creating for any
driver in Designer, select Remember Selection - Don’t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.

If you have a file conflict, you are asked to save the editor’s changes before continuing. Once
the editor is saved, the entitlement displays in the Modeler view.

13.3.2 Valued Entitlement that Queries an External Application

Values are a way of passing data that you might need to use in policies. Valued entitlements can get
their values from an external query; they can be administrator-defined, or they can be free-form.

1 Right-click the driver icon in the Outline view or in the Modeler view, then click New >
Entitlement.

2 Give the entitlement a name. This example uses Application Query, with the Use Name for
Display Name option selected. In the Description box, type Looks for the Class name of
Groupx, then click Next.
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@ New Entitlement Wizard &)

Name Entitlement =] '
Give the entitlerment a name and a description. 1 ,—‘__-_B
MName: |App|icati0n Query
W Lize name for display name
Display Marme: |
Description: | | poks for the Class name of Groupx
@ | Cancel |

3 On the Set Entitlements Values page, select Yes so you can query values from an application or
define a group of values, then click Next.

4 The next Set Entitlements Values page allows you to define where you get the values for this
entitlement. Valued entitlements can get their values from an external query, or they can be
administrator-defined. For this example, select the Values from an application query option,
then click Next.

@ New Entitlement Wizard )]
Q
Set Entitlement Values ;'
Define where to get the values for this entitiement. ,—‘__-_B

This entitlernent will have:
O administrator-defined values
(@) Chaose this if you want an entitement that defines

attributes {phone number, office location, etc.) to be set in
an application,

(@) Chaose this if you want an entitement that allows a user to
become a member of 3 group in an external application.
The groups used are queried from the application.

@ ’ < Back ” Met = l

The Define Application Query window combines two steps: defining the query and mapping
the query results.

5 To fill in the Class Query, click the Schema Browser button on the right side of the Class entry.
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" Schema Browser

X

Classes
¢ 0]
dsa ~
dynamicGroup
dynamicGroupALE
edirSchemalersion

encryptionFolicy
Extarnal Enfity
federatonBoundar:

GroupWise Agent
Groupiise istributon List
GroupWise Domain
GroupiWise External Entity
GroupWise Gateway
Groupiise Library
GroupWise Post Office
GroupWise Resource
homelnfo

hpServer
immediateSuperiorReference
LOAP Group bt

[l onty show changes

g

6 The Schema Browser shows you the Classes in the eDirectory namespace that are available. If

you know the name of the Class type you want to query, click to select a selection in the
Classes tab, then start typing the Class name. The browser jumps to the alphabetical order of

what you type. Select the Class name, then click OK.

@ New Entitlement Wizard

Define Application Query

this entitlerment.

Enter a class to query

Define an application query that will return value(s) to be used by

Class: | Graup

Enter a base DN and select a scope to search from

Base OM: | Blanston

@ < Back | Next > |

Stope: |subtre] -]

Map query results to values used by entitlement consumers
Value From Query =  ¥alue Used by Entitlement Consumers

Source Distinguishec «| = "Display-Name" shown to entitlement consumers
Description v | 5 "Description" shown to entitlement consumers
Association | 5 "“alue" used by policy

| Cancel

7 Type the base distinguished name (DN) and the scope. For this example, select the Class

Group, at the Base Distinguished Name of Blanston, with the Scope of subtree (choices are

subtree, entry, and subordinates).
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This example maps the query results from the connected system to certain values that
entitlement consumers can use. At present, the consumers are iManager managing Role-Based
Entitlement policies and the User Application managing workflow-based provisioning
entitlements. The Value From Query information pre-populates the consumer’s user interface
with the following:

+ Display Name: Defines the attribute that displays in the list of values. The example
selects Source Distinguished Name for the display name. Click the drop-down button on
the Display Name shown to entitlement consumers list to see a list of Attributes associated
with the class you selected through the Schema Browser. The list includes both the
Attributes and the Inherited Attributes for the selected class.

+ Description: Defines the attribute that displays as a description for that value. For the
description, select Description from the Value drop-down list to map the query results
from the connected system to the entitlement.

+ Value: Defines the attribute or token that is the actual value. The Value entry is not seen in
the entitlement consumer, but it is the value that is assigned when the entitlement is
granted or revoked. In this case, choose Association.

If you do not use the Schema Browser button when selecting the class, you see only two
selections in the Value From Query lists: Association and Source Distinguished Name. If these
attributes suit your needs, use them. You can also type the attribute name into the text field.
However, if you want to select the attributes from the lists, use the Schema Browser button
when selecting a class for the query. You see the attributes and inherited attributes for the
selected class.

8 When the values are filled out, select Next.

9 In the Assign Multiple Values window, select Yes if you want the entitlements to be granted
more than once and with different values. If you select No, the entitlement can only be granted
once. For this example, click Yes, then click Next.

It makes sense to assign group entitlements with multiple values, but it would not make sense
to assign an account entitlement more than once.

10 You are asked if this entitlement is intended to be used by Role-Based Entitlement policies
through iManager. If you want this entitlement to be granted or revoked automatically, select
Yes to the Role-Based Entitlements question, click Next, then continue with Step 11.

or

If you want the granting or revoking of this entitlement to be a manual process (approved by
someone), select No to use the User Application, then skip to Step 12 on page 311.

We recommend that you have only one agent control an entitlement. If multiple agents are in
control, you have the following consequences:

+ Whoever comes last controls the entitlement results
+ Results are unpredictable
+ Using both agents to control an entitlement is not supported by Novell

11 (Conditional) If you select Yes to the Role-Based Entitlements question, you are asked if you
want to use the Role-Based Entitlements priority to resolve any conflicts that might happen
when this entitlement is assigned more than once with different values. You can resolve the
conflict by either using Role-Based Entitlements priority, or by merging the values.
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Merging the values merges the entitlements of all involved Role-Based Entitlement policies, so
if one policy revokes an entitlement but another policy grants an entitlement, the entitlement is
eventually granted. Solving conflicts by priority works if you need to ensure that only one
policy is applied to this entitlement at any time. This example uses priority.

12 Click Finish.

For this example, the query values look for the Source Distinguished Name attribute of the
Class name of Group, starting from the Base DN (Blanston) and checking through the subtree
from that beginning point. The values that come back from the query are similar to the
following:

<instance class-name="Group"™ src-dn="o=Blanston,cn=groupl’>
<association>o=Blanston,cn=groupl</association>
<attr attr-name="Description”> the description for groupl</attr>
</instance>
<instance class-name="Group" src-dn="o=Blanston,cn=group2'">
<association>o0=Blanston, cn=group2</association>
<attr attr-name="Description”> the description for group2</attr>
</instance>
<instance class-name="Group" src-dn="o=Blanston,cn=group3'">
<association>o=Blanston, cn=group3</association>
<attr attr-name="Description'> the description for group3</attr>
</instance>
<l-- ->

The information received from the query fills in the various fields. For instance, the
<display-name> field receives o=Blanston,cn=groupl. The <description> field receives
the description for Groupl, and the <ent-value> field receives o=Blanston,cn=groupl.
Because more than one group exists and meets the query criteria, this information is also
collected and shown as other instances of the query.

The association format value is unique for every external system, so the format and syntax are
different for each external system queried.

13 Inthe Add To Filter window, click Yes if you want the driver to listen for this entitlement. This
enables entitlements for the driver.

@ Add To Filter )]

?‘/ To enable entitlements for this driver, the DirxXML-EntitiementRef

~ attribute needs to be added to the User class in the driver filter,
If you want to enable entitlements for another class, you can do
so from the filter editar,

Do you want Designer to enable entitlements for the User class in the
driver filter for you?

Cha

[Cremember selection. Dan't prompt again.

[ Ok l ’ Cancel ]

The DirXML-EntitlementRef attribute allows the driver filter to listen for entitlement activities.
This is necessary in order to use the entitlements you are creating.
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If you don’t want to see the Add To Filter window on entitlements you are creating for any
driver in Designer, select Remember Selection - Don’t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.

If you have a file conflict, you are asked to save the editor’s changes before continuing. Once
the editor is saved, the entitlement displays in the Modeler view.

13.3.3 Administrator-Defined Entitlements with Lists

The example in the following procedure is an administrator-defined entitlement that allows you to
select a listed entry. This type of entitlement is best used through Workflow entitlements rather than
Role-Based Entitlements.

1 Right-click the driver icon in the Outline view or the Modeler view, then click New >

Entitlement.
@ New Entitiement Wizard 3]
MName Entitlement o
Give the entitlernent a narme and a description. x ‘L&

Marme: | Admin-defined

[ Use name for display name

Display Marme: |Admin—deﬁned Entitlernent

Description: | This will show administrator-defined Yalues,

(3] | Mext = | | Cancel |

In this example, the entitlement name is Admin-defined, but the defined display name is
Admin-defined Entitlement. You need to define a display name only if you want the display
name to be different from the name you called the entitlement; otherwise, you can just use the
entitlement name as the display name. In this example, the Description field is defined as This
will show Administrator-defined Values.

2 Click Next.

3 Inthe Set Entitlement Values window, select Yes to the question “Do you want this entitlement
to include values?” Click Next.

4 In the next Set Entitlement Values window, select Administrator Defined Values, then click
Next.

5 In the Define Values window, type the values you want to add to the Entitlement Value entry,
click Add to add the value to the Defined List pane, then click Next.
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. New Entitlement Wizard

Drefine Walues

. . WIS

Entilement values can be taken from a defined list, or they can be entered  W=es
by entilement consumers,

Do ol want to define a list of values?
@) es

@ Choose this if you want to define a list of values for the enfittement
consumers to choose from.

ONo

@ Choose this if you want enfitement consumers to define their own values,

Entilermnent Walue:
Building & Add
Drefined List:

BLilding A
Building < ]
@ ’ < Back ” Mext = ]

In this example, the values are corporate buildings: Building A through Building D. Through
an entitlement client, such as an iManager Role-Based Entitlement task or through the user
application, users or defined-task managers can specify the building information, which is then
included in an external application, such as Novell eDirectory.

Use the Remove button to remove a value, or use the Edit button to edit a value.

In the Assign Multiple Values window, select Yes if you want the entitlements to be granted
more than once and with different values. If you select No, the entitlement can only be granted
once. For the example, click No, then click Next.

It makes sense to assign group entitlements with multiple values, but it does not make sense to
assign building letters more than once.

You are asked if this entitlement is intended to be used by Role-Based Entitlement policies
through iManager. If you want this entitlement to be granted or revoked automatically, select
Yes to the Role-Based Entitlements question, click Next, then continue with Step 8 on page 314.

or

If you want the granting or revoking of this entitlement to be a manual process (approved by
someone), select No to use the User Application, then skip to Step 9 on page 314.

We recommend that you have only one agent control an entitlement. If multiple agents are in
control, you have the following consequences:

+ Whoever comes last controls the entitlement results
+ Results are unpredictable
+ Using both agents to control an entitlement is not supported by Novell
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8 (Conditional) If you select Yes to the Role-Based Entitlements question, you are asked if you
want to use the Role-Based Entitlements priority to resolve any conflicts that might happen
when this entitlement is assigned by different Role-Based Entitlement Policies with different
values. You can resolve the conflict by either using the Role-Based Entitlements priority, or by
merging the values. This example merges the values.

Merging the values merges the entitlements of all involved Role-Based Entitlement policies, so
if one policy revokes an entitlement but another policy grants an entitlement, the entitlement is
eventually granted. Solving conflicts by priority works if you need to ensure that only one
policy is applied to this entitlement at any time.

9 Click Finish.

10 If you see the Add To Filter window, answer Yes if you want the driver to listen for this
entitlement. This enables entitlements for the driver. The DirXML-EntitlementRef attribute
allows the driver filter to listen for entitlement activities, which is necessary in order to use the
entitlements you are creating.

Or

If you don’t want to see the Add To Filter window on entitlements you are creating for any
driver in Designer, select Remember Selection - Don’t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.

Before you can edit this entitlement, you are asked to save the editor’s changes before continuing.
Once the editor is saved, the entitlement displays in the Modeler view.

13.3.4 Administrator-Defined Entitlements without Lists

The example in the following procedure is an administrator-defined entitlement that forces the
administrator to type a value. You can use this kind of entitlement if you do not have all of the
information at the initial setup, so you cannot create a task list.

1 Right-click the driver icon in the Outline view or the Modeler view, then click New >

Entitlement.
@ New Entitlement Wizard &)
MName Entitlement g
Give the entitlement a name and a description. ! ‘LB

Marne: |Admin—deﬁned (no lists)

W Usa namea for display name

Display Marme: |

Description: | There is no pr