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About This Manual

This administration guide is written to provide network administrators the conceptual and procedural
information for administering Micro Focus File Reporter.

*

*

Chapter 1, “What's New,” on page 9

Chapter 2, “Overview,” on page 15

Chapter 3, “The Administrative Interface,” on page 25

Chapter 4, “Performing Setup Procedures,” on page 31

Chapter 5, “Scheduling and Performing File System Scans,” on page 41
Chapter 6, “Generating File System Reports,” on page 57
Chapter 7, “Content Scanning and Reporting,” on page 101
Chapter 8, “Performing Other Administrative Tasks,” on page 111
Chapter 9, “Using the Report Viewer,” on page 117

Chapter 10, “Using the Client Tools,” on page 121

Chapter 11, “Using Report Designer,” on page 131

Appendix A, “Filtering,” on page 147

Appendix B, “Security Settings,” on page 153

Appendix C, “Log File Locations,” on page 157

Appendix D, “Agent Scan Capabilities,” on page 159

Appendix E, “Glossary,” on page 165

Appendix F, “Documentation Updates,” on page 169

Audience

This guide is intended for network administrators who manage network storage resources.

Feedback

We want to hear your comments and suggestions about this guide and the other documentation
included with this product. Please use the User Comment feature at the bottom of each page of the
online documentation, or go to www.novell.com/documentation/feedback.html and enter your
comments there.

Documentation Updates

For the most recent version of the Micro Focus File Reporter 3.5 Administration Guide, visit the Micro
Focus File Reporter Documentation website (http://www.novell.com/documentation/filereporter3).

About This Manual
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Additional Documentation

For additional File Reporter 3.5 documentation, see the following guides at the Micro Focus File
Reporter Documentation website: (http://www.novell.com/documentation/filereporter3)

+ Micro Focus File Reporter 3.5 Installation Guide
+ Micro Focus File Reporter 3.5 Database Schema and Custom Queries Guide

About This Manual
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1.1

1.2

What's New

¢ Section 1.1, “New in Version 3.5,” on page 9

¢ Section 1.2, “New in Version 3.0,” on page 9

+ Section 1.3, “New in Version 2.6,” on page 10
+ Section 1.4, “New in Version 2.5,” on page 11

+ Section 1.5, “New in Version 2.0.2,” on page 11
¢ Section 1.6, “New in Version 2.0.1,” on page 12
¢ Section 1.7, “New in Version 2.0,” on page 12

With each product update, Micro Focus File Reporter introduces significant architectural and feature
enhancements. Starting with the release of Version 2.0, we have provided a timeline summarizing
some of the more notable changes in architecture, performance, and features.

New in Version 3.5

File Content Scanning and Reporting

In addition to reporting on security and metadata, on files located on Windows storage devices, File
Reporter can now report on the content of the files themselves. Through file content scanning,
organizations can identify files containing specified patterns such as U.S. Social Security numbers,
credit card numbers, or other user-defined patterns. Furthermore, these organizations can define and
apply classifications and categories to these identified files.

File content reports that identify files containing personal, confidential, or sensitive information can be
imported into Micro Focus File Dynamics where the location of these files can be remediated.

New Agents

A new AgentFS replaces the previous Windows Agent, now known as the legacy Agent for Windows.
The latter is still available for serving as a Proxy Agent for OES storage devices. For file content
scanning there is the new AgentFC.

Support for OES 2018

This includes the ability for OES 2018 servers to host File Reporter Linux Agents, as well as for File
Reporter 3.5 to perform file system scans on OES 2018 servers.

New in Version 3.0

Micro Focus Branding

Micro Focus File Reporter 3.0 is the first File Reporter release to implement the Micro Focus branding
elements. These are most apparent in the management and installation interfaces. In some cases,
the names of files and folders have changed to reflect the new product name.

What's New
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1.3

Scan Processor

This new .NET application greatly improves the rate at which scans are added to the database. The
Scan Processor resides on the server hosting the Engine and is installed during the Engine
installation process.

Direct Upgrading from Various 2.x Versions

You can upgrade to File Reporter 3.0 directly from versions 2.5, and 2.6.

Updated Analytic Tools

No longer offered as a “Technology Preview,” these tools are now fully developed 64-bit applications.
The Heat Map has been renamed to the more applicably descriptive Tree Map.

New in Version 2.6

Baseline and Previous Scans

Previous versions of Novell File Reporter 2 let you keep only the most recent File System and
Permissions scans of a storage resource. With the release of Version 2.6, you can now designate a
particular scan to be retained as a “Baseline scan” and keep the existing scan as a “Previous scan.”
This means that you can now retain up to three scans for each storage resource: a Baseline scan, a
Previous scan, and a “Current scan.” Any combination of two scans are the means of generating new
built-in Historic Comparison reports being introduced in Version 2.6.

Historic Comparison Reports

This new built-in report lets you view the changes to a storage resource through a comparison of any
two of the following scans: Baseline, Previous, or Current.

Historic Comparison reports include:

+ Historic File System Comparison reports
¢ Historic NCP Permissions Comparison reports
+ Historic NTFS Permissions Comparison reports

Custom Query Report Designer Updates

The Custom Query Report Designer has been updated to support views for Previous and Baseline
scan data, as well as a number of other updates and bug fixes.

Ability to Delete a Scan Immediately

A scan can be manually deleted immediately, or it can be marked for deletion at the next
maintenance interval (by default, currently 12:00 midnight local time).

Ability to Copy a Report Definition

The ability to copy Report Definitions has been added to both the Web Application and the Report
Designer. The Web Application is able to copy any report definition type, and the Report Designer is
able to copy any Custom Query report definitions.

What's New



1.4

1.5

File Query Cookbook

Coinciding with the release of Novell File Reporter 2.6 is the introduction of a new collaborative
community portal for accessing and sharing Custom Query reports. The SQL commands for these
reports are included so all that you have to do is simply copy the commands and paste them into the
Report Designer. In addition, sample report layouts (. repx files) are also included for some reports
which can be opened via the Report Designer report layout interface. Both the SQL and the report
layouts may be customized as needed. You can access the File Query Cookbook directly through the
Report Designer interface, or at http://www.filequerycookbook.com (http://
www.filequerycookbook.com).

New in Version 2.5

Custom Reports through Database Querying

In addition to the built-in report types, you can generate custom reports by crafting your own database
query. The report data is extracted from the scan and generated into a report in delimited text format
or a custom report layout via the new Report Designer.

Custom Query Report Designer

Custom query report data can be further customized for layout and presentation from a Windows
workstation with the Report Designer.

Desktop Report Viewer

Stored reports can now be downloaded and viewed from a Windows workstation with the Report
Viewer application.

Early Access to Analytic Tools in Development

The release of Version 2.5 includes early access to analytic features in a new tool set that can be run
from a Windows workstation.

New in Version 2.0.2

Support for Microsoft SQL Server 2012

With the release of Novell File Reporter 2.0.2, supported databases now include both PostgreSQL
and Microsoft SQL Server 2012. For procedures on properly configuring a new SQL Server 2012
instance that is compatible with Novell File Reporter, see the Novell File Reporter 2.0.2 Installation
Guide.

Configuration Dashboard

A new configuration dashboard is the means of managing the product licensing and sequentially
configuring and administering the database, Engine, and Web Application.

Reporting on Administrative Shares

Novell File Reporter can now report on administrative shares in Windows file systems.

What's New 11
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1.6

1.7

Support for Microsoft Server 2012 R2
Novell File Reporter 2.0.2 fully supports Microsoft Server 2012 R2.

New in Version 2.0.1

Advanced Filtering

With the introduction of Novell File Reporter 2.0.1, you can use advanced filtering capabilities so that
your File Data reports include only the data you want. Boolean filtering is available through a new
Filters tab. For more information, see Appendix A, “Filtering,” on page 147.

Microsoft DFS Namespace Support

Distributed File System (DFS) namespace technology helps Microsoft network administrators group
shared folders located on different servers and presents them to users as a virtual tree of folders
known as a namespace. Novell File Reporter now presents these namespaces as available storage
resources that can be reported on.

New in Version 2.0

Advanced Architecture

To provide expanded reporting capabilities Novell File Reporter 2.0 was built on a new advanced
architecture that supports:

+ Simultaneous integration with eDirectory and Active Directory

+ An SQL database

+ Web-based administration

Easier Configuration and Management

All of the complex DSI installation and configuration tasks have been replaced with a simple
installation and configuration wizard. Once installed, all management tasks are performed through a
browser-based interface.

New Reporting Capabilities

Novell File Reporter 2.0 has a much stronger tie-in to network directory services. File Reporter 2.0
authenticates to a primary identity system (either eDirectory or Active Directory) and then through a
proxy, establishes a connection to the other identity system. You can be connected to one Active
Directory domain and many eDirectory trees at the same time.

New Reports
In addition to the extensive file report types in Version 1, Novell File Reporter 2.0 introduces:

+ Permissions reports that identify who has access to a particular file or the access rights of a
particular user

+ Trending reports that show the growth of data on a Novell volume or Windows share over a
period of time

What's New



+ Detail reports that are specific to an individual user, file type, file, and more

+ Aggregate reports that report on file and folders located on storage resources in eDirectory and
Active Directory

What's New 13
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2.1

2.2

Overview

This section provides an understanding of Micro Focus File Reporter, the supported databases, the
Engine, and Agents, along with how reports and analytics information are generated.

+ Section 2.1, “Micro Focus File Reporter,” on page 15
+ Section 2.2, “How File Reporter Works,” on page 15

Micro Focus File Reporter

Micro Focus File Reporter inventories network file systems and delivers the detailed file storage
intelligence you need to optimize and secure your network for efficiency and compliance. Engineered
for enterprise file system reporting, File Reporter gathers data across the millions of files and folders
scattered among the various network storage devices that make up your network. Flexible reporting,
filtering, and querying options then present the exact findings you need so you can demonstrate
compliance or take corrective action.

File Reporter identifies files currently stored on the network, the size of the files, whether these files
contain personal or other sensitive information, when users last accessed or modified the files, and
the locations of duplicate files. File Reporter can also help you calculate department or individual
storage costs. File Reporter can even identify access rights to folders and consequently, the files that
are contained within.

How File Reporter Works

¢ Section 2.2.1, “Core Components,” on page 16

*

Section 2.2.2, “File System Scanning,” on page 17

¢ Section 2.2.3, “File Content Scanning,” on page 18

+ Section 2.2.4, “Reporting,” on page 19

+ Section 2.2.5, “Client Tools,” on page 21
File Reporter was developed to examine, report and analyze file systems containing petabytes of
data—in other words, millions of files, folders and volumes, scattered among the various storage

devices that make up your network. This reporting includes file content and the associated rights of
these files, folders, and network volumes or shares.

To examine, report, and analyze this data efficiently, File Reporter disperses the work among a Web
application, Engine, Agents, a Scan Processor, either a PostgreSQL or Microsoft SQL Server
database, and either eDirectory or Active Directory.

Overview 15
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Figure 2-1 File Reporter Work Process
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2.2.1 Core Components

The following are core components of Micro Focus File Reporter.

Web Application

The Web application runs on top of Microsoft Internet Information Services (IIS) and is the means of
all administrative interaction. Among other things, the Web application is responsible for:

+ Management of scan policies and report definitions

+ Generating Preview reports

+ Access to stored reports

*

All other management functions

Engine

The Engine is the mechanism that runs File Reporter and runs from a Windows Server host. The
Engine does the following:

+ Schedules the scans that the Agents conduct

Overview



2.2.2

*

Compiles scans for inclusion in a report

*

Runs scheduled reports
+ Manages scan delegations to Agents

*

Sends notifications that File Reporter has completed a scan or generated a report

Database

The database stores information needed for generating reports. This information includes:

+ Cached Active Directory and eDirectory objects
+ Scans

+ |dentity system information such as names of eDirectory trees and Active Directory domains and
forests

+ Schedule information pertaining to scans and reports
+ Notification information

+ Report definitions

+ Scan history

¢ Scan policies

+ Volume free space

File System Scanning

The following are components associated with file system scanning.

Scan Processor

The Scan Processor does the following:

+ Processes file system scan files

+ Updates file system scan information in the database

Agents

Agents are compact programs that can run on Micro Focus Open Enterprise Server and Microsoft
Windows Server hosts. Agents can examine and report on NSS and NTFS file systems. Additionally,
Agents examine and report on file system security, including file and folder rights, trustee
assignments, and permissions. For more information, see Appendix D, “Agent Scan Capabilities,” on
page 1509.

IMPORTANT: For optimal results, you should install an Agent on every server that has a volume or
share you want to report on.

Agents cannot be installed on NAS devices or clustered hardware devices. For File Reporter to report
on these type of devices, Agents can be set up as proxy agents.

Overview 17
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2.2.3

File Reporter includes the following file system Agents:

+ AgentFS: Windows file system Agent that in most cases, should replace any previous File
Reporter Agents on Windows Server hosts. AgentFS performs file system scans (rather than file
content scans) on Windows storage devices.

+ Legacy Agent for Windows: Previous File Reporter Agent for performing file system scans on
Windows Server hosts. You should only use this Agent when you need an Agent hosted on a
Windows Server to function as a Proxy Agent for a Micro Focus Open Enterprise Server (OES)
or NetWare server, as AgentFS cannot perform that function.

+ Agent for OES Linux: Micro Focus OES hosted Agent that performs file system scans on OES
or NetWare servers.

Scans

Through one of the file system Agents (AgentFS, legacy Agent for Windows, or Linux Agent), File
Reporter scans a storage resource. A storage resource can be a Micro Focus (formerly Novell)
network server volume or a Microsoft network share.

File system scans are indexed data that are specific to a storage resource. They are the means of
generating a storage report or the means of analyzing data using the analytics tools. File system
scans include comprehensive information on the file types users are storing, when files were created,
when they were last modified, permission data on the folders where these files reside, and much
more.

File Reporter collects file system scans from the Agents and sends them to the Engine. The Engine
then sends the scans to the Scan Processor, which stores the scans in the database.

You can conduct scans at any time, but we recommend using a scheduled time after normal business
hours to minimize the effect on network performance.

NOTE: Procedures for performing scans are documented in Chapter 5, “Scheduling and Performing
File System Scans,” on page 41.

File Content Scanning

The following are components associated with file content scanning.

ManagerFC

The ManagerFC service is responsible for the execution and management of file scan jobs. The
service performs the following tasks when processing a scan job:

+ Enumeration of files in target paths
+ Submission of files to scan queues in the message broker based on filter criteria

+ Processing of scan results and update of result data to the database and scan result files

AgentFC

AgentFC performs file content scans. AgentFC is hosted only on a Windows Server and performs
content scans only on files stored on Windows storage devices.

Overview
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Scans

Through AgentFC, the RabbitMQ messaging broker, and ManagerFC, File Reporter performs,
classifies, and categorizes file content scans. For example, content scans can identify files containing
specified patters such as U.S. Social Security or credit card numbers.

Reporting

When File Reporter has a file system or file content scan, you can utilize it to generate a report. You
can generate reports through the following means:

+ Built-in Reports
+ Custom Queries

Built-in Reports

Generating a built-in report is as simple as selecting the report type from a menu.

To generate a report, the Engine takes all of the needed scans that are applicable to the
specifications of the report and consolidates them into a single report by indexing the applicable
scans.

Table 2-1 Built-in Report Types

File System Reports Security Reports Trending Reports
Folder Summary Assigned NCP Permissions Volume Free Space
Detail Reports Assigned NTFS Permissions
File Extension Permissions by Path
Duplicate Files Permissions by Identity
Date-Age Historic NCP Permissions
Comparison
Owner Historic NTFS Permissions
Comparison

Storage Cost
Comparison
Directory Quota

Historic File System Comparison

File Reporter lets you present built-in reports in various formats including PDF, Microsoft Excel, RTF,
HTML, TXT, and CSV. The product also includes built-in graphs for certain report types.

Overview 19



Figure 2-2 Sample Report in Graphical Format
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m WWSemver_3 adiLogistics
=~~~ File Count

Custom Query Reports

These reports allow administrators who are familiar with querying the database to generate very
specific report data that might not be available through one of the built-in report types.

Custom Query report data can be further customized for layout and presentation from a Windows
workstation with the Report Designer.

File content reports are delivered as Custom Query reports.

20 Overview
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Figure 2-3 Page from a Custom Query Report Designed with the Report Designer.

Membership List:
NVB!Tatkins NVB'Tsanchez

\\nvb-main nvb local\Shares\Forms

[]Access Based Enumeration Enabled

Total Quota iGB
Remaining Quota 1.65 GB

0 - é_]

Percent Quota Used
NVB'Managers Member Count: 2

Assigned Permissions FMELEW
Membership List:
NVB\JLarkins NVE\Jsmith

NVB\NVE-Users Member Count: 10

Assigned Permissions ELR

Membership List:
NWVE'Flincoln NVEB'DThompson
NVB'Blee NVB'BClarke
NVB!Tatkins NWVB'Tsanchez
NVB\JLarkins NVBJsmith
NVB'Gstinson NVB'Glopez

\\nvb-main nvb local\Shares\Home

[ ]Access Based Ennmeration Enabled

Total Quota 12 GB
Remaining Quota 8.62GB

Percent Quota Used

NVBWNVB-Users Member Count: 10

Assigned Permissions ELR

Membership List:
NWVB'Flincoln NVB'DThompson
NVB'Blee NVB'BClarke

3/4

2.25 Client Tools

File Reporter provides the following Client Tools, designed to be run from a Windows workstation.

Overview

21

9T0Z 1aqwanoN TT (ud) sAsaop



22

Data Analytics

In addition to extensive reporting options, File Reporter provides the ability to graphically analyze file
system data using a variety of analytics tools that are available to administrators through the Client
Tools.

Dashboard

The Dashboard lets you graphically analyze data from file system scans according to the filters that
you specify.

Figure 2-4 Dashboard

m - Dashboard - Fle Reporter Data Analytics - 1.5.0 m - o x

Tree Map

The Tree Map lets you view graphical representations of hierarchical file system data and in the
process, gain insight very quickly.

Overview
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Figure 2-5 Tree Map
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Report Viewer

The Report Viewer lets you to view all stored reports locally from a Windows workstation. Because
the Report Viewer utilizes the resources of the Windows workstation, rather than those of the Engine,
the Report Viewer can display stored reports much faster in most instances.

Figure 2-7 Report Viewer
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3.1

3.2

The Administrative Interface

¢ Section 3.1, “Supported Browsers,” on page 25
+ Section 3.2, “Launching the Administrative Interface,” on page 25

+ Section 3.3, “Using the Administrative Interface,” on page 27

Supported Browsers

Micro Focus File Reporter is managed through a Web browser-based interface and is supported on
the latest versions of the following browsers:

Table 3-1 Supported Browsers

Windows Linux Mac OS X
Firefox Firefox Firefox
Chrome Chrome
Edge

Launching the Administrative Interface

1 Inthe browser’s address bar, type:
https://file_reporter_web_server_dns_name
The DNS name is the one you created in “Micro Focus File Reporter 3.5 Installation Guide.”
You must enter the DNS name. You cannot log in with an IP address.
The login screen appears.

The Administrative Interface
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+ + +
+ + + FILE REPORTER

Login

Enter the username and password of a member of the SRsAdmins group that you created and
click Log In.

If you are authenticating to Active Directory, the username can be entered in any of the standard
Active Directory formats:

domain\SAMAccountName (AD\User1)
UPN(userl@ad.test. lab)
LDAP(CN=userl,0U=home,DC=ad,DC=test,DC=1ab)

With LDAP, there may be partial case sensitivity, especially with the domain (DC=) components.

If you are authenticating to eDirectory, the username must be entered in typeless FDN:

admin.mcirofocus

The File Reporter Home page appears:

MAIN  FILE SYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

HOME  NOTIFICATIONS  SYSTEM CONFICURATION

General i Scans l.l Reports

Version Infe Fila System Scan Policies € Ropart Definitions ]

L Report Generation

Had availsbie
955168
739568

The Administrative Interface
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Using the Administrative Interface

¢ Section 3.3.1, “Viewing Notifications,” on page 27
+ Section 3.3.2, “Configuring the Web Interface,” on page 28
¢ Section 3.3.3, “Viewing System Information,” on page 29

All tasks are conducted by selecting an option from one of the menus at the top of the page.

The Main menu provides access to notifications and system information. The File Systems menu is
the means to setting up and viewing the progress of file system scans. The File Content menu
provides options for setting up and conducting file content scans. The Reports menu is the means of
generating and accessing reports. The Configuration menu is the means of establishing and
modifying configuration settings within File Reporter.

Viewing Notifications

File Reporter displays notifications for successfully completed scans, failed scans, completed reports,
failed reports, errors, warnings, and other information. You can use the filtering options to list only the
notification types you want.

1 From the Main menu, select Notifications.

FR MAIN FILESYSTEMS FILECONTENT REPORTS CONFIGURATION &4 DYNAMICS\Administrator
HOME ~ NOTIFICATIONS  SYSTEM CONFIGURATION
¥ Refresh
Severity Timestamp Status Category Message
The File System Data Scan for target ~
@ Success 6/7/2018 2:53:59 PM (0) Operation successful. Scan
"\dynamics cctec org\DFS\Atlanta\AtiantaShare' with Id '5' completed successfully
The scheduled data scan for storage path
@ o 6/7/2016 2:55:35 PM €0) Operation successful. Scan )
dynamics.cctec.org\DFS\Atlanta\AtlantaUsers was canceled by an administrator.
The scheduled data scan for storage path
@ o /712018 2:53:39 PM (0) Operation successful. Scan i
\\dynamics.cctec.org\DFS\Atlanta\AtlantaShare was canceled by an adminisfrator.
The Permissions Scan for target \\dynamics.cctec.org\DFS\Londor\LondonUsers'
@ Success 6/7/2018 2:53:28 PM €0) Operation successful. Scan }
with Id"4' complefed successfully
The Permissions Scan for target \dynamics.cctecorg\DFS\London\Londonsers'
@ Success 6/7/2018 2:47:14 PM €0) Operation successful. Scan ;
with Id 3" completed successfully
The scheduled data scan for storage path
\\dynamics.cctec. org\DFS\Atlanta\AtlantaUsers (Scan 1D 2) was unable fo complete.
@ Error 6/7/2018 2:38:00 PM (1038) The specified agent name could not be found. Scan
The following error occurrect: (1038) The specified agent name could nof be found.
There are 2 refry attempfs remaining. The next attempt will be made in 3600
Create Filter
Copyright 2018 & Condrey Corporation

Like many pages in the administrative interface, you can modify the current display.
2 (Optional) Display columns in the order you want by dragging them to the desired location.
3 (Optional) List the most recent notification by clicking twice the column heading.
4 (Optional) Filter the notifications to display only the information you want:
4a At the desired column heading, click the “pin” icon.
For example, the Message column.
4b Select the desired filter option.

For example, Contains.

The Administrative Interface 27
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4c In the field to the left of the “pin” icon, enter the distinguishing word or letter for the filter.
For example, Permissions.
The page is updated according to the filtering parameters.

FR MAIN FILESYSTEMS FILECONTENT REPORTS CONFIGURATION £} DYNAMICS\Administratar

HOME ~ NOTIFICATIONS  SYSTEM CONFIGURATION

3 Refresh
Drag a column header here To greup by that column

Severity Timestamp Status Category Message

Permissions|

The Permissions Scan for arget N\dynamics cctec org\DFS\London\L ondenUsers' with
¥ Success 6/7/2018 24714 PM €0) Operation successful.
Id '3 completed successfully

Secan
The Permissions Scan for farget N\dynamics.ccfec.org\DFS\London\LondonUsers' with
@ Success 6/7/2018 25325 PM (0) Operation successful Sean
Id '4' completed successfully
The scheduled permissions scan (Scan 1D 3) for storage path
. \dynamics cctec org\DFS\Londont LondonUsers was unable to complete. The specified
@ Eror £/7/2018 1:47:53 PM (1027) Unable fo communicate with the agent. Sean
agent could not be reached. There are 3 refry attempts remaining. The next attempt wil
be made in 3547 seconds
Contains([Messagel. ‘Permissions’ Clear

Copyright 2018 © Condrey Corporation

3.3.2 Configuring the Web Interface

After 20 minutes of inactivity in the administrative interface, you are required to log in again. You can
adjust this setting and specify the number of items displayed per page through the Web Application
option of the Configuration menu.

1 From the Configuration menu, select Web Application.

FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

IDENTITY SYSTEMS STORAGE RESOURCES FILE CONTENT STORED REPORTS NOTIFICATIONS EMGINE LOGS FILE MANAGEMENT 'WEE APPLICATION

Display Options

Grid Page Size 50 : rows: Note: This setting applies to the current browser only.

Session Options

Authentication Timeout 20 minutes Note: This setting will not affect any current authenticated sessions.

seconds

LR

Report Page Execution Timeout 900

APPLY

Copyright 2018 € Condrey Corporation

2 Inthe Grid Page Size field, specify the number of entries you want displayed.

3 Inthe Authentication Timeout field, specify the minutes of inactivity before you will need to log in
again.

28 The Administrative Interface
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4 Click Apply.

5 When you are notified that the Web interface configuration was saved, click OK.

3.3.3

Viewing System Information

When you work with a Micro Focus Support representative to diagnose the source of a problem, you

might be asked to access the System Info page. To do so, simply select System Configuration from

the Main menu.

FR MAIN  FILE SYSTEMS

Database Statisfics

Database Version String

Database Total Size
Database Host Address
Database Name
Database Schema Version

Scans.

Total Size of Scans

File System Metadata Scans
Permision Scans

Wolume Trend Scans

Identity System Data

Identity Systems Count
Identity System Cached Objects
Identity Systems Size

FILE CONTENT REPORTS CONFIGURATION

HOME  NOTIFICATIONS

Microsoff SQL Server 2017 (RTM) - 14.0.1000.169 (X64)
Aug 22 2017 17:04:49

Copyright (C) 2017 Microsoft Corporation

Standard Edition (64-bit) on Windows Server 2016
Siandard 10.0 <Xé&4> (Build 14393: ) (Hypervisor)
83,886,080 bytes

17217221

srsdb

3501

1.400.832 bytes
2
2
[+]
3

44
442,365 bytes

SYSTEM CONFIGURATION

Referenced Web Application Assemblies

Name Version

Condrey.Srs.Core 3502
Condrey.Srs.CoreExt 3509
Condrey.Srs.Product 3505
Condrey.Srs.ReportLibrary 3501
<

Copyright 2018 ® Condrey Corporation

& DYNAMICS\Administrator

Processor Archirecture

A

None
None
None

None w

The Administrative Interface
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4.1

411

Performing Setup Procedures

Before you can start scanning storage resources and generating reports, you first need to perform
some setup procedures.

+ Section 4.1, “Enabling Other Identity Systems,” on page 31
+ Section 4.2, “Viewing Storage Resources,” on page 35

*

Section 4.3, “Assigning Proxy Targets,” on page 37

+ Section 4.4, “Configuring Notifications,” on page 38

*

Section 4.5, “Integrating with File Dynamics or Storage Manager,” on page 40

Enabling Other Identity Systems

¢ Section 4.1.1, “Enabling eDirectory,” on page 31
+ Section 4.1.2, “Enabling Active Directory,” on page 33

Your license file for File Reporter is either for Active Directory or eDirectory. If the File Reporter
license file is for Active Directory, then Active Directory is the primary identity system. If the license file
is for eDirectory, then eDirectory is the primary identity system.

File Reporter lets you enable other identity systems so that you can scan and report on the storage
resources that are within those systems.

¢ Section 4.1.1, “Enabling eDirectory,” on page 31
+ Section 4.1.2, “Enabling Active Directory,” on page 33

Enabling eDirectory

File Reporter allows you to enable multiple eDirectory trees as identity systems.

IMPORTANT: If you have Universal Passwords set up for all users in your tree, you must have the
proper settings for File Reporter to work. Refer to “Micro Focus File Reporter 3.5 Installation Guide”
for more information.

IMPORTANT: If your primary identity system is Active Directory and you want to enable eDirectory,
you must first install the Client for Open Enterprise Server on the Windows server that is hosting the
Engine.

1 Select Configuration > Identity Systems.

Performing Setup Procedures 31
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FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION

Qrad | D Reset Proxy

Primary Name Type
E gD

Account Password 55 Refresh

Defaulr Server Proxy Credentials

Copyright 2018 & Condrey Corporation

& DYNAMICS\Administrator

IDENTITY SYSTEMS STORAGE RESOURCES FILE CONTENT STORED REPORTS NOTIFICATIONS ENGINE LOGS FILE MANAGEMENT 'WEB APPLICATION

Authenticated

__

2 Click Add.

Add eDirectory ldentity System

eDirectory Authentication:

Default Server Address:
Username:

Paszword:

Tree Name:

Proxy Object FDM:

A

Root] for Proxy Account

CANCEL

Default Server Address: Specify the IP address of any server in the directory tree.

Username: Use typeless FDN format naming to specify an administrator name.

Password: Specify the administrator password.

Tree Name: Specify the name of the eDirectory tree.

Proxy Object FDN: Use typeless FDN format naming to specify a name for the proxy object that

you are creating.

For example, MFRProxyObject.system

Performing Setup Procedures
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4.1.2

Assign Supervisor rights to [Root] for Proxy Account: Leaving this check box selected
enables File Reporter to scan all volumes in the directory tree. If you deselect this option, the
Agent can scan only those volumes to which the File Reporter proxy object has been given
supervisor rights.

When this option is deselected, storage resources might not build properly.

We therefore recommend that this option remain selected.
3 Complete the fields and click OK.
The eDirectory identity system is added.

FR MAIN

FILE SYSTEMS  FILE CONTENT

REPORTS CONFIGURATION & DYNAMICS\Administrator

IDENTITY SYSTEMS STORAGE RESQURCES

dynamics.cctecorg

FILE CONTENT

Type

Active Directory

STORED REPORTS NOTIFICATIONS ENGINE LOGS FILE MANAGEMENT 'WEE APPLICATION

&5 Add € Delete Set Default Server for eDirectory Reset Proxy Account Password 7 Refresh

Defaulr Server Proxy Credentials Authenricared

E- SEIEEIREE e e e _

Copyright 2018 @ Condrey Corporation

4 (Optional) Repeat these steps to add additional eDirectory identity systems.

Enabling Active Directory

File Reporter allows you to enable only one Active Directory forest as an identity system.

1 Select Configuration > Identity Systems.

FR MAIN

@ Add

Primary

FILE SYSTEMS  FILE CONTENT

IDENTITY SYSTEMS  STORAGE RESOURCES

REPORTS CONFIGURATION £} admin.system

FILE CONTENT

STORED REPORTS NOTIFICATIONS ENGINE LOGS FILE MANAGEMENT WESB APPLICATION

3 Refresh

Default Server Proxy Credentials Authenticated

-- SO s __

Copyright 2018 € Condrey Carporation

2 Click Add.

3 Inthe Identity System Type region, click the Active Directory option.

Performing Setup Procedures
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Add Identity System

Identity System Type:

Domain Administrator Credentials:

Username:

Password:

Faorest Root:

Proxy User: CYMAMICSY,

Proxy Rights Group: DYMAMICS,

9T0Z JaqwanoN TT (ud) sAsaop

Username: Specify a username for an administrator in Active Directory.
Password: Specify the password for the administrator.

Forest Root: Because the Windows Engine host server is already part of a domain, the forest
name is entered automatically.

Proxy User: Name the proxy user.
For example, srsproxy.
Proxy Rights Group: Name the proxy rights group.
For example, srsproxyrights.
4 Click OK.
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The Active Directory identity system is added.

FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION A admin.system

IDENTITY SYSTEMS STORAGE RESOURCES FILECONTENT STORED REPORTS NOTIFICATIONS ENGINE LOGS FILE MANAGEMENT  WEB APPLICATION

Qad 0 3 Refresh
Primary Name Default Server Proxy Credentials Authenticated
-- g i __
dynamics.cctecorg Active Directory DYNAMICS\srsproxy

Copyright 2018 © Condrey Corporation

4.2 Viewing Storage Resources

When an identity system has been enabled, the associated storage resources, which include Micro
Focus volumes and Microsoft shares, are available for scanning and reporting.

File Reporter cannot see a Windows network disk drive that is not shared.

1 Select Configuration > Storage Resources.

FR MAIN FILESYSTEMS FILECONTENT REPORTS CONFIGURATION A DYNAMICS\Administrator

IDENTITY SYSTEMS ~ STORAGE RESOURCES ~ FILE CONTENT ~ STORED REPORTS ~ NOTIFICATIONS  ENGINELOGS  FILE MAMAGEMEMT  WEB APPLICATION

5 Refresh
Identity System In Progress Discovery Strategy Rebuild Start Time Rebuild Total Time Rebuild Status
ol - ——
dynamics.cetecorg Containers 6/11/2018 12:00-00 AM 0000:00

Create Filter

Copyright 2018 & Condrey Corporation

2 Select a check box pertaining to one of the listed eDirectory trees or Active Directory forests.

The Rebuild button is enabled, allowing you to rebuild the storage resources for the selected
eDirectory tree or Active Directory forest. You should rebuild the storage resources whenever
you add a new server.

3 (Optional) Click Rebuild to rebuild the storage resources for the eDirectory tree or Active
Directory forest.

4 Click one of the listed eDirectory trees or Active Directory forests.

Performing Setup Procedures
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FR MAIN  FILESYSTEMS FILECONTENT REPORTS CONFIGURATION ) DYNAMICS\Administrator

IDENTITY SYSTEMS ~ STORAGE RESOURCES ~ FILE CONTENT ~ STORED REPORTS ~ NOTIFICATIONS  ENGINELOGS  FILE MAMAGEMENT  WEE APPLICATION

£ Discovery Options =] Schedule ~ Rebuild 'S Refresh

Resource Operating System FDN File System  LastUpdare Last Update Attempt LastStatus

Open Enterprise Server CN=cctec3.0U=1 6/11/2018 1:55:35 PM 6/11/2018 1:55:33 PM

Copyright 2018 ® Condrey Corporafion

All of the servers in the selected eDirectory tree or Active Directory forest are displayed.
Click each button to view options.

Discovery Options: For large organizations with eDirectory trees or Active Directory forests
spanning multiple geographic areas, rebuilding the storage resources can take many hours.
Rather than rebuilding the storage resources for the identity system, you can select this to create
a scope that specifies just those new containers or servers that need added.

Storage Resource Discovery Options - dynamics.cctec.org

@ Scope by Container List O Scope by Server List

Container FDN

New
Mo Containers defined. The entire dynamics.cctec.org forest will be searched.

Select whether to specify the servers through a container FDN or server FDN, then click New to
enter the paths. Specify the FDN path and click Update. When all of the paths you want to be
searched are listed, click OK.

Schedule: By default, File Reporter rebuilds the identity system’s storage resources at 12:00
AM each day. Larger sites might want change this setting to weekly or on a specific day of the
month. To do so, click this option and modify the settings in the dialog box.

Rebuild: Clicking this button automatically rebuilds the identity system’s storage resources.
Rebuild Only Selected Servers: Use this option to rebuild the selected servers.
Refresh: Refreshes the resource list.

Performing Setup Procedures

9T0Z JaqwanoN TT (ud) sAsaop



4.3

6 Click the > for each server to browse the storage resources.

FR MAIN  FILE SYSTEMS  FILECONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

IDENTITY SYSTEMS ~ STORAGERESOURCES ~ FILE CONTENT  STORED REPORTS ~ NOTIFICATIONS  ENGINELOGS  FILE MAMAGEMENT  WES APPLICATION

L Discovery Options 7] Schedule  Rebuild 7 Refresh
Resource Operating System FDN FileSystem  Last Update Last Update Attempt Last Status
il Open Enferprise Server I=colec3.0U= 6/11/2018 1.55:33 PM 6/11/2018 1:55:33 PM
i@ NSMPROXYHOME Ext3
@ voL NSS.
@ voz Xfs
< >

Copyright 2018 & Condrey Corporation

Assigning Proxy Targets

File Reporter does not include a NetWare Agent. Furthermore, an Agent cannot be deployed on a
NAS device or server cluster. Additionally, only one Agent type (Legacy Agent, AgentFS, or AgentFC)
can be hosted on a server. Finally, some organizations might not want Agents deployed on every
server. In situations such as these, you can have a deployed Agent on another server function as a
proxy agent.

1 Select File Systems > Scan Agents.
All of the Agents are listed.

FR MAIN FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

SCANTARGETS ~ SCANPOLICIES — SCANDATA  SCANSIN PROGRESS — SCAN HISTORY  SCAN AGENTS

75 Refresh

Agent Server Version AgentType  Identity System Support Last Heartbeat Proxy Count  Status Message

E! i Gy Rl -—

Create Filter

Copyright 2018 & Condrey Corporation

2 Select the Agent you want to set up as a proxy agent and click Assign Proxy Targets.
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Assign Proxy Targets for cctec2.dynamics.cctec.org

Server

cctecldynamics.cctecorg

Server Type

Windows

Identity System

dynamics.cctecorg

3 Select the proxy targets and click OK.

4.4 Configuring Notifications

Notification parameters specify what types of notifications are listed and how email notifications are

sent.

1 Select Configuration > Notifications.

Performing Setup Procedures
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FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

IDENTITY SYSTEMS ~ STORAGE RESOURCES ~ FILE CONTENT  STORED REPORTS  NOTIFICATIONS  EMNGIME LOGS  FILE MANAGEMENT  WEB APPLICATION

Notification Settings
Only notify me about events of at least this severity level: Success -
Days to display nofifications in the dashboard: 30

D Enable Mail Notifications

Mail Settings

IP Address or Hostname

~

-

noreply@cctecorg
Use Authentication

mailuser

SAVE CHANGES

Copyright 2018 ® Condrey Corporation

Only notify me about events of at least this severity level: This field lets you specify the
severity level of events that are recorded and displayed in the Notifications page and through
email notifications.

The severity levels are listed from lowest to highest, with Success being the default setting.

If you change the severity level, File Reporter records and displays only the events for that
severity level and higher. Older notifications from formerly recorded severity levels continue to
be displayed in the Notifications page. For example, if you change the setting from Success to
Warning, only warning and error events are recorded, but the formerly recorded success and
info events are still displayed, unless you filter them out.

To avoid receiving emails for every successful event, you should modify this setting to a more
restrictive level.

Days to display notifications in the dashboard: This field indicates the number of days an
event is listed in the Notifications page.

Enable Mail Notifications: Clicking this activates the fields in the Mail Settings region of the
page.

Email notifications are sent to all members of the SrsAdmins group. File Reporter finds each
member’s email address from the primary identity system.

Mail Server: Specify the IP address or hostname of the mail server to use for sending the email
notifications.

Port: Specify the port number used by the mail server.
Connection Type: Specify the encryption type used by the mail server.

From Email Address: Specify the address you want displayed in the From field of the email
notifications that are sent.

Use Authentication: If your mail server requires authentication, select this.
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Username: Specify the mail server username.
Password: Specify the mail server password.

Minutes to buffer multiple notifications in a single email: File Reporter can consolidate
messages into a single email notification. If you change this setting to 5, File Reporter
consolidates all of the events that took place in 5 minutes and emails you a notification.

2 Specify your notification parameters and click Save Changes.

4.5 Integrating with File Dynamics or Storage
Manager

If you have Micro Focus File Dynamics or Micro Focus Storage Manager deployed, you can use
Micro Focus File Reporter to report on File Dynamics or Storage Manager policies. Before you can do
so, you must first specify the server address and port number of the server hosting the File Dynamics
or Storage Manager Engine.

IMPORTANT: File Reporter 3.5 integrates with File Dynamics 6.0 and above and Storage Manager
5.0 or above.

1 Select Configuration > File Management.

FR MAIN  FILE SYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

IDENTITY SYSTEMS STORAGE RESOQURCES FILE CONTENT STORED REPORTS NOTIFICATIONS ENGINE LOGS FILE MANAGEMENT WEB APPLICATION
3 Refresh

Engine Communication

Server Address

Port 3009

Copyright 2018 © Condrey Corporation

2 Specify the IP address or DNS name of the server hosting the File Dynamics or Storage
Manager Engine.

3 Specify the port number that the Engine is using.
The default port number is 3009.
4 Click save Changes.
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5.1

Scheduling and Performing File System
Scans

¢ Section 5.1, “Scans,” on page 41

¢ Section 5.2, “Adding a Scan Target,” on page 42

+ Section 5.3, “Removing a Scan Target,” on page 44

+ Section 5.4, “Creating Scan Policies,” on page 44

+ Section 5.5, “Establishing a Baseline Scan,” on page 49

+ Section 5.6, “Clearing a Baseline Scan,” on page 50

+ Section 5.7, “Editing a Scan Policy,” on page 50

+ Section 5.8, “Deleting a Scan Policy,” on page 50

+ Section 5.9, “Scheduling Scans,” on page 50

+ Section 5.10, “Editing a Scheduled Scan,” on page 52

+ Section 5.11, “Clearing a Schedule on a Scheduled Scan,” on page 52
+ Section 5.12, “Conducting an Immediate Scan,” on page 52
+ Section 5.13, “Viewing Scans in Progress,” on page 52

¢ Section 5.14, “Retrying Failed Scans,” on page 53

+ Section 5.15, “Viewing Scan Data,” on page 54

+ Section 5.16, “Viewing Scan History,” on page 54

+ Section 5.17, “Troubleshooting a Failed Scan,” on page 55

Scans

Through a Legacy Agent or AgentFS, Micro Focus File Reporter takes a file system “scan” of the file
system’s storage resource at a given moment. A storage resource can be a Micro Focus network
server volume or Microsoft network share.

File system scans are indexed data that are specific to a storage resource. They are the means of
generating a storage report or analytics views. Scans include comprehensive information on the file
types users are storing, when files were created, when they were last modified, permission data on
the folders where these files reside, and much more.

File Reporter collects file system scans from the Agents, compresses them, and sends them to the
Engine, where the Scan Processor takes them and uploads them to the database.

File system scans can be taken at any time, but we recommend using a scheduled time after normal
business hours to minimize the effect on network performance.

You should consider a number of factors as you decide how often to conduct a file system scan:

+ Although daily scanning always provides the most up-to-date information, scanning is not
throttled and might place a considerable load on the server hosting the Agent.

+ Most storage resources do not change rapidly enough to justify daily scanning.
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5.2

+ Monthly scanning places the least total load on individual servers and on the network, but scans
are not as up-to-date as they could be.

+ You can scan frequently-changing volumes more often and scan the more static volumes less
often.

+ Part of the decision concerning scanning frequency involves the primary purpose of the
reporting. Reporting on storage trending can generally use less frequent scans, but reporting
that is intended to solve immediate problems, such as “Who filled up this volume?” needs more
frequent scans.

+ When information is needed immediately, you can manually trigger a scan.

+ For installations where you are not sure of the optimal scanning frequency, you can start with
weekly scanning, and then adjust that interval based on the needs of the particular site.

Scan Retention

By default, File Reporter only retains the most current file system scan and permissions scan of a
storage resource. However, if you want to generate Historic Comparison reports, which let you
compare two scans of the same storage resource over two points in time, you will need to specify that
scans be retained. Depending on the retained scan type, this is done either manually or automatically.

Manual Retention

You can specify that a file system or permissions scan be retained indefinitely as a “Baseline scan” by
manually specifying it in the Scan Data page. For procedures and more information on Baseline
scans, see Section 5.5, “Establishing a Baseline Scan,” on page 49.

Automatic Retention

Within the scan policy, you can specify that the last file system scan or permissions scan be retained
when a new file system scan or permissions scan is conducted. This version is known as a “Previous
scan.” For procedures and more information on Previous scans, see Section 5.4, “Creating Scan
Policies,” on page 44.

Adding a Scan Target

All volumes and shares must first be specified as a scan target before they can be scanned.

1 Select File Systems > Scan Targets.
2 Click Add.
3 Click the > to view the volumes and shares of the listed servers.
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Resource Filter:

O

O
O
O
O
O
O
O

O
O
O

Storage Resource Browser

Apply Filter

‘Wdynamics.cotec.org\DFS\HOV\HQUsers
‘Wdynamics.cctec.org\DFS\London\LondonShare
YWdynamics.cctec org\DFS\London\LondonUsers
YWdynamics cctec org\DFS\Munich\MunichShare
Yidynamics.cctec.org\DFS\MunichiMunichUsers
YWdynamics.cotec.org\DFS\NYC\NY CShare
YWdynamics.cotecorg\DFS\NYC\NY CUsers

‘“Wdynamics.cotec.org\DFS\SFONSFOUsers

¥  CCTEC_TREE

WCCTECIA\NSMPROXYHOME
WCCTECS\WOLL

WCCTEC3\WVOL2

MNTFS

MNTFS

NTFS

NTFS

NTFS

NTFS

NTFS

MNTFS

M55

Xfs

Refresh

CANCEL

4 Select the volumes and shares you want File Reporter to be able to scan and click OK.
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The scan targets are added.

FR MAIN FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

SCAN TARGETS SCAN POLICIES SCAN DATA SCANS IN PROGRESS SCAN HISTORY SCAN AGENTS
€ Add ] Y3 Refresh W& Rebuild Storage Resources
Drag  column header here 1o group by that column
D Identity System Target Path File System d
E SCTEETREE i A
D CCTEC_TREE WCCTEC3\VOL1 NSS 10
[ ccrec_Tree WCCTECWOL2 Xfs 1
[ cynamicscctecorg \\dynamics cctec org\DFS\Atlanta\AtlantaShare NTFS 2
D dynamics.cctecorg W\dynamics.cctec.org\DFS\Atlanta\AtlantaUsers NTFS 3
[ dynamicscctecorg \dynamics cetec org\DFS\HA\H@Share NTFS 12
[ cynamicscctecorg \\dynamics cctec org\DFS\HO\HGUsers NTFS 13
D dynamics.cctecorg \dynamics.cctec.org\DFS\London\LendenUsers NTFS E Y
Page 1 of 1 (13 items) o
Create Filter
Copyright 2018 © Condrey Corporation

5.3 Removing a Scan Target

1 Select File Systems > Scan Targets.

2 Select the check box pertaining to the volume or share you want to remove as a scan target and
click Delete.

3 When the confirmation dialog box appears, click Yes.

5.4 Creating Scan Policies

The specifications for a scan are established in a scan policy. The scan policy specifies the following
parameters:

+ What type of scan to conduct (File System, Permissions, or Volume Free Space)

+ The scan targets

¢ Scan retry settings

¢ The scan schedule

IMPORTANT: The scan policy name must be unique. If you attempt to give the scan policy an
existing name, File Reporter generates an error.

1 Select File Systems > Scan Policies.
2 Click Add.
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Mew Scan Policy

Policy Mame ‘ |

Policy Type

O Permissions

O Yaolume Free Space

3 Inthe Scan Policy Name field, specify a name for the scan policy.

You can provide a description of the policy in the next dialog box.
4 Select the type of scan that File Reporter is to conduct.

File System: Scans the files currently stored on the network volume or share, the size of those
files, when the files were last accessed, the locations of duplicate versions, and so forth.

Permissions: Scans the rights, trustee assignments, and permissions pertaining to the folders
stored on the volumes or shares.

Volume Free Space: Scans the availability of free space on the volumes or shares.
5 Click OK.
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Scan Policy Editor

Name:* Munich Users FS Scan Policy

Description: File System scan for Munich Users share

Retry Count: 3 ¢

Retry Interval: 60 & Minutes A

Directory Quotas: Scan Directory Quotas

MNote that this may take a significant amount of fime.

Previous Scans: D Save Previous Scan
Add  Remaove
Target Path

Name: Displays the name of the scan policy.
Description: Specify a description of the scan policy in this field.

Retry Count: Specify the number of times File Reporter attempts to scan the storage resource
targets listed in the scan policy if there is a failure.

Retry Interval: Specify the amount of time before File Reporter retries scanning the storage
resource targets listed in the scan policy if there is a failure.

Directory Quotas: By default, a scan does not include home folder quota information, because
gathering this information on Windows shares can extend the scan time significantly. Unless you

plan to generate a Directory Quota report, we recommend that you leave this option deselected.

This option applies only to File System scans.
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Previous Scans: This option lets you specify whether to keep the previous version of a scan
generated through this policy. This scan is known as the “Previous scan” which you can then use
to generate a Historic Comparison report through a comparison with either a Baseline scan or a
“Current scan.” For more information, see Section 6.8, “Historic Comparison Reports,” on

page 86.

Previous scans are designated whenever a new scan is performed. The new scan is the Current
scan and the earlier scan becomes the Previous scan. When the target paths are eventually
scanned again, the new scan becomes the Current scan, the earlier Current scan becomes the
Previous scan, and the former Previous scan is deleted.

NOTE: If you want to maintain a scan indefinitely, you can do so by specifying it as a Baseline
scan. For more information, see Section 5.5, “Establishing a Baseline Scan,” on page 49.

The management of Previous scan retention occurs when processing a new scan. This means
that if you deselect Retain existing Previous scan, no existing Previous scan will be removed at
that time, but it will be removed when a new scan is processed.

Add: Click this option to specify the scan targets for the scan policy.

IMPORTANT: After a target has been added to a scan policy, the same target cannot be added
to another scan policy of the same scan policy type. For example, if you specify \\Pinyon\Vol1l
in one File System scan, you cannot specify the same volume in another File System scan.

Clicking Add brings up a dialog box like the one below where you can select available storage
resources.
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Scan Target Browser
Identity System Target Path
D CCTEC_TREE WCCTECIANSMPROXYHOME
D CCTEC_TREE WCCTEC3WOL1
I:I CCTEC_TREE WCCTEC3WOL2
D dynamics.cctec.org \\dynamics.cctec.org\DFS\AtlantalAtlantaShare
D dynamics.cctec.org Yidynamics.cotec org\DFS\Atlanta\Atlantallsers
D dynamics.cctec.org YWdynamics.cotec.org\DFSYHOWHQShare
D dynamics.cctec.org Yidynamics.cctec.org\DFSYHOQWHQUsers
D dynamics.cctec.org YWdynamics.cotec.org\DFS\LondonLondonUsers
E Wdynamics. coctec org\DFS\Munich\MunichShare
I:I dynamics.cctec.org \\dynamics.cctec.orghDFS\Munich\MunichUsers
Page 1 of 2 (13 items) o 2 ?
“ CANCEL
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6 Click OK to save the scan policy.
The scan policy is now displayed on the Scan Policies page.
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5.5

FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION A DYNAMICS\Administrator

SCAN TARGETS SCAN POLICIES SCAN DATA SCANS IN PROGRESS SCAN HISTORY SCAN AGENTS

@ Add X | & jo 3 Refresh

I:l Policy Name Scan Type Target Paths Save Previous Schedule Refry Count Retry Interval id

O $p Atlanta File System File System Data 2 No [Not Scheduled] 3 60 minutes 1

O B Atlanta User Permissions Permissions 1 No [Not Scheduled] 3 60 minutes 5

O B CCTec Vol 1 Permissions Permissions 1 Yes [Not Scheduled] 3 60 minutes 3

O D HQ File System File System Data 1 No [Not Scheduled] 3 60 minutes 7

O D HQ Users File System File System Data 1 No [Not Scheduled] 5 60 minutes 6
$ London Users Permissions Permissions [&] Not Scheduled] 60 minutes

E Sl e ey -n SRR -m-

Volume Free
5 SFO Trending (Yes) [Not Scheduled] 60 minutes

Space
Page 1 of 1 (8 items) o

Create Filter
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The scan policy still needs to be scheduled. For procedures on scheduling scans, go to
Section 5.9, “Scheduling Scans,” on page 50.

Establishing a Baseline Scan

A Baseline scan is a scan that you save as a reference for a comparison with another scan. You
compare scans when you generate a Historical Comparison report. Unlike a Previous scan, which
gets replaced as a new Current scan is created, a Baseline scan is retained indefinitely until you
decide to delete it. You can have only one Baseline scan per scan target.

IMPORTANT: Because you can have only one Baseline scan per scan type for a scan target,

establishing a scan as a Baseline will override any established Baseline scan of the same scan type

for the same scan target.

1 Select File Systems > Scan Data.

2 In the far left column, select the check box pertaining to the scan you want to set as a Baseline
scan.

3 Click Set Baseline.
4 When the confirmation dialog box appears, click Yes.
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5.6

5.7

5.8

5.9

Clearing a Baseline Scan

Scans designated as Baseline scans are retained until the baseline designation is cleared. If a
Baseline scan that is in the Retained state has its Baseline status removed, that scan will be
immediately marked for deletion.

1 Select File Systems > Scan Data.

2 In the far left column, deselect the check box pertaining to the scan you want to clear as a
Baseline scan.

3 Click Clear Baseline.
4 When the confirmation dialog box appears, click Yes.

Editing a Scan Policy

1 Select File Systems > Scan Policies.

2 Click the check box that pertains to the scan policy that you want to create a edit.
3 Click Edit.

4 Change any of the settings you wish.

5 Click OK.

Deleting a Scan Policy

1 Select File Systems > Scan Policies.
2 Click the check box that pertains to the scan policy that you want to delete.
3 Read the warning and click Yes.

Scheduling Scans

1 Select File Systems > Scan Policies.

2 Click the check box that pertains to the scan policy for which you want to create a schedule.

3 Click Edit Schedule.
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Schedule for Munich Users FS Scan Policy

SCHEDULE START
Engine Local Time:* 12:00 AM o
Engine Local Start Date:* | 6/12/2018 v

SCHEDULE RECURRENCE

O onee
@ Daiy
O weeky
O Monthly
Day

The

Engine Local Time: Specify the time that you want the scan to begin.

The time you select is based on the time zone where the Engine is located and not the Agent
that conducts the scan.

Engine Local Start Date: Specify the date when you want the scan schedule to take effect.

Be aware that entering a date does not mean that the scan takes place on that date. If the
Engine Local Start Date is set for today, which is a Monday, but the Schedule Recurrence setting
is set for Weekly on Sunday, the scan does not take place until Sunday.

Once: Select this option to scan the storage resources specified in the scan policy only once.
Daily: Select this option for a daily scan of the storage resources specified in the scan policy.

Weekly: Select this option and specify a weekday for a weekly scan of the storage resources
specified in the scan policy.

Monthly: Select this option and specify a day for a monthly scan of the storage resources
specified in the scan policy.

4 Specify the scheduling parameters and click OK.
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5.10

5.11

5.12

5.13

Editing a Scheduled Scan

1 Select File Systems > Scan Policies.

2 Click the check box that pertains to the scan policy for which you want to edit a schedule.
3 Click Edit Schedule.

4 Make the schedule changes you want.

5 Click OK.

Clearing a Schedule on a Scheduled Scan

1 Select File Systems > Scan Policies.

2 Click the check box that pertains to the scan policy for which you want to clear a schedule.
3 Click Clear Schedule.

4 When the confirmation prompt appears, click Yes.

Conducting an Immediate Scan

1 Select File Systems > Scan Policies.

2 Click the check box that pertains to the scan policy for which you want to conduct an immediate
scan.

3 Click Scan Now.
4 When the confirmation prompt appears, click Yes.

Viewing Scans in Progress

You can view details on the scans that are in progress through the Scans in Progress page. When the
scan has been completed, you can view the details in the Scan History page.

1 Select File Systems > Scans in Progress.
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FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFICURATION S DYNAMICS\Administrator

SCAN TARGETS  SCANPOLICIES  SCANDATA  SCANS INPROGHESS  SCANMESTORY  SCAN AGENTS

T Refresn

Scami  EcanTarget Ecan Palicy Scan Type Agemt Start Time Srarun Try € Haxt Retry Tiems Lat Brrar

Alanta User

WeynamicLoCtec or\DFSANaTa\ATantspees Permissions CCTEC2 S/L2/2010 121554 P
Fermmassacon

— “ : s . MusichUneis FScan o R E - . {0 Operation
a 10 aynamicsectec oD Manichsers L ile System Data cCrEce A12/2010 1295 54 PH Sean in Progress o el

Landon Users

|} § MamamcwocheconfiOFiLendonLondonsen - L Permissions 7127010 121534 FH wasting for Resry 1 612008 12500 PM byl
serured

o] - - . . TG OO 10 m () Operation

[ Vichymiar arg\DFFUANLantaAllants) flanta File Syatem i em Dt CCTECT 1272018 122534 PH Sean in Progress

(] L adymamica.cchecony UATlanta\Allantalbvers Adlanta File System Fite Syatem Data CTE 41272018 121534 PH Kan oI L] sacoesshil

(m] T ynamicLOcte o DR SUATI T ATINES e ATIgnits File System

CCTECY SI1LI01 121534 PM Sean in Progiess o

Create Fitter
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As you click Refresh, the completed scan listings are removed and listen in the Scan Data and
Scan History pages.

5.14 Retrying Failed Scans

In the Scan Policy Editor dialog box, the default scan policy settings for Retry Count is three and the
Retry Interval is 60 minutes. You can adjust each of these settings. Assuming the default settings are
not adjusted, File Reporter retries the scan in 60 minutes and only retries to scan up to three times.

Until File Reporter has attempted all three retries, the failed scans remain listed on the Scans in
Progress page. After all retries have been performed, the scan listing is moved to the Scan History

page.

As long as a filed scan is listed on the Scans in Progress page, you can retry the scan manually by
doing the following:

1 From the Scans in Progress page, select the check box corresponding to the failed scan.
2 Click Retry.
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5.15 Viewing Scan Data

The Scan Data page lets you view a minimal set of details pertaining to the currently available scans

for each scan target.

1 Select File Systems > Scan Data.

FILESYSTEMS FILE CONTENT  REPOH

[ =] 3 Retresh

[T seanta  ScanTarget Scan Type

Vieynamics.cobec ong\DFS\MunichiMunichUsers. | File System Data

11 Vlynamics ectee seg\DFS\ATAntA\Atiantalisers  Permissions

arg\DFSAtantaAtian File System Data

e g\DPRAN A\ AllarntaShate  File System Date

O 00 O g

Vielyramics. cetoe arghDFESY ool andoriers.  Brereminsions,

Fage 10l 165 ilems) °

] [5tate] Is arvy of CCurrent”. Previows”, Retained)

671272018 121534 PM

Currens False AA201A 121534 PM

Currens Fase 018 1241534 PM

Cusrent Fabe AM2/I01R 121534 PH

[ — Trus AT/I0UR DRTAR P

Copyright 2018 € Candrey Corparation

5.16 Viewing Scan History

The Scan History page displays a complete history of all scans, along with details of the scan and
some basic information of the storage resource at the time of the scan, including the file and folder

count.

1 Select File Systems > Scan History.

FR MAIN  FILESYSTEMS
15 Rrfresn
Fean W Start Tima eam Targat Sean Palicy
8 | &/13/7018 131534 PM yramicsertecorg  Atlanta Flie System
T AM272008 121534 PM \itymamics erincorg Ataanta Flie Syshem
& &/TFI018 25352 PM Wtyramicserteeorg Atanta Fiie System
5 &/F/I018 2636 M \iyramics ectec org  Attanta Fiie System
2e% Lundon Users
4 AFI018 2SRIEPM etyrare
&7F mamicsertecorg LR 8
i Longn Users
3 ATI018 146 M e
¥ ymamics eetecarg | PO
I /20101306 EM W mamiCscTecong ATt File System
1 G018 1IN M WA CTeCon AT File System
Create Filter
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SCANTARGETS  SCANPOLICIES  SCANDATA  SCANS INPROGRESS  SCANMISTORY  SCAN AGENTS

Munich Users F5 Scan

Policy

Atlanla User

CCTEC?
Permissions
Arianta Flle System CCTEC?
Ablanta File Syabem. CCTEC?
Lordon Users A
Permissions

SCAMTARGETS  SCANPOLIIES SCANDATA  SCANSINPROGRESS  SCAN MISTORY — SCAM AGENTS

Z Darabase
S<an Typs Agent S<an Duration Bk
File System Data CCTEC? DA O00000 000 00 BOH0000 263
Filr System Data CCTEC? OO OGO D0 00 OOO000 544
File System Darta CCTEC? G O0HO0HI1 000 00 (00000 333
Flle System Data CCTEC? DAO0O0HT1 000 00 DOH0000 207
Permissions CCTEC? DADOOHT 000 00 D000 540
Permisians CCTEC? DA O0O0H04 000 00000007 290
File System Data OELO00.000 OOLODE000.000
File System Data DODRO000,000 DOLE00.000

Cogryright 2018 8 Comlrey Crmpraintion

Fils Count

£ DYNAMICS\Administrator
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(0 Operation successtul

100 Operation successtul

Clear

& DYNAMICS\Administrator

i
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36 (0 - Success
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& (0 Success
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v
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You can click the columns to list the data in ascending or descending order.

Because the Scan History page logs each successful scan, the most efficient way of locating a
scan is using a filter.

5.17 Troubleshooting a Failed Scan

1 Verify that the Agent service is running properly on its host machine.

2 Verify that the host machine where the Agent is installed has enough free disk space to
temporarily store a copy of the scan in its uncompressed and compressed form.

3 If an Agent is not installed directly on the server with the storage resource you want to scan,
verify that a proxy assignment for the storage resource has been established.

4 If the proxy agent is not scanning, assign the storage resource from a different proxy agent and

try scanning again.

5 When scanning Windows storage resources, verify that the proxy rights group has been
assigned the proper rights to the share.

The proxy rights group must be assigned to the builtin\administrators group or the local
administrators group on the server where the scan is being conducted.

6 Verify that the Windows Firewall is configured to permit network traffic to flow between the
Engine and the Agent.

For more information on the Windows Firewall, see Section B.2, “Firewall Requirements,” on
page 153.
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6 Generating File System Reports

6.1

¢ Section 6.1, “Overview,” on page 57

+ Section 6.2, “Changing Your Cover Sheet Branding,” on page 58

¢ Section 6.3, “Changing the Report Data Font,” on page 59

+ Section 6.4, “Built-in Report Types,” on page 60

+ Section 6.5, “Directory Data Reports,” on page 60

+ Section 6.6, “Permissions Reports,” on page 71

¢ Section 6.7, “File Data Reports,” on page 76

+ Section 6.8, “Historic Comparison Reports,” on page 86

¢ Section 6.9, “Trending Report,” on page 91

¢ Section 6.10, “Custom Query Reports,” on page 92

¢ Section 6.11, “Unformatted Reports,” on page 95

+ Section 6.12, “Micro Focus File Dynamics and Storage Manager Policy Reports,” on page 96
¢ Section 6.13, “Scheduling Reports,” on page 96

¢ Section 6.14, “Editing a Scheduled Report,” on page 98

¢ Section 6.15, “Clearing a Schedule on a Scheduled Report,” on page 98
+ Section 6.16, “Copying a Report Definition,” on page 98

+ Section 6.17, “Viewing Reports in Progress,” on page 99

+ Section 6.18, “Troubleshooting Reports,” on page 100

Overview

After you have conducted scans on storage resources, Micro Focus File Reporter has the content
needed to generate reports. The type of report you can generate depends on the type of scan that
you have conducted. For example, in order to create an Assigned NTFS Permissions report, a
Permissions scan on a Windows share must first be conducted.

All reports are created by first creating report definitions. The report definition specifies the report
name, type, target path to the scans, and more.

IMPORTANT: The report definition name must be unique. If you attempt to give the report definition
an existing name, File Reporter generates an error.

File Reporter has built-in aggregate reporting capabilities, meaning that you can specify multiple
target paths in the same report. Additionally, File Reporter has built-in scoping, which allows you to

browse through the file path or identity system and specify the level where you want to start reporting

data. Finally, Boolean filtering is available for all File Data Reports. For more information, see
Appendix A, “Filtering,” on page 147.

When the definition has been saved, you can generate the report immediately, or schedule it to be
generated.
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You can generate reports in either Preview or in Stored Report mode. Preview lets you view the report
where you can save it locally if you want to. Stored Report saves the report to the server hosting the
Engine, where it remains for a set amount of days.

You can generate Detailed Reports from certain built-in report types. For example, a File Extension
Report can be the means of generating a Detailed Report that includes the specific details of all of the
*_mov files.

All built-in reports include a cover sheet that you can customize to include your organization’s logo.

6.2 Changing Your Cover Sheet Branding

All generated built-in reports include a cover sheet that includes a default graphic. If you want, you
can replace it with your organization’s logo.

1 Select Reports > Report Definitions.
2 Select Report Branding and Styling > Report Branding.

Images must meet the following criteria:
* | gsg than ane megabyte (1 MB)
s« Dimensions no larger than S00x:00 pixels
* File formaf is one of the following:
= PNG (™" png)
= JPEG (“jpg. “jpeq)
= BMP " bmpl

Report Branding

Company Mame:

Company Logo:

Browse__ RESET

=

3 Inthe Company Name field, specify the name of your organization.
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6.3

This is the name that appears on the front cover.
4 Click Browse, then browse to and replace the default logo with a new logo.

Report Branding

Company Mame: | CCTEC

Images must meet the following criteria:
s | gsg than one megabyte (1 MB)
* Dimensions no larger than S00x400 pixels
s Fjle formaf is one of the following:
= PNG (™png)
= JPEG ("jpg. “jpeg?
= BMP " bmp)

Browse__ RESET

e [T

5 Click Save.

Changing the Report Data Font

Due to limitations of font encoding in PDF files, you might need to specify an alternate report data
font. Locales that have multi-byte characters or characters outside the Latin-1 set of characters
supported by the default font are especially at risk.

If you know the collected data is limited to a specific locale or language, choose a font that properly
displays all characters for that locale or language.

If the collected data might contain characters that span multiple locales or that include both multi-byte
and Latin-1 characters, for example, choose an appropriate Unicode Font that can accurately display
most characters from the Unicode set and not just a specific locale.

Two Unicode fonts known for having both good Unicode character coverage and good glyph
presentation are MS Arial Unicode (a sans-serif font) and CODE2000 (a serif font).
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6.4

6.5

For more information on these fonts and on Unicode fonts in general, see http://en.wikipedia.org/wiki/
Unicode_font.

NOTE: You can change the data font to any font that is available on the server hosting the Web
Application.

Headers and parameters in the reports remain in the default Arial font.

To change the report data font:

1 From the Reports menu, select Report Definitions.
2 From the Report Branding and Styling drop-down menu, select Report Data Font.

3 From the Report Data Font Name drop-down menu, select the font you want displayed in the
report.

4 Click Save.

Built-in Report Types

File Reporter has five different built-in report type classifications:

+ Directory Data

+ Permissions

+ File Data

+ Historic Comparison
+ Trending

Each classification includes one or more report types. For example, in the Permissions category,
there are four different reports that can be generated.

For more information about the procedures for generating built-in reports according to classification,
see the following sections:

+ Section 6.5, “Directory Data Reports,” on page 60

*

Section 6.6, “Permissions Reports,” on page 71

*

Section 6.7, “File Data Reports,” on page 76

*

Section 6.9, “Trending Report,” on page 91

*

Section 6.11, “Unformatted Reports,” on page 95

Directory Data Reports

Reports in this classification include Summary, Directory Quota, Storage Cost, and Comparison
Reports.

Before generating any type of Directory Data report, you must first conduct a File System scan on the
volumes or shares you want to report on.

¢ Section 6.5.1, “Generating a Summary Report,” on page 61

+ Section 6.5.2, “Generating a Directory Quota Report,” on page 68
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¢ Section 6.5.3, “Generating a Storage Cost Report,” on page 69

+ Section 6.5.4, “Generating a Comparison Report,” on page 70

6.5.1

Generating a Summary Report

Summary reports provide a summary of the contents of folders according to a specified level in the

file system.

1 Select Reports > Report Definitions.

2 Click Add.

@)
@)
O
@)

@)
O
@)
@)

O

Name:*

Add Report Definition

Directory Data

Summary

Directery Quota

Permissions

Assigned NCP Permissions

Assigned MTFS Permissions

Permissions by Path

Permissions by ldentity

Trending

Volume Free Space

File Data

QO Filename Extension
O ouwner

(O Duplicate File
QO Date-rge

Histeric Comparison

O File System Comparison

Unformatted: D Create report as Unformatted (for use with Text, Csv, or Xls exports)

o Filename Extension Detail

O Owner Detail
O Duplicate File Detail

O Date-Age Detail

O MCP Permissions Comparison

o NTFS Permissions Comparison

Custom Query

O Custom Query Report

3 In the Name field, specify a descriptive name of the report definition.

For example, User Volume Summary Report.

The name can contain up to 64 alphanumeric characters.

4 Select the Summary option and click OK.
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Report Definition Editor - Atlanta User Share Summary Report

MName:* Atlanta User Share Summary Report Report Path Depth 0o £
T Summary Report
Initial Chart Path Depth o ¢
Description: Report Definition created on 6/13/2018 9:15:15 AM by . .
DYNAMICS\Administrator o A Report Path Depth greater than 3 or 4 may result in significant report
size and processing time.
TARGET PATHS FILE MANAGEMENT POLICIES

Add Remove

arget Path

5 Inthe Report Path Depth field, specify the depth of reporting.

For example, if you select 3, the Summary report lists the file contents of all file paths in the
specified shares up to 3 levels in the file structure.

For example, for a server named Las Vegas, the Summary report would list the contents of these
paths:

\\lasvegas.nvb.local\Usersl

\\lasvegas.nvb. local\Usersl\a

\\lasvegas.nvb. local\Usersl\a\stuff
\\lasvegas.nvb. local\Usersl\a\stuff\morestuff

In the Initial Chart Path Depth field, specify the initial path depth for inclusion in the Top Ten
Folders by Size chart that is displayed in the report header section.

This is important so that when the Report Path Depth is greater than zero, the top level folders
are now conditionally included. The Chart Path Depth parameter is not allowed to be greater
than the currently specified Report Path Depth.

7 From the Target Paths tab, click Add.
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Scan Data Browser - File System Data

v+ N CCTEC_TREE

» BB dynamics.cctecorg

CANCEL

8 Click the > to browse to and select the file paths you want included in the report, then click OK.

You must expand the eDirectory tree or Active Directory forest to be able to select the volumes
or shares, even if you want to select the root of the eDirectory tree or Active Directory forest.

9 Click Save.

The report definition is added to the list.
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FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator
REFORT DEFINITIONS ~ REPORTS IN PROGRESS ~ FOLDER SUMMARY ~ STORED REPORTS
) Add [5] Schedule ~ Generate Report Branding and Styling 3 Refresh
ds P by o {l
O Name Report Type Targets File Management Policies ~ Report Owner Schedule id
o a &l sttt User Shre Summary 1 0 dynamics\administrator [Not Scheduled] 1

Summary Report

Page 1 of 1 (1 items) °

Create Filter

Copyright 2018 © Condrey Corporation

9T0Z JaqwanoN TT (ud) sAsaop

10 Do one of the following:

+ Generate the report in Preview mode by following the procedures under “Generating a
Preview Report” on page 64.

+ Generate the report in Stored mode by following the procedures under “Generating a Stored
Report” on page 66.

Generating a Preview Report

A preview report is generated from scan data in the database and is temporarily cached in the Web
application's data folder. When you close a preview report, you cannot access the report again until
you generate a new one using the same report definition.

When you view a report in Preview mode, you can print the report or save the report locally.

1 From the Report Definitions page, select the report definition from which you want to generate a
report.
2 Select Generate > Generate Preview.

3 (Conditional) If you get a message stating that your browser prevented pop-up windows from
appearing, enable pop-ups for this site.
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(& https://filereporter.dynamics.cetec.org/Trpt_id=18&rpt_type=Summary - File Reporter 3.5 - Internet Explorer - ] et

E = Page 1 v~ of 4 » ¥ B B er -

¥ Summary
Parameters
Top 10 Folders by File Size

¥ Report Data

Summary Report

CCTEC

Report Date:  6/13/2018 10:15:41 AM
Generated by: File Reporter

File Reporter Page 1 of 4

All reports are structured similarly, with a title page, report parameters, for some report types a

Top Ten summary, followed by a comprehensive breakdown of the data in the pages that follow.

Display the Search Window button: Lets you conduct a search within the preview report.
Print the Report button: Prints the entire preview report.

Print the Current Page button: Prints the currently displayed page.

First Page button: Takes you to the first page of the preview report.

Previous Page button: Takes you to the page that precedes the page you are viewing.
Page drop-down menu: Lets you advance to a page number by selecting it.

Next Page button: Takes you to the page that follows the page you are viewing.

Last Page button: Takes you to the last page of the preview report.

Export a Report and Save it to the Disk button: Exports the preview report to the file type
listed in the drop-down menu and lets you view or save it in the new format.

Export a Report and Show it in a New Window button: Exports the preview report to the file
type listed in the drop-down menu.
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File Type drop-down menu: Lets you select the file type format to export the report to.

Document Navigation: Lists the contents of the report. You can click any item to advance within

the preview report.
4 Export, save, or print the preview report.

Generating a Stored Report

Generating a report in Stored mode means that the report is saved and available for access for a set
number of days from the time it is generated. Of course, you can save the report locally where you

can keep it indefinitely.

1 From the Report Definitions page, select Generate > Generate Stored Report.
2 Select Reports > Stored Reports.

FR MAIN  FILE SYSTEMS  FILE CONTENT REPORTS CONFIGURATION A DYNAMICS\Administrator

REPORT DEFINITIONS REPORTS IN PROGRESS FOLDER SUMMARY STORED REPORTS

3 Refresh

Name Size Report Type Report Time Expiration Date d

4 Aflanta User Share Summary

O & gen

2035KB  Summary 6/13/2018 10:57:48 AM 7/13/2018 12:00:00 AM

Page 1 of 1.(1 items) o

Create Filter

Copyright 2018 @ Condrey Corporation

3 Click the report you want to view.

4 (Conditional) If you get a message stating that your browser prevented pop-up windows from
appearing, enable pop-ups for this site.
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(& https://filereporter.dynamics.cetec.org/Trpt_id=18&rpt_type=Summary - File Reporter 3.5 - Internet Explorer - ] et

E = Page 1 v~ of 4 » ¥ B B er -

¥ Summary
Parameters
Top 10 Folders by File Size

¥ Report Data

Summary Report

CCTEC

Report Date:  6/13/2018 10:15:41 AM
Generated by: File Reporter

File Reporter Page 1 of 4

All reports are structured similarly, with a title page, report parameters, for some report types a

Top Ten summary, followed by a comprehensive breakdown of the data in the pages that follow.

Display the Search Window button: Lets you conduct a search within the preview report.
Print the Report button: Prints the entire preview report.

Print the Current Page button: Prints the currently displayed page.

First Page button: Takes you to the first page of the preview report.

Previous Page button: Takes you to the page that precedes the page you are viewing.
Page drop-down menu: Lets you advance to a page number by selecting it.

Next Page button: Takes you to the page that follows the page you are viewing.

Last Page button: Takes you to the last page of the preview report.

Export a Report and Save it to the Disk button: Exports the preview report to the file type
listed in the drop-down menu and lets you view or save it in the new format.

Export a Report and Show it in a New Window button: Exports the preview report to the file
type listed in the drop-down menu.
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File Type drop-down menu: Lets you select the file type format to export the report to.
Document Navigation: Lists the contents of the report. You can click any item to advance within

the report.
5 Save or print the stored report.

6.5.2 Generating a Directory Quota Report

68

Directory Quota reports specify folders with assigned quota, the amount of quota assigned, and the

amount of quota consumed.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive hame of the report definition.
4 Select the Directory Quota option and click OK.

Report Definition Editor - HQ Users Directory Quota Report

Name:* HQ Users Directory Quota Report

Unformatted: D

Type: Directory Quota Report

Description: Report Definition created on 6/13/2018 11:45:53 AM by
DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES

Add Remove

arget Path

From the Target Paths tab, click Add.

Browse to and select the file paths you want included in the report and click OK.
Click save.

Generate the report as either a Preview report or a Stored report.

0 N o O

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.
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6.5.3

Generating a Storage Cost Report

Storage Cost reports indicate storage costs according to prices established in the Cost per Unit
setting of the Report Definition editor. You can use this report to determine which users or groups are

being irresponsible with network storage practices.

NOTE: When the report is generated, the monetary symbol that is displayed comes from the local
Engine/Web server's Windows locale and region settings. For example, if the Windows server hosting
the engine and Web application is set up using US locale and region, it will show a $ for costing
displays in the report.

1 Select Reports > Report Definitions.
2 Click Add.
3 In the Name field, specify a descriptive name of the report definition.

4

© 00 N o O

10

Select the Storage Cost option and click OK.

Report Definition Editor - Atlanta Users Storage Cost Report

Mame:™ Atlanta Users Storage Cost Report

Unformatted: D

Type: Storage Cost Report

Description: Report Definition created on 6/13/2018 12:16:55 PM by
DYMNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES

Cost per Unif:"

GE

10

In the Unit drop-down menu, select the storage unit value for which you want to establish a cost.

In the Cost per Unit field, indicate the cost of the selected storage unit.

From the Target Paths tab, click Add.

Browse to and select the file paths you want included in the report and click OK.

Click Save.

Generate the report as either a Preview report or as a Stored report.
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For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

6.5.4 Generating a Comparison Report

70

A Comparison report specifies the differences between two selected folders on the network. This is
useful if you want to verify that servers are hosting the same version of software, library files on
servers are the same, and so forth.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.

4 Select the Comparison option and click OK.

Report Definition Editor - HQ Share Users Comparison Report

Mame:* HQ Share Users Comparison Report Results: Show unigue paths from both targets -

Unformatied: []

Comparison Repart

Description: Report Definition created on 6/13/2018 12:44:45 PM by
DYNAMICS\Administrator

TARGET PATHS

5 Inthe Comparison Results drop-down menu, select an option.

Show unique paths from both targets: The report indicates the differences in folder and file
names for the compared target paths.

Show paths unique to the first target: The report indicates only the unique folder and file
names found in the first target path.

Show paths unique to the second target: The report indicates only the unique folder and file
names found in the second target path.

6 From the Target Paths tab, click Add.

7 Browse to and select two volumes, shares, or folders whose data you want to compare and click
OK.
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6.6

6.6.1

8 Click Save.
9 Generate the report as either a Preview report or as a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

Permissions Reports

Reports in this classification include Assigned NCP Permissions, Assigned NTFS Permissions,
Permissions by Path, and Permissions by Identity.

NOTE: The term “Permissions” in File Reporter includes NTFS permissions as well as NCP rights
and trustee assignments.

Before generating any type of Permissions report, you must first conduct a Permissions scan on the
volumes or shares you want to report on.

+ Section 6.6.1, “Generating an Assigned NCP Permissions Report,” on page 71

+ Section 6.6.2, “Generating an Assigned NTFS Permissions Report,” on page 73

+ Section 6.6.3, “Generating a Permissions by Path Report,” on page 74

+ Section 6.6.4, “Generating a Permissions by ldentity Report,” on page 75

Generating an Assigned NCP Permissions Report

The Assigned NCP Permissions report indicates the assigned Micro Focus (formerly Novell) file
system rights and trustee assignments for all folders and subfolders from a specified path.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive hame of the report definition.

4 Select the Assigned NCP Permissions option and click OK.
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Report Definition Editor - CCTEC3 Volume 1 NCP Permissions Report

Name:* CCTEC3 Volume 1 NCP Permissions Report [ Limit Path Depth

Unformatted: D

ype: Assigned MCP Permissions Report

Description: Report Definition created on 6/13/2018 1:56:46 PM by
DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES

5 (Conditional) If you want to limit the scope of the report to a set depth in the file structure, click
the Limit Path Depth check box and specify the depth level.

For example, if you specify 3, the report lists the file contents of all file paths in the specified
target paths up to 3 levels in the file structure.

If you do not specify a path depth, File Reporter will report on all levels of the specified target
path.

6 From the Target Paths tab, click Add.
7 Browse to and specify the file paths you want included in the report.
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Scan Data Browser - Permissions Data
- N CCTEC_TREE -
" [0 @ WccTECsWOLL
T D = Atlanta
v D = Employees
» D == ajames
* D = AMance
* [J 5 AReid
4 D == ELawson
* D = ENabors
r D =5 CEdwards
4 D = DAdams
* D = DBetts
r D & DThomas "
b1 = iMerned
“ CANCEL

8 Click OK to close the Scan Data Browser.
9 Click save to close the Report Definition Editor.
10 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

6.6.2 Generating an Assigned NTFS Permissions Report

The Assigned NTFS Permissions report indicates the assigned Microsoft file system user
permissions for all folders and subfolders from a specified path.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.
4 Select the Assigned NTFS Permissions option and click OK.
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Report Definition Editor - London Users Assigned NTFS Permissions Report

Mame:* London Users Assigned NTFS Permissions Report D Limit Path Depth
Unformatted: D D Include Inherited ACEs
Type: Assigned MTFS Permissions Report
Description: Report Definition created on 6/13/2018 3:146:21 PM by

DYNAMICS\Administrator
TARGET PATHS FILE MANAGEMENT POLICIES

Add Remove

Target Path

5 (Conditional) If you want to limit the scope of the report to a set depth in the file structure, click
the Limit Path Depth check box and specify the depth level.

For example, if you specify 3, the report lists the file contents of all file paths in the specified
target paths up to 3 levels in the file structure.

If you do not specify a path depth, File Reporter will report on all levels of the specified target
path.

6 (Conditional) If you don’t want the report to include inherited ACEs (Access Control Entries),
deselect the Include Inherited ACEs check box.

7 From the Target Paths tab, click Add.
8 Browse to and specify the file paths you want included in the report and click OK.
9 Click save.

10 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

6.6.3 Generating a Permissions by Path Report

The Permissions by Path report indicates the effective rights to the Micro Focus (formerly Novell) file
system or the permissions to the Microsoft file system according to the paths you specify.

1 Select Reports > Report Definitions.
2 Click Add.
3 Inthe Name field, specify a descriptive name of the report definition.
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4 Select the Permissions by Path option and click OK.

Report Definition Editor - London Users Permissions by Path Report

MName:* Londen Users Permissions by Path Report

Unformatted: D

ype: Permissions by Path Report

Description: Report Definition created on 6/14/2018 9-16:19 AM by
DYNAMICS\Administrater

TARGET PATHS FILE MANAGEMENT POLICIES

Add Remove

Target Path

5 From the Target Paths tab, click Add.

6 Browse to and specify the file paths you want included in the report and click OK.

7 Click Save.

8 Generate the report as either a Preview report or a Stored report.
For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.
For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

6.6.4 Generating a Permissions by Identity Report

The Permissions by Identity report indicates the effective rights to the Micro Focus (formerly Novell)
file system or the permissions to the Microsoft file system according to the identities you specify.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.
4 Select the Permissions by Identity option and click OK.
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Report Definition Editor - HQ Users Permissions by ldentity Report

Name:* HQ Users Permissions by Identity Report
Unformatted: D

Type: Permissions by Identity Report

Description: Report Definition created on 6/14/2018 9:32:54 AM by

DYNAMICS\Administrator

IDENTITIES

Add Remove

Identity System Name

From the Identities tab, click Add.

Browse to and specify the identities you want included in the report.
Click OK to close the Identity Browser.

Click save to close the Report Definition Editor.

Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

6.7 File Data Reports

Reports in this classification include Filename Extension, Owner, Duplicate File, and Date-Age, along
with detailed versions of each of these reports.

Before generating any type of File Data report, you must first conduct a File System scan on the
volumes or shares you want to report on.

*

*

Section 6.7.1, “Generating a Filename Extension Report,” on page 77

Section 6.7.2, “Generating a Detailed Filename Extension Report,” on page 78
Section 6.7.3, “Generating an Owner Report,” on page 79

Section 6.7.4, “Generating a Detailed Owner Report,” on page 80

Section 6.7.5, “Generating a Duplicate File Report,” on page 81

Section 6.7.6, “Generating a Detailed Duplicate File Report,” on page 82
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+ Section 6.7.7, “Generating a Date-Age Report,” on page 84
+ Section 6.7.8, “Generating a Detailed Date-Age Report,” on page 85

Generating a Filename Extension Report

The Filename Extension report presents data grouped according to filename extension. This report is
helpful for determining file types that you do not want stored on your network drives. For example,
you can easily identify who is storing .MP3 or .MOV files.

NOTE: File extensions in File Reporter are limited to 32 characters. File extensions longer than 32
characters are considered part of the file name and not as an extension.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive hame of the report definition.
4 Select the Filename Extension option and click OK.

Report Definition Editor - London Users Filename Extension Report

Name:* HQ Users Filename Extension Report

Unformatted: D

ype: Filename Extension Report

Description: Report Definition created on 6/14/2018 10:06:40 AM by
DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

Add Remove

arget Path

5 From the Target Paths tab, click Add.
6 Browse to and specify the file paths you want included in the report and click OK.
7 (Optional) Click the Filters tab and set the filters for the report.

For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”
on page 147.

8 Click Save.
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9 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

10 (Optional) Generate a Detailed report on an individual file extension by clicking a file extension
name in the report.

6.7.2 Generating a Detailed Filename Extension Report

A Detailed Filename Extension report is similar to a standard Filename Extension report, except you
can filter the report to include only the files with the extension types you want.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.

4 Select the Filename Extension Detail option and click OK.

Report Definition Editor - HQ Users Filename Extension Detail Report

Filename Extensions (no leading dot), ane per line
Mame:* HQ Users Filename Extension Detail Report 9 P

Unformatted: D

Filename Extension Detail Report

Description: Report Definition created on 6/14/2018 10:36:23 AM by
DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

Add Remove

Target Path

5 Inthe Filename Extension field, specify the filename extensions you want included in the report
by listing each on an individual line. Do not precede the filename extension with a period.

For example:
mov
ipg
tmp
6 From the Target Paths tab, click Add.
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7 Browse to and specify the file paths you want included in the report and click OK.
8 (Optional) Click the Filters tab and set the filters for the report.
For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”
on page 147.
9 Click save.
10 Generate the report as either a Preview report or a Stored report.
For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

6.7.3 Generating an Owner Report

An Owner report groups data according to file owners. If it is determined that certain users are using
a disproportionate amount of storage, you can see what these users are storing and if they are
justified in doing so.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive hame of the report definition.

4 Select the Owner option and click OK.

Report Definition Editor - Atlanta Users Owner Report

Mame:* Atlanta Users Owner Report

Unformatted: D

Type: Owner Report

Description: Report Definition created on 6/14/2018 11:05:53 AM by
DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

Add Remove

Target Path

5 From the Target Paths tab, click Add.
6 Browse to and specify the file paths you want included in the report and click OK.
7 (Optional) Click the Filters tab and set the filters for the report.
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For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”
on page 147.

8 Click Save.
9 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

10 (Optional) Generate a Detailed report on an individual owner by clicking an owner’s name in the
report.

6.7.4 Generating a Detailed Owner Report

A Detailed Owner report is similar to a standard Owner report, except you can specify the users you
want information on.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.

4 Select the Owner Detail option and click OK.

Report Definition Editor - Munich Users Owner Detail Report

o See Owners tab below for selected identities.

Name:* Munich Users Owner Detail Report

Unformatted: D

Type: Owner Detail Report

Description: Report Definition created on 6/14/2018 11:17:18 AM by
DYNAMICS\Administrator

OWNERS TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

Add Remove

i Identity System owner

Mo data to display

Mo data to paginate

5 From the Owners tab, click Add, then browse to and specify the owners you want in the report
and click OK.

6 From the Target Paths tab, click Add, then browse to and specify the file paths you want
included in the report and click OK.
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6.7.5

7 (Optional) Click the Filters tab and set the filters for the report.

For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,’

on page 147.
8 Click save.

9 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

Generating a Duplicate File Report

A Duplicate File report indicates duplicate versions of files being stored and their locations. A

principle objective for any organization determined to limit network storage usage should be the

elimination of duplicate versions of files.

1 Select Reports > Report Definitions.
2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.

4 Select the Duplicate File option and click OK.

Report Definition Editor - Atlanta Duplicate File Report

Mame:* Atlanta Duplicate File Report

Unformatted: D

Duplicate File Report

DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES

Add Remove

arget Path

Description: Report Definition created on 6/14/2018 11.37:59 AM by

Match Size
Match Name
D Match Create Time

D Match Madify Time

<>

Minimum Duplicates 2

5 Use the check boxes and Minimum Duplicates field to specify the parameters for reporting.
The more check boxes you select, the more likely it is that File Reporter can identify definitive

duplicate files.
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Match Size: Specifies that files reported must have duplicate file sizes. This option cannot be
deselected.

Match Name: Specifies that files reported must have duplicate names with other files.

Match Create Time: Specifies that files reported must have duplicate file creation times with
other files.

Match Modify Time: Specifies that files reported must have duplicate file modification times with
other files.

Minimum Duplicates: Specifies the minimum number of duplicate files, according to the
parameters selected above, for inclusion in the report.

6 Browse to and specify the file paths you want included in the report and click OK.
7 (Optional) Click the Filters tab and set the filters for the report.

For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”
on page 147.

8 Click Save.
9 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

10 (Optional) Generate a Detailed report on a duplicate file by clicking a specific file name in the
report.

6.7.6 Generating a Detailed Duplicate File Report

82

A Detailed Duplicate File report is similar to a standard Duplicate File report, except you can specify
the exact filename to search for, along with exact create and modify times.

1 Select Reports > Report Definitions.

2 Click Add.

3 Inthe Name field, specify a descriptive name of the report definition.
4 Select the Duplicate File Detail option and click OK.
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Report Definition Editor - HQ Duplicate File Detail Report

Name:* HQ Dugplicate File Detail Report Duplicate Criteria

D Marne
Unformatted: D
Type: Duplicate File Detail Report D Size bytes
I:' Create Time
Description: Report Definition created on 6/14/2018 12:05:04 PM by
DYNAMICS\Administrator D Meodify Time
TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

In the Duplicate Criteria region, specify the file name size, and the dates and times that the file
was created or modified.

IMPORTANT: When specifying Create or Modify times, the time entered must be exact down to
the second. If a date range is required, do not enable the Create or Modify criteria here, but use
the date filters in the Filters tab. For more information on filters, see Appendix A, “Filtering,” on
page 147.

Browse to and specify the file paths you want included in the report and click OK.
(Optional) Click the Filters tab and set the filters for the report.

For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”
on page 147.

Click Save.

Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.
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6.7.7

Generating a Date-Age Report

The Date-Age report presents file count data according to when files were created, last accessed, or
last modified. You can use this report to help you determine which files have not been accessed for a
given amount of time and then decide whether to delete, archive, or move those files to less
expensive storage.

1 Select Reports > Report Definitions.

2 Click Add.

3 Inthe Name field, specify a descriptive name of the report definition.

4 Select the Date-Age option and click OK.

Report Definition Editor - HQ Users Date-Age Report

MName:® HQ Users Date-Age Report Date Type: Create Time hd
Unformatted: D Detail Level: | Year -
T Date-Age Report
Description: Report Definition created on 6/14/2018 12:57:29 PM by

DYNAMICS\Administrator
TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

Add Remove

5 In the Date Type drop-down menu, select an option.

Create Time: Reports when files were created.
Modify Time: Reports when files were last modified.
Access Time: Reports when files were last accessed.
In the Detail Level drop-down menu, select an option.

Year: Groups the file count in the report according to the year they were created, last modified,
or last accessed.

Month: Groups the file count in the report according to the month they were created, last
modified, or last accessed.

Day: Groups the file count in the report according to the calendar date they were created, last
modified, or last accessed.
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7 Browse to and specify the file paths you want included in the report and click OK.
8 (Optional) Click the Filters tab and set the filters for the report.

For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”
on page 147.

9 Click save.
10 Generate the report as either a Preview report or a Stored report.
For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.
For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.
11 (Optional) Generate a Detailed report by clicking a specific year, month, or date in the report.

Unlike the original Date-Age report that lists the data by file count, the generated Detailed report
lists individual files.

6.7.8 Generating a Detailed Date-Age Report

A Detailed Date-Age report is similar to a standard Date-Age report, except you can specify the exact
create, modify, or access date parameters.

1 Select Reports > Report Definitions.

2 Click Add.

3 Inthe Name field, specify a descriptive name of the report definition.

4 Select the Date-Age Detail option and click OK.

Report Definition Editor - Atlanta Shares Detailed Date-Age Report

Mame:™ Atlanta Shares Detailed Date-Age Report Mate T

Date Type: Create Time v
Unformatted:
D Detail Level: Year hd
T : Date-Age Detail Report
Selected Date
Description: Report Definition created on 6/14/2018 1:44:30 PM by
DYMNAMICS\Administrator
Enter one or more dates with the format yyyy-mm-dd,
one per line
TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

Add Remove

Target Path

5 In the Date Type drop-down menu, select an option.
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86

6.8

6.8.1

Create Time: Reports when files were created.

Modify Time: Reports when files were last modified.

Access Time: Reports when files were last accessed.
6 In the Detail Level drop-down menu, select an option.

Year: Groups the file count in the report according to the year they were created, last modified,
or last accessed.

Month: Groups the file count in the report according to the month they were created, last
modified, or last accessed.

Day: Groups the file count in the report according to the calendar date they were created, last
modified, or last accessed.

7 Inthe Selected Dates field, specify the dates you want.

This indicates that only the files created, last modified, or last accessed on those dates will be
included in the report.

8 Browse to and specify the file paths you want included in the report and click OK.
9 (Optional) Click the Filters tab and set the filters for the report.

For information on using the filtering capabilities of File Reporter, refer to Appendix A, “Filtering,”

on page 147.
10 Click Save.
11 Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

Historic Comparison Reports

Historic Comparison reports specify the differences between two similar scan types of the same
target system. For example, if you had a Previous Permissions scan of a Windows share and a
Current Permissions scan of the same share, you could generate a Historic NTFS Permissions
Comparison report that would specify the differences in permissions between the two points in time
that the scans were taken.

Historic Comparison reports can compare the following:

+ Baseline scans to Previous scans

+ Baseline scans to Current scans

+ Historic scans to Current scans
Reports in this classification include Historic File System Comparison, Historic NCP Permissions
Comparison, and Historic NTFS Permissions Comparison.

+ Section 6.8.1, “Generating a Historic File System Comparison Report,” on page 86

+ Section 6.8.2, “Generating a Historic NCP Permissions Comparison Report,” on page 88

+ Section 6.8.3, “Generating a Historic NTFS Permissions Comparison Report,” on page 90

Generating a Historic File System Comparison Report

1 Select Reports > Report Definitions.
2 Click Add.
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3 In the Name field, specify a descriptive name of the report definition.

4 Under Historic Comparison, select the File System Comparison option, then click OK.

Report Definition Editor - Atlanta Historic File System Comparison Report

Include entries modified by:

File Size D Create Time D
Attributes D Madify Time
Owner D Access Time

TARGET PATHS

Add Remove

Target Path

lame:* Atlanta Historic File System Comparison Report D Limit Path Depth
Unfermatted: D Scans to Compare Current and Previous
Ty Historic File System Comparison Report
QUERY FILTERS DETAIL DISPLAY OPTIONS
Descripfion: Report Definition created on &/14/2018 2:39:18 PM by
DYNAMICS\Administrator

Added Entries Files
Removed Entries Folders
@ Medified Entries

Directory Quota

5 (Conditional) If you want to limit the scope of the report to a set depth in the file structure, click

the Limit Path Depth check box and specify the depth level.

For example, if you specify 3, the report lists the file contents of all file paths in the specified

target paths up to 3 levels in the file structure.

If you do not specify a path depth, File Reporter will report on all levels of the specified target

path.

6 From the Scans to Compare drop-down menu, select one of the following options:

Current and Previous: Compares the Current scan of the storage resource to the Previous

scan of the storage resource.

Current and Baseline: Compares the Current scan of the storage resource to the Baseline

scan of the storage resource.

Previous and Baseline: Compares the Previous scan of the storage resource to the Baseline

scan of the storage resource.

All options appear whether you have scans or not. If you do not have scans, File Reporter will

generate an empty report.

7 Inthe Query Filters region, specify whether to include the following metadata categories in the

report:

Added Entries: If you want the report to list files or folders that have been added since the older

scan, leave this check box selected.
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6.8.2

88

10

11
12
13

1
2
3
4

Removed Entries: If you want the report to list files or folders that have been removed since the
older scan, leave this check box selected.

Modified Entries: If you want the report to list files or folders that have been modified since the
older scan, leave this check box selected.

Files: If you want the report to list files, leave this check box selected.
Folders: If you want the report to list folders, leave this check box selected.

In the Include entries modified by: region of the Query Filters, specify which of the attributes
modified between the older and newer scan you want included in the report.

In the Detail Display Options region, identify whether to display the metadata categories
specified below in the Detail Data section of the report.

The categories below pertain to the Detail Data section of the report only, and not the Summary
Data section.

Added Entries: If you want the report to display this category, whether there are added entries
to list or not, select this check box.

Removed Entries: If you want the report to display this category, whether there are removed
entries to list or not, select this check box.

Modified Entries: If you want the report to display this category, whether there are modified
entries to list or not, select this check box.

(Conditional) If you selected the Modified Entries check box, in the Always show modify detail
for: region, select any of the category options you want displayed in the report whether these
metadata categories have been changed between the two scans or not.

By default, the Modified Entries section of the report only shows metadata that has changed.
The options in this region of the dialog box are to force the display of one or more particular
metadata properties.

Any metadata for an entry that File Reporter has determined has changed is displayed in bold
font. Any optional data that has not changed is displayed in regular font.

Browse to and specify the file paths you want included in the report, then click OK.

Click save to close the Report Definition Editor.

Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.
For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

Generating a Historic NCP Permissions Comparison Report

Select Reports > Report Definitions.

Click Add.

In the Name field, specify a descriptive name of the report definition.
Select the Historic NCP Permissions option, then click OK.
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5

Report Definition Editor - CCTEC Vol 1 NCP Permissions Comparison

Name:* CCTEC Vol 1 NCP Permissions Comparison [ Limit Path Depth

Unformatted: D Scans to Compare Current and Previous -

Historic MCP Permissions Comparisen Report

Include Removed Paths
Description: Report Definition created on 6/14/2018 2:57:04 PM by
DYNAMICS\Administrator

TARGET PATHS

(Conditional) If you want to limit the scope of the report to a set depth in the file structure, click
the Limit Path Depth check box and specify the depth level.

For example, if you specify 3, the report lists the permissions of file contents of all file paths in the
specified target paths up to 3 levels in the file structure.

If you do not specify a path depth, File Reporter will report on all levels of the specified target
path.

From the Scans to Compare drop-down menu, select one of the following options:

Current and Previous: Compares the Current scan of the storage resource to the Previous
scan of the storage resource.

Current and Baseline: Compares the Current scan of the storage resource to the Baseline
scan of the storage resource.

Previous and Baseline: Compares the Previous scan of the storage resource to the Baseline
scan of the storage resource.

All options appear whether you have scans or not. If you do not have scans, File Reporter will
generate an empty report.

(Conditional) If you do not want the report to list any paths that have been deleted or removed,
deselect the Include Removed Paths check box.

8 Browse to and specify the file paths you want included in the report, then click OK.

9 Click Save to close the Report Definition Editor.

10

Generate the report as either a Preview report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.
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6.8.3 Generating a Historic NTFS Permissions Comparison
Report

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.
4 Select the Historic NTFS Permissions option, then click OK.

9T0Z JeqwanoN TT (ua) sAsoop

Report Definition Editor - Atlanta Users Historic NTFS Comparison Report

Mame:* Atlanta Users Histaric MTFS Comparison Report I:l Limit Path Depth

Unformatted: D Scans to Compare Current and Previous v

Historic NTFS Permissions Comparison Report

Description: Report Definition created on 6/14/2018 3:18:31 PM by
CYMAMICS\Administrator v

TARGET PATHS

Add Remove

arget Path

5 (Conditional) If you want to limit the scope of the report to a set depth in the file structure, click
the Limit Path Depth check box and specify the depth level.

For example, if you specify 3, the report lists the permissions of file contents of all file paths in the
specified target paths up to 3 levels in the file structure.

If you do not specify a path depth, File Reporter will report on all levels of the specified target
path.

6 From the Scans to Compare drop-down menu, select one of the following options:

Current and Previous: Compares the Current scan of the storage resource to the Previous
scan of the storage resource.

Current and Baseline: Compares the Current scan of the storage resource to the Baseline
scan of the storage resource.

Previous and Baseline: Compares the Previous scan of the storage resource to the Baseline
scan of the storage resource.

All options appear whether you have scans or not. If you do not have scans, File Reporter will
generate an empty report.
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6.9

6.9.1

7 (Conditional) If you want your report to include not only direct permissions, but inherited
permissions, select the Include Inherited ACEs check box.

Reporting inherited permissions could make the report significantly larger.

8 (Conditional) If you do not want the report to list any paths that have been deleted or removed,
deselect the Include Removed Paths check box.

9 Browse to and specify the file paths you want included in the report, then click OK.
10 Click Save to close the Report Definition Editor.
11 Generate the report as either a Preview report or a Stored report.
For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.
For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

Trending Report

Currently, the only report in this classification is the Volume Free Space report. Before generating a
Volume Free Space report, you must first conduct a Volume Free Space scan on the volumes or
shares you want to report on.

Generating a Volume Free Space Report

The Volume Free Space report lets you view available volume or share disk space over a set amount
of time. For best results, you should conduct regularly scheduled Volume Free Space scans on
specific volumes and shares. File Reporter then has the data it needs to graph the pattern of free
space on the volume or share.

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.

4 Select the Volume Free Space option and click OK.

Generating File System Reports 91

9T0zZ leqwanoN TT (ua) sAsoop



6.10

Report Definition Editor - SFO Volume Free Space Report

Mame:* SFO Volume Free Space Report

Unformatted: D

Volume Free Space Trending Report

Description: Report Definition created on 6/14/2018 3:55:00 PM by
DYNAMICS\Administrator

TARGET PATHS

Last number of days to include

365

The lowest number you can specify is 7.

Custom Query Reports

Custom Query Reports are reports that are generated through a series of SQL commands that you
enter. These commands enable you to generate very specific detail in reports that are not available
through the built-in report types in File Reporter.

For example, if you want the report to graph the last month, enter 30.

In the Last number of days to include field, specify the last number of days you want the report
to include.

6 Browse to and specify the volumes or shares you want included in the report and click OK.
7 Click Save.
Generate the report as either a Preview report or a Stored report.
For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.
For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.

The SQL commands must be specific to the database (Microsoft SQL Server or PostgreSQL) that
your deployment of File Reporter is utilizing.

NOTE: For details and examples of the supported database functions, tables, and views that you can
utilize in Custom Query reports, refer to the Micro Focus File Reporter 3.5 Database Schema and
Custom Queries Guide.
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SQL commands are entered through report editors available from the File Reporter browser-based
administrative interface and from the Report Designer client tool.

IMPORTANT: Prior to the release of version 3.0, File Reporter supported the active_fs_scandata
view, which was then deprecated, but not removed. That view has now been removed to support File
Reporter’s current and previous naming parameters. If you have existing Custom Query reports that
include the active_fs_scandata view, you will need to replace each instance with
current_fs_scandata.

NOTE: For details on using the report editor in the Report Designer, see Section 11.3, “Designing a
Custom Query Report,” on page 135.

TIP: Don't forget to utilize File Query Cookbook as a resource for obtaining SQL commands and
sample report layouts that have been submitted by the File Reporter community. Both the SQL
commands and report layouts can be customized as needed.You can access the File Query
Cookbook directly through the Report Designer interface, or at http://www.filequerycookbook.com.

1 Select Reports > Report Definitions.
2 Click Add.
3 In the Name field, specify a descriptive name for the report definition.

4 Select Custom Query Report.

2 https://filereporter.dynamics.cctec.org/Trptld=23 - Custom Query Editor - Internet Explorer o | =
EDITOR ~
E > Include Column Headers
imi , (Comma A
Save  Execute Defimiter . ( )
(Ctl-S)  (Ctl-E)
Query Delimited Text
Record Limit 100

Drag a column here...

Mo data to display

No data to paginate
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94

5 Enter the SQL commands according to what information you want included in your report.

As you enter commands, you can click Execute to get a preview in the bottom portion of the
editor of how the report will appear.

The Row Limit setting does not limit the size of the report. Instead, it limits the how much can be

previewed.
& https//filereporter.dynamics.cctec.org/Trptld=23 - Custom Query Editor - Internet Explorer = ] *
EDITOR ~
E > Include Column Headers
e Execute Delimiter , (Comma) -
(CtlS)  (CH-E)
Query Delimited Text
1 [WITH
2 x(filename_extension, size, category) AS (SELECT sd.filename_extension, 2
3 sd.size,
- CASE WHEN sd.filename_extension IN ('lan’, 'ncp', 'nlm', 'nlk', "vim') THEN 'Novell
5 FROM srs.current_fs_scandata AS sd
6 WHERE (sd.fullpath LIKE '\\dynamics.cctec.org\DFS\HQ\HQShare\%"' ESCAPE '#') AND
7 (sd.path_type = 1))
8 |SELECT
9 x.category,
10 Sum(x.size) AS cat_size, v
11 count(*) AS file count.
17 < >
Record Limit 100 2
# category cat_size file_count cat_size_strir
Configuration A
1 Files 59832 1 5843 KB
Document 1331905 9 127MB v
Files ’
Page 1 of 1 (8 items) o

When you are satisfied with the report and the previewed results, click Save.
Close the Custom Query Report Editor.
Select Reports > Report Definitions.

© 00 N o

Select the Custom Query Report you just saved and generate the report as either a Preview
report or a Stored report.

For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.

For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.
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6.11

6.11.1

Unformatted Reports

File Reporter allows you to generate unformatted reports. In some instances, having an unformatted
report might be useful for doing extensive sorting and filtering of the report data using a product such
as Microsoft Excel.

File Reporter can generate an unformatted report for all built-in report types except for Summary
reports.

You can generate unformatted reports by selecting the option in the Add Report Definition dialog box
or by selecting the Unformatted check box in the Report Definition Editor dialog box.

Generating Unformatted Reports

1 Select Reports > Report Definitions.

2 Click Add.

3 In the Name field, specify a descriptive name of the report definition.
4 Select the report type you want to generate.

5 Select Create report as Unformatted.

Add Report Definition

Name:™ Unfoermatted HQ Users Filename Extension Report

Unformatted: Create report as Unformatted (for use with Text, Csv, or Xls exports)

Directory Data File Data

o Summary @ Filename Exfension O Filename Extension Detail
o Directery Quota O Owner O Cwner Detail

O Storage Cost O Duplicate File O Duplicate File Detail

o Comparison O Date-Age O Date-Age Detail
Permissions Histeric Comparison

o Assigned MCP Permissions O File System Comparison

o Assigned MTFS Permissions O MCP Permissions Comparison

o Permissions by Path O NTFS Permissions Comparison

o Permissions by ldentity

Trending Custom Query
o Volume Free Space O Custom Query Report
6 Click OK.
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6.12

6.13

7 In the Report Definition Editor, specify the settings and the file paths you want included in the
report, then click OK.

8 Click save.
9 Generate the report as either a Preview report or a Stored report.
For procedures on generating a Preview report, see “Generating a Preview Report” on page 64.
For procedures on generating a Stored report, see “Generating a Stored Report” on page 66.
10 From the file type drop-down menu, select either XL S, XLSX, Text, or CSV.
11 Click the Export a Report and Save it to the Disk button.
12 Select Save File and click OK.

Micro Focus File Dynamics and Storage Manager
Policy Reports

In most reports, you browse to and specify a file path for the report through the Target Paths tab. If
you have either Micro Focus File Dynamics or Micro Focus Storage Manager managing your
organization’s user and collaborative storage, you can have File Reporter report on the storage
according to the target paths of the File Dynamics or Storage Manager policies, rather than through a
specific file path.

IMPORTANT: File Reporter 3.5 supports File Dynamics 6.0 and Storage Manager 4.0 or above.

The advantages to specifying a File Dynamics or Storage Manager policy rather than a file path is
that a policy can include many different target paths. For example, in a large organization that utilizes
File Dynamics’ or Storage Manager’s load balancing capabilities, a single policy might have 10 or
more target paths. If you chose to specify the paths through the Target Paths tab, you would need to
list all 10 paths. But if you have each of the target paths listed in a single policy, through the File
Management Policies tab, all you need to do is add the single policy.

Another important advantage is that File Reporter reads the associated policy target paths each time
a report is generated, so that it dynamically responds to changes in assigned target paths for File
Dynamics or Storage Manager policies.

NOTE: Procedures for integrating File Reporter with File Dynamics or Storage Manager are included
in Section 4.5, “Integrating with File Dynamics or Storage Manager,” on page 40.

You can specify policies for all File Reporter reports with the exception of Comparison reports,
Permissions by Identity reports, and Volume Free Space reports.

Scheduling Reports

You can generate reports on a one-time or regularly scheduled basis.

1 Select Reports > Report Definitions.
2 From the list of report definitions, select one that is not scheduled.
3 Select Schedule > Edit Schedule.
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Schedule for Atlanta Shares Detailed Date-Age Report

SCHEDULE START
Engine Local Time:* 12:00 AM o
Engine Local Start Date:® | 6/15/2018 v

SCHEDULE RECURRENCE

O once
O paily
@ Weekly Friday i
O Monthly
Day

The

Engine Local Time: Specify the time that you want the report to generate.

The time you select should be based on the time zone where the Engine is located and not the
workstation where you are accessing the Web application.

Engine Local Start Date: Specify the date when you want the report schedule to take effect.

Be aware that entering a date does not mean that the report generates on that date. If the
Engine Local Start Date is set for today, which is a Monday, but the Schedule Recurrence setting
is set for Weekly on Sunday, the report does not generate until Sunday.

Once: Select this option to schedule the report to be generated only once.

Daily: Select this option to schedule the report to be generated daily.

Weekly: Select this option and specify a weekday to generate the report.

Monthly: Select this option and specify a day to generate the report each month.
Specify the scheduling parameters and click OK.

The new schedule is displayed in the Schedule column of the Report Definitions page.
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6.14

6.15

6.16

Editing a Scheduled Report

1 Select Reports > Report Definitions.

2 From the list of report definitions, select one whose schedule you want to edit.
3 Select Schedule > Edit Schedule.

4 Make the schedule changes you want.

5 Click OK.

Clearing a Schedule on a Scheduled Report

1 Select Reports > Report Definitions.
2 From the list of report definitions, select one whose schedule you want to clear.
3 Select Schedule > Clear Schedule.
4 When the confirmation screen appears, click Yes.
The status of the report definition appears in the Schedule column as Not Scheduled.

Copying a Report Definition
To save time in creating a new report definition and its associated properties, you can copy an
existing report definition.
When you copy a built-in report, the following properties are included:
+ Report Parameters
+ Report Targets Paths
+ Report Identity Targets
+ Filters
+ File Dynamics or Storage Manager Policies

When you copy a Custom Query report, the following properties are included:

+ SQL Query
+ Report Layout

NOTE: Copying a report definition does not copy the content in the Description field, nor does it copy
the report schedule.

1 Select Reports > Report Definitions.
2 From the list of report definitions, select one that you want to copy.
3 From the taskbar, click Copy.
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Copy Report Definition
Source
Target Copy of HQ Share and HO Users Comparison Report
COPY CANCEL
4 Click Copy.

The new report definition is added to the list of report definitions with the name Copy of
preceding the name of the original report definition.

5 Select the copy of the report definition.

6 From the taskbar, select Rename.

Rename Report Definition

Mew Mame Copy of HQ Share and HG Users Comparison Report

7 Inthe New Name field, specify a name for the new report definition, then click Rename.

8 From the taskbar, select Schedule > Edit Schedule.

9 Set the scheduling parameters for the new report definition, then click OK.
10 From the taskbar, click Edit.
11 In the Description field, enter a new description.
12 Click Save.

6.17 Viewing Reports in Progress

When you generate large reports, you can view the progress in the Reports in Progress page.

1 Select Reports > Reports in Progress.
2 Click Refresh.
When the report disappears from the list, the report generation has completed.
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6.18 Troubleshooting Reports

If there is potential for a reporting problem, File Reporter provides notifications to help resolve the
issue. The following points might also be helpful.

1 Verify that a scan exists for the storage resources you want to report on.

2 If your reports include too much data to be useful, narrow the scope of the report by
implementing filters. For more information, see Appendix A, “Filtering,” on page 147.
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1.1

7.1.1

Content Scanning and Reporting

With the release of Micro Focus File Reporter 3.5, customers have the ability to analyze their files

based on content. By analyzing content, organizations can locate files containing confidential,

sensitive, and personal information that should be given restricted access, moved to a more secure

location, or deleted.

All File Content procedures are performed through the File Content menu options.

Creating File Content Classifications

File content classifications are needed by File Reporter as a search parameter. For your

convenience, File Reporter includes three classifications and severity levels. You can modify this list

by editing the settings or creating your own classifications.

Creating a New Classification

1 Select File Content > Classifications.
2 Click Add.

Classification

>

Update Cancel

3 In the Classification field, enter a name.
For example, Private.

4 From the Level field, specify a severity level for the new classification.
For example, 400.

5 Inthe Description text box, enter a description for the new classification.

Content Scanning and Reporting
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For example, High-risk private information, not for public disclosure.
6 Click Update.

7.1.2 Editing a Classification

1 Select File Content > Classifications.

2 Select the classification you want to edit.
3 Click Edit.

4 Edit the fields.

5 Click Update.

7.2 Creating File Content Categories

Categories are an additional way of refining your search parameters. For your convenience, File

Reporter includes three standard categories. You can modify this list by creating your own

classifications.

7.2.1 Creating a New Category

102

1 Select File Content > Categories.
2 Click Add.

Cafegory

Update

Cancel

3 Inthe Category field, enter a name.
For example, National ID.

4 In the Description text box, enter a description for the new category.
For example, US SSNs as well as other national ID schemes.

5 Click Update.
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1.2.2

1.3

7.3.1

Editing a Category

1 Select File Content > Categories.

2 Select the category you want to edit.
3 Click Edit.

4 Edit the fields.

5 Click Update.

Creating Search Patterns

Search patterns specify the conditions for the content scanning, along with how you want to classify

and categorize the results.

File Reporter utilizes regex search strings for conducting content scanning. Regex is short for “regular
expression,” a special text string describing and defining a search pattern. Regex search strings are
ideal for locating files containing specified patterns (e.g. Social Security numbers, credit card

numbers, etc.) or other user-defined patterns.

Creating a New Search Pattern

1 Select File Content > Search Patterns.
2 Click Add.

Search Pattern

Update Cancel

3 Inthe Name field, enter a descriptive name for the search pattern.

For example, Social Security US - High.

Names are restricted to A-Z, a-z, 0-9, space, - (hyphen), and_ (underscore).

4 From the Classification drop-down menu, select a classification.

5 From the Category drop-down menu, select a category.

6 From the Match Confidence drop-down menu, select either Low, Medium, or High.

Content Scanning and Reporting
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These designations allow you to indicate your confidence in the search pattern. Selecting High
does not necessarily make the match confidence better than selecting Low. It simply indicates
your confidence in results of the search, based on the depth of the Regex search string. For
example, a search for all Social Security numbers might be Low, while a search for a particular
Social Security number specified in the regex string would be High.

7 Inthe Regex Options drop-down menu, select any applicable options.

For an explanation of these options, we recommend referring to this document (https://
docs.microsoft.com/en-us/dotnet/standard/base-types/regular-expression-options) published by
Microsoft.

8 Inthe Search String text box, enter or paste the search string.

Note that this version of File Reporter does not yet include an interface for developing regex
search strings.

For basic information and tutorials on compiling regular expression search strings, see the
following sites:

+ https://regexone.com
+ https://www.regular-expressions.info/tutorial.html
+ https://www.rexegg.com

For cases where different regex Engines or languages are mentioned, note that this version of
File Reporter makes use of the C# (.NET) regular expression variant.

Additionally, we will provide a variety of regex search strings on filequerycookbook.com (https://
www.filequerycookbook.com).

9 Inthe Description text box, enter a description of the search pattern.

Search Pattern

Name:* Social Security US - High

Classification: Restricted hd
Category:* PIl -
Match Confidence:* High -

Regex Options Nane hd

IO+ NSO IABINL 23N \s+)6 789121901\ [\s+ )OS Ns+)99F9107 BN\ [\ +)05(-\ s +311200( 1666|0001 Nd{2INd{3I-

Description Search string that looks for the pattern of a Social Security number but leaves out known numbers that are not in circulation.

Update Cancel

10 Click Update.

7.3.2 Editing a Search Pattern

1 Select File Content > Search Patterns.
2 Select the search pattern you want to edit.
3 Click Edit.
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7.4

74.1

4 Edit the fields.
5 Click Update.

Creating Job Definitions

A job definition specifies the file system paths where the content scanning will take place, the search
patterns that will be applied, the filters for the search, and where the content scanning results will be

stored.

Creating a New Job Definition

1 Select File Content > Job Definitions.
2 Click Add.

Job Definition

TARGET PATHS SEARCH PATTERNS FILTERS

Update Cancel

3 In the Name field, enter a descriptive name for the job definition.

4 From the Result Type menu, select from the following options:

+ Database: This option saves the results of the content scan to the database, where you can
use it to generate a report using the Report Designer. Having the scan in the database also

allows you to search and report utilizing the established classifications and categories.

+ File: This option saves the results of the content scan as a file in the Search Results

share. You can access all saved files through the Search Results page.

5 From the Target Paths tab, click Add.
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Scan Data Browser - File System Data

¥ BB dynamics.cctecorg

r D T: Ydynamics.coctecorg\DF3VAtlanta\AtlantaShare
r D T: Wdynamics.coctecorg\DFSVAHanta\ Atlantallsers
* D "':: YWdynamics.cctecorg\DFS\HGWHGShare
4 D T: Wdynamics.coctecorg\DFS\HOVHGUsers
r D T: Wdynamics.cctecorg\DFS\Munich\MunichShare

r D T: Wdynamics.cotec.org\DF3WMunich\MunichUsers

6 Select the targets where you want the file content to be scanned.

9T0Z JaqwanoN TT (ud) sAsaop

IMPORTANT: File paths appear in the Scan Data Browser - File System Data dialog box only if
the paths have had a previous file system scan. If the path you want does not appear in the
dialog box, you must first conduct a file system scan on the path.

7 Click OK.
8 Click the Search Patterns tab.
9 Click Add.
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10
11
12

13

Search Patterns Browser

|:| Name Category Classification
D Social Security US - High Pl Restricted
I:I Social Security US - Low Pl Restricted

From the Search Pattern Browser, select specify your search patterns and click OK.
Click the Filters tab.
In the Maximum File Size field, specify the size of files that will not be scanned for content.

For example, large files such as ISO files should probably not be scanned. If you do not enter a
setting in this field, all files in the file path will be scanned.

In the File Extensions text box, specify the file types that you want scanned.
If you do not specify file extensions, all files in the file path will be scanned.
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Job Definition

Mame* US Social Security Atlanta Users Result Type:* Database, File hd

TARGET PATHS SEARCH PATTERNS FILTERS

Maximum File Size: o ¢ | MB (Vaiue of O is unlimited size)

File Extensions: pptx
ppt
docx
doc
xls
xlsx
pdf
Tt
rtf
xps

Enter filename extensions, one per line, without a leading period.

Update Cancel

9T0Z JaqwanoN TT (ud) sAsaop

14 Click Update to save the job definition settings.

7.4.2 Editing a Job Definition

1 Select File Content > Job Definitions.

2 Select the job definition you want to edit.
3 Click Edit.

4 Edit the fields.

5 Click Update.

7.5 Viewing Jobs in Progress

You can view the status of file content scanning jobs in progress by selecting File Content > Jobs in
Progress.
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1.6

1.7

[:] MAIN  FILESYSTEMS FILECONTENT REPORTS CONFIGURATION £ DYNAMICS\Adminiatrator
CLASSIFICATIONS CATEGORIES SEARCH PATTERNS JO8 DEFINITIONS JOBS IN PROGRESS SCAN DATA SEARCH RESULTS SCAN AGENTS
P ny
S
[0 sbw Jsb Definition Files Submitted Files Processed Status Code ‘Status Message

Secutity Atlanta Users

Viewing Scanned Data Jobs

You can view a list of file content scan jobs by selecting File Content > Scan Data.

FR MAIN FLESYSTEMS FILECONTENT REPORTS CONFIGURATION &, DYNAMICS\Administrator
CLASSIFICATIONS CATEGORIES SEARCH PATTERNS JOBDEFINITIONS  JOBSINPROGRESS  SCAMDATA  SEARCH RESULTS SCAN AGENTS
L] ¥ Refresn
Job
Full Path Scan Time classificarion Category Marched Search Patrern tonfidence

w ok US Social Security Atlants Users - 71 (3 entvies)

Viewing Search Results

For those job definitions where the Result Type setting is set to File, you can download the file
content scan file from the Search Results page.

File Reporter outputs the file as a CSV file so that if you desire, you can import the file into the Micro
Focus File Dynamics Data Owner Client where a Data Owner can perform remediation work.
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FR MAIN  FILESYSTEMS FILE CONTENT REPORTS CONFIGURATION 3 DYNAMICS\Administrator
CLASSIFICATIONS CATEGORIES SEARCH PATTERNS JOB DEFINITIONS JOBS IN PROGRESS SCAN DATA SEARCH RESULTS SCAN AGENTS
3 Refresh
group by

[J  ResultFile Job Status File Size Last Modify Time
E i Aanta Beers 0 e e _

[J | US Social Security Atlanta Users-12.csv Completed 340bytes  6/19/2018 5:34:39 PM

D US Social Security Atlanta Users-13.csv Completed 340 bytes  6/19/2018 5:48:53 PM

D US Social Security Atlanta Users-14.csv Completed 346 bytes  6/19/2018 5:58:43 PM

D US Social Security Atlanta Users-15.csv Completed 346 bytes  6/19/2018 5:59:01 PM

D US Social Security Atlanta Users-16.csv Completed 346 bytes  6/19/2018 5:59:16 PM

D US Social Security Atlanta Users-17 csv Completed 941 bytes  6/19/2018 6:00:07 PM

D US Social Security Atlanta Users-18 csv Completed 938 bytes 6/20/2018 10:05:01 AM

D US Social Security Atlanta Users-19.csv Completed 938 bytes = 6/21/2018 12:13:08 PM

Page 1 of 1 (11 items) °
Copyright- 2018 &/ Condrey Corporation

7.8 Viewing AgentFC Configuration Registrations

You can view the version, and the last heartbeat for each deployed AgentFC by selecting File
Content > Scan Agents.

SEARCH PATTERNS  JOB DEFINITIONS

% IN PROGRESS SCAN DATA SLARCHRESULTS  SCAN AGENTS

| 3 Refresh

Tika Verslen OCR Sratuz

16 15312 PM

Apache Tika 118 O  Ressy

0O ® ccreciaynamicsccrecary 35
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8.1

Performing Other Administrative Tasks

This section provides procedures for performing administrative tasks not covered in the previous
sections.

+ Section 8.1, “Stopping and Restarting Services,” on page 111
¢ Section 8.2, “Using Folder Summary,” on page 112

*

Section 8.3, “Considerations for Reporting on NAS Devices,” on page 113

*

Section 8.4, “Changing the Default Path for Stored Reports,” on page 114

*

Section 8.5, “Changing the Life Span of Stored Reports,” on page 115

*

Section 8.6, “Resetting the Proxy User Password,” on page 115

Stopping and Restarting Services

Use the Configuration Dashboard to stop and restart the Engine, Web Application, Web Service, Web

Site, and Application Pool.

Performing Other Administrative Tasks
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Figure 8-1 Configuration Dashboard

% Fie Reporter Configuration Dashboard - 3.5.0 - o IEH

£ Database V] Configured Configure Datsbase

Database Type: SQL Server - Standard Edition (54-bit)

Database Version: Microsoft SQL Server 2017 (RTM) - 14.0.1000. 169
Database Name: srsdb

Database User: srsadmin

Address: 172.17.2.21:1433

Schema Version: 3.5.0.1

=% License @ valid license Install or Update License

Product: Micro Focus File Reporter
License Type: Production

Expiration: 5/25/2019 4:42: 12 FM
Identity System: dynamics.cctec.org
Platform: Active Directory

Features:

Active Directory Reporting

eDirectory Reporting

Content Analysis

Q Running Configure Engine
Address: 0.0.0.0:3035 i
Stop Enging

Admin Group: DYNAMICS\SrsAdmins
Communications Group: DYMAMICS'\SrsCommunications Stop Scan Processor

Proxy User: DYNAMICS\SrsProxy
Rights Group: DYMAMICS\SrsProxyRights

Engine Timezone: (UTC -04:00) Eastern Daylight Time

@ Web Appllcatlon @ Running Configure Web Application
Web Site: SrsSite ! i
. ) D
https: //filereporter dynamics. cctec.org AppPool: SrsAppPool Stop Web Service
AppPool Identity: DYNAMICS\SrsAppPoolSve Stop Web Site
Disk Path: C:\inetpub‘srs_root!, o
Https Listeners: [All IP Addresses]: 443 Stop Application Poal

Hostname: filereporter.dynamics.cotec.org
AppPool Recyde Time: 03:00:00

Q Active Directory forest 'dynamics. cctec.org' available - joined to domain DYNAMICS

O eDirectory available via Client for Open Enterprise Server 2 SP4 (IR7) 5.1 5P 4 Build 20170920 G Refresh Close

8.2 Using Folder Summary

The Folder Summary feature provides you a visual folder structure according to the latest scanned
file system data. Folder Summary also provides extensive summary information for the folders and
files.

You can access Folder Summary by selecting Reports > Folder Summary.
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8.3

8.3.1

Figure 8-2 Folder Summary

MAIM  FILE SYSTEMS  FILE CONTENT REPORTS CONFIGURATION £ DYNAMICS\Administrator

REPORT DEFINITIONS ~ REPORTS IN PROGRESS  FOLDER SUMMARY  STORED REPORTS

Flle Slze File Count Folder Count  Folder Guora % of Parent Folder Size % of Toral Size
422 Me s 34 100 00
54 MB L na 100
93 ME 2 22 100 100

S/1E/2018 12,0000 AM
S/15/2018 12,0000 AM

Copyright 2018 © Condrey Corporation

You can print, save, or export the data as a PDF or XLS file.

Considerations for Reporting on NAS Devices

In Active Directory network environments, File Reporter can report on the contents of Network
Attached Storage (NAS) devices. Integration information for reporting on specific NAS device types is
found below.

¢ Section 8.3.1, “NetApp filer,” on page 113

+ Section 8.3.2, “EMC Isilon,” on page 114

¢ Section 8.3.3, “Other NAS Devices,” on page 114

NetApp filer

For a NetApp filer device, configuration is very simple because the device does not fully emulate a
Windows Server at the operating system level.

1 Use the NetApp filer administration utility to join the NAS device to a domain where File Reporter
can report.
2 Grant the proxy rights group membership in the NAS device's built-in Administrators group.

3 Grant the proxy rights group the folder share permissions that are required to access the
storage.

There are no LSA rights and privileges to grant on a NetApp filer NAS device.
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8.

3.2

8.3.3

114

8.4

EMC Isilon

Perform the following steps to integrate an EMC Isilon device. You can use these same steps to see if
other NAS devices integrate with File Reporter.

1 Rebuild the storage resources and verify that the NAS device is displayed on the list.

2 Perform any needed steps for giving the proxy rights group access to the desired shares and
folders on the NAS device.

Other NAS Devices

Perform the following steps to see if other NAS devices integrate with File Reporter.

1 In the associated Computer object in Active Directory, add the following text somewhere in the
description attribute for that object:

***SRGenericNASDevice***
2 Rebuild the storage resources and verify that the NAS device is displayed on the list.

3 Perform any needed steps for giving the proxy rights group access to the desired shares and
folders on the NAS device.

Changing the Default Path for Stored Reports

The default path for stored reports is established during the installation of the Engine. If you want to
change the file path, you can do so if the new path is on the server hosting the Engine and Web
application.

Because both the Web application and the Engine via the Stored Reports DLL need access to the
report files, the service accounts those processes run as must have both Read and Write access to
the specified path. For the Engine, this is the Windows Proxy Account; for eDirectory (or the “service
account” when running in eDirectory mode) and for the Web Application, this is the associated 1S
AppPool Identity, which is a hidden account created by Windows and tied to the Application Pool
when the Web service was configured.

If you create a new folder for the stored reports, you must assign Read and Write access for the
associated Windows server/proxy account to that folder, as well as the AppPool Identity. Because you
cannot browse for the AppPool Identity, you need to use the name of the AppPool itself:
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8.5

8.6

Select Users, Computers, Service Accounts, or Groups X

Select this object type:

|Llsers. Groups, or Builtin securty principals | Object Types...

From this location:

|d1,'nami|:5.|:|:tec ang | Locations...

Enter the object names to select {sxamples):
SreAppPoolSve Check Mames

Advanced... Cancel

File Reporter does not move previously generated reports to the new location.

1 Select Configuration > Stored Reports.
2 Inthe Stored Reports Folder field, specify a new path.
3 Click Save Changes.

Changing the Life Span of Stored Reports

By default, stored reports are available for access for 30 days. You can adjust this setting by following
the procedures below.

NOTE: You can always save a Preview or Stored report locally so it remains accessible indefinitely.

1 Select Configuration > Stored Reports.
2 In the Default Expiration field, adjust the setting.
3 Click Save Changes.

Resetting the Proxy User Password

If the proxy user password is not working, you can reset it through the Engine Configuration Utility. As
part of the configuration process, it resets the proxy user password.
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9.1

Using the Report Viewer

NOTE: The Report Viewer is installed as a separate application, rather than part of the Client Tools.
This is so both administrators and other users who need access to the reports, can access saved
reports.

Use the Report Viewer

The Report Viewer lets you to view all stored reports locally from a Windows workstation. Because
the Report Viewer utilizes the resources of the Windows workstation, rather than those of the Engine,
the Report Viewer can display stored reports much faster in most instances.

In comparison to the viewing capabilities of the browser-based administrative interface, the Report
Viewer offers more capabilities. For example, with the Report Viewer you can change the visual
display parameters of the report.

1 Launch the File Reporter File Viewer application.

EB File Reporter Repart Viewer 3.5.0 E - O x
(=3 Print Preview
L
e/
Open

Document Print Navigation Zoom Page Background Exp...

The document does not coniain any pages.

Nothing |

2 Click Open, browse to the location of your stored reports, then click Open.

To determine where stored reports are located, in the File Reporter administrative interface,
select Configuration > Stored Reports and view the location in the Stored Reports Folder field.
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73 File Reporter Report Viewer 3.5.0 E - 0O x
(=3 Print Preview
| @ o an e . N e e - B
E F=—1 @é [T ' >l o 0 =y =y =y @U
Open  Save Print  Quick Find  Bookmarks Mext  Last »' ManyPages ZoomOut Zoom ZoomIn | PageColor Watermark | Export
Page  Page =4 - - 2 To -
Document Print Navigation Zoom Page Background Exp... ~
Document Map nox

4 Owner
» Parameters
Top Ten Owners by File Size
» ReportData

Owner Report

CCTEC

ReportDate:  6/21/2018 3:58:48 PM
Generatedby: File Reporter

File Reporter Page 10f 5
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3 (Optional) Adjust the view to your preferences using the tools discussed below.

Bookmarks: Click to toggle between the report Document Map being displayed and not
displayed.

Many Pages: Click to specify the number of pages you want displayed.
Zoom Out: Click to see more of the report page at a reduced size.

Zoom: Click to change the zoom level of the report preview.

Zoom In: Click to get a close-up view of the report.

Page Color: Click to change the color for the background of the report pages.

Watermark: Click to insert a ghosted text or image behind the content of each page of the
report. A watermark is often used to indicate how a document is to be treated specifically.

The Watermark dialog box lets you specify your watermark settings. Your watermark can either
be in text or graphic form.
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Watermark E3
Text Watermark | Picture Watermark
Text: DO MOT COPY W
Direction: |Forward Diagonal |w Color: 1 W
Font: Verdana W Size: 36 W
Italic
Transparency (0-255): 50
Il
5 )
Position Page Range
In front e Al Pages:
® Behind Enter page numbers andfor page ranges

separated by commas. For example: 1,3,5-12

Clear Al oK Cancel

4 (Optional) Save the Report using the tools discussed below.

Save: Click to save the report. The report is saved as a .PNRX file, meaning that in this format,
the report can only be opened through the Report Viewer.

Export To: Click to export the report to a new format. Each selected format option brings up a
dialog box where you can provide specifics on how you want the report exported.

XLSX Export Options [ x|
Expart mode: Sinale file W
Sheet name: Sheet
Text export mode: | Value W

Show grid lines
v | Export hyperlinks

Raw data mode

Cancel
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10.1

Using the Client Tools

The Micro Focus File Reporter Client Tools are designed to provide members of the administrators
group expanded abilities in analyzing data and designing reports. The Client Tools are run from a
Windows workstation.

The analytics tools are an integrated set of data visualization applications that include a Dashboard,
Pivot Grid, and Tree Map.

The Report Designer allows you to design reports locally from a Windows workstation, while offering
significantly more reporting design capabilities to those of the browser-based administrative interface.
¢ Section 10.1, “Launching the Analytics Tools,” on page 121
¢ Section 10.2, “Using the Dashboard,” on page 123
+ Section 10.3, “Using the Tree Map,” on page 125
¢ Section 10.4, “Using the Pivot Grid,” on page 127

Launching the Analytics Tools

These procedures briefly introduce you to some of the capabilities of each of the applications. You will
discover more capabilities as you work with each of the applications on your own.

1 From the Start menu, select File Reporter 3.5 Data Analytics.
The following login screen appears:
2 Enter your login credentials and click Login.

Login El

Web Service URI | https: /ffilereporter, dynamics. cctec.org
Lser Mame dynamics\administrator

Password Illllllllllll

A selection dialog box similar to the following appears:
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122

©

Logout Server &
Identity System & | Network Path
Load from Database N [ —

Database Connection

3 Expand the shares and volumes.

Server &

Identity System

4 Server: CCTEC3
CCTEC_TREE
CCTEC_TREE

b Server: dynamics.cctec.org

a | Metwork Path

\\CCTEC3WOL1
\\CCTEC3\oL2

b 4 Server: dynamics.cctec.org

dynamics. cctec.org
dynamics. cctec.org
dynamics. cotec.org
dynamics. cotec.org
dynamics. cotec.org

dynamics. cctec.org

V\dynamics., cotec, org\DFS\Atanta\Atantashare
Vidynamics. cctec.org\DFS\Atanta\Atlantalisers
Vidynamics, cotec, org\DFS\HOQ\HQShare
Ydynamics. cotec, org\DFS\HQ\HOUsers
Vdynamics., cotec, org\DFS YunichMunichShare
Vidynamics. cotec. org\DFS YMunich MunichUsers

4 Double-click the File System scan you want to analyze.
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The data from the scan is presented in the Dashboard.

m -

Storage Target: \\dynamics.cctec.org\DFS\HQ\HGQShare B

Filters. B summary Data

Top Owners by Size B Tap Extensions by Size v} Cramers

o M " 22

* o L Fie Exterrsiors

ey s 5 "

w v f .- 36
Fie Ext, @ 12 5 O

s g *8 e

=) ~ T L n 3
Wi |
4 anc 1 B 1.03K
e L ) B
= - T T T T TR \ mar: | - :
o oo BT TRV Admieistrators: 33 38 —r Bt % | s Totd Bytes
i b
W confiy " i 5.33M
W o v o pote o oo s .

Files Created by Year B B Files Hodified by Year r]

Using the Dashboard

NOTE: The exercises in the remainder of this chapter introduces you to some of the very basic
analytical features of the Analytics Tools. Through familiarizing yourself with these basic features, you
will become proficient enough with these tools to try more advanced features.

In the Filters region of the Dashboard, deselect one or two of the check boxes and observe how

the changes are reflected in the Summary Data, Top Extensions by Size, and Summary regions
of the Dashboard.

In the Files Created by Year region, click a specific year.

Observe the changes in the Summary Data, Top Extensions by Size, and Summary regions of
the Dashboard.

The graphical displays in the Summary Data, Top Extensions by Size, and Summary regions of
the Dashboard are driven by the Filters region and the selected years from the Files Created by
Year and Files Modified by Year regions.

In the Summary Data region, place the cursor over a pie graph section and observe how
sectional-specific information appears in a balloon.

Double-click the pie graph section and observe how the Dashboard drills down to show data
specific to the selected section in the Summary Data, Top Extensions by Size, and Summary
regions.

Right-click a section of the new pie graph and select Details Grid to view the individual
filenames.
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10

11
12

s Filtered by: DYNAMICS\gnance m - 80 x
Home
— % g
Open Folder Export Export
to Excel  to CSV
ES
Full Path Mame File Mame E... | Size Owner Create Tme | Modify Time | Access Time | Index Parent Inde]
\\dynamics..,  conusee.mov | mov 152 bytes  DYMAMICS... 6/22/2018 ... ©/22/2018... 6/22/2018... 671 Ly
W\dynamics... eventual.avi avi 688 bytes DYMAMICS... 6/22/2018 ... 6/22/2018... 6/22/2018 ... 674
\\dynamics... | burns.bin bin 504 bytes  DYMAMICS...  6/22/2018 ... 6/22/2018 ... &/222018... 696
\\dynamics... scratch.docx  docx 422 bytes DYMAMICS... &/22/2018 ... 6222018 ... 6/22/201& ... 714
\\dynamics.., sorbets.m4a m4a 474 bytes  DYNAMICS... | 6/22/2018 ... ©/22/2018... 6222018 ... 715
\\dynamics... outrun.app app 443 bytes DYNAMICS... | 6/22/2018 ... ©/22/2018 ... 6222018 ... 732
\\dynamics...  mobilized.w... wma 89 bytes DYMAMICS... |6/22/2018 ... 6222018 ... 6/22/2018 ... 791
\\dynamics... gum.avi avi 911 bytes DYMAMICS... &/22/2018 ... 6222018 ... 6/22{2018 ... 811
\\dynamics... releasable.rtf  rtf 833 bytes DYMAMICS... |6/22/2018 ... 6222018 ... 6/22/201%8 ... a18
\\dynamics.., overcoat.mp4 mp4 433 bytes DYNAMICS...  6/22/2018 ... ©/22/2018... 6222018 ... 835
\\dynamics... ' perches.gz gz 581 bytes  DYNAMICS... |6/22/2018 ... 6/22/2018... 6222018 ... 837 v
Total Cou... 5UM=3 MB
< >

From the grid, right-click a file and select Open Folder to open the folder where the file is located.
The Dashboard gives you the ability to easily access any files you might want to know about.
Close the grid.

Drill up to the originally displayed data by clicking the Drill Up arrow pertaining to the Summary
Data region of the Dashboard.

In the Top Extensions by Size region, place the cursor over one of the bars and observe how
sectional-specific information appears in a balloon.

In the Top Extensions by Size region, right-click and select Export to Image.
Save the image to a location on your desktop.
The graphic can now be used in a presentation or report.
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14

15

16

17
18

Top Extensions by Size

2.1M
1.8M
1.5M

1.2M

Size (Sum)

0.9M

0.6M

0.3M

&

E——

(3unoD) 8zis

oM
Exe config

In the Files Created by Year region, double-click a year span and observe how the displayed

log

csv

data in the other regions is updated to data pertaining to the selected year.
Right-click the selected year span and select Clear Master Filter to have the graph span all of the

years again.

In the Files Modified by Year region, double-click a year span and observe the change in the

displayed data in the Dashboard.

Place the cursor over a bar in the Top Extensions by Size region, right-click and select Print

Preview.

Observe that in addition to printing, you can save the graph as a PDF or email the graph.

Close the Print Preview page.

10.3 Using the Tree Map

The Tree Map lets you view graphical representations of hierarchical file system data and in the

process, gain insight very quickly.

1 From the Dashboard, click Load from Database.
2 Browse to select the file system scan you want and double-click it.

3 Click Tree Map.
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& Vidynamics cotec angDFSIHG iHGShane
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Observe how the Tree Map is presented according to file extension type with the specific color
assignments detailed in the File Extension region.

Each of the squares in the Tree Map represents a single file in the scanned storage resource.

The squares are represented according to the file size, relative to all of the other files in the scan.

Click one of the larger squares to view the details of the file in the Properties region.
Right-click the file and select Open Parent Folder to open the folder where the file resides.
This gives you the ability to easily access any files you might want to know more about.
Expand the file system so it is displayed in the Folders region.

Click one of the folders to see the group of files that reside in that folder.

The files belonging to a selected folder are outlined by a magenta colored outline.

Right-click a folder and select Set Scope to drill down and view the contents of the folder in the
Tree Map.

In the Folders region, right click the listed scan and select Reset Root Scope.
Click Owner.
The Tree Map now displays files according to owners.

Using the color classifications in the Owner region, observe which users are storing the largest
files.

Click Date Range > Access Date.

Observe how the data in the Tree Map is now classified according to when files were last
accessed.

This is one of the most powerful means in File Reporter of quickly determining the relevance of
data being stored on network storage resources.
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10.4 Using the Pivot Grid

The Pivot Grid gives you the ability to visually analyze data according to combinations of variables.

1 From the Dashboard, click Load from Database.

2 Browse to select the file system scan you want and double-click it.

3 Click Pivot Grid.

m e Pvot Gnd ! e Reeontes Diska Arialylics - 3.5.0 ®
Home | Chart  Reports
R E S EE O, T a5 L
¥ 1 b ; [ rieextension [} modey vear ’ gl Show Chart
Loadfrom Loadfrom Sevets  Dashboard Pwot  TreeMap | LosdFwot SavePnot | Resetal = X Case Senmtve u
Catabase Fie Fie id Layout Layout Felds. 3 Duplicate Fies | Access Year -
Scan Data Diata View Pivel Grid Layout. Fivol Grid Presels Prvul Grid Settings Pl Grid Disglay i
Pivol Fickls L
Drag Tems o fhe ProsGrid =]
Py —— Grand Tokal
= ye— Srad Tald Dvega
b L Create Tame
B3 Modfy Tme
B3 Fie Extersion
83 Fie ame
BH owner
4 [ Heansrs
BH count
29 ser
Drag felds between areas below:
°F Fiter area TR Colmmn Aren
Chart 2
= 0THHI2I2IATIANL Graed Total
&8 Ao Aren Z Datn Aeca =
03981071 70553497
0.199526231496888
Defer Layout Update ]

4 From the Pivot Fields region, select Size (residing in the Measures folder) and drag it up to the

area marked Drop Data Items.

5 Again in the Pivot Fields region, select Owner and drag and place it in the area marked Drop

Row Fields Here.

6 Observe the totals now calculated for the two data variables.
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vome | Chart

1Grid

Reports

Phosit Grid - Fie Aeporter Diat Analytics

35.0 | - o0 x

EwCBzZE & @ Oi 2o- O &
) E ' [ Fie Extension  [5] Moy tear = o & gll S Chart
load bom  Losd bom  Savels | Dashboard ool TreeMap | LoadProl SeveProol | Resetdl Case: Sonsitive. Reesct A1 Al Fit
Database  Fie e Gnd Leyout  Layout ek ([ Dushcate Fles (] Acosss vear DockPanels  Data Colmns
Scan Data Data View Prvut Grid Layout Pivol Grid Presels Pivol Deapda; o
¥Dechboard | [IR] Tree Map m .
PivOL Fieids a
Drag ltens o theprotsnd | B ||150°
4 |y omensions e D
+ B3 ecrssTme UILTINVAdmis. .. zm -
+ B Create Time DTMAMICS \cox 24K
. OTHAMICS \ataft 0
" I:_| T DYMAMICS hrlark 3LKE
53 Fie Extension CAMAMICS el .. 23KE
B rie pame CINAMICS ey 24K8
o B Measures EYMAMICS pbwcnr: WE
B count DYMAMICS fecla... 1K
DAMAMICS Vian... 23KE
DrTrAMICS frachols 15 KB
DreaMiCs\frch.... EEL
DTTAMICS \galiman Fald
DiYMAMICE \gnance 1)
CIYMAMICS Yaalers 27K
CYMAMICS san... ET
R LR e et L DMAMICS forer .. 15kE
Frterares  [17] Cohm aren || DIMAMICS Yoorrer %18
DYNAMICS yoole... 33KE v
Chart L]
| EETT
&5 fow Area Z oatn Area
owner & e iH
Defer Layeut Update Updatz(| o

From the Pivot Fields region, expand Access Time to locate Access Time (Month) and drag it up

to the area marked Drop Column Fields Here.

. Preol Gred Pivait Grid - Fie Reporter Data Analytics - 3.5.0 M - O x
vome | Chart  Reports
NI IR = =
L0 E ' - [ Fie Extension  [5] Moy tear = o & gll S Chart
load bom  Losd bom  Savels | Dashboard ool TreeMap | LoadProl SeveProol | Resetdl Case: Sonsitive. Reesct A1 Al Fit
Database  Fie e Gnd Leyout  Layout ek ([ Dushcate Fles (] Acosss vear DockPanels  Data Colmns
Scan Data Data View Prvut Grid Layout Pivol Grid Presels Pivol Deapda; o
anpachkboard | [IR]Tree M -
Pivot Fieids a
Drag Items 1 the Prvatnd a e Access Time (Month) &
« B Dmensons Cumer - May June Grarnd Total
2 B RecrsaTme UILTINVAdmis. .. zm v -
OTMHAMICS L L
HH access Time Pl
99 hecess Tme DraMICS \ataft nm 21K
. s e O | ssncspare IKE 318
el T — 23KE 23KR
AR access Tme (ree) || pyasincs pndiey 24K 2408
b B Create Tme DAVMAMIES ko IR IR
+ [ mody Tme DYMAMICS fecla... 21K 2148
B3 Fir Evtension DAMAMICS Vian... Z3KE 3KB
15 Fie raame: DVPAMECS frichols 15KE 15K8
4 B Measures CMAMECS\frich. .. el 270
29 Cont DTTAMICS \galiman el oL
DiYMAMICE \gnance v KB 3m8
CIYMAMICS Yaalers 7B 7R
CYMAMICS san... EL 248
R LR T et L DMAMICS forer... 1BKE 1RKR
Friteracen [T Cohrmn areg | | DMAMICS foorner ®KE %48
DYNAMICS yoole... I3KE 338
[T L. v
Chart L]
I ey
&5 fow Area Z oatn Area
owner & e iH
Defer Layeut Update Updatz(| o

8 Click the filter icon from the Access Time (Month) filter that you just placed.
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9 Deselect all but one month and OK.

10

%R @ i

o] (Show all)

v May
w'| June

Click the Chart tab.

11 Highlight three consecutive rows to view the data analyzed as graphs in the Chart region.

12
13

14

15
16
17
18

/| - Prvot Grid Fivat Grid - Fie Reporter Data Analytics - 3.5.0 M - O x
wome | Chart | Reports
M bk i
Chort Lo Charl  Sarve Charl =
wazsrd  Layout Layout Ll
Chart Layeut o
sthoachboard | ] Tree ao 3
Pivot Fieids L
= T a7
Drag ltens o theprotsnd | B ||150° Acon Time ety
[Fy— Cnrer - June
4 B aa DTMAMICS iacoi 24m -
OTAMICS ataft nmw
HH access Tme
nm
rss T
i I 23KE
92 Aucess Tive (Qu.. e
AR Access Time (rear) 2K
b [ Create Tive k8]
v 3 moddy Time CAYMAMICS Vlan,.. 23KB
B3 Fir Evtension CAYNAMICS richols 15KB
15 Fie raame: DTMAMECSfrich.... FEL
2 B Measres DTAMICS igalinan EL]
23 Count DTAMICS ignance L]
CYMAMICS Ybalter 7
C aKE
Ll
Cray fieds betmeen aress below: e
P rier aren 1 Cokamn arep | | YMAMICS yoe.... 33KB
CYNAMICS wbar .. 198
fcgess ., a ¥ = v
Chart 2
I 2un
&5 fow Area Z oatn Area
Owrer . aze we

Defer Layeut Update pdat [}

From the Chart Presets options, experiment with different chart views of the data.

Double-click a selected cell from the table to access the Scan Data Details table specifying all of

the files accessed by that user during that month.
From the Scan Data Detalils table, right-click a file and select Open Folder to open the parent

folder of the file.

With the parent folder open, you can examine the file, move it to another location, or delete it.

Click the Reports tab.

Again, highlight three consecutive rows.

Click Generate Report.

Observe that you have the option to print the report or export it to a number of different formats.

Using the Client Tools

129

9T0Z 1aqwanoN TT (ud) sAsaop



docsys (en) 11 November 2016

Using the Client Tools

130



11 Using Report Designer

Report Designer allows you to design reports locally from a Windows workstation, while offering

significantly more reporting design capabilities to those of the browser-based administrative interface.

11.1 Using the Report Designer Interface

NOTE: You must be a member of the SrsAdmins group to design reports using Report Designer. The

name SrsAdmins is the default name (which you can change) of the File Reporter administrators

group created during the installation of the Engine.

1 From the Start menu, launch the Galileo 3.5 Report Designer.

Login X
Web Service URI
Liser Mame
Password
Login Cancel
2 Enter the login credentials and click Login.
Eﬂ File Reporter Report Designer - 3.5.0 Mm - O x
18- Main
SIER "Y ] @i =
) =B XSG B » S
MNew Custom  Rename Copy Delete Refresh | EditQuery DesignReport Clear Report | Visit Community Access Online
Query Repart Layout Portal Templates
Manage Edit Cnline Resources el
Report Name: 4 | Report Type T | Report Owner Last Modified d
? |No ... [Unknown]
| Custom query report Custom Query dynamics\administrator 41/2018 5:52:... B85
b KE-! Find Access DB Files Custom Query dynamics\administrator 3/24/2018 9:45... 33
E.! Find Media File Types Custom Query dynamics\administrator 3/24/2018 9:45... 35
ﬁ-! Home Folder Summary with Owner and Quota Custom Query dynamics\administrator 3/24/2018 9:45.., 36
E.! Training Group Permissions Quota and Remainder Custom Query dynamics\administrator 3/24/2015 9:45... 34
ﬁ.! wfe volumes at latest scan Custom Query dynamics\administrator 3(24/2018 9:45... 32
| [Report Type] = 'Custom Query' Edit Filter
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3 Familiarize yourself with the Report Designer interface.

All Custom Query Reports are listed. Those that have not been designed using the Report
Designer Layout interface are displayed with the green-bannered text icon, while those designed
using the Report Designer have the blue notebook icon.

All of the options on the toolbar are available by selecting a report and right-clicking.

New Custom Query Report: Click to create a new Custom Query Report by launching the
Query Editor.

Rename: Click to rename a selected Custom Query Report.

Copy: Click to create a copy of the report definition of a selected report.
Delete: Click to delete a selected Custom Query Report.

Refresh: Click to refresh the list of saved reports.

Edit Query: Click to edit the SQL commands pertaining to a selected Custom Query Report
through the Report Designer’s Query Editor.

Design Report Layout: Launches the Report Designer Layout interface. For more information
on the Report Designer Layout interface, see Section 11.3, “Designing a Custom Query Report,”
on page 135.

Clear Report Layout: Click to clear custom design settings created using the Report Designer
Layout interface. This is a nonreversible procedure.

Visit Community Portal: Click to access the File Query Cookbook website.

g) File Query Cookbook I O

Serving tasty file reporis one query at a fime!

HOME CUSTOM QUERY RECIPES FORUMS HELP

User login

Usomame * Welcome!
Each day we go about our business whether we create software, train a child in a school district, build planes in aerospace,
. provide healthcare, insure peoples stuff, etc. We all have data with varying degrees of importance, some highly critical to the
Passiand business directly and some highly critical to our customers, while other data is the communication that helps our business units
successfully work together. Each of the data types have similarities in size, age, ownership, and a level of security.
* Create new account Having the ability to query our data helps us to answer a number of questions:

= Reguest new password

How old is the data?
How often is the data being accessed?

+ Where's the data?
_— = What types of data are we maintaining?
» Who owns the data?
» Who has permission to access the data?
Privacy Policy » How fast are we using up our storage space?
H
»

Once queried the data needs to be collated into reports. These reports are read differently based on the perspective of the
individual. A volume free space report, read by the Director of Information Technology will not be read with the same
perspective as the Business Manager, as the former is figuring out the storage budget, while the other is wondering where the
all the current data is. Reports may need to be laid out differently in order to drive the business intelligence needed, based on
perspective.

This site attempts to help you learn how to write queries and generate report layouts to help you achieve a new level of success,
while supporting, maintaining, and protecting your storage.

File Query Cookbook is a community website for sharing Custom Query reports and layouts
created through the Report Designer. You can utilize a shared Custom Query report by simply
copying the SQL commands in a shared Custom Query report “recipe.” You can also download
shared layouts created through the Report Designer.

Access Online Templates: Click to directly access the list of all available Custom Query reports
shared on the File Query Cookbook website. From the Custom Query Recipes page, you can
filter your search by category, database host, and more.
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11.2

Filter: The cell directly below the Report Name column heading is a report filter that lists saved
Custom Query reports according what you enter. For example, if you were to enter the word
access, the listed Custom Query reports would be only those with the word access in the report
name.

[Report Type]: By default, this check box is selected so that it displays only Custom Query
Reports, which are the only reports that can be designed using the Design Editor. You can
deselect the check box to view all of your reports.

Edit Filter: Use this button to further refine your filtering using Boolean operators.

Creating a Custom Query Report

NOTE: For details and examples of the supported database functions, tables, and views that you can
utilize in Custom Query reports, refer to the Micro Focus File Reporter 3.5 Database Schema and
Custom Queries Guide.

1 Click New Custom Query Report.

New Custom Query ;3

Mame |

2 Specify a descriptive name, then click Create.
The Report Designer Query Editor is launched.

Query Editor - Custom Perms 2 = [} hes
I Main
E > /] iy SOL Text Editor — e
- )
1 &2 Query Builder
Save Execute Reset All Refresh Design
Query | 2 QueryResults  Dock Panels Schema Layout
SQL Query View Schema Options Report Designer
SQL Query Text X ot
SQL Query Buider nox |
* %1 Main 4 Q Main
— - /7 Expressions
4. s-rrs IE‘ + [Z2] Objects
b ik srs
Visible | Expression Calu Sort Type Sort Order Aggregate Grouping || .
Hiv| m :
< >
SOL Query Builder  SQL Query Results
Records Loaded : 0
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3 Inthe SQL Query Builder region, expand srs to see the Tables and Views folders.
4 Expand either the Tables or Views folder.

5 Expand a displayed table or view.

6 Select the tables and fields you want included in the query by double-clicking each.

Query Editor - Custom Perms 2 = [m] X

I Main

&7 S0L Text Editor
i
] (&3 Query Builder
Save Execute = Reset All Refresh Design
Query 7| 2 queryResults  Dock Panels Schema Layout
SQL Query View Schema Options Report Designer
=
A
2 srs.current_ntfs_aces.fullpath,
3 srs.current_ntfs_aces.trustee_display_name,
4 srs.access_mask _basic string(srs.current_ntfs_aces.access_mask, 2) AS basic_permissions,
5 srs.current_ntfs_aces.ace_type_string
6 FROM
= e e v
SQL Query Buider 3 Xx
‘ x 1 Main 4 Q Main
: e O 4 ¢ Expressions
. IR QL NTETYL B pCancaia A 7 fullpath (srs.current_ntfs_aces)
b [ current_fs_scandata_edir —
current nt... X < trustee_display_name (srs.curre...
» |2 current_fs_scans 6
- . < basic_permissions: srs.access
+ Bl aarent.ncp_trustees LI ace_type_string (srs.current_n
» | current_ntfs_aces []  identity_system_nam . .J _Type.s g Nt
B ” 0 identi A 4 [] Objects
b |E=] current_permissions_scans : [ identity_system_dom; B current,_ntfs aces (sr5)
= E| _ntfs_:
b |2 previous_fs_scandata ‘j: server charscier van =
b [ previous_fe_scandata_ad ] scan taget charact
v |=] previous_fs_scandata_edir ] fullpath text &
* ‘—‘ previous_fs_scans ‘ Visible ‘ Expression | Colu.. |Sort Type Sort Order ‘ Aggregate |D Grouping
» | previous_ncp_trustees —
=L X S v| B sm.cument_ntfs_.. O &
v [ previous _ntfs_aces <l =
» [T previous nermissions sc.. ¥

SQL Query Builder  SQL Query Results

Records Loaded : 6,118

7 Append the query with any additional SQL commands in the text editor.
8 Click Execute Query to get a preview of the Custom Query Report.

Query Editor - Custom Perms 2 — O X
E > SQL Text Editor '1 E
[l & Query Buider D S
Save Execute — Reset Al Refresh Design
Query || E2 QueryResults  Dock Panels Schema Layout
SQL Query View Schema Options Report Designer
A

2 srs.current_ntfs_aces.fullpath,

3 srs.current_ntfs_aces.trustee_display_name,

4 srs.access_mask_basic_string(srs.current_ntfs_aces.access_mask, 2) AS basic_permissions,

5 srs.current_ntfs_aces.ace_type_string

6 FROM

& T S e v

SQL Query Results - Limited to 10,000 Records 1 X
fullpath |(IustEE_display_namE basic_permissions |atE_typE_

+ [ \\fmsadutp.nfms. utopia.novel.com A tantaUsersHome {onaborsApproved Video Files  : NFMSibnabors FMELRW Access Allo... | A
\\finsadutp.nfms.utopia.novell.comAtiantzUsersiHome \pnabors'Approved Video Files | NFMS\bnabors MELRW Access Alo...
\\fmsadutp.nfms.utopia.novell. com\AtantaUsers\Home \bnabors\Approved Video Files | NFMS'bnabors ELR Access Allo...
\\fmsadutp.nfms.utopia.novell. com\AtantaUsers\Home \bnabors\Approved Video Files | BUILTIN\Administrators FMELRW Access Allo...
\\fmsadutp.nfms.utopia.novell.com\AtantaUsers\Home \bnabors\Approved Video Files | NT AUTHORITY\SYSTEM FMELRW Access Allo...
\\fmsadutp.nfms.utopia.novell. com\AtantaUsers\Home \bnabors\Approved Video Files | \CREATOR OWNER FMELRW Access Allo...
\\fmsadutp.nfms.utapia.novell. com\AtantaUsers\Home \bnabors\Approved Video Files | BUILTIN\Administrators FMELRW Access Allo...
\\fmsadutp.nfms.utopia.novell.com\Atantalsers MFMS'nfrproxyrights ELR Access Allo...
\\fmsadutp.nfms.utopia.novell.com‘AtantaUsers MFMSYNSMProxyRights FMELRW Access Allo...
\\msaduto.nfms.utopia.novell. com\Atantaliser: MFMS\Domain Adrmin: FMELRW Arcess Allo, o

SOL Query Builder  SQL Query Results

Records Loaded : 6,118
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9 Click Save.
10 Close the Query Editor.

11.3 Designing a Custom Query Report

After you have created a Custom Query Report, either through the Report Designer Query Editor or
the Query Editor built into the browser-based administration interface, you can design the layout of

the report.

NOTE: This exercise introduces you to some of the very basic design features of the Report
Designer. Through familiarizing yourself with the basic features, you will become proficient enough in
the interface to try more advanced features.

For a more detailed explanation of features in the Report Designer, refer to: https://
devexpress.github.io/dotnet-eud/interface-elements-for-desktop/articles/report-designer/report-

designer-for-winforms.html.

1 From the listed Custom Query Reports, select the one you want to design.

] File Reporter Report Designer - 3.5.0 M - O =
18- Main
= ™ === I eji I
==Y EE5 1 il
) =t X G B M & N
Mew Custom  Rename Copy Delete Refresh Edit Query DesignReport Clear Report | Visit Community  Access Online
Query Repart Layout Portal Templates
Manage %Edit Online Resources ~
Report Name a | Report Type ¥ | Report Owner Last Modified Id
a = [Unknown] o = =
Extension Report by Category Custom Query dynamics\administrator 6152018 12:5... 23
Sodial Security Numbers in Atlanta Files Custom Query dynamics\administrator 6202018 10:1... bl
v| [Report Type] = 'Custom Query' Edit Filter

2 Click Design Report Layout.
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B v Pile Reporter Report Des = B8
“ RepcrtDesgner  Prink Previen
e e — R Qaomout | =
I F ] { mes Mew Homan ~ H - . s M
0 . + L 24 | O 200m - L |5
Open... Save | RefehDota Dowrload Bt Query 975 v = Layout Winders | Sarighs
B Brdngs Al Data - BIUKS . - @ 2e0min
Rtport Report Data Edt Font Algrment Zoom Ve St

-+ rer .

standard Controls -~ (S 3 [} X S e a (1] Report Data
» (EH Query Resuies
o
A Label
[=] CheckBox
B enText |
& e Box e
B el |

Bl Character Combs

s Line =
- [ Report Explorer i Fiekd Lint
& Shace
Bar Code Property Grid Cl
wl Chart ; Custom{uerfepartBase Repart
Gauge y B 41 (5 F
B Sosidne Appearance
[: QT Background €. [ Traragarenst

Bl Tabie 0f Contents Bordder Color | (NN Black
B rageinic Bordes Dlah 5., Sokd
Border Width | 1
"B Page bresk Group and Sort s x - P
s Cressband Line

8 cromband Bex

Foreground C.... I Black
0.9,0,0

Fiekd Mame Sort Order Showtieader  Show Footer » Paddng
Pasge Coler

Style Sheet

sroun and Sort ks Errors
B St [ig oo B

a: 0 | fi Partal query resits inuse

3 Create a report header.
3a Place the pointer in the upper section of the layout grid.
3b Right click and select Insert Band > Report Header.
A new ReportHeader band appears on the grid.
4 Resize Page 1 and add a page break.

4a Place the pointer on the bottom border of the new band and using the vertical ruler as a
guide, extend the band to fill the first page.

For example, to fill the first page, you might extend the border down to the 8" mark.
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4b From the Standard Controls region, click and drag a Page Break to the bottom of the band.

0o Fie Aeporter Repert Desoner 3.5.0 M - 0 X
ReportDesgner | Print Preview

BEE & B XD000 = RECERlR=a=11

Open... Seve RefreshOats Downlosd  Edit Query Cut Copy Lavout Windows STets
- Brdngs  AlData - - -

Report Report Data Edt Font Adgriment Zoom View Soripts »
Toolxox PRI Extiension Report by Category Faekd List o8 x
Standard Controks A | 4 . : i C 3 i [l S S 7] Regort Data

; A v E QueryResits

Lkl

Ched: Box.

Rich Text

Picture Box

Une .
[E] ReportExplerer | gy Fiekd st
Shape

S Bardode Property Grid o x
ul et B v [@oes pagrHreakl Page Break v
T Gauge B 4 (B F
= spiane o
B Fvstend " b Seripls (Contrel Seripts)
Al Table Of Conbenis . vishie es
= i Design
G Paelnfe < > Py e —
"5 Page reok Group and Sort y % Layout
s Cross-band tne + Location 0, 780.71

T AddsGroup~ T AddasSortr R . . b SeupLine Margin 0,0, 0,0

B cross-band Box

Pl Narree Sort Crder Show Header | Show Foater

5 Insert and design a chart.
5a From the Standard Controls region, click and drag a Chart to the band.
The Chart Designer is launched.

Chart Designer = IEX
L]

+ [l ot
I seve ()
Toolx =] Legerd Appesrance: Defoult (A Colors] | w oA x

hH’?i

Opsons | propertes | Dats

] Addtonal Legends (5] Paletie; Defadt EEEEEDE -
Bl rites ) Bk Cir ]
* Por i Anotatons (1)

Musta Laryout

Thera are no visible senes 1o represent in a chart
Try to add new senes, or make sure that
L A least one of tham is vigible

0 e
L4 Pagl
B Payl
e o Reman,
= ool

' Disgilay the designes every time 8 rew chart s added o Cancel

Tr Gow sd 5t | [ sopu Lrors

5b In the Chart Designer, below the Chart menu, click the + that pertains to the Series option
and select the Bar option.
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5¢
5d

Chart Designer

Q| & »

4 [oll] Chart
[l series (@)

i B E E

i
©
[Enter text to search... [2]
Bar Series -
-
s
Bar Stacked 100%
Side By Side Bar Stacked
Side By Side Bar Stacked 100%
Bar Series 3D
-
Bar 3D stacked
v

There are no visible series to represent in a chart.
Try to add new series, or make sure that
at least one of them is visible.

Display the designer every tine a new chartis added

Options | Properties
APPEARANCE

Appearance:
Palette:

Back Color:

BEHAVIOR

Auto Layout:

Data

Default (All Colors) ||
[Defoult ENENEE|v|

| ﬁ
9T0Z JaqwanoN TT (ud) sAsaop

oK Cancel

Chart Designer

@ K &
a4 o] Chart
a [l series (1)
» Series 1
4 [F] ¥v-Diagram
» Default Pane
Additional Panes (0)

Primary AxisX

Primary AxisY
Secondary X-Axes (1)
Secondary Y-Axes (0)
Legend

Additional Legends (1)
[ Titles (0)

[ Annotations (0)

Display the designer every time a new chart is added

Options | Propertes
GENERAL

Visible:

Name:

Show in Legend:
Labels Visibilty:

View:

VIEW: GENERAL

Bar Width:

Color Each:

VIEW: LAYOUT

Pane:
K-Axis:

Y-fuds:

VIEW: BORDER.

Visibilty:
Color:

Thickness:

VIEW: APPEARANCE
Color:

Fil Mode:

Data

Default Pane
Primary AxisX [v]
Primary AxisY [v]

Click the Date tab and expand Query Results.

Click and drag Category to the Argument cell.

5e Click and drag cat_size to the Value cell.

5f
59

Click the Options tab and in the Name field, replace Series 1 with Category Size.

Below the Chart menu, click the XY-Diagram option.
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5h

5i
5

5k
51

5m

In the Options tab, select the Rotated check box.

Chart Designer o IEM
@ R i
Options | Propertes
4 [ual] Chart
fl 95 W category Size
4 [ series (1) =
9
4 Category Size Rotated: &
Label 85 Pane Layout Direction: Vertical v
Paints (2) .
Indiators (0)
75
a4 [ xv-Diagram
» Default Pane 7
Additional Panes () o5
» Primary Axisk
b Primary AxisY 5
Secondary X-Axes (0) 55
Secondary Y-Axes (0) .
[22] Legend
Additional Legends (0) 45
[ Tites () P
[ Annotations (0) is
3
25
2
1.5
1
05
0
-0.5
0 2 4 5 8 10
7| Display the designer every time s new chartis addsd [ o ][ cona |

Below the Chart menu, select Titles, click the +, and select Title.

In the Options tab, in the Lines field, replace Chart Title with a more descriptive name.

For example, File Extensions by Category.

Below the Chart menu, select Category Size.

Click the Properties tab, scroll down and under the Elements heading and expand View.
Change the Color Each setting to Yes.
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Chart Designer
@ | «# i
a [oll] Chart

File Extensions by Category

a [l series (1)
4 Category Size
Label
Points (0)
Indicators (0)
4 [ xv-Diagram
» Default Pane

Additional Panes (0)

Primary AxisX

Primary AxisY

Secondary X-Axes (0)

Secondary Y-Axes (0)

Options | Propertes | Data

Enter text to search... [v]

Show in Legend Yes A
Tool Tip Enabled Default

Tool Tip Point Pattern

Tool Tip Series Patterr {S}

» Top N Options (Top N Cptions)
Value Scale Type | Numerical
Data -

Argument Data Me. ..
Color Data Member

Data Filters (Collection)
Summary Function

Tool Tip Hint Data M..

+ Tool Tip Image (Chart Image)
Legend » Value Data Members | (Collection)
Additional Legends (0) Elements -
b Label (Side-by-Side Bar Ser...
Tithes (1
4 [ mites (1 4 View (Bar)
Title Aggregate Funct..| Default
A Annotations {0) Bar Distance o
Bar Distance Fixed| 1
Bar Width 0.6
» Border {inside Rectangular Bord. ..
Color ]
Color Each Yes
Equal Bar Width | Yes
» Fill style (Rectangle Fill Style)
Pane (Default Pane)
» Shadow (Shadow)
Tag
Transparency | O
X-Auis Axis X
T ¥-Asis Axis Y
10 Mise <y
Display the designer every time a new chartis added oK Cancel
. Fle Reporter Repert Designer 1.5.0 m - 0O x
Repeort Designer Print Preview
= 5 x K -3 . o . f— L .
= (T4 ] ) u = 2] ml e
Open... Save RefreshDats Downlosd  Edt Query Cut Copy  Paste undo F I Layout Windows Srpts
- Brdngs  AlCata - - -
feport Repart Data Ldt Fant Zoom L et o
Toolox ax Fieid List o8 x
Standard Controk - 4 1 LN} T T i [ T p | ) Report Dsts
- + [ Query Remits
* Poler : 5 T 5
A e - File Extensions by Cate... &
B Checkiox .
9 Ju— 7 —
[E] Fuch Text fr—
_ -
] Picture Box o b - .
@ Fenel | , -
M Tabe -
B Character Comb v
\ Lne N
" ¥ . ¥ Aeport Explorer g Field List
oy Thape o
B B Code Property Gnd orx
ul et B~ @ow chart! Chart -
@ Gauge Bh 4l | F
= ipwkine . Apprarance A
B Prot N Appearance N.. Defadt
[l Table 0f Contents - Badkground €., [
X . b Background 1. (Rackground Tm_
L_’ oo A M o Border Color | [ Black
o Page ek Group and Sort. 2 x Serder Davsh &.. Sold
8 Crossband Une Dorder Width | 1
e % AddaGroup = % AddaSorte O Meve Ug " —
e Fiedd Name: Sort Order Show Header Show Footer » Fll Style
Imagge Type
Incicators Pl...
+ Paddne B3

50 In the upper right-hand corner of the newly-placed chart, click the arrow to access the Chart

Tasks menu and select Run Designer.

5p Click the legend and from the Options tab, deselect the Visibility check box so the legend

no longer appears.
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5q
5r

Click OK.
In the Report Designer, expand the view of the chart to take up more of the page.

6 Insert labels.

6a From the Toolbox, click and drag Label to a position centered below the chart.

6b

6¢c

[§] ReportExplorer  gin Fesld List

[] 1 H 3 4 1 § 7 i [} 10 Property Grid o8 x
labell Label v
4 N F

Appearance
Background C... [ Transparent

Double-click within the label and specify the label name.

For example, Total Size.
Adjust the font size and style to your preferences.

7 Create new fields.

7a
7b
7c

7d

7e
Tf

79

From the Field List, expand the Query Results.
Right-click Query Results and select Add Calculated Field.

In the Design region of the Property Grid for claculatedFieldl, change the (Name)
setting to cfTotalSize.

While still in the Property Grid, under the Data heading, click the ellipses (...) pertaining to
the Expression field.

This launches the Expression Editor.
In the bottom-left column, select Functions.

In the empty field at the top of the middle column, type sum to locate the Sum function, then
double click Sum to place the function in the top text box of the Expression Editor.

In the bottom-left column, select Fields and then in the middle column, double-click
cat_size.
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7h
7i
7]

7k

7l

m

sum([cat_size])

Fields A £ | The type of this field is:

System.Int64
Report Items 4 [EH Query Results

Constants ] cat_size
Operators |ab]| cat_size_string
4 Functions (] category
Aggregate [123] file_count
DateTime
Logical
Math
Strina bl

oK Cancel

Expression Editor E3

Click OK to save the new filed and close the Expression Editor.
Right-click Query Results and select Add Calculated Field.

In the Design region of the Property Grid for claculatedFieldl, change the (Name)
setting to cfTotalSize_String.

While still in the Property Grid, under the Data heading, click the ellipses (...) pertaining to
the Expression field.

In the top text box of the Expression Editor, type Byte so that ByteString() appears.
From the middle column, double-click cfTotalSize that you created earlier and click OK.

8 Place the new fields.

8a From the Field List, hold down the Control key, select the two new fields you just created,

8b

then drag them to the Total Size label on the grid.
Adjust the size so that both fields will appear to the right of the Total Size label.

Using Report Designer

9T0Z JaqwanoN TT (ud) sAsaop



Extension Report by Category *

B

4 1 0

Total Size [cfTotalSize_String[d [ctTotalSize] ]

8c Adjust the font size and style to your preferences.

9 Preview the report.

9a
9b
9c
9d

Click Download All Data.

When the warning dialog box appears, click Yes.

Click the Print Preview tab to observe how the report is going to look at this point.
Make any desired format changes.

10 Create a header for Page 2.

11

10a
10b

10c
10d
10e

10f
10g
10h
10i
10j

Click the Report Designer tab.

In the Report Designer, scroll down below the page break so that you are working on Page

2 of the report.
At the top of the page, right-click and select Insert Band > PageHeader.
From the Tool Box, click and drag a Table to the location of the new page header.
Replace the names of the three new table cells with the following names:

+ Category

+ Size

+ File Count
Select the File Count cell, right-click, then select Insert > Column to Right.
Change the table cell name to Percent of Total.
Resize the table cells to your preferred width.
Adjust the font size and style to your preferences.
Resize the depth of the page header so it is limited to the depth of the table.

Create a new calculated field for Percent of Total.
11la Right-click Query Results and select Add Calculated Field.

11b

In the Design region of the Property Grid for claculatedFieldl, change the (Name)
setting to cfPercentofTotal.
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11c While still in the Property Grid, under the Data heading, click the ellipses (...) pertaining to
the Expression field.

11d From the middle column of the Expression Editor, double-click cat_string.
11le Hit the space bar and then enter the following string: * /100

11f Complete the string by double-clicking cfTotalSize from the middle column of the
Expression Editor.

Expression Editor
[cat_size] * 188/ /[ctTotalsize]
= Y £ | The type of this field is:
stem.Object
Report Items 4 [EH Query Results K :
Constants [23] cat_size
OIIIEFE.ltDTS [zh] cat_size_string
4 Functions [ab| category
Agaregate cfTotalSize_String
DateTime ctTotalSize
Logical [123] file_count
Math
Strirmin R
oK, Cancel
11g Click OK.

12 Insert the table content.

12a Click below the header, hold down the Control key, and from the Field List, select the
following fields in this order:

+ category

¢ cat_size_string

¢ Tile_count

¢ cfPercentofTotal
12b Drag the fields to a location below the header.
12c Line up the tables cells with the headings.
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11.4

11.5

TotalSize  |[cTotalSize St [erTotalSize] g

oflcategony] U [cat_sae_stnng] O [fle_count] @ [cPacentol Total] .

B AddaGroup~ "L AddaSort~

12d Click the Print Preview tab to view how the report will look.
12e Make any needed adjustments.
13 Click Save > Save to Database.

Category Size File Count Percent of Total ¥ Report Explorer g Fieid List

By saving the report to the database you enable the File Reporter Report Generator to use the

report design for updated reports.

In addition to saving the report to the database, you can save the report as a file where you can

import it into another file, such as a Word file or PowerPoint presentation.

Saving the Layout as a Template

When working with the Report Designer, you might create a layout design that you want to utilize as a

template for future Custom Query Reports. You can do so using Save As File.

1 In Report Designer, open the Custom Query Report whose design you want to save as a
template.

2 Select Save > Save As File.
3 Name and save the layout.
The layout is saved as a . repx (Report Layout XML ) file.

Using a Saved Template for Custom Query
Reports

You can use saved . repx files as design templates for Custom Query Reports.

Using Report Designer
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TIP: You can also use the sample report layouts and SQL commands that are available from the File
Query Cookbook, the collaborative community portal for accessing and sharing Custom Query
reports. Both the SQL commands and report layouts can be customized as needed. You can access
the File Query Cookbook directly through the Report Designer interface, or at http://
www.filequerycookbook.com (http://www.filequerycookbook.com).

1 In Report Designer, open the Custom Query Report you want to design using a saved template.

2 Click Open, then select the .repx file you want to use for designing your report.
The report is updated with the design from the . repx file.
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Filtering

*

*

*

Micro Focus File Reporter enables you to utilize advanced filtering capabilities so that your reports
include only the data you want. File Reporter provides this advanced filtering capability for all File

Section A.1, “Filters Tab,” on page 147
Section A.2, “Single Entry Filter Conditions,” on page 149
Section A.3, “Multi-Condition Filtering,” on page 151

Data Reports, which include:

*

*

Filename Extension Reports
Filename Extension Detail Reports
Owner Reports

Owner Detail Reports

Duplicate File Reports

Duplicate File Detail Reports
Date-Age Reports

Date-Age Detail Reports

A.1 Filters Tab

*

*

All filtering takes place in the Filters tab of the Report Definition Editor.

Section A.1.1, “Filter Expression Builder,” on page 148
Section A.1.2, “Relative Date Filtering Parameters,” on page 149
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Figure A-1 Filters Tab

Report Definition Editor - Atlanta Users Owner Report

Name:* Atlanta Users Owner Repart
Unformatted: D
Type Owner Report
le iption Report Definition created on &/14/2018 11:05:53 AM by

DYNAMICS\Administrator

TARGET PATHS FILE MANAGEMENT POLICIES FILTERS

EXPRESSION

RELATIVE DATE

9T0Z JaqwanoN TT (ud) sAsaop

You set filter parameters using the Boolean operators available through the And drop-down menu,
and adding the search parameters with the+ button. Alternatively, you set date filters using the
Relative Date filter parameters on the right-hand portion of the page.

You can filter according to size, dates, or both.

A.1.1 Filter Expression Builder

The And drop-down menu is used to:

+ Select Boolean operators for creating a search filter
+ Create additional groups or conditions
+ Delete search filters, groups, or conditions

148  Filtering



A.l1.2

A.2

A21

Figure A-2 And Drop-Down Menu

¥ And

™ Or

¥ Mot And

@ Mot Or

Add Group

= Add Condition

®X  Remove

The + button next to the And drop-down menu are used to create parameters for a search condition.

Figure A-3 Parameters for Filter

File Extension <enter a values

Relative Date Filtering Parameters

Click Relative Date and then select the Create Date, Modify Date, and Access Date check boxes to
enable the corresponding drop-down menus and fields.

Figure A-4 Relative Date Filtering Parameters

EXPRESSION

<]
“
i
J
1
0
3
a
L]
=]
L
1
a

Days
RELATIVE DATE
~
Modify Date | Since - 0 r Days ¥  ago

<]

A
Since b (4] r Days ¥ ago

(<]

Single Entry Filter Conditions

¢ Section A.2.1, “Using the Filter Expression Builder,” on page 149
+ Section A.2.2, “Using the Relative Date Filtering Settings,” on page 151

You can use either the And drop-menu and + button, or the Relative Date filtering settings to create
single entry filter conditions.

Using the Filter Expression Builder

1 From the And drop-down menu, select a Boolean operator.
2 Click the + button to add an entry.
3 From the File Extension drop-down menu, select a Boolean operator.
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EXPRESSION
And

RELATIVE DATE Eile Extension <enter a value>
File Extension

File Size

Create Time

Modify Time

Access Time

&

4 From the Equals drop-down menu, select a Boolean operator.

EXPRESSION
And

RELATIVE DATE Access Time <enter a values

Equals
Does not equal
Is greater than

|s greater than or equ@

Is less than

v v H

Is less than or equal to

moA

b

Is between

Is not between

4

see |5 any of
**s |5 none of

Date and time operators >

5 In the <enter a value> field, enter a value.

EXPRESSION
And

RELATIVE DATE Access Time 5/17/2 (I

« < MAY 2017 > >
SUN MON TUE WED THU FRI  SAT
1 2 3 4 5 &

7 ] 9 10 11 12 13

14 15 16 ° 18 19 20

21 22 23 24 25 26 27

28 29 30 31

TODAY CLEAR

File size values must be entered in bytes. For example, if your filtering parameters were for all
files larger than 500 MB, you would enter 524288000 (500 x 1024 x1024). A more practical entry
might be 500000000. Do not attempt to enter commas; they are placed automatically.
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A.2.2

A.3

6 Click OK to save the settings in the Report Definition Editor.

Using the settings in this procedure as an example, when you generate a report, the data would
include only files that have been accessed after May 17, 2017.

Using the Relative Date Filtering Settings

1 From the Filters tab, click the Relative Date option.

2 Select from the Create Date, Modify Date, or Access Date check boxes.
3 From the first drop-down menu, select either Since or Before.

4 From the numeric field to the right, enter a numeric setting.

5 From the drop-down menu to the right, select from the options.

]
[1s]
=)

A
Access Date  Since b 7T Cays -

6 Click Save to save the settings in the Report Definition Editor.

Using the setting in this procedure as an example, when you generate a report, the data would
include only files that have been accessed in the last week.

Multi-Condition Filtering

You can set multi-conditioned filters by:

+ Entering parameters for more than one entry using the And drop-down menu
+ Specifying multiple Relative Date filtering settings

+ Combining parameters specified through the And drop-down menu and the Relative Date
filtering settings

IMPORTANT: Be aware that when you set multiple entries in a condition for filtering, that all
entries must be met in order for File Reporter to report on the file.

For example, in the example below, the files would appear in the report only if they were greater
than 500 MB and had been accessed after April 1, 2012.

EXPRESSION

RELATIVE DATE

File Size 524,288,000

Access Time
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B.1

B.1.1

B.2

Security Settings

+ Section B.1, “Rights and Privileges on Scanned Storage,” on page 153

*

Section B.2, “Firewall Requirements,” on page 153

*

Section B.3, “Local Security Authority Rights and Privileges,” on page 154

*

Section B.4, “Proxy Rights Group,” on page 155

*

Section B.5, “Windows Clustering through Proxy Agents,” on page 155

Rights and Privileges on Scanned Storage

Micro Focus File Reporter must have the proper rights set on each network volume or share that it
scans. In addition, certain privileges must be granted to File Reporter on the machine hosting the
Engine and on each server where storage is managed.

Granting Rights

Every Windows network share to be scanned by File Reporter must have proper rights assigned to
the File Reporter proxy rights group.

1 As an Active Directory domain administrator, authenticate to the server where the storage is
located.

2 Grant Read Only sharing privileges to the proxy rights group for each share that File Reporter
will scan.

Firewall Requirements

Depending on the host system, exceptions must be added to the firewall rules for that host. The
following are needed for successful operation of File Reporter tasks.

NOTE: Firewall exceptions for File Reporter components installed on Windows are set up
automatically during configuration of each component.

+ The Engine must remain permitted to make outbound connections.
+ The Engine must remain able to listen on port 3035.
This is the default port choice that is presented during the installation and configuration.

+ File System Agents (legacy Agent for Windows, AgentFS, Agent for OES Linux) must be
permitted to make outbound connections.

+ File System Agents (legacy Agent for Windows, AgentFS, Agent for OES Linux) must remain
able to listen on TCP port 3037.

This is the default port choice that is presented during the installation and configuration.
+ The Web Application hosted on IIS must be allowed to listen on TCP ports 80 and 443.

Security Settings 153
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+ On each server hosting storage that you wish to collect quota via proxy, you must enable the
Remote File Server Resource Manager Management - FSRM Service (RPC-In) firewall rule.

+ [f File Content Analysis is enabled:
+ ManagerFC must remain permitted to make outbound connections.
¢ AgentFC must remain permitted to make outbound connections.
+ RabbitMQ must remain permitted to make outbound connections.

+ RabbitMQ must remain permitted to listen on TCP port 15672 for the management
interface.

This is the default port that RabbitMQ management interface listens on.
+ RabbitMQ must remain permitted to listen on TCP port 5671.
This is the default port that RabbitMQ is configured for with TLS.

B.3 Local Security Authority Rights and Privileges

Local Security Authority (LSA) rights and privileges are assigned to accounts or groups, and they
determine how those accounts or group members may access the system. The rights and privileges
are modified through secpol .msc or Local Security Policy from:

Start > Administrative Tools > Local Security Policy

1 In Local Security Policy, go to the following:
Security Settings > Local Policies > User Rights Assignments

2 In the table of Privileges and the objects to which they apply located on the right, verify that the
File Reporter proxy rights group has the following privileges:

+ Access this computer from the network
+ Back up files and directories

+ Bypass traverse checking

+ Create a token object

+ Create symbolic links

+ Impersonate a client after authentication
¢ Log on as a batch job

+ Manage auditing and security log

9T0Z JeqwanoN TT (ua) sAsoop

IMPORTANT: Absence of some of these privileges causes the Engine and Agent components to not
function properly. Removal of these rights and privileges via Group Policy Object (GPO) results in the
Engine and Agent not functioning properly.

If GPO conflicts are detected, set up an additional GPO with just the privileges listed above and
assign it to the proxy rights group for the appropriate servers.
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B.4

B.5

Proxy Rights Group

By default, whenever any of the components of File Reporter are installed on a server in a domain,
the proxy rights universal security group is granted membership in that server’s built-in Administrators
security group. This grants File Reporter certain permissions needed in addition to the LSA privileges
required for successful scanning of file system metadata.

On other servers in the domain that are hosting storage to be scanned by File Reporter through a
proxy agent, you must also grant the proxy rights group membership in the built-in Administrators
group. This is necessary because there are many actions performed that require membership in this
group regardless of the LSA privileges that the user has been granted—in particular, reading
directory quotas.

Additionally, the other servers in the domain that are not hosting components, but are hosting storage
to be scanned, must have the necessary rights and privileges, along with some file share and NTFS
permissions. The easiest way of granting these rights and privileges is through Group Policy objects
in Active Directory.

As explained previously, at a minimum, you must grant Read Only sharing and security privileges to
the proxy rights group for each share that File Reporter will scan.

IMPORTANT: The proxy rights group for Active Directory must be a member of the built-in
Administrators group on each Windows server that File Reporter scans.

Certain functions, such as collection of quotas via FSRM (File Server Resource Manager) do not
work without this membership despite the assignment of other rights and privileges.

Windows Clustering through Proxy Agents

File Reporter supports clustering of Windows Server through Proxy Agents. Configuring a cluster to
be scanned through a proxy agent is similar to configuring an individual server to be scanned by a
proxy agent. In particular, the File Reporter proxy rights group must be granted membership in the
built-in Administrators group and it must also be granted all of the LSA rights and privileges that are
granted at each cluster node. When this is done, the folder share permissions and NTFS permissions
that are required must be granted to the proxy rights group for all shares and NTFS volumes that will
be scanned by File Reporter.
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C Log File Locations

When troubleshooting Micro Focus File Reporter, you might need to refer to component log files. The
locations for each are specified in the table below.

Table C-1 Log File Locations

Component Typical Log File Path

Engine C:\ProgramData\Micro Focus\SRS\Engine\log\srsengine.log
Scan Processor C:\ProgramData\Micro Focus\SRS\Engine\log\scanprocessor.log

Legacy Agent for C:\ProgramData\Micro Focus\SRS\Agent\log\srsagent.log
Windows

AgentFS C:\ProgramData\Micro Focus\SRS\AgentFS\log\SRSAgentFS.log

Agent for OES Ivar/opt/microfocus/srs/agent/log/srsagentd. log
Linux

Web Application C:\inetpub\srs_root\AppData\logs\webui . log
ManagerFC C:\ProgramData\Micro Focus\SRS\ManagerFC\log\SRSManagerFC. log
AgentFC C:\ProgramData\Micro Focus\SRS\AgentFC\log\SRSAgentFC. log
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D.1

Agent Scan Capabilities

+ Section D.1, “Server Platform and NAS Device Support,” on page 159

+ Section D.2, “File System Metadata,” on page 160

+ Section D.3, “Security Scans — Active Directory File Systems,” on page 161
+ Section D.4, “Security Scans — eDirectory File Systems,” on page 161

¢ Section D.5, “Volume Free Space Scans,” on page 162

+ Section D.6, “Other Microsoft Supported Features,” on page 162

¢ Section D.7, “Current Limitations,” on page 162

Server Platform and NAS Device Support

The following platforms are supported as server hosts for scan targets.

Table D-1 Supported Scan Target Hosts

Server Platform File Reporter 3.5
Windows Server 2008 wa

Windows Server 2008 R2 v

Windows Server 2012 v

Windows Server 2012 R2 v

Windows Server 2016 v

Open Enterprise Server 2015 SP1 w2

Open Enterprise Server 2018 v

1. Older Windows servers including Windows 2003 or 2003 R2 might work, but are not supported.
2. Older editions of Open Enterprise Server including OES 2 SP4 and OES 11 SP1 might work, but

are not fully supported.
3. NetWare 6.5 SP8 might work with limited support.

The following NAS devices are supported as hosts for scan targets.
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Table D-2 Supported Scan Target NAS Hosts

NAS Device File Reporter 3.5
NetApp Filer with OnTAP 8.x (7 mode or Cluster mode) W1

NetApp Filer with OnTAP 9.x v

Isilon OneFS 7.2 e

Isilon OneFsS 8.x v

9T0Z JeqwanoN TT (ua) sAsoop

1. Older versions of NetApp OnTAP and Isilon OneFS might work but are not supported.

2. Other NAS devices not listed here might work with limited support if running a vendor supported
version of the device and management software.

D.2 File System Metadata

The following table lists file system scanning capabilities of File Reporter.

Table D-3 File System Metadata Support

Metadata Feature Windows NTFS Windows ReFS OES NSS! OES NCP Volumes

File Name /
Extension

v v v

File Size

File Sparse Size

X < <
X x <

File Compressed
Size

File Size on Disk?
Create Time
Modify Time3

Access Time?

L € <4 £ L L <

L £ £ 4 & X X

Directory Quota

< X 4 £ < L
L X 4 £ < L

Owner

<
<

1. Even though NSS volumes support compression, they only report compression metrics at the
volume level, not on a per-file basis.

2. File size-on-disk calculations are currently performed using an assumed 4 KB block size, except
when using AgentFS for Windows file systems, which attempts retrieval of the actual allocation
size.
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D.3

D.4

3. Access and Modify time stamps for directories are not consistently defined across file system
types. These time stamps should only be considered for file entries.

4. Directory Quotas for Windows NTFS volumes are only available on Windows 2008 R2 and later
servers, and only if the File Server Resource Manager (FSRM) Role has been installed.

5. Scanning of NSS 64 volumes is supported only by:
¢ Agent for OES Linux running on OES 2015 SP1 or later

+ Legacy Agent for Windows running on Windows Server 2008 R2 or later with OES Client 2
SP4 or later

Security Scans — Active Directory File Systems

Table D-4 Permission Scan Capabilities for Active Directory Environments

Windows Component Supported Notes

Share Permissions

Security Descriptors Includes the ACLs and ACEs, owner, and all ACE and
security descriptor flags. However, only security
descriptors for folders are currently collected. Additionally,
deny ACEs are not factored into calculations for
Permission by Identity or Permission by Path reports.

Universal Security Groups
Global Security Groups

Local Security Groups » The local security groups themselves are collected, but
group memberships for local security groups are not
currently processed.

Nested Group Memberships Nested group membership is collected as a flat list of all
intermediate and leaf groups, users, and other security
principals. The hierarchy of group nesting is not currently
preserved.

Primary Groups

Local Security Authority (LSA) b4 LSA privileges are not currently collected.
Privileges

Security Scans — eDirectory File Systems

Table D-5 Permission Scan Capabilities for eDirectory Environments

Novell Component Supported Notes

Trustees Only trustees for directories are currently collected.
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Novell Component Supported Notes

Inherited Rights Masks (IRMs) o These are fully scanned and collected, but reporting
does not calculate them for Permissions by Path or
Permissions by Identity reports.

Security Equivalence v For calculation of effective rights, security equivalence
is collected for all objects that are direct trustees of any
file system folder entry, as well as implicit trustees.

Rights Inherited from eDirectory v All users in eDirectory that have Write or Supervisor
access to the server object automatically have
Supervisor rights to all volumes on that server.

eDirectory Inherited Rights Filters 4 IRFs are not currently collected nor reported.
(IRFs)

9T0Z JeqwanoN TT (ua) sAsoop

D.5 Volume Free Space Scans

+ Free space for NSS volumes is currently calculated as volume free space + purgeable space.

+ Used space for NSS volumes is currently calculated as total size — calculated free space. This
means that the volume compressed size is included along with actual space used.

+ For NSS volumes that are oversubscribed on a shared NSS Pool, the volume total size of each
volume in the pool will change as data is added or removed from other volumes in the pool. This
is known behavior for oversubscribed volumes.

Oversubscribed NSS volumes are defined as two or more NSS volumes that are set to grow to
the size of a shared NSS Pool.

+ NSS 64 volumes are supported by Agents running on OES 2015 servers or Windows Server
2008 R2 or later with Open Enterprise Server Client 2 SP4 or later.

D.6 Other Microsoft Supported Features

+ Multiple domains in a single forest
+ Distribute File System (DFS) running in domain-based mode

D.7 Current Limitations

The following are scan limitations of File Reporter 3.5:

+ Microsoft Environments
+ No scanning for workstations
+ No scanning for standalone servers
+ No support for Distributed File System (DFS) in standalone mode

+ No support for Single Label Domains
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+ No support for FAT or FAT32 file systems
+ No support for Trusted Forests

¢ Micro Focus (Novell) Environments
+ NetWare Traditional File System (TFS) volumes are not supported.
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Glossary

Agent: Aservice that can run on Micro Focus Open Enterprise Server and Microsoft Windows Server
hosts. Agents can examine and report on NSS and NTFS file systems and content. Additionally,
Agents examine and report on file system security, including folder rights, trustee assignments, and
permissions.

AgentFC: Agent enabled to perform file content scanning.
AgentFS: Agent enabled to perform file system scanning.

Analytics Tools: Windows workstation application included in the Client Tools designed to analyze
data from scans. The current Analytics Tools include the Dashboard, Pivot Grid, and Tree Map.

Baseline Scan: A scan that you save as a reference for a comparison with another scan via a
Historical Comparison report. You can have one File System Baseline scan and one Permissions
Baseline scan for each storage resource.

Built-in Reports: With the exception of Custom Query reports, all of the report types that you can
generate through the options displayed on the Add Report Definition page.

Current Scan: The most recent scan of a storage resource.

Custom Query Reports: Custom reports generated through SQL commands to the database.
Custom Query reports can be generated both from the File Reporter browser-based administrative
interface and from the Report Designer client tool.

Engine: The component that runs File Reporter.
The Engine does the following:

+ Schedules the scans that the Agents conduct
+ Compiles scans for inclusion in a report
+ Provides the report information to the user interface
+ Determines that a condition has been met to start a triggered report
+ Runs scheduled reports
+ Monitors how many agents are online
+ Sends notifications that File Reporter has completed a scan or generated a report
File Content Scan: The process of scanning file content for specified patterns (e.g. U.S Social

Security numbers, credit card numbers, etc.). File Content scans are performed by an AgentFC on a
Windows storage device.

Historic Comparison Report: File system or permissions reports that specify the differences
between two similar scan types of the same target system. Historic Comparison reports can compare
Baseline scans to Previous scans, Baseline scans to Current scans, and Previous scans to Current
scans.

Identity System: Refers to the supported directory services, which are eDirectory and Active
Directory. File Reporter can report on storage resources that reside in either identity system.
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ManagerFC: Service that is responsible for the execution and management of file scan jobs. The
service performs the following tasks when processing a scan job:

+ Enumeration of files in target paths
+ Submission of files to scan queues in the message broker based on filter criteria
+ Processing of scan results and update of result data to the database and scan result files

Micro Focus File Dynamics: A Windows network file management system utilizing Microsoft Active
Directory to enacted policies. Identity-driven policies automate tasks that are traditionally done
manually, resulting in cost savings and the assurance that tasks are being performed properly. Target-
driven policies offer data migration, cleanup, workload, and protection from data corruption and
downtime through nearline storage backup of high-value targets, enabling quick recovery of files and
their associated permissions. File Reporter can output reports that can be imported into File
Dynamics Workload policies for remediation.

Micro Focus Storage Manager: A network file management system that utilizes directory services
enacted policies to automatically manage user and group network storage. When installed and
configured in the same network, File Reporter can report on Storage Manager policies.

Preview Report: A report generated through the Generate Preview option. Might also be referred to
as “viewing the report in Preview mode.”

Previous Scan: When the Retain existing Previous scan option is selected in the Scan Policy Editor,
the status of the Current scan becomes the Previous scan. You can then use the Previous scan as a
reference for a Historic Comparison report. There is only one File System Previous scan and one
Permissions Previous scan for each storage resource.

Proxy Agent: An Agent that performs agent services on a storage resource through a proxy
association. NAS devices, clustered configurations, and NetWare servers require proxy agents.

Proxy Target: Servers, clusters, and NAS devices that are not hosting an Agent but are being
scanned through a proxy agent.

Report: The result of a report request specified through the report definition. Reports are first
presented on-screen in either Preview or Stored mode. You can save reports in a number of different
formats.

Scan: Comprehensive file information pertaining to a storage resource at a specific time. Information
from scans is the means of generating reports.

Scan Policy: Specifies how and where the scan is conducted. All scans are managed through a scan
policy.

Scan Processor: Introduced in File Reporter 3.0, the Scan Processor alleviates some of the
workload that was previously performed by the Engine. This workload includes storing the scans in
the database and processing the scans.

Scan Target: The storage resource on the network that can be scanned by File Reporter.

Storage resource: A resource within the network environment that File Reporter monitors and
reports on. Depending on the environment in which File Reporter is deployed, a storage resource can
be a server volume, a Windows server share, a Micro Focus Storage Manager policy, or a network
folder path.

Stored Report: Areport that is stored in the Reports folder of the Engine. By default, a stored report
is only stored for 30 days, but this setting can be adjusted through the Stored Reports Configuration

page.
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Unformatted Report: Report data generated as “raw” text rather than formatted and presented in a
formatted report. In some instances, having an unformatted report might be useful for doing extensive
sorting and filtering of the report data through a product such as Microsoft Excel.

Web Application: The File Reporter administrative interface that runs on top of Microsoft IIS.
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F.1

F.2

F.3

Documentation Updates

This section contains information about documentation content changes that were made in this Micro
Focus File Reporter 3.5 Administration Guide after the initial release of File Reporter 2.0. The
changes are listed according to the date they were published.

The documentation for this product is provided on the Web in two formats: HTML and PDF. The
HTML and PDF documentation are both kept up-to-date with the changes listed in this section.

If you need to know whether a copy of the PDF documentation that you are using is the most recent,
the PDF document includes a publication date on the title page.

The documentation was updated on the following dates:

July 2, 2018

Updates were made to the following sections:

Location

Update Description

Chapter 7, “Content Scanning and Reporting,” on
page 101.

Appendix B, “Security Settings,” on page 153.

Appendix C, “Log File Locations,” on page 157.

Appendix D, “Agent Scan Capabilities,” on page 159.

New chapter.

Various updates.
Log file locations to new components.

Updated supported scan target hosts, scan target NAS
hosts, and file system metadata support.

July 19, 2016

Updates were made to the following sections:

Location

Update Description

Chapter 9, “Using the Report Viewer,” on page 117.
Chapter 10, “Using the Client Tools,” on page 121.

Chapter 11, “Using Report Designer,” on page 131.

Appendix D, “Agent Scan Capabilities,” on page 159.

New section.
New section.
New section.

Updated this section.

August 5, 2015

Updates were made to the following sections:
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Location Update Description

Section D.7, “Current Limitations,” on page 162. Removed information on support for NetWare
Traditional file system support.

Appendix E, “Glossary,” on page 165. Removed information on support for NetWare
Traditional file system support.

F4  April 27, 2015

Updates were made to the following sections:
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Location Update Description

Section 5.1.1, “Scan Retention,” on page 42. New section.

Section 5.4, “Creating Scan Policies,” on page 44. Information on Previous scans.
Section 5.5, “Establishing a Baseline Scan,” on New section.

page 49.

Section 5.6, “Clearing a Baseline Scan,” on page 50.  New section.

Section 6.8, “Historic Comparison Reports,” on New section.
page 86.
Section 6.16, “Copying a Report Definition,” on New section.
page 98.
Appendix E, “Glossary,” on page 165. New entries.

F.5 October 7, 2014

Updates were made to the following sections:

Location Update Description
“Custom Query Reports” on page 20. New section.
Section 5.14, “Retrying Failed Scans,” on page 53. New section.

Section 6.10, “Custom Query Reports,” on page 92. New section.

Chapter 10, “Using the Client Tools,” on page 121. New section.

F.6 February 18, 2014

Updates were made to the following sections:

Location Update Description

Various. Updated references to database references to include
information specific to Microsoft SQL Server 2012.
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F.7

F.8

F.9

Location

Update Description

Section 8.3, “Considerations for Reporting on NAS
Devices,” on page 113.

Section 6.3, “Changing the Report Data Font,” on
page 59.

Appendix D, “Agent Scan Capabilities,” on page 159.

Updated this section to include new procedures for
EMC Isilon and other NAS devices.

Expanded this section.

New section.

November 26, 2013

Updates were made to the following sections:

Location

Update Description

Section 6.3, “Changing the Report Data Font,” on
page 59.

New section.

April 25, 2013

Updates were made to the following sections:

Location

Update Description

Section 3.3.2, “Configuring the Web Interface,” on
page 28.

Appendix A, “Filtering,” on page 147.
Appendix B, “Security Settings,” on page 153.

Appendix C, “Log File Locations,” on page 157.

New procedures.

New section.
New section.

New section.

February 13, 2013

Updates were made to the following sections:

Location

Update Description

Section 3.1, “Supported Browsers,” on page 25.

Section 5.4, “Creating Scan Policies,” on page 44.

Section 6.7.1, “Generating a Filename Extension
Report,” on page 77.

Removed Internet Explorer 8 from the list of supported

browsers.

Specified that a target path cannot be included in more

than one scan policy of the same type.

Inserted a note on the maximum length of file
extensions.
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